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Foreword 

The HEC-RAS software was developed at the Hydrologie Engineering Center 
(HEC). The software was designed by Mr. Gary W. Brunner, leader of the 
HEC-RAS development team. The user interface and graphics were 
programmed by Mr. Mark R. Jensen. The steady flow water surface profiles 
module was programmed by Mr. Steven S. Piper. The routines that import 
HEC-2 data were developed by Ms. Joan Klipsch. The cross section 
interpolation routines were developed by Mr. Alfredo Mantalvo. 

Many of the HEC staff made contributions in the development of this 
software, including: Vern R. Bonner, Richard Hayes, John Peters, and 
Michael Gee. Mr. Darryl Davis was the director during the development of 
this software.. 

This manual was written by Mr. Gary W. Brunner. 
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CHAPTER   1 

Introduction 

Welcome to the Hydrologie Engineering Center's River Analysis System 
(HEC-RAS). This software allows you to perform one-dimensional steady 
flow, unsteady flow, and sediment transport calculations (The current version 
of HEC-RAS can only perform steady flow calculations. Unsteady flow and 
sediment transport will be added in future versions). 

The HEC-RAS modeling system was developed as a part of the Hydrologie 
Engineering Center's "Next Generation" (NexGen) of hydrologic engineering 
software. The NexGen project encompasses several aspects of hydrologic 
engineering, including: rainfall-runoff analysis; river hydraulics; reservoir 
system simulation; flood damage analysis; and real-time river forecasting for 
reservoir operations. 

This chapter discusses the general philosophy of HEC-RAS and gives you a 
brief overview of the capabilities of the modeling system. Documentation 
for HEC-RAS is discussed, as well as an overview of this manual. 

Contents 

■ General Philosophy of the Modeling System 

■ Overview of Program Capabilities 

■ HEC-RAS Documentation 

■ Overview of This Manual 
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General Philosophy of the Modeling System 

HEC-RAS is an integrated system of software, designed for interactive use in 
a multi-tasking, multi-user network environment. The system is comprised 
of a graphical user interface (GUI), separate hydraulic analysis components, 
data storage and management capabilities, graphics and reporting facilities. 

The system contains three one-dimensional hydraulic analysis components 
for: (1) steady flow water surface profile computations; (2) unsteady flow 
simulation; and (3) movable boundary sediment transport computations. A 
key element is that all three components use a common geometric data 
representation and common geometric and hydraulic computation routines. 
In addition to the three hydraulic analysis components, the system contains 
several hydraulic design features that can be invoked once the basic water 
surface profiles are computed. 

The current version of HEC-RAS only supports Steady Flow water surface 
profile calculations. New features and additional capabilities will be added 
in future releases. 

Overview of Program Capabilities 

HEC-RAS is designed to perform one-dimensional hydraulic calculations for 
a full network of natural and constructed channels. The following is a 
description of the major capabilities of HEC-RAS. 

User Interface 

The user interacts with HEC-RAS through a graphical user interface (GUI). 
The main focus in the design of the interface was to make it easy to use the 
software, while still maintaining a high level of efficiency for the user. The 
interface provides for the following functions: 

■ File management 

■ Data entry and editing 

■ Hydraulic analyses 

■ Tabulation and graphical displays of input and output data 

■ Reporting facilities 

■ On-line help 
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Hydraulic Analysis Components 

Steady Flow Water Surface Profiles. This component of the modeling 
system is intended for calculating water surface profiles for steady gradually 
varied flow. The system can handle a full network of channels, a dendritic 
system, or a single river reach. The steady flow component is capable of 
modeling subcritical, supercritical, and mixed flow regime water surface 
profiles. 

The basic computational procedure is based on the solution of the one- 
dimensional energy equation. Energy losses are evaluated by friction 
(Manning's equation) and contraction/expansion (coefficient multiplied by 
the change in velocity head). The momentum equation is utilized in 
situations where the water surface profile is rapidly varied. These situations 
include mixed flow regime calculations (i.e. hydraulic jumps), hydraulics of 
bridges, and evaluating profiles at river confluences (stream junctions). 

The effects of various obstructions such as bridges, culverts, weirs, and 
structures in the flood plain may be considered in the computations. The 
steady flow system is designed for application in flood plain management 
and flood insurance studies to evaluate floodway encroachments. Also, 
capabilities are available for assessing the change in water surface profiles 
due to channel improvements, levees, and ice cover. 

Special features of the steady flow component include: multiple plan 
analyses; multiple profile computations; and multiple bridge and/or culvert 
opening analysis. 

Unsteady Flow Simulation. This component of the HEC-RAS modeling 
system is capable of simulating one-dimensional unsteady flow through a full 
network of open channels. The unsteady flow equation solver has been 
adapted from Dr. Robert L. Barkau's UNET model (Barkau, 1992 and HEC, 
1993). This unsteady flow component was developed primarily for 
subcritical flow regime calculations. 

The hydraulic calculations for cross-sections, bridges, culverts, and other 
hydraulic structures that were developed for the steady flow component have 
been incorporated into the unsteady flow module. Additionally, the unsteady 
flow component has the ability to model storage areas, navigation dams, 
gated spillways, tunnels, pumping stations, and levee failures. 

Sediment Transport/Movable Boundary Computations. This component of 
the modeling system is intended for the simulation of one-dimensional 
sediment transport/movable boundary calculations resulting from scour and 
deposition over moderate time periods (typically years, although applications 
to single flood events are possible). 
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The sediment transport potential is computed by grain size fraction, thereby 
allowing the simulation of hydraulic sorting and armoring. Major features 
include the ability to model a full network of streams, channel dredging, 
various levee and encroachment alternatives, and the use of several different 
equations for the computation of sediment transport. 

The model is designed to simulate long-term trends of scour and deposition 
in a stream channel that might result from modifying the frequency and 
duration of the water discharge and stage, or modifying the channel 
geometry. This system can be used to evaluate deposition in reservoirs, 
design channel contractions required to maintain navigation depths, predict 
the influence of dredging on the rate of deposition, estimate maximum 
possible scour during large flood events, and evaluate sedimentation in fixed 
channels. 

Data Storage and Management 

Data storage is accomplished through the use of "flat" files (ASCII and 
binary). User input data are stored in flat files under separate categories of 
project, plan, geometry, steady flow, unsteady flow, and sediment data. 
Output data is predominantly stored in separate binary files. 

Data management is accomplished through the user interface. The modeler 
is requested to enter a single filename for the project being developed. Once 
the project filename is entered, all other files are automatically created and 
named by the interface as needed. The interface provides for renaming, 
moving, and deletion of files on a project by project basis. 

Graphics and Reporting 

Graphics include X-Y plots of the river system schematic, cross-sections, 
profiles, rating curves, hydrographs, and many other hydraulic variables. A 
pseudo three-dimensional plot of multiple cross-sections is also provided. 
Tabular output is available. Users can select from pre-defined tables or 
develop their own customized tables. All graphical and tabular output can be 
displayed on the screen, sent directly to a printer (or plotter), or passed 
through the Windows clipboard to other software, such as a word-processor 
or spreadsheet. 

Reporting facilities allow for printed output of input data as well as output 
data. Reports can be customized as to the amount and type of information 
desired. 
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HEC-RAS Documentation 

The HEC-RAS package includes several documents. Each document is 
designed to help the modeler learn to use a particular aspect of the modeling 
system. The documentation has been broken up into the following three 
categories: 

Documentation Description 

User's Manual 

Hydraulic Reference Manual 

Applications Guide 

This manual is a guide to using HEC-RAS. 
The manual provides an introduction and 
overview of the modeling system, installation 
instructions, how to get started, simple 
examples, detailed descriptions of each of the 
major modeling components, and how to view 
graphical and tabular output. 

This manual describes the theory and data 
requirements for the hydraulic calculations 
performed by HEC-RAS. Equations are 
presented along with the assumptions used in 
their derivation. Discussions are provided on 
how to estimate model parameters, as well as 
guidelines on various modeling approaches. 

This document contains a series of examples 
that demonstrate various aspects of HEC- 
RAS. Each example consists of a problem 
statement, data requirements, general outline 
of solution steps, displays of key input and 
output screens, and discussions of important 
modeling aspects. 

Overview of This Manual 

This user's manual is the primary piece of documentation on how to use the 
HEC-RAS system. The manual is organized as follows: 

■ Chapters 1-2 provide an introduction and overview of HEC-RAS, as 
well as instructions on how to install the software. 

■ Chapters 3-5 describe how to use the HEC-RAS software in a step- 
by-step procedure, including a sample problem that the user can 
follow along with. Understanding how this system works with 
projects is also discussed. 
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Chapters 6-7 explain in detail how to enter and edit data, and how to 
perform the different types of analyses that are available. 

Chapter 8 provides detailed discussions on how to view graphical and 
tabular output, as well as how to develop user defined tables. 

Chapter 9 describes how to perform a floodway encroachment 
analysis. 

Appendix A contains a list of references. 

Appendix B contains a listing of all the messages (errors, warnings, 
and notes) that come from the HEC-RAS package (not finished yet). 

Appendix C provides a discussion on "Trouble Shooting" (not 
finished yet). 
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CHAPTER   2 

Installing HEC-RAS 

You install HEC-RAS using the program SETUP.EXE. The Setup program 
installs the HEC-RAS programs, sample applications, and the Help system. 

This chapter discusses the hardware and system requirements needed to use 
HEC-RAS, and how to install the software. 

Contents 

■ Hardware and Software Requirements 

■ Installation Procedure 

Important 

You cannot simply copy files from the distribution disks to your hard disk 
and run HEC-RAS. You must use the Setup program, which decompresses 
and installs the files to the appropriate directories. 
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Hardware and Software Requirements 

Before you install the HEC-RAS software, make sure that your computer has 
the minimum required hardware and software. In order to get the maximum 
performance from the HEC-RAS software, recommended hardware and 
software is show in parenthases. This version of HEC-RAS will run on a 
microcomputer that has the following: 

■ Any IBM or compatible machine with an 80386 processor or higher 
(a 80486 or higher is recommended). 

■ A hard disk with at least 10 megabytes of free space (20 megabytes 
or more is recommended). 

■ A3 1/2" floppy drive. 

■ A minimum of 4 megabytes of RAM (8 or more is recommended). 

■ A mouse. 

■ Color VGA or better Video Display (Recommend running in Super 
VGA or higher, and as large a monitor as possible) 

■ MS-DOS version 3.3 or later, and MS Windows version 3.1 or later 
(running in 386 enhanced mode). This software will also run under 
MicroSoft Windows NT version 3.5 or later. 

Installation Procedure 

Installation of the HEC-RAS software is accomplished through the use of the 
Setup program. When you run the Setup program, you will be asked to set a 
path for the program and data files. A suggested directory of "\HECRAS" 
will be provided. You may choose to use this directory name or provide one 
of your own. 

To install the software onto your hard disk, do the following: 

1. Start Windows by typing WIN, then press the ENTER key. 

2. Insert Disk 1 into the A drive (or B if necessary). 

3. From the File menu of the Windows Program Manager, choose Run. 
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4. Type a:setup (or b:setup if disk 1 is in the B drive) and press ENTER. 

5. Follow the setup instructions on the screen. 

Important 

Once you have finished installing the HEC-RAS software, you will need to 
re-start Windows in order for the program to function properly. 
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CHAPTER   3 

Working With HEC-RAS - An Overview 

HEC-RAS is an integrated package of hydraulic analysis programs, in which 
the user interacts with the system through the use of a Graphical User 
Interface (GUI). The system is capable of performing Steady Flow water 
surface profile calculations, and will include Unsteady Flow, Sediment 
Transport, and several hydraulic design computations in the future. 

In HEC-RAS terminology, a Project is a set of data files associated with a 
particular river system. The modeler can perform any or all of the various 
types of analyses, included in the HEC-RAS package, as part of the project. 
The data files for a project are categorized as follows: plan data, geometric 
data, steady flow data, unsteady flow data, and sediment data. 

During the course of a study the modeler may want to formulate several 
different Plans. Each plan represents a specific set of geometric data and 
flow data. Once the basic data are entered into the HEC-RAS, the modeler 
can easily formulate new plans. After simulations are made for the various 
plans, the results can be compared in both tabular and graphical form. 

This chapter provides an overview of how a study is performed with the 
HEC-RAS software. Special topics on how to import HEC-2 data and how to 
use on-line help are also covered. 

Contents 

■ Starting HEC-RAS 

■ Steps in Developing a Hydraulic Model With HEC-RAS 

■ Importing HEC-2 Data 

■ Getting and Using Help 
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itarting HEC-RAS 

When you run the HEC-RAS Setup program, you automatically get a new 
program group and program icon for HEC-RAS in Windows. They should 
appear as shown in Figure 3.1. 

'■&.■:*; vvv:;H EG imri H# 

FAS= 

HEC^ASl 

Figure 3.1 The HEC-RAS Icon in Windows 

To Start HEC-RAS from Windows: 

Double-click on the HEC-RAS Icon. 

When you first start HEC-RAS, you will see the main window as shown in 
Figure 3.2. 

File    Edit    Simulate    View    Options    Help 

Prciea';',.' IHEC 201 with a'Bridqe :'>V^>::i:viJ?£^ 

Plan •':#'-.; imported Plan.Data 1 .;: '1/:yA^^M^a^V^^g^V^iN^fe^^^^^^^ 

Geometry-.imported Geometry ]■■..'._<■ ;.;-_,^<^^^^t^S^as^ata^^^ggf^J^^^^ci 

Elcv       .  3.*ncortBd F'owData     ' : 

Figure 3.2 The HEC-RAS Main Window 
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The HEC-RAS main window has the following options on the menu bar. 

File This option is used for file management. Options available under the 
File menu include: New Project; Open Project; Save Project; Save Project 
As; Rename Project: Delete Project; Import HEC-2 Data; Import HEC-RAS 
data; and Exit.  In addition, the four most recently opened projects will be 
listed at the bottom of the File menu. 

Edit This option is used for entering and editing data. Data are categorized 
into four types: Geometric Data; Steady Flow Data; Unsteady Flow Data; 

and Sediment Data. 

Simulate This option is used to perform the hydraulic calculations. The 
options under this menu item include: Steady Flow Analysis; Unsteady Flow- 
Analysis; Sediment Analysis; and Hydraulic Design Functions. 

View This option contains a set of tools that provide for graphical and 
tabular displays of the model output. The View menu item currently 
includes: Cross Sections; Water Surface Profiles; Rating Curves: X-Y-Z 
Perspective Plots; Cross Section Tables; Profile Tables; and Summary Err, 

Warn, Notes. 

Options This menu item allows the user to change Program Setup options; 
set Default Parameters; establish the Default Units System (English or 
Metric); and Convert Project Units (English to Metric, or Metric to English). 

Help This option allows the user to get on-line help, as well as display the 
current version information about HEC-RAS. 

Steps in Developing a Hydraulic Model with HEC-RAS 

There are five main steps in creating a hydraulic model with HEC-RAS: 

■ Starting a new project 

■ Entering geometric data 

■ Entering flow and/or sediment data 

■ Performing the hydraulic calculations 

■ Viewing and printing results 
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Starting a New Project 

The first step in developing a hydraulic model with HEC-RAS is to establish 
which directory you wish to work in and to enter a title for the new project. 
To start a new project, go to the File menu on the main HEC-RAS window 
and select New Project. This will bring up a New Project window as shown 
in Figure 3.3. 

;"• New Project : :3|ilmäiS 

SOJC; Cancel Help 

Title File Name 

*prj 

Steady Flow Example from Chapter 4                          ex1 .prj 
HEC 201 Test of HEC-2 File Importer                         hec201 .prj 
Multiple Opening Test                                                   k1 bid.prj 
Mixed Flow Project                                                        mixed.prj 
Multiple Pipe Run from HEC 2 Data                            multpipe.prj 
HEC 2 Normal BT                                                          normalbt.prj 
HEC-2 One Box Data Set                                              onebox.prj 
HEC 2 Data Set One Pipe Culvert                               onepipe.prj 

± 

Create Directory 

Directories 

d.\hecras 

&d:\ 
& hecras 

Drives 

d: 

Set drive and path, then enter a new project title and file name. 

Figure 3.3 New Project window 

As shown in Figure 3.3, you first select the drive and path that they want to 
work in (to actually select a path you must double click the directory you 
want in the directory box), then enter a project title and file name. The 
project filename must have the extension ".PRJ", the user is not allowed to 
change this. Once you have entered all the information, press the "OK" 
button to have the information accepted. After the OK button is pressed, a 
message box will appear with the title of the project and the directory that the 
project is going to be placed in. If this information is correct, press the OK 
button. If the information is not correct, press the Cancel button and you will 
be placed back into the New Project window. 

Note: Before any Geometric data and Flow data are entered, the user 
should select the Units System (English or Metric) that they would like to 
work in. This is accomplished by selecting Unit System from the Options 
menu on the main HEC-RAS window. 

Entering Geometric Data 

The next step is to enter the necessary geometric data, which consist of 
connectivity information for the stream system (Stream Network), cross- 
section data, and hydraulic structure data (bridges, culverts, weirs, etc.). 
Geometric data are entered by selecting Geometric Data from the Edit menu 
on the main HEC-RAS window. Once this option is selected, the geometric 
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m 

.■Junv.t; 

Bidg/Cujy 

data window will appear as show in Figure 3.4 (except yours will be blank 
when you first bring this screen up for a new project). 

File    Edit    View    [Tables    Options    Help 

mm 
Section 

'Weir or. 
Spifiway 

SSII 
'*'■*.■:":• 

lllllf 
•.■:-■ •.-..'; 

•   ■ i 

■y 

llBi 
■■■•      ■■',:••■ 

Figure 3.4 Geometric Data Window 

The modeler develops the geometric data by first drawing in the river system 
schematic. This is accomplished, on a reach-by-reach basis, by pressing the 
River Reach button and then drawing in a reach from upstream to 
downstream (in the positive flow direction). After the reach is drawn, the 
user is prompted to enter an identifier for the reach. The identifier can be up 
to twelve characters in length. As reaches are connected together, junctions 
are automatically formed by the interface. The modeler is also prompted to 
enter an identifier for each junction. 

After the river system schematic is drawn, the modeler can start entering 
cross-section and hydraulic structure data. Pressing the Cross Section button 
causes the cross section editor to pop up. This editor is shown in Figure 3.5. 
As shown, each cross section has a Reach name, River Station, and a 
Description. The Reach and River Station identifiers are used to describe 
where the cross section is located in the river system. The "River Station" 
identifier does not have to be the actual river station (miles or kilometers) at 
which the cross section is located on the stream, but it does have to be a 
numeric value (e.g. 1.1, 2, 3.5, etc.). The numeric value is used to place cross 
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sections in the appropriate order within a reach. Cross sections are ordered 
within a reach from the highest river station upstream to the lowest river 
station downstream. 

=1     th-^oss-g8ctrön:Datäs:Bas"e"<3ebmetry Data     - 
Exit    Edit    Options    Plot    Help 

Reach-* FallCr: River Sto. 9.8| ±i-d 
Description River Mile 9.8 of Fall Creek .3 Apply Data 

Cross Section X-Y Coordinates   H    Downstream Reach Lengths 
"■*  _ .^. _  

Station Elevation 
110. 

117.2 

89.1 

79.1 

174.8 77.1 
184.8^ 69.1 
204.8 70.1 
214.8 78.1 

294. 

301.2 

80.1 

901 

t 450. 

LOBr>i   Channel       ROB 
500. 550. 

Manning's n Values 

-   : , LOB;.     Channel        ROB 

0.06 0.035 0.05 

Main Channel Bank Stations 

.Left Bank RightB.ank 

174.8 214.8 

Cont\Exp Coefficients 

jl'-Contractioii-"--;' ■ •• Expansion 
.1 

[Enter to. move to. next downstream .river, station loceäen 

Figure 3.5 Cross Section Data editor 

The basic data required for each cross section are shown on the Cross Section 
Data editor in Figure 3.5. Additional cross section features are available 
under Options from the menu bar. These options include: adding, copying, 
renaming and deleting cross sections; adjusting cross section elevations, 
stations, and n-values; ineffective flow areas; levees; blocked obstructions; 
adding a lid to a cross section; horizontal variation of n-values; and setting 
the maximum number of station and elevation points. 

Also available from the Cross Section Data editor is the ability to plot any 

cross section or reach profile. Edit features are available to cut, copy, paste, 
insert, and delete data from the Cross Section X-Y Coordinates grid. 

Once the cross-section data are entered, the modeler can then add any 
hydraulic structures such as bridges, culverts, weirs and spillways. Data 
editors, similar to the cross section data editor, are available for the various 
types of hydraulic structures. If there are any stream junctions in the river 
system, additional data are required for each junction. The Junction data 
editor is available from the Geometric Data window. 
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Once geometric data are entered, the data should be saved to a file on the 
hard disk. This is accomplished by selecting the Save Geometric Data As 
option from the File menu on the Geometric Data editor. This option allows 
the user to enter a title for the geometric data. A filename is automatically 
established for the geometric data, and then saved to the disk. Once a title is 
established, geometric data can be saved periodically by selecting Save 
Geometric Data from the File menu of the Geometric Data editor. 

Entering Flow and/or Sediment Data 

Once the geometric data are entered, the modeler can then enter any flow 
and/or sediment data that are required. The type of data that are entered will 
depend on the type of analysis that is going to be performed. If the modeler 
is performing a steady flow analysis, then Steady Flow Data must be entered. 
If an unsteady flow analysis is going to be performed, then Unsteady Flow 
Data must be entered. Likewise, if the modeler is going to perform sediment 
transport calculations, then Sediment Data must be entered. Data entry forms 
for these various types of data are available under the Edit menu bar option 
on the HEC-RAS main window. 

An example of the flow data entry form is shown in Figure 3.6, which is the 
Steady Flow Data form. As shown in Figure 3.6, Steady Flow Data consist 
of: the number of profiles to be computed; the flow data; and the river system 
boundary conditions. At least one flow must be entered for every reach 
within the system. Additionally, flow can be changed at any location within 
the river system. Flow values must be entered for all profiles. 

Boundary conditions are required in order to perform the calculations. If a 
subcritical flow analysis is going to be performed, then only the downstream 
boundary conditions are required. If a supercritical flow analysis is going to 
be performed, then only the upstream boundary conditions are required. If 
the modeler is going to perform a mixed flow regime calculation, then both 
upstream and downstream boundary conditions are required. The Boundary 
Conditions data entry form can be brought up by pressing the Enter 
Boundary Conditions button from the Steady Flow Data entry form. 

Once all of the steady flow data and boundary conditions are entered, the 
modeler should save the data to the hard disk. This can be accomplished by 
selecting Save Flow Data As from the File option on the Steady Flow Data 
menu bar. Flow data is saved in a separate file. The user is only required to 
enter a title for the data, the filename is automatically assigned. 
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Steady Flow.Data 4-10,2 and -1 % chance'evients-; 
File     Options     Help 
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10 

Edit Steady flow data for the profiles in cfs 

Figure 3.6 Steady Flow Data window 

Performing The Hydraulic Computations 

Once all of the geometric data and flow data are entered, the modeler can 
begin to perform the hydraulic calculations. As stated previously, there are 
four types of calculations that can be performed: Steady Flow Analysis; 
Unsteady Flow Analysis; Sediment Transport Analysis; and Hydraulic 
Design Functions. The modeler can select any of the available hydraulic 
analyses from the Simulate menu bar option on the HEC-RAS main window. 
An example simulation window is shown in Figure 3.7, which is the Steady 
Flow Analysis window. 
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Steady Flow Analysis 
File     Options     Help 

Plan:   Brisling Conditions Run Short ID Existing 

Geometry File :        Base Geometry Data 

Steady Flow File: 10. 2 and 1 % chance events 

Flow Regime 

(? SubcriticaJ 

C Supercritical 

C Mixed 

i Computation Range   r 

1               Starting IJLA^LUL' ^*^'j*^ß^M 

; Reach 
■' * Reach + 

i River Sta. ± River Sta. ± 

COMPUTE 

Enter to compute water surface profiles 

Figure 3.7 Steady Flow Analysis window 

As shown in Figure 3.7, the modeler puts together a Plan by selecting a 
specific set of geometric data and flow data. A Plan can be put together by 
selecting New Plan from the File menu bar option of the Steady Flow 
Analysis window. Once a plan has been put together, the modeler must select 
a Flow Regime for which the model will perform calculations. Subcritical, 
Supercritical, or Mixed flow regime calculations are available. 

An option for selecting a Computation Range is also available. This option 
allows the modeler to select a specific piece of the river system to work on. 
By selecting this option, the system will only perform calculations on the 
smaller subset of the full data. This option is useful when it is desired to 
calibrate the model or adjust data for a small piece of the river system. This 
option should be left blank when it is desired to perform calculations for the 
full river system. Also, once the modeler is finished working on the smaller 
subset of the river system, the model should always be re-run for the entire 
system. If the model is not re-run for the entire system, output will only be 
available for the smaller subset. 

Additional features are available under the Options menu for: setting output 
options; conveyance calculation options; friction slope methods; calculation 
tolerances; critical depth computation method; data checking; setting log file 
levels; and viewing the log file output. 

Once the modeler has selected a Plan and set all of the calculation options, the 
steady flow calculations can be performed by pressing the Compute button at 
the bottom of the Steady Flow Analysis window. When this button is pressed, 
the HEC-RAS system packages up all the data for the selected plan and writes 
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it to a run file. The system then runs the steady flow model (SNET) and 
passes it the name of the run file. This process is executed in a separate 
window. Therefore, the modeler can work on other tasks while it is 
executing. 

Viewing and Printing Results 

Once the model has finished all of the computations, the modeler can begin 
viewing the results. Several output features are available under the View 
option from the main window. These options include: cross section plots; 
profile plots; rating curve plots; X-Y-Z perspective plots; tabular output at 
specific locations; tabular output for many locations; and the summary of 
errors, warnings, and notes. 

An example of a cross section plot is shown in Figure 3.8. The user can plot 
any cross section by simply selecting the appropriate reach and river station 
from the list boxes at the top of the plot. The user can also step through the 
plots by using the up and down arrow buttons. Several plotting features are 
available under the Options menu of the Cross Section plot. These options 
include: zoom in; zoom out; selecting which plans, profiles and variables to 
plot; and control over the lines, symbols, labels, scaling, and grid options. 

Hard copy outputs of the graphics can be accomplished in two different ways. 
Plots can be sent directly from HEC-RAS to whichever printer or plotter the 
user has defined under the Windows Print Manager. Plots can also be sent to 
the Windows clipboard. Once the plot is in the clipboard it can then be pasted 
into other programs, such as a word processor. Both of these options are 
available from the File menu on the various plot windows. 

An example of a profile plot is shown in Figure 3.9. All of the options 
available in the cross section plot are also available in the profile plot. 
Additionally, the user can select which specific reaches to plot when a 
multiple-reach river system is being modeled. 

An example of an X-Y-Z Perspective Plot is shown in Figure 3.10. The user 
has the option of defining the starting and ending location for the extent of the 
plot. The plot can be rotated left or right, and up or down, in order to get 
different perspectives of the river reach. The computed water surface profiles 
can be overlaid on top of the cross section data. The graphic can be sent to the 
printer or plotter directly, or the plot can be sent through the Windows 
Clipboard to other programs. 
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:■■:.-[    ".'      Cross Section S8r    * 
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Figure 3.8 Cross Section Plot 
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Figure 3.9 Profile Plot 

3-11 



Chapter 3  Working With HEC-RAS - An Overview 
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Figure 3.10 X-Y-Z Perspective Plot of River Reach with a Bridge 
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Tabular output is available in two different formats. The first type of tabular 
output provides detailed hydraulic results at a specific cross section location 
(cross section table). An example of this type of tabular output is shown in 
Figure 3.11. 

Cross SectionQutput 
File    Type    Options 

Reach RedEoxS ±  River Sto Gl % ;;il %£■ ProfilR 5. * 
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850J11 
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 "i"28: 
259^33; 

55739.2; 

 0.030 

500.00 
744.94 

1 65.00 
10.12 

11^6; 

71.46: 

1760717; 

_qjjoo 
500.00 

_21_3J5 

71.63 
55EL02 

0.34 

0.38 

558.04 

Tß72"Bi 

Errors. Warnings and Notes 

Warninq - The velocity head has changed by more than 0.5 ft (0.15m). This may; 
V-.O-.^-i..:,::■:, . ■    i*. ' "£ ; V.'.'     ■"''v:\V:. ^C .tf-'**'^'^:''-'   '-^^^ 

indicate the need for additional cross sections. 
Warning - The conveyance ratio fupsfream conveyance divided bv'downstreanv; ~ 
  "   .   .    T. *. V.     ...>rK3°      !..t.^'*?*''$$i&..    ■     ^ •'"   -v    '   '"■ '   ■ 1 „H,,' ,1 .in, 'Li .' «I   ft.,.1 .SS..-, 

Calculated water surface fromenargy equation. 

Figure 3.11 Tabular Cross Section Output 

The second type of tabular output shows a limited number of hydraulic 
variables for several cross sections and multiple profiles. An example of this 
type of tabular output is shown in Figure 3.12. There are several standard 
tables that are pre-defined and provided to the user under the Tables menu 
from the profile output tables. Users can also define their own tables by 
specifying what variables they would like to have in a table. User specified 
table headings can be saved and then selected later as one of the standard 
tables available to the project. 

Tabular output can be sent directly to the printer or passed through the 
clipboard in the same manner as the graphical output described previously. 
This option is also available under the File menu on each of the table forms. 
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Profile Output Table - Standard Table T 
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Figure 3.12 Profile Output Table 

in one 

An important feature of HEC-RAS is the ability to import HEC-2 data. This 
feature makes it easy for a user to import existing HEC-2 data sets and start 
using HEC-RAS immediately. To import HEC-2 data, do the following: 

1. Start a new project by selecting New Project under the File menu 
option on the HEC-RAS main window (Figure 3.13). 

2. Select the Import HEC-2 Data option under the File menu on the 
main window (Figure 3.13). A popup window will appear (Figure 
3.14). which will allow you to select a drive, path, and filename for 
the HEC-2 data file. Once you have selected the file, press the OK 
button. 

The data are automatically saved in HEC-RAS format with default names 
and titles. The user can change the titles at any time by using the Rename 
feature, which is available from the File menu of the various data editors. 
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The data associated with HEC-2 options that are not currently supported in 
HEC-RAS are ignored. This includes: vertical n values; k values; cross 
section interpolation; split flow data; channel improvements; n value 
calibration; and ice options. This information will be added to the HEC-2 
import routine as the options become available in HEC-RAS. 

When bridge data are imported, the user must take special care to ensure that 
the data are correctly representing the bridge. The bridge routines in HEC- 
RAS are different than HEC-2, and therefore you may have to modify some 
data and/or enter some additional data. Whenever you import an HEC-2 data 
set with bridge data, carefully review all the data for each bridge. Chapter 6 
of this user's manual describes the required data for bridges in HEC-RAS. 
Some kev differences between HEC-2 and HEC-RAS are as follows: 

Special Bridge Data Sets 

HEC-RAS does not use a trapezoidal approximation for low flow 
through the bridge opening. The actual bridge opening is used in 
both the Yarnell method and the momentum method.. This could be 
a problem for HEC-2 special bridge data sets that do not include low- 
chord information on the BT data. If you have a data set like this, 
you will need to modify the bridge deck information after the data 
have been imported. 

The pressure flow equations use the actual bridge opening, defined by 
the ground and the bridge data. In HEC-2, the user was required to 
enter an area for pressure flow. If the actual bridge opening produces 
a different area than what the user had entered in the HEC-2 data 
deck, the program will get different results for pressure flow, and 
pressure and weir flow answers. 

Pier information from the SB record is incorporated as a single pier in 
the HEC-RAS data set. Piers are treated as a separate pieces of data 
in HEC-RAS. For special bridges that have piers, you may want to 
change the single pier to multiple piers, depending on what is actually 
at the bridge. Pier information can be modified using the Pier editor. 

Normal Bridge Data Sets 

Because piers are treated as a separate piece of data in HEC-RAS, 
they must not be included in the cross section data or the bridge deck. 
Since it is common to include pier information as part of the cross 
section or bridge deck in HEC-2, these data will need to be modified. 
For data sets that have piers, you will need to remove the pier 
information from the cross section or bridge deck, and then add the 
information back in using the Pier editor. 
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Getting and Using Help 

At this time, on-line help is not available in HEC-RAS. The Help system 
will be added before the first official release. For any questions that you 
currently have, please refer to this user's manual or the hydraulics reference 
manual. 
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CHAPTER   4 

Example Application 

This chapter provides an example application of how to perform steady flow 
water surface profile calculations with HEC-RAS. The user is taken through 
a step by step procedure of how to enter data, perform calculations, and view 

the results. 

In order to get the most out of this chapter, you should perform each of the 
steps on your own computer. Also, before you try the example application, 
you should have read the first three chapters in this manual. 

Contents 

■ Starting a New Project 

■ Entering Geometric Data 

■ Entering Steady Flow Data 

■ Performing the Hydraulic Calculations 

■ Viewing Results 

■ Printing Graphics and Tables 

■ Exiting the Program 
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Starting a New Project 

To begin this example, let's first start the HEC-RAS program. Double click 
the HEC-RAS icon in Windows. The main window should appear as shown 
in Figure 4.1 (except yours will be blank the first time you start the program). 

,|A:-4>:> , ^r^&S\k\ ... >f -v 4^,HEG-RAS^* <-?..,■ - ---^ ; , '• v   ->,>- ^ 
File    Edit    Simulate    View    Options    Help 

?*£#>( 

-KK+. $::^~'P)£ Erjgiish Units 

Project       Steady Flow Example from Chapter 4 •- r! U:\hecras\ex1 Iprj 

Plan .Existing Conditions Run i 'd:\hecras\sxl.p01 

Geometry  .Base Geometry Data S^pSSSsa ^ d:\hecr3s\ex1.g01 

Flow (Tfl. 2 and 1% chance events. , S:\hecras\3x1i01 ..'""'   1 

Figure 4.1  HEC-RAS Main Window 

The first step in developing an HEC-RAS application is to start a new 
project. Go to the File menu on the main window and select New Project. 
The New Project window should appear as shown in Figure 4.2 (except the 
title and file name fields will be blank when it first comes up). 

Title 

^ • -T.-   -;,,;>.,>;?,   -i- * N^v>Project\ 

Multiple Opening Test 
Mixed Flow Project 
Multiple Pipe Run from HEC 2 Data 
HEC 2 Normal BT 
HEC-2 One Box Data Set 
HEC 2 Data Set One Pipe Culvert 
New Red Fox 
Trapezoidal Bridge 

File Name 

Steady Flow Example from Chapter 4 äxjample.prj 

^:? ■v»'"'5'?y£'.r'%-;i 

k1t>1 d.prj 
mixed.prj 
multpipe.prj 
normalbt.prj 
onebox.prj 
onepipe.prj 
re df ox. prj 
trapbrdq.prj 

jjB^^jg^f^^gppj^g^s^^ >.' 

■Cancel,     j .rielp       j|g 
11 ■—: —, 

Create pjractofy|p||g=|d 
r- ■■?■'??■■/■■■ ;:.:.•--■■?!■■.■ :"'■. ■-<.' .--- ■■■■-     —-?-.>-^,-"    -.^.•■■■■■■■■    ■■:-'■:-■■:--•:   -y ■■■■■■; 

Jail 
r ■■-■■■' ■      ■ >'   -■ ■        ■-  -        .   .p ■ ■ ..T,    .    ., , . , .    —----- -   ■    ■ 

.Set arivs and pctn, then enter a new project WIB and file name.       gg« 

Figure 4.2 New Project Window 

First set the drive (e.g. C:) and the directory that you would like to work in. 
Next enter the project title and filename as shown in Figure 4.2. Once you 
have entered the information, press the OK button to have the data accepted. 
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Entering Geometric Data 

The next step in developing a steady flow model with HEC-RAS is to enter 
the geometric data. This is accomplished by selecting Geometric Data from 
the Edit menu on the HEC-RAS main window. Once this option is selected 
the geometric data window will appear (Figure 4.3). 

Drawing the Schematic of the River System 

In this example we are going to develop a three-reach system as shown in 
Figure 4.3. Draw in the river system schematic by performing the following 

steps: 

1. Click the River Reach button on the geometric data window. 

2. Move the mouse pointer over to the drawing area and place the pointer 
at the location in which you would like to start drawing the first reach. 

3. Hold down the left mouse button and draw the reach from upstream to 
downstream (in the positive flow direction). 

4. The interface will prompt you to enter an identifier for the reach. This 
identifier is limited to 12 characters. 

5. Repeat steps 1 through 4 for each reach. After you enter the identifier 
for reach three you will also be prompted to enter an identifier for the 
junction (location where two or more streams join or split apart). 

Once you have finished drawing in the river system, there are several options 
available for editing the schematic. These options include: deleting reaches, 
changing labels, and moving any objects (objects are labels, junctions, and the 
ends of reaches).   The editing features are located under the Edit menu on the 
Geometric Data window. Note: when you first draw your schematic there 
will not be any tic marks representing cross sections as shown in Figure 
4.3. The tic marks only show up after you have entered cross section 
data. 
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rigure 4.3 Geometric Data Window with example river schematic 

Entering Cross Section Data 

The next step is to enter the cross section data. This is accomplished by 
pressing the Cross Section button on the Geometric Data window (Figure 
4.3). Once this button is pressed, the Cross Section Data editor will appear as 
shown in Figure 4.4 (except yours should be blank). To enter cross section 
data do the following: 

I. Select a Reach to work with. For this example start with the Fall Cr. 
reach. 

Go to the Options menu and select Add a new Cross Section. An 
input box will appear prompting you to enter a river station identifier 
for the new cross section. The identifier does not have to be the 
actual river station, but it must be a numeric value. The numeric 
value describes where this cross section is located in reference to all 
the other cross sections within the reach. Cross sections are located 
from upstream (highest river station) to downstream (lowest river 
station). For this cross section enter a value of iO.O. 
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Cross Section Data-Base Geometry Data 
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Figure 4.4 Cross Section Data Editor with example data 

Enter all of the data for this cross section as it is shown in Figure 4.4. 

Once all the data are entered press the Apply Data button. This 
button is used to tell the interface that you want the data to be 
accepted into memory. This button does not save the data to your 
hard disk, that can only be accomplished from the File menu on the 
Geometric Data window. 

Plot the cross section to visually inspect the data. This is 
accomplished by pressing the Plot Cross Section option under the 
Plot menu on the Cross Section Data Editor. The cross section 
should look the same as that shown in Figure 4.5. 

In general, the five steps listed would be repeated for every cross section that 
is entered. In order to reduce the amount of data entry for this example, the 
current cross section will be copied and adjusted to represent other cross 
sections within the river system. 
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    __-^ \        - ;     Gross Sect-ci. 
File    Options    Help 

r\e:ich F-ilI Cr WT^^r^^^Mm^^:^;^^ 
Upstream Boundary of Fall Creek 

Figure 4.5 Cross Section Plot for river mile 10.0 of Fall Creek 

The following steps should be followed to copy the current cross section: 

1. Go to the Options menu on the Cross Section Data Editor and select 
Copy Current Cross Section. An input box will appear prompting 
you to select a reach and enter a river station for the new cross 
section. For this example, keep the reach as Fall Cr. and enter a new 
river station of 9.9. Press the OK button and the new cross section 
will appear in the editor. 

2. Change the description for the cross section to "River Mile 9.9 of Fall 
Creek." 

3. Adjust all the elevations of the cross section by -0.5 feet. This is 
accomplished by selecting the Adjust Elevations feature from the 
Options menu on the Cross Section Data Editor. 

4. Adjust the cross section stationing to reduce the overbanks by 10%. 
This is accomplished by selecting the Adjust Stations feature from 
the Options menu on the Cross Section Data Editor, then select 
Multiply by a Factor. When the input box appears for this option, 
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three data entry fields will be available to adjust the stationing of the 
left overbank, channel, and the right overbank separately. Enter 
values of 0.90 for the right and left overbanks, but leave the main 
channel field blank. This will reduce the stationing of both 
overbanks by 10%, but the main channel will not be changed. 

5. Downstream reach lengths remain the same for this cross section. 

6. Press the Apply Data button. 

7. Plot the cross section to visually inspect it. 

These seven steps should be repeated to enter all the data for Fall Creek and 
the Yolo River. The necessary adjustments are listed in Table 4.1. Perform 
the cross section duplications in the order that they are listed in the table. 
Make sure to change the description of each cross section, and also press the 
Apply Data button after making the adjustments for each cross section. 

Table 4.1 Cross Section adjustments for duplicating sections 

Cross Section Adjusted 
Elevation 

Adjusted Stationing Downstream Reach Lengths 

Reach River Sta. Left 
O.B. 

Channel Right O.B. Left O.B. Channel Right 
O.B. 

Fall Cr. 9.8 -0.4 0.80 - 0.80 0.0 0.0 0.0 

Yolo Ri. 9.79 -0.1 1.20 1.20 1.20 500 500 500 

Yolo Ri. 9.7 -0.5 1.20 1.20 1.20 500 500 500 

Yolo Ri. 9.6 -0.3 _ - - 500 500 500 

Yolo Ri 9.5 -0.2 - - - 0.0 0.0 0.0 

This completes all the cross section data for Fall Creek and the Yolo River. 
Now let's work on entering the data for the Butte Creek tributary. To enter 
the first cross section in the Butte Creek tributary do the following: 

1. Go to the Reach text box on the Cross Section Data Editor and select 
the Butte Cr. reach. 

2. Select Add a new Cross Section from the Options menu. When the 
popup box appears prompting you to enter a new river station, enter a 
value of 0.2. 

3. Enter all the data for this cross section as shown in Figure 4.6. 
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4. Once ail the data are entered for this section, press the Apply Data 
button. 

5. Plot the cross section to inspect the data. 

.. ■■■'.. .'Cross Section Data- Base.Geometry Data 
Exit    Edit    Options    Plot    Help 

Reach ButteCr. River Sta.  . 0:2; 't'l 

Description   Upstream Boundary of Butte Cr 

[Edit Station Elevation Data (ft) 

Figure 4.6 Cross Section Editor with river mile 0.2 of Butte Creek 

There are two other cross sections that need to be developed for the Butte 
Creek tributary. These two cross sections will be developed by duplicating 
the cross section that you just entered, and then adjusting the elevations and 
stationing. The necessary adjustments are listed in Table 4.2. Perform the 
cross section adjustments in the order that they are listed in the table. Make 
sure to change the description of each cross section and press the Apply Data 
button after editing is complete. 
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Table 4.2 Cross Section adjustments for Butte Creek sections 

Cross Section Adjusted 
Elevation 

Adjusted Stationing Downstream Reach Lengths 

Reach River Sta. Left 
O.B. 

Channel Right O.B. Left O.B. Channel Right 
O.B. 

Butte Cr. 0.1 -0.6 _ _ 500 500 500 

Butte Cr. 0.0 -0.3 - - - 0.0 0.0 0.0 

Now that all of the cross section data are entered, save the data to a file before 
continuing. Saving the data to a file is accomplished by selecting the "Save 
Geometry Data As" option from the File menu on the Geometric Data 
window. After selecting this option you will be prompted to enter a 
description of the geometric data. Enter "Base Geometry Data" for this 
example, then press the OK button. A file name is automatically assigned to 
the geometry data based on what you entered for the project filename. 

Entering Junction Data 

The next step is to enter the junction data. Junction data consist of a 
description, and reach lengths across the junction. In this example there is 
only one junction, which is labeled Sutter. Junction data is entered by 
pressing the Junction button on the Geometric Data window. Enter the 
junction data as shown in Figure 4.7. 

Junction Data - !3as« Geometry Data 

Junciiun Name 

Dcsciption 

r—     ■   i MI...:—.'-'-r——■ ' 

Sum." m Apply Ditto 

Flow Confluence of Fall and Butte Cre  |    \_\  Computation Mode 

(» Enurgy 

C Momentum 

Ixyirf * f nr.i.in 

T Arid Weight 

Length across Junction 
Reaches                      Length (ft) 

Butte Cr. to Yolo River 60                 : 

F\iM Cr. tu Yolo River 50 

mm CM n eel Hß!p 

Select Junction to Edit . isfl 

Figure 4.7 Junction Data Editor, with Sutter junction data 
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Reach lengths across the junction are entered in the junction editor, rather 
than in the cross section data. This allows for the lengths across very 
complicated confluences (i.e. flow splits) to be accommodated. In the cross 
section data, the reach lengths for the last cross section of each reach should 
be left blank or set to zero. 

In this example the energy equation will be used to compute the water 
surface profile through the junction. If the momentum equation is selected, 
then an angle must be entered for one or more of the reaches flowing into or 
out of a junction.   The momentum equation is set up to account for the angle 
of the flow entering the junction. 

Once you have all of the data entered for the junction, apply the data and 
close the window by pressing the OK button. 

Saving The Geometry Data 

At this point in the example, all of the geometric data has been entered. 
Before we continue with the example, you should save the geometric data to 
the hard disk. Since the data have already been saved once, you simply have 
to select Save Geometry Data from the File menu on the Geometric Data 
window. We can now go on to enter the Steady Flow data. 

Entering Steady Flow Data 

The next step in developing the required data to perform steady flow water 
surface profile calculations is to enter the steady flow data. To bring up the 
steady flow data editor, select Steady Flow Data from the Edit menu on the 
HEC-RAS main window. The Steady Flow Data editor should appear as 
shown in Figure 4.8. 

The first piece of data to enter is the number of profiles to be calculated. For 
this example enter "3" as shown in Figure 4.8. The next step is to enter the 
flow data. Flow data are entered from upstream to downstream for each 
reach. At least one flow rate must be entered for every reach in the river 
system. Once a flow value is entered at the upstream end of a reach, it is 
assumed that the flow remains constant until another flow value is 
encountered within the reach. Additional flow values can be entered at any 
cross section location within a reach. 
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Steady Flow Data>,10,2 and \% chance events. 
File    Options    Help 

Number of Profiles to be Calculated (1-15)    |_3 J   Boundary Conditions] [Apply Data 

Locations of Flow Data Changes 
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River Sta. 0.2 *l Add A Fiow Change Location  ] 

Reach RiverStai Profile 1 Profile 2                   Profile 3 

■ •;-.1 Fall Cr. 10       , 500.1 2000.                          5000. 

2 Butte Cr. 0.2    "; 100. 

600. 

500.                          1500. 

2500"                          6500. V'^3 Yolo River 9.79 .„i: 

■ CA Yolo River .9.6 650. 2700.                          7000. 

'~5 .    .        A", 

^'6 

7 
" ——— -■" 
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9 

10 
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Edit Steady flow data for the profiles in cfs 

Figure 4.8 Steady Flow Data Editor, with example problem data 

In this example, flow data will be entered at the upstream end of each reach. 
An additional flow change location will be entered at river mile 9.6 of the 
Yolo River. To add an additional flow change location into the table, first 
select the Yolo River from the Reach list box. Next select the desired river 
station location (9.6 in this example) from the River Sta. list box. Finally, 
press the Add A Flow Change Location button. The new flow location 
should appear in the table. Now enter all of the flow data into the table as 
shown in Figure 4.8. 

The next step is to enter any boundary conditions that may be required. To 
enter boundary condition data, press the Enter Boundary Conditions button 
at the top of the Steady Flow Data editor. The boundary conditions editor 
should appear as shown in Figure 4.9. 

Boundary conditions are necessary to establish the starting water surface at 
the ends of the river system. A starting water surface is necessary in order 
for the program to begin the calculations. In a subcritical flow regime, 
boundary conditions are only required at the downstream ends of the river 
system. If a supercritical flow regime is going to be calculated, boundary 
conditions are only necessary at the upstream ends of the river system. If a 
mixed flow regime calculation is going to be made, then boundary conditions 
must be entered at all ends of the river system. 
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Steady Row Boundary Conditions 

Critical Depth Normal Depth Rating Curve Delete 

Reach Up Stream Down Stream 

Fall Cr. Junction "Sutter" 

Junction "Sutter" 

Normal S •■=  .0004 

Butte Cr. 

Yolo River Junction "Sutler" 

Toggle between single/multiple boundary condition types per reach ^J 

OK Cancel Help 

Select location, then select boundary condition type 

Figure 4.9 Steady Flow Boundary Conditions 

The boundary conditions editor contains a table listing every reach. Each 
reach has an upstream and a downstream boundary condition.  Connections to 
junctions are considered internal boundary conditions. Internal boundary 
conditions are automatically listed in the table, based on how the river system 
is connected in the geometric data editor. The user is only required to enter 
the necessary external boundary conditions. 

In this example, it is assumed that the flow is subcritical throughout the river 
system. Therefore, it is only necessary to enter a boundary condition at the 
downstream end of the Yolo River. Boundary conditions are entered by first 
selecting the ceil in which you wish to enter a boundary condition. Then the 
type of boundary condition is selected from the four available types listed 
above the table. The four types of boundary conditions consist of: 

Known water surface elevations 

Critical depth 

Normal depth 

Ratine curve 

For this example use the normal depth boundary condition. Once you have 
selected the cell for the downstream end of Yolo River, press the Normal 
Depth button. A popup box will appear requesting you to enter an average 
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energy slope at the downstream end of the Yolo River. Enter a value of 
0.0004 (ft/ft), then press the Enter key. This completes all of the necessary 
boundary condition data. Press the OK button on the Boundary Conditions 
form to accept the data. 

The last step in developing the steady flow data is to save the data to a file. 
To save the data, select the Save Flow Data As option from the File menu on 
the Steady Flow Data Editor. A popup box will prompt you to enter a 
description of the flow data. For this example enter "10,2, and 1 % chance 
events". Once the data are saved you can close the Steady Flow Data Editor. 

Performing The Hydraulic Calculations 

Now that all of the data have been entered, we can calculate the steady water 
surface profiles. To perform the simulations, go to the HEC-RAS main 
window and select Steady Flow Analysis from the Simulate menu. The 
Steady Flow Analysis window should appear as shown in Figure 4.10. 

Sted ly i low ■'■■Vi» Si'. 

File    Options    Help 

Plan :   Existing Conditions Run 'ihort I 
IP-—  
i Existinq 

Geometry File ;       |Base Geometry Data 

Strady Flow Filo     MlQ. ? and 1 % chanru uvan'- 

[Flaw Regime'-^ 

! (? Sub critical 

I C Supercritical 

C Mixed 

I 

p Computation Range 

I Reach 

?*] 

Starting t^Jä 
I+|-'.- Reac m 

River Sta.| [Err; River Sta. 5F 

.COMPUTE 
nftwiHBtinifirirrr'?"-" —- 

Enter to computB water surface profiles 

Figure 4.10 Steady Flow Analysis Simulation Window 

The first step is to put together a Plan. The Plan defines which geometry 
and flow data are to be used, as well as providing a title and short identifier 
for the run. To establish a plan, select iNew Plan from the File menu on the 
Steady Flow Analysis window. Enter the plan title as "Existing Conditions 
Run" and then press the OK button. Enter a short identifier of "Existing" in 
the Short ID box. 
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The next step is to select the desired flow regime for which the model will 
perform calculations.  For this example we will be performing Subcritica! 
flow calculations only.  Make sure that Subcritical is the selected flow 
regime.  Additional job control features are available from the Options menu 
bar. but none are required for this example.  Once you have defined a plan 
and set all the desired job control information, the plan information should be 
saved. Saving the plan information is accomplished by selecting Save Plan 
from the File menu of the Steady Flow Analysis window. 

Now that everything has been set, the steady flow computations can be 
performed by pressing the Compute button at the bottom of the Steady Flow- 
Simulation window". Once the compute button has been pressed, a separate 
window will appear showing you the progress of the computations. Once the 
computations have been completed, the computation window can be closed 
by double clicking the upper left corner of the window. At this time the 
Steady Fiow; Simulation window can also be closed. 

mcj rS3 ]   _ 

Once the model has finished all of the computations successfully, you can 
begin viewing the results.  Several output options are available from the 
View menu bar on the HEC-RAS main window. These options include: 

a Cross section plots 

3 Profile plots 

3 Rating curves 

a X-Y-Z Perspective Plots 

- Detailed tabular output at a specific cross section (cross section table) 

o Limited tabular output at many cross sections (profile table) 

Let's begin by plotting a cross section. Select Cross Sections from the View 
menu bar on the HEC-RAS main window. This will automatically bring up a 
plot of the first cross section in Fall Creek, as shown in Figure 4.11. Any 
cross section can be plotted by selecting the appropriate reach and river 
station from the list boxes at the top of the cross section plot window. The 
user can also step through the plots by using the up and down arrow buttons. 
Several plotting features are available from the Options menu bar on the 
cross section plot window. These options include: zoom in; zoom out; 
selecting which plans, profiles and variables to plot: and control over lines, 
symbols, labels, scaling, and grid options. 
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    Cross Section 
File    Options    Help 

Reach Fall Cr River Sta. *0/l ütü m. i        . 243 66,8933,*! 

Upstream Boundary of Fall Creek 

Figure 4.11  Cross Section Plot for Example Application 

Select different cross sections to plot and practice using some of the features 
available under the Options menu bar. 

Next let's plot a water surface profile. Select Water Surface Profiles from 
the View menu bar on the HEC-RAS main window. This will automatically 
bring up a water surface profile plot for the first reach, which is Yolo Creek 
in our example. To plot more than one reach, select Reaches from the 
Options menu bar on the profile plot. This option brings up a list of 
available reaches from which to choose. Select the Fall Cr. and Yolo River 
reaches. This should give you a profile plot as shown in Figure 4.12. Plot 
the additional profiles that were computed and practice using the other 
features available under the Options menu bar on the profile plot. 
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Figyre 4.12 Profile Plot for Example Application 

Now let's plot a computed rating curve. Select Rating Curves from the 
View menu on the HEC-RAS main window. A rating curve based on the 
computed water surface profiles will appear for the first cross section in Fall 
Creek, as shown in Figure 4.13. You can look at the computed rating curve 
for any location by selecting the appropriate reach and river station from the 
list boxes at the top of the plot. Plotting options similar to the cross section 
and profile plots are available for the rating curve plots. Plot rating curves 
for various locations and practice using the available plotting options. 



Chapter 4  Example Application 
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Figure 4.13 Computed Rating Curve for Example Application 

Next look at an X-Y-Z Perspective Plot of the river reaches. From the View 
menu bar on the HEC-RAS main window, select X-Y-Z Perspective Plots. 
A multiple cross section perspective plot should appear for the Fall Creek 
reach as shown in Figure 4.14. Try rotating the perspective view in different 
directions, and select different reaches to look at. 

Now let's look at some tabular output. Go to the View menu bar on the HEC- 
RAS main window. There are two types of tables available, a cross section 
specific table and a profile table. Select Cross Section Table to get the first 
table to appear. The table should look like the one shown in Figure 4.15. 
This table shows detailed hydraulic information at a single cross section. 
Other cross sections can be viewed by selecting the appropriate reach and 
river mile from the table. 

Now bring up the profile table. This table shows a limited number of 
hydraulic variables for several cross sections. There are several types of 
profile tables listed under the Tables menu bar of the profile table window. 
Some of the tables are designed to provide specific information at hydraulic 
structures (e.g. bridges and culverts), while others provide generic 
information at all cross sections. An example of this type of table is shown in 

Figure 4.16. 



Chapter 4 Example Application 

Reach 

Fall Cr. i 
River Station i t 

Start 10 £: 

End 3 a "M 
Profiles IPfaris: 

Height/Width 

Width/Distance 

10 

4- a. 

Rotation 

Azimuth 

9± 
WS Transparent 

f Reverse WS order 
[x Banks and Invert 

X-Y-Z Perspective Ptof 

Reach: Fail Cr.    RS: 10 to 9.8    PF#: 1,2,3 

Change the perspective vertical rotation angle 

Figure 4.14 X-Y-Z Perspective Plot of Fall Cr. river reach 
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Figure 4.15 Detailed Tabular Output at a Cross Section 
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Figure 4.16 Tabular Output in Profile Format 
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tint™ Graphics and Tables 

All of the plots and tables can be sent directly to a printer/plotter or passed 
through the Windows clipboard to another program (e.g. a word processor). 
The printer or plotter that gets used is based on what you currently have 
selected as the default printer for Windows. The user has the ability to 
change many of the default printer settings (e.g. portrait to landscape) before 
printing occurs. 

Sending Graphics Directly to the Printer 

To send a graphic to the printer/plotter, do the following: 

1. Display the graphic of interest (cross section, profile, rating curve, or 
river system schematic) on the screen. 

2. Using the available options (scaling, labels, grid, etc.), modify the 
plot to be what you would like printed out. 

3. Select Print Current from the File menu of the displayed graphic. 
Once Print is selected, a Printer Options window will appear, 
giving the user the opportunity to change any of the default printer 
settings. Once you have the print settings the way you want them, 
press the Print button on the Printer Options window and the plot 
will automatically be sent to the Windows Print Manager. From that 
point the Windows Print Manager will control the printing. 

Sending Graphics to the Windows Clipboard 

To pass a graphic to the Windows clipboard and then to another program, do 
the following: 

1. Display the graphic of interest on the screen. 

2. Using the available options, modify the plot to be what you want 
printed. 

3. Select Copy to Clipboard from the File menu of the displayed 
graphic. The plot will automatically be sent to the Windows 
clipboard. 

4. Bring up the program that you want to pass the graphic into (e.g. 
word processor). Select Paste from the Edit menu of the receiving 
program. Once the graphic is pasted in, it can be re-sized to the 
desired dimensions. 
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Sending Tables Directly to the Printer 

To send a table to the printer do the following: 

1. Bring up the desired table from the tabular output section of the 
program. 

2. Select Print from the File menu of the displayed table. Once the 
Print option is selected, a Printer Options window will appear. Set 
any print options that are desired, then press the Print button. This 
will send the entire table to the Windows Print Manager. From this 
point the Windows Print Manager will control the printing of the 
table. 

The profile type of tables allow you to print a specific portion of the table, 
rather than the whole thing. If you desire to only print a portion of the table, 
do the following: 

1. Display the desired profile type table on the screen. 

2. Using the mouse, press down on the left mouse button and highlight 
the area of the table that you would like to print. To get an entire row 
or column, press down on the left mouse button while moving the 
pointer across the desired row or column headings. 

3. Select Print from the File menu of the displayed table. Only the 
highlighted portion of the table and the row and column headings will 
be sent to the Windows Print Manager. 

Sending Tables to the Windows Clipboard 

To pass a table to the Windows clipboard and then to another program, do the 
following: 

1. Display the desired table on the screen. 

2. Select Copy to Clipboard from the File menu of the displayed table. 

3. Bring up the program that you want to pass the table into. Select 
Paste from the Edit menu of the receiving program. 

Portions of the profile tables can be sent to the clipboard in the same manner 
as sending them to the printer. 

Practice sending graphics and tables to the printer and the clipboard with the 
example data set that you currently have open. 
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Exiting The Program 

Before you exit the HEC-RAS software, make sure you have saved all the 
data. This can be accomplished easily by selecting Save Project from the 
File menu on the HEC-RAS main window. Any data (geometric, flow, and 
plan data) that have not been saved will automatically be saved for you. 

To exit the HEC-RAS software, select Exit from the File menu of the HEC- 
RAS main window. The program will prompt you to save the project if the 
data have not been saved previously. 
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CHAPTER   5 

Working With Projects 

To create a river hydraulics application with HEC-RAS, you work with 
projects. A project is a collection of files that are used to build a model. This 
chapter describes projects and how you build and manage them. 

Contents 

■ Understanding Projects 

■ Elements of a Project 

■ Creating, Opening, Saving, Renaming, and Deleting Projects 

■ Project Options 

Understanding Projects 

As you develop an application, the management of all the files that get created 
is accomplished through the user interface. When a new project is started, the 
user is requested to enter a title and filename for the project. All other data are 
automatically stored by the user interface using the same name as the project 
file, except for the three character extension. A project consists of: 

■ One Project file (.PRJ) 

■ One file for each Plan (.P01 to .P99) 

■ One Run file for each plan (.R01 to .R99) 

■ One Output file for each plan (.001 to .099) 

■ One file for each set of Geometry data (.G01 to .G99) 

■ One file for each set of Steady Flow data (.F01 to .F99) 

■ One file for each set of Unsteady Flow data (.U01 to .U99) 

■ One file for each set of Sediment data (.SOI to .S99) 

■ One file for each set of Hydraulic Design data (.HOI to .H99) 
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The Project Fiie contains: the title of the project; a list of all the files that are 
associated with the project; and a list of default variables that can be set from 
the interface. Also included in the project file is a reference to the last plan that 
the user was working with. This information is updated every time you save 
the project. 

Elements of a Project 

The following sections describe the various types of files that can be included 
in a project. All of these files are either created by the user interface or the 
various computation engines. The modeler interacts with the data through the 
user interface, and is not required to create any of these files. 

Plan Files 

Plan files have the extension .P01 to .P99. The "P" indicates a Plan file, while 
the number represents the plan number. As plans are created, they are 
numbered from 01 to 99. The plan file contains: a description and short 
identifier for the plan; a list of files that are associated with the plan (e.g., 
geometry file and steady flow file); and a description of all the simulation 
options that were set for the plan. The plan file is created automatically by the 
interface each time the user selects New Plan or Save Plan As from the 
simulation windows. 

Run Files 

Run files have the extension .R01 to .R99. The "R" indicates a Run file, while 
the number represents an association to a particular plan file. A file with an 
extension of .R01 is the run file that corresponds to the plan file with the 
extension .POL The run file contains all of the necessary data to perform the 
computations that are requested by the associated plan file. For example, if a 
steady flow analysis is requested, the run file will contain geometry data, steady 
flow data, and all the necessary computational options that are associated with 
the plan file. The run file contains the input to any of the computational 
engines available in the HEC-RAS system. The run file is automatically 
generated by the interface whenever the user presses the Compute button on 
the Simulation windows. The run file is in an ASCII format, but it is not self 
explanatory. 
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Output Files 

Output files have the extension .001 to .099. The "O" indicates an Output file, 
while the number represents an association to a particular plan file. A file with 
the extension .012 is the output file that corresponds to the plan file with an 
extension .PI 2. The output file contains all of the computed results from the 
requested computational engine. For example, if a steady flow analysis is 
requested, the output file will contain results from the steady flow 
computational engine. The output files are in a binary file format and can only 
be read from the user interface. 

Geometry Files 

Geometry files have the extension .G01 to .G99. The "G" indicates a Geometry 
file, while the number corresponds to the order in which they were saved for 
that particular project. Geometry files contain all of the geometric data for the 
river system being analyzed. The geometric data consist of: cross section 
information; hydraulic structures data (e.g. bridges and culverts); coefficients; 
and modeling approach information. The geometry data are stored in an ASCII 
format. The file contains key words to describe each piece of data, and is for- 
the-most-part self explanatory. A geometry file is created by the user interface 
whenever the modeler selects New Geometry Data or Save Geometry Data 
As from the Geometric Data window. 

Steady Flow Data Files 

Steady flow data files have the extension .F01 to .F99. The "F" represents that 
it is a steady Flow data file, while the number corresponds to the order in which 
they were saved for that particular project. Steady flow data files contain: the 
number of profiles to be computed; flow data; and boundary conditions for each 
reach. The steady flow data files are stored in an ASCII format. The file 
contains key words to describe each piece of data, and is for-the-most-part self 
explanatory. Steady flow data files are automatically created by the user 
interface when the modeler selects New Flow Data or Save Flow Data As 
from the Steady Flow Data window. 

Unsteady Flow Data Files 

Unsteady flow data files have the extension .U01 to .U99. The "U" represents 
that it is an Unsteady flow data file, while the number corresponds to the order 
in which they were saved for that particular project. Unsteady flow data files 
contain: flow hydrographs at the upstream boundaries; starting flow conditions; 
and downstream boundary conditions. The unsteady flow data files are stored 
in an ASCII format. The file contains key words to describe each piece of data, 
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and is for-the-most-part self explanatory. Unsteady flow data files are 
automatically created by the user interface when the modeler selects New Flow 
Data or Save Flow Data As from the Unsteady Flow Data window. 

Sediment Data Files 

Sediment data files have the extension .SOI to .S99. The "S" represents that it 
is a Sediment data file, while the number corresponds to the order in which they 
were saved for that particular project. Sediment data files contain: flow data; 
boundary conditions for each reach; and sediment data. The sediment data files 
are stored in an ASCII format. The file contains key words to describe each 
piece of data, and is for-the- most-part self explanatory. Sediment data files are 
automatically created by the user interface when the modeler selects New 
Sediment Data or Save Sediment Data As from the Sediment Data window. 

Hydraulic Design Data Files 

Hydraulic design data files have the extension .HOI to .H99. The "H" 
represents that it is a Hydraulic design data file, while the number corresponds 
to the order in which they were saved for that particular project. Hydraulic 
design data files contain information corresponding to the type of hydraulic 
design calculation that is requested. The Hydraulic design data files are stored 
in an ASCII format. The file contains key words to describe each piece of data, 
and is for-the most-part self explanatory. Hydraulic Design data files are 
automatically created by the user interface when the modeler selects New 
Hydraulic Design Data or Save Hydraulic Design Data As from the 
Hydraulic Design Data window. 
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Creating, Opening, Saving, Renaming, and Deleting 
Projects 

The following commands from the File menu of the HEC-RAS main window 
allow you to create, open, save, rename, and delete projects. 

File menu command Description 

New Project 

Open Project 

Save Project 

Save Project As 

Rename Project 

Delete Project 

Closes the current project, prompting you to 
save the data if anything has been changed. 
The user is then prompted to enter a title and 
filename for the new project. 

Closes the current project, prompting you to 
save the data if anything has been changed. 
Opens an existing project and all of the 
associated files. 

Updates the project file and all other files in 
which data have been modified. 

Updates the project file and all other  . 
associated data, saving all the information to a 
filename that you specify. 

Allows the user to rename the title of the 
currently opened project. 

Deletes the project file and all other files 
associated with the selected project. The user 
is prompted to make sure that they really want 
to delete all of the files associated with the 
project. 

These commands are the same for all of the other data types that get created 
by the user interface (Plan data, geometry data, steady flow data, unsteady 
flow data, sediment data, and hydraulic design data). 

Project Options 
From the Options menu of the main HEC-RAS window, the user can set 
several default project options. These options include: setting default margins 
and color control for printing; setting default hydraulic variables; establishing 
the default units system (English or Metric); and converting existing projects 
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to a different units system (English to Metric or Metric to English). The 
following four options are available from the Options menu of the main 
window: 

Options menu command        Description 

Program Setup 

- BW to Printer When this option is set all graphics are sent to 
the printer\plotter in Black and White. When 
this option is turned off, all graphics are sent 
as color drawings. Color drawings that are 
sent to a black and white printer will come out 
in grey scale shadings. 

BW to Clipboard 

Default Margins 

When this option is set all graphics are sent to 
the Windows Clipboard in a Black and White 
mode. When this option is turned off, the 
graphics are sent to the Clipboard as color 
drawings. 

This option allows the user to change the 
default margins for printing graphics and 
tables. The default settings are 1 inch margins 
on all four sides. 

- Default File Viewer   This option allows the user to change which 
program is used for viewing the logfile output. 
The default is the Windows Write program. 

- Open last project 

Default Parameters 

Unit System 

When this option is selected, the program will 
automatically open the last project worked on, 
during startup. 

This option allows the user to set defaults for 
some of the hydraulic variables. 

This option allows the user to set the default 
units system to either English or Metric. Once 
the units system is set, the program assumes 
that all input data are entered in that units 
system. Likewise, the display of all output 
data will be done in the default units system. 

Convert Project Units This option allows the user to convert an 
existing project from one units system to 
another. Projects can be converted from 
English to Metric or from Metric to English. 
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CHAPTER  6 

Entering and Editing Geometric Data 

Geometric data consist of establishing the connectivity of the river system 
(River System Schematic), entering cross-section data, defining all the 
necessary junction information, adding hydraulic structure data (bridges, 
culverts, weirs, etc..) and cross section interpolation. The geometric data is 
entered by selecting Geometric Data from the Edit menu on the HEC-RAS 
main window. Once this option is selected, the Geometric Data window will 
appear as shown in Figure 6.1. The drawing area will be blank on your 
screen, until you have drawn in your own river system schematic. 

This chapter describes how to enter and edit all of the necessary geometric 
data for a river system. 

Contents 

■ Developing the River System Schematic 

■ Cross Section Data 

■ Stream Junctions 

■ Bridges and Culverts 

" Cross Section Interpolation 

■ Saving the Geometric Data 

Developing the River System Schematic 

Building The Schematic 

The modeler develops the geometric data by first drawing in the river system 
schematic on the Geometric Data window (Figure 6.1). This is 
accomplished, on a reach-by-reach basis, by pressing the River Reach button 
and then drawing in a reach from upstream to downstream (in the positive 
flow direction). After the reach is drawn, the user is prompted to enter an 
identifier. The identifier can be up to twelve characters in length. As reaches 
are connected together, junctions are automatically formed by the interface. 
The modeler is also prompted to enter an identifier for each junction. 
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Geometric Data 
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Figure 6.1 Geometric Data Window 

Editing The Schematic 

There are several options available for editing the river system schematic. 
These options include: deleting reaches, changing labels, and moving objects 
(objects are labels, junctions, and ends of reaches). Editing features for the 
schematic are found under the Edit menu of the geometric data window as 
follows: 

Change Name: This option allows the user to change the name of any reach 
or junction. This is accomplished by first selecting the Change Name option 
from the Edit menu, then selecting the particular label that you would like to 
change. Once you have clicked the left mouse button over the label to be 
changed, a popup window will appear allowing you to enter a new label. The 
user can continue to change names by simply selecting the next label to be 
changed. The Change Name option is automatically turned off when the user 
selects any other option. 
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Move Object: This option allows you to move any label, junction, or the end 
of a reach. This is accomplished by first selecting Move Object from the 
Edit menu, then selecting the particular object that you would like to move. 
To select an object and then move it, simply place the mouse pointer over the 
object, then press the left mouse button down. Move the object to the desired 
location and then release the left mouse button. The Move Object option will 
remain in effect until the user either turns it off or selects any other option. 

Delete Reach: This option is used to delete a reach. This is accomplished by 
selecting the Delete Reach option from the Edit menu. A list box containing 
all the available reaches will appear allowing you to select those reaches that 
you would like to delete. Be careful when you delete reaches. When you 
delete a reach, all of its associated data will be deleted also. 

Interacting With The Schematic 

In addition to modifying the river schematic, there are options available to 
zoom in, zoom out, and display the cross section river stationing on the 
schematic. These options are available from the View menu on the geometric 
data window as follows: 

Zoom In: This option allows the user to zoom in on a piece of the schematic. 
This is accomplished by selecting Zoom In from the View menu, then 
specifying the area to zoom in on with the mouse. Defining the zoom area is 
accomplished by placing the mouse pointer in the upper left corner of the 
desired area. Then press down on the left mouse button and drag the mouse to 
define a box containing the desired zoom area. Finally, release the left mouse 
button and the viewing area will display the zoomed in schematic. Also 
displayed will be a small box in the upper right corner of the viewing area. 
This box will contain a picture of the entire schematic, with a rectangle 
defining the area that is zoomed in. In addition to showing you where you are 
at on the schematic, this zoom box allows you to move around the schematic 
without zooming out and then back in. To'move the zoomed viewing area, 
simply hold down the left mouse button over the rectangle in the zoom box 
and move it around the schematic. The zoom box can also be resized. 
Resizing the zoom box is just like resizing a window. 

Zoom Out: This option re-displays the schematic back into its original size 
before you zoomed in. Zooming out is accomplished by selecting Zoom Out 
from the View menu on the geometric data window. 

Display River Stationing: This option allows you to display river station 
tags on the schematic at the locations of any cross section data that have been 
entered. This is accomplished by selecting Display River Stationing from 
the View menu on the geometric data window. 
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Cross Section Data 

After the river system schematic is completed, the next step for the modeler 
is to enter the cross section data. Cross section data represent the geometric 
boundary of the stream. Cross sections are located at relatively short 
intervals along the stream to characterize the flow carrying capacity of the 
stream and its adjacent floodplain. Cross sections are required at 
representative locations throughout the stream and at locations where 
changes occur in discharge, slope, shape, roughness, at locations where 
levees begin and end. and at hydraulic structures (bridges, culverts, and 
weirs). 

Entering Cross Section Data 

To enter cross section data, the user presses the Cross Section button on the 
Geometric Data window (Figure 6.1). Once the cross section button is 
pressed, the Cross Section Data Editor will appear as shown in Figure 6.2 
(except yours will be blank). To add a cross section to the model, the user 
must do the following: 

1. Select the reach that you would like to place the cross section in. 
This is accomplished by pressing the down arrow on the reach box, 
and then selecting the reach of choice. 

2. Go to the Options menu and select Add a new Cross Section from 
the list. An input box will appear prompting you to enter a river 
station identifier for the new cross section. 

3. Enter ail of the required data for the new cross section. 

4. Enter any desired optional information. Optional cross section 
information is found under the Options menu at the top of the 
window. 

5. Press the Apply Data button in order for the interface to accept the 
information. The apply data button does not save the data to the hard 
disk, it is only used as a mechanism for telling the interface to use the 
information that was just entered. If you want the data to be saved to 
the hard disk you must do that from the File menu on the geometric 
data window. 

The required information for a cross section consists of: the reach and river 
station where the cross section is located; a description; X & Y coordinates 
(station and elevation points); downstream reach lengths; roughness 
coefficients; main channel bank stations; and contraction and expansion 
coefficients. All of the required information is displayed openly on the Cross 
Section Data editor (Figure 6.2). A description of this information follows: 
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Reach and River Station. The Reach box allows the user to select a reach 
from the available reaches in the schematic diagram. The reach label defines 
which reach the cross section will be located in. The River Station tag 
defines where the cross section will be located within the specified reach. 
The river station tag does not have to be the actual river station of the cross 
section, but it must be a numeric value. Cross sections are ordered in the 
reach from highest river station upstream to lowest river station downstream. 
The up and down arrow buttons next to the river station box can be used to 
sequentially move through the river stations. 

Description. The description box is used to describe the cross section 
location in more detail than just the reach and river station. This box has a 
limit of 256 characters. Only the first line of information is displayed, unless 
the button to the right of the box is pressed. Also, the first 40 characters of 
the description is used as a label for cross section plots and cross section 

tables. 
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Figure 6.2 Cross Section Data Editor 
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Cross Section X & Y Coordinates. This table is used to enter the station 
and elevation information of the cross section. Station and elevation 
information is entered in feet (meters for metric). 

Downstream Reach Lengths. The downstream reach lengths describe the 
distance between the current cross section and the next cross section 
downstream. Reach lengths are defined for the left overbank, main channel, 
and the right overbank. Reach lengths are entered in feet (meters for metric). 

Manning's n Values. At a minimum the user must specify manning's n 
values for the left overbank, main channel, and the right overbank. 
Alternative roughness coefficient options are available from the Options 
menu. 

Main Channel Bank Stations. The main channel bank stations are used to 
define what portion of the cross section is considered the main channel and 
what is considered left and right overbank area. The bank stations must 
correspond to stations entered on the cross section X & Y coordinates table. 
If the user enters a value that does not correspond to the station points of the 
cross section, the interface will ask the user if they would like the value to be 
automatically interpolated and added to the cross section data. 

Contraction & Expansion Coefficients. Contraction and expansion 
coefficients are use to evaluate the amount of energy loss that occurs because 
of a flow contraction or expansion. The coefficients are multiplied by the 
change in velocity head from the current cross section and the previous cross 
section. 

Once all of the required data for the cross section are entered, make sure you 
press the Apply data button to ensure that the interface accepts the data that 
was just entered. 

Editing Cross Section Data 

The bulk of the cross section data is the station and elevation information. 
There are several features available under the Edit menu to assist the user in 
modifying this information. These features include the following: 

Undo Editing. This editing feature applies to all of the information on the 
cross section data editor. Once data has been entered and the Apply Data 
button has been pressed, the Undo Editing feature is activated. If any 
changes are made from this point, the user can get the original information 
back by selecting the Undo Edit option from the Edit menu. Once the 
Apply Data button is pressed, the new information is considered good and 
the Undo Edit feature is reset to the new data. 

6-6 



Chapter 6 Entering and Editing Geoni etric Data 

Cut, Copy, and Paste. Cut, Copy, and Paste features are available for the 
station and elevation information on the cross section editor. These features 
allow the user to pass cross section station and elevation data to and from the 
Windows Clipboard. To use this feature, first highlight a cell or multiple cells 
on the station and elevation table. Cells are highlighted by pressing down on 
the left mouse button and moving it over the cells that you would like to be 
highlighted. Next select either the Cut or Copy feature from the Edit menu. 
If Cut is selected, the information is placed in the Windows Clipboard and 
then it is deleted from the table. If Copy is selected, the information is placed 
in the Windows Clipboard, but it also remains in the table. Once the 
information is in the Windows Clipboard it can be pasted into the station and 
elevation table of any cross section. To paste data into another cross section, 
first go to the cross section in which you would like the data to be placed. 
Highlight the area of the table in which you want the data to be placed. Then 
select the Paste option from the Edit menu. The cut, copy, and paste features 
can also be used to pass station and elevation information between HEC-RAS 
and other programs. 

Delete. This option allows the user to delete a single cell or multiple cells in 
the station/elevation table. Once the cells are deleted, everything below those 
cells is automatically moved up. To use this option, first highlight the cells 
that you would like to delete, then select the Delete option from the Edit 
menu. If you would like to clear cells, without moving the data below those 
cells, simply highlight the cells and press the delete key. 

Insert. This option allows the user to insert one or several rows in the middle 
of existing data in the station/elevation table. To use this option, first 
highlight die area in the table that you would like to be inserted. The select 
Insertfrom the Edit menu. The rows will be inserted and all of the data will 
be moved down the appropriate number of rows. The user can also insert a 
single row by placing the curser in the row just below where you would like 
the new row to be inserted. Then select Insert from the Edit menu. The row 
will be inserted and all of the data below the current row will be moved down 

one row. 

Cross Section Options 

Information that is not required, but is optional, is available from the Options 
menu at the top of the cross section data editor window (Figure 6.2). Options 

consist of the following: 

Add a new Cross Section. This option initiates the process of adding a cross 
section to the data set. The user is prompted to enter a river station tag for the 
new cross section. The river station tag locates the cross section within the 
selected reach. Once the river station is entered, the cross section data editor 
is cleared and the user can begin entering the data for the cross section. 
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Copy Current Cross Section. This option allows the user to make a copy of 
the cross section that is currently displayed in the editor. When this option is 
selected, the user is prompted to select a reach and enter a river station for the 
new section. Once the information is entered, the new cross section is 
displayed in the editor. At this point it is up to the user to change the 
description and any other information about the cross section. This option is 
normally used to make interpolated cross sections between two surveyed 
cross sections. Once the section is copied, the user can adjust the elevations 
and stationing of the cross section to adequately depict the geometry between 
the two surveyed sections. 

Rename Cross Section. This option allows the user to change the River 
Station of the currently displayed cross section. 

Delete Cross Section. This option will delete the currently displayed cross 
section. The user is prompted with a message stating specifically which 
cross section is going to be deleted, and requesting the user to press the OK 
button or the Cancel button. 

Adjust Elevations. This option allows the user to adjust all of the elevations 
of the currently displayed cross section. Positive or negative elevation 
changes can be entered. Once the value is entered, the interface 
automatically adjusts all the elevations in the table. 

Adjust Stations. This option allows the user to adjust the stationing of the 
currently displayed cross section. Two options are available.   The first 
option (Multiply by a Factor) allows the user to separately expand and/or 
contract the left overbank, main channel, and the right overbank. When this 
option is selected, the user is prompted to enter a multiplier for each of the 
three flow elements (left overbank, main channel, and right overbank).   If 
the multiplier is less than one, the flow element is contracted. If the 
multiplier is greater than one, the flow element is expanded. Once the 
information is entered, and the user hits the OK button, the interface 
automatically performs the contraction and/or expansions.   The cross section 
should be reviewed to ensure that the desired adjustments were performed. 
The second option (Add a Constant) allows the user to add or subtract a 
constant value from all the stations in the cross section. This would allow the 
entire cross section to be shifted to the right or the left. 

Adjust n Values. This option allows the user to either increase or decrease 
all the n values of the current cross section. The user is prompted for a single 
value. This value is then used as the multiplier for all of the n values of the 
current cross section. 

Ineffective Flow Areas. This option allows the user to define areas of the 
cross section that will contain water that is not actively being conveyed 
(ineffective flow). Ineffective flow areas are often used to describe portions 
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of a cross section in which water will pond, but the velocity ofthat water, in 
the downstream direction, is close to zero. This water is included in the 
storage calculations and other wetted cross section parameters, but it is not 
included'as part of the active flow area. When using ineffective flow areas, 
no additional wetted perimeter is added to the active flow area. An example 
of an ineffective flow area is shown in Figure 6.3. The cross-hatched area on 
the left of the plot represents the ineffective flow area. 

Two alternatives are available for setting ineffective flow areas. The first 
option allows the user to define a left station and elevation and a right station 
and elevation (normal ineffective areas). When this option is used, and if the 
water surface is below the established ineffective elevations, the areas to the 
left of the left station and to the right of the right station are considered 
ineffective. Once the water surface goes above either of the established 
elevations, then that specific area is no longer considered ineffective. 

The second option allows for the establishment of blocked ineffective flow 
areas. Blocked ineffective flow areas require the user to enter an elevation, a 
left station, and a right station for each ineffective block. Up to five blocked 
ineffective flow areas can be entered at each cross section. Once the water 
surface goes above the elevation of the blocked ineffective flow area, the 
blocked area is no longer considered ineffective. 
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Levees. This option allows the user to establish a left and/or right levee 
station and elevation on any cross section. When levees are established, no 
water can go to the left of the left levee station or to the right of the right 
levee station until either of the levee elevations are exceeded. Levee stations 
must be defined explicitly, or the program assumes that water can go 
anywhere within the cross section. An example of a cross section with a 
levee on the left side is shown in Figure 6.4.  In this example the levee station 
and elevation is associated with an existing point on the cross section. 
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Figure 6.4 Example of the Levee Option 

The user may want to add levees into a data set in order to see what effect a 
levee will have on the water surface. A simple way to do this is to set a levee 
station and elevation that is above the existing ground. If a levee elevation is 
placed above the existing geometry of the cross section, then a vertical wall 
is placed at that station up to the established levee height. Additional wetted 
perimeter is included when water comes into contact with the levee wall. An 
example of this is shown in Figure 6.5. 

Blocked Obstructions. This option allows the user to define areas of the 
cross section that will be permanently blocked out. Blocked obstructions 
decrease flow area and add wetted perimeter when the water comes in 
contact with the obstruction. A blocked obstruction does not prevent water 
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from going outside of the obstruction. 

Two alternatives are available for entering blocked obstructions. The first 
option allows the user to define a left station and elevation and a right station 
and elevation (normal blocked areas). When this option is used, the area to 
the left of the left station and to the right of the right station will be 
completely blocked out. An example of this type of blocked obstruction is 
shown in Figure 6.6. 
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The second option, for blocked obstructions, allows the user to enter up to 20 
individual blocks (Multiple Blocks). With this option the user enters a left 
station, a right station, and an elevation for each of the blocks. An example of 
a cross section with multiple blocked obstructions is shown in Figure 6.7. 
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Figure 6.7 Example of a Cross Section With Blocked Obstructions 

Add a Lid to XS. This option allows the user to add lid (similar to a bridge 
deck/roadway) to any cross section. This is commonly used when trying to 
model a long tunnel. The ground geometry can be used to describe the bottom 
half of the tunnel, while the lid can describe the top half. A lid can be added 
to any number of sections in a row. The program treats cross sections with 
lids just like any other cross section. The energy equation is used to balance a 
water surface, with the assumption of open channel flow. The only difference 
is that the program will subtract out area and add wetted perimeter when the 
water surface comes into contact with the lid. 

Horizontal Variation in n Values. This option allows the user to enter more 
than three Manning's n values for the current cross section. When this option 
is selected, an additional column for n values is added to the cross section 
coordinates table as shown in Figure 6.8. A Manning's n value must be placed 
in the first row of the table. This n value is good for all cross section stations 
until a new n value shows up in the table. The user does not have to enter an 
n value for every station, only at the locations where the n value is changing. 

Set Maximum Sta./Elev. Points. This option allows the user to set the 
maximum number of station and elevation points in a cross section. The 
default value is set to 100 points. A maximum value of 500 can be set. This 
option is only necessary when the user wants to enter more than 100 points for 
the station and elevation points of a cross section. 
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Figure 6.8 Cross section with horizontal variation of n values selected 

Plotting Cross Section Data 

Once all the data have been entered for a cross section, you should plot the 
cross section to inspect it for possible data errors. To plot the current cross 
section from the cross section editor, select Plot Cross Section from the Plot 
menu. 

Stream Junctions 

Entering Junction Data 

Stream junctions are defined as locations where two or more streams come 
together or split apart. Junction data consist of a description, reach lengths 
across the junction, tributary angles, and modeling approach. To enter 
junction data the user presses the Junction button on the Geometric Data 
window (Figure 6.1). Once the junction button is pressed, the junction editor 
will appear as shown in Figure 6.9. 
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Figure 6.9 Junction Data Editor 

The junction editor will come up with one of the junctions loaded. Fill out the 
description and reach lengths for the junction. Reach lengths across the 
junction are entered here instead of the cross section data editor. This allows 
for the lengths across very complicated confluences (i.e. flow splits) to be 
accommodated. In the cross section data, the reach lengths for the 
downstream cross section of each reach should be left blank or set to zero. 

Selecting A Modeling Approach 

In HEC-RAS a junction can be modeled by either the energy equation or the 
momentum equation. The energy equation does not take into account the 
angle of a tributary coming in or leaving, while the momentum equation does. 
In most cases the amount of energy loss due to the angle of the tributary flow 
is not significant, and using the energy equation to model the junction is more 
than adequate. However, there are situations where the angle of the tributary 
can cause significant energy losses. In these situations it would be more 
appropriate to use the momentum approach. When the momentum approach 
is selected, an additional column is added to the table next to the junction 
lengths. This column is used to enter an angle for any river reach that is 
coming into or exiting the main river. For the reaches that are considered to 
be the main river, the angle should be left blank or set to zero. Also, the user 
has the option to turn friction and weight forces on or off during the 
momentum calculations. The default is to have the weight force turned off. 

If there is more than one junction in the river schematic, the other junctions 
can be selected from the Junction Name box at the upper left corner of the 
window.   Enter all the data for each junction in the river system, then close 
the window by pressing the OK button in the lower left corner of the window. 
When the junction data editor is closed the data are automatically applied. 
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Bridges and Culverts 

Once all of the necessary cross-section data have been entered, the modeler 
can then add any bridges or culverts that are required. HEC-RAS computes 
energy losses caused by structures such as bridges and culverts in three parts. 
One part consists of losses that occur in the reach immediately downstream 
from the structure where an expansion of flow takes place. The second part is 
the losses at the structure itself, which can be modeled with several different 
methods. The third part consists of losses that occur in the reach immediately 
upstream of the structure where the flow is contracting to get through the 

The bridge routines in HEC-RAS allow the modeler to analyze a bridge with 
several different methods without changing the bridge geometry. The bridge 
routines have the ability to model low flow (Class A, B, and C), low flow and 
weir flow (with adjustments for submergence), pressure flow (orifice and 
sluice gate equations), pressure and weir flow, and high flows with the energy 
equation only. The model allows for multiple bridge and/or culvert openings 
at a single location. 

The culvert hydraulics in HEC-RAS are based on the Federal Highway 
Administrations (FHWA) standard equations from the publication Hydraulic 
Design of Highway Culverts (FHWA, 1985). The culvert routines include the 
ability to model circular, box, elliptical, arch, pipe arch, and semi circular 
culverts. The HEC-RAS program has the ability to model multiple culverts at 
a single location. The culverts can have different shapes, sizes, elevations, 
and loss coefficients. The user can also specify the number of identical 
barrels for each culvert type. 

Cross Section Locations 

The bridge and culvert routines utilize four user defined cross sections in the 
computations of energy losses due to the structure. A plan view of the basic 
cross section layout is shown in Figure 6.10. 

Cross section 1 is located sufficiently downstream from the structure so that 
the flow is not affected by the structure (i.e. the flow has fully expanded). 
This distance should generally be determined by field investigation during 
high flows. If field investigation is not possible, then there are two sets of 
criteria for locating the downstream section. The USGS has established a 
criterion of locating cross section 1 a distance downstream from the bridge as 
equal to one times the bridge opening width. Traditionally the Corps of 
Engineers criterion has been to locate the downstream cross section about four 
times the average length of the side constriction caused by the structure 
abutments. In practical applications this expansion distance will vary 
depending upon the degree of constriction, the shape of the constriction, the 
magnitude of the flow, and the velocity of the flow. Both of the two criteria 
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should be used as guidance for placing cross section 1. The user should not 
allow the distance between cross section 1 and 2 to become so great that 
friction losses will not be adequately modeled. If the modeler feels that the 
expansion reach will require a long distance, then intermediate cross sections 
should be placed within the expansion reach in order to adequately model 
friction losses. 

4     3   2 1 

Figure 6.10 Cross Section Locations at a Bridge or Culvert 

Cross section 2 is located immediately downstream from the bridge (i.e. 
within a few feet). This cross section should represent the effective flow just 
outside the bridge. 

Cross section 3 should be located just upstream from the bridge. The 
distance between cross section 3 and the bridge should be relatively short. 
This distance should only reflect the length required for the abrupt 
acceleration and contraction of the flow that occurs in the immediate area of 
the opening. Cross section 3 represents the effective flow area just upstream 
of the bridge. 

Both cross sections 2 and 3 will have ineffective flow areas to either side of 
the bridge opening during low flow and pressure flow profiles. In order to 
model only the effective flow areas at these two sections, the modeler should 
use the ineffective flow area option. This option is selected from the cross 
section data editor. 
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Cross section 4 is an upstream cross section where the flow lines are 
approximately parallel and the cross section is fully effective. Because flow 
contractions can occur over a shorter distance than flow expansions, the 
distance between cross section 3 and 4 should be roughly one times the 
average width of the opening. However, this criterion for locating the 
upstream cross section may result in too short a reach length for situations 
where the width of the bridge opening is very small in comparison to the 
floodplain. An alternative criterion would be to locate the cross section a 
distance upstream equal to the average contraction width. 

During the hydraulic computations, the program automatically formulates two 
additional cross sections inside of a bridge structure. This is not necessary for 
culverts. The geometry inside of the bridge is a combination of the bounding 
cross sections (2 and 3) and the bridge geometry. The bridge geometry 
consists of the bridge deck, abutments if necessary, and any piers that may 
exist. The user can specify different bridge geometry for the upstream and 
downstream sides of the structure if necessary. Cross section 2 and the 
structure information on the downstream side are used as the geometry just 
inside the structure at the downstream end. Cross section 3 and the upstream 
structure information are used as the bridge geometry just inside the structure 
at the upstream end. 

Contraction and Expansion Losses 

Losses due to the contraction and expansion of flow between cross sections 
are determined by the standard step profile calculations. Manning's equation 
is used to calculate friction losses, and all other losses are described in terms 
of coefficient times the absolute value of the change in velocity head between 
adjacent cross sections. When the velocity head increases in the downstream 
direction a contraction coefficient is used; and when the velocity head 
decreases in the downstream direction, an expansion coefficient is used. 

Bridge Hydraulic Computations 

Low Flow Computations. For low flow computations the program first uses 
the momentum equation to identify the class of flow.   This is accomplished 
by first calculating the momentum at critical depth inside the bridge at the 
upstream and downstream ends. The end with the higher momentum 
(therefore most constricted section) will be the controlling section in the 
bridge. The momentum at critical depth in the controlling section is then 
compared to the momentum of the flow downstream of the bridge when 
performing a subcritical profile (upstream of the bridge for a supercritical 
profile). If the momentum downstream is greater than the critical depth 
momentum inside the bridge, the class of flow is considered to be completely 
subcritical (i.e. class A low flow). If the momentum downstream is less than 
the momentum at critical deoth in the bridge, then it is assumed that the 
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constriction will cause the flow to pass through critical depth and a hydraulic 
jump will occur at some distance downstream (i.e. class B low flow). If the 
profile is completely supercritical through the bridge then this is considered 
class C low flow. Depending on the class of flow the program will do the 
following: 

Class A low flow. Class A low flow exists when the water surface through the 
bridge is completely subcritical (i.e. above critical depth). Energy losses 
through the expansion (sections 2 to 1) are calculated as friction losses and 
expansion losses. Friction losses are based on a weighted friction slope times 
a weighted reach length between sections 1 and 2. The average friction slope 
is based on one of the four available alternatives in HEC-RAS, with the 
average-conveyance method being the default. This option is user selectable. 
The average length used in the calculation is based on a discharge-weighted 
reach length. 

There are four methods available for computing losses through the bridge 
(sections 2 to 3): 

- Energy equation (standard step method) 

- Momentum balance 

- Yarnell equation 

- USGS Contracted Opening method 

The user can select any or all of these methods in the computations. If more 
than one method is selected, the user must choose either a single method as 
the final solution or tell the program to use the method that computes the 
greatest energy loss through the bridge as the answer at section 3. This allows 
the modeler to compare the answers from several techniques all in a single 
execution of the program. Minimal results are available for all the methods 
computed, but detailed results are available for the method that is selected as 
the final answer. 

Energy losses through the contraction (sections 3 to 4) are calculated as 
friction losses and contraction losses. Friction and contraction losses between 
sections 3 and 4 are calculated the same as friction and expansion losses 
between sections 1 and 2. 

Class B low flow. Class B low flow can exist for either subcritical or 
supercritical profiles. For either profile, class B flow occurs when the profile 
passes through critical depth in the bridge constriction. For a subcritical 
profile, the momentum equation is used to compute an upstream water surface 
above critical depth and a downstream water surface below critical depth, 
using a momentum balance through the bridge. For a supercritical profile, 
the bridge is acting as a control and is causing the upstream water surface 
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elevation to be above critical depth. Momentum is used again to calculate an 
upstream water surface above critical depth and a downstream water surface 
below critical depth. The program will proceed with forewater calculations 
downstream from the bridge. JiA 

Class C low flow.  Class C low flow exists when the water surface through the 
bridge is completely supercritical. The program can use either the energy 
equation or the momentum equation to compute the water surface through the 
bridge. 

Pressure Flow Computations. Pressure flow occurs when the flow comes 
into contact with the low chord of the bridge. Once the flow comes into 
contact with the upstream side of the bridge, a backwater occurs and orifice 
flow is established. The program will handle two cases of orifice flow: the 
first is when only the upstream side of the bridge is in contact with the water; 
and the second is when the bridge constriction is flowing completely full. For 
the first case, a sluice gate type of equation is used, as described in 
"Hydraulics of Bridged Waterways" (FHWA, 1978). In the second case, the 
standard full flowing orifice equation is used. The program will begin 
checking for the possibility of pressure flow when the energy grade line goes 
above the maximum low chord elevation. Once pressure flow is computed, 
the pressure flow answer is compared to the low flow answer and the higher 
of the two is used. The user has the option to tell the program to use the water 
surface, instead of energy, to trigger the pressure flow calculation. 

Weir Flow Computations. Flow over the bridge and the roadway 
approaching the bridge will be calculated using the standard weir equation. 
For high tailwater elevations the program will automatically reduce the 
amount of weir flow to account for submergence on the weir. This is 
accomplished by reducing the weir coefficient based on the amount of 
submergence. When the weir becomes highly submerged, the program will 
automatically switch to calculating losses based on the energy equation 
(standard step backwater). The criteria for when the program switches to 
energy based calculations is user controllable. 

Combination Flow. Sometimes combinations of low flow or pressure flow 
occur with weir flow. In these cases an iterative procedure is used to 
determine the amount of each type of flow. 
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Entering and Editing Bridge Data 

To enter bridge data the user presses the Bridge/Culvert button on the 
geometric data window (Figure 6.1). Once the bridge/culvert button is 
pressed, the Bridge/Culvert Data Editor will appear as shown in Figure 6.11. 
To add a bridge to the model the user must do the following: 

1. Select the reach that you would like to place the bridge in. This is 
accomplished by pressing the down arrow on the reach box, and then 

selecting the reach of choice. 

2. Go to the Options menu and select Add a Bridge and/or Culvert 
from the list. An input box will appear prompting you to enter a river 
station identifier for the new bridge. 

3. Enter all of the required data for the new bridge. This may include: 
- Bridge Deck 
- Abutments 
- Piers 
- Bridge modeling approach information 

4. Enter any desired optional information. Optional bridge information 
is found under the Options menu at the top of the window. 

5. Press the Apply Data button for the interface to accept the data. 

The required information for a bridge consists of: the reach and river station 
where the bridge is located; a short description of the bridge; the bridge deck; 
bridge abutments (if they exist); bridge piers (if the bridge has piers); and 
specifying the bridge modeling approach. A description of this information 

follows: 

Reach and River Station. The Reach box allows the user to select a reach 
from the available reaches that are defined in the schematic diagram. The 
reach label defines which reach the bridge will be located in. The River 
Station tag defines where the bridge will be located within the specified 
reach. The river station tag does not have to be the actual river station of the 
bridge, but it must be a numeric value. The river station tag for the bridge 
should be numerically between the two cross sections that bound the bridge. 
Once the user selects Add a Bridge and/or Culvert from the options menu, 
an input box will appear prompting you to enter a river station tag for the 
new bridge. After the river station tag is entered, the two cross sections that 
bound the bridge will be displayed on the editor. 
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Figure 6.11 Bridge/Culvert Data Editor. 

Description. The description box is used to describe the bridge location in 
more detail than just the reach and river station. This box has a limit of 256 
characters. Only the first line of information is displayed, unless the button to 
the right of the box is pressed. Also, the first 40 characters of the description 
are used as a label for bridge plots and tables. 

Bridge Deck/Roadway. The bridge deck editor is used to describe the area 
that will be blocked out due to the bridge deck, road embankment and vertical 
abutments. To enter bridge deck information the user presses the Deck button 
on the Bridge/Culvert Data Editor. Once the deck button is pressed, the Deck 
Editor will appear as in Figure 6.12 (except yours will be blank). The 
information entered in the deck editor consists of the following: 

Distance - The distance field is used to enter the distance between the 
upstream side of the bridge deck and the cross section immediately upstream 
of the bridge. 

Width - The width field is used to enter the width of the bridge deck/roadway. 
The distance between the bridge deck and the downstream bounding cross 
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section will equal the main channel reach length minus the sum of the bridge 
"width" and the "distance" between the bridge and the upstream section. 

Weir Coefficient - Coefficient that will be used for weir flow over the bridge 
deck in the standard weir equation. 

Skew Angle - Angle that the bridge deck is skewed from a line perpendicular 
to the flow lines passing through the bridge. 

Deck/Roadway Data Editor 
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Figure 6.12 Bridge Deck/Roadway Data Editor 

Upstream Stationing, High Cord, and Low Cord - This table is used to define 
the geometry of the bridge deck on the upstream side of the bridge. The 
information is entered from left to right in cross section stationing. The deck 
is the area between the high and low chord elevation information. The 
stationing of the deck does not have to equal the stations in the bounding cross 
section, but it must be based on the same origin. The Del Row and Ins Row 
buttons allow the user to delete and insert rows. 

Downstream Stationing, High Cord, and Low Chord - This portion of the 
table is used to define the geometry of the bridge deck on the downstream side 
of the bridge. If the geometry of the downstream side is the same as the 
upstream side, then the user only needs to press the Copy Up to Down button. 
When this button is pressed, all of the upstream bridge deck information is 
copied to the downstream side. If the bridge deck information on the 
downstream side is different than the upstream side, then the user must enter 
the information into the table. 
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Max Allowable Submergence - The maximum allowable submergence ratio 
that can occur during weir flow calculations over the bridge deck. If this ratio 
is exceeded, the program switches to energy based calculations rather than 
pressure and weir flow. 

Submergence Criteria - When submergence occurs there are two choices 
available to figure out how much the weir coefficient should be reduced due 
to the submergence. The first method is based on work that was done on a 
trapezoidal shaped broad crested weir (FHWA, 1978). The second criterion 
was developed for an Ogee spillway shape (COE,1965). The user should pick 
the criterion that best matches their problem. 

Min Weir Flow El - This field is used to set the minimum elevation of the 
weir, and therefore the elevation at which weir flow begins. If this field is left 
blank, the elevation that triggers weir flow is based on the lowest high chord 
elevation on the upstream side of the bridge deck. If the user enters a value in 
the field, the value set will be used to determine when weir flow calculations 
begin. All weir flow calculations are still based on the actual geometry of the 
deck. Also, weir flow is based on the elevation of the energy grade line and 
not the water surface. 

Once all of the bridge deck information is entered, the user should press the 
OK button at the bottom of the window. Pressing the OK button tells the 
interface to accept the data and close the window. Once the deck editor 
closes, the graphic of the bridge deck will appear on the Bridge/Culvert Data 
window. An example of this is shown in Figure 6.13. Note! The data are 
not saved to the hard disk at this point. Geometric data can only be saved 
to the hard disk from the File menu of the Geometric Data window. 

Bridge Abutments. The bridge abutments are used to supplement the bridge 
deck information. Whenever bridge abutments are protruding towards the 
main channel (sloping inward abutments), it will be necessary to block out 
additional area that cannot be accounted for in the bridge deck. In this case 
the user has the ability to add abutments into the data set. To add abutments 
the user presses the Abutment button on the Bridge/Culvert Data editor. 
Once this button is pressed the Abutment data editor will appear as in Figure 
6.14. 

Abutments are entered in a similar manner to the bridge deck. When the 
editor is open, it has already established an abutment # of 1. Generally a left 
and right abutment are entered for each bridge opening. Abutment data are 
entered from the abutment left station to the abutment right station. All area 
below the abutment information is filled in and considered part of the ground. 
In general it is usually only necessary to enter two points to describe each 
abutment. 
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The data for each abutment consist of a skew angle (this is optional) and the 
station and elevation information. The station and elevation information 
represents the high chord information of the abutment. The low chord 
information of the abutment is assumed to be below the ground, and it is 
therefore not necessary- to enter it. The geometric information for each 
abutment can vary from upstream to downstream. If this information is the 
same, then the user only needs to enter the upstream geometry and then press 
the Copy Up to Down button. 

To add additional abutments, the user can either press the ADD or the Copy 
button. To delete an abutment, press the Delete button. Once all of the 
abutment data are entered, the user should press the OK button. When the 
OK button is pressed, the abutment information is accepted and the editor is 
closed. The abutments are then added to the bridge graphic on the 
Bridge/Culvert Data editor. 

Bridge Piers. The bridge pier editor is used to describe any piers that exist 
in the bridge opening. Note! All piers must be entered through the Pier 
Editor, they should not be included as part of the ground or bridge deck. 
Several of the low flow bridge computations require that the piers be defined 
separately in order to determine that amount of area under the water surface 
that is blocked by the piers. If the piers are included with the ground or the 
bridge deck, several of the methods will not compute the correct amount of 
energy loss. 

To enter pier information, the user presses the Pier button on the 
Bridge/Culvert Data editor. Once the pier button is pressed, the pier data 
editor will appear as in Figure 6.15 (except yours will not have any data in it 
yet) 

When the pier data editor appears it will have already defined the first pier as 
pier # 1. The user is required to enter a centerline station for both the 
upstream and downstream side of the pier. The skew angle is entered in 
degrees that the pier is skewed from a line parallel to the flow. The skew 
angle is an optional item. The pier geometry is entered as pier widths and 
elevations. The elevations must start at the lowest value and go to the highest 
value. Generally the elevations should start below the ground level. Any 
pier area below the ground will be clipped off automatically. Pier widths that 
change at a single elevation are handled by entering two widths at the same 
elevation. The order of the widths in the table is very important. Keep in 
mind that the pier is defined from the ground up to the deck. If the pier 
geometry on the downstream side is the same as the upstream side, simply 
press the Copy Up to Down button after the upstream side data are entered. 
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Figure 6.15 Pier Data Editor 

Additional piers can be added by pressing either the Add or the Copy button. 
If the piers are the same shape, it is easier to use the copy button and simply 
change the centerline stations of the new pier. To delete a pier, simply press 
the Delete button and the currently displayed pier will be deleted. Once all 
of the pier data are entered, press the OK button. When the OK button is 
pressed, the data will be accepted and the pier editor will be closed. The 
graphic of the bridge will then be updated to include the piers. An example 
bridge with piers is shown in Figure 6.16. This graphic is only the upstream 
side of the bridge with a zoomed in view. 
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Bridge Modeling Approach. The Bridge Modeling Approach editor is used 
to define how the bridge will be modeled and to enter any coefficients that are 
necessary. To bring up the Bridge Modeling Approach editor press the 
Bridge Modeling Approach button on the Bridge/Culvert Data editor. Once 
this button is pressed, the editor will appear as shown in Figure 6.17 (except 
yours will only have the default methods selected). 
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mffieu 

Figure 6.17 Bridge Modeling Approach Editor 

When the Bridge Modeling Approach editor comes up it will be ready to 
enter data for the first bridge opening (coefficient set # 1). If there is more 
than one bridge opening at the current location, the user can either use a 
single set of modeling approaches and coefficients, or establish a different set 
for each bridge opening. 

Establishing a bridge modeling approach consists of defining which methods 
the program will use for class A low flow computations and high flow (flow 
at or above the maximum low chord) computations. The user can instruct the 
program to use any or all of the low flow methods during the computations 
bv clicking the buttons under the Compute column. If either the Momentum 
or Yarnell method are selected, the user must enter a value for the coefficient 
that corresponds to that method. Only one of the methods can be selected as 
the answer to "Use" in order to continue the computations upstream. An 
alternative to selecting a single method to use is to instruct the program to 
use the answer with the highest computed upstream energy elevation. This is 
accomplished by pressing the button under the "Use" column that 
corresponds to the Highest Energy Answer text field. 

For high flows, the modeler can choose between Energy based calculations or 
pressure and weir flow calculations. If pressure and weir flow is the selected 
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high flow method, the user must enter coefficients for the pressure flow 
equations. The first coefficient applies to the equation that is used when only 
the upstream side (inlet) of the bridge is submerged.  If this coefficient is left 
blank, the program selects a coefficient based on the amount of submergence. 
If the user enters a coefficient, then that value is used for all degrees of 
submergence. The second coefficient applies to the equation that is used 
when both the upstream and downstream end of the bridge is submerged. 
Generally this coefficient is around 0.8. For more information on pressure 
flow coefficients see Hydraulics of Bridge Waterways (FHWA, 1978). 

Max Low Chord - This field is used to set the maximum elevation of the deck 
low chord, and therefore the elevation at which pressure flow begins to be 
calculated. If this field is left blank, then the elevation that triggers pressure 
flow calculations is based on the highest low chord elevation on the upstream 
side of the bridge deck.  If the user enters a value in this field, then the value 
set will be used to trigger when pressure flow calculations begin. Pressure 
flow is triggered when the energy elevation exceeds the maximum low chord. 
When pressure flow is calculated, the answer is compared to the low flow 
answer and the higher of the two is selected. Alternatively, the user can tell 
the program to use the w:ater surface instead of the energy elevation to trigger 
pressure flow calculations. 

Once all of the bridge modeling approach information is entered, the user 
should press the OK button. When the OK button is pressed the information 
will be accepted and the editor will close. Remember! The data are not 
saved to disk at this point, it is only accepted as being valid. To save the 
geometric data, use the File menu from the Geometric Data Editor window. 

Culvert Hydraulic Computations 

The culvert hydraulic computations in HEC-RAS are similar to the bridge 
hydraulic computations, except the Federal Highway Administration's 
(FHWA) standard equations for culvert hydraulics under inlet control are 
used to compute the losses through the structure. Because of the similarities 
between culverts and other types of bridges, the cross section layout, the use 
of ineffective areas, the selection of contraction and expansion coefficients, 
and many other aspects of bridge analysis apply to culverts as well. 

The culvert routines in HEC-RAS have the ability to model six different 
types of culvert shapes. These shapes include box (rectangular), circular, 
elliptical, arch, pipe arch, and semi circular culverts. The culvert routines are 
limited to subcritical and mixed flow regime water surface profiles. If you 
are running a supercritical only profile, when the model encounters a culvert, 
critical depth is calculated inside the culvert and used as the water surface. 
The computations then continue downstream starting with a critical depth 
boundarv condition at the downstream side of the culvert. 
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The analysis of flow in culverts is complicated. It is common to use the 
concepts of "Inlet" control and "Outlet" control to simplify the analysis. Inlet 
control flow occurs when the flow carrying capacity of the culvert entrance is 
less than the flow capacity of the culvert barrel. Outlet control flow occurs 
when the culvert carrying capacity is limited by downstream conditions or by 
the flow capacity of the culvert barrel. The HEC-RAS culvert routines 
compute the headwater required to produce a given flow rate through the 
culvert for inlet control conditions and for outlet control conditions. The 
higher headwater "controls", and an upstream water surface is computed to 
correspond to that energy elevation. 

Inlet Control Computations. For inlet control, the required headwater is 
computed by assuming that the culvert inlet acts as an orifice or a weir. 
Therefore, the inlet control capacity depends primarily on the geometry of the 
culvert entrance. Extensive laboratory tests by the National Bureau of 
Standards, and the Bureau of Public Roads (now, FHWA), and other entities 
resulted in a series of equations which describe the inlet control headwater 
under various conditions. These equations are used by HEC-RAS in 
computing the headwater associated with inlet control. 

Outlet Control Computations. For outlet control flow, the required 
headwater must be computed considering several conditions within the culvert 
and the downstream tailwater. For culverts flowing full, the total energy loss 
through the culvert is computed as the sum of friction losses, entrance losses, 
and exit losses. Friction losses are based on Manning's equation. Entrance 
losses are computed as a coefficient times the velocity head in the culvert at 
the upstream end. Exit losses are computed as a coefficient times the change 
in velocity head from just inside the culvert (at the downstream end) to outside 
the culvert. 

When the culvert is not flowing full, the direct step backwater procedure is 
used to calculate the profile through the culvert up to the culvert inlet. An 
entrance loss is then computed and added to the energy inside the culvert (at 
the upstream end) to obtain the upstream energy (headwater). For more 
information on the hydraulics of culverts, the reader is referred to the HEC- 
RAS Hydraulics Reference manual. 

Entering and Editing Culvert Data 

Culvert data are entered in the same manner as bridge data. To enter culvert 
data the user presses the Bridge/Culvert button on the Geometric Data 
window (Figure 6.1). Once this button is pressed, the Bridge/Culvert Data 
Editor will appear (Figure 6.11). To add a culvert group to the model the user 
must then do the following: 

1. Select the reach that you would like to place the culvert in. This is 
accomplished by pressing the down arrow on the reach box, and then 
selecting; the reach of choice. 

6-31 



Chapter 6 Entering and Editing Geometric Data 

Go to the Options menu of the Bridge/Culvert editor and select Add a 
Bridge and/or Culvert from the li.st. An input box will appear 
prompting you to enter a river station identifier for the new culvert 
group. After entering the river station, press the OK button and the 
cross sections that bound the new culvert group will appear in the 
editor. 

Enter ail of the required data for the culvert group. This includes the 
culvert deck information and the culvert specific data. The culvert 
deck and roadway information is entered in the same manner as a 
bridge (using the deck editor). To enter culvert specific data, press the 
Culvert button on the Bridie/Culvert Data editor. 

Once all of the culvert data are entered, press the OK button in order 
for the interface to accept the information. 

Reach and River Station. The Reach box allows the user to select a reach 
from the available reaches that were put together in the schematic diagram. 
The reach label defines which reach the culvert will be located in. The River 
Station tag defines where the culvert will be located within the specified 
reach. The River Station tag does not have to be the actual river station of the 
culvert, but it must be a numeric value. The River Station tag for the culvert 
should be numerically between the two cross sections that bound the culvert. 
Once the user selects Add a Bridge and/or Culvert from the options menu, 
an input box will appear prompting you to enter a River Station tag for the 
new culvert. After the River Station tag is entered, the two cross sections that 
bound the culvert will be displayed on the editor. 

Description. The description box is used to describe the culvert location in 
more detail than just the reach and river station. This box has a limit of 256 
characters. Only the first line of information is displayed, unless the button to 
the right of the box is pressed. Also, the first 40 characters of the description 
are used as a label for culvert plots and tables. 

Culvert Deck. The culvert deck is virtually the same as the bridge 
deck/roadway information. The deck is used to describe the area blocking the 
stream and the roadway profile. The only difference in the deck information 
for culverts is that the low chord elevations should be left blank or set to 
elevations below the ground data. This will cause the deck to completely fill 
the channel up to the roadway elevations (high chord data). Therefore, the 
only opening below the roadway will be whatever culvert openings are 
entered. 

To enter the culvert deck information, press the Deck button on the 
Bridge/Culvert Data Editor window. For an explanation of the deck 
information, please review the section entitled Bridge Deck found earlier in 
this chapter. 
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Culvert Data. To enter culvert specific information, press the Culvert button 
on the Bridge/Culvert Data Editor window. When this button is pressed, the 
Culvert Data Editor will appear as shown in Figure 6.18 (except yours will be 
blank). The information entered in the Culvert Data Editor consists of the 
following: 

Culvert Data Editor 
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Figure 6.18 Culvert Data Editor 

Culvert ID# - The culvert identifier (ID#) is automatically assigned to 
"Culvert #1" the first time you open the editor. The user can enter more than 
one culvert type if they are working on a multiple culvert opening problem. 
If all of the culvert barrels are exactly the same, then only one culvert type 
(Culvert ID#) should be entered. The number of barrels is an input parameter 
in the culvert data. If the user has culverts that are different in shape, size, 
elevation, or loss coefficients, then additional culverts types (Culvert ID#'s) 
must be added for each culvert type. To add an additional culvert type you 
can either use the Add or Copy buttons. The Add button increments the 
culvert ID# and clears the culvert editor. The Copy button increments the 
culvert ID# and makes a copy of the original culvert data. Once a copy is 
made of a culvert, the user can change any of the existing culvert information. 
Culverts can be deleted by pressing the Delete button. 

Shape - The shape selection box allows the user to select from one of the six 
available shapes. This is accomplished by pressing the down arrow on the 
side of the box, and then selecting one of the six available shapes. 
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Rise - The rise field describes the maximum height inside of the culvert. 

Span - The span field is used to define the maximum width inside of the 
culvert. The span is left blank for circular culverts. 

Chart #. - This field is used to select the Federal Highway Administration 
Chart number that corresponds to the type and shape of culvert being 
modeled. Once the user has selected a culvert shape, the corresponding 
FHWA chart numbers will show up in the chart # selection box. More 
information on FHWA chart numbers can be found in the Hydraulics 
Reference manual. 

Scale. - This field is used to select the Federal Highway Administration Scale 
number that corresponds to the type of culvert entrance. Once the user has 
selected a culvert shape and chart #, the corresponding FHWA scale numbers 
will show up in the scale selection box. More information on FHWA scale 
numbers can be found in the Hydraulics Reference manual. 

Length - The length field describes the length of the culvert along the 
centerline of the barrel. 

n-value - The n-value field is used for entering the Manning's n value of the 
culvert barrel. 

Entrance Loss Coefficient - The coefficient entered in this field will be 
multiplied by the velocity head inside the culvert at the upstream end. This 
value represents the amount of energy loss that occurs as flow enters the 
culvert. 

Exit Loss Coefficient - The coefficient entered in this field will be multiplied 
by the change in velocity head from inside the culvert to outside the culvert at 
the downstream end. This value represents the energy loss that occurs as 
water exits the culvert. 

Number of Identical Barrels in Culvert - This field is used to enter the number 
of identical barrels. The number of identical barrels is limited 25. However, 
if more than one barrel is entered, the user must provide different centerline 
stationing information for each barrel. 

Upstream Invert Elevation and Centerline Station - These two fields are used 
to describe where the culvert is located in reference to the cross section on the 
upstream side. 

Downstream Invert Elevation and Centerline Station - These two fields are 
used to describe where the culvert is located in reference to the cross section 
on the downstream side. 
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Once all of the culvert information is entered, the user should press the OK 
button at the bottom of the window. Pressing the OK button tells the interface 
to accept the data and close the window. Once the culvert editor is closed, the 
graphic of the culvert will appear on the Bridge/Culvert Data editor window. 
An example culvert with two identical barrels is shown in Figure 6.19. Note! 
The data are not saved to the hard disk at this point. Geometric data can 
only be saved from the File menu on the Geometric Data window. 
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Figure 6.19 Bridge/Culvert Data Editor with example culvert 

Bridge and Culvert Options 

Some additional options that are available, but not required, are found under 
the Options menu from the Bridge/Culvert Data Editor. These include the 
following: 

Add a Bridge and/or Culvert. This option initiates the process of adding a 
bridge or culvert to the data set. The user is prompted to enter a river station 
tag for the new bridge or culvert. The river station tag locates the bridge or 
culvert within the selected reach. Once the river station is entered, the 
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Bridge/Culvert Data editor is cleared and the user can begin entering the data 
for that new bridge or culvert. 

Delete Bridge and/or Culvert. This option will delete the currently 
displayed bridge or culvert. The user is prompted with a message stating 
specifically which bridge or culvert is going to be deleted, and requesting 
them to press the OK button or the Cancel button. 

Ineffective Flow Areas. This option allows the user to establish ineffective 
flow areas at the cross sections just upstream and downstream of the bridge. 
Ineffective flow areas defined in the bridge/culvert data editor are exactly the 
same as in the cross section data editor. They are only provided here for 
convenience. For more information on ineffective flow areas, go to the 
ineffective flow area section under cross section options. 

Momentum Equation. This option allows the user to change the components 
of the momentum equation. The momentum equation is one of the optional 
low flow methods in the bridge routines. The default momentum equation 
includes terms in the equation to account for friction losses and the weight of 
water component. The user can turn either or both of these components off 
from this option. 

Momentum Class B Defaults. If the program computes that the flow must 
pass through critical depth inside the bridge (Class B flow), critical depth will 
automatically be located inside the bridge at the upstream end. This option 
allows the user to control where the program sets critical depth for class B 
flow. If the user feels that it would be better to set critical depth inside the 
bridge at the downstream end, then this can be selected. 

Pressure Flow Criteria. This option allows the user to select either the 
energy grade line or the water surface, to be used as the criterion for when the 
program begins checking for the possibility of pressure flow. By default the 
program uses the energy grade line. 

Bridge and Culvert View Features 

Several options are available for viewing the bridge/culvert geometric data. 
These options include: Zoom In; Zoom Out; Display Upstream XS; Display 
Downstream XS; Display Both; Highlight Weir, Opening Lid and Ground; 
Highlight Piers; and Grid. These options are available from the View menu 
on the bridge/culvert data editor. 

Zoom In: This option allows the user to zoom in on a piece of the bridge or 
culvert. This is accomplished by selecting Zoom In from the View menu, 
then specifying the area to zoom in on with the mouse. Defining the zoom 
area is accomplished by placing the mouse pointer in the upper left corner of 
the desired area. Then press down on the left mouse button and drag the 
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mouse to define a box containing the desired zoom area. Finally, release the 
left mouse button and the viewing area will display the zoomed in area of the 
bridge or culvert. 

Zoom Out: This option re-displays the bridge or culvert back into its original 
size before you zoomed in. Zooming out is accomplished by selecting Zoom 
Out from the View menu bar on the bridge/culvert data editor. 

Display Upstream XS. When this option is selected, only the upstream side 
of the bridge or culvert will be displayed. 

Display Downstream XS. When this option is selected, only the downstream 
side of the bridge or culvert will be displayed. 

Display Both. When this option is selected, both the downstream and 
upstream sides of the bridge will be displayed in the viewing area. 

Highlight Weir, Opening Lid and Ground. When this option is selected, 
various portions of the bridge/culvert graphic will be highlighted. This allows 
the user to see exactly what the program is going to use as the weir, the 
opening lid (the top of the bridge opening), and the opening ground (bottom 
of the bridge opening). This option is very useful for detecting any data entry 
errors that may otherwise go unnoticed. 

Highlight Piers. When this option is turned on the interface will highlight 
what it thinks is the extent of the pier information. This option allows the user 
to see exactly what the program thinks are piers and to see how the pier 
information has been clipped. Piers are clipped below the ground and above 
the low chord of the bridge. 

Grid. This option allows the user to have a grid overlaid on top of the bridge 

or culvert graphic. 

Multiple Bridge and/or Culvert Openings 

HEC-RAS has the ability to model multiple bridge and/or culvert openings at 
any individual river crossing. Types of openings can consist of badges, 
culvert groups (a group of culverts is considered to be a single opening), and 
conveyance areas (an area where water will flow as open channel flow, other 
than a bridge or culvert opening). Up to seven openings can be modeled at a 
given location, and any combination of bridges and culvert groups can be 
used. Conveyance type openings can range from zero to a maximum of two. 

An example multiple opening is shown in Figure 6.20. As shown in this 
example, there are three types of openings: a conveyance area (left side, 
labeled as opening #1), a bridge (labeled as opening #2), and a culvert group 
(labeled as opening #3). During low flow conditions, flow will be limited to 
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the bridge opening. As flow increases, the culverts will begin to take some of 
the flow away from the bridge opening. The conveyance area was defined as 
ineffective flow (no conveyance) until the water surface goes above the top of 
the bridge. This was accomplished by setting blocked ineffective flow areas. 
In this example, three blocked ineffective flow areas were established: one to 
the left of the bridge (which encompasses the whole conveyance area), one 
between the bridge and the culvert group, and one to the right of the culvert 
group. 
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Figure 6.20 Example Multiple Opening River Crossing 

Entering Multiple Opening Data 

Multiple opening data are entered in the same manner as any other bridge or 
culvert crossing. In general, the user should perform the following steps to 
enter multiple opening data: 
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1. Press the Bridge\Culvert button on the Geometric Data window. 

2. Select the reach in which you would like to place the multiple opening 
river crossing. This is accomplished from the Reach box near the top 
of the window. 

3. Enter the river station at which you want to place the multiple opening 
crossing. Once you have done this, the two cross sections that bound 
this river station will appear in the window. These two cross sections, 
along with the bridge and culvert information, will be used to 
formulate the two cross sections inside the multiple opening river 

4. Enter the deck and road embankment data by using the Deck editor. 

5. Enter any piers or abutments that are required. 

6. Select the Bridge Modeling Approach button and enter a set of 
coefficients and modeling approaches for each bridge opening. 

7. Enter Culvert data for any culvert openings. 

8. Select the Multiple Opening Analysis button on the bridge and 
culvert editor. Enter the types of openings and their station limits. 
Start at the left most station of the crossing and work your way to the 
right end. This is explained in greater detail under the section entitled 
"Defining the Openings". 

Deck/Road Embankment Data. There can only be one deck and road 
embankment entered for any bridge and\or culvert crossing. The deck editor 
is used to describe the area that will be blocked out due to the bridge deck and 
road embankment. As shown by the grey shaded area in Figure 6.20, the deck 
and roadway data are used to block out area around the bridge as well as 
around the culverts. In the area of the bridge, high and low chord information 
is entered in order to define the top of road as well as the bridge opening. In 
the area of the culverts, the high chord information is entered to define the rest 
of the top of the road embankment. However, the low chord information can 
be left blank, or set to elevations below the ground, because the culvert data 
define the culvert openings. 

Piers and abutments. All piers are entered from the pier editor, which was 
described previously under bridge data. The number of bridge openings has 
no impact on how pier data are entered. Piers are treated as separate 
information. Once the user establishes that there is more than one bridge 
opening, the program is smart enough to figure out which piers go with which 
opening. If any abutment data are required for a bridge opening, it can be 
entered as described previously under the bridge data section. 
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Bridge Modeling Approach. A bridge modeling approach and coefficient 
set must be established for at least one bridge opening.  If there is more than 
one bridge opening, and the user has only established a single coefficient set 
and bridge modeling approach, those data will be used for all of the bridge 
openings. The user can establish a different set of coefficients and modeling 
approaches for each bridge opening. 
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Figure 6,21 Bridge Modeling Approach Editor 

As shown in Figure 6.21, the user must enter information under the Bridge 
Modeling Approach editor for at least one bridge Opening. Bridge openings 
are referred to as Bridge # 1, Bridge # 2, etc., up to the number of bridge 
openings. Bridge # 1 represents the left most bridge opening while looking 
in the downstream direction. Bridge # 2 represents the next bridge opening 
to the right of Bridge # 1, and so on. The user can enter additional 
coefficient sets and modeling approaches by selecting either the add or copy 
button. If either of these buttons is selected, the Bridge number will 
automatically be incremented by one. The user can then enter or change any 
of the information on the editor for the second bridge opening. Any bridge 
opening that does not have a corresponding coefficient set and modeling 
approach, will automatically default to what is set for Bridge # 1. 
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Culvert Data. Culvert information is added in the same manner as described 
in the previous section called "Entering and Editing Culvert Data."  Culverts 
will automatically be grouped based on their stationing. 

Defining The Openings 

Once all of the bridge and\or culvert data are entered for a multiple opening 
river crossing, the last step is to define the number and type of openings that 
are being modeled. This is accomplished by pressing the Multiple Opening 
Analysis button on the BridgeVCulvert Data editor. Once this button is 
pressed, an editor will appear as shown in Figure 6.22 (except yours will be 
blank the first time you bring it up). 
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Figure 6.22 Multiple Opening Analysis window 

The user selects from the three available opening types: Conveyance; Culvert 
Group; and Bridge. Openings must be established in order from left to right, 
while looking in the downstream direction. In addition to establishing the 
number and types of openings, the user must also enter a Station Left and a 
Station Right for each opening. These stations are used to establish limits for 
each opening as well as stagnation points. Stagnation points are the locations 
at which flow separates (on the upstream side) from one opening to the next 
adjacent opening. Stagnation points can either be set to fixed locations or they 
can be allowed to migrate within limits. 

As shown in Figure 6.22 (numerical representation) and Figure 6.20 
(graphical representation), there are three openings established in this 
example. The first opening is defined as a conveyance area, and it ranges 
from station 98 (the left most station of the section) to station 260. That 
means that any water in this area will be treated as normal open channel flow, 
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and the water surface through this area will be solved by performing standard 
step calculations with the energy equation. The second opening is the bridge 
opening. This opening has a left station of 260 and a right station of 750. 
This bridge will be modeled by using the cross section data, bridge deck, and 
pier information that lie within these two stations (260 and 750). The bridge 
coefficients and modeling approach for this opening will be based on the data 
entered for bridge opening #1, since it is the first bridge opening. The third 
opening is a culvert group. This opening has a left station of 700 and a right 
station of 940. Any culverts that lie within these stations will be considered as 
being in the same culvert group. 

Notice that the right station of the bridge opening overlaps with the left station 
of the culvert group. This is done on purpose. By overlapping these stations, 
the user is allowing the program to calculate the location of the stagnation 
point between these two openings. This allows the stagnation point to vary 
from one profile to the next. In the current version of the HEC-RAS software, 
stagnation points are allowed to migrate between any bridge and culvert group 
openings. However, stagnation points must be set to a fixed location for any 
conveyance opening type. A more detailed explanation of stagnation points, 
and how the program uses them, can be found in the HEC-RAS Hydraulics 
Reference manual, under the section on Multiple Openings. 

Once the user has entered all of the information into the Multiple Opening 
Analysis window, simply press the OK button to accept the data. 

Multiple Opening Calculations 

Multiple opening calculations are computationally intensive. An iterative 
solution approach is used, by which the amount of flow through each opening 
is adjusted until the computed upstream energies of each opening are balanced 
within a predefined tolerance. The general approach of the solution scheme is 
as follows: 

1. The program makes a first guess at the upstream water surface by 
setting it to the computed energy of the cross section just downstream 
of the bridge. 

2. The program sets an initial flow distribution. This is accomplished by 
first calculating the amount of active flow area in each opening, based 
on the water surface from step one. The program then apportions the 
flow by using an area weighting (i.e. if an opening has 40 percent of 
the active flow area, then it will receive 40 percent of the flow). 

Once a flow distribution is established, the program then calculates the 
water surface and energy profiles for each opening, using the 
estimated flow. 
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4. Once the program has computed the upstream energy for each 
opening, a comparison is made between the energies to see if a 
balance has been achieved (i.e., all energies are within the predefined 
tolerance). If the energies are not within the set tolerance, the program 
re-distributes the flow based on the computed energies. 

5. The program continues this process until either the computed energies 
are within the tolerance or the number of iterations reaches a pre- 
defined maximum. The energy balance tolerance is set as 3 times the 
user entered water surface calculation tolerance (The default is 0.03 
feet or 0.009 meters). The maximum number of iterations for multiple 
opening analysis is set to 1.5 times the user entered maximum number 
of iterations from the normal water surface calculations (the default is 
30 for multiple openings). 

A more detailed discussion of how the program performs the multiple opening 
analysis can be found in the HEC-RAS Hydraulic Reference manual. 
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Cross Seel jrpoSstJon 

Occasionally it is necessary to supplement surveyed cross section data by 
interpolating cross sections in between two surveyed sections.  Interpolated 
cross sections are often required when the change in velocity head is to large 
to accurately determine the energy gradient. An adequate depiction of the 
change in energy gradient is necessary to accurately model friction losses as 
well as contraction and expansion losses. 

Cross section interpolation can be accomplished in three ways from within 
the HEC-RAS interface. The first method is to simply copy one of the 
bounding cross sections and then adjust the station and elevation data. The 
cross section editor allows the user to raise or lower elevations and to shrink 
or expand various portions of any cross section. 

The second and third options allow for automatic interpolation of cross 
section data. From the Geometric Data editor, automatic interpolation 
options are found under the Options menu bar as shown in Figure 6.23. 
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Figure 6.23 Automatic Cross Section Interpolation Options 
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The first cross section interpolation option, Within a Reach, allows for 
automatic interpolation over a specified range of cross sections within a 
single reach. When this option is selected, a window will pop up as shown in 
Figure 6.24. The user must enter a starting River Station and an ending River 
Station for which interpolation will be performed. The user must also 
provide the maximum allowable distance between cross sections. If the main 
channel distance between two sections is greater than the user defined 
maximum allowable, then the program will interpolate cross sections 
between these two sections. The program will interpolate as many cross 
sections as necessary in order to get the distance between cross sections 
below the maximum allowable. 
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Figure 6.24 Automatic Cross Section Interpolating Within a Reach 

Once the user has selected the cross section range and entered the maximum 
allowable distance, cross section interpolation is performed by pressing the 
Interpolate XS's button. When the program has finished interpolating the 
cross sections, the user can close the window by pressing the Close button. 
Once this window is closed, the interpolated cross sections will show up on 
the river schematic as light green tic marks. The lighter color is used to 
distinguish interpolated cross sections from user entered data. Interpolated 
cross sections can be plotted and edited like any other cross section. The 
only difference between interpolated sections and user defined sections is 
that interpolated sections will have an asterics (*) attached to the end of their 
river station identifier. This asterics will show up on all input and output 
forms, enabling the user to easily recognize which cross sections are 
interpolated and which are user defined. 

The second type of automatic cross section interpolation, Between 2 XS's, 
allows the user to have much greater control over how the interpolation is 
performed. When this option is selected, a Cross Section Interpolation 
window will appear as shown in Figure 6.25. 
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Figure 6.25 Detailed Cross Section Interpolation Window 

This cross section interpolation window displays only two cross sections at a 
time. The user can get to any reach or cross section from the Reach and River 
Station boxes at the top of the window. Interpolated cross section geometry is 
based on a string model as graphically depicted in Figure 6.25. The string 
model consists of chords that connect the coordinates of the upstream and 
downstream cross sections. The cords are classified as master and minor 
cords. As shown in Figure 6.25, five master cords are automatically attached 
between the two cross sections. These master cords are attached at the ends of 
the cross sections, the main channel bank stations, and the main channel 
inverts. Minor cords are generated automatically by the interpolation routines. 
A minor cord is generated by taking an existing coordinate in either the 
upstream or downstream section and establishing a corresponding coordinate 
at the opposite cross section by either matching an existing coordinate or 
interpolating one. The station value at the opposite cross section is 
determined by computing the decimal percent that the known coordinate 
represents of the distance between master cords and then applying that 
percentage to the opposite cross section master cords. The number of minor 
cords will be equal to the sum of all the coordinates of the upstream and 
downstream sections minus the number of master cords. Interpolation at any 
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point in between the two sections is then based on linear interpolation of the 
elevations at the ends of the master and minor cords. Interpolated cross 
sections will have station and elevation points equal to the number of major 
and minor cords. 

This interpolation scheme is used in both of the automated interpolation 
options ("Within a Reach" and "Between 2 XS's"). The difference is that the 
Between 2 XS's option allows the user to define additional master cords. This 
can provide for a better interpolation, especially when the default of five 
major cords produces an inadequate interpolation. An example of an 
inadequate interpolation when using the default cords is shown in Figure 6.26. 
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Figure 6.26 Cross Section Interpolation Based on Default Master Cords 

As shown in Figure 6.26, the interpolation was adequate for the main channel 
and the left overbank area. The interpolation in the right overbank area failed 
to connect two geometric features that could be representing a levee or some 
other type of high ground. If it is known that these two areas of high ground 
should be connected, then the interpolation between these two sections should 
be deleted, and additional master cords can be added to connect the two 
features. To delete the interpolated sections, press the Del Interp button. 
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Master cords are added by pressing the Master Cord button that is located to 
the right of the Maximum Distance field above the graphic. Once this button 
is pressed, any number of master cords can be drawn in. Master cords are 
drawn by placing the mouse pointer over the desired location on the top cross 
section. Then while holding the left mouse button down, drag the mouse 
pointer to the desired location of the lower cross section. When the left mouse 
button is released, a cord is automatically attached to the closest point near the 
pointer. An example of how to connect master cords is shown in Figure 6.27. 
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Figure 6.27 Adding Additional Master Cords for Interpolation 

User defined master cords can also be deleted. To delete user defined master 
cords, press the scissors button to the right of the master cords button. When 
this button is pressed, simply move the mouse pointer over a user defined cord 
and click the left mouse button to delete the cord. 

Once you have drawn in all the master cords that you feel are required, and 
entered the maximum distance desired between sections, press the interpolate 
button. When the interpolation has finished, the interpolated cross sections 
will automatically be drawn onto the graphic for visual inspection. An 
example of this is shown in Figure 6.28. 
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Figure 6.28 Final Interpolation With Additional Master Cords 

As shown in Figure 6.28, the interpolation with the addition of user defined 
master cords is very reasonable. 

In general, the best approach for cross section interpolation is to first 
interpolate sections using the "Within a Reach" method. This provides for 
fast interpolation at all locations within a reach. The "Within a Reach" 
method uses the five default master cords, and is usually very reasonable for 
most cross sections. Once this is accomplished, all of the interpolated sections 
should be viewed to ensure that a reasonable interpolation was accomplished 
in between each of the cross sections. This can be done from the "Between 2 
XS's" window. Whenever the user finds interpolated cross sections that are 
not adequate, they should be deleted. A new set of interpolated sections can 
then be developed by adding additional master cords in order to improve the 
interpolation. 

CAUTION: Automatic geometric cross section interpolation should not be 
used as a replacement for required cross section data. If water surface profile 
information is required at a specific location, surveyed cross section data 
should be provided at that location. It is very easy to use the automatic cross 
section interpolation to generate cross sections. But if these cross sections are 
not an adequate depiction of the actual geometry, you may be introducing 
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error into the calculation of the water surface profile.  Whenever possible, use 
topographic maps to assist you in evaluating whether or not the interpolated 
cross sections are adequate. Also, once the cross sections are interpolated, 
they can be modified just like any other cross section. 

If the geometry between two surveyed cross sections does not change linearly, 
then the interpolated cross sections will not adequately depict what is in the 
field. When this occurs, the modeler should either get additional surveyed 
cross sections, or adjust the interpolated sections to better depict the 
information from the topographic map. 

Viewing and Editing Data Through Tables 

Once cross section data are entered, the user can view and edit certain types of 
data in a tabular format. The current version of HEC-RAS allows the user to 
view and edit Manning's n values, cross section reach lengths, and the 
contract and expansion coefficients in tabular form. This option is available 
from the Geometric Data editor. 

Manning's n values 

It is often desirable to view and edit the Manning's n values for several cross 
sections all at the same time. From the Geometric Data editor, the user can 
select Manning's n values from the Tables menu item. Once this option is 
selected, a window will appear as shown in Figure 6.29. 

Manning' n Data View and Editing Table 
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As shown in Figure 6.29, the user has the options to add a constant to one or 
more n values, multiply a group of n values by a factor, or change a group of n 
values to a specific value. 

To add a constant to a group of n values, the user must first highlight the n 
values that they would like to change. Highlighting is accomplished by 
placing the mouse in the upper left cell of the desired cells to highlight, then 
press the left mouse button and drag the cursor to the lower left corner of the 
desired cells to highlight. When the left mouse button is released, the cells 
that are selected will be highlighted (except the first cell). Once the user has 
highlighted the desired cells to be modified, press the Add Constant button. 
This will bring up a popup window, which will allow the user to enter a 
constant value that will be added to all cells that are highlighted. 

To multiple a group of n values by a factor, the user first highlights the desired 
cells. Once the cells are highlighted, pressing the Multiply by a Factor 
button will bring up a popup window. This window allows the user to enter a 
value that will be multiplied by each of the highlighted cells. 

To set a group of n values to the same number, the user must first highlight the 
n values that they would like to change. Once the cells are highlighted, 
pressing the Set Values button will bring up a popup window. This window 
will allow the user to enter a specific n value which will replace all of the 
highlighted n values. 

The user can also go directly into the table and change any individual n value. 

Reach Lengths 

The user has the ability to view and edit cross section reach lengths in a 
tabular format. This is accomplished by selecting Reach Lengths from the 
Tables menu of the Geometric Data editor. Once this option is selected, a 
window will appear as shown in Figure 6.30. The user has the same editing 
features as described previously for the n values table. See the discussion 
under Manning's n values, in the previous section, for details on how to edit 
the data. 

Contraction and Expansion Coefficients 

The user has the ability to view and edit contraction and expansion 
coefficients in a tabular format. This is accomplished by selecting 
Coefficients from the Tables menu of the Geometric Data editor. Once this 
option is selected, a window will appear as shown in Figure 6.31. The user 
has the same editing features as described previously for the n values table. 
See the discussion under Manning's n values, in the previous section, for 
details on how to edit the data. 
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Figure 6.30 Reach Lengths View and Editing Table 
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Figure 6.31 Contraction and Expansion Coefficients Table 
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Saving the Geometric Data 

To save the geometric data, use the Save Geometry Data As option from the 
File menu of the Geometric Data window. When this option is selected, the 
user is prompted to enter a title for the geometric data. Once you have entered 
the title, press the OK button and the data will be saved to the hard disk. If 
the geometric data have been saved before (and therefore a title has already 
been entered), then it is only necessary to select the Save Geometry Data 
option. When this option is selected, the geometry data are saved with the 
previously defined title. 

In general, it is a good idea to periodically save your data as you are entering 
them. This will prevent the loss of large amounts of information in the event 
of a power failure, or if a program error occurs in the HEC-RAS user 
interface. 
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CHAPTER   7 

Performing a Steady Flow Analysis 

This chapter discusses how to calculate steady flow water surface profiles. 
The chapter is divided into two parts. The first part discusses how to enter 
steady flow data and boundary conditions. The second part discusses how to 
develop a plan and perform the calculations. 

Contents 

■ Entering and Editing Steady Flow Data 

■ Performing Steady Flow Calculations 

Entering and Editing Steady Flow Data 

Once all of the geometric data are entered, the modeler can then enter any 
steady flow data that are required. To bring up the steady flow data editor, 
select Steady Flow Data from the Edit menu on the HEC-RAS main 
window. The steady flow data editor should appear as shown in Figure 7.1 

Steady Flow Data 

The user is required to enter the following information: the number of 
profiles to be calculated; the peak flow data (at least one flow for every river 
reach and every profile); and any required boundary conditions. The user 
should enter the number of profiles first. The next step is to enter the flow 
data. Flow data are entered directly into the table. Use the mouse pointer to 
select the box in which to enter the flow, then type in the desired flow value. 

Flow data are entered from upstream to downstream for each reach. At least 
one flow value must be entered for each reach in the river system. Once a 
flow value is entered at the upstream end of a reach, it is assumed that the 
flow remains constant until another flow value is encountered within the 
reach. The flow data can be changed at any cross section within a reach. To 
add a flow change location to the table, first select the reach in which you 
would like to change the flow (from the reach box above the table). Next, 
select the River Station location for which you want to enter a flow change. 
Then press the Add Flow Change Location button. The new flow change 
location will appear in the table. 
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Figure 7.1  Steadv Flow Data Editor 

Boundary Conditions 

After all of the flow data have been entered into the table, the next step is to 
enter any boundary conditions that may be required. To enter boundary 
conditions data, press the Boundary Conditions button at the top right of the 
steady flow data editor. The boundary conditions editor should appear as 
shown in Fisure 7.2. 

Boundary conditions are necessary to establish the starting water surface at 
the ends of the river system (upstream and downstream). A starting water 
surface is necessary in order for the program to begin the calculations.  In a 
subcritical flow regime, boundary conditions are only necessary at the 
downstream ends of the river system. If a supercritical flow regime is going 
to be calculated, boundary conditions are only necessary at the upstream ends 
of the river system.  If a mixed flow regime calculation is going to be made, 
then boundary conditions must be entered at all ends of the river svstem. 
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Figure 7.2 Steady Flow Boundary Conditions Editor 

The boundary conditions editor contains a table listing every reach. Each 
reach has an upstream and a downstream boundary condition. Connections to 
junctions are considered internal boundary conditions. Internal boundary 
conditions are automatically listed in the table, based on how the river system 
was defined in the geometric data editor. The user is only required to enter 
the necessary external boundary conditions. 

To enter a boundary condition, first use the mouse pointer to select the cell 
location in which you would like to enter a boundary condition. Then select 
the type of boundary condition from the four available types listed above the 
table. The four types of boundary conditions consist of: 

Known Water Surface Elevations - For this boundary condition the user 
must enter a known water surface for each of the profiles to be computed. 

Critical Depth - When this type of boundary condition is selected, the user is 
not required to enter any further information. The program will calculate 
critical depth for each of the profiles and use that as the boundary condition. 

Normal Depth - For this type of boundary condition, the user is required to 
enter an energy slope that will be used in calculating normal depth (Manning's 
equation) at that location. A normal depth will be calculated for each profile 
based on the user entered slope. 

Rating Curve - When this type of boundary condition is selected, a popup 
window appears allowing the user to enter an elevation versus flow rating 
curve. For each profile, the elevation is interpolated from the rating curve 
given the flow. 
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An additional feature of the boundary condition data, is that the user can 
specify a different type of boundary condition for each profile at the same 
location. This is accomplished by first pressing the button that says Toggle 
between single/multiple boundary condition types per reach. When this 
button is pressed, the table will expand out to provide a row for each profile, 
at every location. The user can then select the location and profile for which 
they would like to change the boundary condition type. 

Once all the boundary conditions data are entered, press the OK button to 
return to the steady flow data editor. Press the Apply Data button to have the 
data accepted. 

Steady Flow Data Options 

Several options are available from the steady flow data editor to assist users in 
entering the data. These features can be found under the Options menu at the 
top of the window. The following options are available: • 

Undo Editing. This option allows the user to retrieve the data back to the 
form that it was in the last time the Apply Data button was pressed. Each time 
the Apply Data button is pressed, the Undo Editing feature is reset to the 
current information. 

Delete Row From Table. This option allows the user to delete a row from 
the flow data table. To use this option, first select the row to be deleted with 
the mouse pointer. Then select Delete Row From Grid from the options 
menu. The row will be deleted and all rows below it will move up one. 

Ratio Selected Flows. This option allows the user to multiply selected values 
in the table by a factor. Using the mouse pointer, hold down the left mouse 
button and highlight the cells that you would like to change by a factor. Next, 
select Ratio Selected Flows from the options menu. A popup window will 
appear allowing you to enter a factor to multiply the flows by. Once you press 
the OK button, the highlighted cells will be updated with the new values. 

Specify Change in Energy. This option allows the user to force a specific 
change in energy between any to cross sections in the model. The change in 
energy can be set for a specific profile in a multiple profile model. As shown 
in Figure 7.3, the user first selects a the river reach. Then the from river 
station (from RS) and to river station (to RS) within the reach for which the 
energy loss will be applied. Next, the user selects the profile number and 
enters the change in energy. The final step is to press the "set" button to add 
the change in energy to the table. The user can set several changes in energy 
within the model, for various profiles. During the computations, the program 
will use the specifyed change in energy between two section, and then 
compute a water surface for that energy at the upstream section. 
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Figure 7.3 Setting a Change in Energy Between Two Cross Sections 

Specify Change in WS. This option allows the user to force a specific 
change in the water surface elevation between two cross sections. This option 
works exactly the same as the "Specify Change in Energy" option described 
previously. The user can specify changes in water surface elevations at 
multiple locations for various profiles. 

Inset Known WS. This option allows the user to force a specific water 
surface at a given cross section. The known water surface elevations can be 
specified at multiple locations for various profiles. During the computations, 
the program will not compute a water surface elevation for any cross section 
where a known water surface elevation has been entered. The program will 
use the known water surface elevation and then move to the next section. 

Additional EG Losses. This option allows the user to enter an additional 
energy loss between two cross sections. This energy loss gets added to any 
computed energy losses that occur during the balancing of the energy 
equation. The additional energy loss can be specified at multiple locations for 
various profiles. 

Saving The Steady Flow Data 

The last step in developing the steady flow data is to save the information to a 
file. To save the data, select the Save Flow Data As from the File menu on 
the steady flow data editor. A popup window will appear prompting you to 
enter a title for the data. 
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Performing Steat \ih >ns 

Once all of the geometry and steady flow data have been entered, the user 
can begin calculating the steady flow water surface profiles. To perform the 
simulations, go to the HEC-RAS main window and select Steady Flow 
Analysis from the Simulate menu. The Steady Flow Analysis window 
should appear as in Figure 7.4. 
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Figure 7.4 Steady Flow Analysis window 

Defining A Plan 

The first step in performing a simulation is to put together a Plan. The Plan 
defines which geometry and flow data are to be used, as well as provide a 
description and short identifier for the run. Also included in the plan 
information are the selected flow regime and the simulation options. 

To establish a Plan, select New Plan from the File menu on the steady flow- 
analysis window.  When New Plan is selected, a window will appear 
prompting you to enter a title for the plan. After you enter the title, press the 
OK button to close the window and accept the title. The user can also enter a 
short identifier for the plan. This identifier is optional. To enter the short 
identifier, simply click the left mouse button on the identifier box and enter 
the name. The short identifier is limited to 12 characters. 

Once the title and short identifier are established, the next step is specify 
geometry and flow data to be used in the plan. To select a geometry or flow 
file, press the down arrow button next to the desired data type.  When this 
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button is pressed, a list will appear displaying all of the available files ofthat 
type that are currently available for the project. Select the geometry and flow 
files that you want to use for the current plan. 

The last step is to select the desired flow regime for which the model will 
perform calculations. The user can select between subcritical, supercritical, 
or mixed flow regime calculations. 

Saving The Plan Information 

To save the Plan information, select Save Plan from the File menu of the 
simulation window. 

Simulation Options 

The following is a list of the available simulation options under the Options 
menu of the steady flow simulations window: 

Encroachments. This option allows the user to perform a floodway 
encroachment analysis. For a detailed description of how to use the 
floodway encroachment capabilities of HEC-RAS, see Chapter 9 of the 
User's Manual (this manual). For a description of how the encroachment 
calculations are performed for the various encroachment methods, see 
Chapter 8 of the Hydraulic Reference Manual. 

Flow Distribution Locations. This option allows the user to specify 
locations in which they would like the program to calculate flow distribution 
output. The flow distribution option allows the user to subdivide the left 
overbank, main channel, and right overbank, for the purpose of computing 
additional hydraulic information. 

The flow distribution output can be obtained by first defining the locations 
that the user would like to have this type of output. As shown in Figure 7.5, 
the user can either select specific locations or all locations in the model. 
Next, the number of slices for the flow distribution computations must be 
defined for the left overbank, main channel, and the right overbank. The user 
can define up to 45 total slices. Each flow element (left overbank, main 
channel, and right overbank) must have at least one slice. The user can 
change the number of slices used at each of the cross sections. The flow 
distribution output will be calculated for all profiles in the plan during the 
computations. 
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Figure 7.5 Window for Specifying the Locations of Flow Distribution. 

During the normal profile computations, at each cross section where flow 
distribution is requested, the program will calculate the percentage of flow, 
area, wetted perimeter, conveyance, and average velocity for each of the user 
defined slices.   For details on how the flow distribution output is actually 
calculated, see Chapter 4 of the HEC-RAS Hydraulic Reference Manual. For 
information on viewing the flow distribution output, see Chapter 8 of the 
User's Manual (this manual). 

Set Output Options. This option allows the user to request some additional 
output that is not normally computed.  Currently there is only one choice 
available, which is to have the program calculate critical depth at all 
locations. 

Conveyance Calculations. This option allows the user to tell the program 
how to calculate conveyance in the overbanks. Two options are available. 
The first option. At breaks in n values only, instructs the program to sum 
wetted perimeter and area between breaks in n values, and then to calculate 
conveyance at these locations. If n varies in the overbank the conveyance 
values are then summed to get the total overbank conveyance. The second 
option. Between every coordinate point (HEC2 style), calculates wetted 
perimeter, area, and conveyance between every coordinate point in the 
overbanks. The conveyance values are then summed to get the total left 
overbank and right overbank conveyance. These two methods can provide 
different answers for conveyance, and therefore different computed water 
surfaces. The At breaks in n values only method is the default. 
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Friction Slope Methods. This option allows the user to select one of four 
available friction slope equations, or to allow the program to select the 
method based on the flow regime and profile type. The four equations are: 

- Average Conveyance (Default) 
- Average Friction Slope 
- Geometric Mean Friction Slope 
- Harmonic Mean Friction Slope 

Set Calculation Tolerances. This option allows the user to override the 
default settings for the calculation tolerances. These tolerances are used in 
the solution of the energy equation. Warning !!! - Increasing the default 
calculation tolerances could result in computational errors in the water 
surface profile. The tolerances are as follows: 

Water surface calculation tolerance: This tolerance is used to compare 
against the difference between the computed and assumed water surface 
elevations. When the difference is less than the tolerance, the program 
assumes that it has a valid numerical solution. 

Critical depth calculation tolerance: This tolerance is used during the 
critical depth solution algorithm. 

Maximum number of iterations: This variable defines the maximum number 
of guesses that the program will make when attempting to balance a water 
surface. 

Maximum difference tolerance: This tolerance is used during the balance of 
the energy equation. As the program attempts to balance the energy 
equation, the solution with the minimum error (assumed minus computed 
water surface) is saved. If the program goes to the maximum number of 
iterations without meeting the specified calculation tolerance, the minimum 
error solution is checked against the maximum difference tolerance. If the 
solution at minimum error is less than this value, then the program uses the 
minimum error solution as the answer, issues a warning statement, and then 
proceeds with the calculations. If the solution at minimum error is greater 
than the maximum difference tolerance, then the program issues a warning 
and defaults the solution to critical depth. The computations then proceed 
from there. 

Flow Tolerance Factor: This factor is only used in the bridge and culvert 
routines. The factor is used when the program is attempting to balance 
between weir flow and flow through the structure. The factor is multiplied 
by the total flow. The resultant is then used as a flow tolerance for the 
balance of weir flow and flow through the structure. 
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Each of these variables has an allowable range and a default value. The user 
is not allowed to enter a value outside of the allowable range. 

Critical Depth Computation Method. This option allows the user to select 
between two methods that can be used for calculating critical depth during 
the computations. The default method is the Parabolic Method. This 
method utilizes a parabolic searching technique to find the minimum specific 
energy. This method is very fast, but it is only capable of finding a single 
minimum on the energy curve. A second method, Multiple Critical Depth 
Search, is capable of finding up to three minimums on the energy curve.  If 
more than one minimum is found the program selects the answer with the 
lowest energy. Very often the program will find minimum energies at levee 
breaks and breaks due to ineffective flow settings. When this occurs, the 
program will not select these answers as valid critical depth solutions, unless 
there is no other answer available. The Multiple Critical Depth Search 
routine takes a lot of computation time. Since critical depth is calculated 
often, using this method will slow down the computations. This method 
should only be used when you feel the program is finding an incorrect answer 
for critical depth. 

Check Data Before Execution. This option provides for comprehensive 
data input checking. When this option is turned on, data input checking will 
be performed when the user presses the compute button. If all of the data are 
complete, then the program allows the steady flow computations to proceed. 
If the data are not complete, or some other problem is detected, the program 
will not perform the steady flow analysis, and a list of all the problems in the 
data will be displayed on the screen. If this option is turned off, data 
checking is not performed before the steady flow execution. The default is 
that the data checking is turned on. 

Set Log File Output Level. This option allows the user to set the level of 
the Log file. The Log file is a file that is created by the computational 
program. This file contains information tracing the program process. Log 
levels can range between 0 and 10, with 0 resulting in no Log output and 10 
resulting in the maximum Log output. In general, the Log file output level 
should not be set unless the user gets an error during the computations. If an 
error occurs in the computations, set the log file level to an appropriate value. 
Re-run the computations and then review the log output, try to determine 
why the program got an error. 

When the user selects Set Log File Output Level, a window will appear as 
shown in Figure 7.6. The user can set a "Global Log Level", which will be 
used for all cross sections and every profile. The user can also set log levels 
at specific locations for specific profiles.  In general, it is better to only set 
the log level at the locations where problems are occurring in the 
computations. To set the specific location log level, first select the desired 
reach and river station. Next select the log level and the profile number (the 
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log level can be turned on for all profiles).  Once you have everything set, 
press the Set button and the log level will show up in the window below. 
Log levels can be set at several locations individually. Once all of the Log 
Levels are set, press the OK button to close the window. 

y Output log: level 

Global Log Level 0- 

Log Levels for Specific Locations 

Reach     Fa!! Cr. 

Desci 

±    River Ste. 9J,': ^J Profile  _J ±. 

River 'Mile 9.8 of Fall Creek Level I Set'  . 

Fall Cr. 
Fall Cr. 

RS= 10 
RS= 9.8 

LL=  A 
LL=  6 

PF =  1 
PF=  3 

OIC Cancel Clear Ali 

jSet specific log level for selected location 

Figure 7.6 Log File Output Level window 

Warning !!! - setting the log output level to 4 or 5 can result in very large log 
file output.  Log level values of 6 or larger can result in extremely large log 
files. 

View Log File. This option allows the user to view the contents of the log 
file. The interface uses the Windows Write program to accomplish this. It is 
up to the user to set an appropriate font in the Write program.  If the user sets 
a font that uses proportional spacing, the information in the log file will not 
line up correctly. Some fonts that work well are: Line Printer; Courier (8 
pt.): and Helvetica (8 pt.). Consult your Windows user's manual for 
information on how to use the Write program. 

Starting the Computations 

Once all of the data have been entered, and a Plan has been defined, the 
steady flow computations can be performed by pressing the Compute button 
at the bottom of the steady flow simulation window. Once the compute 
button is pressed, a separate window will appear showing you the progress of 
the computations. The information that appears in the window is only there 
as an indicator of the programs progress during the computations. This 
window is not intended to be used for viewing any output.  When the 
computations have been completed, the user can close the computations 
window by double clicking the upper left corner of the window. If the 
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computations ended with a message stating "PROGRAM TERMINATED 
NORMALLY", the user can then begin to review the output. 
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CHAPTER   8 

Viewing Results 

After the model has finished the steady flow profile computations, you can 
begin to view the output. Output is available in a graphical and tabular 
format. The current version of the program allows the user to view cross 
sections, profiles, rating curves, X-Y-Z perspective plots, detailed tabular 
output at a single cross section, and limited tabular output at many cross 
sections. Users also have the ability to develop their own output tables. 

Contents 

■ Cross Sections, Profiles, and Rating Curves 

■ X-Y-Z Perspective Plots 

■ Tabular Output 

■ View Results from the River System Schematic 

■ Viewing Flow Distribution Output 

Cross Sections, Profiles, and Rating Curves 

Graphical displays are often the most effective method of presenting input 
data and computed results. Graphics allow the user to easily spot errors in 
the input data, as well as providing an overview of the results in a way that 
tables of numbers cannot. 

Viewing Graphics on the Screen 

To view a graphic on the screen, select either Cross Sections, Profiles, or 
Rating Curves from the View menu on the HEC-RAS main window. Once 
you have selected one of these options, a window will appear with the 
graphic plotted in the viewing area. An example cross section plot is shown 
in Figure 8.1. The user can plot any cross section by simply selecting the 
appropriate reach and river station from the list boxes at the top of the plot. 
The user can also step through the cross section plots by using the up and 
down arrow buttons next to the river station box. 
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Figure 8.1 Example Cross Section Plot 

An example profile plot is shown in Figure 8.2. The profile plot displays the 
water surface profile for the first reach in the river system. If there is more 
than one reach, additional reaches can be selected from the Options menu on 
the plot. 

An example rating curve plot is shown in Figure 8.3. The rating curve is a 
plot of the water surface elevation versus flow rate for the profiles that were 
computed. A rating curve can be plotted at any location by selecting the 
appropriate reach and river station from the list boxes at the top of the plot. 
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Graphical Plot Options 

Several plotting features are available from the Options menu on all of the 
graphical plots. These options include: zoom in; zoom out; selecting which 
plans, profiles, reaches and variables to plot; and control over labels, lines, 
symbols, scaling, and grid options. In general, the options are about the same 
on all of the graphics. 

Zoom In: This option allows the user to zoom in on a portion of the graphic. 
This is accomplished by selecting Zoom In from the Options menu, then 
specifying the area to zoom in on with the mouse. Defining the zoom area is 
accomplished by placing the mouse pointer at a corner of the desired zoom 
area. Then press down on the left mouse button and drag the mouse to define 
a box containing the desired zoom area. Finally, release the left mouse button 
and the viewing area will display the zoomed-in area of the graphic. 

Zoom Out: This option re-displays the graphic back into its original size 
before you zoomed in. Zooming out is accomplished by selecting Zoom Out 
from the Options menu. 

Plans. This option allows the user to select from the available Plans for 
plotting. The default plan is the currently opened plan. The user can select 
additional plans to view for comparison of results graphically. 

Profiles. This option allows the user to select which profiles they would like 
to have displayed on the graphic. This option does not apply to the rating 
curve, it automatically plots all of the profiles. 

Reaches. This option allows the user to select which river reaches they would 
like to have displayed. This option only applies to the profile plot. 

Variables. This option allows the user to select what ever variables are 
available for plotting. The number and type of variables depends on what 
type of graphic is being displayed. 

Labels. This option allows the user to change the labels on the plot. This 
includes the plot caption, the X axis title, and the Y axis title. 

Legend. This option allows the user to change the labels of the legend. 

Lines and Symbols. This option allows the user to change the line types, line 
colors, line widths, symbol types, symbol colors, symbol sizes, fill patterns, 
and the line labels. 

Scaling. This option allows the user to define the scaling used for the plot. 
Users are allowed to set the minimum, maximum, and labeling increment for 
the X and Y axis. Scaling can be set temporarily, or scaling can be set to be 
persistent (scaling stays constant for all cross sections). Persistent scaling is 
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only available for the cross section and rating curve plots. 

Grid. This option allows the user to overlay a grid on top of the graphic. 
Users have the option to have both major and minor tics displayed. 

Plotting Velocity Distribution Output 

The user has the option of plotting velocity distribution output from the cross 
section viewer. Velocity distributions can only be plotted at locations in 
which the user specified that flow distribution output be calculated during the 
computations. To view the velocity distribution plot, first bring up a cross 
section plot (select "Cross Sections" from the view menu of the main HEC- 
RAS window). Next, select the cross section in which you would like to see 
the velicty distribution output. Select Velocity Distribution form the 
Options menu of the cross section window. This will bring up a popup 
window (Figure 8.4) that will allow you to set the minimum velocity, 
maximum; velocity, and velocity increment for plotting. In general, it is better 
to let the program use the maximum velocity range for plotting. Next, the user 
selects Plot Velocity Distribution. Then press the "OK" button and the 
velocity distribution plot will appear as shown in Figure 8.5. 

For detailes on how to select the locations for computing the velocity 
distribution, see Chapter 7 of the User's Manual. For information on how the 
velocity distribution is actually calculated, see Chapter 4 of the Hydraulic 
Reference Manual. 
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Figure 8.4 Velocity Distribution Options. 
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Figure 8.5 Velocity Distribution Plot 

Plotting Other Variables in Profile 

The profile plotting window has the ability to plot other variables, besides 
water surface and energy, in profile. Any variable that is computed at a cross 
section can be displayed in profile. An example would be to plot velocity 
versus distance. To plot other variables in profile, the user must first select 
the General Profile option from the Options menu of the Profile plot. Once 
this option is turned on, the plot automatically switches to a plot of channel 
velocity versus distance. Other variables can be selected from the Variables 
option under the Options menu. The user can plot several different variable 
types at one time ( e.g. velocity and area versus distance), but the scaling 
may not be appropriate when this is done. An example of plotting other 
variables in orofile is shown in Figure 8.6. 
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Figure 8.6 General Profile Plot of Variables Versus Distance 

Plotting One Variable Versus Another 

The rating curve plotting window has the ability to plot other variables 
besides discharge versus water surface elevation. Any variable that is 
computed at a cross section can be dispayed against onther computed 
variable (or variables). An example of this capability is shown in Figure 8.7. 
In this example, Discharge (x-axis) is being plotted against total flow area 
and main channel flow area (y-axis). 

To plot other variables, the user selects the X Axis Variable and Y Axis 
Variable from the Options menu ofthe rating curve plotting window. When 
selecting variables to plot, keep in mind that all variables selected for a 
particular axis should have a similar range in magnitude. 
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Figure 8.7 Example of Plotting One Variable Against Other Variables 

Sending Graphics to the Printer or Plotter 

All of the graphical plots in HEC-RAS can be sent directly to a printer or 
plotter. The printer or plotter used depends on what you currently have set as 
the default printer or plotter in the Windows Print Manager. To send a 
graphic to the printer or plotter, do the following: 

1. Display the graphic of interest (cross section, profile, rating curve, or 
river system schematic) onto the screen. 

2. Using the available graphics options (scaling, labels, grid, etc.), 
modify the plot to be exactly what you would like printed. 

3. Select Print Current (or just Print on the from the profile plot) from 
the File menu of the displayed graphic. When this option is selected, 
a popup window will appear allowing you to modify the default print 
options. Change any desired options and press the Print button. The 
graphic will be sent to the Windows Print Manager. The print 
manager will then send the plot to the default printer or plotter. 
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Note: The user can print multiple cross sections at one time by using the 
Print Multiple option from the File Menu of the cross section and rating 
curve plots. This option also allows the user to establish how many cross 
sections or rating curves they would like to have printed on each page. 

Sending Graphics to the Windows Clipboard 

All of the HEC-RAS graphics can be sent to the Windows Clipboard. 
Passing a graphic to the clipboard allows that graphic to then be pasted into 
another piece of software (i.e., a word processor). To pass a graphic to the 
windows clipboard, and then to another program, do the following to- 

1. Display the graphic of interest on the screen. 

2. Using the options, modify the plot to be exactly what you want. 

3. Select Copy to Clipboard from the File menu of the displayed 
graphic. The plot will automatically be sent to the Windows 
Clipboard. 

4. Bring up the program that you want to pass the graphic into. Select 
Paste from the Edit menu of the receiving program. Once the 
graphic is pasted in, it can be re-sized to the desired dimensions. 

HEC-RAS sends and displays all graphics in a Window's Meta file format. 
Since Meta files are vector based graphics, the graphic can be resized without 
causing the image to distort. 
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Figure 8.8 Example X-Y-Z Perspective Plot 

The user has the ability to select the reach to be plotted, the range of the river 
stations, and which plans and profiles to be displayed. The plot can be rotated 
left and right, as well as up and down, in order to get different perspectives of 
the river system. The user can choose to overlay the water surface or not. 
The water surface can be displayed in an outline format, a shaded but 
transparent format, or a solid filled format. The graphic can be sent to the 
printer/plotter or the clipboard just like any other plot.  Sending the graphic to 
the printer or clipboard is accomplished by pressing the printer or clipboard 
button, located on the lower left hand side of the plot. The data in the plot can 
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ibu!ar Oo.ni 

also be aligned in several different ways, including: the left edge of the cross 
section (default); the left bank station of the main channel; the channel inverts; 
the right main channel bank station; and the right edge of the cross section 
data. This is accomplished by using the data alignment buttons above the 
printer and clipboard buttons. 

Summary tables of the detailed water surface profile computations are often 
necessary to analyze and document simulation results. Tabular output allows 
the user to display large amounts of detailed information in a concise format. 
HEC-RAS has two basic types of tabular output, cross section tables and 
profile tables. 

W" i 'oss Section Tables 

Cross section tables show detailed hydraulic information at a single location, 
for a single profile. To display a cross section table on the screen, select 
Cross Section Table from the View menu of the main HEC-RAS window. 
An example cross section table is shown in Figure 8.9. 
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i< sou re e 8.9 Example Cross Section Table 
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Any cross section can be displayed in the table by selecting the appropriate 
reach and river station from the list boxes at the top of the table.  Also, any of 
the computed profiles can be displayed by selecting the desired profile from 
the profile list box. 

Users can also view detailed hydraulic information for other types of cross 
section specific tables. Other table types are selected from the Type menu on 
the cross section table window. The following types are available in addition 
to the normal cross section table (which is the default): 

Culvert. The culvert table type brings up detailed culvert information. This 
table can be selected for normal culverts, or for culverts that are part of a 
multiple opening river crossing. An example culvert specific table is shown 
in Figure 8.10. 

.-■Culvert Output- 
File    Type     Options 

iReäch-:j1':' 

ICuly-Nml.Depth "(ft) 
jOulv Crt Depth (ft) - 

RjverSta_ 2J5'.. - ± -* i Profile 
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|if|fjfjfljf||||; 

Figure 8.10 Example Culvert Type of Cross Section Table 

Bridge. The bridge table type brings up detailed output for the cross sections 
inside the bridge as well as just upstream of the bridge. The bridge table type 
can selected for normal bridge crossings, or for bridges that are part of a 
multiple opening river crossing.  An example of the bridge specific cross 
section table is shown in Fisure 8.1 1. 
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Bridge Output 
File    Type    Options 

Reach Easy Creek? River Sta. 3.5  ,:'.",'       ■:.■ A % 1« Pruilie 

Opening Hmiqe #1 * 
mmasmmBmttWBnm SUBC-KSIäKKRaSHTKa 

HEC-RAS   Plan: pressure   Reach: Easy Creek   RivSta:3.5   Profile: 1 Opening: 

E.G. US. (ft) 525.41 

525.09 

8000.00 

8000 00 

Element • Inside BR US       Inside BR DS. 

W.S. US. (ft) E.G. Elev (ft) 525.40 

525.06 

525.37 

Q Total (cfs) W.S. Elev (ft) 525.03 

Q Bridge (cfs) Grit W.S. (ft) 517.49 517.49 

Q Weir (cfs) Max Chi Dplh (ft) 15.06 

4.66 
15.44! 

15.03 

Weir Sta Lft (ft) Vel Total (ft/s) 4.68 

Weir Sta Rgt (ft) FlowArea(sqft) 17 1710.78 

Weir Submerg: Froude # Chi 0.24 0.24 

Weir Max Depth Specif Force 11908.15 11856.62 

MinTopRd(ft)U 531.00 Hydr Depth (ft) 11.75 11.72 

Errors. Warnings and Notes 

% ■ : ■ H ■■' ~0> i' :f' '^'M'M '• - SiMIS ^SI§$S0i^:§MM&^ *   * 

Figure 8.11 Example Bridge Type of Cross Section Table 

Conveyance. The conveyance type of table is the same as a normal cross 
section table. The only difference is that a conveyance type of table is used 
for view the hydraulic results of a portion of a multiple opening river 
crossing. That is, if the user has defined an open channel flow type of 
opening (i.e. conveyance area), at a multiple opening crossing, then this table 
can be used to view the hydraulic results for that specific opening. 

Flow Distribution. The Flow Distribution table type can be used to view the 
computed flow distribution output at any cross section where this type of 
output was requested. An example of the flow distribution table output is 
shown in Figure 8.12. 
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File    Type     Opt! ons 

JD pmfii i_.          

Reach  |i 4- River Sta. m I 8 [T~~|*] 
lillSllillltfl ■     I ! 

Left Sta Right Sta %Q            Area W.P-     |    Conv.    | Hydr D. Velocity t'      J 
|       (ft) (ft) 1    (sqft) (ft)       j     (cfs)      | (ft) (ft/s) : i 
I   217.80 435.60 1.67        121.17        186.34         1351.4 

7.57        320.05        218.23        6138.6 
16.74        514.70        217.84      135S7.6 

12.95        441.26        217.86      10496.2 

0.80           11.34             5.80           658.9 

3.19          26.88            6.30        2627.2 

7.64          43.45            5.63        6303.6 

8.87          45.69            5.10        7316.4 

8.72          45.24            5.11         7195.0 

0.65 

1.47 

2.36 

2.03 

2.22 

5.27 

8.52 

8.96 

8.87 

1.07 
-—-■-" 

1   435.80    !   653.40 1.85! 

2.541 

2.29J 
5.49 

3.24 

13.72; 

15.15! 

15.04UT 

|   653.40 871.20 

j   871.20 1039.00 

!  1089.00 1094.10 

I  1094.10 1099.20 

! 1099.20 1104.30 

I  1104.30 1103.40 

! 1109.40 1114.50 

WBsSx0§§l0S$IXM§M$ «*1J!     *                      •     Jl Mil* v*\l«'ll' '^Alä l! : 

JWarning - Divided flow computed for this cross-section. 
jWarning -The energy loss was greater than 1.0 ft (0.3 m). between the current and 
I                  previous cross section. This may indicate the need for additions! cross 4. 
 ._.          :  „:.: ; „„ .. ™^™.„:....^„_ ^  

■                                       : 

  

Figure 8.12 Example of the Flow Distribution Type of Table 

At the bottom of each of the cross section tables are two text boxes for 
displaying messages. The bottom text box is used to display the definition of 
the variables listed in the table. When the user presses the left mouse button 
over any data field, the description for that field is displayed in the bottom text 
box. The other text box is used to display any Errors, Warnings, and Notes 
thai; may have occurred during the computations for the displayed cross 
section. 

Gross Section Table Options 

Under the Options menu of the cross section table window, the user has the 
following options: 

Include Interpolated XS's. This option allows the user to either view 
interpolated cross section output or not. Turning the "include interpolated 
XS's" option on (which is the default), allows interpolated sections to be 
selected from the river station box. Turning this option off gets rid of all the 
interpolated sections from the river station selection box, ana only the user 
entered cross sections are displayed. 

Units System For Viewing. This option allows the user to view the output in 
either English or Metric units.  It does not matter whether the input data is in 
engiish or metric, the output can be viewed in either system. 
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Profile Tables 

Profile tables are used to show a limited number of hydraulic variables for 
several cross sections.   To display a profile table on the screen, select Profile 
Table from the View menu of the main HEC-RAS window. An example 
profile table is shown in Figure 8.13. 

H'*- Profile Output Table - Standard Table 1 ^t^llfe^^ll dil 
File Options    Std. Tables    User Tables    Help   

HEC-RAS   Ran: pressure   Reach: Easy Creek 

River Sta Q Total Min Ch El W.S. Elev CritW.S. E.G. Elev E.G. Slope | Vel Chnl ♦ 

(cfe)- (ft) («) (ft) (ft) (ft/ft)        | .it's) 

23| 6 - «PjQIIfll 510.00             525.24;                                   525.50 

510.00              530.38                                        530.53 

0.000481 

0.000190 

4. 

6 .   . - 10000.00 j.JÜI 

6    ;.. 25000.00 510.00             533.28!                                     533.88 0.000629 6.82! 

•5'.   '          '' 8000.00 510.00              525.09;             517.30             525.41 0.000553 4.50! 

5 10000.00 

25000.00 

510.00 

510.00 

530.23!             518.16             530.47 0.000260; 3.931 

>5 533.17!             522.78             533.78 0.000642_ 6.86! 

3.5 Bridge:                                                                                           
 L 

■ 2 

8000.00 

10000.00 

510.00              525.03!             517.30 

510.00             529.98!             518.15 

525.35 0.000563 4.531 

12    -      .   '.. 530.23 0.000273; 3.98! 

i—j^ 
*    •   ~                - (" >;f|| saü i^i 5^^||^ü|' ISI? ..... „i ~J 

Top width of the wetted cross section. _ 
■>-."'     i 

Figure 8.13 Example Profile Table 

There are several standard table (Std. Tables) types available to the user. 
Some of the tables are designed to provide specific information at hydraulic 
structures (e.g., bridges and culverts), while others provide generic 
information at all cross sections. The standard table types available to the 

user are: 

Standard Table 1. The is the default profile type of table. This table gives 
you a summary of some of the key output variables. 

Standard Table 2. This is the second of the standary summary tables. This 
table provides information on the distribution of flow between the left 
overbank, main channel, and right overbank. This table also shows the 
friction losses, as well as contraction and expansion losses that occured 
between each section. Energy losses displayed at a particular cross section 
are for the losses that occurred between that section and the next section 
downstream. 
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Four XS Culvert. This standard table provides summary results for the four 
cross sections around each of the culverts in the model. The four cross 
sections are the two immediately downstream and upstream of the culvert. 
This table will list all of the culverts in the model for the selected reaches. 

Culvert Only. This standard table provides hydraulic information about the 
culvert, as well as the inlet control and outlet control computations that were 
performed. 

Six XS Bridge. This table provides summary results for the six cross 
sections that make up a normal bridge transition. The six cross sections 
include the two cross sections just downstream of the bridge; the two cross 
sections inside of the bridge; and the two cross sections just upstream of the 
bridge. The program will display results for all the bridges in the model 
within the selected reaches. When viewing this table, on accassion there will 
be no displayed results for the cross sections inside of the bridge. This 
occurrs only when the user has selected a bridge modeling approach that does 
not compute results inside of the bridge. This includes: Yarnells method; the 
contracted opening method; both pressure flow equations; and pressure and 
weir flow solutions. 

Bridge Only. The bridge only table shows summary information specifically 
for bridges. 

Bridge Comparison. The bridge comparison table shows the results for all 
of the user selected bridge modeling approaches that were computed during 
the computations. For example, the program can calculate low flow bridge 
hydraulics by four different methods. The resuling upstream energy for the 
user selected methods will be displayed in this table. 

Multiple Opening. This table shows a limited number of output variables 
for each opening of a multiple opening river crossing. 

Encroachment 1, 2, and 3. These three standard tables provide various 
types of output for the computations of floodway encroachments. 

To view one of the types of tables, select the desired table type from the Std. 
Tables menu on the profile table. In addition to the various types of profile 
tables, the user can specify which plans, profiles and reaches to include in the 
table. The plans, profiles and reaches options are available from the Options 
menu on the profile plot. 

The user also has the ability to turn the viewing of interpolated cross sections 
on or off. The default is to view all cross sections, including the interpolated 
ones. To prevent the interpolated sections from showing up in the table, de- 
select Include Interpolated XS's from the Options menu. 
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Another feature available to users is the ability to set the number of decimal 
places that will be displayed for any variable of the pre-defined tables. Once a 
pre-defined table is selected from the Tables menu, select Standard Table # 
Dec Places from the Options menu. A window will appear displaying the 
current number of decimal places for each variable. The user can change the 
number of decimal places to what ever they wish. 

User's also have the ability to view profile output tables in either english or 
metric units. This is available from the Options menu on the profile tables. It 
does not matter whether the input data is in english or metric, the output can 
be viewed in either system. 

User Defined Output Tables 

A special feature of the profile tables is the ability for users to define their 
own output tables. User defined output tables are available by selecting 
Define Table from the Options menu of the profile table. When this option is 
selected, a window will appear, as shown in Figure 8.14. At the top of the 
window is a table for the user selected variable headings (Table Column 
Headings), the units, and the number of decimal places to be displayed for 
each variable. Below this table is a table containing all of the available 
variables that can be included in your user defined table. The variables are 
listed in alphabetical order. Below the list of variables is a message box that is 
used to display the definition of the selected variable. 

To add variables to the column headings, simply double click the left mouse 
button while the mouse pointer is over the desired variable. The variable will 
be placed in the active field of the table column headings. To select a specific 
column to place a variable in, click the left mouse button once while the 
mouse pointer is over the desired table column field. To delete a variable 
from the table headings, double click the left mouse button while the mouse 
pointer is over the variable that you want to delete. The number of decimal 
places for each variable can be changed by simply typing in a new value. 

User defined tables are limited to 15 variables. Once you have selected all of 
the variables that you want, press the OK button at the bottom of the window. 
The profile table will automatically be updated to display the new table. 

Once you have the table displayed in the profile table window, you can save 
the table headings for future use. To save a table heading, select Save Table 
from the Options menu on the profile table window. When this option is 
selected, a popup window will appear, prompting you to enter a name for the 
table. Once you enter the name, press the OK button at the bottom of the 
popup window. The table name will then be added to a list of tables included 
under the User Tables menu on the profile table window. To delete a table 
from the list of user defined tables, select Remove Table from the Options 
menu of the profile table window. When this option is selected, a popup 
window will appear displaying a list of all the user defined tables. Click the 
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left mouse button over the tables that you want to delete, then press the OK 
button. The selected tables will then be deleted from the User Tables menu 
list. 

Create a Table Heading 

■   '< **■*"'•*'■'      ' •"  ': .-'. »1:. ■•».lnT;. , !-\*T7T>-' W-.   .       '•* ■.-'■V; .-,•' 

Column .1 1              2 3     V     j 4 •;;    ...-. 

E Variable Q Total 

(cfs) 

2 

Min Ch El              W.S. Elev CritW.S. 
Units (ft) 

2 
(ft) (ft) 

Decimal Pts 2 2 

*!,■:!- ,u. 
Clear All Table Headings 1 

# Barrels 
Alpha 
Area 
Area Channel 
Area Left 
Area Right 
Base WS 
Beta 

Br Sei Mthd 
C& E Loss 
Center Station 
Ch Sta L 
Ch Sta R 
Civ EG No Wr 
Cntr Op EG 
Cntr Op WS 

Conv. Chnl 
Conv. Left 
Conv. Ratio 
Conv. Right 
Conv. Total 
Crit Depth 
Crit E.G. 
Crit Enrgy 1 

Crit Enrgy 2 
Crit Enrgy 3 
Crit Num 

SEE 
CritW.S. 1 
CritW.S. 2 
CritW.S. 3 
Culv Crt Depth 

Culv EG In 
Culv EG Out 
Culv Ent Lss 
Culv Ext Lss 
Culv Frctn Ls 
Culv Ful Lngh 
CulvlnvEi Dn 
CulvlnvEl Up 

Critical water surface elevation. Water surface corresponding to the minimum energy on 
the energy versus depth curve. 

OK Cancel Help 

Figure 8.14 User Defined Tables Window 

Sending Tables to the Printer 

To send a table to the printer do the following: 

1. Bring up the desired table from the tabular output (cross section or 
profde tables) section of the program. 

Select Print from the File menu of the displayed table. When this 
option is selected, a popup window will appear allowing you to 
modify the default print options. Once you have set the printer with 
the desired options, press the Print button. The table will be sent to 
the Windows Print Manager. The Windows Print Manager will 
control the printing of the table. 
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The profile type of tables allow you to print a specific portion of the table, 
rather than the entire table. If you desire to only print a portion of the table, 

do the following: 

1. Display the desired profile type table on the screen. 

2. Using the mouse, press down on the left mouse button and highlight 
the area of the table that you would like to print. To get an entire row 
or column, press down on the left mouse button while moving the 
pointer across the desired row or column headings. 

3. Select Printer from the File menu of the displayed table. Only the ^ 
highlighted portion of the table and the row and column headings will 
be sent to the Windows Print Manager. 

Sending Tables to the Windows Clipboard 

To pass a table to the Windows Clipboard, and then to another program, do 

the following: 

1. Display the desired table on the screen. 

2. Select Copy to Clipboard from the File menu of the displayed table. 

3. Bring up the program that you want to pass the table into. Select 

Paste from the Edit menu of the receiving program. 

Portions of the profile tables can be sent to the Clipboard in the same manner 
as sending them to the printer. 
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Viewing Results From the River System Schematic 

The user has the option of either bringing up graphics and tables from the 
View menu on the main HEC-RAS window (as discussed above), or from the 
river system schematic (found under geometric data). Once data have been 
entered, and a successful simulation has been made, the user can interact with 
the river system schematic. When the left mouse button is pressed over the 
river system schematic, a popup menu will appear listing options that are 
relevant to the area of the schematic that is located under the mouse pointer. 
An example of this is shown in Figure 8.15. 

Figure 8.15 Geometric Data Window With Popup Menu 

In Figure 8.15, the popup menu shown comes up whenever the user presses 
the left mouse button over a cross section. In this particular example, the 
mouse button was pressed over the cross section located at river station 0.1 of 
the Butte Cr. river reach. As shown in the menu, the user has the choice of 
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editing the cross section data; plotting the cross section; plotting the profile 
for the reach containing this cross section; viewing tabular output; or plotting 
the computed rating curve at this cross section. Other popup menus are 
available for bridges; culverts; junctions; and reach data. 
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Chapter 9 Performing a Floodway Encroachment Analysis 

Performing a Floodway Encroachment 
Analysis 

The evaluation of the impact of floodplain encroachments on water surface 
profiles can be of substantial interest to planners, land developers, and 
engineers.  It is also a significant aspect of flood insurance studies. HEC-RAS 
contains five optional methods for specifying floodplain encroachments. This 
chapter describes how to enter floodway encroachment data, how to perform 
the encroachment calculations, and viewing the floodway encroachment 

results. 

For information on the computational details of each of the five encroachment 
methods, as well as special considerations for encroachments at bridges, 
culverts, and multiple openings, see Chapter 8 of the HEC-RAS hydraulics 
reference manual. 

Contents 

■ General 

■ Entering Floodway Encroachment Data 

■ Performing the Floodway Encroachment Analysis 

■ Viewing the Floodway Encroachment Results 
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General 

The HEC-RAS floodway procedure is based on calculating a natural profile 
(existing conditions geometry) as the first profile in a multiple profile run. 
Other profiles, in a run, are calculated using various encroachment options, as 
desired. Before performing an encroachment analysis, the user should have 
developed a model of the existing river system. This model should be 
calibrated to the fullest extent that is possible. Verification that the model is 
adequately modeling the river system is an extremely important step before 
attempting to perform an encroachment analysis. 

Entering Floodway Encroachment Data 

Within HEC-RAS, the data for performing a floodway encroachment analysis 
are entered from the Steady Flow Analysis window. Encroachment 
information is not considered as permanent geometry or flow data, and is 
therefore not entered as such. The enchoachment information is saved as part 
of the existing Plan data. 

To bring up the floodway encroachment data window, select the 
Encroachments option from the Options menu of the Steady Flow Analysis 
window. When this option is selected an Encroachment window will appear 
as shown in Figure 9.1 (except yours will be blank when you first bring it up). 

As shown in Figure 9.1, There are several pieces of data that the user must 
supply for an encroachment analysis. The encroachment analysis can only be 
performed for profiles 2 through 15 (or what ever number has been set by the 
user in the flow data editor. Encroachments are not performed on profile one 
because most of the encroachment methods rely on having a base profile for 
comparison. 

The data for an encroachment analysis should be entered in the following 
manner: 

Global Information. Global information are data that will be applied at 
every cross section for every profile computed. The first piece of global 
information is the Equal Conveyance Reduction selection box at the top of 
the Encroachment data editor window. Equal conveyance reduction applies to 
encroachment methods 3, 4, and 5. When this is turned on, the program will 
attempt to encroach, such that an equal loss of conveyance is provided on both 
sides of the stream. If this option is turned off, the program will encroach by 
trying to maintain a loss in conveyance in proportion to the distribution of 
natural overbank conveyance. The default is to have equal conveyance 
reduction turned on. 
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The second item under global information, is the Left bank offset and the 
Right bank offset. The left and right offset is used to establish a buffer zone 
around the main channel for further limiting the amount of the encroachments. 
For example, if a user established a right offset of 5 feet and a left offset of 10 
feet, the model will limit all encroachments to 5 feet from the left bank station 
and 10 feet from the right bank station. The default is to have no left or right 
offset, this will allow the encroachments to go up to the main channel bank 
stations, if necessary. 

 Encroachments  

F Equal Conveyance Reduction 

Left bank offset (ft) 

Reach 

Apply Data 

0. 

m 
Right bank offsui (Itj' 

Profile '2 

0. 

Start Riv 3ta 

finding Riv Sta 

40800 

29900 

Si)t Selected Range 

Method !* 

Target WS ihcncjt* {») 

v'-iitic :• 

0.8 

Set All Reaches Import to Method 1 

River Station Method 

40B00 

Value 1 Vti\un ?. 

40150 

37200 

37000 

3G3/& 

36350 

3G200 

M 
0.8 
Of 
oi 

0.8 
...„ 

foil Cancel Clear Profile Cl'iii1 .Ml 

Figure 9.1 Floodway Encroachment Data Editor 

Reach and River Station Selection Boxes. The next piece of data for the 
user to select, is the reach in which to enter encroachment data. The user is 
limited to seeing one reach at a time on the encroachment data editor. Once a 
reach is selected, the user can then enter a Starting and Ending River 
Station to work on. By default, the program selects all the sections in the 
reach. The user can change this to any range of cross sections within the 
reach. 

Profile. Next, the user should select a profile number to work on. Profiles 
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are limited to 2 though the maximum number set in the currently opened flow 
data (e.g. 2 through 4, if the user has set 4 profiles in the flow data editor). 
The user can not set encroachments for profile 1. 

Method and Target Values. The next step is to enter the desired 
encroachment method to be used for the currently selected profile. Once a 
method is selected, the data entry boxes that corresponds to that method will 
show up below the method selection box. Some of the methods require only 
one piece of data, while others require two. The user should then enter the 
required information that corresponds to the method that they have selected. 
For example, if the user selects encroachment method 4, only one piece of 
information is required, the target change in water surface elevation. The 
available encroachment methods in HEC-RAS are: 

Method 1 -       User enters right and left encroachment station 
Method 2 -       User enters a fixed topwidth 
Method 3 -       User specifies the percent reduction in conveyance 
Method 4 -       User specifies a target water surface 
Method 5 -       User specifies target water surface and maximum 

change in energy 

Set Selected Range. Once the encroachment method is selected, and its 
corresponding data are entered, the user should press the Set Selected Range 
button. Pressing this button will fill in the table below with the selected range 
of river stations; the selected method; and the corresponding data for the 
method. Note that, if the selected method only has one data item, that 
method's data will go under the Value 1 column of the table. If the selected 
method has two data items, the first goes into the Value 1 column and the 
second goes into the Value 2 column. Once the data is put into the table, the 
user can change the method and corresponding data values directly from the 
table. 

At this point the user should repeat these tasks until all of the encroachment 
data are entered (i.e. for all the reaches and locations in the model, as well as 
all of the profiles for which the user wants to perform the encroachment 
analysis). Once all of the encroachment data are entered, the user presses the 
OK button and the data will be applied and the window will close. The user 
can return to the encroachment window and edit the data at any time. The 
encroachment data are not saved to the hard disk at this time, they are only 
saved in memory. To save the data to the hard disk, the user should either 
select Save Project from the File menu of the main HEC-RAS window, or 
select Save Plan from the File menu of the Steady Flow Analysis window. 

Some additional options on the Encroachment data entry window include: Set 
All Reaches and Import Method 1. The Set All Reaches option allows the 
user to set the selected method and corresponding data for all reaches and 
locations in the model (all cross sections, bridges, culverts, etc.). This is a 
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quick way to start a preliminary encroachment analysis without having to 
enter a lot of data. The Import Method 1 option, allows the user to transfer 
the computed encroachment stations from a previous run to the input data for 
a future run. For example, if the user performs a preliminary encroachment 
analysis using any of the methods 2 through 5, they may want to convert the 
results from one of the runs to a method 1 encroachment method. This will 
allow the user to further define the floodway, using method 1, without having 
to enter all of the encroachment stations. The import of encroachment 
stations, in this manner, is limited to the results of a single encroachment 
profile for each reach. 

Performing The Floodway Encroachment Analysis 

The HEC-RAS floodway procedure is based on calculating a natural profile 
(no encroachments) as the first profile of a multiple profile run. Subsequent 
profiles are calculated with the various encroachment options available in the 
program. 

In general, when performing a floodway analysis, encroachment methods 4 
and 5 are normally used to get a first cut at the encroachment stations. 
Recognizing that the initial floodway computations may provide changes in 
water surface elevations greater, or less, than the "target" increase, initial 
computer runs are usually made with several "target" values. The initial 
computer results should then be analyzed for increases in water surface 
elevations, changes in velocities, changes in top width, and other parameters. 
Also, plotting the results with the X-Y-Z perspective plot, or onto a topo map, 
is recommended. From these initial results, new estimates can be made and 
tested. 

After a few initial runs, the encroachment stations should become more 
defined. Because portions of several computed profiles may be used, the final 
computer runs are usually made with encroachment Method 1 defining the 
specific encroachment stations at each cross section. Additional runs are often 
made with Method 1, allowing the user to adjust encroachment stations at 
specific cross sections to further define the floodway. 

While the floodway analysis generally focuses on the change in water surface 
elevation, it is important to remember that the floodway must be consistent 
with local development plans and provide reasonable hydraulic transitions 
through the study reach. Sometimes the computed floodway solution, that 
provides computed water surfaces at or near the target maximum, may be 
unreasonable when transferred to the map of the actual study reach. If this 
occurs, the user may need to change some of the encroachment stations, based 
on the visual inspection of the topo map. The floodway computations should 
be re-run with the new encroachment stations to ensure that the target 
maximum is not exceeded. 
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iewing the Floodway Encroachment Results 

Floodwav encroachment results can be viewed in both graphical and tabular 
modes. Graphically, the encroachment results show up on the cross section 
plots as well as the X-Y-Z Perspective plot. An example cross section plot is 
shown in Figure 9.2. 

Cress Section 
File    Options    Help 

Rsach Rivar R»3. 37200 174.69.714.81- 

LU 

Example XS Plot with Encroachments 

100 200 300 

Station (ft) 

Figure 9.2 Example Cross Section Plot With Encroachments 

As shown in Figure 9.2, the encroachments are plotted as outlined blocks. In 
this example, the water surface profile for the base run (first profile) is plotted 
along with one of the encroached profiles. The user can plot as many profiles 
as they wish, but it may become a little confusing with several sets of 
encroachments plotted at they same time. 

Another type of graphic that can be used to view the encroachments is the X- 
Y-Z perspective plot, an example is shown in Figure 9.3. In this example, the 
base profile (profile 1) as well as one of the encroached profiles is plotted at 
the same time over a range of cross sections. This type of plot allows the user 
to get a reach view of the floodway encroachment. The user can quickly see if 
the encroachments transition smoothly or if they are erratic. In general, the 
final encroachments should have a consistent and smooth transition from one 
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cross section to the next. With the assistance of this type of plot, the user may 
want to further refine the final encroachment stations and re-run the model. 

Reach 

River Station    [Tj [t 

Start 

End 

40800          |i 

29900 i 

Profiles Plans 

Height/Width 

Width/Distance 

10 

«•...; ■+ 

Rotation 

Azimuth 

c] \-K\ x i3i ta 

WS Solid Riled 

r Reverse WS order 
[K Banks and Invert 

X-Y-Z Perspective Plot 

Reach' 1    RS: 40800 to 23900    PF#: 1. 2 

Select the method of displaying water surface 

Figure 9.3        Example X-Y-Z Perspective Plot with Base and 
Encroached Profiles 

Encroachment results can also be viewed in a tabular mode from the Profile 
Output Tables. Select Profile Table from the View menu of the main HEC- 
RAS window. When the table comes up, the user can select from three 
different pre-defined encroachment tables. To bring up one of the 
encroachment tables, select Encroachment 1 from the Std. Tables menu on 
the Profile table window. An example of Encroachment 1 table is shown in 
Figure 9.4. The table shows the basic encroachment results of : computed 
water surface elevation; change in water surface from the base profile; the 
computed energy; top width of the active flow area; the flow in the left 
overbank, main channel, and right overbank; the left encroachment station; the 
station of the left bank of the main channel; the station of the right bank of the 
main channel; and the right encroachment station. 
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Profile OutputTable - tcnroachment' 
Hie    Options    Std. Tables    User ! abies    Help 

| River Sta. W.S. £l8v 1 ProfDeita 1 E.G. Efev llopWdthAdj Q Left  I Q Channel ]. Q Right I'Enc-StaL': 

! (fit   1 ffö   1 (ft)   | m    i fcfc)  | (ds)  ; (ds) m ■■ ■ ? 
136200 705.03 

705.91 

706.10 

706.48 

703.73 

704.66 

704.84 

705.20 

702.17 

703.16 

703.33 

703.50 

598.30 

699.30 

699.30: 

699.30 

0.88 

1.03 

1.45 

0.92 

1.11 

1.46 

G.S9 

1.16 

1.32 

1.00 

1.00 

1.00 

705.33 

706.26 

706.46 

706.84 

704.04 

704.99 

705,19 

705.47 

702.40 

703.41 

703.59 

703.77 

698.50 

699.49 

699.51 

699.52 

400.52 

187.97 

178.81 

170.70 

324.35 

241.01 

230.18 

219.63 

465.48 

303.58 

290.54 

274.79 

526.75 

353.21 

334.71 

317.26 

1446.64 

1174.11 

1103.29 

1032.90 

528.34 

109.85 

3.32 

2091.96 

1921.26 

1868.19 

1816.28 

4001.32 

4287.34 

4167.98 

4047.86 

3987.24 

4307.82 

4392.29 

4466.95 

3498.08 

3776.00 

3854.03 

3530.57 

3489.63 

3741.27 

3824.11 

3906.37 

3654.32 

3712.66 

3832.02 

3952.14 

2566.13 

2518.07 

2504.42 

2500.15 

3973.58 

4114.15 

4142.65 

4469.43 

2418.42 

2337.47 

2307.70 

2277.35 

343.86 

! ; 

'3S2D0 

'3Ö200 

182.98 

187.4? 

191.15 

i 

:36200 
i 

135100 

135100 108.!:t 

114.37- 

115.60 

135100 

135100 
; 

13370C 

133700 127.40 

13:.67 

138.67 

154.79 

173.79 
; 

 : 

133700 

33700 

I 
; 29900 

J299Ö0 

12930Ü 

J29900 190.71 ---: 

;^n j. ■ ■..■ I -:;-:- ! =^ ! 

I Right station of encroachment 

Figure 9.4 Example of the Encroachment 1 Standard Table 

Encroachment 2 table provides some additional information that is often used 
when plotting the encroachments onto a map. This table includes: the change 
in water surface elevations from the first profile; the top width of the active 
flow area: the percentage of conveyance reduction in the left overbank; the left 
encroachment station; the distance from the center of the main channel to the 
left encroachment station; the station of the center of the main channel; the 
distance from the center of the main channel to the right encroachment station: 
the right encroachment station: and the percentage of conveyance reduction in 
the right overbank.  An example of the Encroachment 2 standard table is 
shown in Fmure 9.5. 
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Profile Output Table - Encroachment 2 ■V- '.■•• .;; V:;~ H* 
File    Options    Stcl. Tables    User Tables    Help 

v,? f^v~ '          *,      HEORAS   Plan: Floodway   Reach: ■1 

River Sta. Prof Delta   JTopWdtliAct K Perc L Eric Sta L Dist Center L Center Dist Center RJ.-Enc Sta R  | ♦ 

i      {ft)      !      (ft) (R! (ft) W (ft) (R)        I (ft) 

»MS» 

^800 g^S^^;^              -11,1,11 
1.00             125.00                2.91              95.00              25.00 

1.18             11/.15                 3.00               95.00               25.00 

1.35             109.21                3.10              95.00              25.00 

245.90 

0.75             141.93                 3.79               95.00               25.00 

0.92             132.27                 3.88               95.00               25.00 

1.12              125.00                 3.98               95.00               25.00 

467.07 

0.45             293.23                 4.87               86.90             128.10 

0.59             282.11                 6.21               87.90             127.10 

0.80            271.04                7.30              94.31             120.69 

465.11 

0.38             240.64                 6.01             100.12             114.88 

0.52             222.42                 7.35             108.38             106.62 

0.72             206.10                 3.63             115.84               99.16 

120.00 

120.00 

120.00 

120.00 

120.00 

120.00 

120.00 

120.00 

215.00 

215.00 

215.00 

215.00 

215.00 

215.00 

215.00 

215.00 

100.00 

92.15 

84.21 

116.93 

107.27 

100.00 

165.13 

155.00 

150.35 

125.76 

115.80 

106.93 

40800 220.00 

212.15 

204.21 

236.93 

227.27 

220.00 

380.13 

370.00 

365.35 

340.76 

330.80 

321.93 

40800 

40800 

40150 

40150 

40150 

40150 

37200 

37200 

37200 

37200 

37000 

37000 

37000 

37000 

*L. * 

: ^....-mm... ,.i»......n«....HiJ 

Figure 9.5 Example of the Encroachment 2 Standard Table 

The last encroachment table, Encroachment 3, provides the minimum 
floodway data for reporting. This table includes: the active flow top width; 
the flow area (including any ineffective flow area); the average velocity of the 
entire cross section; the computed water surface elevation; the base water 
surface elevation (profile 1); and the change in water surface from the first 
profile. An example of this table is shown in Figure 9.5 
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:Px_ ofi I e Output Table - Encroachments 
File    Options    Std. Tables     User Tables    Help 

C-RAS Plan: Floodway   Reach: 1 
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1811.67 
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3106.03 
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inn« fi«; 

4.71;              711.93 

5.54              712.93 

5.73:             713.10 

5.95;             713.28 

3.74             710.82 

4.42             711.58 

4.59             711.74 

4.72;             711.94 

1.87             708.81 

2.22             709.26 

2.25             709.41 

2.28:             709.62 

1.89:             708.72 
2.58               709.10 

2.70              709.23 
2.82              709.43 
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710.82 

710.82 

708.81 

708.81 

708.81 

708.81 
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708.72 
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708.72 
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1.00 

1.18 
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0.59 

0.80 

0.38 
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^■:: 
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40800 

40800 

40150 

4Q150 
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40150 
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37000 

MS5S  ? es: 7fl«i QT 

Figure 9.6 Example of the Encroachment 3 Standard Table 
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CHAPTER   10 

Trouble Shooting With HEC-RAS 

The HEC-RAS software is designed to continue its computations all the way 
through completion, even when the user has entered poor data. Because of 
this, the fact that the program executes a complete run does not necessarily 
mean that the results are good. The user must carefully review the results to 
ensure that they adequately represent the study reach and that they are 
reasonable and consistent. The HEC-RAS software is an engineering tool, it 
is by no means a replacement for sound engineering. 

The HEC-RAS software contains several features to assist the user in the 
development of a model; debugging problems; and the review of results. 
These features include: built in data checking; an Errors, Warnings, and Notes 
system; and a computational Log Output file. In addition to these features, the 
user can use the graphical and tabular output to review the results and check 
the data for reasonableness and consistency. 

Built in Data Checking 

The HEC-RAS user interface has two types of built in data checking. The 
first type of data checking is performed as the user enters the data. Each data 
field of the data entry editors has some form of data checking. The second 
type of data checking occurs when the user starts the steady flow 
computations. When the user presses the compute button, on the steady flow 
analysis window, the entire data set is processed through several data checks 
before the computations are processed.   A detailed discussion of each of these 
two data checking features is described below. 

Checking the Data as it is Entered 

This type of data checking occurs whenever the user enters data into a single 
data field or table. Once the user leaves a particular data entry field or table, 
the program will automatically check that data for reasonableness. The 
following is a list of some of the types of data checks that are performed: 

1. Minimum and maximum range checking for variables. 

2. Alpha and numeric data checks. This is done to ensure that the right 
type of data is entered in each field. 
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3. Increasing order of station for cross sections, bridge deck/roadway, 
and abutments. 

4. Data consistency checks (i.e. when the main channel bank stations are 
entered, the program checks to see if they exist in the cross section 
station and elevation data). 

5. Data deletion warnings. When you delete data the software will give 
you a warning before it is deleted. 

6. File management warnings (i.e. program will give you a chance to 
save the data to the hard disk before the program is closed, or a 
different data set is opened). 

7. Data geometry checks (i.e. when a bridge deck/roadway is entered, the 
program checks to ensure that the deck/roadway intersects with the 
ground data). 

Data Checking Before Computations are Performed 

The second type of data checking is performed to evaluate the completeness 
and consistency of the data. This type of data checking occurs before the 
computations take place. When the user presses the Compute button on the 
Steady Flow Analysis window, the program will perform a series of data 
checks before the computations are allowed to proceed. If any data errors are 
found, the program will not perform the computations. The following is a list 
of some of the types of checks that are made during this time: 

1. Data completeness. These data checks insure that all of the required 
data exists for the entire data set. If any missing data are found, a 
complete list of all the missing data and their specific locations is 
displayed on the screen. An example of this is shown in Figure 10.1. 

Data consistency. This type of data checking is performed to ensure 
that the data is consistent with the computations that are being 
requested. For example, if the user asks to perform a mixed flow 
regime computation, the program checks to ensure that upstream as 
well as downstream boundary conditions have been specified. 
Likewise, if an encroachment analysis is requested, the program 
checks to ensure that the number of profiles lines up with the number 
specified in the encroachment data. There are several other checks of 
this type. 
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bfrYor-Incomplete data, the following errors wore found:      ^^:^s^sÄ'i':^^ss^ii5'sts-s^^ 

- Incom piete dataain Re ach " 1" at Riyer Statipn: 1.2  
- Channel Manning's n value not set 

- Incomplete data on Reach " 1" at River Station: 11 
- Coefficient of Expansion not set 

- Incomplete data on Reach " 1" at River Station: 10 
- Main channel length not set 

Zero or Undefined Flow Values on Reach : 1 Prof # 2 

Clipboard] j Print .„.J Close 

Figure 10.1 Data Completeness Checking Window 

Errors, Warnings, and Notes 

The HEC-RAS software has a system of Errors, Warnings, and Notes that are 
passed from the steady flow computation program to the user interface. 
During the computations, the steady flow computation program will set flags 
for at a particular node (nodes are cross sections, bridges, culverts, or multiple 
openings) whenever it is necessary. These message flags are written to the 
standard output file, along with the computed results for that node. When the 
user interface reads the computed results from the output file, if any errors, 
warnings, or notes exist, they are interpreted and displayed in various 
locations from the interface. 

The user can request a summary of all the errors, warnings, and notes that 
occurred during the computations. This is accomplished by selecting 
Summary Errors, Warnings, and Notes from the View menu on the main 
HEC-RAS window. Once this is selected, a window will pop up displaying 
all of the messages. The user has the options of expanding the window; 
printing the messages; or sending them to the windows clipboard. An 
example of the Errors, Warnings, and Notes window is shown in Figure 10.2. 
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:   -. "-'.Errors .Warnings and Notes for Plan: Existing 

Reach:  1      Riy Sta: 2Profile:  1 
Warning - Divided flow computed for this cross-section. 
Warning -The energy loss was greater than 1.0 ft (0.3 rn). between the current and previous 
cross section. This may indicate the need for additional cross sections. 

Reach:  1      Riv Sta: 3      Profile:  1 
Warning - The energy equation could not be balanced within the specified number of iterations. 
The program used critical depth for the water surface and continued on with the calculations. 
Warning - Divided flow computed for this cross-section. 
Warning - The velocity head has changed by more than 0.5 ft (0.1 5 m). This may indicate the 
need for additional cross sections. 

Clipboard  PnnJLJ     ifile CiflSG 

Figure 10.2 Summary of Errors, Warnings, and Notes Window 

Besides the summary window, errors, warnings, and notes will automatically 
appear on the cross section specific tables. When a specific cross section or 
hydraulic structure is being displayed, any errors, warnings, or notes that were 
set at that location, for the displayed profile, will show up in the Errors, 
Warnings, and Notes message box at the bottom of the table. An example of 
this table is shown in Figure 10.3. 

Cress Seclicr O^;;:".: 
File    Type    Options 

Rfeuch i + . River Sta;' 12 ± |*;| t iViiiiü * 

^^äsBaSÄJIä!? v* **^rf-flU.lI^iJiCv-'X'».JH'**** *':** .*■:'^'1 *'■£•**?.! ?J^ VV-'"^^^"^I.^Jd-1'.::?:-- ','".'.  ■'-"-,V'-'-.'S.^*' 

W.S. Elev(ft) 1815.05 

0.71 

1815.76 

Element ■'f-U'eftO.:B:^|'iä€KanmeI:,':|Bight80'18; 
Vel Houd (ft) Wt. n-Vai. 0.100             0.040:           0.100 
E.G. Elev (ft) Reach Len. (ft) 500.00:         500.00 500.00 

E.G. Slope (ft/ft) 0.006895 

9000.00 

877.23 

Flow Area (sq ft) 2132.27          320 49 99.26 

Q Totol :cfs) Flow (cfs) 5524.31         3375 54          100.14: 

00:        134.22 ■ 
53!             T01 

Top Widlh (ft) Top Width (ft) 698.01              45 

Vei Totai (ft/s) 3.53 Avg. Vel. (ft/s) 2.59I           10 

 3.05i 7 Max Chi Dpih (»} 1 1.45 Hydr. Depth (ft) 12 

80: 
0.74 

CriSW.S. (it) Wetted Per. (ft) 700.79:            50 134 

1 20 

.23 
Conv. Total (cfs) 108385.5 Conv. (cfs) 66528.4         40651.1 6.0 

Errors, Warnings and Notes 
Warning - The velocity head has changed by more than 0.5 ft (0.15 m). This may 

indicate the need for additional cross sections. 
Warning - The energy loss was greater than 1.0 ft (0.3 m), between the current and 

Figure 10.3 Cross Section Table with Errors, Warnings, and Notes 
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In general, the errors, warnings, and notes messages should be self 
explanatory. The three categories of messages were developed to represent 
the following: 

ERRORS: Error messages are only sent when there are problems that 
prevent the program from being able to complete the run. 

WARNINGS: Warning messages provide information to the user that may or 
may not require action on the user's part. In general, whenever a warning is 
set at a location, the user should review the hydraulic results at that location to 
ensure that the results are reasonable. If the hydraulic results are found to be 
reasonable, then the message can be ignored. However, in many instances, a 
warning level message may require the user to take some action that will cause 
the message to disappear on future runs. Many of the warning messages are 
caused by either inadequate or bad data. Some common problems that cause 
warning messages to occur are the following: 

Cross sections spaced to far apart. This can cause several warning 
messages to be set. 

Cross sections starting and ending stations not high enough. If a 
computed water surface is higher than either end point of the cross section, a 
warning message will appear. 

Bad Starting Water Surface Elevation. If the user specifies a boundary 
condition that is not possible for the specified flow regime, the program will 
take action an set an appropriate warning message. 

Bad Cross Section Data. This can cause several problems, but most often 
the program will not be able to balance the energy equation and will default to 
critical depth. 

NOTES: Note level messages are set to provide information to the user about 
how the program is performing the computations. 

Log Output 

Setting Log File Output Level 

This option allows the user to set the level of the Log file. The Log file is a 
file that is created by the computational program. This file contains 
information tracing the program process. Log levels can range between 0 and 
10, with 0 resulting in no Log output and 10 resulting in the maximum Log 
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output. In general, the Log file output level should not be set unless the user 
gets an error during the computations. If an error occurs in the computations, 
set the log file level to an appropriate value. Re-run the computations and 
then review the log output, try to determine why the program got an error. 

When the user selects Set Log File Output Level, a window will appear as 
shown in Figure 10.4. The user can set a "Global Log Level", which will be 
used for all cross sections and every profile. The user can also set log levels at 
specific locations for specific profiles. In general, it is better to only set the 
log level at the locations where problems are occurring in the computations. 
To set the specific location log level, first select the desired reach and river 
station. Next select the log level and the profile number (the log level can be 
turned on for all profiles). Once you have everything set, press the Set button 
and the log level will show up in the window below. Log levels can be set at 
several locations individually. Once all of the Log Levels are set, press the 
OK button to close the window. 

Output Log Level 

Global Log Level 0 J 

Log Levels for Specific Locations i 

Reach Fall Cr. ±! River Sta. 9.8 ± Profile 3 ± 
Desc. River Mile 9.8 of Fall Qeek Level 6     |±j Set 

Fall Cr.                        RS=10                         LL= 
Fall Cr.                        RS = 9.8                        LL= 

4 
6 

PF=  1 
PF =  3 

OK Cancel Help Clear All 

ßet specific log level for selected location 

Figure 10.4 Log File Output Level window 

Warning !!! - setting the global log output level to 4 or 5 can result in very 
large log file output. Global log level values of 6 or larger can result in 
extremely large log files. 

Viewing The Log Fi!e 

This option allows the user to view the contents of the log file. The interface 
uses the Windows Write program to accomplish this. It is up to the user to set 
an appropriate font in the Write program. If the user sets a font that uses 
proportional spacing, the information in the log file will not line up correctly. 
Some fonts that work well are: Line Printer; Courier (8 pt.); and Helvetica (8 
pt.). Consult your Windows user's manual for information on how to use the 
Write program. 
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Reviewing and Debugging the Normal Output 

After the user has successfully completed a run, and reviewed all the errors, 
warnings, and notes, the normal output should be reviewed for consistency 
and reasonableness. 

Viewing Graphics 

In general, the graphical output should be used as much as possible to get a 
quick view of the results. The user should look at all of the cross sections 
with the cross section plotting capability. The cross section plots will assist 
the user in finding data mistakes, as well as possible modeling mistakes 
(mistakes in ineffective flow areas, levees, n values, etc.). 

The profile plotting capability is also a way to get a quick overview of the 
entire study area. The user should look for sudden changes to the energy 
grade line and the water surface. In general, these two variables should 
transition smoothly along the channel. If the user finds rapid changes in the 
energy or the water surface, the results at those locations should be reviewed 
closely to ensure that they are correct. 

The X-Y-Z Perspective Plot can also be used to get a quick view of an entire 
reach. This plot is very helpful for viewing the top width of the flow area. If 
the user finds dramatic changes in the top width from one cross section to the 
next, then the results at those locations should be reviewed closely. Dramatic 
changes in top width may indicate the need for additional cross sections. 

Viewing Tabular Output 

There are several types of tabular output. The user should try to make use of 
all of them when viewing tabular results. In general, the profile types of tables 
should be used to get an overview of some of the key variables at several 
locations. If any problems are found, or any results that seem suspect, the user 
should use the cross section specific tables to get detailed results at a single 
location. 

The Occurrence of Critical Depth 

During the water surface profile calculations, the program may default to 
critical depth at a cross section in order to continue the calculations. Critical 
depth can occur for the following reasons: 

1. Bad cross section data: If the energy equation can not balance because 
of bad cross section data, the program defaults to critical depth. 
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Cross sections spaced to far apart: If the cross sections are spaced to 
far apart, the program may not be able to calculate enough energy 
losses to obtain a subcritical water surface at the upstream section. 

Wrong flow regime: When calculating a subcritical profile, and the 
program comes to a reach that is truly supercritical, the program will 
default to critical depth. Likewise, when calculating a supercritical 
profile, if the reach is truly subcritical, the program will default to 
critical depth. 

Program can not balance the energy equation above or below the top 
of a levee or ineffective flow area: On occasion, when the program is 
balancing a water surface that is very close to the top of a levee, or an 
ineffective flow area, the program may go back and forth (above and 
below the levee) without being able to balance the energy equation. 
When this occurs, the program will default to critical depth. 
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