
 
 
 

 ARL-TR-7711 ● JUNE 2016 
 
 
 

 US Army Research Laboratory 

 
 
Traffic Generator (TrafficGen) Version 1.4.2: 
User’s Guide 

 
by Chien Hsieh and Andrew Toth 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Approved for public release; distribution is unlimited. 



 

 

NOTICES 
 

Disclaimers 
 

The findings in this report are not to be construed as an official Department of the 
Army position unless so designated by other authorized documents. 
 
Citation of manufacturer’s or trade names does not constitute an official 
endorsement or approval of the use thereof. 
 
Destroy this report when it is no longer needed. Do not return it to the originator. 



 

 

 
 
 

 ARL-TR-7711 ● JUNE 2016 

 
 US Army Research Laboratory 

 
 
Traffic Generator (TrafficGen) Version 1.4.2: 
User’s Guide 

 
by Chien Hsieh and Andrew Toth 
Computational and Information Sciences Directorate, ARL 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Approved for public release; distribution is unlimited.



 

ii 
 

REPORT DOCUMENTATION PAGE Form Approved 
OMB No. 0704-0188 

Public reporting burden for this collection of information is estimated to average 1 hour per response, including the time for reviewing instructions, searching existing data sources, gathering and maintaining the 
data needed, and completing and reviewing the collection information. Send comments regarding this burden estimate or any other aspect of this collection of information, including suggestions for reducing the 
burden, to Department of Defense, Washington Headquarters Services, Directorate for Information Operations and Reports (0704-0188), 1215 Jefferson Davis Highway, Suite 1204, Arlington, VA 22202-4302. 
Respondents should be aware that notwithstanding any other provision of law, no person shall be subject to any penalty for failing to comply with a collection of information if it does not display a currently valid 
OMB control number. 
PLEASE DO NOT RETURN YOUR FORM TO THE ABOVE ADDRESS. 

1. REPORT DATE (DD-MM-YYYY) 

June 2016 
2. REPORT TYPE 

Final 
3. DATES COVERED (From - To) 

10/2014–09/2015 
4. TITLE AND SUBTITLE 

Traffic Generator (TrafficGen) Version 1.4.2: User’s Guide 
5a. CONTRACT NUMBER 

 
5b. GRANT NUMBER 

 
5c. PROGRAM ELEMENT NUMBER 

 
6. AUTHOR(S) 

Chien Hsieh and Andrew Toth 
5d. PROJECT NUMBER 

 
5e. TASK NUMBER 

 
5f. WORK UNIT NUMBER 

 
7. PERFORMING ORGANIZATION NAME(S) AND ADDRESS(ES) 

US Army Research Laboratory 
ATTN: RDRL-CIN-T 
2800 Powder Mill Road 
Adelphi, MD 20783-1138 

8. PERFORMING ORGANIZATION REPORT NUMBER 

 
ARL-TR-7711 

9. SPONSORING/MONITORING AGENCY NAME(S) AND ADDRESS(ES) 

ARL TNAB 
ATTN: RDRL-CIN-T 
2800 Powder Mill Road 
Adelphi, MD 20783-1138 

10. SPONSOR/MONITOR'S ACRONYM(S) 

 
11. SPONSOR/MONITOR'S REPORT NUMBER(S) 

 

12. DISTRIBUTION/AVAILABILITY STATEMENT 

Approved for public release; distribution is unlimited. 

13. SUPPLEMENTARY NOTES 
 

14. ABSTRACT 

Network science experimentation often requires modeling of realistic network traffic specific to the experiment environment 
and goals. The multi-generator (MGEN) tool, developed by the US Naval Research Laboratory, reads scripts to generate real-
time traffic patterns to load the network with Transmission Control Protocol and User Datagram Protocol Internet Protocol 
traffic. Each node generating network traffic in an experiment executes a copy of MGEN and requires a custom script to 
represent its traffic patterns. While this approach works well for smaller experiments, managing the scripts and generating 
meaningful interaction of network node traffic via the scripts becomes more cumbersome as the number of network nodes 
increases. This report is a User’s Guide for the US Army Research Laboratory Network Science Research Laboratory (NSRL) 
TrafficGen application, which eases the task of composing network traffic scenarios by visually representing multiple MGEN 
scripts simultaneously in a timeline. 

15. SUBJECT TERMS 

Network traffic, multi-generator, MGEN, Scripted Display Tool 3D, Network Science Research Laboratory (NSRL) 

16. SECURITY CLASSIFICATION OF: 
17. LIMITATION 
       OF  
       ABSTRACT 

UU 

18. NUMBER 
       OF  
       PAGES 

40 

19a. NAME OF RESPONSIBLE PERSON 

Andrew Toth 
a. REPORT 

Unclassified 
b. ABSTRACT 

Unclassified 
c. THIS PAGE 

Unclassified 
19b. TELEPHONE NUMBER (Include area code) 

301-394-2746 
 Standard Form 298 (Rev. 8/98) 
 Prescribed by ANSI Std. Z39.18 



 

Approved for public release; distribution is unlimited. 
iii 

Contents 

List of Figures vi 

1. Overview 1 

2. Starting the Application 2 

2.1 Prerequisites 2 

2.2 Running TrafficGen 2 

2.2.1 Linux 2 

2.2.2 Mac OS X 2 

2.2.3 Windows 2 

3. Understanding the TrafficGen Graphical User Interface (GUI) 3 

3.1 Anatomy of the User Interface 3 

3.2 Scenario Configuration and MGEN Files 4 

4. Working with Scenarios 5 

4.1 Create a New Scenario 5 

4.1.1 Starting a New Scenario 6 

4.2 Open an Existing Scenario 6 

4.3 Add a Node 6 

4.4 Add a Flow 7 

4.5 Add a Reception Event 8 

4.5.1 Adding a Listen or Ignore Reception Event 8 

4.5.2 Adding a Join or Leave Reception Event 9 

4.6 Import Existing Scenario 10 

4.6.1 Node Name Conflict Resolution 11 

4.7 Import Existing MGEN Files 12 

4.8 Edit an Existing Node 12 

4.9 Edit an Existing Flow 13 

4.10 Edit an Existing Reception Event 14 

4.11 Delete a Node 15 

4.11.1 From the Application Menu 15 



 

Approved for public release; distribution is unlimited. 
iv 

4.11.2 From the Context Menu 15 

4.12 Delete a Flow 16 

4.13 Delete a Reception Event 16 

4.14 Clear All Events 16 

4.15 Edit Color Key of a Node 16 

4.16 Use Copy and Paste to Create Events 17 

4.17 Use Mouse to Adjust Flow Event Times 17 

4.18 Use Mouse to Move a Flow or Reception Event 18 

4.19 Save a Scenario 18 

4.19.1 Save a Scenario to a Different Name 18 

4.20 Export Scenario Data 19 

4.20.1 Export SDT File 19 

4.20.2 Export MGEN Timeline Script 19 

5. Working Directly With MGEN Files 20 

5.1 Open Existing MGEN Files 20 

5.2 Save MGEN Files 21 

5.3 Main Differences of Working in MGEN File Mode 21 

6. Customizing View of the Scenario Workspace 21 

6.1 Visibility of Flows and Events 21 

6.2 Multicast Addresses 22 

6.3 SDT3D View 23 

6.3.1 Prerequisite 23 

6.3.2 Operation 24 

6.3.3 Visual Examples 24 

7. Preferences and Options 26 

7.1 Preferences 26 

7.1.1 Node Color Setting 26 

7.1.2 Enable/Disable Tooltip 27 

7.1.3 Change Destination Address Output Mode 27 

7.2 Scenario Properties 27 



 

Approved for public release; distribution is unlimited. 
v 

8. Conclusion 28 

9. References 29 

List of Symbols, Abbreviations, and Acronyms 30 

Glossary 31 

Distribution List 32 



 

Approved for public release; distribution is unlimited. 
vi 

List of Figures 

Fig. 1 TrafficGen user interface .......................................................................4 

Fig. 2 New scenario ..........................................................................................5 

Fig. 3 Opening a scenario .................................................................................6 

Fig. 4 Adding a node ........................................................................................7 

Fig. 5 Adding a flow event ...............................................................................8 

Fig. 6 Adding a listen/ignore reception event ..................................................9 

Fig. 7 Adding a join/leave reception event ....................................................10 

Fig. 8 Importing an existing scenario .............................................................11 

Fig. 9 Resolving node name conflicts ............................................................12 

Fig. 10 Editing an existing node.......................................................................13 

Fig. 11 Editing an existing flow .......................................................................14 

Fig. 12 Editing an existing reception event ......................................................15 

Fig. 13 Editing color key of a node ..................................................................17 

Fig. 14 Saving scenario with a new name ........................................................19 

Fig. 15 Opening existing MGEN files .............................................................20 

Fig. 16 User interface in MGEN file mode ......................................................21 

Fig. 17 Changing visibility of flows and events...............................................22 

Fig. 18 Filtering multicast addresses ................................................................23 

Fig. 19 Integration control with SDT3D ..........................................................24 

Fig. 20 TrafficGen user interface when controlling SDT3D ...........................25 

Fig. 21 SDT3D user interface responding to TrafficGen commands ..............25 

Fig. 22 Changing node color setting ................................................................26 

Fig. 23 Scenario properties...............................................................................27 

 
  



 

Approved for public release; distribution is unlimited. 
1 

1. Overview 

Network Science experimentation often requires modeling of realistic network 
traffic specific to the experiment environment and goals. The US Naval Research 
Laboratory (NRL) Protocol Engineering Advanced Networking (PROTEAN) 
Research Group has developed multi-generator (MGEN) to generate real-time 
traffic patterns to load the network with Transmission Control Protocol (TCP) and 
User Datagram Protocol (UDP) IP traffic. Each network node generating traffic in 
an experiment will have the MGEN application installed and will read the traffic 
patterns from a script. Scripts contain commands to have the network node listen 
on specific ports and flows describing the start time, stop time, and specific traffic 
pattern to send. The variety of patterns MGEN offers enables the researcher to 
model realistic network traffic patterns. MGEN currently runs on various Unix-
based (including MacOS X) and WIN32 platforms.1 

Modeling traffic scenarios using MGEN requires 1 script for each network node 
that will participate in the experiment. As scenarios grow, managing individual 
script files becomes cumbersome and can put the researcher in a position similar to 
that of a playwright composing a scene by writing each actor’s part independently, 
then combining the parts and hoping they align properly. The more actors in the 
play, the more difficult the task.  

The US Army Research Laboratory (ARL) Network Science Research Laboratory 
(NSRL) developed TrafficGen to ease the task of composing network traffic 
scenarios. TrafficGen presents network traffic in a timeline format with 
participating nodes arranged vertically and time presented horizontally. Individual 
traffic flows are represented by horizontal bars indicating the start time, stop time, 
and specific traffic pattern that will be sent. Traffic flows can be specified as TCP, 
UDP, or Sink, with traffic patterns of Burst, Periodic, Poisson, Jitter, and Clone. 
Researchers can experience an added dimension of network traffic visualization by 
pairing TrafficGen with the NRL The Scripted Display Tool 3D (SDT3D) to view 
network nodes and their communication flows overlaid on a topographical map. 
TrafficGen interacts with SDT3D by sending node link commands via TCP or UDP 
to the IP address and port on which SDT3D is listening, illustrating the source to 
destination traffic flows at the time indicated by the timeline cursor. 

This document describes use of the features of the ARL TrafficGen application. 
The TrafficGen Architecture Document described implementation-specific details 
of the application. TrafficGen is available for download on the ARL public web 
site.3 
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2. Starting the Application 

2.1 Prerequisites 

The following are prerequisites prior to using TrafficGen. 

• Java 1.7 or higher is installed on the computer where TrafficGen is expected 
to run.  

• The user is familiar with MGEN script files, events, and options. 

2.2 Running TrafficGen 

The application is distributed in a .tar file. The user will expand the tar file in a 
directory of choice. The content of the distribution include:  

• A script file to start the application (e.g., traffic.sh)  

• A directory named jars where the necessary application related binaries 
reside.  

• Example scenarios in the examples directory. 

2.2.1 Linux  

The following are steps to start TrafficGen on Linux. 

• Open a command prompt  

• Change directories to the directory containing the untarred TrafficGen files  

• Run the following command:  
./traffic.sh 

2.2.2 Mac OS X 

The following are steps to start TrafficGen on MacOS. 

• Open a command prompt  

• Change directories to the directory containing the untarred TrafficGen files  

• Run the following command:  
./traffic.sh 

2.2.3 Windows  

The following are steps to start TrafficGen on Windows. 
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• Open a command prompt  

• Change directories to the directory containing the untarred TrafficGen files  

• Run the following command in the prompt:  
traffic.bat 

3. Understanding the TrafficGen Graphical User Interface (GUI) 

TrafficGen is an interactive tool used to visualize and manipulate a network traffic 
scenario, which is composed of multiple MGEN script files. Using this tool, the 
user can create a scenario, open an existing scenario for edit, and save a scenario. 

3.1 Anatomy of the User Interface 

Fig. 1 shows the TrafficGen user interface.   

1) The nodes. These are the nodes (hosts) that are communicating with each 
other in this scenario. 

2) Time scale (in seconds). This shows when and how long the nodes 
communicated with each other.  

3) Events. The rectangular blocks are flows, which mark the start and stop 
time of transmission events. These blocks are color-coded based on the 
destination of the transmission. When a flow does not have the stop time 
specified, it is considered a continuous flow. Continuous flows are shown 
as thin blocks that extend to the end of the time scale. The rounded-corner 
vertical rectangles are MGEN reception events. 

4) Application menu. The menu items allow the user to build a scenario, 
manipulate the nodes and events in the scenario, and set preferences. 

5) Status bar. The status bar includes message areas to inform the user of the 
current state of the application. In addition, it contains convenient 
navigation buttons to help the user move around the workspace of the 
application. 
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Fig. 1 TrafficGen user interface 

3.2 Scenario Configuration and MGEN Files 

For TrafficGen, a scenario consists of a scenario configuration file, plus MGEN 
files corresponding to the nodes in the scenario, all under a single directory. The 
name of the scenario configuration file is typically identical to the name of the 
scenario directory, and it has the extension of .xscen. The configuration file is in 
XML format and includes mapping of node names to IP addresses, as well as color 
representation of the nodes.  

The following sample scenario directory listing shows the scenario configuration 
file and 8 MGEN files. 

$ pwd  
/opt/traffic_gen/examples/scenario1  
$ ls -l  
-rw-r--r-- 1 user1 users  136 Sep  4 10:50 node_001.mgn 
-rw-r--r-- 1 user1 users  135 Sep  4 10:50 node_002.mgn 
-rw-r--r-- 1 user1 users  313 Sep  4 10:50 node_003.mgn 
-rw-r--r-- 1 user1 users  136 Sep  4 10:50 node_004.mgn 
-rw-r--r-- 1 user1 users  136 Sep  4 10:50 node_005.mgn 
-rw-r--r-- 1 user1 users  232 Sep  4 10:50 node_006.mgn 
-rw-r--r-- 1 user1 users  135 Sep  4 10:50 node_007.mgn 
-rw-r--r-- 1 user1 users  230 Sep  4 10:50 node_008.mgn 
-rw-r--r-- 1 user1 users 1077 Sep  4 10:50 scenario1.xscen 
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4. Working with Scenarios 

The default mode of operation for TrafficGen is the Scenario Mode. In this mode, 
the user is able to plan, design, and visualize a scenario of communications among 
a related set of nodes. The other mode of operation is File Mode, which allows the 
user to directly work with MGEN files. File Mode is described in a later section. 

The following sections describe the various operations of working with a scenario. 

4.1 Create a New Scenario 

When the application is launched, a new scenario is available to the user by default, 
as shown in Fig. 2. 

 

Fig. 2 New scenario 

The following is a set of suggested steps to create a scenario from scratch. 

• Create at least 2 nodes in the scenario. 

• Create flows for each of the nodes in the scenario.  

• Save the scenario to a specific directory.  
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4.1.1 Starting a New Scenario 

If the user has finished making modifications to a scenario and wishes to start a 
new one, or simply wants to discard all changes and start again, do the following 
from the menu: 

• Click File -> New 

4.2 Open an Existing Scenario 

The following are the steps to open a previously created scenario for edit. 

• Click File -> Open Scenario...  

• Navigate to the directory containing the scenario and open the scenario 
configuration file. 

• The data for this scenario will be displayed in the scenario view. 

Figure 3 shows the user interface to open an existing scenario. 

 

Fig. 3 Opening a scenario 

4.3 Add a Node 

The following are the steps to add a new node. 

• Click Edit-> Add -> Node, or right-click anywhere in an empty area in the 
node side of the workspace and select “Add Node” from the context menu. 
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• Edit all options to add the appropriate parameters for the new node.  

• Click “Apply”.  

Figure 4 shows the user interface to add a new node. 

 

Fig. 4 Adding a node 

4.4 Add a Flow 

The following are the steps to add a new flow event. 

• Click Edit -> Add -> Flow, or right-click the row to which a flow is to be 
added and select “Add Flow” from the context menu. 

• Edit all options to add the appropriate parameters for the new flow.  

• Apply changes by clicking the “Apply” button.  

• The window will remain open so the user can add several flows in quick 
succession.  

• Click “Close” to finalize the flow.  

Note: A flow without a specified stop time is considered a CONTINUOUS flow. 

Figure 5 shows the user interface to add a new flow event. 
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Fig. 5 Adding a flow event 

4.5 Add a Reception Event 

4.5.1 Adding a Listen or Ignore Reception Event 

The following are the steps to add a new Listen or Ignore reception event. 

• Right-click the row to which a reception event is to be added.  

• Select “Add Reception Event” from the context menu.  

• Select LISTEN or IGNORE Reception Type. 

• Edit all options for the new reception event.  

• Apply changes by clicking the “Apply” button.  
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• The window will remain open so the user can add several events in quick 
succession.  

• Click “Close” to finalize the event.  

Figure 6 shows the user interface to add a listen or ignore reception event. 

 

Fig. 6 Adding a listen/ignore reception event 

4.5.2 Adding a Join or Leave Reception Event 

The following are the steps to add a new Join or Leave reception event. 

• Right-click on the row to which a reception event is to be added.  

• Select “Add Reception Event” from the context menu.  

• Select JOIN or LEAVE Reception Type. 

• Specify a multicast address in the Group Address field. 

• Edit any applicable options for the new reception event.  

• Apply changes by clicking the “Apply” button.  

• The window will remain open so the user can add several events in quick 
succession.  

• Click “Close” to finalize the event.  

Figure 7 shows the user interface to add a join or leave reception event. 
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Fig. 7 Adding a join/leave reception event 

4.6 Import Existing Scenario 

While working on a particular scenario, the user can import another scenario in its 
entirety—including all nodes and their events—to the currently opened scenario. 
The following are the steps. 

• Click File -> Import -> Scenario... The user is presented with dialog box to 
import an existing scenario, as shown in Fig. 8. 

• Navigate to the directory containing the files of the scenario and open the 
scenario configuration file. The data for this imported scenario will be 
added and displayed in the currently opened scenario. 
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Fig. 8 Importing an existing scenario 

4.6.1 Node Name Conflict Resolution 

During the import process, it is possible that name of one or more of the nodes 
being imported already exists in the currently opened scenario. If duplicate name 
conflicts are detected, the application will prompt the user to resolve the issue, as 
shown in Fig. 9. 

The user may select one of the following actions: 

• Cancel operation. The import operation will be canceled, and none of the 
nodes will be added. 

• Ignore duplicate nodes. Only nodes without name conflicts are added to 
the scenario. Nodes with duplicate names will be discarded. 

• Merge events to existing nodes. Events from nodes with duplicate names 
will be added to the existing nodes with the same names. 

• Add prefix to duplicate node names. The user can specify a prefix in the 
provided textbox, which will be combined with the original (duplicate) 
names to form unique node names before adding them to the scenario. 
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Fig. 9 Resolving node name conflicts 

4.7 Import Existing MGEN Files 

The following are the steps import one or more existing MGEN files into the 
currently opened scenario. 

• Click File -> Import -> MGEN Files...  

• Navigate to the directory containing the MGEN files. Select and open the 
desired files. 

• The data for the imported MGEN files will be added and displayed in the 
currently opened scenario. 

• The user will be prompted to resolve name conflicts if the node names in 
any of the selected files already exist in the scenario. 

4.8 Edit an Existing Node 

The following are the steps to edit an existing node. 

• Click Edit-> Edit -> Node, or right-click the node to be edited and select 
“Edit Node” from the context menu. 

• Edit all options to modify the appropriate parameters for the existing node.  

• Click “Apply” to finalize changes to that node.  
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• Click “Close”.  

Figure 10 shows the user interface to edit an existing node. 

 

Fig. 10 Editing an existing node 

4.9 Edit an Existing Flow 

The following are the steps to edit and existing flow. 

• Right-click the flow to be edited. Select “Edit” from the context menu.  

• Edit all options to modify the appropriate parameters for the existing flow.  

• Apply changes by clicking the “Apply” button. 

• Click “Reset” to undo any changes made to the flow since the last “Apply”. 

• Click “Close” when done.  

Figure 11 shows the user interface to edit an existing flow event. 
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Fig. 11 Editing an existing flow 

4.10 Edit an Existing Reception Event 

The following are the steps to edit and existing reception event. 

• Right-click the reception event to be edited. Select “Edit” from the context 
menu.  

• Edit all options to modify the appropriate parameters for the existing 
reception event.  

• Apply changes by clicking the “Apply” button. 

• Click “Reset” to undo any changes made to the reception event since the 
last “Apply”. 

• Click “Close” when done.  
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Figure 12 shows the user interface to edit an existing reception event. 

 

Fig. 12 Editing an existing reception event 

4.11 Delete a Node 

There are a couple ways to delete a node from the scenario. Please note that deletion 
of a node automatically deletes all flows and reception events associated with that 
node. 

4.11.1 From the Application Menu  

The following are the steps to delete a node from the application menu. 

• Click Edit -> Delete -> Node. 

• Select the node to be deleted from the drop-down list.  

• Click “Delete”.  

4.11.2 From the Context Menu 

The following are the steps to delete a node from the context menu. 

• Right-click the node to be deleted, and select “Delete Node” from the 
context menu. 

•  Confirm to delete node.  
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4.12 Delete a Flow 

The following are the steps to delete a flow. 

• Right-click the flow that is to be deleted. 

• Select “Delete” from the context menu.  

4.13 Delete a Reception Event 

The following are the steps to delete a reception event. 

• Right-click the reception event that is to be deleted. 

• Select “Delete” from the context menu.  

4.14 Clear All Events 

The user can delete all communication events for a scenario while preserving all 
the nodes for that scenario.  

• Select Edit -> Clear All Events  

4.15 Edit Color Key of a Node 

The following are the steps to edit the color key of a node. 

• Right-click the color key block in front of the node name  

• Select “Edit Color” from the context menu.  

• Select a color from the color swatch. Click “Ok” when the desired color is 
selected. 

Figure 13 shows the user interface to edit the color key of a node. 
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Fig. 13 Editing color key of a node 

4.16 Use Copy and Paste to Create Events 

The following are the steps to use Copy and Paste features to create new events. 

• Right-click the flow or reception event to be copied. 

• Select “Copy” from the context menu. 

• Right-click the row at the desired time location where the selected flow or 
reception event is to be copied. 

• Select “Paste” from the context menu.  

• The flow or reception event will appear in the scenario. 

4.17 Use Mouse to Adjust Flow Event Times 

The following are the steps to adjust the flow event times using the mouse. 

• Hover the mouse over either the left or right edge of the rectangle, 
representing the start and stop time, respectively, of the flow to be modified. 

• When the mouse cursor changes to a resize cursor type, press the mouse 
button and drag the mouse.  
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• Move the cursor to the desired time location. Consult with the message in 
the status bar for the exact current time location of the mouse. 

• Release the mouse button when the event time is updated to the desired 
value. 

• Note that only start time can be adjusted for continuous flows. 

4.18 Use Mouse to Move a Flow or Reception Event 

The following are the steps to move a flow or reception event using the mouse. 

• Hover the mouse over somewhere in the middle of the rectangle 
representing the flow or reception event to be move. 

• When the mouse cursor changes to the hand cursor type, press the mouse 
button and drag the mouse.  

• Move the cursor to the desired row and/or time location. Consult with the 
message in the status bar for the exact current location of the mouse. 

• Release the mouse button when the move is completed. 

4.19 Save a Scenario 

Once a scenario has been edited, it can be saved when needed. The scenario 
configuration file and MGEN script files will be updated accordingly. 

• Click File -> Save 

4.19.1 Save a Scenario to a Different Name 

The user can specify a different location where a scenario will be saved.  

• Click File -> Save As...  The user is presented with dialog box to save a 
scenario to a different name, as shown in Fig. 14.  

• When prompted, specify a directory to which the scenario can be saved. To 
save to a directory that does not exist, type the name of the directory in the 
save dialog box. That directory will be created, and files will be saved to it. 
For example, the following graphic shows saving the scenario to 
new_scenario folder under the /opt/traffic_gen/scenarios folder. 
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Fig. 14 Saving scenario with a new name 

4.20 Export Scenario Data 

The user can export scenario data into files of other formats, which, in turn, can be 
ingested by other applications.  

4.20.1 Export SDT File 

The exported SDT script file can be used by the SDT3D application to display time-
sequenced data communication among nodes in a scenario. The commands in this 
script are similar to those generated by TrafficGen when it is in SDT3D View, 
described later in the document. 

• Click File -> Export -> SDT File...  

• Specify the file name when prompted. 

4.20.2 Export MGEN Timeline Script 

The exported MGEN timeline script file contains MGEN commands that can be 
used as input to the control orchestrator to command MGEN actors configured 
within the Common Open Research Emulator. 

• Click File -> Export -> MGEN Timeline Script...  

• Specify the script file name when prompted. 
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5. Working Directly With MGEN Files 

The user has the ability to work directly with the MGEN files outside the context 
of a scenario, mainly to modify events in the files. 

5.1 Open Existing MGEN Files 

The following are the steps to open existing MGEN files. 

• Click File -> Open MGEN Files...  

• Navigate to the directory containing the MGEN files. Select and open the 
desired files, as demonstrated in Fig. 15. 

• The data for the selected MGEN files will be displayed in the TrafficGen 
application. When the user chooses to open MGEN files, the application 
workspace assumes the environment of MGEN File Mode, as opposed to 
Scenario Mode, as seen in Fig. 16. 

 

Fig. 15 Opening existing MGEN files 
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Fig. 16 User interface in MGEN file mode 

5.2 Save MGEN Files 

Once MGEN files have been edited, they can be saved. 

• Click File -> Save 

5.3 Main Differences of Working in MGEN File Mode 

The following highlights the differences when working with TrafficGen in MGEN 
file mode. 

• While working in File Mode, the user interface has a different background 
color in the time scale and node list section. 

• The title of the application will include “[MGEN FILES]”. 

• The Save As, Import, Export functions are disabled, and the user will not 
be able to add or delete nodes. 

6. Customizing View of the Scenario Workspace 

6.1 Visibility of Flows and Events 

Flows, Continuous Flows, and Reception Events can be toggled between “visible” 
and “hidden” on the GUI. 
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• Click View and select the appropriate category. A category is visible when 
it is checked. Select and toggle the visibility settings accordingly.  

Figure 17 shows the user interface to change visibility of flows and reception 
events. 

 

Fig. 17 Changing visibility of flows and events 

6.2 Multicast Addresses 

If the user specified multicast addresses as destinations of flows or a group address 
of JOIN/LEAVE reception events, it is possible to filter the scenario view based on 
one or more of the specified multicast addresses. 

• Click View -> Multicast 

• Select the desired multicast address view filter. The events shown in the 
scenario view will reflect the specified filter. 

Figure 18 shows the user interface to filter multicast addresses in the scenario view. 
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Fig. 18 Filtering multicast addresses 

6.3 SDT3D View 

The SDT3D view is the integration feature that links TrafficGen to the SDT3D 
application. SDT3D is a visualization tool developed by the NRL that allows 
users to visualize a real-world representation of node positions, movements, 
and links between nodes.  

The purpose of this integration is to allow the user to “play” or view 
communication flows from one recipient to another in the designed time 
sequence and within the spatial representation displayed in the SDT3D 
application. 

This integration is accomplished by first initiating a network connection with a 
running SDT3D application, and then sending SDT commands to it. 

6.3.1 Prerequisite 

The following are prerequisites before attempting to have TrafficGen work with 
SDT3D. 

• SDT3D is installed and running on a workstation. 

• It has loaded a file or SDT commands that set up the nodes that correspond 
to the MGEN scenario that is currently opened in TrafficGen. 
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• SDT3D is actively listening for commands on a port, via either UDP or 
TCP. 

6.3.2 Operation 

The following are the steps to operate the integration control with SDT3D.  

• Click View -> SDT3D View. The SDT3D Integration Control dialog will 
appear, as shown in Fig. 19. 

• Specify the IP, protocol, and port where SDT3D is listening for commands. 

• Select the desired play speed. 

• Specify the line width value, which will be used to draw links between the 
nodes in SDT3D application. 

• Click Run to start the event play. Observe the links that will be drawn by 
SDT3D when there are ongoing transmission events (flows). 

• Click Pause/Resume button to pause or resume; click the Stop button to 
terminate the flow of SDT commands. 

 

Fig. 19 Integration control with SDT3D 

6.3.3 Visual Examples 

The screenshots in this section illustrate both TrafficGen and SDT3D applications 
while an integration playback of a scenario was in progress. 

In Fig. 20, the SDT3D Integration Control dialog showed it was at the 24-s mark 
of the play process. At the Scenario view of TrafficGen, a vertical line was drawn 
for that particular instant on the time axis and showed that there were 2 active flows 
at that time, from node0 to node1 and from node1 to node2. 
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Fig. 20 TrafficGen user interface when controlling SDT3D 

On the SDT3D application, the corresponding links for those nodes are drawn on 
the map, as seen in Fig. 21. 

 

Fig. 21 SDT3D user interface responding to TrafficGen commands 
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7. Preferences and Options 

7.1 Preferences 

7.1.1 Node Color Setting 

A user can change the color settings of all the flows belonging to a specific node. 
Note that flow color changes reflect the destination node of the transmission, as 
opposed to the source of the transmission. 

To change the color setting of flows for a node: 

• Click Window -> Preferences -> Color Settings...  The user will be 
presented with the Color Chart dialog, as seen in Fig. 22. 

• Click the colored bar next to the node to be edited. This allows change of 
color of all flows destined to that node.  

• Select a color from the color swatch. Click “Ok” when the desired color is 
selected. 

• Click “Ok”.  

 

Fig. 22 Changing node color setting 
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7.1.2 Enable/Disable Tooltip 

The following are the steps to enable and disable the tooltip in the user interface. 

• Click Window -> Preferences  

• Check the “Tooltip” checkbox accordingly. 

7.1.3 Change Destination Address Output Mode 

Use this option to specify if node names (e.g., node_003) or IP addresses (e.g., 10. 
0.5.10) are to be used in the output to MGEN script files. 

• Click Window -> Preferences -> Dest Address Output Mode. 

• Select either “Node Name” or “IP Address”. 

7.2 Scenario Properties 

To edit scenario properties, click:  

• Window -> Properties.  The Scenario Properties dialog box is displayed, as 
shown in Fig. 23. 

 

Fig. 23 Scenario properties 

The Scenario properties window displays several properties of a scenario that a user 
may be interested in. A user can edit some of those scenario properties directly. 

• Name: The name of the scenario.  
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• Nodes: A count of the nodes in this scenario.  

• Events: A count of the number of flows in this scenario. 

• Time span: The length of all the actual activity in this scenario.  

• Location: The directory where the scenario configuration file and all its 
MGEN files reside.  

• Date: The date and time this scenario was created or edited.  

• Time [in hours]: The maximum length of time allowed in this scenario. 
The user can modify this value.  

• Number of Nodes: The number of nodes used to create an empty scenario. 
Default is 100. 

8. Conclusion 

TrafficGen continues to evolve as researchers apply the TrafficGen capabilities to 
a wider variety of scenarios. The following are some of potential features in the 
future roadmap of the application: 

• Templates for transmission patterns. The user will be able to define and 
save transmission message patterns in form of templates. The templates can 
then be made available for reuse when defining flows. This will greatly 
improve efficiency and consistency when defining similar types of events. 

• Better support for multicast addresses. Currently, when multicast 
addresses are used while defining flows and reception events, the user has 
to enter them manually. We will research and implement a way to better 
define and organize the multicast addresses so they can be more easily 
accessible, thus helping to improve overall user experience. 

• Expanded third-party application integration. We will be looking for 
ways for TrafficGen to work with other applications, in terms of in-process 
communication, similar to the current SDT3D integration, as well as out-
of-process collaboration, via data imports and exports. 

• Orchestration of experimentation events outside of network traffic. 
TrafficGen is being considered as the basis for an application that controls 
experimentation scripts to start and stop processes, network node mobility 
models, and communications effects between nodes.  
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List of Symbols, Abbreviations, and Acronyms 

3D 3-dimensional 

ARL  US Army Research Laboratory  

GUI  graphical user interface  

IP  Internet Protocol  

MGEN  multi-generator  

NRL  US Naval Research Laboratory  

NSRL  Network Science Research Laboratory  

PROTEAN  Protocol Engineering Advanced Networking  

SDT3D  Scripted Display Tool 3D 

TCP  Transmission Control Protocol  

UDP  User Datagram Protocol  
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Glossary 

Continuous Flow  A flow that does not have a stop time defined, which means 
the streaming of data continues indefinitely.  

Flow  Streaming of data (transmission event) from a host to another, 
as specified by an ON event in an MGEN file. A flow can be 
terminated by an OFF event.  

MGEN file  A script file that contains a sequence of commands and events 
sent between hosts. Specified parameters include IP, ports, 
data patterns, and other options.  

Reception Event  An event specified in MGEN file that indicates whether a host 
is actively monitoring network data on a particular port(s).  

Scenario  A set of MGEN files and an associated configuration file that 
in a whole contain a series of related sequences of 
communication events to describe a particular story. 
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