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1. Introduction 
This document is the User’s Manual for the Tactical Medical Logistics (TML+) Planning Tool.  This manual is for 

anyone who uses the TML+ software. 

Before you read this manual you need to be comfortable working with the Microsoft Windows environment and 

its applications. For information about this, refer to the separate Microsoft Windows user documentation, 

including the Windows online Help system. 

1.1 What Is TML+? 

The Tactical Medical Logistics Planning Tool (TML+) is a software program designed for Navy and Marine 

Corps medical planners as a simulation tool that models the flow of patients from the point of injury (POI) 

through more definitive care, and an operations research tool that supports systems analysis, operational risk 

assessment, and field medical services planning. 

TML+ incorporates extensive data for over 400 patient conditions and their corresponding medical treatment 

tasks, treatment times, equipment and consumable supplies, transportation assets, medical personnel and 

required skills, and levels of care.  It employs a Monte Carlo method to simulate patient losses due to treatment 

delays and medical complications in order to assess the impact that resource limitations, system bottlenecks, 

skill limitations, and other factors have on them. 

TML+ is a joint project between the Naval Health Research Center (NHRC) and Teledyne Brown Engineering 

(TBE). This project was sponsored by the Bureau of Medicine and Surgery and the Office of Naval Research. 
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TML+ is a versatile decision aid tool that can perform the following: 

• Generate patient conditions for a patient stream in an identified theater. 

• Prioritize treatment and evacuation of patients based on severity of injuries. 

• Model mortality as killed in action, died of wounds as a function of complications, and died of wounds as a 

function of time.  

• Simulate patient flow through a network of medical facilities, including arrival times, wait times, and 

treatment times. 

• Offer the ability to build a generic treatment facility with user-defined medical capability and personnel 

assets. 

• Model routing and utilization of transportation assets.  

• Provide dynamic reports in graph and tabular formats that show medical treatment facility (MTF) status, 

patient disposition, and resource utilization. 

 

Figure 1-1 displays a small sample scenario with patients flowing from four points of injury (POIs) to a Casualty 

Receiving and Treatment Ship (CRTS).  

 

Figure 1-1  Tactical Medical Logistics Planning Tool 
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1.2 Uses for TML+ 

TML+ can help you identify the best course of action for an anticipated patient stream with projected assets. 

You can use TML+ to determine:  

• if a particular treatment facility can successfully handle a specific patient stream.   

• how changing distances between treatment facilities with different capabilities affects patient treatment. 

• which and how many supply, personnel, and transportation assets are utilized by an expected patient 

stream. 

• if one treatment network (type, location, and number of assets) is more efficient for treating patients than 

another.  

TML+ is a versatile tool that allows you to perform different types of planning: 

• Deliberate planning:  use TML+ before deployment to determine those medical assets and treatment 

networks that would optimally treat an expected patient stream. 

• Crisis-action planning:  use TML+ during deployment to reconfigure a treatment network in response to 

contingency events. 

• Near real-time planning:  use TML+ to track how patient treatment and evacuation events proceed as a 

mission is performed. 

1.3 Casualty Flow Overview 

TML+ simulates casualties/patients moving from one medical treatment facility (MTF) to another while 

competing with each other for scarce resources.  

In Figure 1-2 a casualty “arrives” into the medical network at a randomly selected POI.  Any casualty not killed 

in action (KIA) is immediately administered treatment by himself or a fellow warfighter (buddy) using the 

medical supplies available in his first-aid kit. This is known as Self–Buddy Aid (SBA).  

TML+ represents the network of medical treatment 
and evacuation on the battlefield 

Stochastically models the patient flow from the point 
of injury through more definitive care; supports 
systems analysis, operational risk assessment, and 
field medical services planning
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Figure 1-2  Overview of Casualty Flow 
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Treatment is a series of medical tasks based on the casualty’s patient condition (PC) code. A PC task profile 

consists of tasks and average task times, personnel required to perform the task, equipment required for the 

task, and consumables needed for the task. 

Upon completion of treatment, the casualty walks or is carried to the next MTF in the medical laydown (typically 

a First Responder) designated for continued care. Upon entering any MTF, the patient is checked for death due 

to delay in treatment. 

Since there are a finite number of corpsmen, some casualties must wait for treatment (queue) at the first 

responder facility.  The first responder treats the casualty with his available medical supplies. No treatment is 

denied due to exhausted consumable medical supplies (a file is maintained as the program executes to keep 

track of how many consumables are demanded). 

Upon completion of treatment, a patient is returned to duty (RTD), transferred to another functional area (FA), 

or evacuated to the next MTF. The next MTF provides the transportation for the patients. Each MTF has a pool 

of transporters. A transporter is requested for evacuated patients. Patients who need to be evacuated continue 

treatment until the transport arrives. Upon transport arrival, patients are loaded based on the severity of their 

injuries until transport capacity is reached, or a user-defined maximum time at the facility has elapsed. (The 

maximum time at the MTF has a default value defined for a litter-bound patient as the vehicle capacity times 

the loading time per casualty.) When the transport arrives at the next MTF, patients are unloaded based on 

injury severity then queued to receive treatment. 

A patient flows through the network thus until death occurs or he is successfully treated. It should be noted that 

some patients may still remain in the system at the end of the scenario due to task or transportation time and 

resource constraints. 
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2. Understanding TML+ Concepts 
Like most tools, to really learn how TML+ works there are some underlying concepts that you need to 

understand first. Even if you’re familiar with other medical planning tools, TML+ has some unique concepts 

behind it. 

This Chapter explains those concepts, so that you're best prepared to learn the How To Use TML+ information 

later in this manual.  

2.1 What Are Scenarios in TML+? 

In TML+, a Scenario contains your medical laydown and other related information about a particular concept or 

planning mission.  It is a file (extension .tml) that you can place anywhere on your computer (provided you have 

access privileges) or share with colleagues. 

 

2.2 Understanding the Objects of Your Scenario 

With TML+, your scenario is built of "objects." This section helps you understand them better. 

2.2.1 Assembling Your Scenario 

Creating a scenario in TML+ is like building with Lego bricks — you construct your scenario from many smaller 

pieces called "objects." There are different types of objects that have different functions (like a Lego roofing tile 

or corner brick). 

2.2.2 Reusing Objects 

You can reuse some objects many times, in the same scenario or in many scenarios. When you change an 

object, your changes register instantly in each place the object is used. This saves you lots of time, guarantees 

consistency, and makes it far easier to maintain your scenario. 

Chapter 
Two 

Understanding 
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2.2.3 Commonly Encountered Objects 

 These are the TML+ objects you will encounter most often: 

• Casualty Generators.  A stream of casualties/patients that arrives at a randomly generated time and 

location with randomly generated patient conditions. 

• Points of Injury (POIs).  The location at which casualties are wounded. 

• Medical Capabilities.  The fundamental capability of a medical asset, including types of patients that 

can be treated, personnel (doctors, nurses, etc) assigned, and equipment and consumables available.  

This object may be reused and customized. 

• Medical Treatment Facilities (MTFs).  A deployed medical capability.  An MTF may have defined 

hours of operation, move from one location to another, and have evacuation assets. 

• Transportation Types.  The capabilities of an evacuation asset, including speed, capacity, 

loading/unloading times, and other time delays.  This object maybe reused and customized. 

• Transportation Assets.  A vehicle available for evacuating patients. 

• Routes.  An evacuation path from one MTF to another. 

2.3 Naming Objects 

Some TML+ objects must be uniquely named within similar objects.  Objects that must have unique names 

include: 

• Points of Injury (POIs).  Name must be distinct from other POIs. 

• Medical Capabilities.  Name must be distinct from other medical capabilities. 

• Medical Treatment Facilities (MTFs).  Name must be distinct from other MTFs. 

• Transportation Types.  Name must be distinct from other transportation types. 

• Transportation Pools.  Name must be distinct from other transportation pools. 

• Transportation Assets.  Name must be distinct from other transportation assets. 
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2.4 Where Are the Results From a TML+ Run? 

TML+ outputs raw results to a Microsoft Access database (extension .mdb). This database is known as the 

Reports Database because reports are built from these data.  TML+ will create a Reports Database in the 

same folder in which the scenario is located.  You determine the filename, and whether the file is overwritten 

each time you run your scenario…if not overwritten, a new Reports Database is created with each new run, and 

the filename is appended with the current date and time. 

 

2.5 Why Do Casualties Proceed From POI to SBA to 1RSP? 

All scenarios in TML+ assume that the surviving casualty proceeds from a point of injury immediately to 

Self/Buddy Aid (intuitively there is no distance relationship between POI and SBA). After finishing treatment at 

the SBA, the casualty “walks” (or is carried or dragged) to a First Responder (1RSP) location where additional 

medical intervention is applied.  

2.6 Why Is the GIS Disabled? 

The GIS (Geographical Information System) might be disabled because the evaluation period has expired 

(usually 60 days), or the scenario property GIS Status is set to Disabled.  We have to maintain a count of the 

number of TML+ software applications distributed for licensing purposes.    

If your evaluation period has expired, refer to the How to Enable GIS section. 

To change the GIS status for your scenario, refer to the Editing Scenario Properties section. 

 

 





 
 
 
 
 
 
 
 
 

 TML+ User’s Manual 3-1 

 

3. Getting Help 
This section describes how to get help when you have questions or problems using TML+. 

3.1 Many Ways to Get Help 

There are many ways to get help when you have questions or problems while working with TML+. 

Help Yourself 

Most people like to be able to find their own answers. It's often quicker than other ways, and it's usually more 

satisfying. There are a few options when you want to find the answers yourself. If you can't find the answer 

quickly, don't hesitate to ask us for help directly. 

• Visit the TML+ home page at www.nhrc.navy.mil/programs/tml. 

• Use the standard HTML Help system that ships with TML+.  

• Use the TML+ Help Center…quick access to product documentation and multimedia tutorials. 

• Use the product documentation…TML+ Methodology Manual, TML+ Release Notes, and Mortality Modeling 

in TML+. 

• Use the multimedia tutorials...Overview Tutorial, Scenario Building Tutorial, and Reports Tutorial. 

• Use the sample scenarios. 

Ask Us for Help 

We pride ourselves on our responsive, friendly support.  If you have a question, problem, or suggestion about 

TML+, check our Web site at www.nhrc.navy.mil/programs/tml. Or feel free to email us at tml@nhrc.navy.mil. 
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3.2 Using TML+’s HTML Help System 

The TML+ HTML Help System contains most of the information you'll need to successfully work with TML+. 

To access the HTML Help System, start TML+ and from the Main menu of TML+, choose Help > Help 

Contents. The HTML Help file opens, and the most recently viewed tab is shown first. 

Find the information you need by: 

• Using the Contents tab. Expand topics to find more information. 

• Using the Index tab to find topics containing those terms that have been indexed. 

• Using the Search tab to find all occurrences of a word in the Help file, no matter how trivial. 

3.3 Using TML+’s Help Center 

The TML+ Help Center contains links to the TML+ documentation, multimedia tutorials, and the TML+ Web site.  

To access the HTML Help Center, start TML+ and from the Main menu of TML+, choose Help > Help Center.  

or From Windows…choose Start > Programs > TML+ > Help Center. Note that tutorials are multimedia 

presentations that require audio. 

The Help Center window (see Figure 3-1) appears. 

 

Figure 3-1  TML+ Help Center 
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3.4 Using TML+’s Documentation 

The TML+ Documentation set helps you better understand the TML+ application.   

To access the documentation from Windows, choose Start > Programs > TML+ > Documentation. Select the 

documentation you wish to view.  Note that documentation requires Adobe Reader to view.  

The documents are: 

• The TML+ Release Notes, which detail the hardware and software requirements for TML+ and list the new 

features and bug fixes. 

• The TML+ Methodology Manual, which explains technical details of the simulation and data used by TML+. 

• Modeling Dynamic Casualty Mortality Curves in TML+, which explains the approach used to determine 

an acceptable model for the mortality function in TML+. 

3.5 Using TML+’s Tutorials 

The TML+ Tutorials provide step-by-step instruction of TML+. 

To access the tutorials, use the TML+ Help Center.  Note that tutorials are multimedia presentations that 

require audio.  

The tutorials are: 

• The TML+ Overview Tutorial, which provides an overview of TML+ features. 

• The Scenario Building Tutorial, which outlines how to build a scenario. 

• The Reports Tutorial, which provides an overview of the various TML+ reporting features. 



 

3-4 TML+ User’s Manual 

3.6 Using Sample Scenarios 

The sample scenarios that ship with TML+ provide an excellent resource for understanding how scenarios are 

built. 

To access the sample scenarios from Windows, choose Start > Programs > TML+ > Sample Scenarios. 

Select the scenario you wish to open. 

The sample scenarios are: 

• 1A to 1B to CRTS in SWA (Southwest Asia) scenario is set in Iraq with casualties—wounded in action 

(WIA), nonbattle injury (NBI), and disease (DIS)—arriving over 24 hours.  The medical laydown has patients 

flowing from four points of injury (POIs) to a Casualty Receiving and Treatment Ship (CRTS).   

• 1A to 1B to CRTS in NEA (Northeast Asia) scenario is set along the 38th parallel with casualties (WIA, 

NBI, and DIS) arriving over 72 hours.  The medical laydown has patients flowing from six POIs to a CRTS.   

• OIF1 Days 12-17 scenario is an illustrative Operation Iraq Freedom (OIF) medical laydown for Day 12 (03-

30-03) thru Day 17 (04-04-03).   

• STOM with 2 FRSS scenario is a future concept known as Ship to Objective Maneuver (STOM). One 

Forward Resuscitative Surgical System (FRSS) lands on the objective with a Vertical Maneuver Element 

(VME) while the second FRSS moves with a Surface Maneuver Element (SME). Casualties are based on 

historical data. Additionally, 2 mass casualty events are scheduled for the SME group and VME group, 

respectively.   
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4. Introducing the TML+ Interface 
This chapter describes the work environment and the interface elements you will encounter while you're using 

TML+.  The two interfaces that you need to be familiar with are the Scenario Interface and the Reports 

Interface. 

4.1 Scenario Interface 

The Scenario Interface (see Figure 4-1) helps you build and execute TML+ scenarios.  The Scenario Interface 

has several components, which are described in this section: 

• Network View • Map View 

• Scenario Explorer • Common Data Explorer 

• Properties Window • Assumptions Window 

• Main Menu Bar • Toolbars 
 

Map ViewMap ViewNetwork ViewNetwork View

AssumptionsAssumptions

PropertiesProperties

Scenario 
Explorer

Scenario 
Explorer

Common 
Data 

Explorer

Common 
Data 

Explorer

Title BarTitle Bar

Main Menu BarMain Menu Bar

ToolbarsToolbars

 

Figure 4-1  The Scenario Interface helps you build and execute TML+ scenarios 

Chapter 
Four 

Introducing 
the TML+ 
Interface 
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4.1.1 The Network View 

The Network View (see Figure 4-2) displays a graphical view of your scenario. Most of your scenario building 

will take place in the Network View.  You drag and drop either medical capability or transportation types from 

the Common Data Explorer to create your scenario.  You create evacuation routes by placing your mouse over 

an MTF until the cursor becomes a “hand”     then click and drag a line to the receiving MTF.  When an 

object is selected in the Network View, the object’s properties will be displayed in the Properties Window. 

Points of Injury 
(POIs)

Points of Injury 
(POIs)

Transportation 
Pool with Assets
Transportation 

Pool with Assets

Medical 
Treatment 

Facilities (MTFs)

Medical 
Treatment 

Facilities (MTFs)

Evacuation 
Routes

Evacuation 
Routes

 

Figure 4-2  Network View 
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4.1.2 The Map View 

The Map View (see Figure 4-3) displays a geographical view of your scenario.  Medical treatment facilities are 

positioned based on their latitude and longitude.  You get a feel for the obstacles and terrain that affect your 

mission in this window.  You can move an MTF by clicking and dragging it to a new location.  Any evacuation 

routes attached to the MTF will have their distances automatically recomputed based on the great circle 

distance.  When an MTF is selected in the Map View, its properties will be displayed in the Properties Window. 

Note that the Map View is only available when the Geographical Information System (GIS) is enabled. 

Medical 
Treatment 

Facilities (MTFs)

Medical 
Treatment 

Facilities (MTFs)

Map View Status BarMap View Status Bar

 

Figure 4-3  Map View 
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4.1.3 The Scenario Explorer 

The Scenario Explorer (see Figure 4-4) contains the TML+ objects that define your scenario.  Scenario 

objects may have additional properties that will be displayed in the Properties Window when the object is 

selected. 

List of all casualty streams.

List of points of injury.

List of all medical treatment facilities.

List of all transportation pools.

Each pool contains a list of 
tranportation assets.

Scenario Name

Auto Hide

 

Figure 4-4  Scenario Explorer 

The Scenario Explorer window is a “dockable” window that may be grouped or stacked so that it is selectable 

with a tab.  Auto-hiding allows the Scenario Explorer to move out of the way when not needed and fly back out 

when desired. 
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4.1.4 The Common Data Explorer 

The Common Data Explorer (see Figure 4-5) contains predefined medical capabilities and transportation 

types.  You may drag and drop these objects onto the Network View to build your scenario.  Common objects 

may have additional properties that will be displayed in the Properties Windows when the object is selected.   

The Common Data Explorer also contains additional underlying data (e.g., PC codes and distributions, supply 

list, task list). 

List of predefined “Land Based” medical capability.

List of predefined “Sea Based” medical capability.

List of predefined “Sea” transportation types.

Database contains patient condition codes, PC 
distributions, supply list, and task list.

List of predefined “Ground” transportation types.

List of predefined “Air” transportation types.

Assets are further categorized as “Fixed Wing”
or “Rotor Wing”.

Casualty collection point medical capability.

 

Figure 4-5  Common Data Explorer 

The Common Data Explorer window is a “dockable” window that may be grouped or stacked so that it is 

selectable with a tab.  Auto-hiding allows the Common Data Explorer to move out of the way when not needed 

and fly back out when desired. 
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4.1.5 The Properties Window 

The Properties Window (see Figure 4-6) displays information (or properties) associated with the selected 

TML+ object.  

 

Properties that are 
dimmed may not be 
modified (read-only).

Some properties have a “…”
button, this indicates that an 
additional window (or dialog) 
will be displayed. 

Displays additional information 
about the selected property.

Categorize properties.
Alphabetize properties.

 

Figure 4-6  Properties Window 

The Properties Window is a “dockable” window that may be grouped or stacked so that it is selectable with a 

tab.  Auto-hiding allows the Properties Window to move out of the way when not needed and fly back out when 

desired. 
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4.1.6 The Assumptions Window 

The Assumptions Window (see Figure 4-7) lists the assumptions built into TML+.  Each assumption is 

categorized (Simulation or Data), assigned a module (Casualty Estimation, Care Providing, or Transportation), 

and designated as modifiable by the end user. 

 

Figure 4-7  Assumptions Window 

 

4.1.7 The Main Menu Bar 

The Main Menu Bar (see Figure 4-8) contains a number of menus that tell TML+ what to do. Each menu 

contains a list of commands and sometimes sub-menus.  The menus shown depend on the context of the 

software. 

Disabled options are 
not available in the 
current context

Selected Menu

An arrow means a sub 
menu is available

Clicking an option will cause 
the command to be carried out

 

Figure 4-8  Menu Bar 

Some of the options carry out commands immediately, and others display a window (dialog) so that you can 

enter additional information. If an option is followed by "...", it will display a window. Otherwise, the command is 

carried out immediately. 
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4.1.8 The Standard Toolbar 

The Standard Toolbar gives you quick access to commonly used commands in the TML+ environment. 

 

 

New
  S

ce
na

rio

Ope
n  

Sce
na

rio

Sav
e  

Sce
na

rio

Cut Cop
y

Pas
te

Dele
te

Toolbar 
Options

 

This Button Does the Same as This Shortcut 

New Scenario File > New Ctrl + N 

Open Scenario File > Open… Ctrl + O 

Save Scenario File > Save Ctrl + S 

Cut Edit > Cut Ctrl + X 

Copy Edit > Copy Ctrl + C 

Paste Edit > Paste Ctrl + V 

Delete Edit > Delete Delete 

 

4.1.9 The Execute Toolbar 

The Execute Toolbar allows you to quickly run the scenario. 

 

Run
  S

ce
na

rio

Toolbar 
Options

 

This Button Does the Same as This Shortcut 

Run Scenario Simulation > Run F5 
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4.1.10 The Time Toolbar 

The Time Toolbar allows you to control the current time of the scenario for editing.   

 
Enter time in hrs, 
min, or day units.

Use slider to 
change time.

 
 

MTFs that are not operational (unavailable) will be displayed with a dimmed icon.  As the time changes, MTF 

locations will be updated in the Map View, and distances between MTFs will be updated in the Network View.  

Figure 4-9 illustrates a sample scenario with the time set at 22 hours. 

FRS.2 is not available.

Distances are based on 
locations of MTFs at 22 hrs.

 

Figure 4-9  Sample scenario with time toolbar set to 22 hours 
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4.1.11 The Zoom Toolbar (Network View) 

Use the Zoom Toolbar to control how large or small objects in the Network View are displayed. 

 

Toolbar 
Options

Zoo
m In

Zoo
m O

ut

Zoo
m N

orm
al

Zoo
m to

 Fit

  

This Button Does This 

Zoom In Magnifies the size of the objects in the Network View. 

Zoom Out Shrinks the size of the objects in the Network View. 

Zoom Normal The objects will be displayed at their original size. 

Zoom to Fit Adjusts the magnification so that all the objects appear in the window. 

 

4.1.12 The Format Toolbar (Network View) 

Use the Format Toolbar to align objects in the Network View.  The first selected object is known as the primary 

selection (displayed with a green outline). The other selected objects are displayed with a blue outline. 
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Sam
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Sam
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Toolbar 
Options

  

This Button Does This 

Align Left Sides Aligns the left edges of all selected objects with the primary selection. 

Align Horizontal Centers Aligns the horizontal centers of all selected objects with the primary 

selection. 

Align Right Sides Aligns the right edges of all selected objects with the primary selection. 

Align Tops Aligns the top edges of all selected objects with the primary selection. 

Align Vertical Centers Aligns the vertical centers of all selected objects with the primary selection. 

Align Bottoms Aligns the bottom edges of all selected objects with the primary selection. 

Same  Widths Makes the widths of all selected objects the same as the primary selection. 

Same Heights Makes the heights of all selected objects the same as the primary selection. 

Same Size Makes the size of all selected objects the same as the primary selection. 
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4.1.13 The Map Tools Toolbar (Map View) 

The Map Tools Toolbar gives you quick access to commonly used commands in the Map View. 

 

Full
 E

xte
nt

Zoo
m In

Zoo
m O

ut

Pan Sele
ct

Mea
su

re

La
ye

rs…

Toolbar 
Options

  

This Button Does The Same As This Does This 

Full Extent Map > Full Extent Includes all features in all map layers. 

Zoom In Map > Zoom In Increases the map scale by a factor of two, 
centered on a point you click with the mouse. 

You can also zoom in by dragging a rectangle 
with the mouse. 

Zoom Out Map > Zoom Out Decreases the map scale, centered on a point 
you click with the mouse. 

Pan Map > Pan Changes the center of the map by dragging the 
mouse from one point to another. 

Select Map > Select Changes the location of an MTF by selecting the 
object and dragging to a new location. 

Measure Map > Measure Measures the distance by dragging a line and 
finishing with a double click.  

You can drag a multi-segment line. 

Layers Map > Layers… Displays the map properties dialog. 

 

4.1.14 The Map View Status Bar 

The Map View Status Bar at the bottom of the Map View window tells you about the current status of the map. 

 

 

Latitude Map Scale Ratio DistanceLongitude

 
 

This  Tells You 

Latitude The latitude of the current mouse location. 

Longitude The longitude of the current mouse location. 

Map Scale Ratio Ratio of the size of the map in screen units and map units. 

Distance Great circle distance returned from the measure tool. Units depend on 

preference setting. 
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4.1.15 The Common Data Viewer – Patient Condition Code Tab 

The PCs Tab (see Figure 4-10) allows you to view all of the patient condition (PC) codes for TML+. 

 

 

Figure 4-10 Common Data Viewer – PCs Tab 

 

4.1.16 The Common Data Viewer – PC Distribution Tab 

The PC Distribution Tab (see Figure 4-11) allows you to view all of the PC distributions defined for TML+.  

The PC distributions are named SWA, NEA, Europe, and OIF. 

 

 

Figure 4-11 Common Data Viewer – PC Distribution Tab 
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4.1.17 The Common Data Viewer – Supplies Tab 

The Supplies Tab (see Figure 4-12) allows you to view all of the supplies defined for TML+.  

 

 

Figure 4-12  Common Data Viewer – Supplies Tab 

 
4.1.18 The Common Data Viewer – Tasks Tab 

The Tasks Tab (see Figure 4-13) allows you to view all of the medical tasks defined for TML+.  

 

 

Figure 4-13  Common Data Viewer – Tasks Tab 
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4.1.19 The FA Common Data Viewer – General Properties Tab 

The General Tab (see Figure 4-14) allows you to view general properties defined for a functional area (FA) and 

edit user-created medical capabilities.  

 

 

Figure 4-14  FA Common Data Viewer – General Tab 

4.1.20 The FA Common Data Viewer – Inventory Tab 

The Inventory Tab (see Figure 4-15) allows you to view an inventory defined for an FA and edit user-created 

medical capabilities.  

 

 

Figure 4-15  FA Common Data Viewer – Inventory Tab 
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4.1.21 The FA Common Data Viewer – Tasks/Usage Tab 

The Tasks/Usage Tab (see Figure 4-16) allows you to view the tasks used for each PC for an FA.  The task 

time is based on an exponential distribution using the input task time. The % Patient is used to randomly 

determine whether the task is performed for the patient.  Note that not all tasks are performed. 

 

 

Figure 4-16  FA Common Data Viewer – Tasks/Usage Tab 

 
4.1.22 The FA Common Data Viewer – Treatment Priority/Percentages Tab 

The Treatment Priority/Percentages Tab (see Figure 4-17) allows you to view the treatment priority and task 

percentages for an FA.  The percentage is used to randomly determine whether the FA accepts the patient 

(based on PC). 

 

 

Figure 4-17  FA Common Data Viewer – Treatment Priority/Percentages Tab 
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4.1.23 The FA Common Data Viewer – GTS Tab 

The GTS Tab (see Figure 4-18) allows you to view the Generic Task Sequence, or order, in which the tasks will 

be performed for an FA.  Note that not all tasks are performed. 

 

 

Figure 4-18  FA Common Data Viewer – GTS Tab 

 
4.1.24 The FA Common Data Viewer – Personnel Tab 

The Personnel Tab (see Figure 4-19) allows you to view personnel available for an FA and edit user-created 

medical capabilities. 

 

 

Figure 4-19  FA Common Data Viewer – Personnel Tab 
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4.1.25 The Points of Injury Probabilities Editor 

The Points of Injury Probabilities Editor (see Figure 4-20) allows you to revise ALL POI probabilities.  The 

editor also provides a convenient Normalize button to quickly change all probabilities so that they sum to one.  

Note that that the probabilities must sum to one or an error will be issued upon executing the scenario. 

 

 

Figure 4-20  POI Probabilities Editor 

 
4.1.26 The MTF Availability Editor 

The MTF Availability Editor (see Figure 4-21) allows you to schedule those times that the MTF will be 

available. 

 

 

Figure 4-21  MTF Availability Editor 
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4.1.27 The Route Maneuver Editor 

The Route Maneuver Editor (see Figure 4-22) allows you to simulate movement by varying the distances 

between MTFs.  Simple linear interpolation is used to determine the distance between two entries. Note that the 

Maneuver Table CANNOT be changed if the GIS is enabled.  Use the Map View and the time toolbar to enter 

the necessary maneuver.  

 

 

Figure 4-22  Route Maneuver Editor 

 

4.1.28 The MTF Future Waypoint Editor 

The MTF Future Waypoint Editor (see Figure 4-23) allows you to enter the latitude and longitude of an MTF at 

specified times.  The distance between any two MTFs can be determined by simple linear interpolation and the 

great circle distance algorithm.  Note that the Waypoint Table CANNOT be changed if the GIS is disabled.  

 

 

Figure 4-23  MTF Future Waypoint Editor 
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4.1.29 The Transportation Patient List Editor 

The Transportation Patient List Editor (see Figure 4-24) allows you to select which patient condition (PC) 

codes (and patients) may request an evacuation asset.  In addition, the editor allows you to select which 

patients may be loaded.   

 

 

Figure 4-24  Transportation Patient List Editor 
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4.2 Reports Interface 

The Reports Interface (see Figure 4-25) helps you analyze your scenario’s output.  The Reports Interface has 

several components, which are described in this section: 

• Reports Explorer • Reports 

• Properties Window • Consolidation Reports 

• Main Menu Bar • Toolbars 
 

Reports 
Explorer
Reports 
Explorer

PropertiesProperties

Title BarTitle Bar

Main Menu BarMain Menu Bar

ToolbarsToolbars

ReportReport

 

Figure 4-25  The Reports Interface helps you analyze your scenario’s output 
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4.2.1 The Reports Explorer 

The Reports Explorer (see Figure 4-26) is the primary means of report navigation.  Reports are grouped into 

four categories: Casualty Statistics, Care Providing, Transportation, and General Information.  Each category is 

a folder in the Reports Explorer.  In the diagram below, the Care Providing folder is open.  All reports listed 

under the folder pertain to Care Providing.  By opening a report folder, each available viewing format is listed.  

The report selected will be displayed in the Reports Window.  

List of Care Providing reports.

List of Transportation reports.

List of Casualty Statistics reports.

List of General Information reports.

Auto Hide

 

Figure 4-26  Reports Explorer 

The Reports Explorer window is a “dockable” window that may be grouped or stacked so that it is selectable 

with a tab.  Auto-hiding allows the Properties Window to move out of the way when not needed and fly back out 

when desired 
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4.2.2 The Reports Window 

The Reports Window displays the selected report from the Reports Explorer.  Reports may be either tables 

(see Figure 4-27) or charts (see Figure 4-28). 

 
Chart Title.

Filter Data.

Column Grouping.

Sorting

Selecting data 
for copy/paste 
or exporting.

 

Figure 4-27  Casualties by Final Disposition table 

Chart Options.
Chart Title.

 

Figure 4-28  Casualties by Final Disposition chart 
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4.2.3 The Report Properties Window 

The Reports Properties Window (see Figure 4-29) displays information (or properties) associated with the 

selected report.  Properties vary, depending on the report selected and include things like Custom Title, and 

Report Options. All reports have a Report Type, and those with multiple replications have a Replication Number 

option.  

 

Displays additional information 
about the selected property.

Categorize properties.
Alphabetize properties.

 

Figure 4-29  Report Properties Window 

 
4.2.4 The Report Selection Toolbar 

The Report Selection Toolbar (see Figure 4-30) provides an optional style of report navigation.  You may 

choose a category and a report via convenient drop-down lists. 

 

 

Figure 4-30  Report Selection Toolbar 

 
4.2.5 The Report Options Toolbar 

The Report Option Toolbar (see Figure 4-31) provides quick access to certain report options, such as 

replication, report type, MTF, FA, and Period of Time.  The options on the Report Option Toolbar vary from 

report to report. 

 

 

Figure 4-31  Report Option Toolbar 
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4.2.6 The Report Standard Toolbar 

The Report Standard Toolbar gives you quick access to commonly used commands in the reporting 

environment. 

Cop
y

Exp
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t
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Toolbar 
Options

 

This Button Does This 

Copy Copies the report to the clipboard. 

Export Exports the report.  Tables are exported as comma separated data files.  

Charts are exported as bitmap or windows metafiles. 

Print Prints the report.  The size of the printout depends on the size of the 

displaying report window. 

Switch User Formats Switches between the two user-defined formats (available in Preferences). 

 

 

4.2.7 The Report Comparison Toolbar 

The Report Comparison Toolbar allows you to quickly compare two or more scenario output data. 

Toolbar 
Options

Com
pa

re 
Rep

ort
s

 

This Button Does the Same as This Does This 

Compare Reports Report > Compare Reports Compares two or more scenario output data. 
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4.2.8 The Charting Options Toolbar 

The Charting Options Toolbar allows you to customize visual attributes of the chart. 
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This Button Does This 

Personalized Charts Allows the user to save or load previous charts. 

Gallery Allows the user to select a new chart type. 

Anti-Aliasing Activates or disables anti-aliasing.  Anti-aliasing removes the “jaggy” lines. 

Palette Selector Assigns selected color palettes to chart elements. Helps everything look 

consistent. 

3D/2D Makes the chart appear 3D or 2D. 

Rotate View Allows the user to rotate the view of the chart. Only applies to 3D charts. 

Rotate Around Y Axis Allows the user to rotate the view of the chart around the Y axis. Only 

applies to 3D charts. 

Rotate Around X Axis Allows the user to rotate the view of the chart around the X axis. Only 

applies to 3D charts. 

Clustered (Z Axis) Displays the chart as clustered; otherwise, the chart displays the series side 

by side. 

Axes Setting Allows the user to change axes properties. 

Point Labels Displays or hides the point labels. 

Data Editor Displays or hides the Data Editor. 

Legend Box Displays or hides the Legend Box. 

Zoom Enables or disables zooming. 

Properties Displays the Chart Properties dialog. 
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4.2.9 The Report Alerts Editor 

The Report Alerts Editor (see Figure 4-32) allows you to program TML+ to signal you when defined criteria 

occur in the reports. For example, if you want to know when consumable supplies are depleted, you can set an 

alert to highlight those cells in which the supply quantity is less than zero.  Alerts may also be exported or 

loaded using the Alerts Editor. 

 

Figure 4-32  Report Alerts Editor 
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4.2.10 The Consolidated Reports Editor 

The Consolidated Reports Editor (see Figure 4-33) allows the user to combine a group of reports into one 

presentation.  The consolidated reports may display either two or four reports per page.  Consolidated Reports 

may be saved, loaded, and viewed.  

 

Figure 4-33  Consolidated Reports Editor 
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4.2.11 The Report Comparison Editor 

The Report Comparison Editor (see Figure 4-34) allows the user to compare results from one scenario run to 

results from other scenario runs. For example, if you are interested in learning whether including another 

transportation asset alleviates a delay in treatment, you can look at the “Task Time per Casualty in MTF” report 

before and after you add a transport asset to a scenario.  The user selects the Comparison Database, the Color 

and the Replication number to compare to the current database. 

 

Figure 4-34  Reports Comparison Editor 
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5. The Planning Process With TML+ 
TML+ basically works like this: 

1. Start the TML+ application. 

2. Select a defined scenario or create a new scenario. 

3. Build your scenario laydown. 

a. Enter the time period of your scenario in hours or days. 

b. Create a stream (or streams) of casualties. 

c. Create a medical network by dragging and dropping existing medical capabilities. 

d. Create evacuation routes by drawing routes between MTFs. Note that if the Map View is enabled, 

the route’s distance is automatically computed. 

e. Add transportation assets by dragging and dropping existing transportation types onto the MTFs. 

4. Execute the scenario. 

5. View various output reports on casualty generation, care providing, and transportation. 

 

If conducting sensitivity analysis: 

1. Change a parameter. 

2. Execute the scenario. 

3. View various output reports on casualty generation, care providing, and transportation. 

4. Compare the two runs. 

 

 

 

Chapter 
Five 

The Planning 
Process with TML+ 
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6. How to Build TML+ Scenarios 
A scenario is composed of four user-defined elements:  Casualty Generators, Medical Treatment Facilities, 

Routes, and Transportation Assets.  Each element must be added to the scenario and the appropriate 

properties edited. 

6.1 Working With Scenarios 

TML+ offers five preconfigured scenarios to assist the user in building a scenario: 

1. First Responder (1RSP) to Battalion Aid Station (BAS) to Casualty Receiving Treatment Ship (CRTS) 

2. First Responder to BAS to Surgical Company (SC) to CRTS 

3. First Responder to BAS to Forward Resuscitative Surgical System (FRSS) to CRTS 

4. First Responder to BAS/Shock Trauma Platoon (STP) to CRTS 

5. First Responder to STP/FRSS to CRTS 

 

Figure 6-1 shows an example of configuration 3 displayed in the Network View.  The user can use one of the 

original five configurations or build on them by adding or modifying any of the four elements to represent more 

sophisticated and realistic treatment networks for various tactical scenarios.  All configurations in TML+ assume 

the surviving casualty proceeds from a Point of Injury (POI), where Self-Buddy Aid (SBA) is received, to a First 

Responder  location. 

 

Figure 6-1  Preconfigured scenario with FRSS 
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6.1.1 Creating a New Scenario 

1. From the Main menu, choose File > New.  

or From the Standard toolbar, click the  button. 

or Click the CTRL+N key. 

The New Scenario dialog appears. 

      

2. Select one of the starting configuration scenarios, and click the OK button. 

TML+ opens the scenario and displays its contents in the various views. 

 

6.1.2 Opening a Scenario 

1. From the Main menu, choose File > Open.  

or From the Standard toolbar, click the  button. 

or Click the CTRL+O key. 

or From the Main menu, choose File > Recent Scenarios. Select the desired scenario. 

The standard Open dialog appears. 

2. Select the scenario you want to open from the browser, and click the OK button. 

TML+ opens the scenario and displays its contents in the various views. 
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6.1.3 Saving a Scenario 

1. From the Main menu, choose File > Save.  

or From the Standard toolbar, click the  button. 

or Click the CTRL+S key. 

The scenario contents will be saved to the file.  

If you are in a new scenario that has not yet been saved, the standard Save As dialog appears. 

a) Navigate to where you would like to save your scenario.  

b) Enter the file name and click Save. 

 

6.1.4 Deleting a Scenario 

TML+ creates a separate .tml file for each scenario. You can delete the scenario using Windows Explorer. 

1. Open Windows Explorer. 

2. Navigate to the folder that contains the TML scenario you want to delete.   

3. Right-click the scenario icon and click Delete.   

 

6.1.5 Editing a Scenario’s Properties 

The properties of a scenario may be changed via the Properties Window.  Refer to The TML+ Objects chapter 

for detailed information regarding each property. 
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6.1.6 Print Previewing the Network View of a Scenario 

1. Make the Network View active by clicking anywhere in the Network View window.  

or From the Main menu, choose View > Network.  

 

2. From the Main menu, choose File > Print Preview.  

The standard Print Preview dialog appears.  

 

6.1.7 Printing the Network View of a Scenario 

1. Make the Network View active by clicking anywhere in the Network View window.  

or From the Main menu, choose View > Network.  

 

2. From the Main menu, choose File > Print.  

or Click the CTRL+P key. 

The standard Print dialog appears.  

3. Modify the print parameters as needed, and click the OK button. 

The Network View will be printed. 

 

6.1.8 Print Previewing the Map View of a Scenario 

The Map View is only displayed if the GIS is enabled. 

1. Make the Map View active by clicking anywhere in the Map View window.  

or From the Main menu, choose View > Map.  

 

2. From the Main menu, choose File > Print Preview.  

The standard Print Preview dialog appears.  

 

6.1.9 Printing the Map View of a Scenario 

1. Make the Map View active by clicking anywhere in the Map View window.  

or From the Main menu, choose View > Map.  

 

2. From the Main menu, choose File > Print.  

or Click the CTRL+P key. 

The standard Print dialog appears.  

3. Modify the print parameters as needed, and click the OK button. 

The Map View will be printed. 
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6.2 Working With Casualty Generators 

TML+ offers three ways to generate casualties — repeatable rates, table rates, and user-defined rates. 

 
6.2.1 Adding a Repeatable Rate Casualty Generator 

The rate option is suggested if you want to generate a steady casualty stream of one or more casualty type: 

wounded in action (WIA), disease (DIS), or nonbattle injury (NBI). 

The rate you enter in this generator is repeated until the end of the scenario. For example, if you enter a rate of 

10 WIAs every 24 hours for a 72-hour scenario, the rate is repeated 3 times and approximately 30 casualties 

are stochastically generated.  

1. From the Main menu, choose Insert > Casualty Generator > Insert Rate.  

or Click the casualty generator folder in the Scenario Explorer with the right mouse button to obtain the 

context menu, select Insert Rate. 

 

A casualty generator titled “CG Rate” will be added to the Casualty Generator folder in the Scenario 

Explorer.  

 

6.2.2 Adding a Casualty Table  

The Casualty Table option is suggested if you want to model a pulse or pause in the casualty stream.  Casualty 

generator by table requires you to enter the number and type of casualties for one or more time periods. Like 

the casualty generator by rate, each generator generates one type of patient (WIA, DIS, or NBI).  

Unlike the rate option, the numbers you enter for each casualty type are generated only once. Therefore, you 

identify a rate per block of time. For example, if you enter 10 casualties for 24 hours and 15 for 48 hours, then 

approximately 10 casualties are stochastically generated for the first 24 hours and 15 for hours 25 through 48.   

1. From the Main menu, choose Insert > Casualty Generator > Insert Table.  

or Click the casualty generator folder in the Scenario Explorer with the right mouse button to obtain the 

context menu, select Insert Table. 

 

A casualty generator titled “CG Table” will be added to the Casualty Generator folder in the Scenario 

Explorer.  
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6.2.3 Adding a User-Defined Casualty Stream  

The user-defined option is suggested if you want to use a patient stream from another software program. The 

user-defined casualty generator allows you to override TML+’s stochastic patient stream generation. You enter 

the arrival time, PC code, and POI for each casualty.   

Note that the TML+ database is structured according to PC codes. Any patient streams you paste into TML+ 

must use PC codes.  

1. From the Main menu, choose Insert > Casualty Generator > Insert User Defined.  

or Click the casualty generator folder in the Scenario Explorer with the right mouse button to obtain the 

context menu, select Insert User Defined. 

 

A casualty generator titled “CG User Defined” will be added to the Casualty Generator folder in the Scenario 

Explorer.  

 

6.2.4 Importing a CASEST Casualty Table 

TML+ is able to import relevant properties of a casualty stream generated by the Casualty Estimation Tool 

(CASEST v.4.0.2) as a new casualty generator.  Because CASEST produces random PC codes using methods 

similar to TML, the CASEST import is used only to retrieve a casualty rate. 

1. From the Main menu, choose Insert > Casualty Generator > Import CASEST Casualty Table.  

or Click the casualty generator folder in the Scenario Explorer with the right mouse button to obtain the 

context menu, select Import CASEST Casualty Table. 

 

2.  Browse to locate the CASEST file you wish to import.  Select Open. 

 

CASEST represents data in terms of forces, or collections of people, who participate in battles.  The closest 

TML+ equivalent is a POI (point of injury) that defines the geographical location of the source casualty 

stream.  However, because a large force may have multiple POIs, the importer must allow complex mapping 

between forces and POIs.  After selecting the source of the CASEST data, the first step in the import 

process is to ask the user for force-to-POI mappings.  A single force can be assigned to multiple POIs in the 

dialog box. 

3.  Assign the CASEST forces to POIs.  Click OK. 
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After the user completes the force-to-POI mapping, the import begins.  TML+ first reads the number of the first 

day on which any casualties occur in CASEST.  If the CASEST casualty stream does not start on the first day 

of the output data, TML+ asks the user whether to make the imported casualty table start on the first day of the 

TML+ simulation or on the day specified by CASEST. 

4. Enter the Day you wish the imported casualty table to begin.   Click OK. 

5. Choose for TML+ to automatically set the KIA ratio based on the CASEST KIA rate or set the KIA ratio to a 

specified number. 

Refer to the TML+ Methodology Manual for a detailed description of importing CASEST data. 

 

 

 

6.2.5 Selecting a Casualty Generator 

1. In the Scenario Explorer > Casualty Generator folder, click on the icon/name of the desired casualty 

generator.  

 

The casualty generator will be highlighted and its properties will be displayed in the Properties Window.  
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6.2.6 Copying a Casualty Generator 

1. Select the Casualty Generator to copy.  

2. From the Main menu, choose Edit > Copy.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+C key. 

or Click the casualty generator with the right mouse button to obtain the context menu, select Copy. 

The casualty generator will be copied to the clipboard.  

6.2.7 Pasting a Casualty Generator 

1. Select the Casualty Generator folder in the Scenario Explorer.  

or Select any Casualty Generator. 

2. From the Main menu, choose Edit > Paste.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+V key. 

or Click a casualty generator with the right mouse button to obtain the context menu, select Paste. 

A casualty generator titled “Copy of xxx” will be added to the Casualty Generator folder in the Scenario 

Explorer.  

6.2.8 Editing a Casualty Generator’s Properties 

The properties of a casualty generator may be changed via the Properties Window.  Refer to The TML+ 

Objects chapter for detailed information regarding each property. 
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6.2.9 Setting the KIA Ratio of All Casualty Generators 

Killed in action (KIA) refers to troops who die on the battlefield and receive no medical care.  KIA is entered as 

a ratio. The numerator is the number of troops expected to be killed. The denominator is the number of 

wounded in action (WIA). For example, if the KIA ratio is 1 to 100 and your scenario has 500 WIAs, 

approximately 5 troops will be stochastically generated as KIA. 

1. Click the Casualty Generator folder in the Scenario Explorer. The KIA Ratio is displayed in the Properties 

Window.  

 

 
 

2. Enter the number of WIAs expected to be killed in action.  

 

3. Enter the total number of WIAs.  
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6.2.10 Deleting a Casualty Generator 

1. Select the Casualty Generator.  

2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the Casualty Generator with the right mouse button to obtain the context menu, select Delete. 

The Casualty Generator will be deleted from the scenario. 

6.3 Working with Points of Injury 

A point of injury (POI) is a geographical site on the battlefield where a casualty occurs.  TML+ supports an 

unlimited number of POIs.  Each POI has a probability associated with it that determines the percentage of 

casualties that occur at that location.  All probabilities must total to 1.  POIs may only be added to the Network 

View, not the Map View.   

There is a defined relationship between a POI and a Self-Buddy Aid (SBA) medical capability.  TML+ assumes 

that all casualties proceed from a POI immediately to an SBA (intuitively there is no distance relationship 

between the POI and SBA). 

6.3.1 Adding a Point of Injury 

1. From the Common Data Explorer > Medical Capabilities > Land Based folder, click and drag the Self-

Buddy Aid (SBA) icon onto the Network View.  

 

A POI titled “POI.x” (where x is some number) will be added to the Points of Injury folder in the Scenario 

Explorer.  

An SBA titled “SBA.x” (where x is some number) will be added to the Medical Treatment Facilities folder in 

the Scenario Explorer. 

The POI/SBA pair will be displayed in the Network View as a grouped entity. 

 

The SBA will be displayed in the Map View, if enabled. 
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6.3.2 Selecting a Point of Injury 

1. In the Scenario Explorer > Points of Injury folder, click on the icon/name of the desired POI.  

or In the Network View, click on the icon/name of the desired POI. 

 

The POI will be highlighted and its properties will be displayed in the Properties Window.  

 

6.3.3 Copying a Point of Injury 

1. Select the POI to copy.  

2. From the Main menu, choose Edit > Copy.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+C key. 

or Click the POI with the right mouse button to obtain the context menu, select Copy. 

The POI will be copied to the clipboard.  

 

6.3.4 Pasting a Point of Injury 

1. Select the Point of Injury folder in the Scenario Explorer.  

or Select any POI in the Scenario Explorer. 

or make the Network View active. 

or make the Map View active. 

2. From the Main menu, choose Edit > Paste.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+V key. 

or Click the right mouse button to obtain the context menu, select Paste. This is available in Scenario 

Explorer, Network View, and Map View. 

 

A POI titled “POI.x” (where x is some number) will be added to the Points of Injury folder in the Scenario 

Explorer.  

An SBA titled “SBA.x” (where x is some number) will be added to the Medical Treatment Facilities folder in 

the Scenario Explorer. 
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6.3.5 Editing a Point of Injury’s Properties 

The properties of a POI may be changed via the Properties Window.  Refer to The TML+ Objects chapter for 

detailed information regarding each property. 

 

 

6.3.6 Setting Probabilities for All Points of Injury 

1. Select any POI.  

2. In the Properties Window, select the Probabilities for all POIs property. 

3. Click the “…” button, the POI Probabilities Editor appears. 

 

4. Enter the percentage (in decimal format) of the patient stream you expect to occur at each POI. This 

number must be between 0 and 1.  

Note that the probabilities for all POIs must add up to 1. Casualties are randomly assigned to POIs based on 

these probabilities. 
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6.3.7 Deleting a Point of Injury 

1. Select the POI.  

2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. This is available in the Scenario 

Explorer and Network View. 

The POI and corresponding SBA will be deleted from the scenario. 

6.4 Working With Medical Treatment Facilities 

A Medical Treatment Facility (MTF) is a geographical site at which medical care (varying by capability) is 

available.  TML+ supports an unlimited number of MTFs.   MTFs may only be added to the Network View, not 

the Map View.   

6.4.1 Adding an MTF 

Click and drag a Medical Capability icon in the Common Data Explorer onto the Network View.  An MTF will 

appear and will be added as an MTF in the Scenario Explorer. 

6.4.2 Selecting an MTF 

1. In the Scenario Explorer > Medical Treatment folder, click on the icon/name of the desired MTF.  

or In the Network View, click on the icon/name of the desired MTF. 

 

The MTF will be highlighted and its properties will be displayed in the Properties Window.  

6.4.3 Copying an MTF 

1. On the Network View, select the MTF to copy.  

2. From the Main menu, choose Edit > Copy.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+C key. 

or Click the MTF with the right mouse button to obtain the context menu, select Copy. 

The MTF will be copied to the clipboard.  

6.4.4 Pasting an MTF 

1.  Select the MTF folder in the Scenario Explorer.  

or Select any MTF in the Scenario Explorer. 

or Make the Network View active. 
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or Make the Map View active. 

2.  From the Main menu, choose Edit > Paste.  

or From the Standard toolbar, click the  button. 

or Click the Ctrl+V key. 

or Click the right mouse button to obtain the context menu, select Paste. This is available in Scenario 

Explorer, Network View, and Map View. 

 

An MTF titled “MTFname.x” (where x is some number) will be added to the Medical Treatment Facilities 

folder in the Scenario Explorer.  

 
6.4.5 Moving an MTF 

Once an MTF has been added to the Network View, it is also visible on the Map View.  The MTF may be 

moved around on the Network View or Map View by clicking on the icon and dragging it to a new location.   

6.4.6 Editing Properties for an MTF 

The properties of an MTF may be changed via the Properties Window.  Refer to The TML+ Objects chapter for 

detailed information regarding each property. 

 
 

6.4.7 Deleting an MTF 

1. Select the MTF.  

2. From the Main menu, choose Edit > Delete.  
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or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. This is available in Scenario 

Explorer and Network View. 

The MTF will be deleted from the scenario. 

6.5 Working With Routes 

Routes provide a path for casualty evacuation to the next level of care (an MTF).  Routes are one-directional 

and indicate the distance between two MTFs. 

6.5.1 Adding a Route 

To add a Route to the network, place the cursor over the MTF from which the casualty will be traveling.  Wait 

for the hand icon  to appear over the MTF.  Click the mouse and, while pushing the mouse button, drag the 

cursor to the MTF to which the casualty will be traveling.  Let up the mouse button.  A one directional arrow will 

connect the two MTFs.   

 

6.5.2 Selecting a Route 

Click on the Route in the Network view.  The Route will be marked with highlighted bullets. 

6.5.3 Deleting a Route 

1. Select the Route.  

2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. This is available in Network View 

only. 

The Route will be deleted from the scenario.  When an MTF is deleted, any Routes to or from the MTF will also 

be deleted. 
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6.5.4 Editing Properties for a Route 

The properties of a Route may be changed via the Properties Window.  Refer to The TML+ Objects chapter for 

detailed information regarding each property. 

 

6.5.5 Editing the Distance of a Route  

The default distance of a Route is 1km (kilometers), m (miles), or nm (nautical miles), depending on the Units of 

Measure set in the Preferences.  The distance can be changed by editing the number in the Network View or 

by moving an MTF on either end of the Route in the Map View. 

To edit the distance of a route: 

1. On the Network View, click on the distance of the Route.  The distance will appear in an editable box.  

Change the distance.  Units of Measure (km, m, or nm) are set in the Preferences.  Note that no changes 

will be reflected on the Map View. 

or 

2. On the Map View, select an MTF on one end of the Route and move the MTF.  The distance will change 

according to latitude/longitude locations on the map. 
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6.6 Working With Transportation Assets 

Each MTF, other than SBA and 1RSP, requires transportation assets such as air, ground, or sea vehicles to 

transport casualties to the next higher level of care.  Transportation pools are created for an MTF that consist of 

any combination of transportation types.  Note that without transportation assets, there will be no means of 

transport from one MTF to another.  The transportation pool used to evacuate a casualty is that pool which is 

associated with the receiving MTF. 

6.6.1 Creating a Transportation Pool 

Click a Transportation Type in the Common Data Explorer Transportation Type folder.  Drag it to an MTF in 

the Network View.  A Transportation Pool is created for that MTF and placed in the Transportation Pool folder 

in the Scenario Explorer. 

 

6.6.2 Adding a Transportation Type 

Click a Transportation Type in the Common Data Explorer Transportation Type folder.  Drag it to the 

Transportation Pool located in the Network View.  The transportation type is added to the Transportation Pool 

folder, both on the Network View and in the Scenario Explorer. 

6.6.3 Selecting a Transportation Asset 

Click a Transportation Asset in the Transportation Pool folder in the Scenario Explorer or click on the 

Transportation Asset icon in the Transportation Pool in the Network View. 

1. In the Scenario Explorer > Transportation Pool folder, click on the icon/name of the desired asset.  

or In the Network View, click on the icon/name of the desired asset in the Transportation Pool. 

 

The Transportation Asset will be highlighted and its properties will be displayed in the Properties Window.  

6.6.4 Deleting a Transportation Pool 

1. Select the Transportation Pool.  

2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. This is available in Network View 

only. 

6.6.5 Deleting a Transportation Asset 

1. Select the Transportation Asset. 
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2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. This is available in Network View 

only. 

The Asset will be deleted from the Transportation Pool.  If the Asset being deleted is the only Asset in the 

Transportation Pool, then the pool will also be deleted. 

6.6.6 Editing Properties for a Transportation Pool 

The properties of a Transportation Pool may be changed via the Properties Window.  Refer to The TML+ 

Objects chapter for detailed information regarding each property. 

 

6.6.7 Editing Properties for a Transportation Asset 

The properties of a Transportation Asset may be changed via the Properties Window.  Refer to The TML+ 

Objects chapter for detailed information regarding each property. 
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6.7 Working With Comments 

Comments may be added to the Network View to convey additional information about the medical laydown. 

 

6.7.1 Insert a Comment 

1. From the Main menu, choose Insert > Comment. 

 

 
A comment will be added to the middle of the Network View. 

 

6.7.2 Selecting a Comment 

1. Click on the rectangle of the desired comment in the Network View.  

 

The comment will be highlighted and available for editing.  

 

6.7.3 Moving a Comment 

1. Select the Comment.  

2. Drag the comment to a desired location.  

 

6.7.4 Deleting a Comment 

1. Select the Comment.  

2. From the Main menu, choose Edit > Delete.  

or From the Standard toolbar, click the  button. 

or Click the Delete key. 

or Click the right mouse button to obtain the context menu, select Delete. 
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7. How to Execute TML+ Scenarios 
Once you are satisfied with all your scenario inputs, you may “execute” the scenario.  Your scenario will 

simulate the arrival of casualties and then output results of their flow through the medical laydown.  The number 

of times your scenario will execute will correspond to the number of replications you specified, with a different 

random number seed for each replication.  

7.1 To Run the Scenario 

1. From the Main menu, choose Simulation > Run.  

or From the Execute toolbar, click the Run button. 

or Click the F5 key. 

The Executing dialog appears. 

 
The progress of the run will be displayed in the dialog. 

2. After the run is complete, the Reports Window will be displayed. 

7.2 To Abort the Run 

1. From the Executing dialog, click the Abort button.   

The Confirm Abort dialog appears. 

 
 

2. Choose Yes to abort the run. 
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8. How to Use TML+ Reports 
While running a scenario, TML+ generates output that is viewed through reports.  Once the simulation has 

completed execution, the Reports Explorer and Reports Window are displayed and the Scenario Explorer and 

Network View are closed.   Reports of the TML+ output may be viewed and printed from the Reports Window.  

Note that the Scenario, Common Data, and Properties Explorers and the Network View may be viewed by 

Selecting the View Menu. 

8.1 Working With Reports  

TML+ Reports are organized into four categories: Casualty Estimation, Care Providing, Transportation, and 

General Information. 

• Casualty Estimation reports pertain to the number and types of casualties that occur in the scenario. 

• Care Providing reports pertain to the treatment that occurs within each MTF and functional area, such 

as how many patients are treated, how long treatment takes, and how long patients wait to receive 

treatment. 

• Transportation reports pertain to patient evacuation, such as how many patients are evacuated per 

trip, how long patients have to wait for evacuation, and how many times each asset is used. 

• General Information reports provide a summary of your scenario inputs as well as a list of the 

assumptions built into TML+.  

Within each report category are various reports containing information related to that category.  Each report 

may be displayed in tabular or graphical format. 

8.2 Generating Report Output  

Open the scenario you wish to run, select Simulation > Run.  The simulation will run and a TML report will be 

generated.   To set the report database name and audit report options, please refer to the Report Properties 

section of this document.  
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8.3 Working With Report Display Preferences  

Users may set report display preferences for time format, toolbar displays, report column options, and default 

report.   

 

8.3.1 Setting the Report Navigation Style 

TML+ offers two styles of report navigation – Reports Explorer and Toolbars.  The two report methods are 

synchronized, allowing the user to use a combination of methods for report viewing.  The Reports Explorer is 

always displayed and may be opened or closed like any window.  The Report Selection toolbar and Report 

Options Toolbar are optional.   The Report Options Toolbar is set as the default, but both or neither toolbar may 

be displayed by editing the Report Preferences under the Edit Menu. 
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To set the Report Navigation Style: 

1. Go to Edit > Preferences. A new window opens.  

2. Click the Reports Display tab. 

3. Choose a Report Navigation Style to use for report navigation. 

4. Click OK. 

 

 
8.3.2 Setting the Data Table Features 

When viewing tabular reports, several options are available for displaying column data.  Filtering, column 

pinning, and column summaries are optional features that may be activated by editing the Preferences for 

Reports Display.   

1. Go to Edit > Preferences. A new window opens.  

2. Click the Reports Display tab. 

3. Select the Data Table Features you wish to activate. 

4. Click OK. 

 

 
8.3.3 Setting Time Format Preferences  
 

Many reports generated by TML+ include the actual time an event occurred.  The user may format the time 

data field, choosing from two different formatting profiles. For example, you may choose to display time in 

dd:hh:mm or in total minutes.  When a report is open, you can toggle between the two preferences (see below).  
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To set your report format preferences: 

1. Go to Edit > Preferences. A new window opens.  

2. Click the Reports Display tab. 

3. Under the User Format 1 section, click the Time Format drop-down menu and select a format in which to 

display time. 

4. Enter the number of decimal places to display for numbers that appear anywhere in the report and are not 

whole numbers. 

5. Repeat for User Format 2 section. 

6. Click OK. 

While viewing a report, the user can toggle between the two formats defined above. Whenever a table is open, 

you can switch between the two formats by clicking the Toggle icon   on the main toolbar. 

 

 
8.3.4 Setting the Default Report 

The user may choose a Selected Report, a Consolidated Report, or a previously Saved Report as the default 

report to view when the reports database opens.  A Selected Report is a report from the pull-down menu.  A 

Consolidated Report is a combination of reports in graphical format.  A Saved Report is any report, either 

Selected or Consolidated, which was previously saved to disk. 

To set the Default Report: 

1.  Go to Edit > Preferences. A new window opens.  

2. Click the Reports Display tab. 

3. Choose Selected Report, Default consolidated report, or Saved report.  If choosing Saved report, use the 

Browse button to locate the previously saved report. 

4. Click OK. 
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8.4 Working With Report Navigators  

In order to view the reports generated by a running a scenario, TML+ offers two methods of report navigation – 

Reports Explorer and Toolbars.  The two report methods are synchronized, allowing the user to use a 

combination of methods for report viewing.  

8.4.1 Working With the Report Explorer  

The TML Reports Explorer Navigator is displayed in two pieces – the Reports Explorer and the Reports 

Properties.  

The Reports Explorer organizes reports into folders in a Reports Tree.  Report Category is the highest level 

folder, containing four categories:  Casualty Estimation, Care Providing, Transportation, and General 

Information.  When a Category folder is opened, a list of reports available for that category is displayed.  When 

the Report folder is opened, a list of available report types is displayed.  Report Types are either tabular or 

graphical in format.   

The Reports Properties contains a set of properties and options that pertain to the report currently being 

viewed.  Refer to the Properties section of this document for detailed information regarding properties and 

options. 

8.4.2 Selecting a Report Using the Report Explorer  

1. Choose a Report Category in the Reports Explorer.  Open the Category folder by clicking on the + or by 

double-clicking on the Category name. 

2. Choose a Report by clicking on the + or by double-clicking the report name. 

3. Choose a report format and click on the name.  The number of formats for a report depends on the 

report.   

4. Choose Report Options or set Report Properties as needed for the report being viewed.  Refer to the 

Report Properties section of this document for details on each property and option. 
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8.4.3 Working With the Report Toolbars 

In addition to the Reports Explorer, Report Toolbars are available for navigational purposes.  TML+ has two 

toolbars – a Report Selection Toolbar and a Report Options Toolbar.   The Report Options Toolbar is set as the 

default, but both or neither toolbar may be displayed by editing the Report Preferences under the Edit Menu. 

• The Report Selection Toolbar organizes reports into drop-down lists for Report Category, Report 

Name, and Report Type.  Report Category is the highest level folder, containing four categories:  

Casualty Estimation, Care Providing, Transportation, and General Information.  When a category has 

been selected, a list of reports available for that category is available in the Report drop-down menu.  

When a report has been selected, a list of report types available is shown in the Report Type drop-

down menu.  Report Types are either tabular or graphical in format.   
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• The Report Options Toolbar contains of a set of options that can be used to filter the report currently 

being viewed.  The options vary depending on the report selected for viewing.    

Replication – If you run more than one replication of a scenario, the Replication menu lets you 

select the data for an individual replication or for all replications. When you select All from the drop-

down menu, you see a summary of data across all replications.  

Medical Treatment Facilities (MTF) and Functional Area (FA) – MTF and FA menus appear when 

appropriate, depending on the choices you make in the Category and Report menus. You use 

these menus to view the data pertaining to the different MTFs and FAs in your scenario.  

Additional options may appear depending on the report selected. One example is Period.  Period 

refers to a period of time expressed in hours. 

 

8.4.4 Selecting a Report Using Toolbars 

1. Edit Report Preferences to display both toolbars. 

2. Choose a Report Category in the Reports Explorer.  Open the Category folder by clicking on the + or 

by double-clicking on the Category name. 

3. Choose a Report by clicking on the + or by double-clicking the report name. 

4. Choose a report format and click on the name.  The number of formats for a report depends on the 

report itself.   

5. Choose Report Options or set Report Properties as needed for the report being viewed.  Refer to the 

Report Properties section of this document for details on each property and option. 
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8.4.5 Viewing a Report Generated From a Previous Run 

Output from previously run reports may also be opened and viewed at any time.   

1.  Select View > Reports > Open Reports.   

2.  The Open TML+ Reports Database Window dialog will open.  Browse for the report database of interest.  

Select Report Database and click Open. 

3.  Use a Report Navigator (either Reports Explorer or toolbars) to view the desired reports. 

8.5 Working With Data Table Features  

Each column within a tabular report may be sorted, summed, filtered, or pinned.  Sorting is a default feature for 

all columns in a report.  Filtering, summing, and pinning are preferences that may be set in Edit > Preferences 

> Reports Display > Data Column Features. 

8.5.1 Sorting Data in a Column 

You can sort columns of data within a report.  Sorting is a feature that is available for all columns in a tabular 

report. 

1.  Click the heading once for ascending order.  

2.  Click the heading twice for descending order. 

8.5.2 Summing Data in a Column 

The Summing Data feature is an optional feature that is not active when TML+ Reports opens. You may 

activate the summing feature by editing the Preferences for Reports Display.  For each column of data, field 

statistics such as Count, Maximum Value, and Minimum Value may be calculated.   For numeric fields, 

additional statistics for Average and Sum may be calculated. 

To sum statistical fields for a column of data: 

1.  Click  , located beside the column name. 

2.   Select the statistical fields desired. 

3.  Click OK. 

4.  Scroll to the bottom of the Report to see the field statistics.  They will be labeled Grand Summaries report. 
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8.5.3 Filtering Data in a Column 

Filtering a data column is an optional feature for tabular reports that is active when TML+ Reports opens.  You 

may elect to inactivate the filter option by editing the Preferences for Reports Display.  When filtering a data 

column, you are selecting to display a subset of the data in a report. Filtering is different from sorting because it 

hides the information on which you do not want to focus. Filtering is also different from sorting because you can 

filter more than one column at a time.  

The filtering function is located at the top of each column as denoted by .  

Note that once you select a filter, the filter icon turns blue so that you can identify which columns have filters. 

 

8.5.4 Using Standard Filtering Options 

Columns can be filtered on blanks, non-blanks, or any entry in the column. If you filter on blanks, only those 

rows with empty fields in the column on which you filtered are displayed. If you filter on non-blanks, only those 

rows with an entry (text or numeric) in the column on which you filtered are displayed.  

In addition, you can filter the column on any entry in that column. For example, if you have the following entries 

in a column: 3, 4, 8, 8, 8, and you want to see only the data with a value of 8, you can select 8 from the filter 

and view only those three records with a value of 8 in that column.   

To filter a report: 

1. Click the  button, located beside the column name. 

2. Select the entry or column to filter. 

3. Repeat steps 1 and 2 for all the columns you want to filter. 

8.5.5 Customizing a Filter 

If you do not want to filter on the standard filtering choices (blanks, non-blanks, and entries in the column), you 

can customize the filter. The customizing feature allows you to filter on one or more conditions rather than one 

specific entry. For example, if you have the following entries in a column: 3, 4, 5, 5, 8, you can use the 

customization feature to display only those columns with a quantity greater than 4. 

1. Click the  button. 

2. Select Custom. A new dialog box opens. 

3. Click the drop-down menu and select the Operator. 

4. Click the drop-down menu and select the Operand. 

5. To add another condition, click the Add a condition button and follow steps 3 and 4. 
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6. Click OK. 

 

8.5.6 Clearing a Filter 

1. Click the  button. 

2. Select All. 

3. Repeat for each column you wish to clear. 

8.5.7 Pinning a Column 

Pinning a column is an optional feature for tabular reports that is not activated when TML+ Reports opens.  You may 

elect to activate the pinning feature by editing the Preferences for Reports Display.  Pinning and unpinning relocates 

a column.  When a column is pinned, it is relocated to the first column in the table.  If a second column is pinned, it is 

moved to the second column in the table.  When a column is unpinned, it is moved to the right of all columns already 

pinned.  Column position is relative to other columns and their status of pinned or unpinned.  All columns are 

unpinned when the reports open. 

1. Click the  button to pin a column.  The icon changes from  to . 

2. Click the  button to unpin a column.  The icon changes from  to . 
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8.5.8 Dragging a Column Heading for Grouping 

While viewing a tabular report, the user can view the data by groups, based on a column heading.   

1. Click the column heading you wish to group. 

2. Drag the heading to the area above the report table labeled “Drag a column heading here to group by that 

column.”  The data will be grouped by the heading, each in a separate folder. 

3. To ungroup, click the column heading and drag it back down to the report table. 

 

 

8.6 Configuring Report Alerts 

The Alerts function allows you to program TML+ to signal you when defined criteria occur in the reports. For 

example, if you want to know when the consumable supplies are depleted, you can set an alert that highlights 

cells in the reports in which the supply quantity is less than zero. To configure an alert, you first create the alert 

and then enter the criteria.  

8.6.1 Adding an Alert 

1.  Click the Reports > Configure Alerts.  A new window opens. 

2.  Click Add Alert. 

3.  Select the background color (color for the cell in the report) and foreground color (text color), and enter a 

name for the alert.  

Before Grouping 

After Grouping 
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4.  Click in the Active column and select whether to display this alert. True displays the alert and False shuts 

the alert off. 

5.  Select whether to show the alert when all criteria are met (And) or when any single criteria is met (Or). 

6.  Select whether to place the alert on the cell, row, or column. 

7.  Click in the Report field and select the report on which to place the alert. Click in the Target Column Name 

field and select the column on which to place the alert. 

8.  Enter a tool tip. This will be displayed when you place the mouse over the highlighted cell with this alert.  

9.  The alert will be added to the Alerts folder. 

 

8.6.2 Adding Alert Criteria 

An alert compares two values to determine if the alert is necessary. Criteria must be defined for the values.  For 

example, for an alert that signals when the Percent Utilization is less than 10%, the number in the Percent 

Utilization column is compared with the quantity 10%. In this section, you are selecting values for the alert 

(steps 4 and 6) and how to compare them (step 5). 

1. Click the + to the left of the new alert. 

2. Click Criteria (the item indented under the alert).  

3. Enter a name for the Report. 

4. Click in the Column Name field and select the column in which the first item to compare appears. 
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5. Select the method for comparing the value in step 4 and step 6 (e.g., equal to, less than, greater than). 

6. Click on Literal/Column/Expression to enter the text or quantity that will be compared with the column or 

cell selected in step 4. You can also use the drop-down menu to select another column to which to compare the 

first one.  

8.6.3 Deleting Alerts and Criteria 

1. Click the criteria or alert you want to delete. 

2. Click the Remove button. 

3. Removing an alert will remove all of the criteria associated with the alert. 

8.6.4 Exporting Alerts 

The Alerts folder and all of the properties and criteria associated with each alert may be exported or saved to 

disk for other users to share.  

1. Click the Export Alerts button. 

2. A dialog box appears. Enter the name and location for the exported alert. 

3. Click Save. 

8.6.5 Loading Alerts  

An Alerts folder that has been exported and saved by another user or at a previous time may be loaded into 

TML+. 

1. Click the Load Alerts button. 

2. A dialog box appears. Browse to locate the alerts to be loaded. 

3. Click Open. 

4. Alerts may also be appended to existing alerts by clicking Yes in the Load Alerts dialog box. 
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8.7 Comparing Reports 

Results from one scenario run may be compared with results from other scenario runs. For example, if you are 

interested in learning whether including another Transportation Asset alleviates a delay in treatment, you can 

look at the Task Time per Casualty in MTF Report before and after you add the Transportation Asset to the 

scenario. 

1. Open the report of your choice. 

2. Click the Compare Reports icon  on the Report toolbar. A new dialog box opens. 

3. Click the ellipsis to open a list of previous runs of the scenario.  

4. Select the run to compare with the current database. 

5. Repeat steps 3 and 4 until you have selected all the runs you want to compare. 

6. Click OK. TML+ automatically imports the data from the database you selected and displays it in blue 

type. 

7. The comparison feature stays enabled even while you change reports. To disable the report 

comparison feature:  Click the icon on the Report toolbar. A new dialog box opens.  Click the Delete 

button for those comparisons you wish to disable. 

Note that not all reports may be compared.  For those in which a comparison does not make sense, the icon 

button will be grayed and inactive.  Both tabular and graphical reports may be compared.  
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8.8 Consolidated Reports 

TML+ allows the user to build Consolidated Reports, or a collection of reports for a single simulation run.  

Consolidated Reports provide a quad-chart type view, displaying data in a presentation format.  Consolidated 

Reports include up to eight reports and may be displayed two per page or four per page.  A Consolidated 

Report with eight reports, four per page is set as the default report, but others may be configured. 

8.8.1 Viewing a Consolidated Report 

1.  Select Reports >View Consolidated Reports. 

2.  Select View Without Saving. 

 

 
8.8.2 Building a Consolidated Report 

1.  Select Reports >View Consolidated Reports. 

2.  Click on Consolidated Reports in the Component Reports Window.  

3.  Edit the properties for the Consolidated Report.  Enter a Report Title, Layout (select two or four charts per 

page), and Page Titles for each page of the report. 
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4.  Click Add.  Select a report from the Choose Report Type Window. 

 

5.  The Report will be added to the Consolidated Report List. 

6.  Select a report name and edit properties for the report. 

7.  Enter a custom title, if desired.  Enter a Replication number, Report Type, and a Y Axis upper limit, if other 

than zero. 
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8.  Repeat steps 4 thru 7 to add more reports to the Consolidated Report. 

9.  To remove a report from the Consolidated Reports, select the report and click Remove. 

 
8.8.3 Saving a Consolidated Report 

Consolidated Report settings may be saved for later use or use by another user.  Click Save Report and enter 

the name and location of the saved file. 

8.8.4 Loading a Consolidated Report 

Consolidated Report settings that have been saved may be loaded.  Click Load Report and use the Load 

Consolidated Report Window to locate the file you wish to load. 

8.8.5 Closing a Consolidated Report 

1.  Click Close Consolidated Report. 
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8.9 Printing a Report 

1. Select File > Print from the Menu Bar or click the printer icon on the toolbar.  

2. Select the printer from the drop-down menu. 

3. Select the number of copies. 

4. Click OK. 

8.10 Exporting a Report 

TML+ supports the exportation of data to a comma-separated file (.csv), which can be opened in Excel.  

1. Click the Export icon  on the toolbar. A dialog box opens. 

2. Navigate to where you would like to save the file. Make a note of this location. 

3. Type a name for the exported file. 

4. Click Save. 
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9. The TML+ Objects 
With TML+, you build your scenario from reusable components, or "objects."  Each type of object is designed to 

represent a specific aspect of your scenario.  This chapter describes the properties of the different types of 

objects.  The objects are in alphabetical order. 

9.1 Casualty Generator Objects 

The Casualty Generator Object represents a patient stream.  The three Casualty Generator Objects are: 

• Repeatable Rate Casualty Generator 

• Time Intervals Casualty Rate Table 

• User-Defined Casualty Stream 

9.1.1 Repeatable Rate Casualty Generator 

The Repeatable Rate Casualty Generator object generates casualties across a specified time interval and 

repeats if the scenario time permits. 
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The properties of the Repeatable Rate Casualty Generator object are (in alphabetical order): 

Property Description 

Mean Number of 

Casualties 

Mean number of casualties for this generator for the selected time period. 

Name Name of this casualty generator.  The name does NOT have to be unique. 

PC Distribution Name Name of the patient condition distribution for this casualty generator. 

Point of Injury Point of injury location for casualties created by this generator.  If Random, 

then the POI will be randomly determined based on the POI distribution. 

Time Period The time interval, expressed in hours, for which to repeatedly generate 

casualties.  

Type Type of casualties created by this generator.  Choices are WIA, NBI, 

Disease, or Battle Fatigue. 
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9.1.2 Time Intervals Casualty Rate Table 

The Time Intervals Casualty Rate Table object generates casualties across a collection of time intervals. 

 

The properties of the Time Intervals Casualty Rate Table object are (in alphabetical order): 

Property Description 

Casualty Table Table of time periods with the corresponding mean number of casualties 

that will be generated for that time period. 

Name Name of this casualty generator.  The name does NOT have to be unique. 

PC Distribution Name Name of the patient condition distribution for this casualty generator. 

Point of Injury Point of injury location for casualties created by this generator.  If Random, 

then the POI will be randomly determined based on the POI distribution. 

Type Type of casualties created by this generator.  Choices are WIA, NBI, 

Disease, or Battle Fatigue. 
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9.1.3 User-Defined Casualty Stream 

The User-Defined Casualty Stream object generates casualties across a collection of time intervals. 

 

The properties of the User-Defined Casualty Stream object are (in alphabetical order): 

Property Description 

Name Name of this casualty generator.  The name does NOT have to be unique. 

User-Defined Table Table of casualties. 

 

The properties of the User-Defined Table are (in alphabetical order): 

Property Description 

Arrival Time The time at which this casualty arrived, expressed in hours. 

Casualty Type Type of casualty.  Choices are WIA, NBI, Disease, or Battle Fatigue. 

Patient Condition Code Patient condition code of this casualty. 

Point of Injury POI of this casualty. 
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9.2 Common Database Object 

The Common Database object represents the medical capability and transportation types that may be reused 

in your scenario. The Common Database also incorporates data for over 400 patient conditions (PCs) and the 

corresponding medical treatment tasks. 

 

The properties of the Common Database are (in alphabetical order): 

Property Description 

Description Description of the common database.  Read-only. 

Name Name of the common database.  Read-only. 

Pathname Pathname of the common database.  Read-only. 

Patient Condition Codes List of patient condition codes.  Available under View Details > PCs tab.  

Read-only. 

Patient Condition 

Distribution 

List of PC distributions by theater.  Available under View Details > PC 

Distribution tab.  Read-only. 

Supplies List of all supplies.  Available under View Details > Supplies tab.  Read-only. 

Tasks List of all tasks.  Available under View Details > Tasks tab.  Read-only 
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9.2.1 Patient Conditions 

A Patient Condition (PC) code is a three-digit number describing patients’ injuries, physical conditions, or 

diseases that were formulated by the Defense Medical Standardization Board to standardize diagnostic formats 

across medical resource models. PC codes constitute the underlying data on which TML+ and other medical 

modeling and simulation programs draw to model, among other things, supply and personnel usage and 

requirements. The PCs tab under the Common Data Viewer (from the View Details button) contains the PC 

codes. 

 

The properties of Patient Conditions are (in alphabetical order): 

Property Description 

Ambulatory Checked (X) if the patient condition is ambulatory…does not need a 

stretcher during evacuation. Read-only. 

Category Category of the patient condition.  Read-only. 

Description Description of the patient condition. Read-only. 

ID  Unique identifier of the patient condition.  Read-only. 
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9.2.2 Patient Condition Distribution 

To determine a patient stream in a model like TML+, real data from previous similar missions are used, and 

then percentages are statistically distributed across patient conditions likely to result from input parameters. 

The percentages must all add up to one to be considered valid.  In TML+, various distributions are available for 

your scenario. 

The PC Distribution tab under the Common Data Viewer (from the View Details button) contains the patient 

condition distributions by theater. 

 

The properties of the PC Distribution are (in alphabetical order): 

Property Description 

Battle Fatigue  Battle Fatigue (BF) probability for the PC. Read-only. 

Disease Disease probability for the PC. Read-only. 

NBI Nonbattle injury (NBI) probability for the PC. Read-only. 

PC Patient Condition. Read-only. 

WIA Wounded in action (WIA) probability for the PC. Read-only. 
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9.2.3 Supplies 

Supplies are linked to the tasks medical providers perform to treat patients. Supplies are classified as 

equipment, consumables, or durables.  Equipment generally refers to large pieces such as oxygen tanks, 

consumables to things used once (medications, IV tubes), and durables for things like batteries that may be 

used more than once. 

The Supplies tab under the Common Data Viewer (from the View Details button) lists all of the supplies. 

 

The properties of a Supply are (in alphabetical order): 

Property Description 

Description  Description of the supply. Read-only. 

Divide By Number of supply items in a package, box, bottle, carton.  Read-only. 

ECD Equipment, Consumable, or Durable.  Read-only. 

NSN Unique identifier for the supply. Read-only. 

Unit of issue How supply is issued e.g., by the box, in a package of 100, Read-only. 

Unit of measure How supply is measured out e.g., in liter, mg, ml, Read-only. 
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9.2.4 Tasks 

Tasks are linked to PC codes, and refer to that which medical providers do in order to treat their patients. Tasks 

can range from repeatable ones like taking a pulse once every 4 hours to tasks one may perform only once, 

such as prepping a patient for surgery. Each one is associated with one or more PCs and, consequently, tied to 

resources such as those supplies and personnel needed to treat the condition(s). 

The Tasks tab under the Common Data Viewer (from the View Details button) lists all the tasks. 

 

The properties of a Task are (in alphabetical order): 

Property Description 

Description Description of the task.  Read-only. 

Task Number Unique identifier for the task.  Read-only. 
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9.3 Functional Area Object 

The Functional Area object defines an area of medical capability.  A Medical Treatment Facility (MTF) is 

composed of one or more Functional Areas (FAs). 

 

The properties of a Functional Area are (in alphabetical order): 

Property Description 

Long Name More descriptive name of the Functional Area.  Read-only. 

Short Name Short name of the Functional Area.  Used in certain reports.  Read-only. 

Tasks List of all tasks.  Available under View Details > Tasks tab.  Read-only. 
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9.3.1 General Properties 

The General tab under the FA Common Data Viewer (from the View Details button) lists all the general 

properties. 

 

The General properties are (in alphabetical order): 

Property Description 

Descriptive Name More descriptive name of the FA.  Read-only. 

FA Routing  Routing table for this FA.  When the specified task has been completed, the 

patient will be routed to the specified FA.  Optional: may reserve a spot 

(similar to a bed).  Read-only. 

Max Casualties in FA The maximum number of casualties that can be in this FA.  This property is 

similar to the number of beds.  Read-only. 

Max Simultaneous Tasks The maximum number of simultaneous (concurrent) tasks that may be 

performed in this FA.  Read-only. 

Service Discipline The method of choosing the casualty to treat. Choices are PRIORITY and 

FIFO (First In First Out).  Read-only. 

Short Name Short name of the functional area.  Used in certain reports.  Read-only. 

Tasks List of all tasks.  Available under View Details > Tasks tab.  Read-only 

 



 

9-12 TML+ User’s Manual 

9.3.2 Supply Inventory 

The Inventory tab under the FA Common Data Viewer (from the View Details button) lists the Supply Inventory 

defined for the FA. 

 

The properties of a Supply Inventory are (in alphabetical order): 

Property Description 

Inventory Multiplier 

Consumables 

Increases the initial quantity of the consumables by the specified multiplier. 

Inventory Multiplier 

Equipment 

Increases the initial quantity of the equipment by the specified multiplier. 

Quantity Issued The starting quantity of the supply item. 

Supply  The category, number, and description of the supply item.  Read-only. 

Tasks List of all tasks.  Available under View Details > Tasks tab.  Read-only. 
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9.3.3 Tasks 

The Tasks/Usage tab under the FA Common Data Viewer (from the View Details button) lists the tasks 

performed for each PC code.  Note that the treatment order is determined by the Generic Task Sequence 

(GTS). 

 

The properties of the Tasks are (in alphabetical order): 

Property Description 

Init Time The number of times to perform the task in the first 24-hour period. 

Max Task Time The maximum time in minutes to perform the task. The actual task time is 

randomly determined. (Bounded exponential distribution).  Read-only. 

Min Task Time The minimum time in minutes to perform the task. The actual task time is 

randomly determined. (Bounded exponential distribution).  Read-only. 

PC The patient condition code for the task.  Read-only. 

% Patients  The percentage of patients who will have this task performed.  This is 

randomly determined.  Read-only.  

Quantity The number of supplies used when the task is performed.  Read-only. 

Recur Time The number of times to perform the task in subsequent 24-hour periods.  

Read-only. 

Supply List of supplies used when the task is performed. 

Task Number The unique task number and description.  Read-only. 

Task Time The time in minutes to perform the task. The actual task time is randomly 

determined. (Bounded exponential distribution).  Read-only. 
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9.3.4 Treatment Priority 

The Treatment Priority/Percentages tab under the FA Common Data Viewer (from the View Details button) 

lists the treatment priority and the percentage of patients accepted by the FA for each PC code. 

 

The properties of the Treatment Priority/Percentages are (in alphabetical order): 

Property Description 

Description  The patient condition code.  Read-only. 

Percent The percentage of patients who will be accepted by this FA.  This is 

randomly determined.  Read-only. 

Treatment Priority The treatment priority of the patient condition code.  Read-only. 
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9.3.5  Generic Task Sequence (GTS) 

The GTS tab under the FA Common Data Viewer (from the View Details button) lists the order in which the 

tasks will be performed in the FA.  Note that not all tasks are performed. 

 

 

The properties of the GTS are (in alphabetical order): 

Property Description 

Continuous  A continuous task will hold equipment until the patient leaves the Functional 

Area.  Read-only. 

DefaultPersLvl The skill level of the personnel type who attempts to perform the task first. 

Read-only. 

Lock  If Locked (checked), the personnel type must be available.  Read-only. 

MimPersLevel The minimum skill level of the personnel type who attempts to perform the 

task when the default is busy. Read-only. 

Sequence The treatment order of the task.  Tasks are called concurrent if the 

sequence numbers are identical.  Concurrent tasks may be performed 

simultaneously (up to max).  Read-only. 

Task Code The unique task number and description.  Read-only. 
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9.3.6 Personnel 

The Personnel tab under the FA Common Data Viewer (from the View Details button) lists the medical staff 

available for the FA. 

 

 

The Personnel properties are (in alphabetical order): 

Property Description 

Description  Additional information about the personnel type.  

Personnel Type  A short name for the personnel type. 

Quantity The number of people of this type. 

Shift End The time the personnel type stops being available during any 24-hour 

period. 

Shift Start The time the personnel type is available during any 24-hour period. 

Skill Level The skill level of the personnel type.  Used in selecting the medical provider, 

especially if default provider is busy. 
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9.4 Medical Capability Object 

The Medical Capability object defines the capabilities of a Medical Treatment Facility (MTF). 

 

The properties of the Medical Capability object are (in alphabetical order): 

Property Description 

Echelon Echelon of this medical capability.  Deprecated.  Read-only. 

Icon Icon of this medical capability.  Read-only. 

Long Name More descriptive name of this medical capability.  Read-only. 

Max Casualties Waiting The maximum number of casualties waiting at this medical capability before 

an alternate route is chosen for new casualties.  Read-only. 

Short Name Short name of the medical capability.  Used in certain reports.  Read-only. 
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9.5 Medical Treatment Facility Object 

The Medical Treatment Facility (MTF) object is a deployed medical capability.  The user may define the 

MTF’s hours of operation, move it from one location to another, and endow it with evacuation assets. 

 

The properties of the Medical Treatment Facility object are (in alphabetical order): 

Property Description 

Evac Route Rule Rule to determine route for evacuation.  Choices are Shortest Distance and 

Priority. 

Future Waypoints Geographical position waypoints in the future for this MTF.  Valid when GIS 

is enabled. 

Icon Icon of this MTF. 

Name Name of this MTF.  Name must be distinct from other MTFs in the scenario. 

Schedule List of time that this MTF is available. 

Type Type of this MTF.  Read-only. 
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9.6 Point of Injury Object 

The Point of Injury object represents the location of the casualty’s wounding. 

 

The properties of the Point of Injury object are (in alphabetical order): 

Property Description 

Name Name of this point of injury.  Name must be distinct from other POIs in the 

scenario. 

Probability Probability of casualties occurring at this POI.  Probabilities for all POIs must 

sum to 1.0. 
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9.7 Route Object 

The Route object represents the evacuation path from one MTF to another. 

 

The properties of the Route object are (in alphabetical order): 

Property Description 

From MTF Name of the medical treatment facility from which the route comes.  Read-

only. 

Maneuvers List of maneuvers for this route.  Read-only when the GIS is enabled. 

Priority Priority of this route relative to the other routes originating from the MTF.  

The route with the highest priority (e.g., 1) is attempted first, and so forth.  

The user should make sure that no two routes have the same priority. 

Random Distance If Yes, the distances (in the Maneuver property) for this route are treated as 

the maximum of randomly determined distances. 

Schedule List of time that this route is available.  Currently used only for display 

purposes.  An unavailable route is displayed dimmed. 

To MTF Name of the medical treatment facility to which the route is going.  Read-

only. 
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9.8 Scenario Object 

The Scenario object represents the content and structure of a TML+ document.   

 

The properties of a Scenario object are (in alphabetical order): 

Property Description 

Author Author of this scenario. 

Classification Highest security classification of this scenario. 

Creation Date Date this scenario was created. Read-only. 

Description Description of this scenario. 
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Property Description 

E-mail Address Author’s e-mail address. 

Filename Filename of the TML+ reports database output for this scenario.   

The extension “.mdb” is automatically added to the filename. 

Full Path Location of this scenario file. Read-only. 

GIS Status Enables or disables the Geographical Information System (GIS). 

Length of Scenario Length in time of this scenario. 

Modification Date Date this scenario was modified. Read-only. 

Number of Replications Number of times the simulation will be executed. Each replication will use a 

different random number seed. Changing this value will automatically 

generate new random number seeds. 

Organization Author’s organization. 

Output Audit  -> Output 

Audit 

If Yes, a log of simulation events will be added to the Reports Database.  

If No, the log will not be created. 

Output Audit  -> Output 

Care Providing Messages 

If Yes, all care providing messages will be output to the Reports Database.  

If No, no care providing messages will be output. 

Output Audit  -> Output 

Casualty Generator 

Messages 

If Yes, all casualty generator messages will be output to the Reports 

Database.  

If No, no casualty generator messages will be output. 

Output Audit  -> Output 

Transportation Messages 

If Yes, all transportation messages will be output to the Reports Database.  

If No, no transportation messages will be output. 

Overwrite If Yes, the previously created Reports Database is overwritten. 

If No, a new Reports Database is created and the filename is appended with 

the current date and time. 

Phone # Author’s telephone number. 

Random Number Seeds List of random number seeds. Each replication will use its respective 

random number seed. 

Scenario Name Name of this scenario. 

Units Unit of time for the scenario length. Choices are hours and days. 

Version Version of this scenario. 
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9.9 Transportation Asset Object 

The Transportation Asset object represents a vehicle available for evacuating patients. 

 

The properties of a Transportation Asset object are (in alphabetical order): 

Property Description 

Behavior Behavior of this transportation asset.  Choices are Designated or Divert. 

Icon Icon of this transportation asset. 

Load Patient List List of patient conditions that can be loaded on this transportation asset. 

Name Name of this transportation asset.  Name must be distinct from other 

transportation assets in the scenario. 

Pool Parent transportation pool for this transportation asset.  Read-only. 

Priority Priority of this transportation asset relative to the other assets belonging to 

the parent pool.  The asset with the highest priority (e.g., 1) is attempted 

first, and so forth.  The user should make sure that no two assets have the 

same priority. 

Requesting Patient List List of patient conditions that can request this transportation asset. 

Start Time (hour) The time (in a 24-hour period) that this transportation asset starts accepting 

demands. For example, a helicopter may only fly during daytime hours. 
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Property Description 

Stop Time (hour) The time (in a 24-hour period) that this transportation asset stops accepting 

demands. For example, a helicopter may only fly during daytime hours. 

Type Type of transportation asset.  Read-only. 

 

9.10 Transportation Pool Object 

The Transportation Pool object represents all available Transportation Assets for a specific MTF. 

 

The properties of a Transportation Pool object are (in alphabetical order): 

Property Description 

Icon Icon of this transportation pool. 

MTF Parent medical treatment facility for this transportation pool.  Read-only. 

Name Name of this transportation pool.  Name must be distinct from other 

transportation pools in the scenario. 
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9.11 Transportation Type Object 

The Transportation Type object defines the capabilities of an evacuation asset. 

 

The properties of a Transportation Type object are (in alphabetical order): 

Property Description 

Ambulatory Loading Time Time in minutes to load an ambulatory patient on this transportation type. 

Ambulatory Unloading 

Time 

Time in minutes to unload an ambulatory patient on this transportation type. 

Capacity Maximum number of seats available for this transportation type.  An 

ambulatory patient occupies one seat. A litter patient occupies two seats. 

Description Description of this transportation type. 

Empty Speed Speed of this transportation type when empty (no patients).  Units may be 

kilometers per hour (kph), miles per hour (mph), or knots. 

Icon Icon of this transportation type. 

Litter Loading Time Time in minutes to load a litter patient on this transportation type. 
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Property Description 

Litter Unloading Time Time in minutes to unload a litter patient on this transportation type. 

Loaded Speed Speed of this transportation type when loaded (1 or more patients).  Units 

may be kilometers per hour (kph), miles per hour (mph), or knots. 

Name Name of this transportation type.  Name must be distinct from other 

transportation types in the scenario. 

Post Mission Delay Time that this transportation type will be unavailable after a mission.  Units 

may be minutes (min), hours (hrs), or days. 

Pre Mission Delay Time that this transportation type will be unavailable before a mission.  Units 

may be minutes (min), hours (hrs), or days. 

Range Range of this transportation type.  Units may be kilometers (km), miles (mi), 

or nautical miles (nm). 

Wait Time Time in minutes that this transportation type will wait for additional patients. 
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A.  Glossary 
Glossary 

Name Description 

1RSP First Responder – The first person a casualty encounters in the medical 
chain of evacuation. 

Alerts A message, customized by the user, sent to signal them when defined 
criteria appear in TML+ simulation run reports. 

AMAL Authorized Medical Allowance List – Collection of medical supplies grouped 
for use by functional area. 

BAS Battalion Aid Station – A far-forward medical treatment facility (MTF) that 
offers clinical assessment; treatment administered includes use of 
intravenous fluids and antibiotics, preservation of the airway by surgical 
procedure, and application of more secure splints and/or bandages. The 
BAS provides initial resuscitation and routine health services and carries 
the theater sick-call supplies. 

Capabilities-based 
sets 

Medical supplies grouped by their function and usage within a treatment 
facility. 

CASEVAC Casualty evacuation system – The evacuation system that renders care 
during patient transport from the point of injury (POI) to a collection point or 
MTF. 

Casualty Generators A stream of casualties/patients that arrives at a randomly generated time 
and location with randomly generated patient conditions. In TML+ the 
various methods used to calculate casualty numbers include by rate, by 
table, or by user-defined rates. TML+ uses FORECAS and CASEST as 
underlying patient stream data. 

Colocated Medical 
Treatment Facility 

MTFs grouped together to augment the medical services they provide. For 
instance, an FRSS and an STP may be placed together to add operating 
room tables and hence the ability to perform life- and limb-saving 
procedures. 

Appendix 
A Glossary
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Glossary 

Name Description 

Common Database The Common Database is an object within a scenario that represents the 
medical capability and transportation types that may be reused. The 
Common Database also incorporates data for over 400 patient conditions 
and the corresponding medical treatment tasks. 

CRTS Casualty Receiving Treatment Ship – A general-purpose amphibious 
assault ship that receives, provides treatment for, and transfers casualties. 
Its objectives are to save life and limb, provide initial resuscitative 
treatment, and perform stabilization for evacuation of casualties whose 
medical requirements exceed its capabilities. CRTS capabilities include 
triage, lab, x-ray, operating room (OR), ward, pharmacy, dental, battle 
dressing station, portable medical locker, antidote locker, first-aid box, 
emergency response kit (ERK), junior ERK, and preventive medicine (PM) 
capability. CRTS is modeled with the medical capabilities, personnel, and 
supplies of a Surgical Company (SC). 

DIS Disease – A casualty type designation indicating that the person presented 
at an MTF with an illness. 

DOW Dead of wounds or died of wounds. 

ERCS En Route Care System – A medical capability that provides treatment while 
in transit. ERCS has three phases: casualty evacuation (CASEVAC), 
tactical medical evacuation (MEDEVAC), and strategic evacuation. (See 
each of those entries for more specific definitions.) 

FA  Functional Area – A medical capability within an MTF designated for a 
specific purpose (e.g., the OR, or the x-ray component).  

FRSS Forward Resuscitative Surgical System – A medical capability that provides 
limited triage/preoperative trauma management and postoperative holding 
capability, and is equipped to provide life- and limb-saving surgical 
procedures. Includes triage, OR, and ward (with limited holding capability). 
An FRSS can serve as a forward element of the SC or as a stand-alone 
surgical element colocated with a BAS or STP. 

Iteration(s) Also called a run, the number of times a scenario is “run”, or simulated, 
through TML+. 

KIA Killed in action – Troops who die on the battlefield and do not receive any 
medical care. 
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Glossary 

Name Description 

Lab/Pharm Functional areas within a Surgical Company or a CRTS. Lab provides 
hematology, microbiology, blood chemistry, and urinalysis capabilities. 
Pharmacy provides the materiel required to establish and maintain 
pharmacy capabilities. 

MEDEVAC Medical evacuation system – The evacuation system that provides care 
during evacuation from a BAS, STP, FRSS, or SC to a theater hospital. 

MTF Medical treatment facility – Any of a number of different configurations of 
medical materiel and personnel combined to provide various levels of 
medical care. 

NBI Nonbattle injury – Injury incurred while engaged in any activity performed 
outside the battlefield. 

NEA Northeast Asia 

Objects The parts of TML+ and its scenario-building functions that include casualty 
generators, points of injury, medical capabilities, MTFs, transportation 
assets, and routes between MTFs. 

OR Operating Room – A functional area within an MTF. The OR provides 
resuscitative/stabilizing surgery to casualties unlikely to survive MEDEVAC. 

Patient queuing The part of the system for drawing a population of casualties through a 
medical treatment network that dictates the order in which patients will be 
treated. 

Patient stream The specific configuration of casualties (in PC Code descriptors) that a 
scenario may include, in some cases stochastically calculated, based on 
probabilities established by the casualty estimation tools FORECAS and/or 
CASEST. 

PC or 

PC Code 

Patient Condition code – A three-digit number describing casualty patients’ 
injuries, physical conditions, or diseases. A group of 400 or so PCs were 
formulated by the Defense Medical Standardization Board to standardize 
diagnostic formats across medical resource models. PC codes constitute 
the underlying data on which TML+ and other medical modeling and 
simulation programs draw. 
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Glossary 

Name Description 

PM Preventive Medicine – Equivalent in some ways to a functional area, but 
because it does not treat patients, it is more a medical capability, as it 
performs necessary technical functions for ensuring water potability, food 
inspection, sanitary waste disposal, vector control, and communicable 
disease monitoring and immunization. 

POI Point of injury – Indicates a geographical site on the battlefield where injury 
occurs. In TML+, it is considered the point from which the First Responder 
must move or transport the injured individual. 

Properties Details of those variables that define TML+ objects within a scenario. For 
instance, to establish overall units of measure for time or distance, the user 
navigates within the Properties box to select either days or hours (for time), 
or kilometers (km), miles (mi), or nautical miles (nm) (for distance). 
Properties may also determine scenario parameters such as mean number 
or type of casualty, or types of behavior within an evacuation route for an 
MTF. 

Random Seed 
Number 

As a stochastic model, TML+ uses random draws to simulate a scenario. 
This process requires a random seed number, used to initialize the random 
number generator. A large prime number works best. 

Replications Each replication represents a patient stream being run through a simulated 
treatment network once. The user may define the number of times the 
stream is put through the simulation so as to get a representative sample. 

Runs The number of times a given scenario is run. See also Iteration. 

SBA Self-Buddy Aid – The treatment at the POI that each patient gives 
themselves or receives from another troop. 

SC Surgical Company – An MTF that typically has greater surgical and medical 
capabilities than a BAS, including triage, OR, ward, x-ray, laboratory, 
pharmacy, dental, and preventive medicine functional areas. SC objectives 
are to save life and limb, provide initial resuscitative treatment, and perform 
stabilization for evacuating casualties whose medical requirements exceed 
SC capabilities. 

Service discipline This refers to the two rules by which a patient stream is queued: either 
based on a first-in, first-out basis (FIFO) or one which dictates that the 
casualty with the worst injuries is treated first. 
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Glossary 

Name Description 

Stochastic vs. 
Deterministic 

Statistical methods used in TML+ to determine patient stream and flow. 
Stochastic is synonymous with random, pertaining to chance, while a 
deterministic method does not involve chance, but always produces the 
same output for a given starting condition. In TML+ this means that when 
creating a patient stream, the model takes a stochastic or random draw 
from the pool of underlying data that relies on assigned probabilities to 
determine if a particular patient condition will show up for treatment in the 
patient stream. A deterministic equation would read: if this condition is 
present, that always occurs, and in TML+, it is used to model patient flow 
within the medical chain of evacuation. If the first MTF is busy, then the 
patient moves to the next level of care. 

STP Shock Trauma Platoon – An MTF that can serve as a beach evacuation 
station, reinforce a BAS, operate as an intermediary casualty collecting and 
clearing point between forward elements and the Surgical Company (SC), 
or serve as the forward element of an SC (i.e., triage /evacuation platoon) 
preparing to relocate. STP has triage and limited operating room (OR) and 
ward capabilities. 

Strategic evacuation An En Route Care System (ERCS) that renders care during evacuation 
from the theater hospital to definitive care inside or outside the continental 
United States. 

SWA Southwest Asia 

Triage/SST A functional area within an MTF that provides receipt, resuscitation, and 
sorting of casualties, treating casualties with battle injuries, nonbattle 
injuries (NBIs), and those who can return to duty within 72 hours. The 
triage/SST renders general surgical support and preoperative clinical 
functions. 

Ward A functional area within an MTF. Surgical Company ward provides 
monitoring and recuperative care to postoperative patients and those who 
can return to duty within 72 hours. FRSS ward has limited holding 
capabilities. 

WIA Wounded in action 

X-ray A functional area within an MTF that provides x-ray and processing 
capabilities. 
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