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Overview 

History 
The Head Spine Model (HSM) was originally developed by the USAF Aeromedical 
Research Laboratory during the late seventies. The HSM was created to aid the 
solution of problems related to spinal loads resulting from ejection seat acceleration. 
Unfortunately, the original researchers who developed and used the HSM left the 
Government and the original code has not been maintained or used in research for 
several years. 

Biodynamic Research Corporation contracted with the USAF to create a computer 
model of the dynamic response of the human head and spine that executes on a PC 
compatible computer under a Windows environment. The HSM-PC is aimed at 
creating simulations of the biomechanical responses of the head and spine to 
potentially traumatic impulsive acceleration and impact events. 

About This Guide 
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User Guide Organization 

Chapter Description 

Overview 

Installation 

User Interface 

The Simulation Wizard 

Editing Parameters 

Running a Simulation 

Plotting Output Values 

Animation 

HSM-PC Database 

Glossary of Terms 

Technical Support 

The history of the Head-Spine Model and a 
documentation overview. 

A description of HSM-PC system requirements, 
installation procedures and the uninstall 
procedure. 

A description of the major features of the user 
interface including the menu bar, toolbars, and 
tabs. 

How to design a simulation by specifying the 
model elements, the environment, and the 
simulation parameters. 

A description of the mechanism for editing 
various parameters in a simulation. 

How to run a simulation once you have all the 
specifications assigned. 

An overview of the plotting facilities included in 
HSM-PC. 

A description of the animation capabilities of 
HSM-PC. 

A description of the HSM-PC database and its 
customization options. 

List of key terms used in this document, and the 
corresponding definitions. 

A description of the technical support services 
that are available for HSM-PC. 
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Installation 

What You Need 
HSM-PC is a native 32-bit Windows applications designed to install with a 32-bit 
operating system. 

Before you begin installing HSM, make sure you have 

• An IBM PC or compatible with a 486 or Pentium-class microprocessor 
and 8 megabytes of RAM (16 recommended) and a mouse. 

• The HSM CD-ROM or floppy disks. 

• Windows 95 or Windows NT 4.0 (or higher) on your system. 

• Approximately 15 megabytes of available hard disk space. 

Installing HSM 
This section describes how to install HSM on a stand-alone system. 

To install HSM: 

1. Run Windows. 

2. Put the HSM CD ROM into your CD ROM drive. 

3. Click the Start button and click Run. 
The Run dialog box displays. 

4. Type the letter of the drive into which you put the CD ROM followed 
bySETUP.EXE. Then click OK. 
For example, if D is the letter assigned to your CD ROM drive, you 
would type, D:\Setup.exe. 
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Removing HSM 

The Setup Information screen displays. 

Read this screen and click OK. 
The HSM Directory dialog box displays. In this dialog box you can 
select the directory in which you want to install HSM. The default is 
C:\PrograrnFiles\HSM. 

To install: 

A) To the default directory, click the large square button on the dialog. 
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(B) To specify another directory, click the Change Directory button 
and type the full path in which you want to install HSM. 

When you have selected a path, click OK. You will see a status bar 
indicating the progress of the install. Then you will see a message 
iriforming you that the setup is complete. 

7.    Click OK. 

This section describes how to remove all HSM program files from your system. 

1. Run Windows as you normally would. 

2. Click the Start button and point to Settings. In the Settings folder, 
click Control Panel. 

3. Double-click the Add/Remove Programs icon. 
The Add/Remove Programs Properties dialog box displays. 

4. Click the Install/Uninstall button. 

5. In the Uninstall list box, click HSM and click the Add/Remove button. 
The Uninstall HSM dialog box asking if you want to remove the HSM 
program and all of its files displays. 

6. Click Remove to remove all HSM files from your system. 
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User Interface 

MoM It In M*rloU»*^.i 

Tabs 

Menu Bar 
The HSM-PC Menu Bar is always visible within HSM-PC. It contains five drop- 
down menus: 

• The File menu contains New, Open, Close, Save, Save As, and Exit 
options. 

• The Edit menu allows you access to property screens for the simulation 
parameters. 

• The Run menu is used to initiate the computational portion of the 
simulation. 

• The View menu is used to evaluate the results of the simulation. It 
includes options for Animation or Plotting data. 

• The Tools menu allows the user to access either the Calculator or a 
Text Editor. 

• The Help menu gives you quick access to the Help Index and version 
information. 

Status information is displayed on the Menu Bar to the right of the Help option. 
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Toolbar 
Many of the essential HSM-PC tools are included on the toolbar, which is located at 
the top of the main HSM-PC window. While some of these buttons should be very 
familiar to you from other Windows applications, others will be new to yaa. 

New   Open  Save   Properties   Run  Animation Editor  Help 

Name Function 

New Create a new the simulation. 

Open Open an existing simulation. 

Save Save the current simulation. 

Properties Shows a drop-down menu of property dialogs. 

Run Runs the computational portion of the program. 

Animation Loads animation data and displays the animation toolbar. 

Editor Opens the text editor. 

Help Opens the help file. 

Tabs 
The tabs at the lower left corner of the screen give you access to either viewing the 
graphical representation of the Head-Spine model or viewing plots of the output data 
from the simulation. 
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Simulation Wizard 

Creating a New Simulation 
Creating a simulation is a 5-step process. The Simulation Wizard walks the user 
through five screens and indicates the options available. Along with each step in the 
simulation specification process a separate text file is generated. These files can 
later be reused in designing future simulations. The initial wizard screen is shown 
below. 

Simulation Parameters 
In Step 1 the simulation times, units, and print style are specified. The Starting Time 
and Ending Time are needed to determine the simulation duration. The Print Interval 
indicates how often data is recorded in the output file. The Units option is used to 
specify units for the user interface and the output file. Print Style indicates whether 
all values are recorded at each time step, or the output values are grouped by 
element. The Step-by-Step mode is an option to facilitate debugging when the 
computational portion of the program does not run to completion. The Step-by-Step 
Print Style enables the user to determine at what point the computation failed and 
what values were recorded just before the failure. 

Simulation Paiamete 
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The file containing simulation parameters is referred to as the Input File. As you 
leave this dialog you will be asked if you wish to use an existing Initialization File or 
generate a new one. The Initialization File contains data for the model during the 
initial settling period. When an Initialization File is reused, time is saved on the 
computations. 
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Selecting A Model 
In Step 2 the simulation model is selected. There is a choice of three different 
models. The first model, Selected Vertebrae, allows the user to select a range of 
vertebrae to include in the simulation. When this option is selected a list box of all 
rigid bodies is displayed and the range of vertebrae can be selected. The second 
model, Head-Cervical Spine, includes the head, cervical spine, Tl, and 
representations of the viscera. The third model, Head Spine, includes the head, all 
vertebrae from Cl to L5, the ribs, the pelvis, and representations of the viscera. The 
file containing the parameters for the elements of the selected model is referred to as 
the Elements File. 

Specifying the Environment 
In Step 3 the environment is specified by adding Rigid Bodies, Springs, Planes and 
Constraints to the simulation. Rigid Bodies, Springs and Planes can be used to 
represent restraint systems and occupant seating. Planes are required for the 
application of forcing functions during the simulation. Constraints are used to 
constrain the motion of a rigid body in any dimension. The file containing the 
parameters for Rigid Bodies, Springs, Planes and Constraints is referred to as the 
Environment file. 
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Defining Forcing Functions 
In Step 4 Forcing Functions can be defined. There are two types of Forcing 
Functions that can be applied to the planes of a simulation. The user can select from 
a set of Standard Functions (rectangle, triangle, sinusoid, and haversine) or design 
their own. The functions can be defined as a Position, Velocity or Acceleration. The 
user must also define a Direction Vector for the plane of the forcing function. User 
defined functions can be supplied from a text file or by utilizing a Spreadsheet that is 
provided with the program. The file containing forcing function information is 
referred to as the Forcing Function file. 

Fencing Function Definition 

Specifying Output 
In Step 5 the data for the Output file is specified. The elements and appropriate data 
values that will be recorded in the Output file are selected using the dialog shown 
below. Use the check boxes to select the parameters to be recorded and the list box 
to select the elements. The Output file will contain data for each recorded value of 
each selected element at each time step. 
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Editing Parameters 

To edit the parameters of a simulation, either click the 
select Edit from the Main Menu. 

J?M toolbar button or 

The pull-down menu on the right will be 
displayed. This menu gives access to the 
dialog boxes for editing various parameters 
of the simulation run. It also displays the 
names of the text files used to store the 
parameter values. If the file name is 
selected, a Save As dialog will be displayed 
and the name of the text file can be 
changed. 

Editing Model Parameters 
When Model is selected from the Edit pull-down menu the Model Properties dialog 
is displayed. The Model Properties dialog has a tab for each type of element in the 
model. The specific element for that type can be selected from a combo box at the 
top of the tab and then the properties for that element will be displayed below. These 
properties are read from the HSM-PC database. The properties are displayed in the 
units which were selected for that simulation. These values can be changed for a 
specific simulation, but changing the model parameters is strongly discouraged. 
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Editing Environment Parameters 
When Environment is selected from the Edit pull-down menu, the External Element 
Properties dialog is displayed. This dialog has a tab for each type of element in the 
environment (Rigid Bodies, Springs, and Planes) and a tab for specifying Constraints 
on Rigid Bodies in the model. To add new elements to the environment, use the 
Add button at the bottom of the dialog. To remove an element, first select it in the 
list box above and then use the Delete button at the bottom of the dialog. To save 
the changes, select the OK button. To exit without saving, use the Cancel button. 

Rigid Bodies 

To define a Rigid Body, select the Rigid Bodies tab and press the Add button at the 
bottom of the dialog. You will be prompted for a name for the rigid body. Next, 
enter the x, y, and z coordinate values of the primary node for that rigid body using 
global coordinates. Once a primary node has been defined, secondary nodes for that 
rigid body can be added using the Add button under the Secondary Nodes list box. 
Again you will be prompted for a name for each secondary node. After the node has 
been named, enter the x, y, and z coordinate values (in local coordinates) in the fields 
provided on the right. 
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Springs 

To define a Spring in the environment, select the Springs tab and press the Add 
button at the bottom of the dialog. You will be prompted for a name for the Spring 
and the name will be added to the list box. Now the type of Spring can be selected 
along with its Kl and K2 values. The end points are selected from a list of primary 
and secondary nodes. 

Planes 

To define a Plane in the environment, select the Planes tab and press the Add button 
at the bottom of the dialog. You will be prompted for Plane number and the number 
will be added to the list box. Now the coordinates for the three points defining the 
plane can be entered. The Tab key will position the cursor for entering x, y, and z 
for point 1 and similarly for point 2 and point 3. Then stiffness to deflection and 
stiffness to deflection rate can be entered. If any of the values need to be adjusted, 
simply position the cursor on the appropriate field and enter the new value. Any 
Planes that are defined for the environment can later be used in defining forcing 
functions. 
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Constraints 

To define a Constraint for a rigid body, select the Constraints tab and press the Add 
button at the bottom of the dialog. You will be prompted for Constraint number and 
the number will be added to the list box. Next select the Rigid Body that you wish to 
constrain. Use the check boxes at the lower part of the dialog to indicate the motion 
requiring Constraint. 
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Editing Forcing Function Parameters 

When Forcing Function is selected from the Edit pull-down menu, the Forcing 
Function Definition dialog is displayed. To add a new Forcing Function, select a 
Plane using the arrows at die upper left of the dialog. Once you have selected a 
Plane you can specify the style, type and direction vector for the function. 

Standard Functions 

If you select a Standard Function as the style, use the second tab to specify the type 
of function and the function parameters. For Standard Functions you can select from 
rectagular, triangular, haversine and sinusoidal. Further you need to specify the 
begin time, end time, peak time (for triangular functions only), offset, and amplitude. 

Head-Spine Model Editing Parameters «15 



User Defined Functions 

When a User Defined FumctiOT is selected, the options are to use a file to define the 
function or use the Spreadsheet provided by the program. If you opt to use a file you 
will be prompted for the file name. The file should be a text file with two columns 
of values. The first column specifies the time and the second column specifies the 
function value for each time. 

When the Spreadsheet option is selected, select the Spreadsheet tab and enter the 
data describing the function in the value column of the Spreadsheet. The 
Spreadsheet includes graphing capability so that you view the function as you enter 
values into the Spreadsheet. When the Forcing Function Definition is complete the 
Forcing Function file will be saved for later use. 
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Editing Simulation Parameters 
When Simulation is selected from the Edit pull-down menu, a submenu is displayed. 
The submenu contains options for Timing Parameters and Output Parameters. 
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Editing Timing Parameters 
The dialog for editing the simulation Timing Parameters is the same as the dialog 
described in the Simulation Wizard for setting up Simulation Parameters. Change 
any of the values that require updating and then press OK. 

Editing Output Parameters 
The dialog for editing the Output Parameters is shown below. Different element 
types are displayed on different tabs. Elements from the environment are grouped on 
the External Elements tab. Use the check boxes to select the parameters to be 
recorded and the list box to select the elements of interest. Change any of the values 
that require updating and then press OK. 
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Running a Simulation 

The Run Option 
To initiate the computational portion of HSM-PC, eisfaer click the 
button or select Run Simulation from the Rua metw. 

toolbar 

During the execution of the simulation the screen will display the time steps as the 
simulation progresses. 

When the simulation computations are complete a dialog will indicate that the 
program has terminated and will ask "Exit Window?" Select Yes. 

After the simulation has been run the Text Editor will display the Error File to 
display any messages from the computational run. If the simulation is successful, the 
user will now be able to review the results. Plotting and animation capabilities are 
provided, or the output file can be viewed with the Text Editor to observe the raw 
data values. 
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Plotting Output Values 

Plotting Options 
When the Plotting tab is selected the screen will display the Plotting Screen. On the 
right-hand portion of the screen are two panels for specifying the Plotting Options. 
The upper panel has a list of any mode! elements which have plot values available in 
the output file. The lower panel has the element values to plot. 
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Plot Items 

Plot Values 
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Mconds 

The Plot Items Panel displays a hierarchical list of all the model elements which 
were selected for the output file. A heading will appear for each group of an element 
type such as Rigid Bodies or Muscles. When the "plus" sign to the left of the 
heading is clicked the hierarchy is expanded to show all the specific elements ofthat 
type. After expansion, the "plus" sign becomes a "minus" sign. To collapse an 
expanded portion of the hierarchy, click the "minus" sign and the specific elements 
will no longer be listed. To select model element for plotting, click on the specific 
element in the expanded hierarchical list. 

Once a model element is selected from the Plot Items list, the lower panel will 
display the values which are available for that model element. Select the value you 
wish to plot from the Plot Values and the plot ofthat value will be displayed. 
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Animation 

Simulation Animation 

After the computational portion of the HSM program has been run, the output data 
can be viewed as an animation. To initiate an Animation either select the Animation 
option on the View menu or click the Animation button on the toolbar. 

The screen will display the animation toolbar on the right-hand side. The model will 
only display rigid bodies and planes during the Animation sequence. 

Animation Toolbar 

Animation 
The Animation portion of the toolbar allows you to play, 
stop, and rewind the animation sequence. The Loop 
Mode button will play the animation sequence 
continuously until the stop option is selected. 

Step Mode 
The Step Mode portion of the toolbar has tools for 
stepping through the animation sequence in a forward or 
backward direction. The Step Frames options allows you 
to set the number of frames to be advanced with each 
step. 

Speed 
The Speed portion of the toolbar allows the user to set the 
rate of the animation sequence. The Time Step of the 
current frame is also displayed here. 
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Print Image 
The Print Image option brings up a dialog which allows the user to select a page 
layout for printing snap shots from the Animation sequence. The dialog has options 
for a single image page and two sizes of images on a four image per page layout. 
The dialog will also prompt the user for the bitmap images to use for the page 
layouts. 

Save Image 
The Save Image option enables the user to download the current screen image to a 
bitmap file. The user can use the step mode controls to select the desired image and 
then capture that image using the Save Image option. A Save File dialog will prompt 
the user for a file name to assign to the bitmap. These saved images are used with 
the Print Image option described above. 
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HSM-PC Database 

Background 

Interface 

The researchers who created the original AAMRL HSM created an extensive 
collection of anatomic, geometric, and materials property data relating to the spine 
and its associated tissues. These data were documented in the program Technical 
Reports or in the HSM code. The data documented in the original HSM program is 
dated and is not available in an easily accessible form. A key technical objective of 
the Phase II program was to extract, update, and audit the geometric and materials 
properties for incorporation in an HSM-PC Database which can be accessed by the 
HSM-PC program on-line or employed as a stand-alone database on the structure 
and materials properties of the spine. 

The HSM-PC Database was developed using Microsoft Access 97. The data in the 
database include the coordinates and parameter values used in HSM as well as 
additional data from the more current literature. 
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The database application has a main menu that allows, access to data from different 
areas of the spine. Once a selection has been made from the main menu, individual 
records fkom the database can be viewed. 
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The buttons at the lower left coiner on fee screen allow navigation through the 
database. From this screen a multiple record view can be selected by pressing the 
button labeled Multiple Record View. 
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Glossary of Terms 

Sliding Node 
A sliding node is used to represent tie forces exerted by muscles which curve around 
the bones of the spine and torso. 
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Index 

Error! No index entries found. 
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