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Preface 

The Convenience Food Logistics Model (CFLM) and its supporting Database Management 
Information System (DBMS) were developed by Information Technology Solutions, Inc. (ITS) as a 
decision support system for the Naval Supply Systems Command (NAVSUP). The project was 
completed under the direction of US Army Natick Research, Development & Engineering Center 
from September 1994 until June 1995. The purpose of this effort was to develop a computer based 
information system that projects the potential impact of prepared or "convenience" foods on food 
service aboard 21st century Navy warships. 

This report is one of four related reports published as a result of the efforts for the Navy Food Service 
2000 (NFS 2000) project. The purpose of this project was to investigate the impact of using 
convenience foods in Navy food service. The other three reports include the design of the model, an 
analysis using the model, and the results of Navy Food Service 2000 project. Their respective titles 
and Technical Report numbers are: "Convenience Food Logistics Model - Design," Miller, J., Saraf, 
S.,PhD, and Evangelos, K., NATICK/TR-96/016;   "Logistical Analysis of Convenience Food 
Substitution in a Typical Navy Menu for a Wasp Class Amphibious Assault Ship (LHD)," Saraf, S., 
Ph.D., Evangelos, K. And Hill, B., NATICK/TR-96/018; and "Analysis of the Impact of Convenience 
Foods on Navy Food Service," Evangelos, K., Adams, S., Dr.PH, RD, Short, P. et al., NATICK7TR- 
96/019. 

The authors extend their appreciation to Dean-Michael Sutherland, Operations Research Systems 
Analyst, Advanced Systems Concepts Directorate, for his efforts in project documentation and 
technical editing. 

The authors also wish to acknowledge Teddy Spealman and Rebecca Shuford, of the ITS project 
team, for their assistance in the development of the User's Manual, Windows on-line Help System, 
and Graphics, as well as their efforts. 
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CONVENIENCE FOOD 
LOGISTICS MODEL 
USER'S MANUAL 

1. INTRODUCTION 

1.1 Purpose Of The User's Guide 
The objective of this manual is to familiarize new users with the Convenience Food Logistics Model 
(CFLM) and to provide information necessary for effectively using system functions and features. 

1.2 Conventions 
The following conventions are used throughout this document: 

• Bold text indicates the name of a pull down menu. 

• Bold Italicized text indicates the name of the screen displayed. 

• Italicized text is used to indicate buttons. 



A Glossary of Terms and Abbreviations used throughout this manual can be found in Appendix A; 
Appendix B contains a list of Error Messages; Appendix C contains Recipe Labor Codes; Appendix 
D contains Convenience Food Product Labor Codes; Appendix E contains the Recipe Categories; 
Appendix F contains Product Types; and Appendix G contains Ship Classifications, Types, and Class 
Codes. 

1.3 Security 
The Convenience Food Logistics Model is based on Naval Supply Systems Command (NAVSUP) 
Publication 7, Armed Forces Recipe Service (AFRS), REVISION, September 1992. Any changes to 
a recipe alters this military document. Changes to a recipe should be saved as a new recipe versus 
replacing an existing one thus ensuring data integrity. In addition, it is important to note that the 
CFLM is designed using tables stored in specific directories. Any attempt to change these directories 
will cause system failure. 

1.4 Messages 
The system is designed with a series of built-in messages to alert and prompt the user as necessary. 
These messages are in the form of Error, Warning, and Information Messages. These messages are 
displayed in dialog boxes and most require a response by the user. Click on the OK button of the 
Error, Warning, or Information dialog box after reading the message to continue. If the Program 
Error box appears, click on the Ignore button. The system will return to the data field that caused the 
message to allow the user to respond accordingly. (A list of Error Messages can be found in 
Appendix B.) 



2. GETTING STARTED 

2.1 Installing The Convenience Food Logistics Model - 
Database Management System 
Before installation of the Convenience Food Logistics Model (CFLM) - Database Management 
System (DBMS) a backup copy of the original installation disks should be made. To install the 
CFLM - DBMS, insert Disk 1 in the 3 1/2 inch disk drive and type Setup. The user will be instructed 
to insert additional disks as required. Once installed, a back-up copy of the contents in the Tables 
directory should be made which may be used to restore operation of the system in case the data 
becomes corrupted. These files should also be backed-up on a regular basis in case of system failure. 
The user will be able to restore the system by simply copying the back-up Tables sub-directory over 
the corrupted file. 

2.2 Accessing The Convenience Food Logistics Model 
Database Management System 

n 
CFLM 

The CFLM - DBMS is accessed by double-clicking the CFLM DBMS Icon located 
in the Main Application Window of the Program Manager. The Convenience Food 
Logistics Model Screen (Figure 2.2-1) will appear with main menu options 
displayed. 

FIGURE 2.2-1 Convenience Food Logistics Model Screen 



3. SYSTEM SUMMARY 

3.1 General Information 
The CFLM DBMS was designed for the Naval Supply Systems Command (NAVSUP) to be used as a 
management tool for conducting logistics and cost/benefit analyses on the Armed Forces Recipe 
Service menu items (A-Rations) when substituted with convenience food products. The model has 
several Navy unique features and includes inquiry and report generation capabilities. Analyses are 
accomplished by iteratively running logistical inquiries for various ship types, attendance and selection 
rates. Changes to substitution rates for various 'generic categories' of menu items such as entrees, 
breakfast items, etc. can easily be generated to determine effects of convenience food product 
substitution on labor hours, food costs, and storage. 

3.2 System Requirements 
The following paragraphs define the hardware and software requirements necessary to implement and 
support the CFLM DBMS application. 

3.2.1 Hardware Requirements 
Workstations - In order to implement the CFLM DBMS application, workstations should be, 
at a minimum, a 486DX class PC with a Central Processing Unit (CPU) speed rated at 33 
MHz. Each workstation should be configured with a minimum of 8 MB of RAM, a 3 1/2 inch 
floppy disk drive, 4 MB hard disk space, a high resolution, non-interlaced color video display 
(1024 x 768), an SVGA video card, a keyboard and a mouse. 

3.2.2 Software Requirements 
The CFLM DBMS application workstations should be configured with the following 
software: MS DOS 6.0, Microsoft Windows Version 3.1, or higher. 



3.3 CFLM DBMS Menu Structure 
The CFLM DBMS Menu Structure (Figure 3.3-1) displayed below contains a menu bar with menu 
items that allow the user to navigate through the system processes. The menu options for all of the 
menu levels are described in detail in the following chapters. 
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FIGURE 3.3-1 CFLM DBMS MENU STRUCTURE 



*REPORTS 

• Run Logistical Inquiry A-Rations 

1. Print User Input 

2. Print Selected Menu 

3. Print Menu with Labor/Eq/Strg/Cost Req. 

4. Print Logistical Info with List of Requirements 

5. Identify Items by Application Logistics Code 

6. Print List of Acquisition Advice Codes 

7. Print List of Usage Management Codes 

* Run Optimization Model Option 

1. Print User Input 

2. Print Input A-Ration Menu 

3. Print A-Ration Menu with Logistics 

4. Print Optimized Menu with Substitutions 

5. Print Optimized Menu with Logistics 

6. Print Items with List of all Substitutes 

7. Print A-Ration versus Optimized Comparison 

8. Print Equipment Comparison 

3.4 Standard Menu Options 
There are three standard menu options available on the menu bar for the Recipe Information, 
Convenience Foods, Logistical Information, and Ship Information Screens: 

1. File -- New, Delete, Search, and Exit. 

2. Print — Varies with each screen based on preformatted print functions 

3. Help ~ Contents and Search For Help On. 

The Menu Creation Screen has three standard menu options available: 

1. File — Create Menu, Select Menu, Delete Menu and Exit. 

2. Print -Varies based on preformatted print functions 

3. Help ~ Contents and Search For Help On. 

The four standard menu options available when selecting Run Logistical Inquiry A-Rations or Run 
Optimization Model from the Options menu item are: 

1. File-Exit 

2. Inquiry — New Inquiry 



3. Reports — Previews/Prints preformatted reports. 

4. Help— Contents and Search For Help On. 

The system's default mode is Edit. The system will remain in edit mode until either the Search or 
New option is selected. To add a new record to the CFLM DBMS, select New from the File menu 
option; the system will enter append mode. To delete a record, select Delete from the File menu 
option. To search for a record, select Search from the File menu option, provide the desired search 
criteria and click on the Execute Search button located on the bottom of the screen to start the 
search. 

3.5 Standard Button Functions and Keystrokes 
Command Buttons, also called Push Buttons, are used throughout the CFLM DBMS to invoke a 
particular action associated with a screen. To execute the action, use the mouse to point-and-click on 
the Command Button. Note that most Command Buttons only require a single-click on the mouse to 
be executed. Most commonly used Command Buttons throughout the CFLM are the Save and Exit 
buttons. 

Press the Save button to save new information. To exit the screen click on the Exit button. If a new 
record has been added and has not yet been saved, a dialog box will appear prompting the user to 
save the changes prior to exiting. On the screens that do not display a Save button, any modifications 
made will be saved directly. Click on the Exit button or select Exit from the File menu to exit the 
screen. 

Another type of button used in the CFLM DBMS is called the Radio button. These buttons are 
displayed as circles with a black dot placed in the center of the chosen option. If the user selects a 
different option, the one that is currently selected is changed back to a plain circle. Only one option 
can be selected at a time. For example, Radio buttons are used to select the report destination in the 
Print option. 

Check Boxes provide the ability to select from various options. When an option is selected, an 'X" 
appears in the box; otherwise the box appears empty. For example, the user can select other 
equipment required for a recipe in the Recipe Information Screen by using the Check Box feature. 

To view or edit records, use the 'Page Up' and 'Page Down' keys located on the keyboard. The 
Status bar located at the bottom of the screen indicates the leading table into which information is 
being stored. It will also indicate the record number in the table where the system is standing. For 
example if'Log file 1713/1925' was displayed, the system would be standing at record number 1713 
(1925 records total) in the Log-file table. Press the Execute Search button to activate the search 
function after Search has been selected from the File menu and the search criteria has been entered. 
Use 'Page Up' and 'Page Down' keys to review the result set. There may be a slight delay between 
the time a user presses a 'Page Up' or 'Page Down' key and the time the data is displayed on the 



screen. This is due to the overhead required to refresh the screen. ('Refreshing' the screen is the 
process by which new data appears as the system moves to a new record.). 

When selecting an item from a pop-up, use the scroll bar to view the entire selection and click on the 
desired item. If the list of items is larger than can fit in the pop-up, the user can access an item 
quicker by pressing the first letter of the item (i.e., 'L' to scroll quickly to the items whose title begins 
with an 'L'). Click outside the pop-up to avoid selecting from the box if desired. 

To move around in the CFLM DBMS screens, the user can use the 'Tab' or the 'Enter' key after 
entering a data field to automatically move the cursor to the next logical data field. The user can use 
the mouse to move directly to a specific data field if desired. 

Selecting menu options can be done using shortcut keys. By pressing the lAlf key and the letter that 
is underlined moves the user quickly to the desired function. For example, pressing Alt R opens the 
Recipe Information Screen. 

3.6 On-Line Help 
The Help menu allows users to obtain information about the CFLM DBMS and its functions, using 
the standard hyper-text features found in other Windows Help systems. These features include the 
capability to search for topics by keywords, print and annotate topics, and create bookmarks. 



4. RECIPE INFORMATION 
SCREEN 

4.1 General Information 
The Recipe Information Screen allows the user to perform functions such as add, delete and search 
for recipes in the AFRS database. The Ingredients Screen, a subsystem of the Recipe Information 
Screen, allows the user to view a list of the ingredients required in the selected recipe. Ingredients 
may be added, changed or deleted from this screen. It is recommended that changes to existing 
AFRS Recipes should be done by creating a new recipe with a "Z" prefix. Cost of recipes based on 
ingredients used and Convenience Food Substitution Lists are also generated from the Recipe 
Information Screen. To access the Recipe Information Screen menu selections, the user will select 
the Recipes menu item in the CFLMMain Application Screen menu bar. The remainder of this 
section will describe in detail the Recipe Information and Ingredients Screens' Command Buttons 
and step by step instructions for using the Recipe Information and Ingredients Screen. 

4.2 Recipe Information Screen Command Buttons 

4.2.1 Select Recipe Category Command Button 
Allows the user to identify the part of the meal for which the recipe would be served. 
Clicking on this button produces a pop-up displaying available meal categories from 
appetizers to desserts. (Refer to Appendix E for a listing of Recipe Categories.) 

4.2.2 Select Product Type Command Button 
Allows the user to categorize the type of the ingredient. Recipe items and convenience food 
products should be categorized based on the main ingredient of the item. However, to 
maintain consistency with ethnic themes in a menu, the user should categorize such items 
based on their ethnic (cultural) flavor as opposed to their main ingredient item. This category 
is required for generating convenience food substitutes. Clicking on this button produces a 
pop-up displaying available meal types such as pasta items, Asian food, seafood, etc. (Refer 
to Appendix F for a list of Product Types.) 



4.2.3 Select Standard Labor Type Command Button 
Allows the user to identify the actual "hands on" time involved with preparing the recipe. 
(Refer to Appendix C for a complete list of Recipe Labor Codes.) Variations in the 
preparation time due to progressive cookery, kettle cooked, and more labor intensive recipes 
such as bakery items are factored into the average time associated with the labor type. 
Clicking on this button produces a pop-up displaying standard cooking categories; Prepare 
and Bake, Bake from Scratch, Bake from Mix, etc. Once selected, the estimated time (in 
minutes) to prepare for 100, 200 and 500 portions are displayed. This data field can be 
changed as necessary resulting in different time requirements based on the labor type entered. 
The time displayed is an average time based on test data. 

4.2.4 Browse Existing Recipes Command Button 
Allows the user to locate and select a specific recipe in the AFRS database. Clicking on this 
button produces a pop-up displaying all recipes stored in the AFRS database. The user can 
scroll down the list to select a specific recipe. The user can access a recipe more quickly by 
pressing the first letter of the recipe prefix (i.e., 'L' to scroll quickly to the recipes whose 
prefix begins with an 'L'). When a recipe is selected, all associated information is displayed. 

4.2.5 Ingredients Command Button 
Allows the user to view, enter or change ingredients for a selected or current recipe displayed 
on the screen. Clicking on this button produces the Armed Forces Recipe Service - 
Ingredients Screen. 

4.2.5.1 Armed Forces Recipe Service - Ingredients Screen 

Once activated the Armed Forces Recipe Service - Ingredients Screen allows the 
user to view existing ingredients for the selected recipe, add new ingredients, and/or 
delete ingredients. 

4.2.5.1.1 Add Ingredients 
File Menu Item —Add - Allows the user to view/select an ingredient from a 
pop-up and add it to the selected recipe. 

4.2.5.1.2 Delete Ingredients 
File Menu Item — Delete - Allows the user to view/select an existing 
ingredient and delete it from the selected recipe. 

4.2.5.1.3 Exit 
File Menu Item — Exit - Allows the user to exit the AFRS Ingredients Screen 
and return to the Recipe Information Screen. 
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4.2.5.1.4 Browse Command Button 
Allows the user to enter amounts required for an ingredient and/or to make 
changes to existing ingredients. Clicking on this button opens the Browse 
Window Screen displaying ingredient name, quantity per 100 portions, and the 
unit of measure. The Browse Window Screen allows the user to enter 
amounts required for ingredients for a recipe and for making changes to 
existing ingredient information. (Whenever an ingredient is added, the user 
must activate the Browse Window Screen to add the quantity and unit of 
measure for the ingredients entered.) 

4.2.5.1.5 Return Command Button 
Allows the user to return to the Recipes Information Screen. Clicking on this 
button saves the changes made in the Armed Forces Recipe Service - 
Ingredients Screen and returns the user to the Recipe Information Screen. 

4.2.6 Calculate Cost/100 Command Button 
Allows the user to calculate the cost per 100 portions of the recipe based on the ingredients 
used. Any changes to the ingredients necessitates the need to recalculate this cost to ensure 
that the cost information displayed reflects those changes. This cost information is considered 
when the system generates new menus with convenience food substitutes. Clicking on this 
button will update the cost and display the date of calculation (based on computer's internal 
calendar). This button will also update the storage requirements and store them in the 
A_Items database. 

4.2.7 Generate Substitution List Command Button 
Allows the user to create a list of convenience food substitutes and/or to update an existing 
one. Clicking on this button links the selected recipe item to convenience food product(s) 
which may be suitable substitutes. An Information dialog box will appear informing the user 
that this process may take a few moments. When completed the date the substitution list was 
generated will be displayed (based on computer's internal calendar). If the user changes the 
Recipe Category or Product Type associated with the recipe, the Substitution List must be 
Regenerated. 

4.2.8 Display Conv Food Substitutes Command Button 
Allows the user to view the list of Convenience Food Substitutes. Clicking on this button 
produces a pop-up displaying all available substitutes. If a substitute is not available a dialog 
box will appear stating that the database contains "No Convenience Food Substitutes for the 
selected recipe." 
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4.2.9 Save Command Button 
When the system is in an append mode, the user will not be allowed to exit until the new 
information has been saved. The Save button allows the user to save the new recipe and 
return to the edit mode. Changes made while the system is in edit mode will take affect. 

4.2.10 Exit Command Button 
Allows the user to exit the Recipe Information Screen and return to the CFLM DBMS main 
menu. If the New Recipe has not been previously saved, clicking on this button produces a 
dialog box stating that the user "Must First Press The Save Button to Store the New 
Recipe/Product." 

4.2.11 Execute Search Command Button 
Allows the user to search for recipe items stored in the AFRS database that meet a certain 
criteria in the Recipe Category and/or Product Type data fields. The Execute Search button 
should only be activated after the Search option is selected from the File menu item. This 
button produces a pop-up displaying all the recipe items that matched the search criteria. If 
there are no matches, a dialog box will appear stating that "No Records Were Found." 

4.3 Adding New Recipes 
To add a new recipe select the New option from the File menu item in the menu bar. 
The Recipe Information Screen (Figure 4.3-1) will appear with blank fields. 
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4.3.1 How to Add a New Recipe 
1. Enter a six digit Recipe Number. If the recipe number already exists in the 

database a dialog box will appear prompting the user to enter a different number. 

2. Enter Name of Recipe. 

3. Enter the AFRS Portion Size. 

4. Click on the Select Recipe Category button and select appropriate recipe category 
from the pop-up. 

5. Click on the Select Product Type button and select appropriate product type from 
the pop-up. 

6. Enter the # of ovens required to prepare 100 portions. 

7. To select other equipment required, click on the check box by the equipment 
required to prepare recipe. An X will appear in the check box by the equipment 
name when selected; click on the check box again to deselect it. 

8. Click on the Select Std Labor Type button and select appropriate labor type from 
the pop-up. The estimated time required (in minutes) to prepare the recipe as 
obtained from the database will be displayed. Changing the labor type will result in 
changes to the time required. 

9. Click on the Ingredients button to activate the AFRS - Ingredients Screen (Figure 
4.3.1-1). 
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10. Select Add from the File menu item. A pop-up will appear displaying all available 
ingredients in the Federal Stock Catalog. The user can press the first letter of the 
ingredient item number to move closer to that ingredient in the pop-up. 

11. Click on the desired ingredient. Repeat step 10 as required to add all ingredients 
for the recipe. 

12. Click the Browse button to display the Browse Window (Figure 4.3.1-2). 
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3.0600 ;LB 

40000 iLB 

0.0156 jLB 
03730 ,'LB 
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1.1230 !LB ONIONS, DRY, 2 INCH DIAMETER 

GARLICDEHYDRATED, 12 02 I 
JUICE.TOMATO.SINGLE STRENGTH^ CYi 
BREAD CRUMBS.BREADING, 5 LB 
PEPPER3LACK.GR0UND, 1 LB 
SALT, TABLE, 5 LB 
BEEF, PATTIE MIX BULK I 
EGGS^HELUMEDIUM OR LARGER.DOMES 

I 

PEPPERS.SWEET, 2 1/2 INCH DIAMETER 
WATER, TAP 

Aitscatc figc«itgfi3<l^a82S Sscbgyg  Hfe»     Sara 

FIGURE 4.3.1-2 BROWSE WINDOW 

13. Enter the quantity per 100 portions and unit of measure for each ingredient 
displayed. If Qty and Unit information is not entered, an error message will appear 
indicating that the user must enter this information before continuing. Figure 4.3.1- 
3 provides a list of Unit of Issue Designations, the user can also utilize the 
Logistical Information Screen to find the correct Unit of Measure for an 
ingredient if unknown. 

14 



UNIT OF ISSUE DESIGNATIONS: 
BG- —bag GL-- —gallon 

BR- —bar HD- —hundred 

BT- —bottle JR— -jar 

BX- —box LB- —pound 

CK- —cake ME- —meal 

CN- —can MX-- —thousand 

co- —container PG-- —package 

DZ- —dozen PZ— —packet 

EA- —each QT- —quart 

RA-- —ration 

FIGURE 4.3.1-3 UNIT OF ISSUE DESIGNATIONS 

14. Select Exit from the Document Control menu to return to the AFRS -Ingredients 
Screen. 

15. Click on the Return button to return to the Recipe Information Screen. 

16. Click on the Calculate Cost/100 button to calculate and display the cost/100 
portions for this recipe item. There will be a slight delay prior to data appearing in 
the cost and date fields (based on computer's internal calendar). If the Units of 
Measure entered in the Ingredients File are incompatible with the Units of Issue in 
the Logistics File a dialog box will appear instructing the user to revise and rerun. 
Click on the OK button to continue. A message will appear at the top of the 
screen identifying the problem and correct Unit of Issue. 

17. Click on the Generate Substitution List button to identify convenience food 
products which may be substituted for this recipe item. An Information Window 
dialog box will appear alerting the user that this process may take a few minutes. 
When completed, the Date Substitution List Was Generated data field is filled in 
with the current date (based on computer's internal calendar). 

18. Click on the Display Conv Food Substitutes button to view the Convenience Food 
Substitute List if desired. A pop-up will appear displaying all available 
Convenience Food Substitutes for the selected recipe. If there are none, a dialog 
box will appear stating that "The Database Contains No Convenience Food 
Substitutes For This Recipe." Click on the OAT button to continue. 

19. Click on the Save button to store the New Recipe/Product information and return 
to the edit mode. 

20. Click on the Exit button to return to the CFLM DBMS main menu. If the new 
recipe/product has not been saved a dialog box will appear stating that the user 
"Must First Press The Save button to Store the New Recipe/Product." 
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4.4 Deleting Recipes 
The Delete Recipe function allows the user to select specific recipe items and delete them from the 
CFLM DBMS. Once this function is performed the deleted item is no longer available for use 
throughout the CFLM DBMS and may affect the menus previously created. To Delete a recipe item 
select the Delete option from the File menu item in the menu bar. A Warning dialog box (Figure 4.4- 
1) will appear providing the user an opportunity to stop the function if desired. If the No button is 
selected a dialog box will appear notifying the user that the delete command has been canceled. 
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FIGURE 4.4-1 DELETE RECIPE WARNING DIALOG BOX 

4.4.1 How to Use the Delete Option 
1. Locate the recipe to be deleted using the Browse Existing Recipe button, the 

Execute Search button, or the 'Page Up/Page Down' keys to display recipe 
selected for deletion. 

2. Select Delete from the File menu item. 

3. Click on the Yes button in the Delete dialog box to confirm deletion. 
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4.5 Searching for Recipes 
Recipe information viewing and manipulation are an important function of the CFLM DBMS. Users 
are able to quickly view and modify any recipe that has been entered into the CFLM DBMS using the 
Search menu option and Execute Search button. This function searches on the Recipe Category 
and/or the Product Type data fields. These are the only fields that will be accessible when in the 
search mode. Enter both Recipe Category and Product Types, if possible, to make the search more 
effective. 

4.5.1 How to Use the Search Option 
1. Select the Search option from the File menu item. All data fields on the Recipe 

Information Screen will become blank. 

2. Click on the Select Recipe Category button and select from the pop-up and/or, 

3. Click on the Select Product Type button and select from the pop-up. 

4. Click on the Execute Search button. If there are no matches, a dialog box will 
appear stating that "No Records Were Found." Click on the OK button to 
continue. 

5. A successful search will produce a pop-up of all recipes matching the search 
criteria. Select the desired recipe and press enter to bring recipe information into 
view. Recipe Information Screen data fields will be filled in with the information 
from the selected recipe. 

4.6 Saving Recipe Information 
Once a recipe has been added or changed it is important to perform the Save function. The system 
will not allow the user to exit until a new recipe has been saved. If the user tries to exit the Recipe 
Information Screen prior to initiating the Save function, the system will respond with a dialog box 
informing the user that the Save function is required. Click on the OK button in the dialog box. The 
system will return the user to the Save button; click on the Save button. Once the user starts the 
process of adding a new recipe the process cannot be aborted. The user must Save the recipe then 
select the Delete option from the File menu item to remove the recipe from the CFLM DBMS. 

4.7 Print Options 
The Print menu item allows the user to preview and/or print selected information derived from the 
Recipe Information Screen. The user has the option to view the information on the screen and/or on 
paper. To view the information select the Print menu item, select the desired report, and click on the 
appropriate radio button in the Report Generation dialog box. Selecting Preview sends the report to 
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the Page Preview Screen, Print sends the report to the printer. The Recipe Information Screen data 
is available in three different formats as described below. 

4.7.1 Recipe Information 
The Recipe Information print option provides the user with a report that displays Recipe 
Number, Item Name, Recipe Category, Product Type, Portion Size, Cost per 100, Equipment 
required, Storage requirements, Type of Preparation Required and Ingredients by quantity per 
100 portions, and the unit of measure for each selected recipe. 

4.7.2 Convenience Food Substitutes 
The Convenience Food Substitutes print option provides the user with a report that displays 
the Item Number and the Product Name of all the convenience food products that have been 
identified as suitable substitutes for the selected recipe. 

4.7.3 Ingredients Not Available To Navy 
The Ingredients Not Available To Navy print option provides the user with a report that 
displays the National Stock Number (NSN) and the Ingredient Name of all the ingredients 
required for the selected recipe that are not authorized for Navy acquisition (if any). 
Authorized changes to the availability of these ingredients are updated through the Logistical 
Information Screen and are reflected in this report. 
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5. CONVENIENCE FOODS 
SCREEN 

5.1 General Information 
The Convenience Foods Screen allows the user to perform functions such as add, delete and search 
for Convenience Food Products. The information stored in the Convenience Food Product database 
file is used to associate A-Ration recipe items with similar convenience food products. The 
Convenience Foods Screen allows the user to input Convenience Food Product attributes that are 
then used in the optimization algorithm which takes an A-Ration menu and substitutes with 
Convenience Food Products when available. The remainder of this section will describe in detail the 
Convenience Foods Screen Command Buttons and step by step instructions for using the 
Convenience Foods Screen. 

5.2 Convenience Foods Screen Command Buttons 

5.2.1 Category Command Button 
Allows the user to identify the part of meal during which the convenience food product would 
be served. Clicking on this button produces a pop-up displaying available meal categories 
from appetizers to desserts. (Refer to Appendix E for a listing of Recipe Categories.) 

5.2.2 Manufacturer Command Button 
Allows the user to view/select the Manufacturers listed in Convenience Food Products 
database when adding and searching for convenience food products. Clicking on this button 
produces a pop-up displaying all Manufacturers currently listed in the database. If the 
manufacturer of a product is not listed, it can be added as described in the following section. 

5.2.3 Product Type Command Button 
Allows the user to view/select the type of convenience food product. Clicking on this button 
produces a pop-up displaying available product types such as fruit, egg item, duck item, etc. 
(Refer to Appendix F for a list of Product Types.) 

19 



5.2.4 Select Standard Labor Type Command Button 
Allows the user to identify the effort involved in preparation of the Convenience Food 
Product. Clicking on this button produces a pop-up displaying standard labor codes, i.e., 
TAS for Thaw and Serve. (Refer to Appendix D for a list of Convenience Food Product 
Labor Codes.) Once selected, the estimated time required in minutes to prepare for 100, 200 
and 500 portions are calculated and displayed. The time displayed is an average time based on 
test data and may vary accordingly. 

5.2.5 Storage Type Command Button 
Allows the user to identify the type of storage required for the Convenience Food Product. 
Clicking on this button produces a pop-up displaying available storage categories (chilled, dry, 
or freezer). 

5.2.6 Calc Reqmts/100 (Calculate Cost and Storage per 100 
Portions) Command Button 
Allows the user to calculate the cost of the Convenience Food Product based on the AFRS 
portion size for a similar recipe item. The storage requirements are also calculated. Clicking 
on this button calculates the cost and storage per 100 portions and displays the cost and 
storage information, and the date of calculation (based on computer's internal calendar). 
Note: if the user has not entered key data used to calculate this information an error message 
will appear. 

5.2.7 Save Command Button 
The Save button allows the user to save the new Convenience Food Product and return to the 
edit mode. Any changes made while the system is in an edit mode will take affect. The 
system will not allow the user to exit until new product information has been saved. 

5.2.8 Exit Command Button 
Allows the user to exit the Convenience Foods Screen and return to the CFLM DBMS main 
menu. If a New Convenience Food Product information has not been previously saved, 
clicking on this button produces a dialog box stating that the user "Must First Press The Save 
Button to Store the New Recipe/Product." 

5.2.9 Execute Search Command Button 
Allows the user to search for Convenience Food Products stored in the DBMS that meet a 
certain criteria in the Category, Manufacturer and/or Product Type data fields. These are the 
only fields that will be enabled when in the search mode. Clicking on this button produces a 
pop-up displaying all the Convenience Food Products that matched the search criteria. If 
there are no matches, a dialog box will appear stating that "No Records Were Found." 
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5.3 Product Attributes 
Allows the user to input product attributes required for calculating storage requirements and cost. 
This information is then used in the optimization algorithm which takes an A-Ration menu and 
substitutes with Convenience Food Products when available. The portions and servings per case are 
adjusted to reflect the AFRS portion sizes. The user enters the data for the convenience food product 
as indicated by the manufacturer (e.g. Manufacturer Suggested Portion, Number of Servings Per Case 
(as per Manufacturer), Cost Per Case, Storage (cubic feet) Required Per Case, and the Portion Size 
for a Similar AFRS Recipe Item. The model will adjust the servings per case based on this 
information after checking for compatible units. All product attributes displayed in Figure 5.3-1 
below are mandatory data fields. An error message will appear informing the user which data field 
needs to be entered if omitted. 
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FIGURE 5.3-1 PRODUCT ATTRIBUTES 

Portion Size (Amount/Person) - Manufacturer Suggested 

This data field allows the user to enter the Manufacturer's suggested portion size for the 
convenience food product being added (i.e., 4.00 OZ). 

Portion Size (Amount/Person) - AFRS Portion 

This data field allows the user to enter the AFRS's suggested portion size for the 
convenience food product being added (i.e., 6.00 OZ). 

Servings per Case 

This data field allows the user to enter the amount of the manufacturer suggested servings 
per case that the convenience food product is packaged (i.e., 58 servings in this case). 

Case Pack 

This data field is used to store the manufacturer's format indicating how the item is 
packaged (i.e. 4/58 OZ for 58 - 4 OZ servings/case). This field is not mandatory. 

Case Weight Net 
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This data field allows the user to enter the weight of the actual product in the case (i.e., if 
the case pack is 4/58 oz packs the net weight would be 4*58 oz or 14.50 lbs) 

• Case Weight Gross 

This data field allows the user to enter the weight of the product and the weight of the 
case and packaging materials (i.e., if the case pack is 4/58 oz packs the net weight would 
be 4*58 oz or 14.50 lbs plus the weight of packaging which may increase this value to 
16.11 lbs, as shown). 

• Case Vol (cu ft) 

This data field allows the user to enter the volume of the case in cubic feet (i.e., .58 cubic 
feet). 

• Cost/Case. 

This data field allows the user to enter the cost per case (i. e., $31.15). 

5.3.1 How to Add New Convenience Food Products 
To add a new Convenience Food Product select the New option from the File menu item in the menu 
bar. All data fields in the Convenience Food Screen (Figure 5.4-1) will become blank. 
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FIGURE 5.4-1 CONVENIENCE FOOD SCREEN 

1. Click on the Category button and select appropriate category from the pop-up. 

2. Click on the Manufacturer button and select appropriate manufacturer from the 
pop-up. If this is a new manufacturer click outside the pop-up and proceed to the 
Enter New Manufacturer Below data field. 
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3. Click on the Enter New Manufacturer Below data field and enter the New 
Manufacturer. 

4. Click on the Prefix for New Item Number data field and enter two identifying 
letters. If the letters already exist a dialog box stating "This Prefix Is Used To 
Identify Another Manufacturer. Please Select Another Prefix." will appear. Click 
on the OK button to continue and enter a different Prefix. Press the 'enter' key. 

5. Click on the Product Type button and select appropriate type from the pop-up. 

6. Enter the Manufacturer's Product Code. The product code will appear in the 
upper right hand corner of the screen proceeded by the system's manufacturer 
code and padded with 'Os' if necessary to create a 10 digit code required by the 
system. 

7. Enter Product Name. 

8. Enter the # of ovens required to prepare 100 portions. 

9. To select other equipment required, click on the check box by the equipment 
required to prepare the convenience food product. An X will appear in the check 
box by the equipment name when selected; click on the check box again to 
deselect. 

10. Click on the Select Std. Labor Type button and select appropriate labor type from 
the pop-up. The time required (in minutes) to prepare the convenience food 
product will be calculated and displayed. Changing the labor type will result in 
changes to preparation time. 

11. Enter all the product attributes. The user will be prompted to complete all 
mandatory data fields (such as portions/cost, etc.) and will be notified if 
incompatible or incomplete data (such as the missing portion information) is 
entered. The Calculate Req/100 function should be performed if any changes are 
made to these data fields. 

12. Click on the Storage Type button and select appropriate type from the pop-up. 

13. Click on the Calculate Req./lOO button to calculate and display the cost/100 
portions for this convenience food product based on AFRS portion amounts. 
There will be a slight delay prior to data appearing in the cost and date fields. If 
any product attribute information is missing or incorrect, a dialog box will appear 
notifying the user. Click on the OK button to continue. Once the error has been 
corrected, proceed with the calculation function. 

14. Enter any comments in the Comment data field as desired. Comments can be up to 
30 alpha/numeric characters. 

15. Click on the Save button when all data has been properly entered. The system is 
returned to the 'Edit' mode and is ready for a new option. 
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5.4 Deleting Convenience Food Products 
The Delete Convenience Food Products function allows the user to select specific Convenience Food 
Products and delete them from the CFLM DBMS. Once this function is performed the deleted item is 
no longer available for use throughout the CFLM DBMS and may affect previously generated menus. 
To Delete a Convenience Food Product select the Delete option from the File menu item in the menu 
bar. A Warning dialog box will appear providing the user an opportunity to stop the function if 
desired. If the No button is selected, a dialog box will appear notifying the user that the delete 
command has been canceled. 

5.4.1 How to Use the Delete Option 
1. Use the 'Page Up/Page Down' keys or the Search option (described below) to 

display the convenience food product selected for deletion. 

2. Select Delete from the File menu item. 

3. Click on the Yes button in the Delete dialog box to confirm deletion. 

5.5 Searching for Convenience Food Products 
This function allows the user to locate items quickly to obtain information, to delete items, etc. The 
searches are performed on the Convenience Food Product Category, Manufacturer and/or Product 
Type data fields. These are the only fields that will be enabled when in the search mode. Enter data 
in all three data fields, if possible, to make the search more effective. 

5.5.1 How to Use the Search Option 
1. Select the Search option from the File menu item. All data fields on the 

Convenience Food Product Screen will become blank. 

2. Click on the Category button and select from the pop-up and/or, 

3. Click on the Manufacturer button and select from the pop-up and/or, 

4. Click on the Product Type button and select from the pop-up. 

5. Click on the Execute Search button. If there are no matches, a dialog box will 
appear stating that "No Records Were Found." Click on the Q£ button to 
continue. 

6. A successful search will produce a pop-up displaying all products matching the 
search criteria. Select the desired convenience food product. Convenience Food 
Screen data fields will be filled with the information from the selected convenience 
food product. 
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5.6 Saving Convenience Food Product Information 
Once a Convenience Food Product has been added or changed it is important to perform the Save 
function. The system will not allow the user to exit until the new information has been saved. If the 
user tries to exit the Convenience Food Product Screen prior to initiating the Save function, the 
system will respond with a dialog box informing the user that the Save function is required. Click on 
the OK button in the dialog box. The system will return the user to the Save button. Click on the 
Save button. The user can then use the Delete function to delete the information if desired. 

5.7 Print Options 
The Print menu item allows the user to preview and/or print selected information derived from the 
Convenience Food Product Screen. The user has the option to view the information on the screen 
and/or on paper. To view the information select the Print menu item, select the Print Convenience 
Food Product Information option, and click on the appropriate radio button in the Report 
Generation dialog box. Selecting Preview sends the report to the Page Preview Screen; Print sends 
the report to the printer. 
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6. MENU CREATION SCREEN 

6.1 General Information 
The Menu Creation Screen allows the user to Create New Menus, Select and Modify existing 
Menus, and Delete selected Menus from the CFLM DBMS. In working with the Menu Creation 
Screen the user can select any menu file stored in the CFLM DBMS with the same structure as the 
Menu Creation Screen (i.e., as created using the Menu Creation Screen). The default directory is 
'C:\cflm\MENUS\.' However, if the desired menu file is in a different directory or on a different 
drive, the user can access it by entering the information in the Open dialog box. This dialog box is 
displayed after the Select Menu option is chosen from the File menu item in the menu bar. Once the 
menu is selected the Menu File Name: data field, located at the top of the Menu Creation Screen, is 
filled in with the menu name and directory. This field becomes blank when the menu is closed. The 
remainder of this section will describe in detail the Menu Creation Screen, Command Buttons and 
step by step instructions for using the Menu Creation Screen. 

6.2 Menu Creation Screen Command Buttons 

6.2.1 Add Recipe Command Button 
Allows the user to add a record to the selected menu file. Clicking on this button will cause 
the Recipe Selected display box to become blank. The day and meal fields will inherit the 
contents.of the previous record. This avoids having the user re-enter the same data for 
multiple recipes entered for the same meal. However, these data fields can be modified. To 
enter a recipe, the user must then press the Select Recipe button. The exception to this 
process is in the first record of a new menu. Clicking this button will add a new record, and 
display the pop-up of recipes shown when Select Recipe button is clicked. 

6.2.2 Select Recipe Command Button 
Allows the user to view/select and change recipes in existing menus. The default selection 
rate for each menu item is displayed and may be changed, if desired. Clicking on this button 
produces a pop-up displaying all the recipes stored in the CFLM DBMS. Once selected the 
recipe replaces the one displayed in the Recipe Selected data field (versus adding another 
recipe to the menu as in the Add Recipe function explained above). If the intention is to add a 
recipe versus replace an existing one, the user must first use the Add Recipe button. 
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6.2.3 Delete Recipe Command Button 
Allows the user to delete a recipe from the selected menu. Clicking on this button produces a 
Warning dialog box allowing the user to cancel or continue the deletion process. Selecting 
the Yes button deletes the selected recipe from the selected menu. 

6.2.4 View Menu Command Button 
Allows the user to view all menu items stored in the currently selected menu. Prior to clicking 
on this button the user must first select a menu using the Select Menu option from the File 
menu item. Clicking on this button produces a pop-up displaying all the menu items by day of 
menu cycle (1-35) and category (breakfast, lunch, dinner, midrats). 

6.2.5 Save Menu Command Button 
Allows the user to save the new or changed menu to an existing file or to a new file. When 
adding a new menu, clicking on this button produces a dialog box prompting the user to 
"Enter a File Name for the Menu File Created." Click on the OK button to continue and enter 
a new file name in the Filename data field. When working with an existing file, clicking on 
this button produces a Warning dialog box asking the user to "Save Changes To Current 
Menu File? Select 'No' To Save Changes To New File Menu." If the No option is selected, 
the system prompts the user to enter a new filename. 

6.2.6 Close Menu Command Button 
Allows the user to close the menu file. Clicking on this button produces a dialog box 
prompting the user to "Select from the Following Options: Save to Existing File, Save to 
New File, or Close without Saving." 

6.2.7 Exit Command Button 
Allows the user to exit the Menu Creation Screen and return to the CFLM DBMS main 
menu. If the new or changed menus have not been saved and closed, clicking on this button 
produces a dialog box stating "A Menu File Is Open Press 'Close Menu' Before Leaving 
Screen Or Creating A New Menu File." 

6.2.8 Select a Meal Command Button 
Allows the user to identify the meal category for the recipe item (breakfast, lunch, dinner, 
midrats). Clicking on this button produces a pop-up displaying all the meal categories 
available. The category selected is displayed to the right of this button. 
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6.3 Creating a New Menu 
The Create Menu option allows the user to develop a new menu file. To achieve optimum utility of 
the CFLM DBMS features, the user developing the new menu needs to be aware that the ship 
information is based on a 35 day replenishment cycle. If a user enters a menu for less than 35 days, 
when the storage availability of the ship is compared to the storage requirements of the menu, the 
results may be misleading. If the ship has a 21 day replenishment cycle as opposed to 35 days, and 
the storage on the ship is greater than the menu requires, the menu is feasible. However, if the 
replenishment cycle is 35 days and the menu entered is for less then the 35 days with storage 
requirements equal to the ships' storage availability, the menu may not be feasible. To create a new 
menu, select the Create Menu option from the File menu item. The Menu Creation Screen (Figure 
6.2-1) will appear with blank fields. 
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FIGURE 6.2-1 MENU CREATION SCREEN 

6.3.1 How to Create a New Menu 
1. Enter the # of the day within the Menu Period in the Day data field (i.e.,' 1' for the 

first day of the menu cycle). 

2. Click on the Select Meal button and select appropriate meal category. 

3. Click on the Add Recipe button and select desired recipe. Enter the first letter of 
the recipe number to quicken the search if number is known. 

4. Enter the appropriate Selection Rate (%) if the default is not desired. 
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5. Repeat steps 1-4 until menu requirements have been met. Note that the Day 
within the Meal Period and the Select Meal data fields remain when adding new 
items to avoid repetitive operations. These values can be changed as necessary. 

6. Click on the View Menu button to display New Menu, if desired. 

7. Click on the Save button to store the New Menu. An Information dialog box will 
appear instructing the user to "Enter a File Name For The Menu File You 
Created." Click on the OK button to continue. 

8. Enter the Path and the New File name in the File Name data field. The file name 
must be less than or equal to 8 characters in length. Once saved, the menu will 
now appear in the Select Menu Open dialog box. 

9. Click on the Close Menu button. 

6.4 Deleting a Menu 
The Delete Menu function allows the user to select specific menus and delete them from the CFLM 
DBMS. Once this function is performed the deleted menu is no longer available for use throughout 
the CFLM DBMS. To Delete a Menu select the Delete option from the File menu item in the menu 
bar. The Menu Open dialog box will appear allowing the user to select the specific menu for deletion. 
Once selected, a Warning dialog box will appear providing the user an opportunity to stop the 
function if desired. If the No button is selected a dialog box will appear notifying the user that the 
"Menu File Was Not Deleted." A menu can also be deleted from the File Manager by double clicking 
on the Menus directory, selecting the appropriate Menu and pressing the Delete key. 

6.4.1 How to Use the Delete Option 
1. Select the Delete option from the File menu item. 

2. Click on the desired menu in the Open dialog box then click on the Open button. 

3. Click on the Yes button in the Warning dialog box to confirm deletion. 

6.5 Print Options 
The Print menu item allows the user to preview and/or print selected information derived from the 
Menu Creation Screen. The user has the option to view the information on the screen and/or on 
paper. To view the information the user will choose the Select Menu option from the File menu item 
(select the desired menu and click on the Open button in the Open dialog box), select the Print menu 
item from the menu bar, select the desired report, and click on the appropriate radio button in the 
Report Generation dialog box. Selecting Preview sends the report to the Page Preview Screen; Print 
sends the report to the printer. The Menu Creation Screen data is available in four different formats 
as described below. With the exception of the Print Current Menu report, each of these are standard 
menus created for taking into account such items that would not be substituted. A user is able to 
create their own salad bar and speedline menus but these would not change or replace the system's 
menus for these items. 
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6.5.1 Print Current Menu 
The Print Current Menu print option provides the user with a report that displays the Day, 
Meal, Recipe No. and Item Name for all recipes in the selected menu. 

6.5.2 Print Generic Salad Bar Menu 
The Print Generic Salad Bar Menu print option provides the user with a report that displays 
the standard items generally found in a ship's Salad Bar. This menu is used to account for the 
cost and storage requirements associated with Salad Bar items. These items would most 
likely not be substituted with convenience food products, but are still required for logistical 
calculations. 

6.5.3 Print Generic Speedline Menu 
The Print Generic Speedline Menu option provides the user with a report that displays the 
standard items generally found in a ship's Speedline. This menu is used to account for the 
cost and storage requirements associated with Speedline items. These items would most 
likely not be substituted with convenience food products, but are still required for logistical 
calculations. 

6.5.4 Print Miscellaneous Items Menu 
The Print Miscellaneous Items Menu option provides the user with a report that displays 
miscellaneous items (i.e., condiments, beverages) that are available at meals. This menu is 
used to account for the cost and storage requirements of the miscellaneous items. These items 
would most likely not be substituted with convenience food products, but are still required for 
logistical calculations. 
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7. LOGISTICAL INFORMATION 
SCREEN 

7.1 General Information 
The Logistical Information Screen allows the user to update the Logistical Database file containing 
the food products available through the Group 89 Federal Stock Catalog (FSC), June 1993 Price List 
of 1 April through 30 June 1994. Any items added or deleted from this screen may affect AFRS 
recipes previously entered. After completing the Logistical Information Screen it may be necessary 
to return to the Recipes Screen and make the appropriate changes (i.e., add new ingredient to an 
existing recipe, find a substitute ingredient for a deleted ingredient, etc.). The remainder of this 
section will describe in detail the Logistical Information Screen Command Buttons and step by step 
instructions for using the Logistical Information Screen. 

7.2 Logistical Information Screen Command Buttons 

7.2.1 Storage Command Button 
Allows the user to choose the storage type for selected NSN item. Clicking on this button 
produces a pop-up displaying the types of storage available (Chilled, Dry, Freezer). The 
storage type selected will appear to the right of the Storage button. 

7.2.2 Acq. Advice Code Command Button 
Allows the user to identify the Acquisition Advice Code that applies to added item according 
to the FSC. Clicking on this button produces a pop-up displaying the different types of 
acquisition codes available (i.e., Local Purchase, DOD Integrated Material). 

7.2.3 Usage Mgmt Codes Command Button 
Allows the user to identify the type of usage for the added item according to the FSC. 
Clicking on this button produces a pop-up displaying the different types of usage codes 
available (i.e., Afloat Only, Submarines Only, Controlled Item). 
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7.2.4 Browse Existing Items Command Button 
Allows the user to locate and select a specific item in the logistical database file. Clicking on 
this button produces a pop-up displaying all items stored in the logistical database in NSN 
order. The user can scroll down the list to select a specific NSN item. When an NSN item is 
selected all information associated with that item is displayed. 

7.2.5 Execute Search Command Button 
Allows the user to search for items stored in the Logistical Information database that meet a 
certain criteria in the Description (Keyword), Storage Type, and the Perishable or Semi- 
Perishable data fields. The Execute Search button should only be activated after the Search 
option is selected from the File menu item. Clicking on this button produces a pop-up 
displaying all the Food Product items that matched the search criteria. If there are no 
matches, a dialog box will appear stating that "No Records Were Found." 

7.2.6 Recipes Command Button 
Allows the user to view existing recipes that contain selected NSN items. Clicking on this 
button produces a pop-up displaying all recipes which require the selected NSN item and, 
therefore, are the recipes that would be impacted if the NSN item was not available. If there 
is an overstock of a particular item, the user could see what recipes contain this ingredient and 
incorporate them in new menus. 

7.2.7 Save Command Button 
The Save button allows the user to save the new NSN items and return to the edit mode. Any 
changes made while the system is in an edit mode will take effect. 

7.2.8 Exit Command Button 
Allows the user to exit the Logistical Information Screen and return to the CFLM DBMS 
main menu. 

7.3 Adding Federal Stock Catalog Items 
To add Federal Stock Catalog Items to the CFLM DBMS select the New option from the File menu 
item in the menu bar. All data fields in the Logistical Information Screen (Figure 7.3-1) will become 
blank. The required Logistical Information Screen data fields are the NSN, Description, Storage, 
Unit Price, Gross lbs, Net lbs, Vol (cu ft), Units per Case, Units Issued by, and the Conversion 
Factor. 
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7.3.1 How to Add Federal Stock Catalog Items 
1. Enter a 13 digit National Stock Number in the NSN data field. If the NSN is less 

than or equal to 13 an error message dialog box will appear stating that "The 
Length of The National Stock Number Must be 13 Digits." Click the OK button 
to continue. 

2. Enter a description of the item in the Description data field. Descriptions can be 
up to 50 alpha/numeric characters and should contain keywords. 

3. Enter a two digit code in the Food Identification Code (FIC) (Navy items only) 
data field, if available. 

4. Click on the Storage button and select appropriate storage type from the pop-up. 

5. Check the box labeled Perishable or Semi-Perishable, if applicable. 

6. Enter the Fiscal Month, Year, Price Month, Year and Unit Price. 

7. Click on the Acq. Advice Code button and select appropriate code. If the code is 
unknown the user can tab over to the next data field or select the blank line in the 
pop up. 

8. Click on the Usage Mgmt Codes button and select appropriate code.   If the code 
is unknown the user can tab over to the next data field or select the blank line in 
the pop up. 

9. Enter Action Code. (See Figure 7.3-2 for a list of Action Codes.) 
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A (ADD) 

B (REINSTATE) 

C (CHANGE) 

D (DELETED) 

ACTION CODES 
Indicates NSN not included in a previous publication. 

Indicates that the NSN previously deleted from a 
publication is being reinstated. 

Indicates a change in descriptive and/or management data 
since the previous publication. An asterisk is placed to the 
right of the element(s) of management data that has 
changed. 

Deletions are not cited in the Revision. 

FIGURE 7.3-2 ACTION CODES 

10. Enter five digit Index Number. 

11. Enter known data for the Case Lot Data. 

12. Click on the Save button. 

13. If desired, return to the Recipe Information Screen and replace new item for a 
similar ingredient in an existing recipe. 

14. Adding new items, increases the choice of ingredients to select from when creating 
new recipes or modifying existing ones. To incorporate the new ingredient in a 
recipe, the user must return to the Recipe Information Screen, search for the 
desired recipe, activate the AFRS Ingredients Screen and add the new item. 

7.4 Deleting Federal Stock Catalog Items 
To delete a Federal Stock Catalog Item select the Delete option from the File menu item in the menu 
bar. When an item is deleted it may affect AFRS recipes previously entered. Use the Recipes button 
to view any recipes that will be affected prior to deleting the item. Upon deletion return to the 
Recipes Information Screen and select replacement ingredients for the deleted item. 

7.4.1 How to Delete Federal Stock Catalog Items 
1. Use the Tage Up/Page Down' keys or the Execute Search button to display the 

Federal Stock Catalog Item selected for deletion. The record displayed is the 
record that will be deleted. 

2. Click on the Recipes button to view affected recipes, if desired. (Click outside of 
the pop-up to close it.) If there are no recipes associated with the selected item a 
dialog box will appear stating that "There are No Recipes Associated with This 
Item." Click on the OK button to continue. 

3. Select Delete from the File menu item. 

4. Click on the Yes button in the dialog box to confirm deletion. 
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7.5 Searching for Logistical Information 
This function searches on the Description, Storage Type, and Perishable or Semi-Perishable data 
fields. These are the only fields that will be enabled when in the search mode. Enter all three data 
fields, if possible, to make the search more effective. 

7.5.1 How to Use the Search Option 
1. Select the Search option from the File menu item. All data fields on the 

Logistical Information Screen will become blank. 

2. Enter a keyword in the Description data field and/or, 

3. Click on the Storage button and select type of storage from the pop-up and/or, 

4. Click on either the Perishable or Semi-Perishable check box. 

5. Click on the Execute Search button. If there are no matches, a dialog box will 
appear stating that "No Records Were Found." Click on the OK button to 
continue. 

6. A successful search will produce a pop-up displaying all NSN items that matched 
the search criteria. Select desired Food Product. Logistical Information Screen 
data fields will be filled in with the information from the selected food product. 

7.6 Print Options 
The Print menu item allows the user to preview and/or print selected information derived from the 
Logistical Information Screen. The user has the option to view the information on the screen and/or 
on paper. To view the information the user will select the Print menu item from the menu bar, select 
the desired report, and click on the appropriate radio button in the Report Generation dialog box. 
Selecting Preview sends the report to the Page Preview Screen, Print sends the report to the printer. 
The Logistical Information Screen data is available in two different formats as described below. 

7.6.1 Print Logistical Information for Item 
The Print Logistical Information for Item print option provides the user with a report that 
displays all the Logistical Information for the selected Item by NSN. 

7.6.2 Print List of Recipes with this Ingredient 
The Print List of Recipes with this Ingredient print option provides the user with a report that 
displays all recipes in the CFLM DBMS that require the selected ingredient by NSN and 
Ingredient Name. If the ingredient selected has no associated recipe, a dialog box will appear 
stating "There are No Recipes Associated With This Item" and the print function will be 
canceled. 
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8. SHIP INFORMATION SCREEN 

8.1 General Information 
The Ship Information Screen allows the user to enter all pertinent ship information for ship 
classification, ship type and class of ship. The ship's complement, mess information, galley 
equipment, and total available storage data for the general mess are used to compare the results of 
logistical calculations for selected A-Ration menus with the actual ship attributes. The remainder of 
this section will describe in detail the Ship Information Screen Command Buttons and step by step 
instructions for using the Ship Information Screen. 

8.2 Ship Information Screen Command Buttons 

8.2.1 Classification of Ship Command Button 
Allows the user to view/select different Ship Classifications stored in the CFLM database. 
(Refer to Appendix G for a listing of Ship Classifications, Type, Class Codes.) Clicking on 
this button produces a pop-up displaying the different ship classifications stored in the CFLM 
DBMS. 

8.2.2 Type w/in Classification Command Button 
Allows the user to view/select the different types of ships stored in the CFLM database. 
(Refer to Appendix G for a listing of Ship Classifications, Type, Class Codes.) Clicking on 
this button produces a pop-up displaying the types of ships associated with the ship 
classification previously selected. 

8.2.3 Class of Ship Command Button 
Allows the user to view/select the different classes of ships stored in the CFLM database. 
(Refer to Appendix G for a listing of Ship Classifications, Type, Class Codes.) Clicking on 
this button produces a pop-up displaying the classes of ships associated with the classification 
and type previously selected. 
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8.2.4 Browse Existing Ships Command Button 
Allows the user to view/select information on specific ships stored in the CFLM database. 
Clicking on this button produces a pop-up displaying all the ships stored in the CFLM 
database. The user can scroll down the list to select a specific ship. The user can access a 
ship more quickly by pressing the first letter of the ship's Hull # (i.e., 'F' to scroll quickly to 
the FFG 7 Oliver Hazard Perry). When the ship is selected all associated information is 
displayed. 

8.2.5 Execute Search Command Button 
Allows the user to search for ship information stored in the AFRS database that meets a 
certain criteria in the Ship Classification, Type, and Class of Ship data fields. The Ship 
Classification data field should be selected prior to entering the other two search data fields. 
However, these three criteria can be entered individually as search criteria. Clicking on this 
button produces a pop-up displaying all the ships that matched the search criteria. If there are 
no matches, a dialog box will appear stating that "No Records Were Found." 

8.2.6 Save Command Button 
The Save button allows the user to save the new Ship Information and return to the edit 
mode. Any changes made while the system is in an edit mode will take affect. 

8.2.7 Exit Command Button 
Allows the user to exit the Ship Information Screen and return to the CFLM DBMS main 
menu. 

8.3 Adding New Ship Information 
To add a ship to the CFLM DBMS select the New option from the File menu item in the menu bar. 
All data fields in the Ship Information Screen (Figure 8.3-1) will become blank. 
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FIGURE 8.3-1 SHIP INFORMATION SCREEN 

8.3.1 How to Add New Ship Information 
1. Click on the Classification of Ship button and select appropriate ship classification 

from the pop-up list. 

2. Click on the Type w/in Classification button and select appropriate ship type from 
the pop-up list. 

3. Click on the Class of Ship button and select appropriate class of ship from the 
pop-up list. 

4. Enter the Hull No. of Ship data field. Type in the given letters again with the 
appropriate number. 

5. Enter the Name of Ship data field. 

6. Enter the Ship's Complement data fields. Include all personnel such as Marines 
and Airwing, if applicable. Once this data field is entered the Total Available 
Storage associated with the general mess will be calculated and displayed based on 
the Ship's Complement entered. 

7. Check all Available Messes that apply. 

8. Enter the General Mess (Galley Eq) data fields. 

9. Enter the Comment data field, if desired. 

10. Click on the Save button. 
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8.4 Deleting Ship Information 
The Delete Ship Information function allows the user to select a specific ship and delete the ship and 
associated attributes from the CFLM DBMS. To Delete Ship Information, select the Delete option 
from the File menu item in the menu bar. A Warning dialog box will appear providing the user an 
opportunity to stop the function if desired. If the No button is selected a dialog box will appear 
notifying the user that the delete command has been canceled. 

8.4.1 How to Delete Ship Information 
1. Use the 'Page Up/Page Down' keys or the Execute Search button to display the 

Ship Information selected for deletion. 

2. Select the Delete option form the File menu item. 

3. Click on the Yes button in the Warning dialog box to confirm deletion. 

8.5 Searching for Ship Information 
Users are able to quickly view and modify Ship Information that has been entered into the CFLM 
DBMS using the Search menu option and Execute Search button. This function searches on the 
Classification of Ship, Type W/in Classification and Class of Ship data fields. The user can use one, 
two, or all three of these data fields to locate a particular ship. If all three attributes are used, the 
Ship Classification should be selected prior to the Type W/in Classification. Similarly, the Type W/in 
Classification should be selected prior to Class of Ship data field. 

8.5.1 How to Use the Search Option 
1. Select the Search option from the File menu item. All data fields on the Ship 

Information Screen will become blank. 

2. Click on the Classification of Ship button and select appropriate ship classification 
from the pop-up list. 

3. Click on the Type w/in Classification button and select appropriate ship type from 
the pop-up list, if known. 

4. Click on the Class of Ship button and select appropriate class of ship from the 
pop-up list, if known. 

5. Click on the Execute Search button. If there are no matches, a dialog box will 
appear stating that "No Records Were Found." Click on the OK button to 
continue. 

6. A successful search will produce a pop-up displaying ships matching the search 
criteria. Select the desired Ship. The Ship Information Screen data fields will be 
filled with the information from the selected ship. 
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8.6 Print Options 
The Print menu item allows the user to preview and/or print selected information derived from the 
Ship Information Screen. The user has the option to view the information on the screen and/or on 
paper. To view the information the user will select the Print menu item from the menu bar, select the 
Print Ship Information option, and click on the appropriate radio button in the Report Generation 
dialog box. Selecting Preview sends the report to the Page Preview Screen, Print sends the report to 
the printer. 

40 



9. OPTIONS - RUN LOGISTICAL 
INQUIRY A-RATIONS 

9.1 General Information 
The Options Run Logistical Inquiry A-Rations Logistical Inquiry A-Rations Screen allows the user 
to view logistical information associated with specific ships for selected menus. The remainder of this 
section will describe in detail the Logistical Inquiry A-Rations Screen Command Buttons and step 
by step instructions for using the Logistical Inquiry A-Rations Screen. 

9.2 Logistical Inquiry A-Rations Screen Command 
Buttons 

9.2.1 Select Menu Command Button 
Allows the user to view/select all menus stored in the CFLM DBMS. Clicking on this button 
produces the Open dialog box listing all available menus. Once selected, the menu name and 
file location are displayed in the Select Menu data field. 

9.2.2 Select Ship 
Allows the user to view/select the ships stored in CFLM DBMS. Clicking on this button 
produces a pop-up displaying all available ships. Once selected, the Ship's Name, Hull No., 
and Ship's Complement (Enlisted Only) data fields are entered. 

9.2.3 Calculate Logistics 
Allows the user to view the portions, ingredient amounts, labor, equipment, etc. required for a 
given menu based on specified data. Clicking on this buttons starts the calculating process. 
The results may be viewed by selecting from the Reports option. 

9.2.4 Close Menu Button 
Allows the user to close the currently displayed menu and perform a different function. 
Clicking on this button closes the current menu and clears the data fields. 
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9.2.5 Exit Command Button 
Allows the user to exit the Logistical Inquiry A-Rations Screen and return to the CFLM 
DBMS main menu. 

9.3 New Inquiry 
The New Inquiry option allows the user to enter the information in the Logistical Inquiry A-Rations 
Screen (Figure 9.3-1) required for the various calculations. To run a new inquiry select the New 
Inquiry option from the Inquiry menu item in the menu bar. 
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FIGURE 9.3-1 LOGISTICAL INQUIRY A-RATIONS SCREEN 

9.3.1 How to Run a New Inquiry 
1. Select the New Inquiry option from the Inquiry menu item in the menu bar. 

(System will prompt the user to Select a Menu) 

2. Double-click on the Select Menu button. 

3. Select desired Menu from the Open dialog box. The user can select from other 
directories, but the Menu File must have been created using the CFLM DBMS. 
Click on the Open button. 

4. Click on the Select Ship button and select appropriate ship from the pop-up. 

5. Enter the % of the Total # of Customers Who Subsist from the Speedline (If 
Available) data field. 
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6. Enter the % of the Total # of Customers Who Visit the Salad Bar data field if 
default value is incorrect. Enter 0 (zero) if no Salad Bar is available. 

7. Enter T or F in the All Ranks Subsist from the General Mess data field. 

8. Enter T or F in the Ship is at Sea data field, selecting F would infer that the ship 
was inport. (Once entered the Attendance Rates data fields are filled in with the 
default rates.) 

9. Enter the Attendance Rates data fields if different from defaults. 

10. Click on the Calculate Logistics button. The system produces an Information 
dialog box notifying the user that "The System Is Calculating the Logistical Data. 
It Will Take a Few Moments. Please Wait..." When the calculation process is 
complete the system will produce an Information dialog box notifying the user that 
the "Logistical Calculations are Complete and to Select From The Report Options 
To View Results." Click on the OK button to continue. 

11. Select from the Report Options to view the results. 

12. Save the Files as desired 

• User Input, and, or 

• Logistical Data (Ingredients) and/or 

• Daily Menu with Requirements. 

(The default directory is CFLMYLOGS. Using the Save features listed above 
saves only the data. The most useful format to save details is as a database file 
(.DBF) or spreadsheet file (.XLS).) 

13. Click on the Close Menu button. 

14. Click on the Exit button to return to the CFLM DBMS main menu. 

9.4 Preview/Print Reports 
The Report menu item allows the user to preview and/or print selected information derived from the 
Logistical Inquiry A-Rations Screen. The user has the option to view the reports on the screen 
and/or on paper. A report may be re-selected as often as desired. However, once a new inquiry is 
entered or the user leaves this screen, the information is lost unless the report was printed or the data 
saved to a file. To retrieve this data at a later time, a commercial database or spreadsheet software 
program must be used. To view the information, the user will select the Report menu item from the 
menu bar, select the desired report, and click on the appropriate radio button in the Report 
Generation dialog box. Selecting Preview sends the report to the Page Preview Screen, Print sends 
the report to the printer. The Logistical Inquiry A-Rations Screen Reports are described below: 
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9.4.1 Print User Input 
The Print User Input Report option provides the user with a report that displays all data 
entered to generate the new inquiry. This report will display the ship information which can 
then be compared to the selected menu's requirements (i.e., freezer storage). 

9.4.2 Print Selected Menu 
The Print Selected Menu Report option provides the user with a report that displays each 
recipe entered by Day, Meal, Recipe No., and Item Name for the selected menu. 

9.4.3 Print Menu with Labor/Eq/Strg/Cost Req. 
The Print Menu with Labor/Eq/Strg/Cost Req. Report option provides the user with a report 
that displays the Number of Portions, Cost($), Storage Required per cubic foot (Dry, Chilled, 
Freezer), Labor Hours, Number of Ovens, and any other equipment required for individual 
recipes in the selected menu. Daily Totals for Cost ($), Labor Hours, and Number of Ovens 
are provided as well as Totals for Menu Cycle for Cost($) and Storage Requirements. 

9.4.4 Print Logistical Info with List of Requirements 
The Print Logistical Info with List of Requirements Report option provides the user with a 
report that displays a summary of storage space requirements in cubic feet and ingredient 
costs broken out by the three different types of storage (Dry, Chilled, Frozen). The storage 
amounts are displayed by the Required Amount (based on the actual ingredients used) and the 
Minimum Amount (based on the minimum number of cases required). The Total Cost for the 
selected menu is also provided. 

9.4.5 Identify Items by Application Logistical Code 
The Identify Items by Application Logistical Codes Report option provides the user with a 
report that lists the NSN, Ingredient Name, Usage Management Code (when available), and 
the Acquisition Advice Code. If there are ingredients identified in this report which should 
not be used (i.e., Terminal Item) the user can go to the Logistical Information Screen to use 
the Print List of Recipes with this Ingredient Print option to list affected recipes. 

9.4.6 Print List of Acquisition Advice Codes 
This Report option provides the user with a list of Acquisition Advice Codes and 
Descriptions. The Acquisition Advice Codes are provided for NSN items in the Identify Items 
by Application Logistical Codes Report option described above. 

9.4.7 Print List of Usage Management Codes 
The Print List of Usage Management Codes Report option provides the user with a list of 
Usage Management Codes and Descriptions. The Usage Management Codes are provided for 
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NSN items in the Identify Items by Application Logistical Codes Report option described 
above. 
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10. OPTIONS-RUN 
OPTIMIZATION MODEL OPTION 

10.1 General Information 
The Options-Run Optimization Model Option Logistical Optimization Screen allows the user to 
view logistical information associated with specific ships for selected A-Ration menus. It also allows 
the user to compare this logistical information with that of a newly generated menu containing 
convenience food substitutes. This substitution menu can be optimized by iteratively changing the 
substitution rates and weights of the objective function (i.e., minimize cost, labor, etc.). The 
remainder of this section will describe in detail the Logistical Optimization Screen Command 
Buttons and step by step instructions for using the Logistical Optimization Screen. 

10.2 Logistical Optimization Screen Command Buttons 

10.2.1 Select Menu Command Button 
Allows the user to view/select a menu. Clicking on this button produces the Open dialog box 
listing the menus stored in the CFLM\MENUS directory. Note that a menu located in another 
directory or drive may be accessed. Once selected, the menu name and file location are 
displayed in the Select Menu data field. 

10.2.2 Select Ship Command Button 
Allows the user to view/select the ships stored in CFLM DBMS. Clicking on this button 
produces a pop-up displaying all available ships. Once selected, the Ship's Name, Hull No., 
and Ship's Complement (Enlisted Only) data fields are entered. 

10.2.3 Generate Substituted Menu Command Button 
Allows the user to produce a new menu based on the data entered in the Logistical 
Optimization Screen. The new menu is developed using a mix of AFRS recipe items and 
convenience food substitutes based on the user's input (i.e., substitution rates, preferences). 
Clicking on this buttons starts the new menu generation process. 
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10.2.4 Close Menu Button 
Allows the user to close the currently selected A-Ration menu file and start a new inquiry. 
Clicking on this button closes the current menu and clears the data fields. 

10.2.5 Exit Command Button 
Allows the user to exit the Logistical Optimization Screen and return to the CFLM DBMS 
main menu. 

10.3 New Inquiry 
The New Inquiry option allows the user to enter the information in the Logistical Optimization 
Screen (Figure 10.3-1) required for developing a new menu with convenience food substitutes. To 
run a new inquiry select the New Inquiry option from the Inquiry menu item in the menu bar. 
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10.3.1 How to Run a New Inquiry 
1. Select the New Inquiry option from the Inquiry menu item in the menu bar. 

(System will prompt the user to Select a Menu) 

2. Double-click on the Select Menu button. 
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3. Select desired menu from the Open dialog box. The user can select from other 
directories, but the Menu File must have been created or have the same structure 
as the Menu Files created from the CFLM DBMS. Click on the Open button. 

4. Click on the Select Ship button and select appropriate ship from the pop-up. 

5. Enter the % of the Total # of Customers Who Subsist from the Speedline (If 
Available) data field. 

6. Enter the % of the Total # of Customers Who Visit the Salad Bar data field if 
default value is incorrect. Enter 0 (zero) if no Salad Bar is available. 

7. Enter T or F in the All Ranks Subsist from the General Mess data field. 

8. Enter T or F in the Ship is at Sea data field, selecting F would infer that the ship 
was inport. (Once entered the Attendance Rates data fields are filled in with the 
default rates.) 

9. Enter the Attendance Rates data fields if different from defaults. 

10. Enter the desired substitution rates (%) for each of the meal categories shown. 
Substitution rates must be less than 100 %. High substitution rates are likely to 
provide a dialog box notifying the user that the substitution rates are too high and 
the substitution process infeasible. The substitution rates entered will be used by 
the model to generate menus having the desired number of convenience food items 
based on the rates entered (i.e., if the Entrees field is given a 20.0 % substitution 
factor, the system will substitute 20% of the Entrees with a convenience item if 
feasible). 

11. Enter the importance/weights for each of the objectives shown. These values must 
be between 1-10. This data field allows the user to set priorities for calculation 
factors (i.e., if the goal is to minimize costs, the Minimize Costs factor would be 
entered to identify to the system that minimizing costs is a priority.) 

12. Click on the Generate Substituted Menu button. An Information dialog box 
appears notifying the user that "The System is Generating a New Menu, It May 
Take A Few Moments, Please Wait...." Click on the OK button to continue. 
When the processing is complete the system produces another Information dialog 
box notifying the user that the "Processing Has Completed, Select From The 
Report Options To View The Results." Click on the OK button to continue. If 
the data entered is not feasible the system will display an error message stating 
"Problem Infeasible, Reduce Substitution Rate and Re-run." Click on the OK 
button to continue. 

13. Save the Files as desired. (Although the reports can not be saved in their existing 
format, the new data saved can later be manipulated by the user for other 
purposes.) 

• Save File Name for Model Input, and/or 

• Save A-Ration Menu w/Log. File Name, and/or 

• Save Substituted Menu w/Log. File Name, and/or 
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• Save File Name for Substituted Menu, and/or 

• Save File Name for Logistical Comparison data. 

(The default directory is CFLM\LOGS. Using the Save features listed above 
saves only the data. The most useful format to save details is as a database file 
(.DBF) or spreadsheet file (.XLS).) 

14. Click on the Close Menu button. 

15. Click on the Exit button to return to the CFLM DBMS main menu. 

10.4 Preview/Print Reports 
The Report menu item allows the user to preview and/or print selected information derived from the 
Logistical Optimization Screen. The user has the option to view the reports on the screen and/or on 
paper. A report may be re-selected as often as desired. However, once a new inquiry is entered or 
the user leaves this screen, the information is lost unless the report was printed or the data saved to a 
file. To view the information the user will select the Report menu item from the menu bar, select the 
desired report, and click on the appropriate radio button in the Report Generation dialog box. 
Selecting Preview sends the report to the Page Preview Screen; Print sends the report to the printer. 
The Logistical Optimization Screen reports are described below: 

10.4.1 Print User Input 
The Print User Input Report option provides the user with a report that displays all data 
entered to generate the new inquiry, information associated with the ship selected, and the 
estimated logistical requirements for the standard menu items. 

10.4.2 Print Input A-Ration Menu 
The Print Input A-Ration Menu Report option provides the user with a report that displays 
each recipe entered by Day, Meal, Recipe No., and Item Name for selected menu. 

10.4.3 Print A-Ration Menu with Logistics 
The Print Menu with Labor/Eq/Strg/Cost Req. Report option provides the user with a report 
that displays the Number of Portions, Cost($), Storage Required per cubic foot (Dry, Chilled, 
Freezer), Labor Hours, Number of Ovens, and any other equipment required for individual 
recipes in the selected A-Ration Menu. Daily Totals for Cost ($), Labor Hours, and Number 
of Ovens are provided as well as Totals for Menu Cycle for Cost($) and Storage 
Requirements. 

10.4.4 Print Optimized Menu with Substitutions 
The Print Optimized Menu with Substitutions Report option provides the user with a report 
that displays the Substituted Menus for the Menu selected by Day, Meal, Recipe/Convenience 
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Product #, and Item Name. Three asterisks (***) before and after an Item Name represents 
the Item the system recommends based on the objectives entered. 

10.4.5 Print Optimized Menu with Logistics 
The Print Optimized Menu with Logistics Report option provides the user with a report that 
displays that displays the Number of Portions, Cost($), Storage Required per cubic foot (Dry, 
Chilled, Freezer), Labor Hours, Number of Ovens, and any other equipment required for 
Substituted Menus. Daily Totals for Cost ($), Labor Hours, and Number of Ovens are 
provided as well as Totals for Menu Cycle for Cost($) and Storage Requirements. 

10.4.6 Print Items with List of all Substitutes 
The Print Items with List of all Substitutes Report option provides the user with a report that 
displays by Day, Meal, Recipe No. and Item Name the Convenience Substitute No. and Name 
of the menu items that have been identified as items to be replaced with Convenience Food 
Substitutes. Three asterisks (***) before and after an Item Name represents the Item the 
system recommends based on the objectives entered. 

10.4.7 Print A-Ration versus Optimized Comparison 
The Print A-Ration versus Optimized Comparison Report option provides the user with a 
report displaying by Day and Meal the Daily and Grand Totals for Cost, Storage 
Requirements, and Labor Hours for the A-Ration Menu and its Substituted Menu. 

10.4.8 Print Equipment Comparison 
The Print Equipment Comparison Report options provides the user with a report displaying by 
Day and Meal the Daily and Grand Total Equipment Requirement for Ovens, Fryers, Kettles, 
Mixers, and Griddles for the A-Ration Menu and its Substituted Menu. 
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11. OPTIONS - UPDATE PRICES 

11.1 General Information 
The Price Update Screen allows the user to automatically update the ingredient prices and recipe 
costs for recipes entered in the CFLM DBMS. This option should be used with caution as it could 
corrupt the Logistics File and cost information in the Recipe File if done improperly. The remainder 
of this section will describe in detail the Price Update Screen Command Buttons and step by step 
instructions for using the Price Update Screen. 

11.2 Price Update Screen Command Buttons 

11.2.1 Update Prices Command Button 
The Update Prices button allows the user to start the price update process. If the file 
information is incomplete, an error message will appear prompting the user to enter the Name 
of File Containing New Prices. The cursor will be returned to the field where the Drive is 
entered. Executing this feature will adjust the unit costs in the Logistical File used by the 
model to store the data found in the Group 89 FSC. This feature only updates the prices and 
dates (as entered by the user on the screen) for matching items. New items must first be 
entered using the Logistical Information Screen. (Note, these items would most likely be 
identified in the Updating File by an A in the Action Code field). 

11.2.2 Update Recipe Costs Command Button 
The Update Recipe Costs button allows the user to commence the process of updating the 
recipes stored in the CFLM DBMS based on the updated ingredient prices. This process 
could take an hour or more to complete. 

11.2.3 Close File Command Button 
The Close File button allows the user to close the update file. 

11.2.4 Exit Command Button 
Allows the user to exit the Price Update Screen and return to the CFLM DBMS main menu. 
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11.3 Logistics File Database Price Update Procedures 
To update the Logistics File Database Prices select the Update Prices option from the Options menu 
item in the menu bar. The Price Update Screen (Figure 11.3-1) will appear. The default values 
listed below are based on the FoxPro database file used by NAVSUP to maintain the data found in 
the Group 89 FSC. Note that these values are defaults and can be modified as necessary. 

• DEFAULT VALUES 

• Drive - A 

• Path - None 

• Filename - UFOODITM.DBF 

• Field - CURFPRI. 

To successfully perform the price update function the FoxPro database file used to update the model 
must have at least the following data fields defined: 

• FOXPRO DATABASE FILE - REQUTRED DATA FTELDS 

• NSN - A character data type field named NSN with a width of 13 . 

• PRICE - A numeric data type field containing the unit price with a width of 6 
and 2 decimal places. 

This table should be indexed on the NSN. The index file should also exist in the selected drive/path 
(i.e. UFOODITM.CDX). 

52 



Eile   Help 

mmm^ lX>GjRl£:a&r PftlCS UPDATE 
wJmSm 

th* «utfftftt <tfi6M 4t« tafcjrt&d x   <a*<acuint «lÄh 9w cunant infiirmtmi». 

PaÄ.        r ?p;s ' Ü£2£   ' f|«» 
,,_''.  " '" " **\f'.<:z ''„ »mtc: r   i y ri 

s      -rVBIU. itmitMw tnii WIIHH »tint • • 

K::v::S^.***y>r>Vy^::::::ii»i»»iiM> iimi *,'*''''''tii'''->-<'>>y--^ 

mm» %m 

m 
ffism 

HI 
«isssü ^^ 

mm 

Wm> 

mm 

tYi'MtViYi I'Ii'i't' 1 i't'i \  it'l 

isoJfc «eawd 327fl31S £«&wt 
111 'IVM I'I'III'I I'I YI'I i YI'I Y '♦ Viinn *** im tun HIII*HIIIIIIM»I' i'i'i HIHI 

: tra£ '■■'. ?&üm:i -.1 CK» : 

FIGURE 11.3-1 PRICE UPDATE SCREEN 

11.3.1 How to Update Prices 
1. Enter the Drive data field where the Update File is located (i.e., A). 

2. Enter the Path data field, if applicable. 

3. Enter the name of the file containing the new prices in the Filename data field. The 
Filename entered cannot be 'LOG_FILE'. It must be a FoxPro compatible 
database file with the key field being 'NSN' and the CDX index on 'NSN'. An 
error message will appear notifying the user if the Update File is in an unacceptable 
format. 

4. Enter the Field data field (this is the name of the field that represents the new unit 
price in the update file). 

5. Enter the current fiscal month/year associated with the current information. 

6. Enter the actual price month/year associated with the current information. 

7. Click on the Update Prices button. 

8. Click on the Update Recipe Prices button. An Information dialog box will appear 
notifying the user that "This Process Could Take An Hour Or More. Continue?" 
Click on the Yes button to continue. 

9. Click on the Close button to close the active file. 

10. Click on the Exit button to return to the CFLM DBMS main menu. 
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APPENDIX A - GLOSSARY OF 
TERMS AND ABBREVIATIONS 
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Acquisition Advice Code 
Identifies the type of purchase for the product (i.e., Local Purchase, DOD 
Integrated Material, etc.). 

Action Code 
A code denoting an addition, change, or deletion to published data. 

AFRS 
Armed Forces Recipe Service. 

Browse Window Screen 
Allows the user to enter ingredient amounts required for a recipe and to make 
changes to existing ingredient information. 

Check Boxes 
Provide the ability to select from various options. When an option is selected, an 
'X" appears in the box; otherwise the box appears empty. Click in the check box 
to select and deselect an option. 

Command Buttons 
Buttons used throughout the CFLM DBMS to invoke a particular action 
associated with a screen. Most Command Buttons only require a single-click on 
the mouse to be executed. 

Convenience Food Logistics Model (CFLM) 
A stand-alone system used to conduct costs/benefits of convenience food product 
substitution by iteratively running the CFLM for various ship types, attendance and 
selection rates. 

Convenience Foods Screen 
Allows the user to add, delete and search for Convenience Food Products. The 
information stored in the Convenience Food Product database file is used to 
associate A-Ration recipe items with similar convenience food products to be used 
on board Navy Ships. 

CPU 
Central Processing Unit. 
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DBMS 
Database Management System. 

FIC 

Food Identification Code. 

FSC 
Federal Stock Catalog. 

Index Number 
A sequencing number assigned to each item in accordance with its alphabetical 
position. 

Ingredients Screen 
A subsystem of the Recipe Information Screen, the Ingredients Screen allows the 
user to view a list of ingredients required in the selected recipe. Ingredients may 
be added, changed or deleted from this screen. 

Labor Code 
The effort involved in preparing the convenience food product (i.e., Heat and 
Serve, Thaw and Serve, etc.). (Refer to Appendix D for a list of Convenience 
Food Product Labor Codes.) 

Labor Type 
The effort involved in preparing the recipe (i.e., Prepare and Bake, Bake from 
Scratch, Bake from Mix, etc.). (Refer to Appendix C for a list of Recipe Labor 
Codes.) 

Price Update Screen 
Allows the user to automatically update the ingredient prices and recipe costs for 
recipes entered in the CFLM DBMS. 

Logistical Information Screen 
Allows the user to update the Logistical Database file containing the food products 
available through the Federal Supply Catalog. 
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Logistical Inquiry A-Rations Screen 
Allows the user to view logistical information associated with specific ships for 
selected menus. 

Logistical Optimization Screen 
Allows the user to view logistical information associated with specific ships for 
selected A-Rations menus. It also allows the user to compare this logistical 
information with that of a newly generated menu containing convenience food 
substitutes. 

Menu Creation Screen 
Allows the user to create new menus, select and modify existing menus, and delete 
selected menus from the CFLM DBMS. 

NAVSUP 
Naval Supply Systems Command. 

NSN 
National Stock Number. 

Product Type 
A descriptor for the food product or ingredient (i.e., pasta items, Asian food, 
seafood, etc.). 

Radio Buttons 
Radio buttons are displayed as circles with a black dot placed in the center of the 
chosen option. If the user selects a different option, the one currently selected is 
changed back to a plain circle. Only one option may be selected at a time. 

Recipe Category 
The part of the meal for which the recipe would be served (i.e., appetizer, entree, 
etc.). (Refer to Appendix E for a listing of Recipe Categories.) 

Recipe Information Screen 
Allows the user to perform functions such as add, delete and search for recipes in 
the AFRS database. 
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Refreshing the Screen 
The process by which new data appears as the system moves to a new record. 

Search 
Allows the user to identify items stored in the AFRS database that meet specified 
criteria. 

Select a Meal 
Allows the user to identify the meal category for the recipe item (breakfast, lunch, 
dinner, midrats). 

Ship Information Screen 
Allows the user to enter all pertinent ship information for ship classification, ship 
type and class of ship. 

Status Bar 
Located at the bottom of the screen, the status bar indicates the leading table into 
which information is being stored. It will also indicate the record number in the 
table where the system is standing. 

Storage Type 
The form of storage required for a Food Product (chilled, dry, or freezer). 

Substitution List 
A list of convenience food products which may be suitable substitutes for selected 
recipes. 

Usage Mgmt Codes 
Identify the type of usage for the food product (i.e., Afloat Only, Submarines Only, 
Controlled Item, etc.). 
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APPENDIX B - ERROR 
MESSAGES 
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ERROR ID ERROR MESSAGE 

ADDCATGRY You Must First Enter A Category, Then A Manufacturer. 

ADDINGR You Must First Enter The Ingredients For This Recipe. 

ADDMANUF You Must Enter The Manufacturer of This Product. 

ADDPTYPE You Must First Enter The Product Type For This Product. 

ADDQTY Please Enter A Quantity And CookJJnit For All Ingredients. 

CASECOST You Must Enter The Cost/Case For The Convenience Food Product. 

CASESVGS You Must Enter The Servings Per Case For The Convenience Food Product 
Based on Mnftr. Suggested Serving Size. 

CASEVOL You Must Enter A Case Volume For The Convenience Food Product. 

CASEWGT You Must Enter The Net Weight/Case For The Convenience Food Product. 

CLOSEMEN Close Menu File Before Running A New Logistical Inquiry. 

CODECHG If You Changed The Category Code Or Product Type Of This Recipe, Re- 
Generate The Conv. Foods Subst. List Their Prefix 

CODEEXST This Prefix Is Used To Identify Another Product Type. Please Select Another 
Prefix. 

COMPLETE Logistical Calculations are Complete. Select From The Report Options To 
View Results. 

DBFFILE The File Used To Update Prices Must Be A FOXPROW Compatible (.dbf) 
File. 

DBFSELE The File Selected Must Be A .dbf File Generated Through The Menu Screen. 

DELMENU Are You Sure You Want To Delete The Selected Menu File? 

DELWARN Are You Sure You Want To Delete The Current Record? 

DOCALC If You Added, Deleted, Or Changed An Ingredient, Re-Calculate Cost/100. 

ENTRUNTT You Must Enter The Units of Measure. 

FILEOPEN Your Price Updating File Is Open. Press 'Close File' Button Before Exiting. 

FLEXIST This File Already Exists. Copy Over Existing File? Select No' To Save 
Changes To New Menu File. 

GROSSWT You Must Enter The Gross Weight/Case For The Convenience Food Product. 

GT100 The Substitution Rate Should Be Between 0 And 100 (%). 

INFEAS Problem Infeasible. Reduce Substitution Rate and re-run. 

INVALID You Can Not Update The Logistical File (LOG_FILE.dbf) With A File Of The 
Same Name. 

LABRSEL You Must Select The Type Labor Required To Prepare This Item. 

LENGTH The Length of The National Stock Number (NSN) Must Be 13 Digits. 

LOGCALC The System is Calculating The Logistical Data. It May Take A Few Moments. 
Please Wait  

MANUEXST This Manufacturer Already Exists. 

MENUGEN Processing Has Completed. Select From The Report Options To View Results. 

MENUSELE You Must Select A Menu File Before Adding Recipes. Select From Menu 
Options. 

NEWMENU The System is Generating a New Menu. It May Take A Few Moments. Please 
Wait  

NODIR The Tables In This Directory Are Restricted. Please Select Again. 

NONAME You Must Give The Menu File A Name. 

NORECORDS No Records Found. 

NORECP There Are No Recipes Associated With This Item. 

NOSUBST The Database Contains No Convenience Food Substitutes For This Recipe. 
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ERROR ID ERROR MESSAGE 

NSMNUM Enter An NSN First. 

NWNAME You Must Enter A File Name. 

PORTSIZE You Must Enter A Portion Size For Both The Convenience Food Product And A 
Comparable AFRS Recipe. 

PORTUNIT The AFRS Portion Must Be Compatible With The Convenience Food Product 
Orln'OZ.' 

PRESSAVE You Must First Press The Save Button To Store New Recipe/Product. 

PRFXEXST This Prefix Is Used To Identify Another Manufacturer. Please Select Another 
Prefix. 

RECLENG The Length of The Recipe Number Must Be Equal To 6. 

RECNUM Enter A Recipe Number First. 

RECPEXST This Recipe Number Already Exists. Enter New Number. 

SAVECHG Did You Save Changes First? 

SAVECOMP Do you want to save comparison information between the A-ration and 
Substituted menus? 

SAVEINP Do You Wish To Save The Input Used In This Inquiry? If Yes,' Enter Filename 
Now. 

SAVELOG Do You Wish To Save The Output Logistical Data? If Yes', Enter Filename 
Now. 

SAVEMEN A Menu File Is Open. Press 'Close Menu' Before Leaving Screen Or Creating A 
New Menu File. 

SAVEMSG Select From The Following Options. 

SAVESUB Do You Wish To Save The New Menu File? If Yes,' Enter Filename Now. 

SAVESUM Do You Wish To Save The Input Menu File With Portions, Costs, Storage 
Reqmts, Labor & Equipment Info? If Yes,' Enter Filename Now. 

SAVFILE Save Changes To Current Menu File? Select "No' To Save Changes To New 
Menu File. 

SAVMENU Enter A File Name For The Menu File You Created. 

SELEFILE Enter Name of File Containing New Prices. 

SELMENU Press The 'Select Menu File' Button To Locate a Menu File. 

STORTYPE You Must Select The Type Of Storage Required For This Convenience Food 
Product. 

SUBLIST Identifying Convenience Food Substitutes May Take A Few Minutes. Please 
Wait. 

TWOCHAR This Number Should Contain Two Digits. 

TYPEEXST This Product Type Already Exists. 

UNITS Cook_Units In The Ingredient File Are Incompatible With The Units Of Issue 
In The Logistical File. Revise And Rerun Cost Calculation. 

UPDATE This Message Will Disappear When The Recipe Costs Have Been Updated. 
Press 'OK' to Continue. 

UPDTRECP This Process Could Take An Hour Or More. Continue? 

WAITOPEN Please Wait Until The New Price File Has Been Opened. 

WRNGCODE The Length of The Manufacturer's Product Code Must Not Be Longer Than 8. 

WT10 Weight should be between 0 and 10 

ZPREFTX Note that changes to the existing AFRS Recipes should be done by creating a 
new recipe with a T prefix. 
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APPENDIX C - RECIPE LABOR 
CODES 
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LABOR TIME (MIN) /# PORTIONS 
CODE DESCRIPTION /100 /200 /500 

BE EASY BAKE 45 80 120 
BMP MEATLOAF: MOREPREPREQ. 120 210 300 
BMX BAKEW/MK 15 30 45 
BP PREPARE & BAKE 100 170 250 
BPRG PROG. COOK/BAKED 100 100 100 
BPRS PREPARE, ROAST & SLICE 150 200 330 
BRD BREADS 45 60 105 
BRS BREADS: SHORT TIME 30 45 90 
BS BAKE FROM SCRATCH 30 35 50 
BTR BATTER 10 10 10 
BWSM WGH, SL, MLD, BAKE (SALS.STK) 90 180 280 
BYD BAKE/FRY W/YEAST DOUGH: DIFFI 135 180 260 
BYE BAKE/FRY W/YEAST DOUGH: EASY 110 150 200 
BYMX BAKE/FRY W/YEAST USING A MIX 60 80 180 
CKD CAKEDONUTS 60 75 105 
CKDM CAKE DONUTS W/ MIX 45 60 75 
CKDMT CAKE DONUTS W/ MIX & TOPP 60 75 90 
CKDT CAKE DONUTS W/TOPPING 75 90 120 
COM COMMERCIALLY PURCHASED ITEM 10 20 35 
COMP COMMERCIALLY PURCH.W/PREP. 30 50 85 
COMX COOKIES W/MTX 45 60 120 
COSCR COOKIES FROM SCRATCH 60 75 155 
CP COLD PREP. REQ. (SANDWICH) 50 100 180 
CRPF CREAM PUFFS 120 165 240 
CSC COLD SAUCE 20 25 35 
CSP COLD SAUCE: XTRA PREP. REQ 25 40 60 
EGGS EGGS TO ORDER/OMELETTES 90 105 120 
FPRG PROG. COOKFRIED 125 150 180 
FR FRIED-NOPREP 30 45 90 
FRP FRIED-W/PREP 50 80 150 
FRT FRUIT CUP/ITEM 75 105 180 
FRXP FRIED - W/EXTRA PREP REQ 290 400 600 
GBH BACON/HAM GRILLED OR OVEN GRL 25 35 80 
GE EASY GRIDDLE (PANCAKES) 60 80 120 
GP GRIDDLE: MORE PREP. REQ. 80 100 140 
GPRG PROG. COOK/GRIDDLE 110 120 150 
GXP GRILL-XTRA PREP. REQ (FAJITAS) 180 320 600 
HSC HOT SAUCE/GRAVY 25 40 60| 
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LABOR TIME (MIN) /# PORTIONS 

CODE DESCRIPTION /100 /200 /500 

HSMX HOT SAUCE/GRAVY FROM A MIX 20 25 35 

JUICE CND/CONC JUICE MK 10 20 45 

KE KETTLE COOKED - EASY 15 25 45 

KPRG PROG COOK/STEAM 110 130 180 

LASGN LASAGNE/PREP. CASSEROLE 165 210 420 

MFNX MUFFINS W/MK 40 60 90 

MFSC MUFFINS FROM SCRATCH 60 75 105 

MXFRE MIX & FRY: EASY 35 45 60 

MXFRP MIX & FRY: MORE PREP. REQ 50 80 150 

OAGR OATMEAL/GRITS 10 15 20 

OTHDS OTHER DESSERTS 30 45 90 

PDGL PUDDINGS/GELATINS W/MLX 15 20 30 

PffiCM CREAM/CUSTARD PIES W/MTX 60 75 135 

PIECS CREAM/CUSTARD PIES: SCRATCH 100 125 200 

PffiFP FRUIT Pffi/COBLRS W/PREP FILLG 45 60 120 

PIEFS FRUIT PIE/COBLRS: SCRATCH 75 90 150 

PRCE EASY PASTA/RICE CASSEROLE 45 65 100 

PSRCG PASTA/RICE MJX: GRIDDLE 60 75 135 

PSRCO PASTA/RICE MJX: OVEN PREP 45 60 120 

PSTRC PASTA/RICE 20 30 45 

PZ PIZZA 150 200 240 

ROL ROLLS 50 80 180 

SPC CONDENSED CANNED/DEHYD SOUPS 10 20 45 

SPS SOUPS FROM SCRATCH 30 60 120 

SIE STEWS: EASY PREP 50 80 160 

STP STEWS: MORE PREP TIME REQ 100 150 210 

STXP STEWS: EXTRA PREP TIME REQ 180 300 480 

TST TOAST/WAFFLES 15 25 45 

VC VEGETABLE ITEM/CASSEROLE 20 50 80 

VCE EASY VEG OR POT. ITEM/CASSEROL 15 20 35 

VFR FRESH VEGETABLES 75 105 180 

VFZ FROZEN VEGETABLES 20 45 105 

VPC VEGETABLE ITEM/CASSEROLE (POT) 30 60 120 

VS VEGETABLE SALAD 75 105 180 

VSTRF STJR FRY VEGETABLES 40 60 100 
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APPENDIX D - CONVENIENCE 
FOOD LABOR CODES 
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LABOR 
TIME (MIN)/# 
PORTIONS 

CODE DESCRIPTION /100 /200 /500 

BFE BREAKFAST ENTREE ITEMS 25 50 120 
BHT BAKERY HEAT/NON INDIV ITEMS 15 25 45 
BKI BAKERY INDIVIDUAL (NON-YEAST) 20 30 70 
BTT READY MADE BATTERS 20 35 90 
FRY DEEP FAT FRYER 30 45 90 
GRD GRIDDLE/NON-PROGRESSIVE 25 35 80 
HAS HEAT AND SERVE 7 15 35 
HAT HEAT AND TRANSFER 15 30 60 
HT1 HEAT, INDIV. PKGD(LOW COUNT) 25 50 120 
HT2 HEAT, INDIV. PKGD(HIGH COUNT) 20 40 95 
KET HEAT IN KETTLE/NON-PROGRESSIVE 10 20 45 
PST PASTA 20 30 45 
TAS THAW/SERVE 10 20 35 
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APPENDIX E - RECIPE 
CATEGORIES 
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CATEGORY DESCRIPTION                             SEL.RATE 
AP APPETIZER 51.8 
BE BREAKFAST ENTREES 57.1 
BR BRDS/BISCUrrS/ROLLS/MUFFINS 80.0 
BS BREAKFAST SIDE ITEMS 47.8 
BV BEVERAGES 64.6 
DS DESSERT 70.9 
EN ENTREE 62.7 
MS MISCELLANEOUS 25.0 
SC SAUCES 49.6 
SI SIDE ITEM 71.2 
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APPENDIX F - PRODUCT TYPES 
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PRODUCT PRODUCT TYPE DESCRIPTION 
CODE 
ASIA ASIAN ITEM 
BAKG BREADS/BISCUITS/ROLLS 
BEFG GROUND BEEF ITEM 
BEFR ROAST BEEF ITEM 
BEFS BEEF (STEAK) ITEM 
BKFT BREAKFAST ITEMS 
CAJN CREOLE/CAJUN ITEM 
CAKE CAKES 
CDAP COLD APPETIZER 
CDBV COLD BEVERAGE 
CHKN CHICKEN ITEM 
COOK COOKIES 
DUCK DUCK ITEM 
EGDS EGG ITEM 
FISH FISH ITEM 
FRUT FRUIT 
GLTN GELATIN ITEM 
GRMY GERMAN ITEM 
GRVY GRAVIES 
HTAP HOT APPETIZER 
HTBV HOT BEVERAGE 
ICEY ICE CREAM/YOGURT 
ITAL ITALIAN ITEM 
LAMB LAMB ITEM 
MEXI MEXICAN ITEM 
MISC MISCELLANEOUS 
MSMN MISC MAINITEMS 
MSSI MISC SIDE ITEMS 
MSTP MISCELLANEOUS TOPPINGS 
PDDG PUDDING 
PIEC CREAM PIE/CUSTARD/MISC 
PIEF FRUIT/NUT PIE 
PORK PORK ITEM 
PSCH PASTA WITH CHEESE 
PSMT PASTA WITH MEAT OR SEAFOOD 
PSTA PASTA ITEM 
RCDH RICE ITEM 
RELH RELISHES 
SFDH SEAFOOD ITEM 
SLAD SALAD 
SLDR SALAD DRESSINGS 
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PRODUCT PRODUCT TYPE DESCRIPTION 
CODE 
SNDW SANDWICH 
SOUT SOUTHERN ITEM 
SPBF BEEF BASED SOUP 
SPCK CHICKEN BASED SOUP 
SPCR CREAM OF (SOUPS) 
SPPK PORK BASED SOUP 
SPSF SEAFOOD BASED SOUPS 
SPVG VEGETABLE SOUP 
SWSA SWEET SAUCES/TOPPINGS 
TRKY TURKEY ITEM 
VEAL VEAL ITEM 
VEGP VEGETABLE ITEM (POTATOES) 
VEGT VEGETABLE ITEM 
WSIN WEST INDIAN ITEM 
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APPENDIX G-SHIP 
CLASSIFICATION, TYPE, CLASS 

CODES 
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SHIP CLASSIFICATION 

Ship 
Classification 

Description 

AUX AUXILIARY SHIP 
AWC AMPHIBIOUS WARFARE CRAFT 
AWS AMPHIBIOUS WARFARE SHIP 
CS COMBATANT SHIP 
MWS MINE WARFARE SHIP 
PC PATROL CRAFT 
SC SERVICE CRAFT 

TYPE CODES (WITHIN A CLASSIFICATION) 
Ship 
Class 

Type 
Code 

Type Code Description 

AUX AD DESTROYER TENDER 
AUX AE AMMUNITION SHIP 
AUX AFS COMBAT STORE SHIP 
AUX AG MISCELLANEOUS 
AUX AGDS DEEP SUBMERGENCE SUPPORT SHIP 
AUX AGEH HYDROFOIL RESEARCH SHJDP 
AUX AGF MISCELLANEOUS COMMAND SHIP 
AUX AGM MISSILE RANGE INSTRUMENTATION SHIP 
AUX AGOR OCEANOGRAPHIC RESEARCH SHIP 
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Ship 
Class 

Type 
Code 

Type Code Description 

AUX AGP PATROL CRAFT TENDER 
AUX AGSS AUXILIARY RESEARCH SUBMARINE 
AUX AH HOSPITAL SHIP 
AUX AK CARGO SHIP 
AUX AKR VEHICLE CARGO SHIP 
AUX ALS AUXILIARY LIGHTER 
AUX AO OILER 
AUX AOE FAST COMBAT SUPPORT SHIP 
AUX AOG GASOLINE TANKER 
AUX AOR REPLENISHMENT OILER 
AUX AOT TRANSPORT OILER 
AUX AP TRANSPORT 
AUX APB SELF PROPELLED BARRACKS SHIP 
AUX AR REPAIR SHIP 
AUX ARC CABLE REPAIRING SHIP 
AUX ARL REPAIR SHIP, SMALL 
AUX ARS SALVAGE SHIP 
AUX AS SUBMARINE TENDER 
AUX ASR SUBMARINE RESCUE SHIP 
AUX ATA AUXILIARY OCEAN TUG 
AUX ATF FLEET OCEAN TUG 
AUX ATS SALVAGE AND RESCUE SHIP 
AUX AVM GUIDED MISSILE SHIP 
AUX AVT AUXILIARY AIRCRAFT LANDING TRAINING SHIP 
AUX AGOS OCEAN SURVEILLANCE SHIP 
AWC LCAC LANDING CRAFT, AIR CUSHION 
AWC LCM LANDING CRAFT, MECHANIZED 
AWC LCPL LANDING CRAFT,PERSONNEL, LARGE 
AWC LCU LANDING CRAFT, UTILITY 
AWC LCVP LANDING CRAFT, VEHICLE, PERSONNEL 
AWC LSSC LIGHT SEAL SUPPORT CRAFT 
AWC LWT AMPHIBIOUS WARPING TUG 
AWC MSSC MEDIUM SEAL SUPPORT CRAFT 
AWC SDV SWIMMER DELIVERY CRAFT 
AWC SLWT SIDE LOADING WARPING TUG 
AWC SWCL SPECIAL WARFARE CRAFT, LIGHT 
AWC SWCM SPECIAL WARFARE CRAFT, MEDIUM 
AWS LCC AMPHIBIOUS COMMAND SHIP 
AWS LHA AMPHIBIOUS ASSAULT SHIP 
AWS LHD AMPHIBIOUS ASSAULT SHIP 
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Ship 
Class 

Type 
Code 

Type Code Description 

AWS LKA AMPHIBIOUS CARGO SHIP 
AWS LPD AMPHIBIOUS TRANSPORT DOCK 
AWS LSD DOCK LANDING SHIP 
AWS LSV LOGISTICS SUPPORT VESSEL (ARMY) 
AWS LST TANK LANDING SHIP 
AWS LPH AMPHIBIOUS ASSAULT SHIP (HELICOPTER) 
cs CV AIRCRAFT CARRIER 
cs CVN AIRCRAFT CARRIER (NUCLEAR PROP) 
cs CG GUIDED MISSILE CRUISER 
CS CGN GUIDED MISSILE CRUISER (NUCLEAR PROP) 
cs DD DESTROYER 
cs DDG GUIDED MISSILE DESTROYER 
cs FF FRIGATE 
cs FFG GUIDED MISSILE FRIGATE 
cs PHM PATROL COMBATANT MISSILE (HYDROFOIL) 
cs SSBN BALLISTIC MISSILE SUB (NUCLEAR PROP) 
cs SSN ATTACK SUBMARINE (NUCLEAR PROP) 
cs SSAG AUXILIARY SUBMARINE 
MWS MCM MINE COUNTERMEASURES SHIP 
MWS MHC MINEHUNTER COASTAL 
MWS MSO MINESWEEPER OCEAN 
MWS MSB MINESWEEPING BOATS 
MWS MSD MINESWEEPING DRONES 
PC ATC MINI-ARMORED TROOP CARRIER 
PC PB(C) PATROL BOAT (COASTAL) 
PC PBR RIVER PATROL BOAT 
PC PC PATROL CRAFT 
PC PCF PATROL CRAFT' (FAST) 
PC PCC PATROL CRAFT (COASTAL) 
sc AFDB LG AUX FLOATING DRY DOCK (NON SELF-PROP) 
sc AFDL SML AUX FLTG DRY DOCK (NON SELF-PROP) 
sc AFDM MED AUX FLTG DRY DOCK (NON SELF-PROP) 
sc APL BARRACKS CRAFT (NON SELF-PROP) 
sc ARD AUX REPAIR DRY DOCK (NON SELF-PROP) 
sc ARDM MED AUX REPAIR DRY DOCK (NON SELF-PROP) 
sc DSRV DEEP SUBMERGENC RESCUE VEHICLE 
sc DSV DEEP SUBMERGENCE VEHICLE 
sc HSB HARBOUR SECURITY BOATS 
sc IX UNCLASSIFIED MISCELLANEOUS 
sc NR SUBMERSIBLE RESEARCH VEHICLE 
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Ship 
Class 

Type 
Code 

Type Code Description 

SC YAG MISC. AUXILIARY (SELF-PROPELLED) 
SC YC OPEN LIGHTER (NON SELF-PROPELLED) 
SC YCF CAR FLOAT (NON SELF-PROPELLED) 
SC YCV AIRCRAFT TRANSPORTATION LIGHTER (NSP) 
SC YD FLOATING CRANE (NON SELF PROP) 
SC YDT DIVING TENDER (NON SELF PROPELLED) 
SC YF COVERED LIGHTER (SELF-PROPELLED) 
SC YFB FERRY BOAT OR LAUNCH (SELF-PROPELLED) 
SC YFD YARD FLOATING DRY DOCK (NON SELF PROP) 
SC YFN COVERED LIGHTER (NON SELF PROP) 
SC YFNB LG COVERED LIGHTER (NON SELF PROP) 
SC YFND DRY DOCK COMPANION CRFT (NON SELF PROP) 
SC YFNX LIGHTER (SPECIAL PURPOSE) (NON SELF PROP 
SC YFP FLOATING POWER BARGE (NON SELF PROP) 
SC YFR REFRIGERATED COVERED LIGHTER (SELF-PROP) 
SC YFRN REFRIG COVERED LIGHTER (NON SELF PROP) 
SC YFRT COVERED LGHTR (RANGE TENDER) (SELF-PROP) 
SC YFU HARBOR UTILITY CRAFT (SELF-PROPELLED) 
SC YG GARBAGE LIGHTER (SELF-PROPELLED) 
SC YGN GARBAGE LIGHTER (NON SELF PROP) 
SC YHLC SALVAGE LIFT CRAFT, MED (NON SELF PROP) 
SC YM DREDGE (SELF-PROPELLED) 
SC YMLC SALVAGE LIFT CRAFT, MED (NON SELF PROP) 
SC YNG GATE CRAFT (NON SELF PROP) 
SC YO FUEL OIL BARGE (SELF-PROPELLED) 
SC YOG GASOLINE BARGE (SELF-PROPELLED) 
SC YOGN GASOLINE BARGE (NON SELF PROP) 
SC YON FUEL OIL BARGE (NON SELF PROP) 
SC YOS OIL STORAGE BARGE (NON SELF PROP) 
SC YP PATROL CRAFT (SELF-PROPELLED) 
SC YPD FLOATING PILE DRIVER (NON SELF PROP) 
SC YR FLOATING WORKSHIP (NON SELF PROP) 
SC YRB REPAIR AND BERTHING BARGE (NSP) 
SC YRBM REPAIR, BERTHING AND MESSING BARGE (NSP) 
SC YRDH FLOATING DRY DOCK WORKSHOP (HULL) (NSP) 
SC YRDM FLOATING DRY DOCK WORKSHOP (MC) (NSP) 
SC YRR RADIOLOGICAL REPAIR BARGE (NSP) 
SC YRST SALVAGE CRAFT TENDER (NON SELF-PROP) 
SC YSD SEAPLANE WRECKING DERRICK (SELF-PROP) 
SC YSR SLUDGE REMOVAL BARGE (NON SELF-PROP) 
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Ship 
Class 

Type        Type Code Description 
Code 

SC YTB         LARGE HARBOUR TUG 
sc YTL         SMALL HARBOUR TUG 
SC YTM        MEDIUM HARBOUR TUG 
SC YW          WATER BARGE (SELF-PROPELLED) 
sc YWN       WATER BARGE (NON SELF-PROP) 

SHIP CLASS 
Type 
Code 

Class Code Class Code Description 

AD SG SAMUEL GOMPERS CLASS 
AD YW YELLOWSTONE CLASS 
AE SR SURIBACHI CLASS 
AE NT NITRO CLASS 
AE KIL KTLAUEA CLASS 
AE AS AMMUNITION SHIP 
AFS MARS MARS CLASS 
AFS CSS COMBAT STORES SHIP 
AG ss SURVEYING SHIPS 
AG NRS NAVIGATION RESEARCH SHIP 
AGF RALAUS RALEIGH AND AUSTIN CLASS 
AGM MRIS MISSILE RANGE INSTRUMENTS SHIPS (TYPE) 
AGOR ORS OCEANOGRAPHIC RESEARCH SHIPS (TYPE) 
AGOS OSS OCEAN SURVEILLANCE SHIPS 
AGSS DOLPH DOLPHIN CLASS 
AH HS HOSPITAL SHIPS 
AK FBMSS FLEET BALLISTIC MISSILE SUPPORT SHIP 
AK MPS MARITIME PREPOSITIONING SHIPS (MPS) 
AK LASH LASH (TYPE) 
AK FRTR FREIGHTERS (TYPE) 
AKR FSS FAST SEALIFT SHIPS (TYPE) 
AO HJK HENRY J. KAISER CLASS 
AO TNKR TANKERS (TYPE) 
AO CIMAR CIMARRON CLASS 
AOE SACR SACRAMENTO CLASS 
AOE SUPPLY SUPPLY CLASS 
AOR WICH WICHITA CLASS 
AR CRS CABLE REPAIR SHIPS 
ARS BOL BOLSTER CLASS 
ARS SAFE SAFEGUARD CLASS 
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Type 
Code 

Class Code Class Code Description 

AS HUNLEY HUNLEY CLASS 
AS SIMON SIMON LAKE CLASS 
AS SPEAR SPEAR CLASS 
AS EMORY EMORY S LAND CLASS 
ASR CHANT CHANTICLEER CLASS 
ASR PIGEON PIGEON CLASS 
ATF POWH POWHATAN CLASS 
ATS EDEN EDENTON CLASS 
AVT ASS AVIATION SUPPORT SHIPS 
CG TICON TICONDEROGA CLASS 
CG LEAHY LEAHY CLASS 
CG BELK BELKNAP CLASS 
CGN BAIN BAINBRIDGE CLASS 
CGN TRUX TRUXTON CLASS 
CGN CALIF CALIFORNIA CLASS 
CGN VIRG VIRGINIA CLASS 
CV FORR FORRESTAL CLASS 
CV KITTY KITTY HAWK CLASS 
CV JFK JOHN F KENNEDY CLASS 
CVN ENTER ENTERPRISE CLASS 
CVN NIMITZ NIMITZ CLASS 
DD SPRU SPRUANCE CLASS 
DDG ARLE ARLEIGH BURKE CLASS 
DDG KJJDD KIDD CLASS 
FF KNOX KNOX CLASS 
FFG OLIVER OLIVER HAZARD PERRY CLASS 
LCC BLUE BLUE RIDGE CLASS 
LHA TARA TARAWA CLASS 
LHD WASP WASP CLASS 
LPD AUSTIN AUSTIN CLASS 
LPH IWO IWO JJMA CLASS 
LSD ANCHOR ANCHORAGE CLASS 
LSD WIC WHIDBEY ISLAND CLASS 
LST NEWPRT NEWPORT CLASS 
MCM AVENGR AVENGER CLASS 
MHC OSPR OSPREY CLASS 
MSO AGRESS AGRESSIVE CLASS 
PC CYCL CYCLONE CLASS 
SSBN JAMES JAMES MADISON CLASS 
SSBN BENJ BENJAMIN FRANKLIN CLASS 
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Type 
Code 

Class Code Class Code Description 

SSBN OHIO OHIO CLASS 
SSN BENF BENJAMIN FRANKLIN CLASS 
SSN SEAW SEAWOLF CLASS 
SSN STURG STURGEON CLASS 
SSN NARW NARWHAL CLASS 
SSN LOSANG LOS ANGELES CLASS 
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