RAPID PROTOTYPING–UNMANNED COMBAT AIR VEHICLE (UCAV)/SENSORCRAFT

Charles Tyler, Richard J. Schwartz, Gary Fleming, and Sergey Fonov
Computational Sciences Branch
Aeronautical Sciences Division

JANUARY 2008
Final Report

Approved for public release; distribution unlimited.
See additional restrictions described on inside pages

STINFO COPY

AIR FORCE RESEARCH LABORATORY
AIR VEHICLES DIRECTORATE
WRIGHT-PATTERSON AIR FORCE BASE, OH 45433-7542
AIR FORCE MATERIEL COMMAND
UNITED STATES AIR FORCE
Using Government drawings, specifications, or other data included in this document for any purpose other than Government procurement does not in any way obligate the U.S. Government. The fact that the Government formulated or supplied the drawings, specifications, or other data does not license the holder or any other person or corporation; or convey any rights or permission to manufacture, use, or sell any patented invention that may relate to them.

This report was cleared for public release by the Air Force Research Laboratory, Wright-Patterson Air Force Base (AFRL/WPAFB) Public Affairs Office and is available to the general public, including foreign nationals. Copies may be obtained from the Defense Technical Information Center (DTIC) (http://www.dtic.mil).

AFRL-RB-WP-TR-2008-3034 HAS BEEN REVIEWED AND IS APPROVED FOR PUBLICATION IN ACCORDANCE WITH ASSIGNED DISTRIBUTION STATEMENT.

*//Signature//
CHARLES TYLER Team Lead
Computational Sciences Branch
Aeronautical Sciences Division

//Signature//
REID B. MELVILLE, Chief
Computational Sciences Branch
Aeronautical Sciences Division

*//Signature//
MATTHEW BURKINSHAW, Technical Advisor
Computational Sciences Branch
Aeronautical Sciences Division

This report is published in the interest of scientific and technical information exchange, and its publication does not constitute the Government’s approval or disapproval of its ideas or findings.

*Disseminated copies will show “//Signature//” stamped or typed above the signature blocks.
RAPID PROTOTYPING–UNMANNED COMBAT AIR VEHICLE (UCAV)/SENSORCRAFT

Charles Tyler (AFRL/RBAC)
Richard J. Schwartz and Gary Fleming (NASA/Langley)
Sergey Fonov (Innovative Scientific Solutions, Inc.)

Computational Sciences Branch (AFRL/RBAC) Aeronautical Sciences Division
Air Force Research Laboratory Air Vehicles Directorate
Wright-Patterson Air Force Base, OH 45433-7542
Air Force Materiel Command
United States Air Force

NASA/Langley
Advanced Sensing & Optical Measurement Branch
Hampton, VA

Innovative Scientific Solutions, Inc.
Dayton, OH

Air Force Research Laboratory Air Vehicles Directorate
Wright-Patterson Air Force Base, OH 45433-7542
Air Force Materiel Command
United States Air Force

To characterize and improve upon aircraft designs in an expedient and efficient manner, it is imperative to generate approaches for rapidly assessing new aircraft designs. Recent technological advancements have enabled faster and more accurate assessment in three specific areas: computational fluid dynamics (CFD) modeling, rapid prototyping (RP), and experimental global measurements. The Air Force Research Laboratory Air Vehicles Directorate (AFRL/RB) initiated a joint computational/experimental ground testing program to investigate and analyze the flow field of the unmanned combat air vehicle (UCAV) X45-A as well as a strike tanker configuration. The test program used various rapid prototyping manufacturing technologies to fabricate models for ground testing; implemented innovative, nonintrusive measurement techniques; and compared CFD results with experimental data acquired from ground tests.
# TABLE OF CONTENTS

List of Figures ............................................................................................................................... iv

Foreword ........................................................................................................................................ v

Preface/Acknowledgements ........................................................................................................... vi

1. Introduction .................................................................................................................................. 1

2. Rapid Prototyping ......................................................................................................................... 2

3. Unmanned Combat Air Vehicle Effort ....................................................................................... 7

   3.1 Experimental Ground Test Facility ........................................................................................ 7

   3.2 Global Measurement Techniques .......................................................................................... 8

      3.2.1 Pressure Sensitive Paint (PSP) ...................................................................................... 8

         3.2.1.1 Intensity-based method .......................................................................................... 8

         3.2.1.2 Lifetime-based method .......................................................................................... 8

      3.2.2 Projection Moire Interferometry (PMI) .......................................................................... 10

      3.2.3 Planar Doppler Velocimetry (PDV) .............................................................................. 10

      3.2.4 Skin Friction Shear Stress Sensors (SFS3) ................................................................... 11

   3.3 Computational Fluid Dynamics (CFD) ............................................................................... 12

   3.4 Joining of Experiments and CFD ......................................................................................... 14

4. STRIKE TANKER .......................................................................................................................... 16

   4.1 Experimental Ground Test Facility ....................................................................................... 16

   4.2 Diagnostic Measurement Techniques ................................................................................... 17

      4.2.1 Pressure Sensitive Paint (PSP) – intensity based ......................................................... 17

      4.2.2 Temperature Sensitive Paint (TSP) .............................................................................. 18

   4.3 Computational Fluid Dynamics (CFD) ............................................................................... 18

   4.4 Comparison of Experiments and CFD ............................................................................... 18

Bibliography (pertinent papers and reports) ................................................................................. 20

Appendix A - Virtual Diagnostics Interface (ViDI) ........................................................................ 21

Appendix B – OMS ......................................................................................................................... 61
# LIST of FIGURES

<table>
<thead>
<tr>
<th>Figure</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Exploded View of UCAV X45-A Built with SLA Method</td>
</tr>
<tr>
<td>2</td>
<td>Finite Element Analysis for UCAV X45-A Wing Deflection</td>
</tr>
<tr>
<td>3</td>
<td>Finished SLA-built UCAV X45-A Mounted in SARL</td>
</tr>
<tr>
<td>4</td>
<td>Finite Element Analysis of Strike Tanker Wing Deflection</td>
</tr>
<tr>
<td>5</td>
<td>Exploded View of Strike Tanker Built by SLS Method</td>
</tr>
<tr>
<td>6</td>
<td>Finished SLS-built Strike Tanker Mounted in AFIT Wind Tunnel</td>
</tr>
<tr>
<td>7</td>
<td>Schematic Drawings (Top, Right, and Front) of SARL</td>
</tr>
<tr>
<td>8</td>
<td>Cartoon Depictions of the Concepts of PSP</td>
</tr>
<tr>
<td>9</td>
<td>Side-by-side Comparison of Intensity-based and Lifetime-based PSP</td>
</tr>
<tr>
<td>10</td>
<td>Depiction of the PMI Concept</td>
</tr>
<tr>
<td>11</td>
<td>Side-by-side Comparison of Finite Element Analysis and PMI</td>
</tr>
<tr>
<td>12</td>
<td>PDV Measurement Technology Concept</td>
</tr>
<tr>
<td>13</td>
<td>Magneto-resistive Transducer and its Placement in the UCAV X45-A</td>
</tr>
<tr>
<td>14</td>
<td>Visualization of Flowfield about UCAV X45-A (Euler Simulation)</td>
</tr>
<tr>
<td>15</td>
<td>CFD Flowfield Visualizations for UCAV X45-A, Three Elevator Settings</td>
</tr>
<tr>
<td>16</td>
<td>Side-by-side Comparison of CFD and PSP</td>
</tr>
<tr>
<td>17</td>
<td>Using CFD to Validate PDV Camera Position for Testing</td>
</tr>
<tr>
<td>18</td>
<td>Visualization of Coefficient of Skin Friction as Predicted by CFD</td>
</tr>
<tr>
<td>19</td>
<td>AFIT’s Low Speed Wind Tunnel</td>
</tr>
<tr>
<td>20</td>
<td>Strike Tanker Mounted in the AFIT Low Speed Wind Tunnel</td>
</tr>
<tr>
<td>21</td>
<td>Comparison of CFD and PSP Results for Varied Angles of Attack</td>
</tr>
</tbody>
</table>
FOREWORD

This report documents the effort to couple computational fluid dynamics (CFD) and experimental ground testing more closely. The effort is comprised of rapid prototyping manufacturing techniques, CFD, experimental ground testing, a multitude of diagnostic measurement techniques, and computer software designed as interface tools.

Experiments were conducted in both the Air Force Research Laboratory (AFRL) Subsonic Aerodynamic Research Laboratory (SARL) and the Air Force Institute of Technology’s (AFIT) 3 by 3 wind tunnel; both tunnels are located at Wright-Patterson Air Force Base, Ohio.

This report contains descriptions of the rapid prototyping techniques, experimental operations, and computational analyses. The purpose of the report is to document pertinent information about this effort. The information provides planners with guidelines for similar efforts that may be required in the future. For more details, the reader is directed to review the papers and journals listed in the bibliography section.

After the performance of the two experimental ground tests, methods to properly integrate experimental testing methodologies and computational simulations seamlessly were developed in the forms of the Virtual Diagnostics Interface (ViDI) and OMS software. These systems are the culmination of the unified approach to testing and data visualization/analysis.
PREFACE/ACKNOWLEDGEMENTS

This program effort is comprised of rapid prototyping manufacturing techniques, CFD, experimental ground testing, a multitude of diagnostic measurement techniques, and computer software designed as interface tools. The efforts associated with this program were performed over the course of several years with a multitude of personnel from various government agencies as well as academia and the commercial sector. The author would like to acknowledge the work in the field of Rapid Prototyping performed by the Johns Hopkins University Applied Physics Laboratory (JHU/APL), the University of Dayton Research Institute (UDRI), and the Air Force Research Laboratory Material and Manufacturing Directorate (AFRL/RX). The author also acknowledges the worked performed by NASA/Langley and Innovative Scientific Solutions, Inc. (ISSI) for their work in developing the plethora of diagnostic measurement technologies. Experimental ground testing was instrumental in the scheme of this effort as the testing was performed by the Air Force Institute of Technology (AFIT) and the Air Force Research Laboratory/Air Vehicles Directorate’s/Aerospace Vehicle Integration and Demo Branch (AFRL/RBAI). Finally, the author acknowledges with appreciation the computational simulations provided by the Air Force Research Laboratory/Air Vehicles Directorate/Computational Sciences Branch (AFRL/RBAC).
1. INTRODUCTION

To characterize and improve upon aircraft designs in an expedient and efficient manner, it is imperative to generate approaches for rapidly assessing new aircraft designs. Recent technological advancements have enabled faster and more accurate assessment in three specific areas: CFD modeling, Rapid Prototyping (RP), and experimental global measurements. The Air Force Research Laboratory Air Vehicles Directorate (AFRL/RB) initiated a joint computational/experimental ground testing program to investigate and analyze the flow field of the Unmanned Combat Air Vehicle (UCAV) X45-A as well as a Strike Tanker configuration. The test program used various rapid prototyping manufacturing technologies to fabricate models for ground testing; implemented innovative, non-intrusive measurement techniques; and compared CFD results with experimental data acquired from ground tests.
2. Rapid Prototyping

Rapid Prototyping (RP) is a robust, accurate, and affordable method to support aerospace research and development. RP serves as the link between CFD simulations and experimental ground testing correlations. Current manufacturing techniques used for manufacturing metal wind tunnel models are slow and costly. Reliance on these traditional methods creates a delay in validating the analytical model's predicted results with results from testing the physical model. RP may prove to be the fastest means to create a bridge between these CFD and experimental ground testing databases.

In the past, it took months to manufacture models for ground testing. With the seamless merging of computational models and recent innovations in RP technologies, inexpensive models can be fabricated literally overnight and tests performed immediately thereafter. Rapid fabrication results in a faster and better response to the designer's needs by permitting concurrent study of new concepts in the wind tunnel and via computer simulation. Testing of RP models early in the design cycle serves as a vital verification of system performance. Should the testing indicate a need for design changes, the changes can be made early in the design cycle where the cost and schedule impacts are less severe.

While current RP manufacturing processes include stereo lithography, selective laser sintering, laser engineered net-shaping, and fused deposition modeling, among many others, two techniques were implemented under the direction of the Air Force Research Laboratory Air Vehicles Directorate: stereo lithography (SLA) and selective laser sintering (SLS).

SLA is a layered manufacturing method that utilizes a photo-curable liquid resin in combination with an ultraviolet laser. A vat of the resin sits underneath the laser, and the laser "draws" on the top layer of liquid. When the ultraviolet laser beam hits the liquid it hardens a small amount of the resin under the beam point. By drawing and then filling the outline of a layer, a solid layer of material is created. This layer is then lowered a small amount into the vat, a new layer of liquid is placed on top, and the process repeats itself. By creating one flat layer at a time, a very precise geometry can be created, resulting in a complete part. Due to its accuracy and surface finish, it has become the most popular of the rapid prototyping methods.

SLS is a layered manufacturing method that creates solid, three-dimensional (3-D) objects by fusing powdered materials with a CO$_2$ laser. A thin layer of powder material is laid down and the laser draws on the layer, sintering together the particles hit by the laser. The layer is then lowered a small amount and a new layer of powder is place on top. This process is repeated one layer at a time until the part is complete. Subsequent to this process, the part is sintered, which fuses the powder particles together, and finally the part is infiltrated with another metal to fill the voids between the particles and form a fully dense high strength part. SLA is generally used to make inexpensive, plastic parts having relatively modest mechanical properties. In contrast, SLS is a more expensive process but can generate metallic parts with mechanical properties comparable to steel. Also, SLS parts can be machined, drilled, and polished just like traditional metals.
The basic philosophy is to use RP technologies to quickly and inexpensively build parts that define the outer mold line of the model. Models built entirely with these materials are generally not stiff enough or strong enough to withstand the loads in a wind tunnel test. For the UCAV X-45A model, a quarter-inch-thick steel plate was used to support the model. The plastic parts were then fabricated using a process called SLA. The entire computer model can be seen in Figure 1.

![Figure 1: Exploded View of UCAV X45-A Built with SLA Method](image)

The model is roughly 3 feet long with a span of 4 feet and has three pairs of deflecting control surfaces on the trailing edge. Models built entirely with these materials are generally not stiff enough or strong enough to withstand the loads in a wind tunnel test. The SLA parts were manufactured using Accugen 100 resin. This material has a tensile strength of 9.7 ksi and a modulus of elasticity of 440 ksi. The maximum deflection at the wing tip is about 0.35 inch, as can be seen in the deflection contours shown in Figure 2. The completed model, as mounted in the Subsonic Aerodynamic Research Laboratory (SARL) is shown in Figure 3. Various testing has been performed on this model at Mach numbers of 0.2 and 0.4 through the angle of attack range of -4 to 24 degrees.
With some understanding of rapid prototyping manufacturing technologies the further investigations were performed to demonstrate the advantages of rapid prototyping in the early development of AFRL technology demonstrators.

An airframer provided the University of Dayton Research Institute with detailed electronic model information to fully define the external Strike Tanker geometry. Efforts began for the design of the model to address the factors of mounting, instrumentation, and rapid prototype fabrication material and technique.
Having addressed the mounting and instrumentation issues, the final aspect of the wind tunnel model design effort was the selection of a particular rapid prototyping technique. Given the extremely thin wing cross sections in the current design there was concern that the wings might fail or deflect excessively during testing, so an analysis was performed to estimate the wind deflection at Mach 0.2 with a 20 degree angle of attack for both SLA and SLS model configurations. Deflection results from the SLS model are indicated in Figure 4. Maximum wing tip deflections for the SLA and SLS model configurations were 0.25 and 0.004 inch, respectively. With this information, a decision was made to use SLS for the application to demonstrate the technology and generate experience for future applications.

![Figure 4: Finite Element Analysis for Strike Tanker Wing Deflection](image)

Current generation SLS equipment limits the maximum part size to approximately a 10 by 10 by 10 inch volume, so the wind tunnel model had to be fabricated in several pieces and then assembled. Ultimately, the model was broken into six pieces: forward and aft fuselage, left and right wings, and left and right tail fins as depicted in Figure 5.

![Figure 5: Exploded View of Strike Tanker Built by SLS Method](image)
As depicted in Figure 6, the assembled wind tunnel model was delivered and successfully mounted in the AFIT low speed wind tunnel where testing of the aircraft configuration has occurred.

![Figure 6: Finished SLS-built Strike Tanker Mounted in AFIT Wind Tunnel](image)

This project has demonstrated that non-metallic prototypes can be used successfully as wind tunnel models with some careful design. Each wind tunnel environment imposes a set of performance requirements that must be defined before choosing the RP process. Selection of the appropriate material for the design constraints is crucial and the aircraft CAD model may have to be adjusted to accommodate the RP process.
3. UCAV X45-A

The John Hopkins University Applied Physics Laboratory (JHU/APL), under contract to AFRL designed, analyzed, and fabricated a low cost wind tunnel model of the UCAV X45-A. Multiple configurations of the model were tested with varying inboard, mid-board, and outboard elevator angles (-20, 0, and +20 degrees) at Mach numbers of 0.2 and 0.4. Although angle of attack sweeps from -4 to 24 degrees were performed, the majority of the data acquisition occurred at the angles of 12 and 20 degrees as a result of aerodynamic interest.

3.1 Experimental Ground Test Facility

The UCAV X45-A model was installed in the SARL. The SARL, as schematically shown in Figure 7, was built to provide research for complex flow configuration vehicles in the subsonic regime to researchers within the Air Force and DoD organizations. The SARL is an open-circuit, atmospheric subsonic wind tunnel with a test section dimension of 10 by 7 and 15 feet. The facility is capable of operating at the Mach number range of 0.15 to 0.6.

Figure 7: Schematic Drawings (Top, Right, and Front) of SARL
3.2 Global Measurement Techniques

Three major global diagnostic techniques: Pressure Sensitive Paint (PSP), Projection Moire Interferometry (PMI), and Planar Doppler Velocimetry (PDV), were implemented during a seven-week test. In addition, a software system called Virtual Diagnostics Interface (ViDI), consisting of an interactive, 3D environment of the SARL facility, has been developed to enable both the pre-test optimization and planning of the instrumentation deployment, and the comparative evaluation of global surface pressure distributions (PSP) and model deformation (PMI). The last portion of the test included state-of-the-art skin friction measurement technique (SFS).

3.2.1 Pressure Sensitive Paint (PSP)

PSP is an optical diagnostic capable of recovering global surface pressure distributions on test models. PSP is a surface coating that utilizes luminescence to measure static pressure on the surface. The technique exploits oxygen-sensitive luminescent molecules that are dispersed in polymer binders or paints. In wind tunnel applications, the PSP is applied to the model by conventional paint spraying techniques. The cured paint is illuminated with a short wavelength (< 530 nm) source, and the surface image is observed through a long-pass (> 550 nm) optical filter. Light sources such as blue LED arrays are mounted external to the test section to illuminate the painted model and effect luminescence emission from the entrapped oxygen-sensitive molecules. PSP emission occurs in the orange region of the visible spectrum (~650 nm), the intensity of which is inversely proportional to pressure such that brighter regions in the paint emission indicate lower pressure relative to the darker areas. Typically, the image is acquired with a digital camera to enhance the measurement sensitivity and accuracy and is processed with false color for clarity. Scientific-grade CCD cameras with spectral band-pass filters to discriminate between the excitation (blue) and emission (orange) signals, capture the intensity image of the PSP-coated model surface, providing a means to recover global surface pressure distributions on test articles of interest. A very high resolution, two-dimensional map of the air pressure can be achieved with this technology. The application of the Pressure Sensitive Paint technology is divided into two separate methods; Intensity-based and Lifetime-based, each depicted in Figure 8, respectively. Figure 9 shows a side-by-side comparison of the two PSP concepts as performed on the same UCAV X45-A configuration.

3.2.1.1 Intensity-based method

PSP images acquired either prior or immediately following tunnel operation (wind off) are ratioed with images acquired during tunnel operation (wind on). This “intensity method” requires the acquisition of associated wind off images at each model position, attitude and configuration to allow ratioing with the corresponding wind-on image.

3.2.1.2 Lifetime-based method

In the time-resolved, lifetime-based method, excitation of the PSP is accomplished using the same light sources as the intensity-based method. Following excitation of the PSP, the excited state luminescence decay is collected using a fast-framing camera. Typically, the decay is
approximated using two images at different decay times following the pulsed excitation and integrating photons for fixed periods of time that have been predetermined to maximize pressure sensitivity. The first image usually consists of a short gate width and is collected either during or shortly after it ends. This can be thought of as the reference image because the excited-state decay has the least pressure sensitivity. The second image is taken at a later time after the excitation pulse and usually has a longer gate width, ensuring maximum pressure and temperature sensitivity.

Figure 8: Cartoon Depictions of the Concepts of PSP

Figure 9: Side-by-side Comparison of Intensity-based and Lifetime-based PSP
3.2.2 Projection Moire Interferometry (PMI)

PMI is a video-based, noncontacting measurement technique capable of obtaining spatially continuous measurements of out-of-plane structural deformations, as depicted in Figure 10. The technique is well suited to measuring the deformation of aeroelastic vehicle components or aerodynamic control surfaces. PMI provides a full-field measurement of the actual wind-on model geometry, facilitating the refinement of baseline CFD grids to match the wind-on model shape. Figure 11 shows a side-by-side comparison of the earlier performed Finite Element analysis and the Projection PMI visualization for the UCAV X45-A.

![PMI data image showing projected grid lines](image1)

![Moiré fringes generated by interfering raw PMI data with a computationally generated reference grid](image2)

![PMI-measured airfoil shape data obtained by processing moiré fringe images](image3)

Figure 10: Depiction of the PMI concept

![Finite Element Analysis](image4)

![Projection Moire Interferometry](image5)

Figure 11: Side-by-side Comparison of Finite Element Analysis and PMI

3.2.3 Planar Doppler Velocimetry (PDV)

PDV is a velocity measurement technique capable of recovering planar three-component velocity data, as observed in Figure 12. The method relies on a direct measurement of the frequency-shifted light scattered by moving particles suspended in the flow under investigation (i.e.,
Doppler effect). Since the frequency shift is many orders of magnitude smaller than the frequency of the illuminating light itself, a molecular filter serves as a frequency-to-intensity converter. Negative velocity causes negative Doppler shift and increased transmission through the molecular filter, whereas positive velocity causes positive Doppler shift and decreased transmission through the molecular filter.

![Graph showing frequency shift from etalon flash point to transmission](image)

**Figure 12: PDV measurement technology concept**

### 3.2.4 Skin-Friction Shear Stress Sensor (SFS³)

Skin friction balances (direct sensors) are based on a floating element. Direct sensors measure the integrated force produced by the wall shear-stress on a flush-mounted, moveable, floating element. The size of the floating element dictates the sensitivity required of the measuring system, which may be passive (displacement) or active (force-feedback). The principle of the measurement is based on the transformation of tangential tension into the deformation of a thin film. A magneto-resistive transducer, as seen in Figure 13, for point measurements, was tested in both the Innovative Scientific Solutions, Inc.’s low speed wind tunnel at 10 to 40 meters per second flow velocity, and the Air Force Research Laboratory’s Subsonic Aerodynamic Research Laboratory at 30 to 140 meters per second flow velocity.
3.3 Computational Fluid Dynamics (CFD)

Initially, a grid and subsequent solutions were generated to provide needed information for the fabrication and stress analysis of the UCAV X45-A model. Three-dimensional Euler solutions were obtained using AVUS, an Euler/Navier-Stokes code developed in the Computational Sciences Branch Air Vehicles Directorate. AVUS is an unstructured, cell-centered, finite-volume, Godunov-type solver that uses least-squares gradient reconstruction and limiting for second-order spatial accuracy and second-order point-implicit time integration. It handles two and three dimensions, arbitrary cell types, and has been efficiently parallelized using Message Passing Interface (MPI).

In an effort to compare similar scenarios and resulting conditions the initial grid was modified to encompass not only the aircraft configuration but also the wind tunnel walls and sting/mount device at the various pitching angles chosen for the experimental test. The intent of the revised grid is to better emulate the wind tunnel experiment. The domain boundaries relating to the wind tunnel walls were modeled as no-slip, inviscid surfaces while the inflow/outflow boundaries were modeled using the Riemann invariant freestream condition.

Euler simulations for quasi-steady-state conditions were acquired for Mach 0.2 and 20 degrees angle of attack to compare with the PDV measurements, Figure 14. However, realizing that viscous effects would be an issue, especially in the region of the nose-generated vortex and the vortex at the wing/body juncture, grids were reconstructed to develop a viscous grid layer. The revised grid consisted of 14,546,389 cells and was used by the AVUS solver under full Navier-Stokes viscous capability. Figure 15 shows a few example visualizations of the simulations for various elevator angle settings for Mach 0.2 and 20 degrees angle of attack conditions.

Each computational case was performed using the two-equation Wilcox (1998) k-w turbulence model. Computational damping factors of advection and diffusion were 0.15 and 0.1, respectively. AVUS was operated in double precision with spatial discretization set for second-order accuracy and temporal discretization set for first-order accuracy.
Figure 14: Visualization of Flowfield about UCAV X45-A (Euler Simulation)

Figure 15: CFD Flowfield Visualizations for UCAV X45-A, Three Elevator Settings
3.4 Joining of Experiments and CFD

The seven week test of the rapid prototyped UCAV X-45A wind tunnel model within the Subsonic Aerodynamic Research Laboratory allowed the Air Vehicles Directorate (AFRL/RB) to establish its process for the integration of CFD and experimental ground testing. AFRL/RB demonstrated the ability to assess the aerodynamics of an advanced configuration through the use of technology assessment tools such as CFD, experimental ground testing, and global diagnostic measurement techniques. Future efforts will focus on the automation and refinement of the global diagnostic measurement techniques as well as the development of software for the ease of geometry and grid manipulation.

CFD results provide a database of global surface and off-body measurements. It is imperative that the data supplied by experimental ground testing also provide such global measurements. It is one thing to perform experimental ground testing and compare it to computational simulations; it is another thing to integrate the two elements. Within one-half hour after the acquisition of the experimental data, the data was processed and recorded side-by-side with the computational results. The goal of the integration was for each separate program to provide their strengths to better each other. The CFD analyses could be used to develop the test matrix and direct the test whereas the experimental ground test may be used to validate the CFD results. Eventually, once confidence in the CFD code is established, the CFD could be used to extend the knowledge database for a given aircraft configuration beyond the ground test envelope and into the flight regime. Working in tandem, in an integrated fashion, these two technology assessment tools can be quite powerful.

The following images, shown in Figure 16, are comparisons between the computational simulations and the Pressure Sensitive Paint measurements. Even though only a Euler solver for CFD was used, the comparison is within 10 percent.

Figure 16: Side-by-side Comparison of CFD and PSP
During testing the positions of the cameras and the verification of the flowfield physics as analyzed by PDV were validated through the use of CFD analysis. Figure 17 shows, in sequence, the raw image obtained during PDV testing; the CFD analysis for the same viewing angle of the flowfield; and the finished PDV image relating velocity vectors.

Figure 17: Using CFD to Validate PDV Camera Position for Testing

Initial testing within the SARL at the 30 to 140 meters per second conditions proved destructive to the polymer suspending the floating element used to make the skin friction measurements. After readjusting the polymer the experiments were performed again. Visualizations of skin friction as predicted by CFD are shown in Figure 18.

Figure 18: Visualization of the Coefficient of Skin Friction as Predicted by CFD
4. STRIKE TANKER

4.1 Experimental Ground Test Facility

The tunnel is of Eiffel-type, with a closed test section. The intake plenum has dimensions of 122 by 111 by 70 inch, and is fitted with a one-quarter-inch aluminum honeycomb flow-straightener and four 20 by 20 inch steel mesh anti-turbulence screens. The converging section has a contraction ratio of 9.5:1. The length from the end of the last anti-turbulence screen to the beginning of the test section is 95.5 inch. The test section is 31 by 44 by 72 inch and is composed of Plexiglas side walls and a Plexiglas upper wall. The model support sting enters the tunnel through a slot at the bottom of the test section. It can traverse angles of attack from -25 to +25 degree, and is supported by a turntable, enabling sideslip angles from -20 to +20 degree. The tunnel is shown in schematic in Figure 19.

![AFIT's Low Speed Wind Tunnel](image)

Figure 19: AFIT’s Low Speed Wind Tunnel

The force and moment data were collected with an Able Corporation Series D, MKII nominal 100 pound-force, six-component internal strain gauge balance, accurate to 0.25 percent of full capacity.

The model is shown mounted on the balance, supported by the sting in the wind tunnel in Figure 20. The model wing span, b, was 20 inches, which led to a ratio of the span to wind tunnel width of 0.49.
4.2 Diagnostic Measurement Techniques

4.2.1 Pressure Sensitive Paint (PSP) – intensity based

PSP was utilized in the current study. Pressure maps of the upper surface of the strike tanker were collected using PSP. The PSP setup in this experimental study utilized a Bi-Luminophore PSP from Innovative Scientific Solutions Inc. (ISSI). Notably, no base coat was applied to the model for the series of tests described here, though future testing may incorporate a base coat in order to reduce noise in the PSP signal. This paint was chosen due to its low temperature sensitivity and its ability to provide compensation for the model displacement relative to the excitation light source, as well as the instability of the light source itself. The Bi-Luminophore PSP is very similar to Uni-FIB, a single layer paint composed of PtTFPP that uses a FIB binder; however, it uses a reference probe in addition to the signal probe. The bi-luminophore paint exhibits a pressure sensitivity of 6% psig and a response time of 0.3 s and its emission spectrum ranges from 500 nm to 800 nm with a peak at 650 nm with 460 nm illumination at 20°C. The light sources used to illuminate the model for the strike tanker test condition were in the form of an array of four 2-inch blue LED light sources emitting at a wavelength of 405 nm. A matrix of more than 30 marker points was utilized to account for the spatial deformation of the model during the data processing.

The intensity images of the PSP during testing were captured using one of two lenses mounted to a 14-bit Cooke PCO Series 1600 CCD camera linked up with ISSI’s image acquisition software, OMS Acquire. The Bi-Luminophore paint requires that two images be taken at each test condition. The use of a filter wheel is therefore necessary to capture two separate images under the same illumination conditions separated in time. The filter wheel used contained a 645-nm long pass filter for the signal probe and a 550 ± 40-nm band-pass filter for the reference probe. In addition to all of the PSP equipment used for the last set of experimental tests, all of the previously discussed wind tunnel equipment including the force and moment balance and pressure tap system was used. The pressure at each tap was collected using Endevco 5 psig pressure transducers.

For each measurement, the analysis began with the reference image that was acquired at ambient pressures, also known as a wind-off image. In addition, a dark, or background, image was
acquired with the lighting system turned off to account for any variations in background room light. The two categories of “wind on” images (one for each filter) collected during for test were processed with reference to the dark image and the wind-off image using ISSI’s OMS Lite Version 1.0 software in order to obtain surface pressure plots. The images were aligned using the marker points within the images, and the resulting pressure maps were filtered and smoothed using a Gaussian filter with the maximum half width of the filter set to 10 pixels in each of the two axes.

4.2.2 Temperature Sensitive Paint (TSP)

Evaluation of several binary paint systems developed specifically for two-gate lifetime approaches (mentioned previously) indicate that Py2/UniFIB and RuBpy/UniFIB are good candidates for temperature compensated pressure measurements. Both binary paints reduce the temperature sensitivity of Innovative Scientific Solutions, Inc’s UniFIB pressure paint from 0.5% per degree Celcius to less than 0.1% per degree Celcius. Because the RuBpy/UniFIB binary is a one-layer system, it was chosen for low-speed PSP demonstration tests on the Strike Tanker model. Initial results from the Strike Tanker indicated that even though the RuBpy/UniFIB is a single-layer paint the reference and pressure probes are distributed non-uniformly necessitating the need for a wind-off measurement. Close agreement was obtained in the low-speed tests between PSP and pressure tap data.

4.3 CFD

CFD analyses were performed to determine the pressure distribution over the wing surface. The three-dimensional solutions were obtained with a full Navier-Stokes code implementing the Spalart-Allmaras turbulence model. The CFD code is an unstructured, cell-centered, finite volume, Godunov-type solver that has least-squares gradient reconstruction and limiting for second-order spatial accuracy and first-order, point implicit time interpretation. The grid consisted of 501,300 cells: 372,472 tetrahedral and 128,828 prisms to acquire viscous boundary layer effects.

4.4 Comparison of Experiments and CFD

CFD results are compared to the PSP measurements in Figure 21. The plots of surface pressure based on the CFD simulation employing the Spalart-Allmaras turbulence model showed a similar trend as the angle of attack was increased from 8 degrees to 14 degrees. The low pressure region near the leading edge of the wing diminished as a broader low pressure region near the wing body junction grows. It should be noted that the mesh spacing near the surface of the CFD model was on the order of 10 microns.
Figure 21: Comparison of CFD and PSP Results for Varied Angle of Attack
Bibliography (pertinent papers and reports)


APPENDIX A

Virtual Diagnostic Interface (ViDI)

The virtual diagnostics interface (ViDI) is a software ensemble that provides unified data handling and interactive 3D displays for pretest planning, real time data visualization and post test analysis to enable: 1) test planning and optimization remotely with no facility impact, 2) comparative evaluation of experimental and computational data sets of disparate file formats for code optimization and validation, and 3) the establishment of a central hub to source, store and retrieve experimental results and display them in near-real time to enable characterization of the impact of technologies on the vehicle aerodynamics, structures, controls, and integration components to achieve a true rapid technology assessment capability.

Appendix A is the tutorial generated to introduce a new user to tasks needing to be performed to prepare geometry for visualization, to plan out optical instrumentation, and to visualize data. The authors of this tutorial are Richard Schwartz and Gary Fleming of the Advanced Sensing and Optical Measurement Branch, NASA/Langley Research Center.
Virtual Diagnostics Interface
ViDI
Introductory Tutorial

Technical Lead
Richard J. Schwartz
Swales Aerospace, supporting the
Advanced Sensing and Optical
Measurement Branch
NASA Langley Research Center
Hampton, VA
r.j.Schwartz@larc.nasa.gov
757 – 864 – 4597

Contract Monitor
Gary A. Fleming
Assistant Branch Head
Advanced Sensing and Optical
Measurement Branch
NASA Langley Research Center
Hampton, VA
g.a.fleming@larc.nasa.gov
757 – 864 – 6664

Advanced Sensing and Optical Measurement Branch
Langley Research Center
Introduction

The Virtual Diagnostic Interface, or ViDI is designed around 3D Studio Max by
AutoDesk, a commercial three-dimensional computer modeling and animation program
for the PC platform. ViDI takes this application and expands its capabilities in many
ways with custom programming using MaxScript, a fully implemented programming
language embedded within the product, and Visual Basic Version 6, a Microsoft
programming language.

The three-dimensional graphics capabilities of ViDI can be roughly divided into three
areas:
   a. Pre-test planning
   b. Real-time data visualization
   c. Post test data visualization

To take advantage of any one of these areas, users must be familiar with 3D Studio Max.
This tutorial will concentrate on how 3D Studio Max is used in conjunction with the
visualization issues that ViDI attempts to address. This tutorial is just a starting point.
There is much detail that is left out, which at this point would tend to overwhelm the new
user. With time and experience, more and more of the capabilities of the software will
come into play in creating ever more complex and realistic simulations. The user will
find numerous opportunities to apply the capabilities of ViDI to a wide array of
problems.

About this Tutorial

This tutorial is meant to introduce a new user to tasks commonly needing to be done to
prepare geometry of visualization, to plan out optical instrumentation, and to visualize
data. There also is a section on LiveView3D, an application of ViDI for real-time data
visualization in the virtual environment. It is expected that the user will have had some
experience with 3D Studio Max prior to going through this material (such as the first
several tutorials included with 3D Studio Max) and has been exposed to some computer
programming.
Topic 1. Basic Modeling Skills

Goal:

Use basic modeling skills to create a fighter aircraft model from provided blueprints. While most ViDI tasks will involve importing models from other CAD sources, skills presented here can be useful in modeling sting adapters or specialized hardware that may not exist as a three-dimensional computer model.

Scenario:

A customer has requested a comprehensive series of tests on a fighter configuration in the SARL wind tunnel. The customer is using an older model for this test, and does not have a 3D CAD file available. Based on the original blueprints, a 3D model will have to be built. A special sting adapter is also required, with drawings provided by the customer.

You will be provided with a three-dimensional computer model of the SARL wind tunnel.

Creating a fighter model from blueprints

The customer has provided drawings of the model to be tested. The configuration is straightforward with the exception of the nose cone and cockpit. Flaps will have to be modeled as separate objects and linked to the model. Ultimately, a MaxScript program will be written to allow the user to adjust the flap settings using a custom user interface in 3D Studio Max. Note that a new tail will be used, which is not shown in the drawing below.

![Blueprint of the model](image-url)

Figure 0.1. Blueprint of the model
The fighter will be broken up into the following parts, as shown in the image below.

![Figure 0.2. Model Parts Breakup](image)

The fuselage, nose and canopy will be created first. A wing and a flap will then be modeled. The other wing and flap will be copied and mirrored. The same procedure will apply to the tail. By going through this modeling process, you will become familiar with the majority of modeling tools used with ViDI applications of 3D Studio Max.

**Step 1: Fuselage**

The fuselage consists of a straight body with a constant cross section. The best way to create this shape is to draw a 2D spline shape for the cross section, and then form it into a 3D shape with the extrude modifier.

1a. Use the Station 14 cross-section as your guide. Draw a 2D spline rectangle of dimensions 2.4 x 2.8 inches with a corner radius of 0.20 inches. In the Front View, the rectangle should be taller than wide.
1b. Go to the Modify screen and select Edit Spline from the list of Modifiers. Now select Insert, and place a vertex on the top segment in the center. Move the vertex up approximately 0.2 inches. Repeat the procedure for the bottom segment. Click Insert again to turn off the mode.

1c. The final step in shaping the fuselage cross section is to adjust the curvature on the top and bottom segments we just scaled. Under the Edit Spline, select Vertex. Now all vertices appear as small crosses. Click on the top center vertex, the left-click to bring up the quad menu. Select Bezier and move the control handle to form a smooth, symmetric curve. Then do the same for the top end vertices, except set them to smooth. Repeat for the bottom segment. Rename the shape Fuselage.

1d. Make a Clone Copy of the shape to use for the nose cone, and move it to the side for the moment. Rename the shape Nose.

1e. Select the first cross-section shape, and go to Modify Extrude. Set the amount to 19.425 inches, and 1 segment, to create the fuselage, with Cap Start and Cap End turned on.
Step 2: Nose cone

The nose cone is formed by taking the cross section developed for the fuselage and lofting it into three dimensions. By doing a loft, it is easier to control the curved tapering of the nose using the graphic scale editor, as will be shown below.

2a. In the Top viewport, draw a line (Create\Shapes\Line) that is 14 inches long. Once created, select this line. The line will act as the path along which the nose cone will be lofted into three dimensions.

2b. Go the Create\Geometry\Compound Objects. With the line selected, click on Loft, and then Get Path, and then click on the line again. This sets the line as the path to form a shape along.

2c. Click the Get Shape button, and then click on the cross section of the nose cone. A solid block of constant cross section will be created along the Path line. For some reason, 3D Studio Max will create the object perpendicular to the line. With the new nose cone block selected, go to the Select and Rotate tool and left click on it. A Rotate Transform Type-In box will appear. Type in 90 under the Offset World X: entry. Now the nose will be aligned with the fuselage. Rename Loft01 to Nosecone.

2d. Select Nosecone. Go to Modify. Under the Deformations rollout, click on the Scale button. A graphical interface appears. Go to the left most node and move it down to zero (left side ruler). This will create a straight taper. Now use the Insert Corner Point tool to place a new node at the 40 mark (top ruler). Left click on this new node and change it to a Bezier-Smooth. Now adjust the Bezier control points to create a smooth curve. This will form a smooth, curving taper for the nose cone.
2e. Use the Align tool to get an exact alignment between the nose cone and the fuselage.

2f. Group the fuselage and nose cone together. Call the group Fuselage - no canopy.

Figure 1.2.2. Completed geometry from steps 1 and 2.

Step 3. Cockpit

The cockpit canopy is the most difficult shape we will tackle. Most of it will be done by eye, manipulating the geometry of a basic sphere into the elongated, swoopy shape depicted in the blueprints.
3a. In the left Viewport, create a sphere with a 4.25 inch radius.

3b. Delete the lower half of the sphere by going to Modify\Edit Mesh. Select Vertex. Using the Select Object tool, select the vertices on the lower half of the sphere. Once selected, press the Delete key on the keyboard. You should now have half a sphere.

3c. Using the Select and Uniform Scale tool, squash down the sphere into an ellipsoid shape by scaling along the vertical axis only. Rotate your view and scale down the canopy in the lateral direction. You should now have a symmetrical half-ellipsoid of the approximate dimensions of the canopy.

![Figure 3.1. Half sphere that has been scaled down in two dimensions.](image)

3d. The final shaping of the canopy will be done with the FFD 3x3 Modifier. With the canopy selected, choose the FFD 3x3 modifier. A lattice of 9 points will surround the canopy. Click on the plus sign under the FFD 3x3 modifier in the stack, and select Control Points. Now go to the canopy, and manipulate the control points to do the final shaping of the canopy. This is where your artistic eye will help. For our purposes, the exact shape is not critical, but it should look convincingly like the blueprint drawing when complete.

3e. Move the canopy onto the fuselage. You will have to rotate the canopy slightly. Group them together and call the group Fuselage.

![Figure 1.3.2. Completed canopy placed on the fuselage.](image)
Step 4. Wings and Flaps

The wing will be extruded from the planform. Since there is no airfoil information, a simple diamond pattern will be used for the wing. The flap will be created by a Boolean operation, in which a template is used to cut out the shape from the wing. We will do one wing, then copy and mirror it for the other side.

Step 4a. Using the blueprints, determine the 2D coordinates for the wing. (Or you can cheat and use the table below.)

Table 4.1. Wing planform 2D Coordinates – Note that the negative numbers are for aligning the wing to the fuselage in the top view.

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.000</td>
<td>0.000</td>
</tr>
<tr>
<td>0.000</td>
<td>-13.125</td>
</tr>
<tr>
<td>4.200</td>
<td>-13.825</td>
</tr>
<tr>
<td>7.875</td>
<td>-15.400</td>
</tr>
<tr>
<td>7.875</td>
<td>-13.300</td>
</tr>
</tbody>
</table>

Step 4b. Use the Top View. Using the Create\Shapes\Splines\Line tool, enter the lines that define the wing. Use the keyboard entry to enter the points. After the final point, click on Close to make a closed form (without this, you will not be able to extrude the shape).

Figure 1.4.1 Wing planform top view
Step 4c. Extrude the wing
Select the wing planform shape. Go to Modify \ Extrude, and set the Extrude to 0.25 inches, with 2 segments. The wing is now a solid 3D object.

Step 4d. Go to a right view, wireframe mode, and zoom in to the edge of the wing. Select the wing, and go Modify \ Edit Mesh. Select vertex mode, and using the Object select tool select and move the top and bottom vertices to create a quasi-diamond airfoil shape for the wing. Move the trailing edge vertices so they overlap each other and form a sharp trailing edge shape.

Figure 1.4.2. Wing extruded with vertices adjusted to form a diamond-like airfoil.

Step 4d. Using the blueprints (or cheating by using the table below), determine the dimensions of the flap. Create the flap as you created the wing, but extrude the flap into 1 segment that is 1 inch thick. This will be our template for the flap. Rename object Flap Template.

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.000</td>
<td>0.000</td>
</tr>
<tr>
<td>2.900</td>
<td>-0.500</td>
</tr>
<tr>
<td>2.9</td>
<td>1.000</td>
</tr>
<tr>
<td>0.0</td>
<td>1.633</td>
</tr>
</tbody>
</table>

Table 4.1 X-Y coordinates for the flap

Step 4e. Use the Tape Tool to help align the flap on the wing. Go to Create \ Helpers \ Tape, and then click on Specify Length. Type in 0.620. Now click by the wing root trailing edge, and create the tape. Position the flap as shown in Figure 4.3 below. Note – For the Boolean operation we will perform in a few steps, it is important that the trailing edge of the flap is slightly aft of the wing trailing edge. Move the flap template down slightly so it fully intersects the wing, as shown in Figure 4.4.
Figure 1.4.3. Flap template positioned with respect to the wing. Note the slight extension of the flap beyond the wing trailing edge. This will be important for the flowing Boolean operation.

Figure 1.4.4. Flap template and wing properly aligned with respect to each other.

Step 4f. Select the wing and the flap template and make a copy of them. Move the copy off to the side. This copy will be used to create the actual flap geometry. The original will be used to form the wing with the flap cutout.

Step 4g. Select the original wing. Go the Create\Geometry\Compound Objects\Boolean.
Select Pick Operand B and click on the flap template. The template should disappear, as will the area of the union of the wing and the flap template. If this does not occur, make sure the Subtraction (A-B) is selected.

Step 4h. Move to the copy of the wing and the flap template. Select the wing again, and click on Boolean, then Pick Operand B and the flap template. You will get the same result as in Step 4g. Now go to the Operation, and click on Intersection. This will leave the wing section where the template was, which is our properly contoured flap. Rename this object wing flap, and move it into the opening left in the original flap. Also change the color of the flap if it is the same as the wing color.

Figure 1.4.5. Completed wing geometry with flap.

Step 5. Preparing the flap for deployment.

In order to properly deploy the flap, the flap geometry must rotate about the flap leading edge along an axis aligned with that surface. This is done by adjusting the object’s pivot point.

Step 5a. Select the flap. Now go to the Hierarchy tab, and click on the Affect Pivot Only button. This will allow us to move the center of rotation of the flap. An axis system will appear in the default center of rotation location. Click to Center to Object just to get started.

Step 5b. Using the Select and Move tool, move the axis to the leading edge of the flap. Then select the Select and Rotate tool, and rotate the coordinate system so the X axis is parallel to the leading edge of the flap.

Step 5c. To check the rotation, exit the Hierarchy tab, and select the flap. Then go the coordinate system selector, and choose Pick. Click on the flap. Now click the Select and Rotate tool, select the flap, and rotate the flap. It will rotate along the proper axis, and look just like a flap on a wing!
Step 5d. Select both the wing and the fuselage, and then create a copy of them. Move the copy to the side, and use the Mirror tool to flip the wing along the X-axis. This will create the left wing and flap. Now move the wings and fuselage into proper position.

Step 6. Creating the Tail

The twin tail of the configuration consists of two smoothly curved fins with airfoil cross-sections. This exercise will use the lofting tool to combine two different cross sections along a curved path. To aid in creating the shape, the cross sections and the shape of the tail will be imported into 3D Studio max as a viewport background.
Step 6a. In the case of the tail, the cross sections and the shape have been scanned in from a hardcopy. The bitmap of the scan can be set as the background of the viewport, so the shape can be directly traced. Do this in the Left Viewport. Go to the Views Menu, and select Viewport Background. Click the Files... Button, and select the file `tail_sections.bmp` from your tutorial directory. In the Viewport background box, select match bitmap for your Aspect Ratio. The image will be quite large. We will work from this image, then scale down the final tail geometry. If there is any existing geometry blocking the view move or hide it.

![Diagram of root, tip, and profile.]  
Figure 1.6.1 Bitmap drawing of the root and tip cross-sections and the profile.

Step 6b. Use the Create\Shapes\Ellipse tool to create the cross sections for the root and the tip. Once the ellipses are drawn, go to the Modify\Edit Spline and in Vertex mode, adjust the vertices. You may have to convert the vertices to Bezier, and you may want to insert a vertex on the top and bottom segments to get an exact fit. Then create the shape for the profile by drawing two straight lines with a vertex near the center point that approximates the curved shape. Use the Modify\Edit Spline tools in vertex mode to get a good match.
Figure 1.6.2 Viewport with bitmap imported and splines traced over the bitmap. Scale will be corrected later.

Step 6c. Select the line that is the Path for the tail. Now select the Create\Compound Objects\Loft tool. Click on Get Path, and the selected line will become the path. Now click the Get Shape button, and click on the root airfoil section. This creates a three-dimensional shape. However, the object is not as desired (Figure 6.2). The shape is aligned along the wrong axis. Click on the Twist button on the Deformation rollout, and select both ends of the control line. Move them to 100, and watch the shape alignment change to the desired orientation. (Figure 6.3) When complete, rename this object Right Tail.

Figure 1.6.3 Lofted shape, with the root cross-section aligned in the wrong direction.
Figure 1.6.4. Using the Modify/Twist Deformation, twist the root shape to 100 (which equals 90 degrees) using the graphical user interface.

Step 6d. Now we want to add the tip cross-section. Select Right Tail, and then Modify. The loft options will come up on the command panel. Under path parameters, click on the Path Steps, and then use the spinner to go the highest number under the Path value. Once there, go to the Get Shape button, click it, and then select the tip cross-section.

Step 6e. Scale the tail in three dimensions so that the root is 3.6 inches long.

Step 6f. Make a copy of the tail, rename it Left Tail, and move and orientated the tails to the fuselage where they belong. Group the tails to the fuselage. Call the entire group Model.
Figure 1.6.5. Completed geometry.

Step 7. Applying a finish.

The model is made out of stainless steel, and we will presume that the tail section was formed from a resin composite. We will color the geometry appropriately, and add a joint USAF/NASA decal to the wing.

Step 7a. Open the Material Editor. The first box in the upper left hand side is selected. We will modify this material to be out steel. Under the Shader Basic Parameters Rollout, select the Metal Shader from the drop-down list. Click on the Diffuse color box, and adjust the color to a lighter gray. Then raise the Specular Level to about 55, and the Glossiness to about 60. Apply this material to the fuselage and wings on the model.

Step 7b. The tails will be made from a beige resin. Select a new box in the upper section of the material editor, and use the default Blinn shader. Click on the Diffuse color box, and select a beige color. Apply the color to the tails.

Step 7c. Make the flaps a bright orange. Choose another box with a default material in it, and adjust it to a bright orange. Apply the color to the flaps.

Step 7d. Select the wing from a top view. Now go to Modify>UVW Map. In the Stack, under UVW mapping, select Gizmo. Go to Bitmap Fit, and select the bitmap wing decal.bmp in the tutorial directory. Now use the Select and Uniform Scale tool to resize the gizmo. Move it to final position.
Step 7e. In the material editor, select the steel color. Drag this color to a box with a default color to make a copy. Rename it Wing logo. Open the maps rollout, and select the Diffuse Color selection. Under Map, click where it says “None”. Now choose Bitmap under the Material/Map Browser. Open the file \wing decal.bmp. You will see the bitmap wrapped around the sample sphere. Make sure that the Mirror and Tile options under the Coordinates Rollout are turned off. Turn On the Show Map in Viewport button. Then drag and drop the material to the right wing of the aircraft. You can now go back to the UVW mapping, and adjust the gizmo to fine tune the placement of the logo in the surface.

![Image of a winged aircraft with a logo]

Figure 1.7.1 The completed model.

The test configuration model is now complete.
Topic 2. Importing and preparing an IGES File

The first step in preparing a visualization is to create or import the test geometry in the virtual environment. This session will go over importing and manipulating an IGES format 3D CAD file into 3D Studio Max prior to merging the model with the wind tunnel geometry.

Note: It is generally best to import files into a “fresh” 3D Studio Max environment. To do this, either restart the program, or go to the File Menu and select Reset.

Goal: Import and prepare an imported IGES file for use in 3D Studio Max

Scenario: A customer has provided an IGES CAD model of ½ of a UCAV model that will be wind tunnel tested. The model has movable inboard control surfaces that will require modification. A MaxScript will be written to provide a user interface to move the flaps.

Step 1. Importing the model.

A CAD model of ½ of the UCAV has been provided in IGES format. This file, ucav_half_cfd.igs is located in the \WInd\Meshes directory. Use the File menu Import function to bring up the Open File Dialogue box titles Select File to Import. Under Files of type: Select IGES. Now open the file. When asked, select the Completely replace scene option. Opening the file will take a few moments. You can watch the progress on the bottom of the screen.

Step 2. Adjusting the viewports to show all surfaces

When the import is done, place the Perspective viewport into Smooth + Highlights mode. You will now see that several surfaces are invisible (Figure 2.1).

Figure 2.2.1 Imported IGES file
Step 2a. The first setting to adjust is in the Viewport Configure screen (left click on the viewport name and select Configure). Turn on Force-2-Sided, and make sure you select All Viewports in the Apply To box.

Step 2b. Now go to the Edit menu and Select All. Left click on the selected geometry, and choose Convert at the bottom of the pop-up menu. Select Convert to Editable Mesh. This has changes the object from a NURBS to a mesh model. However, we still have all of the holes.

Step 2c. With the model still selected, go to the Display tab. Under the Display Properties, make sure the Backface Cull option is turned off. Now the holes have become black faces.

Step 2d. With the model still selected, go to Modify, and select Normal from the list of choices. The Unify Normals should be turned on, and the Flip Normals should be turned off.

Step 2e. Go to the Material Editor, and create a light beige material under the Blinn shader. Make sure to select the 2-Sided option under the Shader Basic Parameters. Apply this material to the model.

Step 2f. Again with the model selected, go to Modify, and select Optimize. After a moment, the model will have been optimized, with a significant reduction in the number of surface faces without loss of quality (Figure 2.2).

![Figure 2.2.2 Model and viewports adjusted to depict all surfaces](image)

**Step 3. Detaching the flap**

For this example, we want to be able to deflect the innermost control surface at the trailing edge of the wing. Since the geometry is complex in this area, the easiest way to
do this is to make a copy of the UCAV geometry, and from the original remove the flap, and from the copy remove all other geometry except the flap.

Step 3a. To start, select Edit\Clone, and make a Copy of the UCAV half (make sure to make a copy, not an Instance or a Reference). Now go to the display tab, and hide the selected copy. We will return to it later.

Step 3b. Select the original UCAV geometry, and go to Modify\Edit Mesh. Select Vertex, and then zoom in to the section with the flap from the Top Viewport (Figure 3.1).

![Figure 2.3.1 Flap with vertices shown.](image1)

Step 3c. Proceed to select and delete the vertices from the flap, Figure 3.2. Work your way around, taking small sections. If you remove part of the fuselage, simply use the Undo button or Edit\Undo. Hint: Use the Fence Select region tool instead of the Rectangular Select Region tool.

![Figure 2.3.2 Flap with some vertices removed.](image2)
When complete, hide this geometry, unhide the copy, and repeat the process in reverse, eliminating the vertices from everything except the flap. Then go to Display\Unhide All.

Note: Since this is a rather boring and time consuming operation, this geometry has been prepared for you in the file \Mesh\UCAV with Flap – Not linked.max.

Step 4. Adjusting the Flap Pivot Point

The center of rotation of any 3D object is set at the Pivot Point. The Pivot Point is set at the center of mass of the object at the time of creation. However, after manipulation it may be relocated. This exercise will adjust the location and orientation of the pivot point so the flap will properly rotate about the flap hinge.

Step 4a. Select the flap, and note where the object axis is located. This is the pivot point.

![Flap Pivot Point](image)

With the Flap selected, go the Hierarchies\Pivot\Affect Pivot Only option. The Axis icon changes to double wide arrows, with a blue central box. Move this icon to approximately mid-span of the flap, with the center located at the position about which the flap would rotate. Now use the Select and Rotate Tool to rotate the X axis of the icon to be parallel with the leading edge of the flap. (Note: Get the height correct in the Right viewport).
Step 4b. Now, to properly rotate the flap, you have to tell Max to rotate the object about the flap pivot point. This is done by clicking on the Reference Coordinate System, and choosing Local. Use the Select and Rotate tool to click on the flap and rotate it about the proper axis.

Step 4c. Now go to the Hierarchies\Link Info tab, and click on the locks for the Y and Z rotation. This will prevent the flap from ever rotating about the wrong axis.

Step 5. Linking.

While the flap rotates about the proper axis, if the rest of the UCAV is moved or rotated, it will leave the flap behind. If the flap is Grouped to the rest of the geometry, it will loose its independent rotation capability. The answer is to Link the flap to the fuselage.
Step 5a. Choose the Select and Link tool. Click and hold down the mouse button on the flap. Note the icon change. Now drag the icon to the fuselage, and release the mouse. The flap has now become a child of the fuselage (the parent). Now, everything the fuselage is told to do (move, rotate, scale) the flap will do as well. However, if the flap is told to do something (notably rotate), that rotation will not affect the fuselage.

**Step 6. Completing the Model**

The half of the UCAV will be copied and mirrored to complete the model.

Step 6a. Go to Edit→Select All. Then go to Edit→Clone and make a copy of the model. Select the Mirror tool, and click on the Y-axis choice. The fuselage and flap will flip over to the proper orientation.

Step 6b. Now select the two fuselage halves (but not the flaps) and group them together with the name UCAV. Rename the flaps to Right_Flap and Left_Flap, and color them orange.

![Figure 2.5.1 The completed UCAV import.](image)
Topic 3. MaxScript – Programming 3D Studio Max

One of the reasons 3D Studio Max is such an attractive software package for ViDI is the MaxScript programming language. Using MaxScript, just about anything that the user can do with the mouse and keyboard can be automated or enhanced through a program written in MaxScript. It is also possible to do things that are just impossible through the standard user interface. Thus, ViDI relies on the power and flexibility MaxScript provides to merge together the realms of computer animation, mechanical simulation, and data visualization.

**Note:** MaxScript is a complex and full featured programming language. This exercise is meant as an introduction to its capabilities. To really learn MaxScript will require time spent with the programming language.

**Goal:** Produce a MaxScript program that will adjust the flap angle setting on our UCAV model using a simple graphical user interface.

**Scenario:** The customer provided UCAV model has been imported and prepared for use in the ViDI environment. The flaps have been modified to rotate around the proper hinge points, and they have been linked to the UCAV fuselage.

**Note:** The completed code can be found in the files \Scripts\Flapsdev1.ms and Flapsdev2.ms.

**Step 1. Functional code.**

Using MaxScript, there are several ways to implement and interact with the code. The easiest is to work directly from the program command line, and this is how we will start. Once we have some functional code we will wrap a user interface around it. We will ultimately produce a Utility program. This appears as part of the Command Panel when called up from the MaxScript utility. Other options include creating a separate window, or code that is invoked once a custom button is placed on the toolbar.

But first the functional code. We want to figure out how to make the flap rotate.

Step 1a. Select MaxScript\New Script from the menu. Now go to MaxScript\MaxScript Listener... This will open up the Listener, which will provide feedback as to the status of the MaxScript code.

Enter the following lines in the MaxScript window:

```
val = 25
$Right_Flap.rotation.x_rotation = val
```

Save the script, and then go to File\Execute in the MaxScript window. Watch the flap as you execute the code! Now set val = 0, and run it again.
Step 2. User interface

The code above is useful, but not very practical. To enhance the usability, we will create a simple user interface for it.

Step 2a. The program will be designed to run from the Utilities Tab\MaxScript button location. To start such a code, enter

```
utility AngleSet *Set Flap Angle*
{
    -- Start the code contained in the Utility Script

    -- Specify the user interface for the utility script
    spinner spn_Angle "Flap Angle" range:=[-90,90,0] type:=float
    slider sld_Angle "Flap Deflection" range:=[-90, 90, 0] type:=float ticks:18
    button btn_Reset "Reset Flaps to 0"

    -- Make sure to close out the Utility Script code
}
```

Step 2b. Run the code by using the File\Evaluate command in the MaxScript window. Look at the output in the Listener Window for any error messages. If you receive an error, check your syntax carefully.

The following user interface is created by the code shown above:

![Utility panel MaxScript user interface](image)

Figure 2.1 Utility panel MaxScript user interface

Step 3. Unifying the functional code with the user interface.

Each of the user interface items needs to have code to command actions when the user interacts with the item. For the spinner, it can be typing a number in or clicking the
up/down buttons. The slider will react then the pointer is moved left or right, and the button will respond to a mouse click. It is also necessary to update the state of each interface item with respect to actions conducted by other interface items. The code below shows how to do this.

```cpp
on spn_Angle changed angle do
   $right_flap.rotation.x_rotation = angle
   $left_flap.rotation.x_rotation = angle
   spn_Angle.value = angle
   Move the flaps
end

on sld_Angle changed angle do
   $right_flap.rotation.x_rotation = angle
   $left_flap.rotation.x_rotation = angle
   sld_Angle.value = angle
   Update the slider
end

on btn_Reset pressed do
   $right_flap.rotation.x_rotation = 0
   $left_flap.rotation.x_rotation = 0
   spn_Angle.value = 0
   sld_Angle.value = 0
   Move the flaps
   Update the spinner
   Update the slider
end
```

Enter each section one at a time and execute the code. Keep an eye on the Listener to make sure it compiled and ran without error messages.

**Step 4. Optimizing the code for readability and “update-ability”**

The code is fully functional, but it can be optimized to make it easier to read and to make modifications easier. Placing the section of code that moves the flaps into a Function would allow you to write it only once.

Since the code is “p-code”, or compiled on the fly as it is executed, it is important too make sure that the code is properly organized so that all elements are ready when required. Thus, the Function will be placed at the start of the Utility. Note: make sure it is “inside” the parenthesis for the utility.

For brevity, the entire updates script is shown below.

```
utility AngleSet "Set Flap Angle"

--This code will move flaps on an aircraft configuration. The flaps MUST BE named
--Left_Flap and Right_Flap. A user interface consisting of a spinner, slider and reset
--button is included.
--Written by Rich Schwartz, Swales Aerospace, supporting ASOMB, NASA LaRC.
--Last changed: 6-11-05
--Written in 3D Studio Max R7.0 SP1

( -- Start the code contained in the Utility Script
```
Declare function(s) at the start so they are seen within the scope of the utility

```latex
Function FlapRotate Angle =
{
    $right\_flap\_rotation\_x\_rotation = Angle$
    $left\_flap\_rotation\_x\_rotation = Angle$
}
```

Specify the user interface for the utility script:

- Spinner `spin_Angle` "Flap Angle" range: [-90, 90, 0] type: #float
- Slider `slider_Angle` "Flap Deflection" range: [-90, 90, 0] type: #float ticks: 18
- Button `btn_Reset` "Reset Flaps to 0"

Here the commands for each user interface action is specified:

```latex
on spin_Angle changed angle do
    ret = FlapRotate angle
    slider_Angle.value = angle

on slider_Angle changed angle do
    ret = FlapRotate angle
    spin_Angle.value = angle

on btn_Reset pressed do
    angle = 0
    ret = FlapRotate angle
    spin_Angle.value = angle
    slider_Angle.value = angle
```

Make sure to close out the Utility Script code.

You now have a program that can be reused easily for other projects. You can adapt it for ailerons by multiplying the rotation angle by -1 for one aileron, or introduce offsets and gains as desired. A very similar code is also used to control the angle of attack of the model and the sting. But first we have to put the model into the virtual wind tunnel...
**Topic 4. Camera Calibration**

One of the key features of the ViDI setup is the ability to very closely match the virtual representation of a camera view to a real camera view. However, in order to represent an individual camera/lens/zoom setting, a calibration must be performed.

**Step 1. Calibration Images**

The calibration is extremely simple. An image of an item that is graduated in length has to be acquired with the camera/lens/zoom setting desired. The distance between the camera and the center of the graduated item must also be known. With this information, the angle of the field of view can be determined.

![Calibration Images](image)

Figure 4.1.1 Calibration images. A is set at a 28mm zoom; b is set at a 70 mm zoom. The camera is 36 inches from the center of the yardstick.

\[
\Theta = \sin^{-1}\left(\frac{0.5r}{h}\right)
\]

The value of \(2\Theta\) will be required for 3D Studio Max

For the case of camera a, \(2\Theta = 60.0\) degrees, and for b the angle is 23.6 degrees.
Step 2. Setting Camera FOV in 3D Studio Max

Step 2a. In 3D Studio Max, go to the Modify section once you have a camera selected. Under the Parameters rollout, you will see the Lens and Field Of View (FOV). Set the Field Of View to the value determined by the image calibration above. Make sure the orientation button is set to the proper direction for the measurement taken. Note that for the actual 28 mm lens (60 degree angle) the corresponding Max lens would be 31.177 mm.

**Note:** Do not count on the Lens settings in 3D Studio max to be accurate enough to match your particular camera optics.

![Parameters dialog box](image)

Figure 2.1 Modify\Camera settings in the Command Panel

Step 2b. To match the camera resolution for the final rendered output, you can go to the Render Scene dialog box, and adjust the resolution in the Common Parameters to match the resolution of the actual camera.

![Render Scene\Common Parameters](image)

Figure 2.1 Render Scene\Common Parameters interface used to set the camera resolution.
Topic 5. Finalizing the virtual test environment.

The virtual environment used for pre-test planning is comprised of the test article, the wind tunnel, and the instrumentation. We will use the UCAV test model with the SARL wind tunnel, then we will simulate a DGV experiment with cameras and laser light sheet.

Goal: Create a complete virtual testing environment in order to plan out the setup of DGV instrumentation on the UCAV model.

Scenario: The updated customer UCAV model will be used with the AFRL provided SARL wind tunnel model. The user is interested in DGV investigations of the flow pattern around the inner control surfaces at a variety of angle of attacks and flap deflections. The flow will be analyzed directly ahead of the flap, at the flap mid-section, and at the aft-most trailing edge location. All laser light sheets will be placed perpendicular to the free-stream flow.

Test Matrix:

Repeated for each of three laser light sheet locations:

<table>
<thead>
<tr>
<th>Alpha</th>
<th>0 Flaps</th>
<th>-5 Flaps</th>
<th>-10 Flaps</th>
<th>-15 Flaps</th>
<th>-20 Flaps</th>
<th>-25 Flaps</th>
</tr>
</thead>
<tbody>
<tr>
<td>-4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Negative alpha is nose down. Negative flaps means flaps are deployed downward (standard usage).

Step 1. Merging the UCAV with the wind tunnel.

Step 1a. Have the file UCAV with flap-linked final.max open. Go to the File\Merge menu, and select the file ViDI Tutorial\Sarl Facility\Meshe\SARL baseline geometry.max.

Step 1b. In the Merge window appears, click on the All button to select all elements of the SARL baseline geometry.max file. Now click OK. Select the UCAV and move it to the end of the sting. Using the Select and Link tool, link the UCAV model to the sting boom.

Step 2. The Alpha MaxScript Program

A MaxScript utility program has been written to change the angle of attack of the model using a user interface similar to that created for the flaps.
Step 2a. To open the script, go the Utility Panel\MaxScript button, and click on it. Click on Open Script, and then open the file \Sarl facility\Scripts\SetAlpha2.ms.

Step 2b. In the MaxScript windows, go to File\Execute, then look at the list in the Utility Panel for the “Set Alpha” entry. You can use the slider, type in a number, or use the up and down arrows to adjust the angle of attack of the sting. Note that the pivot point of the sting has been located at the center of rotation of the model, as specified in the drawings of the facility.

Step 3. Laser Light Sheet

There are two ways to display a laser light sheet in 3D Studio Max. Method #1 is based on using a very thin box to represent the light sheet. This is the easiest and will work well for most planning, but it is unrealistic. Method #2 involves projecting an actual simulated light, and having the ray-trace rendered create the laser light sheet. With shadowing turned on, this produces a very realistic looking light sheet; a tutorial has been attached to your documentation that describes how to make a laser beam. Due to the time constraints of this class, we will not go into detail on this technique.

![Figure 5.3.1 Ray Traced laser light sheet (Method #1).](image)

Step 3a. Go to a Right View in the viewport, and switch to wireframe mode. Draw a box across the test section, and set the height to 0.1 inches.

Step 3b. Now go to Modify\Edit Mesh, and select vertex mode. Then scale down the vertices on one side of the box to form a triangle. Rename the box Laser Light Sheet, and change the wireframe color to green.
Step 3c. The next step is to make the laser light sheet glow a radiant green color. Go to the Material Editor and select an unused material entry. With the Blinn shader click on the Diffuse color box and choose the full green color (RGB 0, 255, 0). Note that the Ambient is locked to the Diffuse color, which is what we want. Drag the green color from the Diffuse to the Specular, and choose to Copy the color. Now go the Self Illumination edit box, and type in 100. Next, go to the Opacity box, and enter 50. Rename the material “Laser Light Sheet” and assign it to the laser light sheet box.

Figure 5.3.3 Box based Laser Light Sheet in Wind Tunnel. Note that there is no blockage of light using this method.
Step 4 – Camera creation and positioning

Use Create\Cameras\Target to create three targeted cameras. Taking into consideration the DGV requirements for camera placement, place the cameras in approximate positions. Then adjust the field of view to match the existing real lens. This is done in the Modify screen, where you can select the field of view and set the viewing angle of the camera. To get an exact match to the real camera, go to the Render Scene tool, and set the rendered to the resolution of the camera. Then render the scene to create an accurate representation of what the camera will see.

![Figure 5.4.1 Cameras in the virtual test environment](image)

Now the goal is to obtain the best position and determine the best lenses for all three cameras with the flaps and angle of attack at different settings. This exercise if left for the student to complete...
Topic 6. Data Visualization

One of the main aspects of VIDI is the ability to display three-dimensional time varying data in the virtual environment. The primary way to do this is by “texture mapping” (often referred to just as mapping), where a bitmap is projected onto geometry in the scene. This section will cover mapping data taken from an experiment in which a small scale Apollo capsule was placed in a hypersonic flow in order to visualize the path of the Reaction Control System (RCS) thruster plume under reentry conditions. The technique used was Planar Laser Induced Fluorescence, or PLIF. The purpose of these recent tests was to explore the potential of PLIF for use with the upcoming Crew Exploration Vehicle development testing.

Using PLIF, a laser light sheet in the ultraviolet range (~226 nm) is projected into the region of interest. This light will cause Nitrous Oxide to fluoresce, thus creating a visible plume of the gas in the flow. A detailed description of PLIF is included in the Appendix section of your manual.

In this experiment, the laser was projected along the centerline of the Apollo capsule in the stream-wise direction. This placed the light sheet along the center of a port representing the location of an RCS jet. A mixture of Nitrogen gas and Nitrous Oxide was exhausted from the port to act as seed material for the flow visualization. The grayscale images digitally acquired were processed and converted to false color, then delivered for visualization as a series of TIF format bitmaps.

Scenario: The experiment has been completed, and an IGES CAD model of the test configuration has been provided. The data has been provided as a series of 100 bitmap images in TIF format.

Goal: Create still and animated imagery depicting the data in relation to the Apollo capsule.

Step 1. Creating a plane to place the data on.

Step 1a. Open the file \Apollo Baseline\max. The file contains the converted IGES file of the capsule, which has been given a chromed metallic finish. We have to create a plane upon which the data will be placed for visualization.

Step 1b. Go to Create\Geometry\Plane. In the Front viewport, create a square plane. It needs to be square since the data image is square, with a 513x513 resolution. The exact size is not important at this stage; we will scale the data to the geometry in a later step. Make sure the Generate mapping Coordinates is on. Rename the plane Dataplane. Go to the Top view, and align the Dataplane with the centerline of the capsule.
Step 2. Create a material to map to Dataplane.

Now open up the Material Editor. Select the first material slot that has a generic material in it. Rename this material “Averaged Data”. Under the maps Rollout, click the Diffuse Color check box, and ensure that the Amount value is 100. Click on the Map button, which currently labeled as “None”. The Material/Map Browser now appears. Double click on the Bitmap. Select the Apollo\Data\averagedimage.bmp file. This file contains the averaged value from the 100 individual images. Under the coordinates rollout, make sure that tiling is set to 1.0 for U and V, and that Tile is checked for both of them (this will ensure the data visible on both sides of the plane). Click on the Show Map in Viewport button. Now apply the data to the Dataplane object.

Step 3. Adjusting the material appearance.

In the Material Editor, use the center list box to go back to the Averaged Data set of parameters. In the Shader Basic parameters, click on 2-sided. Under Self Illumination, make the numerical entry 100. Note the change in the viewport. Now set the Opacity to 50. In the Viewport control (right click on the viewport name) set the Transparency setting to Best.
Step 4. Positioning the data

Use the Select and Move tool to move the data plane to the capsule. Unfortunately, when this experiment was conducted, no reference images were taken to help scale and place the data. (Otherwise the reference image would be used here, and then replaced by the data image once the data was scaled and aligned properly.)

Our clues here are the slightly visible line of the capsule, and the size and location of the plume. The plume emanates from the second hole down from the heat shield. There is also a faint line that shows the reflection off of the sting. Manipulate the position and scale until you have a good fit, as shown in Figure 4.1.

Figure 6.4.1 Proper position and scaling of data.

Step 5. Render the image and save your work

Figure 6.5.1 Rendered image of data visualization
Step 6. Animating data

Go back to step 2, and create a new material with a map, but this time pick the image001.ifl file for the map. This file is an ASCII text list of filenames of each of the data files. Max will use this list to update the image file for each frame of the animation. Once you have the material mapped to the Dataplane, use the Time Slider to change the frame and see how the data changes over time.
APPENDIX B

OMS 3.xx (ProImage, Profield, Prograph)

The original OMS 3.xx software code was modified to increase its capability to compare results from experimental ground testing and Computational Fluid Dynamics solutions, and to facilitate CFD validation using experimental data.

Appendix B consists of a description of the modification tasks performed and a brief instruction manual to OMS 3.xx. In addition, “How to” application package tutorials for ProImage, ProField, and ProGraph are included. The information in Appendix B was generated and provided by Sergey Fonov, Innovative Scientific Solutions, Inc., Dayton OH.
Application Package
OMS

USER's GUIDES
ProImage
Version 3.XX

2005
Contents

Preliminary Operations ........................................................................................................64
  Step 0. Preparing a Model for Data Processing Using the OMS ProImage Program .............64

Chapter 1. Working with a Project File ............................................................................70
  Step 1. Creating a Project File .......................................................................................70

Chapter 2. Processing a Project .....................................................................................74
  Files Necessary for Working with a Project .................................................................74
  Step 2. Processing a Project Using Default Parameters .............................................74
  Step 3. Processing a Project Automatically .................................................................87
  Step 4. Processing a List of Projects Automatically ....................................................90
  Step 5. Influence of Dialog Parameters on the Results of Project Processing ............93

Chapter 3. Editing a Single Bitmap ...............................................................................104
  Step 6. Editing the Intensity Values on a Bitmap .......................................................104
  Step 7. Removing Background from a Bitmap ............................................................126

Chapter 4. Preparing a File for ProField Application ....................................................131
  Step 8. Preparing a File for ProField Application ......................................................131
Preliminary Operations

Step 0. Preparing a Model for Data Processing

Using the OMS “ProImage” Program

1. Apply contrast marker points on the model surface. The number and position of these markers should describe the peculiarities of the Model Geometry. The total number of markers should be about 15..25, and applying them on the periphery and extreme points of the model is most effective.

![Figure 1]

2. Measure the 3D coordinates of these markers, and write them into a file (in our case, MARK_UP.APM).

Note. The file is a list of marker coordinates in ASCII format.

3. Prepare a bitmap with the model image.

4. After starting ProImage open an existing bitmap SENS_OFF.B16 that is located in subfolder SAMPLES\STEP_0 of the current folder:

Choose the Open... command from the File menu, or

Click the following icon from the upper toolbar:

![Figure 2]

The standard Open Dialog will appear on your screen.
5. Choose the file STEP_0.B16, and click the Open control button. The Open Dialog will be closed, and the bitmap will appear on your screen.

6. Select 2D markers on the bitmap in the order of sequence of the 3D marker numbers using the model photo (Figure 1).

   Choose the Mark... command from the Markers menu, or

   Click the following icon from the upper toolbar:

   The Mark Options Dialog will appear on your screen.
7. Choose all of the needed parameters in the Mark Options Dialog as shown above.

8. Click the OK control button. The cursor shape is changed to . Click on the points on the bitmap, and the markers will be placed at these points.

Note. The selection of markers is to be performed with the highest accuracy. If a marker has been selected inaccurately, it is recommended that this be corrected through the use of Move radio button. Use of the Delete radio button does not change the numbers of the rest of the markers. If a marker is to be added (using Add radio button), it will acquire a number that is equal to the last marker number plus one. Therefore, the order of the marker numeration may be violated.

9. To turn off the regime of marker selection, choose the Mark... command from the Markers menu again.
10. The quality of the marker choice can be controlled using the resection procedure. Choose the **Resection...** command from the **OMS Project** menu. The **Resection Methods Dialog** will appear on your screen.

![Resection Methods Dialog](image)

**Figure 8**

11. Choose all of the needed parameters in the **Resection Methods Dialog** as shown above.

12. Click the **Project** control button. The **Mesh Files** tab of the **OMS Property Sheet Dialog** will appear on your screen.

![OMS Property Sheet Dialog](image)

**Figure 9**

13. Choose all of the needed parameters in the **Mesh Files** tab as shown above. The appropriate files are to be chosen from the same folder (subfolder SAMPLES\STEP_0 of the current folder). You may type the names or click the ... control button. In this case the standard **Open Dialog** will appear on your screen to permit you to choose the files and their storage.

14. Click the **OK** control button. The **Resection Methods Dialog** will appear on your screen again.

15. Click the **OK** control button. The warning message concerning the absence of the file with the standard markers will appear on the screen.
16. Click the **OK** control button. The warning messages concerning the transformation error will appear on the screen.

17. Click the **OK** control button or press Enter. The standard *Save As Dialog* will appear on your screen.

**Figure 10**

![Save As Dialog](image)

18. Click the **OK** control button. The 3D Flowfield will be saved on the disk with the default name UP.XYZ in the same folder. To visualize it is necessary to open this file using the *ProField* application.

Note. If the result of the procedure is unsatisfactory (the Flowfield is displaced relative to the Geometry), it is necessary to repeat Steps 6-18.

**Figure 11**

19. To save the chosen markers on the disk, choose the *Save Markers As...* command from the *Markers* menu. The standard *Save As Dialog* will appear on your screen.
20. Choose all of the needed parameters in the **Save As Dialog** as shown above.

21. Click the **OK** control button. The markers will be saved on the disk as the file HST_315DD.MPT. In subsequent processing this file will be used as a file with standard markers.
Chapter 1. Working with a Project File

Step 1. Creating a Project File

1. To create a new project file, choose the New OMS Project... command from the OMS Project menu. The OMS Property Sheet Dialog will appear on your screen.

2. Choose all of the needed parameters in the Test Features tab as shown above.

3. Click the Write... control button. The standard Save As Dialog will appear on your screen.

4. Enter subfolder SAMPLES\STEP_1 of the current folder.

5. Type “STEP_1” in the File name text box, and click the Save control button. The Save As Dialog will be closed, and the project file with the name STEP_1.IMS will be created. Its name will appear in the This File information pane.
6. Click the **Refe Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.

**Figure 1.2**

6. Click the **Refe Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.

7. Choose all of the needed parameters in the **Refe Files** tab as shown above.

7. Choose all of the needed parameters in the **Refe Files** tab as shown above.

8. Click the **Sens Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.

8. Click the **Sens Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.
9. Choose all of the needed parameters in the **Sens Files** tab as shown above.

10. Click the **Mesh Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.
11. Choose all of the needed parameters in the **Mesh Files** tab as shown above.

12. Click the **Test Features** tab in the **OMS Property Sheet Dialog**. It will appear on your screen again.

13. Click the **Check** control button. The presence of all chosen files in the project folder SAMPLES\STEP_1 will be verified.

14. Click the **OK** control button. The project file will be created, and all chosen parameters will be saved into it.
Chapter 2. Processing a Project

Files Necessary for Working with a Project

Subfolder SAMPLES\STEP_2 of the current folder contains the following bitmaps:
1) REFE_DARK.B16 – a dark reference bitmap;
2) SENS_DARK.B16 – a dark sensitive bitmap;
3) REFE_OFF.B16 – a wind-off reference bitmap;
4) SENS_OFF.B16 – a wind-off sensitive bitmap;
5) REFE_ON.B16 – a wind-on reference bitmap;
6) SENS_ON.B16 – a wind-on sensitive bitmap.

The following files with information concerning markers should be in the same subfolder:
1) HST_315DD.MPT – markers on the image. This file is created manually by the user. It will be used for 3D transformations;
2) MARK_UP.APM – real 3D coordinates of markers on the model.

The following files with additional information should be in the same subfolder:
1) STEP_2.IMS – project file that contains the information that is necessary for processing the PSP test data;
2) UP.APT – Geometry of the model;
3) COEFFNEW.CLB – file that contains the coefficients of the calibration;
4) PCO_CAMERA.CAM – file that contains the camera parameters.

Step 2. Processing a Project Using Default Parameters

1. After running ProImage open an existing file STEP_2.IMS that is located in subfolder SAMPLES\STEP_2 of the current folder. Choose the Open Project... command from the B Convert menu. The standard Open Dialog will appear on your screen.
2. Choose the file STEP_2.IMS, and click the Open control button. The Open Dialog will be closed, and the wind-on sensitive bitmap will appear on your screen.

3. Choose the Dark Frame Subtraction command from the B Convert menu to subtract dark bitmaps from the processed bitmaps. The corrected wind-on sensitive bitmap will appear on your screen. (Four bitmaps--wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive--will be corrected. Use the Image command from the View menu to switch between these bitmaps.)
4. Choose the **Flat Field Correction** command from the **B Convert** menu to compensate for vignette-effect of the videocamera objective lens and the spread of the sensitivity of the photodetector array. The corrected wind-on sensitive bitmap will appear on your screen. (Four bitmaps—wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive—will be corrected. Use the **Image** command from the **View** menu to switch between these bitmaps.)
5. Choose the **Automatic Marking...** command from the **B Convert** menu. The **Quick Marker Search Dialog** will appear on your screen.

**Figure 2.5**

![Quick Marker Search Dialog](image)

6. Choose all of the needed parameters in the **Quick Marker Search Dialog** as shown above.

7. Click the **OK** control button. Four bitmaps with markers will be created (wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive). Use the **Image** command from the **View** menu to switch between these bitmaps.
8. Choose the **Markers Precise Position...** command from the **B Convert** menu. The **Revise Markers Dialog** will appear on your screen.

9. Choose all of the needed parameters in the **Revise Markers Dialog** as shown above.

10. Click the **OK** control button. The position of the markers will be corrected.
11. Choose the **Hide Markers** command from the **Markers** menu. The special symbols of the markers and their numbers will become invisible.

12. Choose the **Fill Up All Markers...** command from the **B Convert** menu to remove the marker images from the bitmaps. The **Fill Up Markers Dialog** will appear on your screen.
13. Choose all of the needed parameters in the Fill Up Markers Dialog as shown above.

14. Click the OK control button. The position of the markers will be corrected.

15. Choose the Filtering... command from the B Convert menu to apply the 2D Gauss filter on the bitmaps. The Gaussian Filter Parameters Dialog will appear on your screen.

16. Choose all of the needed parameters in the Gaussian Filter Parameters Dialog as shown above.

17. Click the OK control button.
18. Choose the **BackGround Work**... command from the **B Convert** menu to remove the background on the bitmaps. The **BackGround Select/Compensate Dialog** will appear on your screen.

**Figure 2.14**

![BackGround Select/Compensate Dialog]

---

**Mode of Operation**
- **BackGround Select**
- **BackGround Compensate**

**BackGround Select**
- by Threshold Value: 0
- by Scaled Image Average: 1
- the Same as Mask
- by Relative Value (0-1): 0.5
- by Whole Image Plane Approximation

**BackGround Compensate**
- by Value: 0
- by Mask Average
- by BackGround Average
- by 2 Side Steps Interpolation: 50
- by 4 Side Steps Interpolation: 10
- by BackGround Plane Approximation: 20
19. Choose all of the needed parameters in the BackGround Select/Compensate Dialog as shown above.

20. Click the OK control button. The bitmaps will be corrected.

Figure 2.15

21. Choose the Distortion Correction command from the B Convert menu to compensate for objective-lens distortions of the bitmaps. This command may be used only once. Then it becomes inactive.

Figure 2.16
22. Choose the **Alignment Images...** command from the **B Convert** menu to align the bitmaps. The **Image Alignment Dialog** will appear on your screen.

**Figure 2.17**

![Image Alignment Dialog](image)

23. Choose all of the needed parameters in the **Image Alignment Dialog** as shown above.

24. Click the **OK** control button. Warning messages about the transformation error will appear on the screen.

25. Click the **OK** control button, or press Enter. Four aligned bitmaps will be created (wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive). Use the **Image** command from the **View** menu to switch between these bitmaps.

**Figure 2.18**

![Aligned Bitmaps](image)

26. Choose the **Image Convert** command from the **B Convert** menu to transform the intensity on the aligned bitmaps to the physical parameters. Four bitmaps will be created (ratio of the intensity on the reference bitmap to the intensity on the sensitive bitmap, pressure, ratio of...
the pressure to the static pressure, and \( \text{Cp} \). Use the \textit{Image} command from the \textit{View} menu to switch between these bitmaps. The \( \text{Cp} \) flowfield is shown below.

\textbf{Figure 2.19}

27. Choose the \textit{Final Filtering...} command from the \textit{B Convert} menu to apply the 2D Gauss filter on the bitmaps with physical parameters. The \textit{Gaussian Filter Parameters Dialog} will appear on your screen.

\textbf{Figure 2.20}

\begin{center}
\textbf{Gaussian Filter Parameters}
\end{center}

\begin{tabular}{|c|c|}
\hline
3 & Filter diameter (3-15) \hline
1 & Number of iterations (1-100) \hline
\end{tabular}

28. Choose all of the needed parameters in the \textit{Gaussian Filter Parameters Dialog} as shown above.

29. Click the \textit{OK} control button. The corrected bitmap with the \( \text{Cp} \) flowfield will appear on your screen.
30. Choose the **Resection...** command from the **B Convert** menu to map the 2D bitmaps (with physical parameters) on the 3D mesh that describes the model surface. The **Resection Methods Dialog** will appear on your screen.

**Figure 2.22**

![Resection Methods Dialog](image)

31. Choose all of the needed parameters in the **Resection Methods Dialog** as shown above.

32. Click the **OK** control button. The **Image Alignment Dialog** will appear on your screen.

**Figure 2.23**

![Image Alignment Dialog](image)

33. Choose all of the needed parameters in the **Image Alignment Dialog** as shown above.
34. Click the OK control button. The warning messages concerning the transformation error will appear on the screen.

35. Click the OK control button, or press Enter. The 3D flowfields will be created. For visualization it is necessary to open the file STEP_2.XYZ (it is created at Step 36) using the ProField application.

36. Choose the Save Results command from the B Convert menu to save the active project and the results of the data processing. Four bitmaps will be written on the disk (STEP_2_P_TO_PST.IMP, STEP_2_IREFE_ISENS.IMP, STEP_2_PRESSURE.IMP, and STEP_2_CP.IMP). These files contain the bitmaps of the physical parameters and the markers on them. Also the file with 3D flowfields will be written on the disk (STEP_2.XYZ).

37. Choose the Close Project command from the B Convert menu to close the project file.
Step 3. Processing a Project Automatically

Subfolder SAMPLES\STEP_3 of the current folder contains all of the files necessary to process the project (for additional information see Step 2).

1. Open an existing file STEP_3.IMS that is located in subfolder SAMPLES\STEP_3 of the current folder (for additional information see Steps 1-2 of Step 2.) The wind-on sensitive bitmap will appear on your screen.

2. Choose the Automatic Convert... command from the B Convert menu. The Automatic Convert Scenario Dialog will appear on your screen.
3. Choose all of the needed parameters in the **Automatic Convert Scenario Dialog** as shown above.

4. Click the **OK** control button. Steps 3-35 of **Step 2** will be performed. Default parameters will be used in the Dialogs. To change them you may click the necessary control buttons, and the appropriate Dialog will appear on your screen.

Four bitmaps will be created (ratio of the intensity on the reference bitmap to the intensity on the sensitive bitmap, pressure, ratio of the pressure to the static pressure, and Cp). Use the **Image** command from the **View** menu to switch between these bitmaps. Also 3D flowfields will be created.

The Cp flowfield is shown below.
5. Choose the **Save Results** command from the **B Convert** menu to save the active project and the results of the data processing. Four bitmaps will be written on the disk (STEP_3_P_TO_PST.IMP, STEP_3_IREFE ISENS.IMP, STEP_3_PRESSURE.IMP, and STEP_3_CP.IMP). These files contain the bitmaps of the physical parameters and the markers on them. Also the file with 3D flowfields will be written on the disk (STEP_3.XYZ). For visualization it is necessary to open the file STEP_3.XYZ using the **ProField** application.

6. Choose the **Close Project** command from the **B Convert** menu to close the project file.
Step 4. Processing a List of Projects Automatically

Subfolder SAMPLES\STEP_3 of the current folder contains all of the files necessary to process the project (for additional information see Step 2). The project files from subfolders SAMPLES\STEP_1, SAMPLES\STEP_2, and SAMPLES\STEP_3 will be processed.

1. Choose the Automatic Convert List... command from the B Convert menu. The Automatic Convert Scenario Dialog will appear on your screen.

![Figure 4.1](image)

2. Select the STEP_1.IMS file in the Files/Directory list using the mouse.

3. Click the > control button. This file will be placed in the Files list pane.
4. Double click the [..] in the Files/Directory list. The list of folders in the SAMPLES folder will appear on your screen.

5. Repeat Steps 2-4 to select the STEP_2.IMS file from the SAMPLES\STEP_2 folder and the STEP_3.IMS file from the SAMPLES\STEP_3 folder.

6. Click the OK control button. Three project files will be processed automatically. Steps 3-35 of Step 2 will be performed. Default parameters will be used in the Dialogs. To change these you may click the necessary
control buttons, and the appropriate Dialog will appear on your screen.

Four bitmaps for each project file will be created (ratio of the intensity on the reference bitmap to the intensity on the sensitive bitmap, pressure, ratio of the pressure to the static pressure, and Cp). They will be written on the disk into the appropriate folder. These files contain the bitmaps of the physical parameters and the markers on them.

Also 3D flowfields for each project file will be created. These files with 3D flowfields will be written on the disk into the appropriate folder.
Step 5. Influence of Dialog Parameters on the Results of Project Processing

Subfolder SAMPLES\STEP_5 of the current folder contains the same files as SAMPLES\STEP_2, except that it contains a file for the Flat Field Correction and the following files with markers on the bitmaps:

1) REFE_OFF.MPT – markers on the wind-off reference bitmap;
2) SENS_OFF.MPT – markers on the wind-off sensitive bitmap;
3) REFE_ON.MPT – markers on the wind-on reference bitmap;
4) SENS_ON.MPT – markers on the wind-on sensitive bitmap.

1. Open an existing file STEP_5.IMS that is located in subfolder SAMPLES\STEP_5 of the current folder (for additional information see Steps 1-2 of Step 2). The wind-on sensitive bitmap will appear on your screen.

Figure 5.1

2. Choose the Dark Frame Subtraction command from the B Convert menu to subtract the dark bitmaps from the processed bitmaps. The corrected wind-on sensitive bitmap will appear on your screen. (Four bitmaps—wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive—will be corrected. Use the Image command from the View menu to switch between these bitmaps.)
3. Choose the Flat Field Correction command from the B Convert menu to compensate for distortions of the videocamera objective lens and the spread of the sensitivity of the photodetector array. The corrected wind-on sensitive bitmap will appear on your screen. (Four bitmaps—wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive—will be corrected. Use the Image command from the View menu to switch between these bitmaps.)
4. Choose the **Automatic Marking...** command from the **B Convert** menu. The **Quick Marker Search Dialog** will appear on your screen.

**Figure 5.4**

```
Markers on Bitmap
- Positive Markers (peaks)
- Negative Markers (pts)

Markers Radius (~2..15)

Threshold
- Entropy based
- Relative loss based

Entropy scale (~1)
Relative scale (0.01 - 0.95)

Acceleration
- Normal Speed
- High Speed

Select only fixed markers

Output
- Output As Is
- Output Gradient with markers
```

5. Choose all of the needed parameters in the **Quick Marker Search Dialog** as shown above. In the case of chosen parameters (the **Select only fixed markers** check box is turned on), only fixed markers will be copied.

6. Click the **OK** control button. Four bitmaps with markers will be created (wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive). Use the **Image** command from the **View** menu to switch between these bitmaps.
7. Choose the **Automatic Marking...** command from the **B Convert** menu. The **Quick Marker Search Dialog** will appear on your screen again.

8. Turn off the **Select only fixed markers** check box; type “7” in the **Markers Radius** text box; and click the **OK** control button. The number of markers will more than **Markers Radius** is equal to “2”.

9. Choose the **Automatic Marking...** command from the **B Convert** menu. The **Quick Marker Search Dialog** will appear on your screen again.
10. Turn on the **Output As Is** radio button in the **Output** pane and the **Entropy Based** radio button in the **Threshold** pane. Click the **OK** control button. The number of markers will increase.

**Figure 5.7**

11. Choose the **BackGround Work...** command from the **B Convert** menu to remove the background on the bitmaps. The **BackGround Select/Compensate Dialog** will appear on your screen.
12. Choose all of the needed parameters in the **Background Select/Compensate Dialog** as shown above.

13. Click the **OK** control button. All of the intensities on the bitmaps that are less than 500 will become background.
14. Choose the **BackGround Work...** command from the **B Convert** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

15. Turn on the **by Scaled Image Average** radio button, and type “0.5” in the **Scale** text box in the **BackGround Select** pane. Click the **OK** control button. All of the intensities on the bitmaps that are less than one-half of the average intensity will become background.

Figure 5.9

16. Choose the **BackGround Work...** command from the **B Convert** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

17. Turn off the **BackGround Select** check box, and turn on the **BackGround Compensate** check box in the **Mode of Operation** pane. Type “60” in the **Value** text box. Click the **OK** control button. All of the intensities on the bitmaps will be diminished by 60.
18. Choose the BackGround Work... command from the B Convert menu. The BackGround Select/Compensate Dialog will appear on your screen again.

19. Turn on the by 2 Sides Strap Interpolation radio button, and type "50" in the Side Straps Width text box in the BackGround Compensate pane. Click the OK control button.

20. Choose the Alignment Images... command from the B Convert menu to align the bitmaps. The Image Alignment Dialog will appear on your screen.
21. Choose all of the needed parameters in the Image Alignment Dialog as shown above.

22. Click the OK control button. Warning messages about the transformation error will appear on the screen.

23. Click the OK control button, or press Enter. Four aligned bitmaps will be created (wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive). Use the Image command from the View menu to switch between these bitmaps.

24. Choose the Image Convert command from the B Convert menu to transform the intensity on the aligned bitmaps to the physical parameters. Four bitmaps will be created (ratio of the intensity on reference bitmap to the intensity on the sensitive bitmap, pressure, ratio of the pressure to the static pressure, and Cp). Use the Image command from the View menu to switch between these bitmaps. The Cp flowfield is shown below.
25. Choose the **Resection**... command from the **B Convert** menu to map 2D bitmaps (with physical parameters) on the 3D mesh that describes the model surface. Then the **Resection Methods Dialog** will appear on your screen.

26. Choose all of the needed parameters in the **Resection Methods Dialog** as shown above.

27. Click the **OK** control button. The **Image Alignment Dialog** will appear on your screen.

28. Choose all of the needed parameters in the **Image Alignment Dialog** as shown above.
29. Click the **OK** control button. Warning messages about the transformation error will appear on the screen.

30. Click the **OK** control button, or press Enter. The 3D flowfields will be created. For visualization it is necessary to open the file STEP_5.XYZ (it is created at Step 31) using the **ProField** application. An inaccurate Flowfield is caused by poor Alignment and poor Resection. The violet parts of the Flowfield are attributed to background due to discrepancy.

![Figure 5.17](image)

31. Choose the **Save Results** command from the **B Convert** menu to save the active project and the results of the data processing. Four bitmaps will be written on the disk (STEP_5_P_TO_PST.IMP, STEP_5_IREFE_ISENS.IMP, STEP_5_PRESSURE.IMP, and STEP_5_CP.IMP). These files contain the bitmaps of the physical parameters and the markers on them. Also the file with 3D flowfields will be written on the disk (STEP_5.XYZ).

32. Choose the **Close Project** command from the **B Convert** menu to close the project file.
Chapter 3. Editing a Single Bitmap

Step 6. Editing the Intensity Values on a Bitmap

1. After running ProImage open an existing bitmap STEP_6.P that is located in subfolder SAMPLES\STEP_6 of the current folder:
   - Choose the Open... command from the File menu,
   - or
   - Click the following icon from the upper toolbar:

   Figure 6.1

   The standard Open Dialog will appear on your screen.

   Figure 6.2

   ![Open Dialog](image)

2. Choose the file STEP_6.P, and click the Open control button. The Open Dialog will be closed, and the bitmap will appear on your screen.
3. Choose the **Arithmetic**... command from the **Edit** menu. The **Arithmetic Operations with Constant Dialog** will appear on your screen.

![Figure 6.4](image)

4. Choose all of the needed parameters in the **Arithmetic Operations with Constant Dialog** as shown above.

5. Click the **OK** control button. The palette in the right-hand portion of the application window will be changed, and the level of intensity on the bitmap will be increased by 10.
6. To create a mask region on the bitmap:

Choose the **Mask by Boxes** command from the **Mask** menu, or

Click the following icon from the upper toolbar:

![Figure 6.6](image)

The cursor shape will be changed to 

7. Press the left mouse button, and move the mouse. Choose the desired box size, and release the mouse. The selected part of bitmap will be represented with bright colors and the out-mask region with muted colors.
8. Repeat Step 6-7, and create an additional mask region on the bitmap.

9. Choose the **Flood in Masked Regions...** command from the **Edit** menu. The **Flood In Masked Region With User Defined Value Dialog** will appear on your screen.
10. Choose all of the needed parameters in the **Flood In Masked Region With User Defined Value Dialog** as shown above.

11. Click the **OK** control button. The intensity in the masked regions will be equal to 15.

12. Choose the **Close** command from the **File** menu to close the bitmap.

13. Open an existing file STEP_6.P again (or more information see Steps 1-2). **Figure 6.3** will appear on your screen.

14. Choose the **Cut Off Intensities...** command from the **Edit** menu. The **Cut Off Intensities Dialog** will appear on your screen.
15. Choose all of the needed parameters in the **Cut Off Intensities Dialog** as shown above.

16. Click the **OK** control button. The palette in the right-hand portion of the application window will be changed, and the limits of intensity on the bitmap will be equal to 0.2 and 0.9.

**Figure 6.12**

17. To rotate the bitmap choose the **Flip/Rotate...** command from the **Edit** menu. The **Flip/Rotate Dialog** will appear on your screen.

**Figure 6.13**

18. Choose all of the needed parameters in the **Flip/Rotate Dialog** as shown above.

19. Click the **OK** control button. The bitmap will be rotated.
20. To create a mask region on the bitmap:

Choose the **Mask by Polygon** command from the **Mask** menu, or

Click the following icon from the upper toolbar:

**Figure 6.15**

The cursor shape will be changed to \( \text{\textbullet} \).

21. Click the mouse to fix the polyline nodes at some points. Click the mouse at the first node to close the polyline. The cursor shape will be changed to \( \text{\textbullet} \). Click inside (outside) the polygon. The inner (outer) region of the bitmap will be represented with bright colors and the out-mask region with muted colors.
22. Choose the **Fill Up...** command from the **Edit** menu. The **Eight Connected Float Fill Up Dialog** will appear on your screen.

23. Choose all of the needed parameters in the **Eight Connected Float Fill Up Dialog** as shown above.

24. Click the **OK** control button. The intensity in the masked region will be changed using bilinear interpolation.
25. Choose the **Close** command from the **File** menu to close the bitmap.

26. Open an existing file **STEP_6.P** again (for additional information see Steps 1-2). **Figure 6.3** will appear on your screen.

27. Open an existing file with coordinates of the markers **STEP_6.MRK** that is located in the same folder. Choose the **Open Markers...** command from the **Markers** menu. The standard **Open Dialog** will appear on your screen.

28. Choose the file **STEP_6.MRK**, and click the **Open** control button. The **Open Dialog** will be closed, and the markers on the bitmap will appear on your screen.
29. To add new markers:
   - Choose the Mark... command from the Markers menu,
     or
   - Click the following icon from the upper toolbar:

   ![Figure 6.21](image)

   The Mark Options Dialog will appear on your screen.

   ![Figure 6.22](image)

30. Choose all of the needed parameters in the Mark Options Dialog as shown above.

31. Click the OK control button. The cursor shape is changed to 🔤. Click at the points on the bitmap, and the markers will be placed at these points.
32. To turn off the regime of markers selected, choose the Mark... command from the Markers menu again.

33. To hide the images of the markers on the bitmap, choose the Hide Markers command from the Markers menu.

34. To remove the dark spots of the marker images from the bitmap, choose the Fill Up Markers... command from the Edit menu. The Fill Up Markers Dialog will appear on your screen.
35. Choose all of the needed parameters in the *Fill Up Markers* Dialog as shown above.

36. Click the **OK** control button. The regions of the markers will be bi-interpolated using region boundary points on the bitmap. (The region of the marker is the circle with the center at the point where the marker has been placed.)

37. Create mask regions on the bitmap (for additional information see Steps 6-7).
38. Choose the **Flat Filter**... command from the **Edit** menu. The **Flat Round Filter Dialog** will appear on your screen.

**Figure 6.28**

![Flat Round Filter Dialog](image)

39. Choose all of the needed parameters in the **Flat Round Filter Dialog** as shown above.

40. Click the **OK** control button. The intensity in the masked regions will be changed using the flat filter.
41. Choose the **Close** command from the **File** menu to close the bitmap.

42. Open an existing file STEP_6.P again (for additional information see Steps 1-2). **Figure 6.3** will appear on your screen.

43. Choose the **Gauss Filter...** command from the **Edit** menu. The **Gaussian Filter Dialog** will appear on your screen.

44. Choose all of the needed parameters in the **Gaussian Filter Dialog** as shown above.

45. Click the **OK** control button. The intensity on the bitmap will be changed using the Gauss filter.
46. Choose the **Close** command from the **File** menu to close the bitmap.

47. Open an existing file **STEP 6.P** again (for additional information see Steps 1-2). **Figure 6.3** will appear on your screen.

48. Create mask regions on the bitmap (for additional information see Steps 6-7.)

![Figure 6.32](image1)

![Figure 6.33](image2)
49. Choose the **Median Filter**... command from the **Edit** menu. The **Median Filter Dialog** will appear on your screen.

![Median Filter Dialog](image)

50. Choose all of the needed parameters in the **Median Filter Dialog** as shown above.

51. Click the **OK** control button. The intensity in the masked regions will be changed using the median filter.

![Figure 6.35](image)

52. Choose the **Ranged Filter**... command from the **Edit** menu. The **Ranged Filter Dialog** will appear on your screen.
53. Choose all of the needed parameters in the **Ranged Filter Dialog** as shown above.

54. Click the **OK** control button. The intensity in the masked regions will be filtrated.

55. To undo the mask selection:
   - Choose the **Mask All** command from the **Mask** menu,
   - or
   - Click the following icon from the upper toolbar:

![Figure 6.37](image)

The entire bitmap will be represented with bright colors.
Figure 6.39

56. Choose the 3D Filter... command from the Edit menu. The 3D Round Gaussian Filter Dialog will appear on your screen.

Figure 6.40

57. Choose all of the needed parameters in the 3D Round Gaussian Filter Dialog as shown above.

58. Click the OK control button. The intensity in the masked regions will be filtrated.
59. Choose the **Thinning...** command from the **Edit** menu. The **Thinning Dialog** will appear on your screen.

![Figure 6.41](image)

60. Choose all of the needed parameters in the **Thinning Dialog** as shown above.

61. Click the **OK** control button.
62. Choose the Expansion... command from the Edit menu. The Spread Dialog will appear on your screen.

63. Choose all of the needed parameters in the Spread Dialog as shown above.

64. Click the OK control button.
65. Choose the **Weighted Hybrid Map**... command from the **Edit** menu. The **Image Histogram Dialog** will appear on your screen.

66. Choose all of the needed parameters in the **Image Histogram Dialog** as shown above.

67. Click the **OK** control button.
Figure 6.47
Step 7. Removing Background from a Bitmap

1. After running ProImage, open an existing bitmap STEP_7.B16 that is located in the subfolder SAMPLES\STEP_7 of the current folder (for additional information see Steps 1-2 of Step 6).

Figure 7.1

2. Choose the BackGround... command from the Tools menu to remove the background on the bitmap. The BackGround Select/Compensate Dialog will appear on your screen.
3. Choose all of the needed parameters in the BackGround Select/Compensate Dialog as shown above.

4. Click the OK control button. All of the intensities on the bitmaps that are less than the average intensity will be background.
5. Choose the **BackGround...** command from the **Tools** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

6. Turn on the **by Threshold Value** radio button, and type “1000” in the **Threshold Value** text box in the **BackGround Select** pane. Click the **OK** control button. All of the intensities on the bitmap that are less than 1000 will become background.

Figure 7.4

7. Choose the **BackGround...** command from the **Tools** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

8. Turn on the **by Scaled Image Average** radio button, and type “0.5” in the **Scale** text box in the **BackGround Select** pane. Click the **OK** control button. All of the intensities on the bitmap that are less than one-half of the average intensity will be background.
9. Choose the **BackGround...** command from the **Tools** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

10. Turn off the **BackGround Select** check box, and turn on the **BackGround Compensate** check box in the **Mode of Operation** pane. Turn on the **by Value** radio button, and type "300" in the **Value** text box. Click the **OK** control button. The palette in the right-hand portion of the application window will be changed, and all of the intensities on the bitmap will be diminished by 300.

**Figure 7.4**

**Figure 7.5**
11. Choose the **BackGround...** command from the **Tools** menu. The **BackGround Select/Compensate Dialog** will appear on your screen again.

12. Turn on the **by 2 Sides Strap Interpolation** radio button, and type “100” in the **Side Straps Width** text box in the **BackGround Compensate** pane. Click the **OK** control button. The bitmap will be corrected.

**Figure 7.5**
Chapter 4. Preparing Project File for *ProField* Application

**Step 8. Preparing a File for *ProField* Application**

The subfolder `SAMPLES\STEP_8` of the current folder contains all of the files necessary to process the project (for additional information see Step 2).

1. Open an existing file `STEP_8.IMS` that is located in the subfolder `SAMPLES\STEP_8` of the current folder (for additional information see Steps 1-2 of Step 2). The wind-on sensitive bitmap will appear on your screen.

![Figure 8.1](image)

2. Repeat Steps 3-4 of Step 2 with the same parameters.
3. Choose the **Automatic Marking...** command from the **B Convert** menu. The **Quick Marker Search Dialog** will appear on your screen.

**Figure 8.3**

- **Markers on Bitmap**
  - Positive Markers (peaks)
  - Negative Markers (pts)
- **Markers Radius**
  - [2] (2 to 15)
- **Threshold**
  - Entropy based
  - Relative law based
- **Entropy scale**
  - [1]
- **Relative scale**
  - [0.15] (0.01 - 0.95)
- **Acceleration**
  - Normal Speed
  - High Speed
- **Select only fixed markers**
- **Output**
  - Output As Is
  - Output Gradient with markers
4. Choose all of the needed parameters in the **Quick Marker Search Dialog** as shown above.

5. Click the **OK** control button. Four bitmaps with markers will be created (wind-off reference, wind-on reference, wind-off sensitive, and wind-on sensitive). Use the **Image** command from the **View** menu to switch between these bitmaps.

6. Repeat Steps 8-21 of **Step 2** with the same parameters.

Figure 8.4

7. To restore the 3D Flowfields from all of the project bitmaps, choose the **Resection...** command from the **OMS Field** menu. The **Resection Methods Dialog** will appear on your screen.

Figure 8.5

![Resection Methods Dialog](image)

8. Choose all of the needed parameters in the **Resection Methods Dialog** as shown above.

Note. It is recommended that the **Resect 1** be used when 3D markers are measured with mean accuracy. In this case the **Resect 1** yields a reliable solution. It is recommended that the **Resect 2** be used when the 3D markers are measured with extremely high accuracy. Although the
Resect 2 yields a more exact solution than Resect 1, the solution is not so reliable.

9. Click the OK control button. Warning messages about the transformation error will appear on the screen.

10. Click the OK control button, or press Enter. STEP_8.XYZ will be created. It contains 3D flowfields that are mapped from the wind-off reference, wind-off sensitive, wind-on reference, and wind-on sensitive bitmaps. The bitmaps with markers are also mapped on the 3D mesh to create appropriate 3D Flowfields.

11. Choose the Close Project command from the B Convert menu to close the project file.
Application Package
OMS

USER's GUIDES
ProField
Version 3.XX
2005
Contents

Chapter 1. Processing a Project................................................................. 137
    Files Necessary for Working with a Project ..................................... 137
    Step 1. Calculating the Cp Flowfield................................................. 138

Chapter 2. Simple Operations with Files ............................................... 144
    Step 2. Editing the Geometry and Flowfield.................................... 144
    Step 3. Representing the Flowfield Value as a 3D Object ................. 152

Chapter 3. Working with a Project File .................................................. 155
    Step 4. Creating a Project File....................................................... 155

Chapter 4. Additional Features............................................................. 161
    Step 5. Drawing the Chart ............................................................. 161
    Step 6. Creating a New Function.................................................... 163
Chapter 1. Processing a Project

Files Necessary for Working with a Project

Subfolder SAMPLES\STEP_1 of the current folder contains the STEP_1.XYZ file. This file was created in the ProImage application. For additional information concerning its creation, see Step 8 of ProImage How to...

This subfolder also contains the following bitmaps:

1) REFE_DARK.B16 – a dark reference bitmap;
2) SENS_DARK.B16 – a dark sensitive bitmap;
3) REFE_OFF.B16 – a wind-off reference bitmap;
4) SENS_OFF.B16 – a wind-off sensitive bitmap;
5) REFE_ON.B16 – a wind-on reference bitmap;
6) SENS_ON.B16 – a wind-on sensitive bitmap.

The subfolder contains the following files with information concerning markers:

1) REFE_OFF.MPT – markers on the wind-off reference bitmap;
2) SENS_OFF.MPT – markers on the wind-off sensitive bitmap;
3) REFE_ON.MPT – markers on the wind-on reference bitmap;
4) SENS_ON.MPT – markers on the wind-on sensitive bitmap;
5) HST_315DD.MPT – markers on the image. This file is created manually by the user and used for 3D transformations;
6) MARK_UP.APM – real 3D coordinates of markers on the model.

This subfolder contains the following files with additional information:

1) STEP_1.IMS – project file containing the information necessary for processing the PSP test data;
2) UP.APT – file containing the geometry of the model;
3) COEFFNEW.CLB – file containing the coefficients of the calibration;
4) PCO_CAMERA.CAM – file containing the camera parameters.
Step 1. Calculating the Cp Flowfield

1. After running ProField, open an existing file STEP_1.IMS that is located in the subfolder SAMPLES\STEP_1 of the current folder. Choose the Open Project... command from the OMS Field menu. The standard Open Dialog will appear on your screen.

   Figure 1.1

   ![Open Dialog](image)

   2. Choose the file STEP_1.IMS, and click the Open control button. The Open Dialog will be closed, and the OMS Property Sheet Dialog will appear on your screen.

   This project works with two fields transferred on the 3D geometry: “sens” - ratio of the wind-on to wind-off sensitive images and “refe” - ratio of the wind-on to wind-off reference images. These fields were created using the “step_2pr.ims” and step_2re.ims projects included in the step_2 subdirectory of the Sample_ProImage directory.

   Significant angular parallax between the CCD cameras acquiring reference and sensitive images for bi-luminophore paint application can create a problem in alignment between the sensitive and reference channels. In this case it is more desirable to align independently the images in the sensitive and reference channels. The 2D-3D command in the ProImage Program allows the possibility of transferring all four source images on the mesh (after background subtraction, flat field and distortion correction).
3. Click the **OK** control button. The **OMS Property Sheet Dialog** will be closed, and the Geometry will appear on your screen.
4. To rotate the Geometry on your screen:
   - Choose the **Rotate** command from the **View** menu, or
   - Click the following icon from the upper toolbar:

   ![Figure 1.4](image)

   The cursor shape will be changed to 🔄.

5. Press the left mouse button, and drag the mouse. The Geometry will be rotated around the axis that is directed from the point of view to the center of the model while moving the mouse. Release the mouse button at the final position of the Geometry.

   ![Figure 1.5](image)
6. Choose the **Cp Calculation...** command from the **OMS Field** menu. The **Cp calculation Options Dialog** will appear on your screen.

**Figure 1.6**

![Cp calculation Options Dialog]

7. Choose all of the needed parameters in the **Cp calculation Options Dialog** as shown above.

8. Click the **OK** control button. The 3D Cp flowfield will appear on your screen.

9. To represent the Cp flowfield in a more desirable view, choose the **Appearance...** command from the **Options** menu. The **Appearance Dialog** will appear on your screen.
10. Choose all of the needed parameters in the **Appearance Dialog**

11. Click the **OK** control button. The palette will appear in the right-hand portion of your screen.
12. Click the **Options** control button at the bottom of the palette. The *Spectrum Appearance Dialog* will appear on your screen.

13. Choose all of the needed parameters in the *Spectrum Appearance Dialog*.

14. Click the **OK** control button. The 3D Cp flowfield will appear on your screen. It may be compared with the 3D Cp flowfield that was obtained in **Step 2** of *ProImage How To*.

15. Choose the **Save Results** command from the **OMS Field** menu to save the result of the Cp calculation.

16. Choose the **Close Project** command from the **OMS Field** menu to close the project file.
Chapter 2. Simple Operations with Files

Step 2. Editing the Geometry and Flowfield

1. Open an existing file STEP_2.FLD that is located in subfolder SAMPLES\STEP_2 of the current folder:
   - Choose the Open... command from the File menu, or
   - Click the following icon from the upper toolbar:

   Figure 2.1

   The standard Open Dialog will appear on your screen.

   Figure 2.2

2. Choose the file STEP_2.P, and click the Open control button. The Open Dialog will be closed, and the Geometry will appear on your screen.
3. To view separate blocks of Geometry, choose the Appearance... command from the Options menu. The Appearance Dialog will appear on your screen.

**Figure 2.4**

![Appearance Dialog](image)

4. Choose all of the needed parameters in the Appearance Dialog as shown above.

5. Click the OK control button. The blocks will be represented with different colors, and the front blocks will be displayed as a grid.

**Figure 2.5**

![Geometry Blocks](image)

6. To select a part of the Geometry:
   - Choose the Select... command from the Edit menu, or
   - Click the following icon from the upper toolbar:
7. Choose all of the needed parameters in the Select Dialog as shown above.

8. Click the OK control button.

9. Click the necessary block. The nodes of this block will be represented as red markers.

10. To magnify a portion of the screen on your screen:
    - Choose the Zoom Rectangle command from the View menu, or
    - Click the following icon from the upper toolbar:
The cursor shape will be changed to $\mathbb{E}$.

11. Press the left mouse button, and drag the mouse. The new picture fragment will be limited by the rectangle appearing on the screen. Releasing the mouse button rescales the picture.

12. Choose the **Destruct Mesh...** command from the **Edit** menu. The **Destruct Mesh Dialog** will appear on your screen.

13. Choose all of the needed parameters in the **Destruct Mesh Dialog** as shown above.

14. Click the **OK** control button. The grid of the selected block will become unstructured.
15. Choose the **Undo** command from the **Edit** menu. The grid of the selected block will return to the structured form. **Figure 2.10** will appear on your screen.

16. Choose the **Redirect Normal** command from the **Edit** menu. The normal of the selected block will become opposite. **Figure 2.13**

17. Choose the **Undo** command from the **Edit** menu. The normal of the selected block will return to the initial one. **Figure 2.10** will appear on your screen.

18. To show the Cp flowfield:

   - Choose the **Field Variables...** command from the **Options** menu, or
   - Click the following icon from the upper toolbar: **Figure 2.14**
The **Field Variables Dialog** will appear on your screen.

**Figure 2.15**

![Field Variables Dialog](image)

19. Choose all of the needed parameters in the **Field Variables Dialog** as shown above.

20. Click the **OK** control button. The Cp flowfield will appear on your screen. (**Figure 2.10** will appear on your screen.)

21. To view the Flowfield, choose the **Appearance...** command from the **Options** menu. The **Appearance Dialog** will appear on your screen again.

**Figure 2.16**

![Appearance Dialog](image)

22. Choose all of the needed parameters in the **Appearance Dialog** as shown above.

23. Click the **OK** control button.
24. Choose the **Filter...** command from the **Edit** menu. The **Field Filtering Dialog** will appear on your screen.

25. Choose all of the needed parameters in the **Field Filtering Dialog** as shown above.

26. Click the **OK** control button. The flowfield of the selected block will be filtered.
27. Choose the **Close** command from the **File** menu to close the opened file.
Step 3. Representing the Flowfield Value as a 3D Object

1. Open an existing file STEP_3.XYZ that is located in subfolder SAMPLES\STEP_3 of the current folder. (For additional information, see Steps 1-2 of Step 2.)

2. To visualize the Geometry rotate it on your screen. (For more information, see Steps 4-5 of Step 1.)

3. Show the Cp flowfield. (For more information see Steps 18-20 of Step 2.)

4. Choose the Import 3D Field... command from the Import/Export menu. The standard Open Dialog will appear on your screen.
5. Choose the file STEP_3.XYZ, and click the Open control button. The Open Dialog will be closed, and the Import Dialog will appear on your screen.

6. Choose all of the needed parameters in the Import Dialog as shown above.

7. Click the OK control button.
Chapter 3. Working with a Project File

Step 4. Creating a Project File

1. To create a new project file, choose the New OMS Project... command from the OMS Project menu. The OMS Property Sheet Dialog will appear on your screen.

2. Choose all of the needed parameters in the Test Features tab as shown above.

3. Click the Write... control button. The standard Save As Dialog will appear on your screen.

4. Create a subfolder SAMPLES\STEP_4 of the current folder, and enter it.

5. Type “STEP_4” in the File name text box, and click the Save control button. The Save As Dialog will be closed, and the project file with the name STEP_4.IMS will be
created. Its name will appear in the This File information pane.

6. Click the **Refe Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.

Figure 4.2

![OMS Property Sheet Dialog]

7. Choose all of the needed parameters in the **Refe Files** tab as shown above.

8. Click the **Sens Files** tab in the **OMS Property Sheet Dialog**. It will appear on your screen.
9. Choose all of the needed parameters in the Sens Files tab as shown above.

10. Click the T Files tab in the OMS Property Sheet Dialog. It will appear on your screen.
11. This tab remains empty at this Step. It is used for processing TSP images.

12. Click the Mesh Files tab in the OMS Property Sheet Dialog. It will appear on your screen.
13. Choose all of the needed parameters in the Mesh Files tab as shown above. The Field on Mesh text box is empty. In this version of the ProField application, a default filename is used. It is created by ProImage. For example, if ProImage runs project STEP_4.IMS, it creates the default name STEP_4.XYZ.

14. Click the Resultant Files tab in the OMS Property Sheet Dialog. It will appear on your screen.
15. The tab remains empty at this step. In this case the appropriate filenames will be created as a default. In our case the image files will be named `STEP_4_IREFE_ISENS.IMP`, `STEP_4_PRESSURE.IMP`, `STEP_4_P_PSTAT.IMP`, and `STEP_4_CP.IMP`; the marker files will be named `STEP_4_IREFE_ISENS.MPT`, `STEP_4_PRESSURE.MPT`, `STEP_4_P_PSTAT.MPT`, and `STEP_4_CP.MPT`.

Files for temperature are created for TSP only.

16. Click the **Test Features** tab in the **OMS Property Sheet Dialog**. It will appear on your screen again.

17. Click the **Check** control button. The presence of all of the chosen files in the project folder `SAMPLES\STEP_4` will be verified.

18. Click the **OK** control button. The project file will be created, and all of the chosen parameters will be saved in it.
Step 5. Drawing the Chart

1. Open an existing file STEP_2.FLD that is located in subfolder SAMPLES\STEP_2 of the current folder. (For more information see Steps 1-2 of Step 2.)

2. View the Cp flowfield. (For more information see Steps 18-20 of Step 2.) The Cp flowfield will appear on your screen.

3. To draw the chart:
   - Choose the Chart command from the Tools menu, or
   - Click the following icon from the upper toolbar:
Figure 5.3

The **step_2 (Cp) window** will appear in the right lower corner of your screen.

4. Press the left mouse button at the first point (cursor shape is changed to $\uparrow$), and move the mouse. Release the mouse button at the second point, and the function chart will appear in this window.

Figure 5.4
Step 6. Creating a New Function

1. Open an existing file STEP_2.FLD that is presented in subfolder SAMPLES\STEP_2 of the current folder. (For more information see steps 1-2 of Step 2.)

2. View the Cp flowfield. (For more information see Steps 18-20 of Step 2.) The Cp flowfield will appear on your screen.

3. Choose the Field Calculator... command from the Tools menu. The Field Calculator Dialog will appear on your screen.
4. To create a new function, click the Create A control button. The New field name Dialog will appear on your screen.

5. Choose all of the needed parameters in the New field name Dialog as shown above.

6. Click the OK control button. The warning message will appear on the screen.

7. Click the OK control button, or press Enter. The function “new_Cp” will be created, and the Field Calculator Dialog will appear on your screen again.
8. Choose all of the needed parameters in the Field Calculator Dialog as shown above.

9. Click the \( A = B + C \) control button. The warning message will appear on the screen.

10. Click the OK control button, or press Enter. The "new_Cp" will be equal to the sum of "Cp" and 10.

11. Click the Close control button.

12. Turn on the palette. (For more information see Steps 9-11 of Step 1.)
13. View the “new_Cp” flowfield. (For more information see Steps 18-20 of Step 2.) The “new_Cp” flowfield will appear on your screen. The palette in the right portion of the application window will be changed, and the level of intensity on the bitmap will be increased on 10.

14. Click the Options control button at the bottom of the palette. The Spectrum Appearance Dialog will appear on your screen.
15. Choose all of the needed parameters in the **Spectrum Appearance Dialog** as shown above.

16. Click the **OK** control button. The 3D Cp flowfield will appear on your screen. It may be compared with the 3D Cp flowfield.
Chapter 1. Creation of simple Geometries (using File menu)

Step 1. How to input data at the beginning of work using keyboard

1. After running ProGraph:
   - Choose the New... command from the File menu.
   - or
   - Click the following icon from the upper toolbar:

     ![Figure 1.1]

   Then the Regular Input Dialog Box will appear on your screen.

   ![Figure 1.2]

2. Input the coordinates of the point. Type "0", "-1" and "1" in text boxes as shown below.
3. Save the coordinates in the keyboard buffer.
   • Click the **Input after** control button.
   or
   • Press Enter.

   **Note.** Coordinate values appear in the list above. \( X \), \( Y \) and \( Z \) are the coordinates of this point; \( K \) is the number or patch; \( N \) is the number of the section and \( M \) is the current number of points in this section.

4. Repeat steps 2-3 to input the coordinates of the following points:

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
<th>Z</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>1</td>
<td>-1</td>
</tr>
<tr>
<td>0</td>
<td>-1</td>
<td>-1</td>
</tr>
<tr>
<td>0</td>
<td>-1</td>
<td>1</td>
</tr>
</tbody>
</table>

   **Note.** The input points will appear in the list below.
5. Click the **Cut** button the in **Points** pane. This permits one to turn on the regime of working with the Clipboard.

6. Select the second point in the list above with the use of the mouse.

**Note.** You also may click the list and use the following keys to move in the list:

→, ↓ - upward

↑, ← - downward

PgUp, Home - to the beginning of the list

PgDn, End - to the end of the list.

7. Cut the second point into the Clipboard.

   • Click the **Cut** button.

   or

   • Press Enter.

**Note.** The second point is removed from the list and placed into the Clipboard. The remaining points are renumbered.

8. Turn on the **Paste** check box in the **Points** pane.
9. Select the last point in the list.

10. Put the content of Clipboard to the end of list.
   - Click the **Input after** control button.
   
   or
   
   - Press Enter.

   **Note.** The fifth point appears in the list.

   ![Figure 1.7](image)

11. Input a new content to Clipboard. Type “0”, “2” and “2” in text boxes in the **Buffer** pane.

12. Select the fourth point in the list.

13. Click the **Replace** button in the **Points** pane to replace the selected point with a Clipboard contents.

14. Save the inputted coordinates in keyboard buffer.
   - Click the **Replace** control button.
   
   or
   
   - Press Enter.
15. Turn off the Paste check box in the Points pane (click on it with the mouse).

16. Click the New line button in the "Componentry" pane to input a new section.

17. Click the New line button.  

or

Press Enter.

Note. The first point of a new line is the point that has been selected in the first line.
18. Click the **Find** button in the **Component Entry** pane to find some inputted point with the use of its integer-valued address (K, N and M indices).

19. Then:
   - Click the **Find** button.
   - **or**
   - Press Enter.

   The **Find Dialog Box** will appear on your screen.

20. Type “1”, “1” and “3” in the text boxes and click the **Find** control button. This point will be selected in the list of inputted points.
21. Click the **OK** button in **Componentry** pane to finish the input.

22. Then:
   - Click the **OK** control button.
   - or
   - Press Enter.

The **Regular Input Dialog Box** will be closed and the Geometry will appear on your screen.
Figure 1.13
Step 2. How to open a file containing the Geometry

ProGraph uses Geometries in the form of regular or non-regular meshes which can be created by different geometrical systems such as AutoCAD© 14, Tecplot©, UniGraphics©.

Geometry should be converted to one of the following formats: APT, SKL, DAT or WRL.

1) When an APT file is opened, its format remains the same and the file is not converted. Its patches are painted with the following colors: the first — blue, the second — green, the third — red, the fourth — white and the fifth — pink. If the number of patches is greater than five, the color scheme is repeated periodically.

2) When a SKL file is opened, two cases may take place.
   - Sections of the Geometry have different number of points. In this case the file isn’t converted and it appears on your screen as a series of sections. The colors of these sections correspond to the numbers of patches (see the first point).
   or
   - All sections of the Geometry have the same number of points. In this case the file is converted to an APT one automatically. The colors of the patches correspond description in 1).

3) When a DAT file is opened, three events may take place.
   - The DAT file contains a structured grid only. In this case the file is converted to an APT one automatically.
   or
   - DAT file contains an unstructured grid only. In this case the file appears on your screen as a number of triangles. ProGraph uses only triangles as an element of unstructured grid. Another polyhedrons are converted to triangles automatically.
   or
   - DAT file contains both structured and unstructured grid. In this case the file is converted to an unstructured grid and it appears on your screen as a number of triangles (see the previous point).
4) When WRL file is opened, it is converted to unstructured grid automatically (see the previous point).

1. To open an existing file STEP_2.APT that is presented in the subfolder SAMPLES of the current folder:
   - Choose the **Open...** command from the **File** menu.
   - or
   - Click the following icon from the upper toolbar:

   ![Figure 2.1](image)

   Then the standard **Open Dialog Box** will appear on your screen.

   ![Figure 2.2](image)

   2. Choose the file **STEP_2.APT** and click the **Open** control button. Then the **Open Dialog Box** will be closed, and the Geometry will appear on your screen.
Figure 2.3
Step 3. How to append one Geometry file with another

The procedure for appending depends on the format of opened file.

1) When APT file is opened, only APT, SKL or DAT file may be appended. A new file is converted in accordance with the procedure described in Step 2.

2) When SKL file is opened, only APT or SKL file may be appended. A new file is converted in accordance with the procedure described in Step 2.

3) When DAT file is opened, only DAT or WRL file may be appended. A new file is converted in accordance with the procedure described in Step 2.

4) When WRL file is opened, only DAT or WRL file may be appended. A new file is converted in accordance with the procedure described in Step 2.

0. To append an existing file STEP_3.APT that is presented in subfolder the SAMPLES of the current folder to the existing file STEP_2.APT opened in Step 2:

- Choose the Append... command from the File menu.

or

- Click the following icon from the upper toolbar:

Figure 3.1

Then the standard Open Dialog Box will appear on your screen.

Figure 3.2
1. Choose an existing file STEP_3.APT. The Geometry will appear on your screen.

**Figure 3.3**

![ProGraph User's GUIDE 15](image-url)
Step 4. How to save a Geometry file on the disk

The procedure of saving depends on the format of created file.

1) When a file of APT format has been created, it may be saved as a file of APT, SKL, DAT, or WRL format.

2) When a file of SKL format has been created, it may be saved as a file of SKL format only.

3) When a file of DAT format has been created, it may be saved as a file of DAT, or WRL format only.

4) When a file of WRL format has been created, it may be saved as a file of DAT, or WRL format only.

0. To save a file created in Step 3 with a new name STEP_4.APT to the subfolder SAMPLES of the current folder:

- Choose the Save... command from the File menu.
- Click the following icon from the upper toolbar:

Then the standard Save As Dialog Box will appear on your screen.

1. Type "STEP_4" in the File name text box and click the Save control button. Then the Save As Dialog Box will be closed and the file will be saved under the new name.
Figure 4.3
Chapter 2. Geometry editing (using the Edit menu)

Step 5. How to select a patch and create a block

0. Open an existing file STEP_2.APT that is presented in the subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the patch:
   - Choose the Patches ~ Capture command from the Edit menu.
     or
   - Click the following icon from the upper toolbar:
     
     Figure 5.1

The cursor shape will be changed to.

2. Then:
   - Press the left mouse button and drag the mouse. The patch under the cursor will be painted with a yellow color and patch number will appear in the Status Bar. Releasing the mouse button captures the patch and inputs it to the block.
     or
   - Click the patch.

The selected patch will be highlighted with a yellow color and its points will be painted in blue. The selected patch will be transferred into the block and its number will appear in the Status Bar.

The patch that is included in block as the second one will be highlighted by green nodes, the third by red, the fourth by white and the fifth by pink. If the number of selected patches is more than five, the color scheme will be repeated periodically.
Figure 5.2

![ProGraph User Interface](image)

For Help, press F1
Step 6. **How to select a patch and to add it to the block with the use of the *Input & Add to block* command**

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see Steps 1-2 of Step 2.)

1. To select the patch:
   - Choose the **Patches ~ Input & Add to block...** command from the **Edit** menu.
   - or
   - Click the following icon from the upper toolbar:

   ![Figure 6.1](image)

   Then the **Input Patch Dialog Box** will appear on your screen.

   ![Input patch](image)

   2. Choose necessary parameters in the **Input Patch Dialog Box** as shown above.

   3. Click the **OK** button. Then the selected patch will be highlighted by a yellow color and its points will be represented as blue markers. (For more information about colors see Step 5.) The caught patch will be inputted to the block and its number will be in Status Bar.
Figure 6.3
Step 7. How to select a patch and to add it to non-empty block

0. To add a new patch to the block created at Step 6:
   • Choose the Patches ~ Add to block command from the Edit menu.
     or
   • Click the following icon from the left toolbar:

   Figure 7.1

   Then cursor shape will be changed to 🖼.

1. Then:
   • Press left mouse button and drag the mouse. The patch under cursor will be painted with a yellow color and patch number will appear in Status Bar. Releasing the mouse button selectes the patch and inputs it to the block.
     or
   • Click the patch.

   Then the caught patch will be painted with a yellow color and its points will be represented as green markers. The caught patch will be inputted to the block and its number will appear in Status Bar. (For more information about colors see Step 5.)

   Figure 7.2
Step 8. How to remove a patch from the block

0. To remove a patch from the block created at Step 7:
   - Choose the Patches ~ Remove from block command from the Edit menu.
   or
   - Click the following icon from the left toolbar:

   Figure 8.1

   Then cursor shape will be changed to 🗑️.

1. Then:
   - Press left mouse button and drag the mouse. The patch under cursor will be painted with a brown color and patch number will appear in Status Bar. Releasing the mouse button removes the patch from the block.
   or
   - Click the patch.

   Then the initial color of removed patch will be restored. (For more information about colors see Step 2 and Step 5.) The patch isn’t deleted from the Geometry and remains on its place.

Figure 8.2
Step 9. A set of one-action operations with block

0. To delete all needed patches included in the block created at **Step 8**:
   - Choose the **Patches ~ Delete block** command from the **Edit** menu.
   
or
   - Click the following icon from the left toolbar:
     
     Figure 9.1

     Only the patches that aren’t included in the block remain on your screen. Their colors are changed. (For more information about colors see **Step 2**.)

1. To undo all changes:
   - Choose the **Patches ~ Undo** command from the **Edit** menu.
   
or
   - Click the following icon from the upper toolbar:
     
     Figure 9.3

     Then old Geometry will appear on your screen again.
2. Select the patch with the number 1. (For more information see steps 2-3 of Step 5.)

3. To keep all the patches included in the block:
   - Choose the **Patches ~ Extract block** command from the **Edit** menu.
   - or
   - Click the following icon from the left toolbar:
Figure 9.6

Only the patches included in the block remain on your screen. Their colors may be changed. (For more information about colors see Step 2.)

Figure 9.7

4. To undo all changes choose the Patches ~ Undo command from the Edit menu. Then old Geometry will appear on your screen again.
Step 10. How to convert files to another format

0. Open an existing file STEP_10.APT that is presented in
subfolder SAMPLES of the current folder. (For more
information see steps 1-2 of Step 2.)

Figure 10.1

1. To convert this file to DAT format:
   - Choose the **Patches ~Convert to ~ VRML or DAT** command from the
     **Edit** menu.
   - or
   - Click the following icon from the right toolbar:

   Then the file of DAT format will appear on your screen.
2. To convert this file to SKL format:
   
   - Choose the **Patches ~ Convert to ~ SKL...** command from the **Edit** menu.
     
   or
   
   - Click the following icon from the right toolbar:
     
     **Figure 10.4**
   
     Then the **Convert to SKL Dialog Box** will appear on your screen.
   
3. Choose all needed parameters in the **Convert to SKL Dialog Box** as shown below.
4. Click the **OK** control button. Then the file of SKL format will appear on your screen.

5. To undo all changes:
   - Choose the **Patches ~ Undo** command from the **Edit** menu.
     
   or
     
   - Click the following icon from the upper toolbar:
     
   Then old Geometry will appear on your screen again.
6. Choose the *Patches ~ Convert to ~ SKL...* command from the *Edit* menu again. Then the *Convert to SKL Dialog Box* will appear on your screen.

7. Choose all needed parameters in the *Convert to SKL Dialog Box* as shown below.

![Convert to SKL Dialog Box](image)

8. Click the *OK* control button. Then the file of SKL format will appear on your screen.
9. To undo all changes choose the **Patches ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

10. Choose the **Patches ~ Convert to ~ SKL...** command from the **Edit** menu again. Then the **Convert to SKL Dialog Box** will appear on your screen.

11. Choose all needed parameters in the **Convert to SKL Dialog Box** as shown below.
12. Click the **OK** control button. Then the file of SKL format will appear on your screen.

13. To convert this file to APT format:
   - Choose the **Patches ~ Convert to ~ APT...** command from the **Edit** menu.
   - or
   - Click the following icon from the right toolbar:
Then the **Convert to APT Dialog Box** will appear on your screen.

**Figure 10.15**

![Convert to APT Dialog Box](image)

14. Choose all needed parameters in the **Convert to APT Dialog Box** as shown above.

15. Click the **OK** control button. Then the file of APT format will appear on your screen.

**Figure 10.16**

![STEP_10.apt - ProGraph](image)
Step 11. How to select a section

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the section:
   - Choose the Lines ~ Capture ~ Section command from the Edit menu.
   or
   - Click the following icon from the upper toolbar:
     Figure 11.1
     
     Then cursor shape will be changed to 🖐.

2. Then:
   - Press left mouse button and drag the mouse. The points of section under cursor will be painted with a white color and section and patch numbers will appear in Status Bar. Releasing the mouse button selectes the section.
   or
   - Click the section.
     Then the points of caught section will be painted with a white color.

When a block has been created, only a section belonging to this block may be caught. When no patches are included in the block, any section may be caught.
Step 12. How to select a section with the use of Input ~ Section command

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the section:
   - Choose the **Lines ~ Input ~ Section...** command from the **Edit** menu.
   or
   - Click the following icon from the upper toolbar:

   ![Figure 12.1](image1)

   Then the **Input section Dialog Box** will appear on your screen.

2. Choose all needed parameters in the Input section Dialog Box as shown below.

   ![Figure 12.2](image2)

3. Click the **OK** control button. The points of caught section are painted with a white color and section and patch numbers appear in Status Bar.

   When a block has been created, only a section belonging to this block may be caught. When no patches are included in the block, any section may be caught.
Figure 12.3

[Image of ProGraph interface]

Captured section: Patch K=1, Section N=14 // Press right button to continue
Step 13. How to select a line

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the line:
   - Choose the **Lines ~ Capture ~ Line** command from the **Edit** menu.
     or
   - Click the following icon from the upper toolbar:

   ![Figure 13.1](image)

   Then cursor shape will be changed to 🍀.

2. Then:
   - Press left mouse button and drag the mouse. The points of line under cursor will be painted with a white color and line and patch numbers will appear in Status Bar. Releasing the mouse button selectes the line.
     or
   - Click the line.

   Then the points of caught line will be painted with a white color.

   When a block has been created, only a line belonging to this block may be caught. When no patches are included in the block, any line may be caught.
Figure 13.2
Step 14. How to select a line with the use of *Input ~ Line* command

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the line:
   - Choose the *Lines ~ Input ~ Line...* command from the *Edit* menu.
   - or
   - Click the following icon from the upper toolbar:

   ![Figure 14.1](image)

   Then the *Input line Dialog Box* will appear on your screen.

2. Choose all needed parameters in the *Input line Dialog Box* as shown below.

   ![Input line Dialog Box](image)

3. Click the **OK** control button. The points of caught line are painted with a white color and line and patch numbers appear in Status Bar.

   When a block has been created, only a line belonging to this block may be caught. When no patches are included in the block, any line may be caught.
Figure 14.3

[Image of a ProGraph screen with a 3D mesh model]
Step 15. How to split a patch on two patches

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. Select a section. (For more information see steps 2-3 of Step 11.)

Figure 15.1

2. To split a patch on two patches:
   
   • Choose the **Patches ~ Split patch in block** command from the **Edit** menu.

   or

   • Click the following icon from the left toolbar:

   ![Figure 15.2]

   Then the patch that contains the caught section will be split. This section is used as a border of two new patches. The caught section belongs to both patches. The colors of patches will be changed. (For more information about colors see Step 2.)
Figure 15.3

Press right button to continue
Step 16. A set of one-action operations with sections

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. Select a section. (For more information see steps 2-3 of Step 11.)

2. To delete the caught section:
   - Choose the Lines ~ Delete command from the Edit menu.
   - or
   - Click the following icon from the left toolbar:

   Then the caught section will be deleted. The next section becomes the caught one.
3. To undo all changes:
   - Choose the **Lines ~ Undo** command from the **Edit** menu.
   - or
   - Click the following icon from the upper toolbar:

**Figure 16.5**

Then old Geometry will appear on your screen again.
4. To copy the caught section:
   - Choose the **Lines ~ Duplicate...** command from the **Edit** menu.
   or
   - Click the following icon from the left toolbar:

   ![Figure 16.6]

   Then the **Duplicate Dialog Box** will appear on your screen.

5. Choose all needed parameters in the **Duplicate Dialog Box** as shown below.

   ![Figure 16.7]

6. Click the **OK** control button. Then the caught section will be duplicated and its points will be distinguished as a white markers with green border.

   ![Figure 16.8]

7. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
8. To copy the caught section to Clipboard:

   • Choose the **Lines ~ Copy** command from the **Edit** menu.
   
or

   • Click the following icon from the left toolbar:

   **Figure 16.10**

   Then the caught section will be copied to Clipboard. It may be placed at any position.

9. To select another section press right mouse button, choose the **Next Section (Line)** command from the context menu and select necessary section. (For more information see steps 2-3 of **Step 11**.)
10. To place the Clipboard content instead of the caught section:
   - Choose the **Lines~Paste** command from the **Edit** menu.
     or
   - Click the following icon from the left toolbar:

   **Figure 16.12**

   Then the Clipboard content will replace the caught section.
Figure 16.13
Step 17. How to rebreak a section

0. Open an existing file STEP_17a.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.) Then the Geometry will appear on your screen.

1. Select the second section of a green patch. (For more information see steps 2-3 of Step 11.)

2. To rebreak the caught section:
• Choose the **Lines ~ Rebreak...** command from the **Edit** menu. 
  or 

• Click the following icon from the left toolbar: 
  ![Figure 17.3](image)

  Then the **Rebreak Dialog Box** will appear on your screen.

3. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.
  ![Figure 17.4](image)

4. Click the **OK** control button. Then the caught section will be rebroken.
5. To undo all changes:
   - Choose the **Lines ~ Undo** command from the **Edit** menu.
   - Click the following icon from the upper toolbar:

   ![Figure 17.5](image)

   Then old Geometry will appear on your screen again.

6. To rebreak another section choose the **Lines ~ Rebreak...** command from the **Edit** menu again. Then the **Rebreak Dialog Box** will appear on your screen.

7. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.
8. Click the **OK** control button. Then the fourth section will be rebroken. It will become the caught one.

9. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
10. To rebreak all sections of the patch choose the **Lines ~ Rebreak...** command from the **Edit** menu again. Then the **Rebreak Dialog Box** will appear on your screen.

11. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.

![Rebreak Dialog Box](image)

12. Click the **OK** control button. Then all the sections of green patch will be rebroken.
13. To undo all changes choose the Lines ~ Undo command from the Edit menu. Then old Geometry will appear on your screen again.

14. To rebreak the green patch in some range choose the Lines ~ Rebreak... command from the Edit menu again. Then the Rebreak Dialog Box will appear on your screen.

15. Choose all needed parameters in the Rebreak Dialog Box as shown below.
16. Click the **OK** control button. Then the green patch in
the range from the fifth line to the tenth line will be
rebroken.

17. To undo all changes choose the **Lines ~ Undo** command from
the **Edit** menu. Then old Geometry will appear on your
screen again.
18. To rebreak the second and the third sections of green patch choose the **Lines ~ Rebreak...** command from the **Edit** menu again. Then the **Rebreak Dialog Box** will appear on your screen.

19. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.

![Rebreak Dialog Box](image)

20. Click the **OK** control button. Then the second and the third sections of green patch will be rebroken.
21. To undo all changes choose the Lines ~ Undo command from the Edit menu. Then old Geometry will appear on your screen again.

22. To rebreak the second and the third sections of green patch choose the Lines ~ Rebreak... command from the Edit menu again. Then the Rebreak Dialog Box will appear on your screen.

23. Choose all needed parameters in the Rebreak Dialog Box as shown below.
24. Click the **OK** control button. Then the second and the third sections of green patch will be rebroken with new number of points.

**Note.** APT format of opened file is violated.

25. Open an existing file STEP_17b.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of **Step 2**.) Then the Geometry will appear on your screen.
26. Select the second section of a green patch. (For more information see steps 2-3 of Step 11.)

27. To rebreak all sections of green patch in accordance with the caught section choose the **Lines ~ Rebreak** command from the **Edit** menu. Then the **Rebreak Dialog Box** will appear on your screen.

28. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.
29. Click the OK control button. Then all sections of green patch will be rebroken in accordance with the caught section.

30. Open an existing file STEP_17c.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.) Then the Geometry will appear on your screen.
31. Select the last section. (For more information see steps 2-3 of Step 11.)

Figure 17.27

32. Choose the Lines ~ Rebreak... command from the Edit menu. Then the Rebreak Dialog Box will appear on your screen.

33. Choose all needed parameters in the Rebreak Dialog Box as shown below.
34. Click the **OK** control button. Then new Geometry will appear on your screen.

35. Open an existing file **STEP_17d.APT** that is presented in subfolder **SAMPLES** of the current folder. (For more information see steps 1-2 of **Step 2**.) Then the Geometry will appear on your screen.
36. Select the ninth line of green patch. (For more information see steps 2-3 of Step 13.)

37. To change the number of sections in green patch choose the Lines ~ Rebreak... command from the Edit menu. Then the Rebreak Dialog Box will appear on your screen.

38. Choose all needed parameters in the Rebreak Dialog Box as shown below.
39. Click the OK control button. Then new Geometry will appear on your screen.

40. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
41. Choose the **Lines ~ Rebreak...** command from the **Edit** menu. Then the **Rebreak Dialog Box** will appear on your screen.

42. Choose all needed parameters in the **Rebreak Dialog Box** as shown below.

**Figure 17.35**

43. Click the **OK** control button. Then new Geometry will appear on your screen.
Figure 17.36

Translate model in XY plane
Step 18. How to select a point

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the point:
   - Choose the **Point~Capture** command from the *Edit* menu.
     or
   - Click the following icon from the upper toolbar:

     ![Figure 18.1](image)

     Then cursor shape will be changed to 🗑️.

2. Then:
   - Press left mouse button and drag the mouse. The point under cursor will be distinguished as a white marker with red border and its number will appear in Status Bar. Releasing the mouse button selectes the point.
     or
   - Click the point.

   Then the caught point will be distinguished as a white marker with red border.

   When a block has been created, only a point belonging to this block may be caught. When a section or a line has been caught, only a point belonging to this section or line may be caught. When no patches, sections or lines have been caught, any point may be caught.
Figure 18.2
Step 19. How to select a point with the use of Input command

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. To select the section choose the Point-Input... command from the Edit menu. Then the Find Dialog Box will appear on your screen.

2. Choose all needed parameters in the Find Dialog Box as shown below.

![Find Dialog Box](image)

3. Click the OK control button. Then the caught point will be distinguished as a white marker with red border.

When a block has been created, only a point belonging to this block may be caught. When a section or a line has been caught, only a point belonging to this section or line may be caught. When no patches, sections or lines have been caught, any point may be caught.
Figure 19.2
Step 20. A set of one-action operations with points

0. Open an existing file STEP_2.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

1. Select a point. (For more information see steps 2-3 of Step 18.)

Figure 20.1

2. To delete the caught point:
   - Choose the **Point ~ Delete** command from the **Edit** menu.
   - or
   - Click the following icon from the left toolbar:

   ![Figure 20.2](image)

Then the caught point will be deleted. The next point will become the caught one.

**Note.** APT format of opened file is violated.
3. To undo all changes:
   - Choose the **Point ~ Undo** command from the **Edit** menu.
     or
   - Click the following icon from the upper toolbar:

**Figure 20.4**

Then old Geometry will appear on your screen again.

**Figure 20.5**
4. To copy the caught point:
   - Choose the **Point ~ Duplicate...** command from the **Edit** menu.
   - or
   - Click the following icon from the left toolbar:
     [Figure 20.6]

     Then the **Duplicate Dialog Box** will appear on your screen.

5. Choose all needed parameters in the **Duplicate Dialog Box** as shown below.

   [Figure 20.7]

6. Click the **OK** control button. Then the caught point will be duplicated and distinguished as a green markers with red border.

   **Note.** APT format of opened file is violated.

   [Figure 20.8]

7. To undo all changes choose the **Point ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
8. To copy the caught point to Clipboard:

- Choose the **Point ~ Copy** command from the **Edit** menu.
  
or

- Click the following icon from the left toolbar:

Figure 20.10

Then the caught point will be copied to Clipboard. It may be placed at any position.

9. To select another point press right mouse button, choose the **Next point** command from the context menu and select necessary section. (For more information see steps 2-3 of **Step 18**.)
10. To place the Clipboard content instead of the caught point:

- Choose the **Point~Paste** command from the **Edit** menu.
  
  or

- Click the following icon from the left toolbar:

**Figure 20.12**

Then the Clipboard content will replace the caught point.
11. To undo all changes choose the **Point ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

12. To edit the coordinates of the caught point:
   - Choose the **Point ~ Edit...** command from the **Edit** menu.
   - or
   - Click the following icon from the left toolbar:
Then the *Edit point Dialog Box* will appear on your screen.

13. Choose all needed parameters in the *Edit point Dialog Box* as shown below.

![Figure 20.16](image)

14. Click the **OK** control button. Then the caught point will be moved.

![Figure 20.17](image)

15. To undo all changes choose the **Point ~ Undo** command from the *Edit* menu. Then old Geometry will appear on your screen again.
16. To drag the caught point:

- Choose the **Point~Drag** command from the **Edit** menu.
  
  or

- Click the following icon from the left toolbar:

**Figure 20.19**

17. Then:

- Press left mouse button and drag the mouse. The caught point will be moved and its new coordinates will appear in Status Bar. Releasing the mouse button drops the caught point at the last position.
  
  or

- Click a new position of the caught point.

Then the caught point is moved in the plane of curvilinear quadrangle that is formed by neighboring sections and lines. This curvilinear quadrangle is covered by a grid that has 100x100 cells. The point can be placed in the points of this grid only. The point can’t be dragged outside the quadrangle.
Figure 20.20
Chapter 3. Block transforming (using Transformations menu)

Step 21. How to create a block projection on other patches

0. Open an existing file STEP_21a.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 21.1

1. Append an existing file STEP_21b.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 3.)
2. Select the green patch. (For more information see steps 2-3 of Step 5.)

3. To create a projection of block on the other patch:
   - Choose the Reflection command from the Transformations menu.
     or
   - Click the following icon from the right toolbar:
Then the Geometry will appear on your screen.

4. Keep all the patches included in the block. (For more information see step 4 of Step 9.) Only the patches included in the block remain on your screen. Their colors are changed. (For more information about colors see Step 2.)
Step 22. How to create an intersection of two patches

0. Open an existing file STEP_22a.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 22.1

1. Append an existing file STEP_22b.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 3.)

Figure 22.2
2. To show first points and sections choose the **View features** command from the **Options** menu. Then the **View features Dialog Box** will appear on your screen.

3. Choose all needed parameters in the **View features Dialog Box** as shown below.

![View features Dialog Box](image)

4. Click the **OK** control button. Then first sections will be represented with big yellow markers and first point at each section will be represented as big red markers.

**Note.** Patches must be crossed.

![Geometry projection](image)

5. To set the plane view \( Y = \text{const} \) click the following icon from the upper toolbar. Then a new projection of Geometry will appear on your screen.
6. Select the green patch. (For more information see steps 2-3 of **Step 5**.)

7. To intersect these patches and to create smooth conjugation of intersecting area:
   - Choose the **Intersection...** command from the **Transformations** menu.
   - or
   - Click the following icon from the right toolbar:
Then the **Intersection Dialog Box** will appear on your screen.

8. Choose all needed parameters in the **Intersection Dialog Box** as shown below.

9. Click the **OK** button. Then the Geometry will appear on your screen.

10. To set the plane view $X = \text{const}$ click the following icon from the upper toolbar $\%$. Then a new projection of Geometry will appear on your screen.
Figure 22.10
Step 23. How to merge patches included in the block

0. Open an existing file STEP_23a.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 23.1

1. Select the green patch. (For more information see steps 2-3 of Step 5.)

Figure 23.2

2. Select the red patch. (For more information see steps 1-2 of Step 7.)
3. To merge this patches:

- Choose the **Merge...** command from the **Transformations** menu.
  or
- Click the following icon from the upper toolbar:

**Figure 23.5**

Then the **Merge Dialog Box** will appear on your screen.

4. Choose all needed parameters in the **Merge Dialog Box** as shown below.

**Figure 23.5**

5. Click the **OK** control button. Then the number of lines will remain the same and the number of sections will
increase. Double points will be represented with big green markers. The colors of patches will be changed. (For more information about colors see Step 2.)

Figure 23.6

6. Open an existing file STEP_23b.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 23.7

7. Select the green patch. (For more information see steps 2-3 of Step 5.)
8. Select the red patch. (For more information see steps 1-2 of Step 7.)

9. Choose the **Merge...** command from the **Transformations** menu again. Then the **Merge Dialog Box** will appear on your screen.

10. Choose all needed parameters in the **Merge Dialog Box** as shown below.
11. Click the **OK** button. The patches in block have different numbers of lines. After merging APT format will be violated. Then a warning about APT format violation will appear on your screen.

12. Click the **Yes** control button or press Enter. Then a new Geometry of SKL format will appear on your screen. The sections of block belong to one patch now. The colors of patches will be changed. (For more information about colors see **Step 2**.)

13. Open an existing file **STEP_23c.APT** that is presented in subfolder **SAMPLES** of the current folder. (For more information see steps 1-2 of **Step 2**.)
14. Select the green patch. (For more information see steps 2-3 of Step 5.)

15. Select the red patch. (For more information see steps 1-2 of Step 7.)
16. Choose the **Merge...** command from the **Transformations** menu again. Then the **Merge Dialog Box** will appear on your screen.

17. Choose all needed parameters in the **Merge Dialog Box** as shown below.

18. Click the **OK** control button. The points of sections in the first and the second patches have different distributions.

A new Geometry appears on your screen. The sections of block belong to one patch now. The second patch is rebroken in accordance with the first one. The colors of patches are changed. (For more information about colors see **Step 2**.)
19. Open an existing file STEP_23d.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

20. Select the red patch. (For more information see steps 2-3 of Step 5.)
21. Select the green patch. (For more information see steps 1-2 of Step 7.)

22. Choose the **Merge...** command from the **Transformations** menu again. Then the **Merge Dialog Box** will appear on your screen.

23. Choose all needed parameters in the **Merge Dialog Box** as shown below.
24. Click the OK control button. Then the number of sections will remain the same and the number of lines will increase. The colors of patches will be changed. (For more information about colors see Step 2.)
Step 24. A set of one-action transformations of block

0. Open an existing file STEP_10.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 24.1

1. Select the green patch. (For more information see steps 2-3 of Step 5.)

Figure 24.2

2. To scale the block:
   - Choose the Scaling... command from the Transformations menu.
or

- Click the following icon from the right toolbar:

Figure 24.3

Then the **Scaling Dialog Box** will appear on your screen.

3. Choose all needed parameters in the **Scaling Dialog Box** as shown below.

Figure 24.4

4. Click the **OK** control button. Then the block will be scaled and a new Geometry will appear on your screen.

Figure 24.5

5. To undo all changes:

- Choose the **Patches ~ Undo** command from the **Edit** menu.
or

- Click the following icon from the upper toolbar:

**Figure 24.6**

Then old Geometry will appear on your screen again.

**Figure 24.7**

6. To move the block:
   - Choose the Move... command from the Transformations menu.
     or
   - Click the following icon from the right toolbar:

**Figure 24.8**

Then the **Move Dialog Box** will appear on your screen.

7. Choose all needed parameters in the Move Dialog Box as shown below.
8. Click the OK control button. Then the block will be moved and a new Geometry will appear on your screen.

9. To undo all changes choose the Patches ~ Undo command from the Edit menu. Then old Geometry will appear on your screen again.
10. To rotate the block:

- Choose the **Rotation...** command from the **Transformations** menu.

  or

- Click the following icon from the right toolbar:

  **Figure 24.12**

Then the **Rotation Dialog Box** will appear on your screen.

11. Choose all needed parameters in the **Rotation Dialog Box** as shown below.

**Figure 24.13**

![Rotation Dialog Box](image-url)
12. Click the **OK** control button. Then the block will be rotated and a new Geometry will appear on your screen.

**Figure 24.14**

![Image of ProGraph window with rotated block](image)

13. To undo all changes choose the **Patches ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

**Figure 24.15**

![Image of ProGraph window with unrotated block](image)

14. To mirror the block:
   - Choose the **Flip...** command from the **Transformations** menu.
   - or
• Click the following icon from the right toolbar:

![Figure 24.16](image)

Then the **Flip Dialog Box** will appear on your screen.

15. Choose all needed parameters in the **Flip Dialog Box** as shown below.

![Figure 24.17](image)

16. Click the **OK** control button. Then the block will be mirrored and a new Geometry will appear on your screen.

![Figure 24.18](image)

17. To undo all changes choose the **Patches ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
18. To add symmetrical block to the present one:
   - Choose the **Symmetric...** command from the **Transformations** menu.
   - Click the following icon from the right toolbar:
   
   ![Figure 24.20](image)
   
   Then the **Symmetry Dialog Box** will appear on your screen.

19. Choose all needed parameters in the **Symmetry Dialog Box** as shown below.

![Figure 24.21](image)
20. Click the **OK** control button. Then a new Geometry will appear on your screen.

**Figure 24.22**

21. To undo all changes choose the **Patches ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

**Figure 24.23**

22. To halve the number of points in every section of block:
   - Choose the **Knife** command from the **Transformations** menu.
   - or
• Click the following icon from the right toolbar:

Figure 24.24

Then a new Geometry will appear on your screen.

Figure 24.25

23. To enlarge the linear size of the block press right mouse button and choose the Extrapolate... command from the context menu. Then the Extrapolation Dialog Box will appear on your screen.

24. Choose all needed parameters in the Extrapolation Dialog Box as shown below.

Figure 24.26

25. Click the OK control button. Then a new Geometry will appear on your screen.
Figure 24.27
Chapter 4. Section transforming (using right mouse menu)

Step 25. A set of one-action transformations of section

0. Open an existing file STEP_10.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 25.1

1. Select a section. (For more information see steps 2-3 of Step 11.)

Figure 25.2
2. To scale the selected section press the right mouse button and choose the **Scaling...** command from the context menu. Then the **Scaling Dialog Box** will appear on your screen.

3. Choose all needed parameters in the **Scaling Dialog Box** as shown below.

![Figure 25.3](image)

4. Click the **OK** button. Then the selected section will be scaled and a new Geometry will appear on your screen.

![Figure 25.4](image)

5. To undo all changes:
   - Choose the **Lines ~ Undo** command from the **Edit** menu.
     or
• Click the following icon from the upper toolbar:

Figure 25.5

Then old Geometry will appear on your screen again.

Figure 25.6

6. To move the caught section press right mouse button and choose the **Move**... command from the context menu. Then the *Move Dialog Box* will appear on your screen.

7. Choose all needed parameters in the *Move Dialog Box* as shown below.

Figure 25.7

8. Click the **OK** control button. Then the caught section will be moved and a new Geometry will appear on your screen.
9. To undo all changes choose the `Lines ~ Undo` command from the `Edit` menu. Then old Geometry will appear on your screen again.

10. To rotate selected section press right mouse button and choose the `Rotation...` command from the context menu. Then the `Rotation Dialog Box` will appear on your screen.

11. Choose all needed parameters in the `Rotation Dialog Box` as shown below.
12. Click the **OK** control button. Then selected section will be rotated and a new Geometry will appear on your screen.

13. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
14. To mirror selected section press right mouse button and choose the **Flip...** command from the context menu. Then the **Flip Dialog Box** will appear on your screen.

15. Enter all necessary parameters in the **Flip Dialog Box** as shown below.

**Figure 25.13**

```
<table>
<thead>
<tr>
<th>Button</th>
</tr>
</thead>
<tbody>
<tr>
<td>X=const plane</td>
</tr>
<tr>
<td>Y=const plane</td>
</tr>
<tr>
<td>Z=const plane</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>X plane</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>Y plane</td>
</tr>
<tr>
<td>3000</td>
</tr>
<tr>
<td>Z plane</td>
</tr>
<tr>
<td>OK</td>
</tr>
<tr>
<td>Cancel</td>
</tr>
</tbody>
</table>
```

16. Click the **OK** button. Then selected section will be mirrored and a new Geometry will appear on your screen.
17. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

18. To add symmetrical section to the caught one press right mouse button and choose the **Symmetric...** command from the context menu. Then the **Symmetry Dialog Box** will appear on your screen.

19. Enter all required parameters in the **Symmetry Dialog Box** as shown below.
20. Click the OK button. Then a new Geometry will appear on your screen.

**Note.** APT format of opened file is violated.

21. To undo all changes choose the Lines ~ Undo command from the Edit menu. Then old Geometry will appear on your screen again.
22. To move selected section using linear interpolation press right mouse button and choose the **Interpolate...** command from the context menu. Then the **Interpolate Dialog Box** will appear on your screen.

23. Enter all required parameters in the **Interpolate Dialog Box** as shown below.

24. Click the **OK** button and selected section will be moved to the next one and a new Geometry will appear on your screen.
25. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.

26. To prescribe a definite value for coordinate (X, Y or Z) of all the points included in the selected section press right mouse button and choose the **Prescribe...** command from the context menu. Then the **Prescribe Dialog Box** will appear on your screen.
27. Choose all required parameters in the *Prescribe Dialog Box* as shown below.

![Prescribe Dialog Box](image)

28. Click the **OK** control button. Then selected section will be moved to the next one and a new Geometry will appear on your screen.

![Geometry](image)

29. To undo all changes choose the **Lines ~ Undo** command from the **Edit** menu. Then old Geometry will appear on your screen again.
30.To halve the number of points in the selected section press right mouse button and choose the **Knife** command from the context menu. Then a new Geometry will appear on your screen.

**Note.** APT format of opened file is violated.
Step 26. A set of one-action transformations of section part

0. Open an existing file STEP_10.APT that is presented in subfolder SAMPLES of the current folder. (For more information see steps 1-2 of Step 2.)

Figure 26.1

1. Select a section. (For more information see steps 2-3 of Step 11.)

Figure 26.2

2. Choose a point of selected patch. (For more information see steps 2-3 of Step 18.)
3. To diminish the number of points in the selected section press right mouse button and choose the Knife command from the context menu. Then the new Geometry will contain only the points from the first one up to caught one.

**Note.** APT format of opened file is violated.

**Figure 26.4**

4. To undo all changes:
   - Choose the Patches ~ Undo command from the Edit menu.
   - or
• Click the following icon from the upper toolbar:

**Figure 26.5**

Then old Geometry will appear on your screen again.

**Figure 26.6**

5. To copy a part of selected section to Clipboard press right mouse button and choose the *Copy part* command from the context menu. Then the section part from the first point up to the chosen point will be copied to Clipboard. It may be placed at any position.

6. To return to the regime of section editing press right mouse button and choose the *Exit* command from context menu.
7. To select another section press right mouse button, choose the **Next Section (Line)** command from the context menu and select necessary section. (For more information see steps 2-3 of **Step 11**.)

8. To place a copy of the Clipboard contents to the end of the caught section press right mouse button and choose the **Merge** command from the context menu. Then a new Geometry will appear on your screen.

**Note.** APT format of opened file is violated.