Computer-Aided Structural Engineering (CASE) Project


Version 5.00

by David Wickersheimer, Gene McDermott, Ken Taylor, Carl Roth Wickersheimer Engineers, Inc.

Approved For Public Release; Distribution Is Unlimited

94-16336

Prepared for Headquarters, U.S. Army Corps of Engineers
The contents of this report are not to be used for advertising, publication, or promotional purposes. Citation of trade names does not constitute an official endorsement or approval of the use of such commercial products.

Version 5.00

by David Wickersheimer, Gene McDermott, Ken Taylor, Carl Roth

Wickersheimer Engineers, Inc.
821 South Neil St.
Champaign, IL 61820
Waterways Experiment Station Cataloging-In-Publication Data

User's guide: Computer-Aided Structural Modeling (CASM), version 5.00 / by David Wickersheimer ... [et al.]; prepared for U.S. Army Corps of Engineers, monitored by Information Technology Laboratory, U.S. Army Engineer Waterways Experiment Station. 358 p.; 28 cm. -- (Instruction report ; ITL-94-2) Includes index.

1. Computer-aided design -- Handbooks, manuals, etc. 2. Structural engineering -- Computer programs. 3. CASM (Computer program. I. Wickersheimer, David. II. Computer-Aided Structural Engineering (CASE) Project. III. Information Technology Laboratory (U.S. Army Corps of Engineers, Waterways Experiment Station) IV. U.S. Army Engineer Waterways Experiment Station. V. Instruction report (U.S. Army Engineer Waterways Experiment Station) ; ITL-94-2.

TA7 W34i no. ITL-94-2
This user's guide describes the use of the computer program CASM, which is designed to aid the structural engineer in the preliminary design and evaluation of structural building systems by the use of three-dimensional interactive graphics. Funds for the development of this program and publication of this report were provided to the Information Technology Laboratory (ITL), U.S. Army Engineer Waterways Experiment Station (WES), Vicksburg, MS, by the Directorate of Military Programs, Headquarters, U.S. Army Corps of Engineers (HQUSACE), under the Research, Development, Test, and Evaluation (RDT&E) program. The work was accomplished under Work Unit No. AT40-CA-001 entitled "CASE (Computer Aided Structural Engineering) Building Systems." The work was performed by members of Wickersheimer Engineers, Inc., of Champaign, IL, under Contract No. DACA39-86-C-0024.

Specifications for the program were provided by members of the Building Systems Task Group of the CASE Project. The following were members of the task group during program development:

- Mr. Dan Reynolds, U.S. Army Engineer (USAE) District, Sacramento (Chairman)
- Ms. Anjana Chudgar, USAE Division, Ohio River
- Mr. Pete Rossbach, USAE District, Baltimore
- Mr. Dave Smith, USAE District, Omaha
- Mr. Mark Burkholder, USAE District, Tulsa
- Mr. Jerry Maurseth, USAE District, Portland
- Mr. Chris Merrill, WES
- Mr. Michael Pace, WES

The computer program and tutorial were written by Messrs. David Wickersheimer, Gene McDermott, Ken Taylor, and Carl Roth of Wickersheimer Engineers, Inc. The work was monitored at WES by Mr. Michael E. Pace and Mr. Chris Merrill, Computer-Aided Engineering Division (CAED), under the general supervision of Mr. H. Wayne Jones, Chief, Scientific and Engineering Applications Center; Dr. Reed Mosher, Chief, CAED; Mr. Timothy Ables, Assistant Director, ITL; and Dr. N. Radhakrishnan, Director, ITL. Mr. Donald Dresler was the original HQUSACE point of contact, and Mr. Charles Gutberlet is the present technical monitor.

Dr. Robert W. Whalin is Director of WES. COL Bruce K. Howard, EN, is Commander.
# CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>PREFACE</td>
<td>1</td>
</tr>
<tr>
<td>BACKGROUND</td>
<td>xi</td>
</tr>
<tr>
<td>WHAT IS CASM?</td>
<td>xi</td>
</tr>
<tr>
<td>CASM VERSION 5.00</td>
<td>xi</td>
</tr>
<tr>
<td>PROJECT HISTORY</td>
<td>xii</td>
</tr>
<tr>
<td>INTRODUCTION</td>
<td>1-1</td>
</tr>
<tr>
<td>PURPOSE</td>
<td>1-1</td>
</tr>
<tr>
<td>PROGRAM USER GUIDES</td>
<td>1-2</td>
</tr>
<tr>
<td>CASM USER'S GUIDE</td>
<td>1-2</td>
</tr>
<tr>
<td>CASM TUTORIAL</td>
<td>1-3</td>
</tr>
<tr>
<td>CASM SCHEME A</td>
<td>1-3</td>
</tr>
<tr>
<td>CASM SCHEME B</td>
<td>1-3</td>
</tr>
<tr>
<td>CASM SCHEME C</td>
<td>1-4</td>
</tr>
<tr>
<td>CASM QUICK REFERENCE</td>
<td>1-4</td>
</tr>
<tr>
<td>FOR THE BEGINNING USER</td>
<td>1-4</td>
</tr>
<tr>
<td>FOR THE ADVANCED USER</td>
<td>1-4</td>
</tr>
<tr>
<td>CONVENTIONS USED IN THIS MANUAL</td>
<td>1-5</td>
</tr>
<tr>
<td>INSTALLATION</td>
<td>2-1</td>
</tr>
<tr>
<td>PACKING LIST</td>
<td>2-1</td>
</tr>
<tr>
<td>MINIMUM PROGRAM REQUIREMENTS</td>
<td>2-1</td>
</tr>
<tr>
<td>OPTIONAL EQUIPMENT</td>
<td>2-3</td>
</tr>
<tr>
<td>PROGRAM INSTALLATION</td>
<td>2-5</td>
</tr>
<tr>
<td>PROGRAM OVERVIEW</td>
<td>3-1</td>
</tr>
<tr>
<td>GETTING STARTED</td>
<td>3-1</td>
</tr>
<tr>
<td>STARTING CASM - WINDOWS METHOD</td>
<td>3-1</td>
</tr>
<tr>
<td>STARTING CASM - DOS METHOD</td>
<td>3-3</td>
</tr>
<tr>
<td>THE CASM PROGRAM WINDOW</td>
<td>3-5</td>
</tr>
<tr>
<td>SOME DEFINITIONS</td>
<td>3-6</td>
</tr>
<tr>
<td>RUNNING THE PROGRAM</td>
<td>3-8</td>
</tr>
<tr>
<td>MENUS AND DIALOG WINDOWS</td>
<td>3-12</td>
</tr>
<tr>
<td>PULL-DOWN MENU BAR</td>
<td>3-12</td>
</tr>
<tr>
<td>TOOL PALETTE WINDOWS</td>
<td>3-13</td>
</tr>
<tr>
<td>USE OF POP-UP DIALOG WINDOWS</td>
<td>3-14</td>
</tr>
<tr>
<td>GRAPHIC DISPLAY OF MODEL</td>
<td>3-17</td>
</tr>
<tr>
<td>VIEWPOINT TOOLS</td>
<td>3-17</td>
</tr>
</tbody>
</table>
## CONTENTS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>VIEW MENU</td>
<td>3-19</td>
</tr>
<tr>
<td>USE OF MOUSE OR KEYBOARD TO INPUT DIMENSIONS</td>
<td>3-20</td>
</tr>
<tr>
<td>SELECTING COORDINATE INPUT MODE</td>
<td>3-20</td>
</tr>
<tr>
<td>USING THE MOUSE</td>
<td>3-21</td>
</tr>
<tr>
<td>USING THE KEYBOARD</td>
<td>3-25</td>
</tr>
<tr>
<td>SAVING YOUR WORK ON DISK</td>
<td>3-29</td>
</tr>
<tr>
<td>SAVE</td>
<td>3-29</td>
</tr>
<tr>
<td>SAVE AS</td>
<td>3-30</td>
</tr>
<tr>
<td>PRINT/CREATE OUTPUT FILES</td>
<td>3-30</td>
</tr>
<tr>
<td>PRINT DATA</td>
<td>3-31</td>
</tr>
<tr>
<td>PRINT SCREEN</td>
<td>3-32</td>
</tr>
<tr>
<td>USING PREVIOUSLY SAVED FILES</td>
<td>3-36</td>
</tr>
<tr>
<td>USING EXCEL TO SIZE MEMBERS</td>
<td>3-39</td>
</tr>
<tr>
<td>STOPPING THE CASM PROGRAM</td>
<td>3-43</td>
</tr>
<tr>
<td>DESKTOP APPLICATION PROGRAMS</td>
<td>3-46</td>
</tr>
<tr>
<td>OTHER APPLICATION PROGRAMS</td>
<td>3-47</td>
</tr>
<tr>
<td>CASM APPLICATION PROGRAMS</td>
<td>3-48</td>
</tr>
<tr>
<td>REFERENCE</td>
<td>4-1</td>
</tr>
<tr>
<td>BOTTOM TOOL PALETTE</td>
<td>4-2</td>
</tr>
<tr>
<td>VIEWPOINT TOOLS</td>
<td>4-3</td>
</tr>
<tr>
<td>CONTROL MENU</td>
<td>4-6</td>
</tr>
<tr>
<td>RESTORE</td>
<td>4-7</td>
</tr>
<tr>
<td>MOVE</td>
<td>4-8</td>
</tr>
<tr>
<td>SIZE</td>
<td>4-9</td>
</tr>
<tr>
<td>MINIMIZE</td>
<td>4-9</td>
</tr>
<tr>
<td>MAXIMIZE</td>
<td>4-10</td>
</tr>
<tr>
<td>CLOSE [Alt] + [F4]</td>
<td>4-10</td>
</tr>
<tr>
<td>SWITCH TO [Ctrl] + [Esc]</td>
<td>4-12</td>
</tr>
<tr>
<td>RUN</td>
<td>4-14</td>
</tr>
<tr>
<td>FILE MENU</td>
<td>4-16</td>
</tr>
<tr>
<td>NEW</td>
<td>4-17</td>
</tr>
<tr>
<td>OPEN</td>
<td>4-18</td>
</tr>
<tr>
<td>SAVE</td>
<td>4-20</td>
</tr>
<tr>
<td>SAVE AS</td>
<td>4-21</td>
</tr>
<tr>
<td>PRINT DATA</td>
<td>4-22</td>
</tr>
<tr>
<td>PRINT SCREEN</td>
<td>4-26</td>
</tr>
<tr>
<td>PRINTER SETUP</td>
<td>4-30</td>
</tr>
<tr>
<td>IMPORT</td>
<td>4-30</td>
</tr>
<tr>
<td>EXPORT</td>
<td>4-31</td>
</tr>
<tr>
<td>CASM SETTINGS</td>
<td>4-33</td>
</tr>
<tr>
<td>EXIT</td>
<td>4-35</td>
</tr>
<tr>
<td>VIEW MENU</td>
<td>4-37</td>
</tr>
</tbody>
</table>
CONTENTS

STRUCTURAL PLANE INFORMATION .................. 4-38
SHOW LOADS ................................... 4-39
SHOW STRUCTURE ................................ 4-40
PERSPECTIVE (3D) ................................. 4-41
PLAN .......................................... 4-41
ELEVATION ....................................... 4-41
SECTION ........................................ 4-41
HORIZONTAL STRUCTURAL PLANE .................... 4-42
INCLINED STRUCTURAL PLANE ...................... 4-42
VERTICAL STRUCTURAL PLANE ..................... 4-43
PAN ............................................ 4-43
ZOOM WINDOW ................................... 4-43
VIEW PREVIOUS ................................ 4-44
WIRE FRAME .................................... 4-44
TRANSPARENT .................................... 4-44
SOLID .......................................... 4-44
HIDE SHAPES .................................... 4-45
SHOW SHAPES ................................... 4-45
FULL SCREEN .................................... 4-45
STORE VIEW ..................................... 4-45
RECALL VIEW .................................... 4-46

CRITERIA MENU .................................. 4-47
PROJECT ........................................ 4-49
REGIONAL ....................................... 4-53
SITE ............................................ 4-55
WIND ROSETTE (NOT IMPLEMENTED) ................. 4-57

HELP MENU ..................................... 4-58
CONTENTS [F1] .................................. 4-59
SEARCH FOR HELP ON ............................. 4-61
HOW TO USE HELP ................................ 4-62
ABOUT CASM .................................... 4-63

DRAW MODEL TOOL PALETTE ......................... 4-65

SHAPES MENU .................................... 4-67
EDIT MENU ....................................... 4-72

UNDO ............................................ 4-74
DRAG VERTEX .................................... 4-74
DRAG EDGE ....................................... 4-75
DRAG PLANE ...................................... 4-76
DELETE SHAPE .................................... 4-78
MOVE SHAPE ...................................... 4-78
ROTATE SHAPE .................................... 4-79
SLICE SHAPE ..................................... 4-80
DUPLICATE SHAPE ................................ 4-81
CONTENTS

NARROWLY SPACED ........................................ 4-120
WIDELY SPACED ........................................... 4-120
BEAMS ALL GRID LINES ................................. 4-122
TRUSS - CUSTOM ........................................ 4-123
NON-HORIZONTAL ARCH (NOT IMPLEMENTED) ............ 4-126
GRIDS TWO-WAY (NOT IMPLEMENTED) ..................... 4-126
COLUMN/WALL ............................................ 4-127
  ALL GRID INTERSECTIONS ............................... 4-128
  ONE GRID INTERSECTION ............................... 4-129
  2 GRID POINTS ........................................ 4-131
  PILASTER (NOT IMPLEMENTED) .......................... 4-133
  FOOTING ................................................ 4-133
LATERAL MENU ............................................ 4-134
  DEFINE LOCATION ..................................... 4-135
  DEFINE ELEMENTS ..................................... 4-136
ENTIRE PLANE ............................................ 4-139
  FLEXIBLE DIAPHRAGM .................................. 4-139
  RIGID DIAPHRAGM ...................................... 4-139
DEFINE AREA ............................................. 4-140
  FLEXIBLE DIAPHRAGM .................................. 4-140
  RIGID DIAPHRAGM ...................................... 4-140
  DIAPHRAGM GUIDELINES ................................. 4-141
LOADS AND DESIGN TOOL PALETTE ......................... 4-143
EDIT MENU ............................................... 4-145
  UNDO .................................................. 4-145
  DELETE LOAD .......................................... 4-145
  MODIFY LOAD .......................................... 4-146
  COPY DESIGN .......................................... 4-146
  MODIFY DESIGN ........................................ 4-147
LOADS MENU ............................................... 4-149
  LOAD COMBINATIONS .................................... 4-149
AREA AND LINEAR DEAD LOADS ............................. 4-151
  FLOOR (DL) ........................................... 4-151
  WALL (DL) ............................................. 4-151
  CEILING (DL) ......................................... 4-151
  ROOF (DL) ............................................. 4-151
POINT LOADS AND MOMENTS ................................ 4-155
  POINT (DL) ........................................... 4-156
  POINT (LL) ............................................ 4-156
  MOMENT (DL) .......................................... 4-156
  MOMENT (LL) .......................................... 4-156
  OCCUPANCY (LL) ....................................... 4-159
  MIN ROOF (LL) ........................................ 4-162
## CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNOW LOADS</td>
<td>4-164</td>
</tr>
<tr>
<td>WIND LOADS</td>
<td>4-169</td>
</tr>
<tr>
<td>SEISMIC LOADS</td>
<td>4-176</td>
</tr>
<tr>
<td>EARTH LOADS (NOT IMPLEMENTED)</td>
<td>4-183</td>
</tr>
<tr>
<td>TEMPERATURE LOADS (NOT IMPLEMENTED)</td>
<td>4-183</td>
</tr>
<tr>
<td>MAT'L MENU</td>
<td>4-184</td>
</tr>
<tr>
<td>CONCRETE</td>
<td>4-184</td>
</tr>
<tr>
<td>MASONRY</td>
<td>4-184</td>
</tr>
<tr>
<td>STEEL</td>
<td>4-184</td>
</tr>
<tr>
<td>WOOD</td>
<td>4-184</td>
</tr>
<tr>
<td>SURFACE/LINEAR MENU</td>
<td>4-185</td>
</tr>
<tr>
<td>COLUMN/WALL MENU</td>
<td>4-188</td>
</tr>
<tr>
<td>DESIGN MENU</td>
<td>4-190</td>
</tr>
<tr>
<td>PRELIMINARY</td>
<td>4-190</td>
</tr>
<tr>
<td>LATERAL RESISTANCE</td>
<td>4-223</td>
</tr>
<tr>
<td>LATERAL RESISTANCE INPUT FILE</td>
<td>4-230</td>
</tr>
<tr>
<td>COMPARE MIN ROOF LL &amp; SNOW LOAD</td>
<td>4-232</td>
</tr>
<tr>
<td>COMPARE WIND &amp; SEISMIC</td>
<td>4-234</td>
</tr>
<tr>
<td>QUANTITY TAKE-OFF</td>
<td>4-235</td>
</tr>
<tr>
<td>MODELING</td>
<td>5-1</td>
</tr>
<tr>
<td>SIMPLIFY THE GEOMETRIC MODEL</td>
<td>5-1</td>
</tr>
<tr>
<td>MAKE SURE PLANES ARE IN CONTACT.</td>
<td>5-1</td>
</tr>
<tr>
<td>DO NOT INTERSECT SHAPES</td>
<td>5-1</td>
</tr>
<tr>
<td>PLANE AND COLUMN SHAPES VS. CUBE SHAPE</td>
<td>5-2</td>
</tr>
<tr>
<td>LINE UP THE EDGES OF THE SHAPES</td>
<td>5-3</td>
</tr>
<tr>
<td>CREATING FLOOR PLANES</td>
<td>5-3</td>
</tr>
<tr>
<td>MODELING ONE- AND TWO-STORY SPACES</td>
<td>5-4</td>
</tr>
<tr>
<td>CREATING STRUCTURAL BAYS</td>
<td>5-5</td>
</tr>
<tr>
<td>MODELING OVERHANGS</td>
<td>5-5</td>
</tr>
<tr>
<td>RELATIONSHIP OF SHAPE TO GROUND PLANE ANGLE</td>
<td>5-6</td>
</tr>
<tr>
<td>USE OF HIDE SHAPE AND SHOW SHAPE</td>
<td>5-8</td>
</tr>
<tr>
<td>VERIFYING THE MODEL</td>
<td>5-8</td>
</tr>
<tr>
<td>INCLINED OPEN ROOFS</td>
<td>5-9</td>
</tr>
<tr>
<td>DRAW STRUCTURE</td>
<td>6-1</td>
</tr>
<tr>
<td>STRUCTURAL PLANES</td>
<td>6-1</td>
</tr>
<tr>
<td>LINEAR ELEMENTS</td>
<td>6-1</td>
</tr>
<tr>
<td>DRAWING SURFACE AND LINEAR ELEMENTS</td>
<td>6-2</td>
</tr>
<tr>
<td>COPY STRUCTURE</td>
<td>6-2</td>
</tr>
<tr>
<td>STRUCTURAL WALLS VS. VERTICAL PLANE SHAPES</td>
<td>6-3</td>
</tr>
<tr>
<td>GRID LINES</td>
<td>6-4</td>
</tr>
<tr>
<td>SURFACE ELEMENTS</td>
<td>6-4</td>
</tr>
</tbody>
</table>
### CONTENTS

<table>
<thead>
<tr>
<th>LOADS</th>
<th>7-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASSIGNING LOADS</td>
<td>7-1</td>
</tr>
<tr>
<td>MINIMUM ROOF LIVE LOADS</td>
<td>7-1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ANALYSIS AND DESIGN</th>
<th>8-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>MEMBER SELF WEIGHTS</td>
<td>8-1</td>
</tr>
<tr>
<td>USING ACTUAL PROPERTIES</td>
<td>8-2</td>
</tr>
<tr>
<td>RE-ANALYZING ADJOINING MEMBERS</td>
<td>8-2</td>
</tr>
<tr>
<td>E AND I VALUES</td>
<td>8-2</td>
</tr>
<tr>
<td>SURFACE ELEMENT ANALYSIS</td>
<td>8-3</td>
</tr>
<tr>
<td>COLUMN AND WALL LOAD RUN DOWN</td>
<td>8-3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SPREADSHEETS</th>
<th>9-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>SPREADSHEET FORMAT</td>
<td>9-1</td>
</tr>
<tr>
<td>PULL DOWN MENUS</td>
<td>9-4</td>
</tr>
<tr>
<td>FILE MENU</td>
<td>9-4</td>
</tr>
<tr>
<td>MEMBER MENU</td>
<td>9-5</td>
</tr>
<tr>
<td>SCRATCHPAD MENU</td>
<td>9-8</td>
</tr>
<tr>
<td>GUIDELINES MENU</td>
<td>9-8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CASM OUTPUT</th>
<th>10-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRINTING OUTPUT DIRECTLY FROM CASM</td>
<td>10-1</td>
</tr>
<tr>
<td>USE OF THE PRINT MANAGER</td>
<td>10-1</td>
</tr>
<tr>
<td>CHANGING PRINTERS</td>
<td>10-3</td>
</tr>
<tr>
<td>PRINTING OUTPUT FROM OTHER PROGRAMS</td>
<td>10-4</td>
</tr>
<tr>
<td>USING WINDOWS NOTEPAD PROGRAM</td>
<td>10-4</td>
</tr>
<tr>
<td>USING WINDOWS WRITE PROGRAM</td>
<td>10-5</td>
</tr>
<tr>
<td>USING WINDOWS DRAW OR DESIGNER PROGRAMS</td>
<td>10-6</td>
</tr>
<tr>
<td>USING CASM .DXF FILES IN AUTOCAD</td>
<td>10-8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ADDITIONAL CASM PROGRAMS</th>
<th>11-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>BMWT</td>
<td>11-1</td>
</tr>
<tr>
<td>FRAME</td>
<td>11-2</td>
</tr>
<tr>
<td>LOADS</td>
<td>11-2</td>
</tr>
<tr>
<td>ICONS</td>
<td>11-7</td>
</tr>
<tr>
<td>XGLUT</td>
<td>11-7</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>TROUBLE SHOOTING</th>
<th>12-1</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRECAUTIONS</td>
<td>12-1</td>
</tr>
<tr>
<td>ERROR MESSAGES AND CORRECTIVE ACTIONS</td>
<td>12-1</td>
</tr>
<tr>
<td>WINDOWS FATAL ERRORS</td>
<td>12-2</td>
</tr>
<tr>
<td>CASM FATAL ERRORS - PROGRAM TERMINATES</td>
<td>12-2</td>
</tr>
</tbody>
</table>
## CONTENTS

### WHAT TO DO IF SOMETHING IS WRONG

12-4

### Appendix A: TRADEMARKS

A-1

### Appendix B: CASM FILE CONTENTS

B-1

### Appendix C: MATROX INSTALLATION

C-1

### Appendix D: SAMPLE OUTPUT

D-1

- Design Criteria Output Example .................................. D-2
- Snow Load Output Examples ........................................ D-4
- Wind Load Main Force Resisting System Output Examples ..... D-6
- Wind Load Components and Cladding Output Example ........ D-9
- Wind Load Open Enclosure Output Example ........................ D-10
- Minimum Roof Live Load Output Example ........................ D-11
- Structural Analysis And Design Output Examples ............. D-12
- Lateral Resistance Element Output Example ..................... D-16
- Seismic Output Example .............................................. D-21
- Quantity Take-Off Output Example: ................................. D-24
WHAT IS CASM?

First of all, CASM stands for Computer Aided Structural Modeling. It is a program designed to aid the structural engineer in the preliminary design and evaluation of structural building systems by the use of 3-D interactive graphics. Think of this program as a scratch pad for the structural decision process that would have been done on paper before you went to the computer to do the final numerical analysis of structural members. CASM will let you change your mind quickly and give you results that previously might have taken hours to obtain. By allowing quick changes, CASM allows you to make more informed decisions in the initial structural evaluation process.

CASM VERSION 5.00

This release of CASM following phase G of its development is designed to help you with design criteria, building loads, and structural framing. For instance, CASM will let you calculate building loads, both dead and live loads, for different areas of the building by looking up loads from a predefined table of values. CASM will also let you develop and display snow, wind, and seismic loads for your 3-D structural model. You may use these values, or create your own, to add to the load total. You may assign these loads to preliminary structural framing plans in order to evaluate different framing schemes for selection of the best preliminary solution for final design and in-depth analysis. This version of CASM provides you with several convenient programs. First a beam analysis program is provided for developing shear, moment, and deflection diagrams for beams with a variety of loading (including pattern loads and live load reductions) and a variety of connectivity (including continuous beams). Second a truss analysis program is provided where you can quickly designate a truss geometry and analyze it based on applied loads defined in CASM. A column load run down routine is provided to total up CASM applied loads to a column at all levels and provide a total summary of loads on the designated column. You can do lateral analysis with flexible or rigid diaphragms on braced and unbraced frames or shear walls with or without openings. After you have assigned member sizes, you can do quantity take-offs for a comparison of different framing schemes. Data for all your preliminary schemes can be edited, printed, and used as justification for your preliminary solutions.

You have two options for displaying the CASM 3-D interactive graphics. If you currently have an EGA or a VGA graphics system, you may display the CASM model as a 16-color or 256 color wireframe or solid fill on your graphics screen. If you purchase a Matrox SM graphics card and a high-resolution monitor, you can display the CASM model as a 256-color, shaded, solid model on the high-resolution monitor. Although the screen response of the CASM model with the Matrox graphics card is significantly faster, the VGA graphics display is the recommended system. A brief description of the MATROX graphics card installation and use is contained in
Appendix C. Please refer to the installation section in this guide for a list of hardware components that you will need for the program.

A complete listing of the CASM program files is contained in Appendix B. In addition a CASM Tutorial Guide has been developed to provide you with illustrated examples and detailed procedures for using CASM for Structural Design.

PROJECT HISTORY

The CASM project grew out of a desire by the US Army Corps of Engineers to have a simple structural engineering modeling system that engineers could use to try out their design ideas without doing extensive calculations and looking through several separate manuals of data. This program would be a trial-and-error, flexible, easily repeated process that the engineer could change at will and get feedback from the computer directly on the screen. The task of analyzing what decision paths the structural engineer used was given to Professor David Wickersheimer of the University of Illinois and President of Wickersheimer Engineers, Inc.

With the study of the structural engineering process completed, the Army awarded Wickersheimer Engineers a contract to produce such a program. The CASM team consists of David Wickersheimer, Gene McDermott and Carl Roth. Initially it was a three-year, three-phase contract to produce a usable program that will be an interactive program with a 3-D graphics display of the building geometry and structure. The third phase was completed December 31, 1989. Copies of the program (version 1.0) were distributed to several groups for testing and evaluation. Completed sections of the program were being used for developing wind and snow loads.

Regular meetings at select intervals with the Building Systems Task Group of the Computer Aided Structural Engineering (CASE) Project resulted in minor scope changes and a prerelease non-graphic version (0.1) to acquaint potential users with the program. Version 1.0 which was released at the end of the third phase, permitted the user to develop load lists, snow, wind, and minimum live loads and apply the loads to a preliminary structural framing system. The user then could select a member from the framing system and develop shear and moment diagrams. Four new phases were awarded to allow enhancements which were implemented in the following three years. The last phase G completed in September of 1993 provided the user with the full range of options originally planned for the program.
INTRODUCTION

PURPOSE

The purpose of this manual is to help you understand the CASM program. The CASM program is designed by structural engineers for structural engineers. Its purpose is to help solve those basic early problems that all engineers face when trying to fit a structural system into a building.

This release marks the end of phase G in the development of the program (Version 5.00). The areas that are addressed in this program include:

Basic Design Criteria. This section has a wide range of features that are useful in preparing regional data, site-specific data, and also building-specific data for a new project. Once entered, this data can be saved and re-used for future projects.

Building Geometry and Structural Layout. You can use computer 3-D building blocks to quickly model the building geometry. After you have created the building geometry, you can experiment with different structural framing plans to select the optimum framing plan for your building.

Dead and Live Loads. How many times do you find yourself flipping through the same old manuals trying to locate the weight for materials or occupancy? Here you will be able to pick and choose from pre-compiled lists and then total them to create reports. You may also edit the lists and enter your own weights for materials.

Snow, Wind, and Seismic Loads. The program quickly calculates these values for the building geometry that you create on the screen. Make some changes to your design model, and recalculate the snow, wind, and seismic loads for comparison. The program calculates load data quickly so that you can use it to make better decisions about your building.

Member Analysis and Preliminary Sizing. The CASM program allows you to apply both gravity and lateral loads to your building geometry from the list of load cases that you created. You may then use an analysis program for beams, frames, or trusses in combination with spreadsheets to quickly determine a preliminary size for the structural members. Based on this preliminary information, you can quickly evaluate several structural schemes and do quantity take-offs.

When you begin using the CASM program, you will see that it is quite comprehensive. Follow the directions given in this guide to get started.
PROGRAM USER GUIDES

There are six CASM guides provided for your use. The CASM User's Guide provides you with information for installing the program, a general overview covering its use, a detailed reference of each of the commands, and a trouble-shooting section. The CASM Tutorial guide describes the CASM methodology and takes you through all the structural design features of the program including a series of example design problems that have been taken from the appendixes of Load Assumptions for Buildings, Technical Manual (TM) 5-809-1/Army Field Manual (AFM) 88-3. CASM Schemes A, B, and C are three tutorial guides that were developed to permit exploration and instruction of the broadest possible range of CASM capabilities. The CASM Quick Reference is a one page abbreviated guide with instructions for installing, starting, and exiting CASM and a list of CASM menus and icons.

Chapter 1, Introduction, gives general information about the CASM program.
Chapter 2, Installation, shows you how to install the CASM program on your computer.
Chapter 3, Program Overview, presents the basic program operation of CASM.
Chapter 4, Reference, provides a description for each command in the CASM program and use of Excel spreadsheets.
Chapter 5, Modeling, provides the user with hints, options, and ramifications with regard to use of the 3-D modeling process.
Chapter 6, Draw Structure, provides the user with hints, options, and ramifications with regard to use of drawing structures.
Chapter 7, Loads, provides the user with hints, options, and ramifications with regard to assigning and computing loads.
Chapter 8, Analysis and Design, provides the user with hints, options, and ramifications with regard to performing analysis and design.
Chapter 9, Spreadsheets, provides the user with hints, options, and advice with regard to using the CASM Excel spreadsheets.
Chapter 10, Output Format, gives advice for combining text and graphics from CASM for final documentation.
Chapter 11, Additional CASM programs, gives advice for using the additional programs packaged with CASM.
Chapter 12, Troubleshooting, gives advice for problems with the computer and CASM.

The appendixes present other miscellaneous information including Trademarks (Appendix A), Disk File Contents (Appendix B), Matrox Installation (Appendix C), and Sample Graphics (Appendix D).

This guide ends with an Index, which we have made every effort to make as complete as possible.
Chapter 1, *CASM Philosophy*, describes the intent of the program in aiding in the structural decision-making process.

Chapter 2, *Design Criteria*, shows you how to select and enter project criteria data.

Chapter 3, *Loads*, shows you how to use the CASM load generation and application features for dead, live, wind, and snow loads. Examples from TM 5-809-1 are used.

Chapter 4, *Structural Analysis and Design*, shows you how to use CASM to generate preliminary structural framing schemes; shows you how to use the preliminary analysis feature of CASM for generating shear, moment, and deflection diagrams; and shows you how to use the Microsoft Excel spreadsheet to select preliminary member sizes based on the preliminary analysis data.

Chapter 5, *Seismic Forces*, shows you how to use the CASM seismic load generation and application features for seismic loads based on the equivalent static force method.

Chapter 6, *Quantity Take-Off*, demonstrates the procedures incorporated in CASM to accumulate quantities appropriate for preliminary cost estimating.

Scheme A is a building project example of a one and two-story non-composite steel frame building with rigid frames to resist lateral loads. Flowcharts are provided to guide you through each of the steps. Graphic illustrations and samples of graphics and text output are included to permit you to verify your output. The scheme should not be viewed as completely logical structural framing solution to the given design parameters, nor as necessarily economical. The scheme contains a variety of elements, which if properly combined and interchanged might produce "real" schemes for consideration at a 35% review. Refer to the User's Guide or the Tutorial for more detailed information on commands used in Scheme A.

Scheme B is a building project example of a one and two-story composite steel frame building with x-braced frames to resist lateral loads. Flowcharts are provided to guide you through each of the steps. Graphic illustrations and samples of graphics and text output are included to permit you to verify your output. The scheme should not be viewed as completely logical structural framing solution to the given design parameters, nor as necessarily economical. The scheme contains a variety of elements, which if properly combined and interchanged might produce "real" schemes for consideration at a 35% review. Refer to the User's Guide or the Tutorial for more detailed information on commands used in Scheme B.
Scheme C is a building project example of a one and two story monolithic concrete building with shear walls to resist lateral loads. Flowcharts are provided to guide you through each of the steps. Graphic illustrations and samples of graphics and text output are included to permit you to verify your output. The scheme should not be viewed as completely logical structural framing solution to the given design parameters, nor as necessarily economical. The scheme contains a variety of elements, which if properly combined and interchanged might produce "real" schemes for consideration at a 35% review. Refer to the User's Guide or the Tutorial for more detailed information on commands used in Scheme C.

**Quick Reference**

**Installation** - Brief steps for installing CASM.

**Start** - Brief sequence for starting the program.

**Saving** - Brief sequence for saving project files.

**Output** - Brief sequence for printing output.

**Exit** - Brief sequence for exiting the program.

**List of Commands and Icons**

---

*For the Beginning User*

For the beginning user, we assume no experience with Microsoft® Windows. At this point we suggest that you may want to become familiar with Windows by installing it on your computer and reviewing chapters 1 through 6 of the Microsoft Windows User's Guide. You will want to know more about Windows because CASM is a Windows application program which uses many of the Windows conventions.

Available from Microsoft is a Productivity Pack for Windows which provides new users with a tutorial for learning Windows. Also included is a Quick Troubleshooting program and a Working Smarter program to aid users in optimizing the performance of Windows.

The installation section of this guide provides you with guidance for installing CASM. Once you have installed CASM, the Program Overview section will provide you with a preview of all the primary CASM command sequences. The Reference section of this guide provides you with detailed descriptions for each of the CASM commands. You may then proceed to the "Tutorial Guide" to learn how to use CASM.

---

*For the Advanced User*

For the advanced user, we assume that you have a working knowledge of Microsoft Windows and that it is already installed on your computer. The installation section of this guide will show how to install CASM, after which you should review the Overview section before beginning with the "Tutorial Guide". Use the Reference section in this guide to learn more about any of the CASM commands.
CONVENTIONS USED IN THIS MANUAL

For the beginning CASM user, there are many terms and symbols used in this guide and the tutorial guide that you may not understand. The following definitions of terms and symbols are provided to help you understand the guides.

Many additional notes and reminders are used in these guides. These include:

[ENTER] - word in brackets indicates single key entry.

[KEY1] + [KEY2] - A plus sign (+) between keys means to hold down the first key while you press the second key, then release both keys.

Bold - Words or phrases in bold in command sequence steps indicate keyboard input that must be typed exactly as it appears.

Italic - Words or phrases in italics in command sequence steps indicate keyboard input which represents actual input that you provide instead of the word shown in italics.

Press - Words or phrases underlined in command sequence steps indicate specific user actions.

>> NOTE: - indicates additional information about a specific function or feature in the program.

WARNING! - indicates where caution should be used to ensure that you do not lose data!

Tab Key symbol. Look for this symbol on top of the key when you are directed to use the TAB key to select dialog window commands.

Cursor Direction Keys - Four keyboard keys with up [↑], down [↓], right [→], and left [←] arrows printed on top of the keys. Allow you to position the screen pointer or cursor.

>> The cursor direction keys can be used in combination with the mouse to make final incremental movements of selected objects. The up [↑] and down [↓] cursor keys drag in the north-south direction. The left [←] and right [→] cursor keys drag in the east-west direction. Hold down the [Alt] key while pressing the up [↑] or down [↓] cursor keys to drag vertically. The [Enter] key equals the left mouse key (select). The [Esc] key equals a double click right mouse key (cancel).
The following items specifically address actions with the mouse:

Click - To quickly press and release the mouse button. Placing the mouse pointer on an item and clicking the \textit{left} mouse key is used primarily for selecting items on the screen.

Double Click - Place the mouse pointer on an item and press the mouse key twice in quick succession, less than a second pause between presses. If the pause is too long the double click may not produce the desired result.

- Double clicking the \textit{left} mouse key is used to select and initiate an action. For example, placing the mouse pointer on a list of project files and double clicking the \textit{left} mouse key will automatically open the project file without having to move the mouse pointer to the Open command box and pressing the mouse key again.

- Double clicking the \textit{right} mouse key is used to exit (cancel) a CASM command sequence. For example, to exit the Add Shape mode, you must double click the \textit{right} mouse key.

Drag - To hold down the mouse key while you move the mouse.

- Holding down the \textit{left} mouse key will move application windows on the screen. For example, place the mouse pointer on an application title bar then press and hold the \textit{left} mouse key while moving the mouse will relocate the application window on the screen.

- Holding down the \textit{right} mouse key will drag a shape vertically. For example, to move a shape vertically, when placing shapes on the screen press and hold the \textit{right} mouse key and move the mouse away from you to move an object up.

- The cursor direction keys can be used in combination with the mouse to make final incremental movements of selected objects.

- Function keys F2 and F3 can be used to move selected objects instead of “dragging the mouse”. Function key F2 permits you to activate the keyboard for coordinate input. Function key F3 permits you to activate the keyboard for entering translated dimensions or coordinates.

Point - By moving the mouse, locate the pointer symbol on the screen until the tip of the pointer rests on the item of choice.

- Users who are unfamiliar with the use of the mouse often have difficulty using it. To aid first-time users, the CASM Settings command under the CASM File pull-down menu permits you to adjust the sensitivity of the mouse for drag and selection of handles within CASM. To adjust the mouse for all other operations, use the mouse settings in the Windows Control program.
The following definitions define a few of the terms in this guide that you may not be familiar with.

Handle - A colored dot which will appear on planes, edges, or elements when you select an edit command. You must place the mouse pointer on the handle and press the left mouse key to select the element and move it or modify it.

Icon - A graphic representation for various elements in CASM and Windows. Icons are used to represent CASM commands and Windows program applications.

Path - A designation for the location of files or directories on your hard drive. For example, c:\window\user is the path to the \user subdirectory of the \window directory on drive c:.

Select - To mark an item by highlighting it with key combinations or by pointing to it with the mouse pointer and clicking it with the mouse. Selecting an item may or may not initiate an action. If the action is not automatic after selecting an item, there are action blocks which you must point to and click on before action occurs.

Tool Palette - Collection of graphic icons which represent specific CASM commands. Selecting an icon from the tool palette will highlight the icon and initiate a command sequence.

>> The Tool Palette icons are not visible on the single screen version of CASM unless you move the pull-down menus.

Window - A rectangular area displayed on the monitor screen that contains a program display or message. Windows can be opened and closed, re-sized and moved. You can open several at one time or you can shrink them to icons or enlarge them to fill the whole screen.

Because the CASM program will respond to keyboard entries or mouse inputs and the CASM program can be displayed on one screen or two screens, the following symbols are included in the guide to help you find the command sequence or display comments appropriate to your hardware configuration.

Mouse symbol - indicates commands and/or procedures activated by the mouse input device.

Keyboard symbol - indicates commands and/or procedures activated by keyboard keys.
PACKING LIST

You should have three 1.2Mb, 5-1/4-inch floppy disks that contain the CASM program and three guides, a User's Guide (this guide), a Tutorial Guide, and a Quick Reference Guide. If you do not have all these materials, you can call or write the Engineering Computer Programs Library at:

Commander and Director
US Army Engineer Waterways Experiment Station
3909 Halls Ferry Road
Vicksburg, MS 39180-6199
(601) 634-2581

Appendix B contains a detailed listing of the diskette contents.

MINIMUM PROGRAM REQUIREMENTS

To use CASM you will need the following minimum requirements:

An IBM AT (286) computer or compatible which runs at 12Mhz. Although the program will run on a 286 computer we strongly recommend that you use a 386 computer. The size and complexity of this program combined with Microsoft Windows makes for a lot of calculations for the computer, especially if you are using the single-monitor configuration.

MS-DOS 3.1 or greater.

1.0 MB of memory (RAM) to run Windows 3.0 in the standard mode. To run Windows 3.x in the 386 enhanced mode you will need 2.0 Mb of memory. The single-monitor configuration will require more memory for large projects. The ideal minimum memory for the best performance of Windows 3.x and CASM is 3.0 Mb.

1.2MB Floppy Disk Drive. Currently CASM files are distributed on 1.2MB floppy disks.

80MB Hard Disk Drive. CASM will require 6 to 8 Mb of free disk space.

Microsoft Windows, Version 3.0 or above. Windows 3.1 is recommended.

Microsoft EXCEL, Version 3.0 or above. EXCEL is a spread sheet program which can be used to provide a preliminary size for selected structural members. CASM also provides an output text file of design information which can be used with other spreadsheet programs to determine a preliminary member size.
A mouse that is compatible with Microsoft Windows. A partial list of pointing devices that work with Microsoft Windows includes:

- Microsoft Mouse (either bus or serial port version)
- Mouse systems Mouse (connected to serial port Com1 or Com2)
- Logitech Logimouse (bus or serial)
- Digitizing Tablets (Most either have a mouse emulation mode or Windows drivers. These are not necessary for CASM, but you can use one if you already have it.)

Other devices are always being developed and made available. If you have a particular mouse or pointing device that is not listed here, refer to the Microsoft Windows documents for a more detailed list. If your device does not appear on that list, contact the device manufacturer to see if they provide a Microsoft Windows software driver for the device. Most manufacturers will supply the necessary software driver free of charge and often include it with the item.

A monitor (color or monochrome) with an adaptor card. A VGA board and monitor will give you the best color and resolution for the single-monitor display option. An EGA-compatible monitor will also work as a color monitor for the single-monitor system. A Hercules® compatible monochrome monitor would be acceptable as an inexpensive primary monitor for the dual-monitor display option (please refer to the high-resolution option discussed later in this section). We do not recommend a CGA-compatible monitor, either for the single-monitor system or as the primary monitor for a dual-monitor system, because of the poor resolution.

A printer (and a plotter as an option). Windows supports a number of dot-matrix printers, laser printers, and plotters on the market. A list of printers can be seen in the "Installation" section of the "Control Panel" program that comes with Windows. Please refer to the Microsoft Windows documentation for more printer information. A partial list of printers includes:

- Epson FX-80
- Epson LQ-1500
- IBM Graphics
- Okidata 92/93 (IBM or Std)
- Hewlett-Packard LaserJet
- HP 7470A Plotter
- HP 7550A
- Xerox 4020
- Apple LaserWriter
- Epson MX-80
- Any printer that can emulate Epson graphic commands
- IBM Proprinter
- Okidata 192/193 (IBM or Std)
- HP LaserJet +
- HP 7475A Plotter
- HP ThinkJet (2225 C - D size)
- Any PostScript Laser Printer
- Any Generic, Text-Only printer
MINIMUM PROGRAM REQUIREMENTS

Extended Memory. New versions of Windows, the Excel spreadsheet, and this program require a lot of memory. You may experience problems running all these programs with only 1.0 Mb of memory. Three megabytes of memory would be ideal for your CASM system—one megabyte of conventional memory and two megabytes of extended memory.

Windows 3.x utilizes extended memory more efficiently than expanded memory.

WARNING! The Matrox software supplied with the graphics card utilizes memory address locations 0C6000 to 0C63FF in the 384Kb memory segment from 640Kb to 1.0Mb. Some expanded memory software may also try to access the same memory segment, which will lock up the computer. If you have a Matrox graphics card and expanded memory, you will need to verify that the memory address locations 0C6000 to 0C63FF are protected for Matrox use. Use the EMMTEST.EXE program provided on Disk 1 to test for a memory conflict (see Appendix B).

Windows Draw by Micrografx®. The CASM program will dump screen displays directly to the printer. However, if you wish to edit and enhance the screen display, you may copy it to the Windows Draw program. This is a simple 2-D graphics program that lets you edit screen dumps generated by the CASM program. It is an object-oriented CAD program similar to Autocad®, but not as complex.

Designer by Micrografx®. The CASM program will dump screen displays directly to the printer. However, if you wish to edit and enhance the screen display, you may copy it to the Designer program. This is a graphics program similar to Windows Draw but offers more advanced procedures including graphics for Desktop Publishing and Technical Illustration. The program will read and display the graphic output files from CASM.

CASM also provides graphic output files in a DXF format which can be read by AutoCAD and other programs capable of reading the DXF format.

Microsoft Productivity Pack for Windows. A valuable guide to the Microsoft Windows environment. It provides three products in one. Learning Windows is a set of tutorials that make learning Windows easy and fun. The Quick Troubleshooter is a program which helps the user diagnose problems with Windows easily. The Working Smarter program provides tips and hints for working within the Windows environment.

Dual Monitor Display Option. The dual monitor option will require the use of two monitors and two graphic cards. The single monitor display is similar to the dual monitor display, however the dual monitor display is faster. The primary monitor which displays Windows can be any of the required monitors and boards. The monitor displaying the high-resolution, solid, 3-D structural model will require the following equipment:

1. A Matrox SM-1024 or SM-1281 graphics board. This special graphics card produces 3-D solid, shaded images. It will allow you to move and
change the building shape and structure in either solids or wireframe interactively. This graphics board gives you the power to alter the building with a minimum delay because the graphics board calculates all the coordinate information instead of burdening the computer memory with the calculations. The cost of the Matrox SM graphics card is approximately $5,000. It requires two adjoining 16-bit slots in the computer and it will work with most 80286, 80386, and 80486 computers. Refer to the Troubleshooting section of this guide for information about possible incompatibilities between the Matrox card and computer.

WARNING! The Matrox software supplied with the graphics card utilizes memory address locations 0C6000 to 0C63FF in the 384Kb memory segment from 640Kb to 1.0Mb. Some expanded memory software may also try to access the same memory segment, which will lock up the computer. If you have a Matrox graphics card and expanded memory, you will need to verify that the memory address locations 0C6000 to 0C63FF are protected for Matrox use. Use the EMMTEST.EXE program provided on Disk 1 to test for a memory conflict (see Appendix B).

The CASM Matrox graphics driver was developed using the Matrox SM-1024 graphics board. The graphics driver has not been tested and may not work with the newer Matrox SM-1024C or SM-1024CV graphics boards. Upgraded graphic drivers can be provided.

2. A high-resolution monitor. The Matrox graphics board requires a high-resolution, large-screen monitor to display the graphics. The monitor should also accept RGB analog signals. Here your selection for a monitor is more restricted because of the high resolution. A few monitors that may work with the Matrox graphics boards include:

<table>
<thead>
<tr>
<th>Monitor</th>
<th>MATROX Board</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>NEC Multisync XL</td>
<td>SM-1024</td>
<td>1024x768</td>
</tr>
<tr>
<td>Mitsubishi 9918</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
<tr>
<td>Mitsubishi 6600</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
<tr>
<td>Mitsubishi 6905</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
<tr>
<td>Hitachi 4115</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
<tr>
<td>Hitachi 4119</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
<tr>
<td>CDU 1964</td>
<td>SM-1281</td>
<td>1281x1024</td>
</tr>
</tbody>
</table>

The above monitors range in price from about $2000 to almost $4500! Always double check the specifications of these and any other monitors that you may be considering. Its worth the extra time to prevent a costly mistake.

WARNING! We do not guarantee the compatibility of all the monitors listed. We have used only the NEC Multisync XL and the MATROX SM-1024. Please contact your Matrox Dealer or Matrox directly for more information on monitors.

3. A cable to connect the monitor and the graphics board. The Matrox SM-1024 has a DB-9 pin female connector that carries the RGB signals. Most monitors today also have DB-9 connectors, but some have BNC connec-
tors. Please check your monitor to see which type of connector it is so you can order the correct one or have one made at your local computer store. The cable that comes with the NEC Multisync works!

Consult the MATROX manual and "Read.me" files for procedures on installing the MATROX card and downloading the LIB shell from the hard drive to the memory on the graphics card. We provide you with an abbreviated MATROX installation checklist in Appendix C of this guide. We also provide you with a sample download program (xgdownl.bat) to help you download the shell. You may need to edit the program for your own use.

PROGRAM INSTALLATION

The following steps provide information for setting up the Windows program and CASM program on your computer by loading program files onto your hard disk. In addition, steps are provided to speed up access to the project files.

Make a backup copy of your disks !!!!!!!!!!!!!

At this time we urge you to make backup copies of your CASM disks. Some users have experienced the horrible feeling of their hard disks dying. Don’t let it happen to you! Also, remember to make backups of your project files daily on a floppy diskette.

Set up Windows on your computer

Microsoft provides a setup routine right on the Windows disk. All you have to do is:

1. Insert the Windows Disk 1 in the disk drive you want to use for the installation and close the drive door.
2. Change to the desired installation drive by typing the drive letter followed by a colon (:) (i.e. A: then press [ENTER]).
3. Type setup and press [ENTER].
4. Follow the instructions on the screen.

The Setup routine will prompt you with instructions to complete the installation. For a more complete description, see Chapter 1 of the "Microsoft Windows User’s Guide."

You must use the Windows setup program to install Windows. Do not try to install Windows by copying files directly from the Windows disks. The files are converted to usable files during the setup process.

Set up directories for CASM and load the program onto your hard disk

We have provided a program to automatically create a CASM subdirectory on your hard disk and transfer all the files from the floppy disk onto your hard disk. This should be done after you have loaded Windows onto your hard disk. All you have to do is:

1. Make sure Microsoft Windows 3.x is loaded and is on the active path.
The Windows directory must be on the path designated in the Autoexec.bat file. If the Windows directory is not on the path, then you will either need to change the path or select the Windows directory by typing after the DOS prompt: cd \windows [ENTER].

2. Insert the CASM disk in the disk drive you want to use for the installation and close the drive door.

3. Select the RUN command from the Windows File pull-down menu.

4. Type a:setup and press the [Enter] key.

A CASM Installation dialog window will appear to help you with the installation process.

5. Verify the directory for the CASM installation is C:\CASM.

6. Verify the type of Graphics Card which you will be using. Single Screen Windows is the typical display.

The installation program will create the directory and copy all the files into the specified directory. It will make appropriate changes to the Windows WIN.INI file in the Windows directory, erase unnecessary files, and create a CASM group window with CASM icons on the Windows desktop display. Please see Appendix B for a listing of all the CASM program files.

7. Check the appropriate options.

Program files. Copies all CASM program files required to run the program.

Examples. Copies example tutorial files that you may view when doing the tutorials.

Spreadsheets. Copies all of the Excel spreadsheets that work with CASM.

If you altered any of the CASM spreadsheets, make a backup copy of them before installing CASM or do not select 'Copy Spreadsheets'.
Data Files. Copies the selected CASM Data Files required to run the program. If you altered any of the CASM default data files, de-select the files from the Select Files list to NOT install them.

Help File. Copies the online CASM help file.

Extra Files. Copies extra files which you may need. Use the Select Files box to load the Extra Files. Bitmap - Corps bitmap wallpaper. Autocad Files - Script and linetype files necessary for CASM .DIF files. SM-1024 Files - for dual monitor version of CASM.

The required and available hard disk memory is displayed at the bottom of the dialog window.

Create CASM Group. Creates a CASM group window and icons that you may use to access CASM or the spreadsheets.

If you are installing CASM 5.0 again, delete the CASM 5.0 Program Manager group or do not select ‘Create CASM Group’. If you fail to do either, all of the program icons will be repeated.

8. View the README.TXT file for new information not contained in this guide.
9. Use the mouse pointer to select INSTALL to proceed or select EXIT to not load CASM.

The install program will copy all selected files, make the appropriate changes to your WIN.INI file, erase any unnecessary files, and create a CASM 5.00 Program Manager group window.

If you have a Matrox graphics card, you will need to edit and add a batch file that will set up the Matrox graphics card.

Refer to the Matrox documentation which accompanies the graphics card. Appendix C in this guide contains an abbreviated procedure for checking the graphics board, loading the graphics software, and setting up your autoexec.bat file to load the Matrox software program which controls the graphics board.

Set up EXCEL on your computer
Microsoft provides a setup routine right on the EXCEL disk. All you have to do is:

1. Start Microsoft Windows in standard or enhanced mode.
2. Insert the disk labeled "Setup" in drive A:
3. From the Windows Program Manager File pull-down menu, select RUN.
4. Type a:setup in the Command Line box and press [ENTER].
5. Follow the Setup instructions on the screen.

The Setup routine will prompt you with instructions to complete the installation. For a more complete description, see Chapter 1 of the "Microsoft EXCEL User’s Guide."

Now you may proceed to the Program Overview chapter for instructions on how to start CASM and a brief description of how to use the program.
PROGRAM OVERVIEW

Described in this chapter are instructions on how to start the CASM program, a description of the CASM program window, a brief overview of how to use the CASM commands and the Excel spreadsheets, information on how to save your project files, and instructions for stopping the program. This chapter also briefly describes other Microsoft Windows application programs which can be used with CASM.

Microsoft Windows provides an easy method for operating the Computer Aided Structural Modeling (CASM) program. Windows is a menuing program that provides the user with a variety of program windows, pull-down menus, pop-up dialog windows, program icons (graphic representation of program names, i.e., a house for the CASM program), and the choice of using the keyboard and a mouse for data input and program control. Windows makes it easy to combine information from several programs. You may copy text or graphics from one program to another.

GETTING STARTED

In order to run the CASM program, both Windows and CASM must be loaded into subdirectories on the computer. Refer to the Installation section of this guide for instructions on installing the programs. Windows provides access to the DOS commands via the File Manager program which is on the Main group window in the Program Manager window. A detailed description of the use of the program is covered in the Microsoft Windows User’s Guide.

There are a couple of methods for starting CASM. The DOS Method of loading CASM is always available, especially if you generally use the DOS commands to access programs. The Windows Method is available whenever you are in Windows.

> CASM can only be run while Windows is in the standard or enhanced mode.

STARTING CASM: WINDOWS METHOD

You may start the CASM program through the Windows program. After turning on the computer, the sequence for starting Windows is:

1. Start the Windows program by typing after the DOS prompt:

   win [ENTER]

   WIN is the name of the primary Windows executable file, WIN.COM. By typing WIN, the Windows program will be loaded in the computer memory and displayed on the monitor.

> The Windows directory must be on the path designated in the Autoexec.bat file. If the Windows directory is not on the path, then you will either need to change the path or select the Windows directory by typing after the DOS prompt:

   cd \windows [ENTER]
If the Windows subdirectory has been given another name, then enter that name in place of 'windows' in the above line.

The Windows program will be loaded into the computer memory. An hourglass symbol will be displayed on the screen until the program has been loaded. Once loaded, the screen will look like the figure below.

The sequence for starting CASM from Windows is:

The CASM program is represented by a house icon on the CASM Application group window which is automatically generated by the installation program. If the CASM Application group window is not open, then you will need to do one of the following steps.

**CASM Group icon visible at bottom of Program Manager window:**
1. Move the mouse pointer to the CASM Group icon.
2. Double click the left mouse key. You may also press the left mouse key once to open the Control menu, then select Restore to display the CASM Group window.

**CASM Group icon and CASM Group window not visible on Windows Program Manager window:**
1. Move the mouse pointer to the Window selection on the Pull-down menu bar.
2. Press the left mouse key.
   The Windows pull-down menu will appear.
3. Look for the CASM entry on the pull-down menu.
4. Move the mouse pointer to the CASM selection.
5. Press the left mouse key.

The CASM Group window will open and display the CASM program icon (house).

To start CASM:
1. Move the mouse pointer to the CASM program icon (house).
2. Double click the left mouse key.

If you only press the left mouse key once or do not press the key twice quickly, CASM will be highlighted but will not run. You must double click the left mouse key again.

An hourglass will appear while the CASM program is loading into the computer memory. The hourglass symbol will remain on the screen until the CASM program is fully loaded. After the CASM program has loaded: The monitor will display both the program window and the ground plane. Please refer to Figure 3.1 in the CASM Program Window section.

If you have a dual-monitor system, the primary monitor (EGA, VGA, or Monochrome) will display the program window and the secondary monitor (Hi-resolution MATROX) will display the ground plane.

After the Windows and CASM programs have been installed in directories, and the AUTOEXEC.BAT path line has been modified by the installation programs, you may use the following DOS commands to activate CASM.

The sequence for starting the CASM program is:
After the DOS prompt:
1. Go to the directory where the CASM project files are located by typing:
   ```
cd \profile \> [ENTER]
```
The Windows directory must be on the path designated in the Autoexec.bat file. If the Windows directory is not on the path, then you will need to change the path.

2. **Type:** `win casm [ENTER]`
   An hourglass will appear while the CASM program is loading into the computer memory. The hourglass symbol will remain on the screen until the CASM program is fully loaded. After the CASM program has loaded, the monitor (EGA or VGA) will display both the program window and the ground grid. Please refer to Figure 3.1.

   When you start CASM, the program uses the DEFAULT.BLD file to set initial defaults. If you want to change the initial defaults, you may access the DEFAULT.BLD file, make your desired default changes, and save the DEFAULT.BLD file. We recommend that you change defaults only after you have some experience with using CASM.

3. **Load your project file by using the Open command on the CASM File pull-down menu bar.**
   You may also open the project file by typing the following line at the DOS prompt:
   
   ```
   WIN CASM filename [Enter]
   ```
   The CASM program will load into memory with the project file.
The CASM program window provides you with a variety of command menuing options. You may use the keyboard to activate the commands in the menus; however, the program is much easier to use if you have a mouse. There are two CASM Window display options depending on your hardware configuration. The single-monitor option is displayed in Figure 3.1. The single-monitor configuration is used for a single EGA or VGA graphics card and monitor. The dual-monitor configuration is used for a primary monitor consisting of a monochrome, EGA, or VGA graphics card and monitor and a secondary monitor consisting of a high-resolution Matrox SM graphics card and high-resolution, multi-sync, large-screen monitor. All of the CASM program window elements are displayed in the following figures. Following this figure are brief definitions of the program window elements.

![Diagram of the CASM Program Window](image)

**Figure 3.1. Single-Monitor System Screen Display.**
Some Definitions:

The following definitions of screen elements may be helpful as you begin to use CASM:

- The Control Menu Box is common to the Windows format. It contains commands for manipulating the program windows. Activate by the mouse pointer or by the [Alt]+[Space Bar] keys on the keyboard. Double-clicking the left mouse key with the pointer on the Control menu box will close the application window.

- The Window Size Arrows (Maximize and Minimize) permit you to expand/reduce the size of the CASM program window or change it to an icon. Activate by the mouse pointer or by the Control Menu commands Maximize, Minimize, or Restore.

- The CASM Title Bar contains the window name and the current project filename. You may use the Title Bar to move a window by placing the mouse pointer on the Title Bar; then press and hold the left mouse key while moving the mouse or use the Move command on the Control Menu.

- The Pull-Down Menu Bar contains the menu titles of the CASM command menus. Menu bar selections change based on the selected top tool palette, Draw Model, Draw Structure, and Loads and Design. Use the Change Top Tool Palette Icon to select tool palettes. Make menu selections with the mouse pointer or [ALT] + [the underlined letter key].

- The Dialog and Modeling Area is the location on the screen where the Pop-up Dialog Windows are displayed. The Modeling Area contains the display of the Ground Plane, the 3-D structural model, plans, elevations, and sections. For the dual-monitor system the Modeling Screen is located on the high-resolution monitor. For the single-monitor system the Modeling Screen is located in the Dialog and Modeling Area on the Windows display.

- Pop-up Dialog Windows in the Dialog and Modeling Area (not shown in Figure 3.1) permit you to make data selections and enter data. Move the mouse pointer to select the data/input selection box or use the Tab key to make selections and the [Spacebar] to activate the selection. Pressing the [Enter] key will save the selections and close the window. Pressing [Esc] will cancel the dialog window.

- The Side Tool Palette contains several icon groups. The Change Top Tool Palette icons can be used to change the pull down menu and the icons in the Top Tool Palette. The Viewpoint Tools can be used to change the modeling display. The File Menu icons can be used to access File pull down menu commands. The View Menu icons can be used to access View pull down menu commands.

- The Change Top Tool Palette icons are used to change the selections on the pull down menu bar and the icons in the Top Tool Palette. Three selections are available, Draw Model, Draw Structure, and Loads and Design. The Control key (Ctrl) plus a letter key can be also be used to access the three selections. [Ctrl] + D selects the Draw Model tool palette. [Ctrl] + S selects the Draw Structure tool palette. [Ctrl] + L selects the Loads and Design tool palette.
• The Viewpoint Tools on the Side Tool Palette permits you to change the
  viewer's position in relation to the structural model on the modeling screen.

• The File Menu Icons permit you to access File pull down menu commands
  without using the pull down menu.

• The View Menu Icons permit you to select model displays such as solid,
  transparent, wireframe, 3-D, elevations, plans, sections, or structural planes
  without using the pull down menu.

• The Top Tool Palette is a graphic icon selection menu of CASM commands
  for the Draw Model, Draw Structure, or Loads and Design commands. All the icon
  command selections on the Top Tool Palette are repeated on the Pull-Down
  Menu bar. Use the Change Top Tool Palette Icons to select tool palettes.

• The Bottom Tool Palette displays the command prompts and Structural Plane
  Name drop-down list. Use the Structural Name drop-down list to select
  structural planes. Several icons are located on the right side of the bottom tool
  palette. These icons are the Snap Mode icons, the Define Units icon, and the
  Tape Measure icon. These commands can be used as an aid for creating the
  structural model. The commands are also located on the Draw Model Edit and
  Layout pull-down menus.

• The Mouse Pointer is the indicator you use to select menus, commands, tools,
  icons, modes, and elements. Movement of the Pointer is controlled by the
  mouse. The pointer will change shape depending on the selected command. 
  An hourglass shape indicates that the program is processing a command and
  the pointer is temporarily not available. The vertical "I" is displayed when the
  program is waiting for text input.

• The Icon Area is the location at the bottom left corner of the VGA screen (not
  shown in figure 3-1) where icons representing active programs are stored for
  reference and ease of access. To activate a program icon, move the mouse
  pointer to the icon and double click the left mouse key. The Icon Area will not
  be visible until you Minimize or Restore the CASM window.

• The Program Manager Icon (not shown in figure 3.1) represents the Windows
  Program Manager program. It will only be displayed if the Program Manager
  program window has been minimized.

• The Ground Plane is the base plane for the structural model. A north arrow is
  located next to the Ground Plane for your reference. The ground plane grid
  spacing and size can be varied as desired.
RUNNING THE PROGRAM

Although CASM is very flexible in the creation of a structural model for load generation and analysis, there are several commands which require the completion of several modeling steps before useful data can be obtained. Also, you may develop very complex models with CASM, however you should try to keep the model simple and use only the necessary shapes to develop a model that will be useful in comparing several framing alternatives. You may want to refer to the Modeling, Draw Structure, Loads, and Analysis and Design chapters in this guide.

Use the following sequence as a guide when creating your building model in CASM. You may use either the menus or the icons to access the commands. The sequence is abbreviated, not all of the possible commands are included. Additional information on CASM commands are contained in the Reference chapter, the CASM Tutorial, and Schemes A, B, and C.

- **START THE CASM PROGRAM**
- **DEFINE PROJECT CRITERIA**
  - CRITERIA pull-down menu - Use to input project, regional, and site data.
- **DRAW MODEL**
  - DRAW MODEL tool palette - Use to generate the CASM model.
    - Use the LAYOUT pull-down menu to select:
      - Define Ground Plane to fit the dimensions of your model.
      - Define Units to control the Snap to Units option. The larger the unit value, the easier to place.
      - Initial Shape Size to input shape dimensions and/or orientation before placing them on the modeling screen.
      - Stack on Ground, Stack on Last Shape, or Stack on Plane to control placement of shapes.
    - Use the SHAPES pull-down menu to select shapes and add them to the model.
    - Use the EDIT pull-down menu to modify the dimensions of your selected shapes.
      - Drag Edge to change prism slopes.
      - Drag Plane to change shape dimensions.
      - Delete Shape to remove unwanted shapes.
      - Slice Shape to remove overlapping shapes.
      - Tape Measure to verify dimensions, slopes, and aid in accurate placement of objects.

**NOTE:** If you are creating a CASM model from Autocad drawings, load the Autocad reference files using the Import command from the CASM File pull-down menu. Then use the DRAW MODEL Reference pull-down menu to position the reference drawings. Use View Reference to turn on/off drawing layers. Use Move Reference to relocate the reference drawing on the ground plane. Use the sequence steps above to place shapes. Then use the Edit commands with the Tape Measure command to fit the shapes into the reference drawing.
COMPUTE SNOW AND WIND LOADS

LOADS AND DESIGN tool palette - Use to generate wind and snow loads.

Use the LOADS pull-down menu to select:
- Snow Load to generate snow loads on the model.
- Wind Load to generate wind loads on the model.

LAYOUT STRUCTURAL FRAMING

VIEW tool palette - Use to select structural planes.

Use the VIEW pull-down menu to select:
- Horizontal, Inclined, or Vertical Structural Plane.

DRAW STRUCTURE tool palette - Use to create a framing scheme within the model.

NOTE: You can define a structural grid in the 3-D wireframe display, however you need to select a Structural Plane in order to draw structural elements.

Use the GRID/OPENING pull-down menu to select:
- Define Grid to layout a structural grid.

NOTE: You must have a grid before you can draw structural elements. Structural elements are drawn on the grid.

- Add Main Grid Line and Add Sub Grid Line to insert new grid lines.
- Add Opening to insert floor openings.

Use the EDIT pull-down menu to select:
- Delete Grid Line or Move Grid Line
- Delete Opening or Modify Opening.

Use the SURFACE/LINEAR pull-down menu to draw surface or linear structural elements. Linear elements must be drawn before surface elements.

- Narrowly Spaced to draw joists.
- Widely Spaced to draw beams and/or girders.
- Truss - Custom to draw floor or roof trusses.
- One Way to draw surface elements on top of linear elements.

Use the COLUMN/WALL pull-down menu to draw columns, walls, and footings.

- All Grid Intersections draws columns at all grid intersections.
- One Grid Intersection draws column at each selected intersection.
- 2 Grid Points draws walls between two selected grid intersections.
- Footing, if selected, will draw a footing at the base of each wall and column.

Use the EDIT pull-down menu to select:
- Copy Structure to copy structural elements.
- Paste Structure to place copied structural elements in designated locations.
- Delete Structure to remove unwanted structural elements.
Use the LATERAL pull-down menu to define horizontal diaphragms and vertical lateral resistance elements.

- Flexible or Rigid Diaphragm defines the horizontal plane as flexible or horizontal. A label will appear in the bottom right corner of the screen.

>> NOTE: Before selecting lateral resistance elements, you need to draw structural elements on all levels in order to transfer gravity loads to the lateral resistance elements.

- Define Location permits you to locate lateral resistance elements.
- Define Elements permits you to define bracing, rigid frame, and openings in shear walls.

DEFINE LOADS

VIEW tool palette - Use to select structural planes.

Use the VIEW pull-down menu to select:

- Horizontal, Inclined, or Vertical Structural Plane.

LOADS AND DESIGN tool palette - Use to create and assign loads.

>> NOTE: You need to select a Structural Plane in order to assign loads.

Use the LOADS pull-down menu to define and assign loads to the model.

- Floor, Wall, Ceiling, and Roof (DL) permit you to define an assembly of materials and an area load to assign to a selected area on the model.
- Occupancy (LL) permits you to define a list of occupancy live loads for your project and assign them to selected areas on the model.

Use the EDIT pull-down menu to change the assigned loads.

- Delete Load to remove an assigned load.
- Modify Load to change the location of an assigned load.

SEISMIC LOADS

>> NOTE: All applicable dead and live loads must be assigned at ALL levels before using the Seismic Load command.

Use the LOADS pull-down menu to select the Seismic Load command.

- Seismic Load to automatically generate the seismic loads on the model.

ANALYZE MEMBERS

>> NOTE: You need to select a Structural Plane in order to select and analyze members.

LOADS AND DESIGN tool palette - Use to do analysis of selected members.

Use the MATL pull-down menu to select a material.

Use the LOADS pull-down menu to select the Load Combinations.

Use the SURFACE/LINEAR or COLUMN/WALL pull-down menu to select a member.

Use the DESIGN pull-down menu to select Preliminary design.

CASM will produce a loading diagram for the selected member. Following the analysis, CASM will produce shear, moment, and deflection diagrams.
RUNNING THE PROGRAM

for the selected member. EXCEL spreadsheets can be used to select a member designation and structural properties which will be attached to the selected member.

Use the EDIT pull-down menu to copy or modify the selected member designation:

- Copy Design to copy member designations and member properties to other selected members.
- Modify Design to modify selected member designations and member properties.

LATERAL ANALYSIS

NOTE: You need to select a Structural Plane from the VIEW pull-down menu in order to select and analyze a lateral resistance system.

Note: All horizontal diaphragms must be defined and all vertical lateral resistance locations must be defined before doing a lateral analysis.

NOTE: In order to produce an accurate analysis of the selected lateral analysis system you need to assign sizes to members in the system by using Preliminary Design and the EXCEL spreadsheets for sizing members based on gravity loads. You may modify sizes by using the Modify Design command on the EDIT pull-down menu.

Use the EDIT pull-down menu to copy or modify the selected member designation.

- Copy Design to copy member designations and member properties to other selected members.
- Modify Design to modify selected member designations and member properties.

Use the LOADS pull-down menu to select the Load Combinations.

Use the DESIGN pull-down menu to select a lateral resistance system.

- Lateral Resistance to select a system for analysis.
CASM will produce a loading diagram for the selected system. Following the analysis, CASM will produce shear, moment, and deflection diagrams for the selected system.

QUANTITY TAKE OFF

NOTE: Before using Quantity Take-Off, structural members must be sized using Preliminary Design in combination with the Copy Design and Modify Design commands from the EDIT pull-down menu.

Use the DESIGN pull-down menu to select the Quantity Take-Off command.
MENUS AND DIALOG WINDOWS

CASM commands are organized into two distinct elements in the CASM window—
the Pull-Down Menu Bar and the Tool Palettes. The commands activate pop-up
dialog windows for data entry and selections.

If you want to review how to choose commands in the CASM program or enter data,
read the steps given here for the keyboard or the mouse. For complete information
on choosing CASM commands and entering data, please refer to the Reference
section following this section or refer to the CASM Tutorial.

The Pull-down menu bar displays selections for the pull-down menus on the Pull
Down Menu bar.

To make a selection with the mouse:

1. Move the mouse pointer to a menu title on the pull-down menu bar.
2. Press the left mouse key.
   The pull-down menu will appear on the screen.

3. Move the mouse pointer down the list of pull-down menu commands to the
   selection you want or put the mouse pointer on the desired tool icon.
4. Press the left mouse key to carry out the command.
To choose a command with the keyboard:

1. When the CASM window is the active window (the Title Bar is highlighted), press the [Alt] key and the underlined letter key. For example [ALT] + [F] opens the File Menu.

2. Type the underlined letter of a command on the menu to carry out the command -OR- use the up or down arrows on the keyboard to move the selection bar up or down on the command menu and press the [Enter] key to carry out the command.

If the command needs more information, a Pop-up Dialog Window will appear prompting you for additional information. See the section entitled Use of Pop-up Dialog Windows later in this discussion.

Active command selections on the Pull-down Menus are designated by black print. Selections listed in gray print are either not active due to other command or configuration selections or not implemented in this version of CASM.

There are five Tool Palettes; BOTTOM, SIDE, DRAW MODEL, DRAW STRUCTURE, and LOADS AND DESIGN. Located on the Tool Palettes are Tool Icons which are graphic representations of commands that are also located on the pull-down menus. The Tool Icons in the Tool Palettes allow you to quickly select commands without having to pull down a menu to select the command.

To display Draw Model, Draw Structure, or Loads and Design Tool Palettes:

1. Move the mouse pointer to the Change Top Tool Palette Icon on the Side Tool Palette.

2. Press the left mouse key.

   This will bring the selected Top Tool Palette window on the screen and hide the current top tool palette.

To select a command from the Tool Palette window:

1. Move the mouse pointer to the desired Tool icon.

2. Press the left mouse key.

   The selected Tool icon will be highlighted.

   A variety of responses will occur depending on which Tool icon is selected. Refer to the Reference section for a complete description of each Tool Icon.

To aid the user, the name of the Icon where the mouse pointer is located is displayed in the Command Prompt box on the Bottom Tool Palette.
An alternate method to the Tool icon is to select the same command from the pull down menus.

**To select a command from the pull down menus:**

1. Move the mouse pointer to the menu selection of the Pull-Down Menu Bar.
2. Press the left mouse key.
   This will display the Pull-Down Menu on the screen.
3. Move the mouse pointer to the desired menu selection and press the left mouse key.
   A variety of responses will occur depending on which menu item is selected.
   Refer to the Reference section for a complete description of each menu selection.

**Pop-up Dialog Windows**

Pop-up Dialog Windows will appear in the Tool & Dialog Area on the screen, after a menu command is selected, to guide you with data entries and data selections and to confirm the intended action. The Dialog Window will contain all or some of the following items: a title bar; lines of text, headings, or lists; and data input/selection boxes with a vertical or horizontal cursor bar that represents the keyboard cursor location. You may use the Tab key or the mouse to switch between boxes.

There are six types of data input/selection boxes in the Pop-up Dialog Window:

- Confirmation boxes which contain confirmation words such as OK, YES, NO, SAVE, CANCEL;
- Text boxes which are either blank or contain alphanumeric data;
- Drop down list box which is a down arrow in a box at the end of a text box. When selected a list of data will appear;
- Option buttons which are circles which are blank or contain a dot;
- Check boxes which are blank or contain an 'X';
- Data window button which is a right arrow in a box at the end of a text box.
Refer to the following general guidelines when using Pop-up Dialog Windows.

To select a data input/check box:

When the pop-up dialog window first appears, the cursor is automatically located in the first data input/check box. If the first box is a text box, you may enter data by typing it from the keyboard. If the first box is a confirmation box, you may press the [Space bar] to initiate the action/confirmation.

For other data input/selection boxes:

1. **Move** the mouse pointer to the appropriate text input/check box.
   - For some text boxes you may use the [Tab] key on the keyboard to move sequentially through the text boxes.
   - We want to caution you about using the [Enter] key when entering data in the Dialog Windows. Pressing the [Enter] key automatically accepts your entry and closes the Dialog window before you finish entering data. You may re-open the window, if necessary, to finish adding data.

2. **Press** the left mouse key.
   - For the confirmation boxes, pressing the left mouse key will confirm the action initiated by a menu command or stated by the word in the confirmation box. When a horizontal cursor is located under the confirmation box and statement, pressing the [Space bar] after the box has been selected may be used instead of pressing the left mouse key.
   - For the option button, pressing the left mouse key will add or delete a dot, which represents either a selection or non selection of the item specified. Only one option button can be selected. You may also press the [Space bar] after the button has been selected to select or deselect the option.
   - For the check box, pressing the left mouse key will add or delete an 'X', which represents either a selection or non selection of the item specified. Several check boxes can be selected. You may also press the [Space bar] after the box has been selected to select or deselect the option.
   - For the text box, pressing the left mouse key will position the vertical cursor for data entry. You may highlight a word in the text box by placing the mouse pointer on the word and double-clicking the left mouse key. Text entered from the keyboard replaces the highlighted word. You may also highlight text by placing the mouse pointer at the start of the text, press and hold the left mouse key while dragging the pointer over the text. Text entered from the keyboard replaces the highlighted text. Or you may place the mouse pointer on the text box and press the left mouse key, then use the keyboard to insert or delete text.

For a blank text box,

Position the vertical cursor at the left end of the empty box with the mouse and press the left key. Type in the appropriate entry. Do not use the [Enter] key when you have completed your entry or the dialog window will close before you finish entering data.
For a text box which already has an entry, you may:

Move the mouse pointer to the entry, press and hold the left mouse key, and
drag the pointer across the entry (or double-click the left mouse key). Release
the mouse key when the entry is highlighted. Typing in the new entry will
overwrite the old entry.

-OR-

Move the mouse pointer to any point on the current entry; press the left mouse
key and the vertical cursor will appear at the designated point on the current
entry. New characters as you type them from the keyboard will be inserted in
the current entry. Use the [Backspace] key to delete letters.

- Drop down list box, is combined with a text box. Selecting the drop down list
box displays a list of items that can be entered in the text box. Selecting an
item from the list will display the item in the text box. The item in the text box
cannot be changed by typing.

- Data window button, is combined with a text box. Selecting the data window
button displays a list of items that can be entered in the text box. Use the scroll
bars to view items not visible on the list. Selecting an item from the list will
display the item in the text box. The item can be edited or changed after entry
from the list.

For a text box that has an associated list of entries, you may:

Select an entry from the list box by moving the mouse pointer to the desired
item on the list. You may double click (press and release twice in quick
succession) the left mouse key to automatically move the item from the list to
the text box. After the item is in the text box, you may edit/modify the item by
use of the backspace key and by typing new characters.

-OR-

An alternate method is to press the left mouse key once to highlight the item.
Then move the mouse pointer to the 'OK' box and press the left mouse key to
transfer the item to the text box.
GRAPHIC DISPLAY OF MODEL

VIEWPOINT TOOLS

The Viewpoint Tools are located on the Side Tool Palette. The Viewpoint Tools can be used to change the orientation or view of the model on the modeling screen, such as viewing rotation, viewing height, and viewing distance from the center of the ground-level plane grid. Refer to the Reference section for additional information.

To rotate the model on the modeling screen:
1. Move the mouse pointer to the black arrow that points to the circle.
2. Press the left mouse key and hold it down.
3. While holding down the left mouse key, move the mouse to drag the arrow around the circle.
   When the arrow is moved, the 3-D model will rotate on the modeling screen.
4. Release the mouse key when the desired model orientation is established.

   You may also locate the mouse pointer to a new location on the circle and press the left mouse key, the black arrow will move to the new location and the model will rotate to the new orientation. You may also type in the edit box inside the circle.

To change your 3-D viewing center (initial location is designated by a plus symbol at the center of the ground plane):
1. Move the mouse pointer to the Pan icon. (3-D wireframe model must be displayed on the modeling screen.)
2. Press the left mouse key.
3. Move the mouse in the direction which you desire to move the viewing center:
   Right/Left = E-W
   Toward/Away = N-S
   Hold down right key & Toward/Away = Vertical
   When the mouse is moved, the viewing center mark on the screen will move.
4. Press the left mouse key when the desired viewing center location is established.

To pan the 2-D display (change the display vertically or horizontally on the screen):
1. Move the mouse pointer to the Pan icon. (2-D plane, elevation, or section must be displayed on the modeling screen.)
2. Press the left mouse key.
3. Move the mouse in the direction which you desire to Pan the display (right, left, away-down, toward-up)
   When the mouse is moved, the display will pan on the modeling screen.
4. Press the left mouse key when the desired view is established.
To change your viewing height:
1. Move the mouse pointer to a black arrow above or below the current height value.
2. Press and release the left mouse key to increment the viewer height up or down.

-OR-
  a. Press and hold the mouse key.
  b. Move the mouse pointer in the direction the height arrow is pointing in order to make large height changes. You may also reverse the direction of the mouse to reverse the height change.

The 3-D model on the modeling screen will be oriented to reflect the change in viewer height.

You are allowed to select a negative height value (less than zero). This will allow you to look at any structure that is below the ground plane grid. You may also enter the Height in the edit box.

c. Release the mouse key when the desired viewer height is established.

To change your viewing distance:
1. Move the mouse pointer to a black arrow to the right or left of the current distance value.
2. Press and release the left mouse key to increment the viewer distance farther or closer to the model.

-OR-
  a. Press and hold the mouse key.
  b. Move the mouse pointer in the direction the distance arrow is pointing in order to make large distance changes. You may also reverse the direction of the mouse to reverse the viewing distance change.

The 3-D model on the modeling screen will be oriented to reflect the change in viewer distance.

c. Release the mouse key when the desired viewer distance is established.

You may also enter the Distance in the edit box.

The distance tool will permit you to ZOOM IN and OUT for 2-D views.
The View Menu or View icons on the Side Tool Palette can be used to change the model display. With the View pull-down menu you can turn on or off structural displays. You can change the model view from a perspective to a plan, elevation, or section view. You can display structural planes (horizontal, inclined, or vertical). You can hide or show objects, display wireframe or solid shapes. The Full Screen selection can be used to return the model viewing height to 60 feet, viewing distance to 160 feet, and center the model display on the screen, both in 3-D and 2-D. You may also store and recall views.

To change the model display using the View pull-down menu:

1. Move the mouse pointer to the View selection on the CASM pull-down menu bar.
2. Press the left mouse key.
   The View pull-down menu is displayed.
3. Move the mouse pointer to the desired menu selection.
4. Press the left mouse key to activate the command.
   Some command selections will automatically change the model view while others will require that you select a shape or plane in order to display a different view.

To change the model display using the View icons:

1. Move the mouse pointer to the desired tool icon.
2. Press the left mouse key.
   The icon will be highlighted. Some command selections will automatically change the model view while others will require that you select a shape or plane in order to display a different view.
YOU MAY USE THE MOUSE OR THE KEYBOARD TO ENTER DIMENSIONAL DATA FOR YOUR MODEL.

The CASM Settings command on the File pull-down menu permits you to select the desired method of entering dimensional data.

With the mouse, you can drag an object (shape, plane, area, etc.) to define the desired dimensions for your model. While you drag the selected object, dimensional information is displayed in coordinate dialog windows to aid you with the final placement of the selected object. You may use the Mouse Speed control from the CASM Settings command and the Define Units and Snap to Units commands to control the dimensions during object drag. Function keys [F2] and [F3] permit you to temporarily select the keyboard mode of entering dimensional data when you are in the mouse coordinate input mode.

With the keyboard, you can enter dimensional data directly in the text boxes in the coordinate dialog windows. The dimensional changes are displayed after you select OK.

**SELECTING COORDINATE INPUT MODE**

At any time during your modeling session you may select either the mouse or keyboard coordinate input mode by using the CASM Settings command on the File pull-down menu. The default input mode when you start CASM is the last selected coordinate input mode. When using the mouse, you may temporarily access the keyboard entry mode by selecting the [F2] or [F3] function keys. In order to change coordinate input mode you will need to use the CASM Settings command on the File pull-down menu.

*Using CASM Settings command to select mouse or keyboard entry:*

1. Move the **mouse pointer** to the CASM File selection on the pull-down menu bar.
2. Press the **left mouse key**.
   
The File pull-down menu will appear.
3. Move the **mouse pointer** to the CASM Settings command.
4. Press the **left mouse key**.
   
a. You may also access the CASM Settings command by selecting [alt] + [F], then select [M] for CASM Settings.
   
The CASM Settings dialog window will appear.
5. Move the **mouse pointer** to the desired option button for the Mouse or Keyboard in the Coordinate Input section of the dialog window.
6. Press the **left mouse key** to select the desired option.
7. Select the **OK** confirmation button to exit the dialog window.

If the mouse option is selected, coordinate input will be performed by dragging the selected object with the mouse after selecting an object (shape, plane, area, etc.) and viewing the dimension values in the coordinate dialog windows.
for the desired dimension values. The [F2] and [F3] function keys will permit you to temporarily switch to the keyboard input mode for hard to place objects. If the keyboard option is selected, coordinate input will be performed by using the mouse or [Tab] key to select the desired coordinate text box in the coordinate dialog window, then entering the desired dimension value from the keyboard.

**USING THE MOUSE**

The mouse is the preferred method for entering dimensional data for your model. However, you may find that the mouse pointer or drag mode may be too sensitive to movements of the mouse and hard to control when you are trying to achieve a precise dimension. There are several commands that permit you to control the mouse more effectively.

- Selecting the Mouse icon from the Windows Control Panel icon or the Windows Main group window permits you to adjust the mouse tracking speed (speed of movement of the mouse pointer on the screen), the double click speed (time interval between clicks), and swapping the left and right mouse buttons.

- Select the CASM Settings command from the CASM File pull-down menu permits you to adjust the mouse speed for CASM drag and handle selection operations.

- Selecting the Define Units command from the Layout pull-down menu on the Draw Model tool palette permits you to select the desired unit snap increment. Then selecting the Snap to Units command on the Layout pull-down menu on the Draw Model tool palette will control the placement of model elements.

**NOTE:** The desk or table surface that you are using the mouse on can affect the control of the mouse pointer on the screen. Slick surfaces may cause erratic control of the mouse pointer.
Adjusting mouse control settings (tracking speed, double-click, button control):

1. Move the mouse pointer to the Control Panel icon in the Windows Main application group window.
2. Double click the left mouse key.
   - The Control Panel window will appear with program icons.
3. Move the mouse pointer to the Mouse icon.
4. Double click the left mouse key.
   - The Mouse dialog window will appear.

To adjust the Mouse Tracking Speed (speed of mouse pointer on the monitor screen):

1. Place the mouse pointer on the rectangle between the SLOW and FAST setting.
2. Press and hold the left mouse key to drag the box closer to the FAST or SLOW setting.
3. Release the mouse key.
4. Move the mouse to check the speed of the mouse pointer. Re-adjust the speed as necessary.

To adjust the Double Click Speed (time interval between clicks):

1. Place the mouse pointer on the rectangle between the SLOW and FAST setting.
2. Press and hold the left mouse key to drag the box closer to the FAST or SLOW setting.
3. Release the mouse key.
4. Place the mouse pointer on the TEST box and double click the left mouse key to check the interval. The TEST box will change color when you successfully double click the button. Re-adjust the speed as necessary.

To Swap the Left/Right Mouse Button:

1. Place the mouse pointer on the check box to the left of the Swap statement.
2. Press the left mouse key to swap the mouse buttons.
USE OF MOUSE OR KEYBOARD TO INPUT DIMENSIONS

PROGRAM OVERVIEW

The X in the box indicates the right mouse key is the active key. You can verify the swap by trying to grab and drag the rectangles in the speed control selections.

3. Click on OK to save your changes.

Adjusting mouse speed for CASM drag operations:

1. Move the mouse pointer to the CASM File selection on the pull-down menu bar.
2. Press the left mouse key.
   The File pull-down menu will appear.
3. Move the mouse pointer to the CASM Settings command.
4. Press the left mouse key.
   The CASM Settings dialog window will appear.

5. Place the mouse pointer on the rectangle between the FAST and SLOW setting.
6. Press and hold the left mouse key to drag the box closer to the FAST or SLOW setting.
7. Release the mouse key.
8. In order to check the CASM drag speed, you will need to exit the CASM Settings dialog window by selecting OK. Then select an object to drag on the screen and check the sensitivity of the dimension control. Re-adjust the speed as necessary.

Using Snap to Units to control coordinate placement:

1. Place the mouse pointer on the Define Units icon on the Bottom Tool Palette.
   The Define Units dialog window will appear.
2. Place the mouse pointer on the desired snap increment option button.

3. Press the left mouse key.

   **NOTE:** When dragging objects (shapes, planes, etc.), larger snap increments will permit easier placement or modification of shapes.

4. Select OK to save the selection and close the dialog window.

5. Select the Layout pull-down menu again. Verify that the Snap to Units command is on (highlighted on Bottom Tool Palette).

   If it is not on, (1) move the mouse pointer to the Snap to Units icon on the Bottom Tool Palette; (2) press the left mouse key. The Snap to Units icon will be highlighted. Whenever you drag objects, the dimension boxes will change dimensions according to the selected snap increment.

   **NOTE:** With the Snap to Units off, the snap increment is 1 inch. Exact object placement may be more difficult to achieve with the mouse with the 1 inch snap increment.

**Using the mouse to input DRAW MODEL dimensional data:**

Activating an add Shape command from the DRAW MODEL tool palette or selecting one of the Edit commands and selecting an item to edit will change the mouse pointer to the selected shape or item to edit.

A Dimensions dialog window will appear with text boxes indicating dimensions of the selected shape or selecting item.

<table>
<thead>
<tr>
<th>Dimensions</th>
<th>Roof Slopes</th>
</tr>
</thead>
<tbody>
<tr>
<td>N-S: 20'0&quot; ft</td>
<td>North: 0.00 in 12</td>
</tr>
<tr>
<td>E-W: 20'0&quot; ft</td>
<td>South: 0.00 in 12</td>
</tr>
<tr>
<td>Vert.: 20'0&quot; ft</td>
<td>East: 0.00 in 12</td>
</tr>
<tr>
<td>Ridge: 0'0&quot; ft</td>
<td>West: 0.00 in 12</td>
</tr>
<tr>
<td>Translated Distances</td>
<td></td>
</tr>
<tr>
<td>N-S: 0'0&quot; ft</td>
<td>E-W: 0'0&quot; ft</td>
</tr>
<tr>
<td>Vert.: 0'0&quot; ft</td>
<td></td>
</tr>
</tbody>
</table>
1. Move the **mouse** to drag the shape or selected object on the modeling screen.
   The dimension values in the text boxes will change as you drag the object on the modeling screen.
2. Press the **left mouse key** when the desired dimensions are displayed in the dialog window.

**NOTE:** The [F2] function key will activate the keyboard input mode for Shape Coordinate Input or Rotate Coordinate Input. Refer to the following section on Using the Keyboard for entering dimensional data in the dialog windows.

**NOTE:** The [F3] function key will activate the keyboard input mode when you are using the mouse while in the Edit Shape Coordinate Input mode. Pressing the [F3] function key will display a Translate Coordinates dialog window to permit you to use the keyboard to enter new coordinates in the text boxes in order to move the shape or selected object to the new coordinates after selecting OK. Refer to the following section on Using the Keyboard for entering dimensional data in the dialog windows.

---

**Keyboard dimensional data input for Shape Coordinates:**

The Shape Coordinate dialog window appears when you are inputting shapes, moving planes, or moving shapes. When the shape appears on the modeling screen or the selected plane or shape is highlighted, the Shape Coordinate dialog window appears on the modeling screen. Use the following methods to change coordinate data.

**ADDING SHAPES**

1. Activating an add Shape command from the DRAW MODEL Tool Palette will draw the selected shape on the modeling screen and a Shape Coordinate dialog window will appear with text boxes indicating dimensions of the selected shape.
2. Select the desired **text box** with the [Tab] key or the mouse pointer.
3. Enter the desired **dimensional data**.
   - Entries in the Dimension data boxes control the size of the shape.
   - Entries in the Centroid data boxes control the location of the shape.
   - Entries in the Roof Slope data boxes control the slope of the prism.
NOTE: Whenever you make dimensional changes to the shape, you will need to change the Centroid location in order to place the shape properly.

FOR EXAMPLE:
The following illustration demonstrates the use of entering dimensions and centroid values to place a shape on the modelling screen.

1. Enter the dimension of the shape in the dimension text boxes.
   N-S = 40 feet; E-W = 60 feet; Vert = 14 feet

2. In order to displace the shape 6 feet south, 5 feet east, and stack it on top of another 14 foot high shape the following centroid dimensions must be added:
   N-S = -6 feet; E-W = 5 feet; Vert = 21 feet

3. The vertical centroid dimension of 21 feet includes the 14 foot height of the shape below plus 7 feet to the centroid of the 14 foot high shape being stacked on the lower shape.

4. Select OK to save the shape dimensions and location and add a new shape. The next shape will be placed according to the current stack mode. The Stack on Ground Plane will use the current dimensions of the shape for the next shape.

5. Select Cancel to exit the Shape Coordinates dialog window.
EDITING SHAPES

Selecting one of the Edit commands from the DRAW MODEL Tool Palette and selecting a shape to edit will highlight the shape to be edited and a Shape Coordinate dialog window or Translate Coordinates dialog window will appear with text boxes indicating dimensions of the selected shape or selected item. The Shape Coordinates dialog window will appear when the Drag Plane or Move Shape commands are selected. The Translate Coordinates dialog window will appear when the Drag Vertex or Drag Edge commands are selected. The Translate Coordinates dialog window can also be accessed for the Drag Plane or Move Shape commands.

6. Select the desired text box with the [Tab] key or the mouse pointer.
7. Enter the desired dimensional data.
   - Entries in the Dimension data boxes control the size of the shape.
   - Entries in the Centroid data boxes control the location of the shape.
   - Entries in the Roof Slope data boxes control the slope of the prism.

   NOTE: Whenever you make dimensional changes to the shape, you will need to change the Centroid location in order to place the shape properly. You may change the Centroid location by entering dimensional data in the Centroid text boxes or by selecting the Translate Coordinates command from the Control menu on the Shape Coordinates dialog box.

Using the Translate Coordinates dialog window:
1. Place the mouse pointer on the Control Menu box in the top left corner of the Shape Coordinates dialog box.
2. Press the left mouse key.
   The Control Menu for the Shape Coordinates dialog box will appear.
3. Place the mouse pointer on the Translate Coordinates command.
4. Press the left mouse key.
PROGRAM OVERVIEW

USE OF MOUSE OR KEYBOARD TO INPUT DIMENSIONS

The Translate Coordinates dialog window will appear. You may make changes based on the Initial Coordinates of the selected object or based on Tape Measure dimensions.

```
Translate Coordinates

N-S: 0.00 ft
E-W: 0'0" ft
Vertical: 0'0" ft

- Initial Coordinates
- Tape Measure

OK Cancel
```

**NOTE:** To activate the Tape Measure option, you must initially select two vertices by using the Tape Measure command on the DRAW MODEL Edit pull-down menu. A Measure dialog window will appear displaying dimensional information of the two vertices selected.

5. If Tape Measure has been selected, select the desired option, Initial Coordinates or Tape Measure by clicking on the option button with the mouse or press the [Space bar] after selecting the option button with the [Tab] key if using the keyboard.

6. Select the desired text box with the [Tab] key or the mouse pointer.

7. Enter the desired coordinate data.

8. Select OK to exit the Translate Coordinates or Shape Coordinates dialog window and update dimensions of the selected object on the modeling screen.

9. Double click the left mouse key to exit the editing command.
SAVING YOUR WORK ON DISK

This version of CASM does not have an automatic save feature. You must use the SAVE or SAVE AS commands from the FILE pull-down menu in order to save your project files to a specified disk. The data that is saved in the project file includes load lists, criteria data, and modeling data. The file name extension .bld is automatically added to the 8-character or less project file name when the file is saved.

When the CASM program calculates the snow and wind load, all your output files for wind or snow loads are automatically saved to disk with the file name which you specify. The extension .txt is automatically added to the 8-character or less load output file name when the file is created and saved.

To SAVE the project file:

Select the Save or Save As commands from the File Menu.

1. Move the mouse pointer to the File menu selection on the Pull-Down Menu Bar (you may also use [ALT]+ [F]).
2. Press the left mouse key.
   The File Pull-Down Menu will appear.
3. Move the mouse pointer to the Save or Save As command.
4. Press the left mouse key (you may also activate the Save command by typing [S] on the keyboard or the Save As command by typing [A] on the keyboard).

If the file has been saved before:

The SAVE command automatically replaces (adds changes to) the last disk copy of the project file name displayed on the Title Bar in the CASM program window. The hourglass symbol will appear to indicate that the file is being saved to the hard disk.

If the file has not been saved before:

The label (untitled) is in the Title Bar, and you will be prompted for a file name by a pop-up dialog window. You must enter a project name before you save the file.

1. Type the desired project file name (8 characters or less). The extension .bld is automatically added to the project file name by the CASM program when you press ENTER or select OK in the pop-up dialog window with the mouse pointer.
2. Select OK with the mouse pointer and press the left mouse key to save the file (you may also press the [Enter] key to activate the SAVE command).

SAVE AS:

You may use the SAVE AS command if you do not want to replace (add changes to) the data stored under the file name displayed in the Title Bar in the CASM program window.

A pop-up dialog window will appear to permit you to enter a project file name.

1. Type the desired project file name (8 characters or less). The extension .bld is automatically added to the project file name by the CASM program.

If you enter the same name as a file that is currently stored on the disk, a pop-up window will warn you and confirm if you want to replace the file.

2. Select OK with the mouse pointer and press the left mouse key to save the file (you may also press the [Enter] key to activate the OK command).

The current project file in the CASM Title Bar will be changed to the new file name.

PRINT/CREATE OUTPUT FILES

You may print or create a variety of output files to the hard disk or floppy disks from CASM in order to provide documentation for your selection of a building system. Project criteria and load values can be printed to an output file or to a printer when you select the Print Data command on the File pull-down menu. Model views can be sent directly to the printer or be printed to an output file in a Designer or Windows Draw .PIC format or an AutoCAD .DXF format when you select the Print Screen command on the File pull-down menu. When calculating loads and analyzing members, all calculations are printed to output files in the current directory on disk. You can send the files to the printer by selecting the desired files from the Print Data dialog window.

Because output files can easily be created by CASM, we recommend you use default names as much as possible and overwrite existing output files rather than generating new output files each time.
Using Print Data command to print/create a file

1. Move the mouse pointer to the File selection on the pull-down menu bar.
2. Press the left mouse key.
   The File pull-down menu will appear.
3. Move the mouse pointer to the Print Data command.
4. Press the left mouse key.
   A pop-up dialog window will appear with options to print or create a file with project criteria and/or load data.

5. You may use the mouse pointer to check the appropriate boxes by moving the mouse pointer to the box and pressing the left mouse key. The X in the check box indicates a selected option.

   If you are saving the data to an output file you need to check the output file name in the box and change it if you desire.

   If you want to edit the file in Notepad before you print it, you may do so immediately by selecting the Execute Notepad box or you may access the file later by activating Notepad and opening CASM text files (.txt).

6. After you have made your selections, you can activate the command by pressing the [Enter] key or by moving the mouse pointer to the OK box and pressing the left mouse key.

If you are printing data to a file:
If you have selected the Execute Notepad option by checking the box, the NOTEPAD program will run with a copy of your output file. You may review the
output data, print the file from Notepad, and exit NOTEPAD using the CLOSE command on the Control pull-down menu box or the Exit command from the NOTEPAD File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the NOTEPAD program, unless you have made text changes to the file. Refer to the CASM Output section of this guide for guidance on using Notepad and Windows Write with CASM.

If you print a CASM output file from Notepad, you must set the left margin to 0.5 inch and right margin to 0.0 inch. The CASM output file is formatted to use 75 columns of the page. Use the Page Setup command from the Notepad File pull-down menu to adjust the margins.

If you make editing changes or entries to the output file while in Notepad, you must use the Save or Save As commands in the Notepad File pull-down menu to save them in the output file.

When you exit the Notepad program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file. After you exit Notepad you will be returned to the CASM Program Window.

When CASM output files are too large to load in Notepad, Windows Write may be used instead. Most analysis files are too large for Notepad.

Using Print Screen command to create a model view file
1. Move the mouse pointer to the File selection on the pull-down menu bar.
2. Press the left mouse key.
   The File pull-down menu will appear.
3. Move the mouse pointer to the Print Screen command.

4. Press the left mouse key.

A pop-up dialog window will appear with options to send the screen image directly to the printer or to create a graphic file within either a Designer or Windows Draw .PIC format or an AutoCAD .DXF format.

5. You may use the mouse pointer to check the appropriate boxes by moving the mouse pointer to the box and pressing the left mouse key. A "black dot" in the circle indicates a selected option.

   If you are saving the data to an output file you need to check the output file name in the box and change it if you desire (the default file name is CASM.PIC for the Designer or Windows Draw file and CASM.DXF for the AutoCAD file).

6. Select the page orientation as either "portrait" or "landscape".

7. If printing directly to the printer, enter the appropriate margins.

8. If writing to a Windows Draw, Designer, or AutoCAD file, select the page size.

9. If writing to an AutoCAD file, select the coordinates as screen or exact.

10. After you have made your selections, you can activate the command by pressing the [Enter] key or by moving the mouse pointer to the OK box and pressing the left mouse key.

    If you select the Designer or Windows Draw file and the Execute Designer or Windows Draw option is selected, the screen image will be automatically loaded and displayed in Designer or Windows Draw. Use the CLOSE command in the Designer or Windows Draw Control menu to return to CASM. You may also access the .PIC graphic file by Windows Draw or Designer and the .DXF file by AutoCAD after you exit CASM.
Using Snow, Wind, Seismic, or Min Roof Ld commands to create a text file

1. Move the mouse pointer to the Loads and Design selection on the pull-down menu bar.
2. Press the left mouse key.
The Loads and Design pop-up Tool Palette will appear.
3. Move the mouse pointer to the Snow, Wind, or Min Roof Ld Icon or use the Loads pull-down menu from the pull-down menu bar.
4. Press the left mouse key.
A pop-up dialog window will appear with project-specific code values and a default filename for saving the output load data after the wind, snow, seismic, or minimum roof load on the structure has been calculated.

5. You may use the mouse pointer to check the appropriate boxes by moving the mouse pointer to the box and pressing the left mouse key. Use the Data Window buttons to access dialog windows on values for Importance Factors, Exposure factors, and Thermal Factors.
6. After you have made your selections, you can activate the command by pressing the [Enter] key or by moving the mouse pointer to the OK box and pressing the left mouse key.
The load data is automatically saved to an output file. You need to check the output file name in the box and change it if you desire or leave it the same and overwrite the existing file.

To access the designated load output file:

You can access the Snow, Wind, Seismic, or Min Roof Load output files with the Windows Notepad program. To access Notepad you can use either the Print Data command from the CASM File pull-down menu or the Run command on the CASM Control menu or the Windows File Manager.

To use the Print Data command on the CASM File pull-down menu:

1. Move the mouse pointer to the File selection on the pull-down menu bar.
2. Press the left mouse key.
   The File pull-down menu will be displayed.
3. Press the [D] key to activate the Print Data command option. (You may also move the mouse pointer to the Print Data command and press the left mouse key.)
   A Print Data Application pop-up window will appear.

4. Place the mouse pointer on the box next to the output file(s) that you wish to view or print.

   You may select one, several, or all files. When you select several or all files they will automatically be combined into one file. If the file is too large for notepad, you may need to access the Windows Write program from the Run command on the CASM Control pull-down menu and load the file into Windows Write.

5. Press the left mouse key.
6. Move the mouse pointer to the Print to File check box.
7. Press the left mouse key.
8. Move the mouse pointer to the Execute Notepad check box.
9. Press the left mouse key.
10. Move the mouse pointer to the OK box.
11. Press the left mouse key. (You may also press the [Enter] key to activate Notepad.)

The Notepad window will open over the CASM window. All selected files will automatically be combined into one sequential file.

If the combined file is too large for Notepad, you will see an error message indicating the file is too large for Notepad. You may exit Notepad and reduce the number of files you want to view or access the files in Windows Write by using the Run command on the Control pull-down menu.

You may review and print the output data, then exit Notepad using the Close command on the Notepad Control pull-down menu box or Exit from the Notepad File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the Notepad program.

If you print a CASM output file from Notepad, you must set the left margin to 0.5 inch and right margin to 0.0 inch. The CASM output file is formatted to use 75 columns of the page. Use the Page Setup command from the Notepad File pull-down menu to adjust the margins.

If you make editing changes or entries to the output file while in Notepad, you must use the Save or Save As commands in the Notepad File pull-down menu to save them in the output file.

When you exit the Notepad program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file.

The CASM window will automatically re-appear when you exit Notepad.

USING PREVIOUSLY SAVED FILES

You may use the Windows File Manager Application to manage the quantity of project files and output files which accumulate in the CASM directory. You may use the following commands from the File Manager FILE pull-down menu to manage the CASM files:

Before you can manage the project files, you must open the File Manager Application by the following steps:
1. Move the mouse pointer to the CASM Control pull-down menu bar.
2. Press the left mouse key.

The Control pull-down menu will be displayed.
3. Move the mouse pointer down to the Run selection.
USING PREVIOUSLY SAVED FILES

4. **Press** the left mouse key.
   The Run Application pop-up window will appear.

5. **Move** the mouse pointer to the File Manager name or circle.

6. **Press** the left mouse key.
   The File Manager application window will appear on top of the CASM window.

![File Manager Window]

7. **Find** the CASM directory, use the up/down sidebar arrows to check the displayed tree of directories. Select a different drive if the CASM directory does not appear on the directory tree.
   
   a. **Move** the mouse pointer to the desired drive.
   
   b. **Press** the left mouse key.
   
   The directories of the selected drive will appear.

   **To select the CASM directory:**
   
   1. **Move** the mouse pointer to the CASM directory name.
   
   2. **Click** the left mouse key.
   
   The directory window will open listing all the directory files.

   Use the following commands from the File pull-down menu to manage the CASM files:

---

3 - 37
COPY or MOVE
To copy or move the CASM project files with the .bid, .txt, .pic, or .dxf extensions to another directory or disk.
3. Select the file(s) with the mouse. Hold down the [Shift] or [Ctrl] key when selecting multiple files.
4. Select Copy or Move from the File pull-down menu (or use [F8] key).
5. Type in the path to a new location (include a new file if you want to change it).
6. Select Copy or Move box.

DELETE
To delete unwanted CASM project files with the .bid, .txt, .pic, or .dxf file extension. Do not delete filenames with extensions other than .bid, .txt, .pic, or .dxf.
7. Select the file(s) with the mouse. Hold down the [Shift] or [Ctrl] key when selecting multiple files.
8. Select Delete from the File pull-down menu (or use [Del] key).
9. Confirm the file deletion in the confirmation pop-up window.

RENAME
To rename CASM project files. You must add the .bid, .txt, .pic, or .dxf extension to the new file name.
10. Select the file with the mouse.
11. Select Rename from the File pull-down menu.
12. Type in the new name for the selected file.
13. Select the Rename box.
USING EXCEL TO SIZE MEMBERS

USING EXCEL TO SIZE MEMBERS

The EXCEL Spreadsheets can be used to find preliminary structural member sizes based on member data from CASM or by inputting data such as load values, member properties, and spans directly to the spreadsheet. Once you have indicated a preliminary member size, you may transfer the data to CASM for a quantity take-off. There are two spreadsheets for each member type. The Preliminary Selection spreadsheet uses analysis data provided by CASM to provide you with several member sizes to choose from. The Scratch Pad spreadsheet allows you to vary spans, spacings, deflection criteria, loads, and member properties and provides you with several member sizes to choose. Pull-down menus on the spreadsheets allow you to change entries, view special member information, and print spreadsheets.

To use the EXCEL member design spreadsheets:

Microsoft Excel must be on the active path or the path for the Excel program must be designated in the WIN.INI file in order for the spreadsheets to execute from CASM and the Windows Program Manager icons.
PROGRAM OVERVIEW

USING EXCEL TO SIZE MEMBERS

1. Select a structural member in CASM for Preliminary Design.

2. Select the Execute Excel option after the member analysis and the display of the shear and moment diagrams.

The Excel spreadsheet program will be opened and the Preliminary Selection spreadsheet for the selected structural member will be displayed.

If you experience problems running Excel while CASM is still running or there is not enough RAM memory to run Excel then you can send the spreadsheet data to a file. You may activate the data using the SendXL program once you exit CASM.

![Send Data to Excel]

Using the SendXL program if you cannot access Excel from CASM:

1. Use the "Send data to file" option in the CASM Excel Data window after analyzing a member in CASM.

2. Exit CASM.

3. Start the SendXL program by double-clicking on the SendXL icon in the CASM application window.

4. Move the mouse pointer to the desired file name.

5. Double-click the left mouse key. (You may also press the left mouse key to highlight the file name, then move the mouse pointer to the Send box and press the left mouse key.)

The Excel Preliminary spread sheet will open with the data created by CASM. You may make changes, designate a selection, and print the spreadsheet by use of the pull-down menu. If the selected file name does not contain CASM Excel data, you will receive a message to reselect another file name.

To modify data on the spreadsheet:

Individual spreadsheet cells are protected to prevent inadvertent entries that will wipe out essential equations. Entries that are not protected are displayed in bold print and are underlined. You may change data in these cells by:

1. Move the mouse pointer to the Member pull-down menu selection (or press [Alt] + [M]).

2. Press the left mouse key.

The Member pull-down menu will be displayed.

3. Move the mouse pointer to the desired menu selection.

4. Press the left mouse key.
The menu selection will display a data window where you can change data on the spreadsheet.

5. Move the mouse pointer to the OK box.
6. Press the left mouse key.
   The new data is inserted in the cell and the spreadsheet is automatically re-calculated to indicate optional member sizes.

To view member guidelines:
1. Move the mouse pointer to the Guidelines pull-down menu.
2. Press the left mouse key.
   The Guidelines pull-down menu will appear.
3. Move the mouse pointer to the Cardfile selection.
4. Press the left mouse key.
   The Cardfile application program will be opened on top of the spreadsheet with the card for the selected member displayed. Use the mouse pointer to select other guideline cards. Use the Close command in the Cardfile Control pull-down menu to exit the Cardfile Application program.

To print spreadsheets:
1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
   The File pull-down menu will appear.
3. Move the mouse pointer to the Print Spreadsheet selection.
4. Press the left mouse key.
   The Print pop-up window will appear. If you want to view the spreadsheet before you print it, select the Preview box. A screen displaying the spreadsheet as it would appear on the printout will appear. If it looks good you may select the Print option to send the file to the printer. If the displayed spreadsheet does not look good then you may select the Cancel option to cancel the print command and return to the spreadsheet.

   You may use the following File menu selections to make changes to the appearance of the spreadsheet before printing it:

Page Setup - Allows you to change margins.
Select Font - Allows you to change font style and font size. You must select the cell with the font that you intend to change before selecting the command.
Printer Setup - Allows you to change printers.

To use the Scratchpad spreadsheet to vary member parameters in order to determine an optimum member size:
1. Move the mouse pointer to the Scratchpad pull-down menu.
2. Press the left mouse key.
   The Scratchpad pull-down menu will appear.
3. Move the mouse pointer to the selection for the current structural member being sized.
4. Press the left mouse key.
The Scratch Pad spreadsheet for the current structural member will be displayed. You may vary the member span, spacing, loads, deflection criteria, and properties in order to determine the optimum parameters. The initial scratchpad load values selected are Equivalent Uniform load values calculated from the Preliminary Selection spreadsheet.

### Steel Beam Scratch Pad

<table>
<thead>
<tr>
<th>Load &amp; Analysis Data:</th>
<th>Load Combination D * L</th>
</tr>
</thead>
<tbody>
<tr>
<td>Method: Analysis</td>
<td></td>
</tr>
<tr>
<td>Member ID: J1</td>
<td></td>
</tr>
<tr>
<td>Connectivity: Hinge (Left) Roller (Right)</td>
<td>Dead 33.8 1.00 33.8 6.8</td>
</tr>
<tr>
<td>Bm Span: 20.0 ft</td>
<td>Sup Dead 20.0 1.00 20.0 4.0</td>
</tr>
<tr>
<td>Trib Width: 20.0 ft</td>
<td>Live 100.0 1.00 100.0 20.0</td>
</tr>
<tr>
<td>Depth Limit: 36.0 in max</td>
<td>Min Roof 1.00</td>
</tr>
<tr>
<td>Fy = 36.0 ksi</td>
<td>Snow 1.00</td>
</tr>
<tr>
<td>Fv = 14.4 ksi</td>
<td>Wind 1.00</td>
</tr>
<tr>
<td>Fb = 0.6*Fy = 24 ksi</td>
<td></td>
</tr>
<tr>
<td>E = 29,000 ksi</td>
<td>Summary 153.8 153.8 30.8</td>
</tr>
<tr>
<td>Live Ld Defl = L/360 = 0.67in</td>
<td>Max M = 1538 kip-ft</td>
</tr>
<tr>
<td>Total Defl = L/240 = 1.00in</td>
<td>R = 308 kips</td>
</tr>
</tbody>
</table>

### Beam Selection Table:

<table>
<thead>
<tr>
<th>END CONDITIONS</th>
<th>Simple(S)</th>
<th>Two Span(D)</th>
<th>Continuous(C)</th>
<th>Fixed(F) = S</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beam Size</td>
<td>Depth (in)</td>
<td>Width (in)</td>
<td>Ix (in^4)</td>
<td>Sx (in^3)</td>
</tr>
<tr>
<td>W 14 x 53</td>
<td>13.9</td>
<td>8.06</td>
<td>541</td>
<td>78</td>
</tr>
<tr>
<td>W 12 x 58</td>
<td>12.2</td>
<td>10.01</td>
<td>475</td>
<td>78</td>
</tr>
<tr>
<td>W 18 x 46</td>
<td>18.1</td>
<td>6.06</td>
<td>712</td>
<td>79</td>
</tr>
<tr>
<td>W 16 x 50</td>
<td>16.3</td>
<td>7.07</td>
<td>659</td>
<td>81</td>
</tr>
<tr>
<td>W 21 x 44</td>
<td>20.7</td>
<td>6.50</td>
<td>843</td>
<td>82</td>
</tr>
</tbody>
</table>

### CASM Steel Beam Selection:

| W 18 x 46 | Span = 20.0 ft | Ix = 712.0 | Sx = 78.8 | Defl (in) = 0.35 | W (lbs) = 860 |

5. Select Return to Preliminary from the File pull-down menu to return to the Preliminary spreadsheet.

### To return to CASM:

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
3. Move the mouse pointer to the Return to CASM selection.
4. Press the left mouse key.

The Excel program and the spreadsheet will be closed and the CASM program window will be opened.
STOPPINGS THE CASM PROGRAM

PROGRAM OVERVIEW

You may also access the Scratch Pad spreadsheets individually by the use of CASM icons in the CASM Application Group Window.

To access the Excel Scratch Pad spreadsheets from the CASM Icons:

1. Move the mouse pointer to the desired structural member icon.
2. Double-click the left mouse key.
   The Scratch Pad spreadsheet for the selected structural member will be displayed. You may vary the member span, spacing, loads, deflection criteria, and properties in order to determine the optimum parameters and member selection.
3. Select "Return to Icons" from the File pull-down menu to return to the icon display.

STOPPINGS THE CASM PROGRAM

You can stop the CASM program at any point in your project development and resume at a later time. You may stop the CASM program by selecting Exit from the CASM File pull-down menu or Close from the Control pull-down menu box.

Stopping CASM using Exit from the File pull-down menu:

1. Move the mouse pointer to the File selection on the Pull-Down Menu Bar.
2. Press the left mouse key.
   The File Pull-Down menu will appear.
3. Move the mouse pointer to the Exit selection on the menu.

4. Press the left mouse key to activate the command (you may also activate the Exit command by typing [X]).
   The CASM program window will disappear.

   If changed/new entries have been made to your project file from the last time you saved the file, a pop-up dialog window will appear to prompt you to save changes to the file.

   ![Save current changes: [untitled]](image)

5. Select Yes to Save changes. Selecting Cancel will allow you to remain in CASM.

Stopping CASM using Close from the Control pull-down menu:

1. Move the mouse pointer to the Control Box in the top left corner of the CASM window.

2. Double click the left mouse key.
   The CASM Window will disappear.
   You may also use the following method:
   a. Press the left mouse key once.
      The Control pull-down menu will appear.

      ![Control pull-down menu]

      b. Move the mouse pointer to the Close selection on the menu.
      c. Press the left mouse key to activate the command (you may also activate the Close command by typing [C]).
      The CASM program window will disappear.

   If changed/new entries have been made to your project file from the last time you saved the file, a pop-up dialog window will appear to prompt you to save changes to the file.
3. Select Yes to Save changes. Selecting Cancel will allow you to remain in CASM.

![Save current changes dialog box with options: Yes, No, Cancel]
Windows also provides several useful Desktop application programs which are listed below with a brief description of its use and its application to CASM.

Detailed instruction covering the use of these applications is contained in the Windows Desktop Applications User Guide which is contained in the Microsoft Windows User's Guide.

Accessories Group Applications - Select the icon from the Accessories Group window to activate or use the Run command from the CASM Control pull-down menu.

**CARDFILE**

Cardfile is a very simple database management program which permits you to store data on program-generated notecards. With Cardfile you can avoid sorting paper note cards by hand. Enter any information you want (i.e., names, addresses, phone numbers, structural data, material cost data) in any order and let Cardfile do the sorting for you. CASM criteria data are saved in a Cardfile datafile based on city/installation location (cities.crd). Whenever a location is selected for a building project, all the regional and site-specific data will be automatically copied into the CASM project criteria file. You may modify or create new CASM criteria data cards for cities/installations using the Cardfile program. Cardfile is also used by CASM to display structural engineering guidelines about structural systems (guides.crd).

**NOTEPAD**

Notepad is a program-generated memo pad. You can copy or cut (delete) text from other applications and paste it into Notepad or cut text from Notepad and paste it into other applications. All CASM text output files such as design criteria and load and structural data from CASM are automatically formatted for review, editing, and printing via Notepad. Notepad is an ASCII text editor. It can also be used for editing batch files instead of EDLIN, the standard DOS editor. If the text file is too large for Notepad, you will need to use Windows Write to edit the file.
DESKTOP APPLICATION PROGRAMS

PROGRAM OVERVIEW

CALCULATOR

Use the Calculator program to perform standard arithmetic functions while running other programs. You may want to start the Calculator program and keep it handy as an icon while using the CASM program. You have a choice of two calculators, either a scientific calculator or a standard calculator. Use the View pull-down menu to select the calculator display.

CALENDAR

The Calendar program helps you keep track of your daily appointments. It also has an alarm to remind you of your appointment time.

CLOCK

Shrink the clock to an icon, and the familiar clockface—complete with sweeping second hand or digital readout remains on the screen without taking work space.

WRITE

Write is a word processor provided with the Windows program. With Write you can write, edit, and print all kinds of documents. Graphic or other information can be electronically "pasted" from other applications into your Write documents. Text output from the CASM program may be converted to Write file format by opening the file and accessing it from the Write program. Views from the CASM program may be "pasted" from Draw Plus or Designer onto your Write documents. You must first 'copy' the view from Draw Plus or Designer before you can 'paste' it into Write.

PAINTBRUSH

Paintbrush is a basic drawing tool provided with the Windows program. With Paintbrush you can create, enhance, save, and print graphics such as charts or diagrams.

OTHER APPLICATION PROGRAMS

There are several other programs which interface with Windows and are used with CASM. These programs are not included in the Windows package and must be purchased separately. User guides which describe the operating procedures are provided with each of these programs. The other application programs and a brief description are listed below.

Windows Draw by Micrografx

With Windows Draw you can create, enhance, save, and print CASM .PIC graphics such as plans, elevations, and sections. A library of symbols is available for your use. Views from the CASM program may be electronically pasted on your Windows Draw canvas then edited before printing. To combine views you may "Import" drawings which have been created by CASM. You may also paste text from the Notepad or Write programs into Windows Draw. Use the CASM Settings command from the File pull-down menu to select which program to execute after creating a print screen file.
DESIGNER by Micrografx

Designer is a more advanced graphics program for use with CASM. With Designer you can create, enhance, save, and print structural graphics such as plans, elevations, and sections for presentations or for inclusion in a document. Special libraries of symbols are available for your use. Views from the CASM program may be electronically pasted on your Designer canvas. Then edited before printing. You may import all of your CASM screen views into the Designer program. You may also paste text from the Notepad or Write programs into Designer. You can also use Designer as a Presentation Graphics program. Use the CASM Settings command from the File pull-down menu to select which program to execute after creating a print screen file.

EXCEL by Microsoft

Excel is a spreadsheet program for use with Microsoft Windows. A series of Excel spreadsheets have been developed for use with CASM in order to allow the user to evaluate several structural framing alternatives based on project criteria and to select preliminary member sizes for cost evaluation and structural analysis. Once a member has been selected, structural and quantity information about the member can be copied to CASM for analysis or quantity take-off.

Windows Productivity Pack

The Windows Productivity Pack is an inexpensive package of several programs for use with Windows to aid you in learning how to use Windows more effectively. The programs are:

Learning Windows. A useful tutorial program for helping first time users understand the Microsoft Windows program and teaches them how to use it effectively. It is very easy to use and is highly recommended for users with none or limited experience in using a Windows environment.

Quick Trouble-Shooting. invaluable as a tool to help Windows users set up their system. It describes how to correct problems that you may be having with Windows. The specific topics it addresses are printers, networks, applications, and memory.

Working Smarter. Provides numerous tips on how to set up and optimize the Windows program in order to increase your proficiency with using Windows. Specific topics addressed are speeding up your work, a personal touch, managing information, equipment tips, and printing tips.

SENDXL

If you experience problems running CASM and Excel at the same time, CASM will permit you to create an Excel input file of CASM analysis data. After you exit CASM and free memory to run Excel, you can use SendXL to send the file to the Member selection spreadsheets. When the SendXL Application window is displayed, designate the member data file to send to Excel. Select the Send block to open up the
spreadsheet. If the file you select is not in the proper Excel input format, you will receive a message, then reselect the correct file.

FRAME

Frame is a copy of the Corps of Engineers' X0020-2D Frame Analysis program. To use the Frame program, you must generate an input file using a text editor. Then select the Frame program for the analysis. Designate the input file from the list of files. Select Execute to begin analysis. Analysis data will be written to the output file (.out).

BEAM WEIGHT

The Beam Weight program displays a table of various beam weights based on member spans. Use Next or Previous to view selections. Use Close to exit the program.

LOADS

The Loads program permits you to generate your loading output data by filling in the dialog windows with project information. You do not need to develop the building geometry in order to use the Loads program to generate load output information for Minimum Roof loads, Snow loads, Wind loads, and Seismic loads.

In addition, Windows supports a variety of other programs, such as databases, publishing programs, and structural analysis programs. Windows is the primary menuing/utility program for use with DOS. Windows permits multi-tasking and multi-displays for the IBM and IBM-compatible 386 and 286 computers.

You may also create windows for other programs which were not designed specifically for the Windows environment. Use the PIF Editor to create the parameters for your special program windows via a .PIF file which you can create by using the PIF Editor. Refer to the Windows User Guide for more specific information.
This chapter describes all of the elements on the CASM screen and the CASM Excel spreadsheets. It includes a graphic display of each of the special graphic Tool Palette windows used in the CASM program. Refer also to the Program Overview section which describes the basic operations of CASM.

A discussion and listing of the operational sequence for each of the graphic Tool Palettes, menu selections, and window dialog boxes accompanies each graphic display. Also included in this chapter are brief instructions for using four additional Applications: Notepad for the editing and printing of the Design Criteria and Load lists including Snow and Wind loads; Cardfile for recording and reviewing standard Design Criteria data used frequently for building projects; Excel for the selection of preliminary structural member sizes; and Windows Draw or Designer for editing and printing CASM screen images.

Detailed descriptions on the use of MS-DOS, Microsoft Windows, Microsoft Excel, and Micrografx Windows Draw and Designer are not included in this chapter. You may want to refer to the MS-DOS, Microsoft Windows, Microsoft Excel, and Micrografx Windows Draw and Designer user guides for additional information concerning their use.
The Bottom Tool Palette located at the bottom of the CASM window displays the command prompts, contains the Structural Plane Name drop down list, and has the Snap Modes, Define Units, and Tape Measure command icons.

### Command Prompt Display:

The Command Prompt Display on the left end of the Bottom Tool Palette can be used to display the name of the command icon where the mouse pointer is located. Place the mouse pointer on any command icon on the CASM window and the name will be displayed in place of the word 'Ready'. The Command Prompt Display will also display brief command prompts when using CASM commands.

### Structural Plane Drop Down List:

The Structural Plane Name Drop Down List box will display the currently selected structural plane. The Structural Plane Name Drop Down List can also be used any time to switch to a 2D structural plane.

**Select the Structural Plane Name Drop Down List box with the mouse pointer:**

1. Move the mouse pointer to the Structural Plane Name Drop Down List box.
2. Press the left mouse key.
   
   A list of structural plane names appears, if a model has been started in CASM.
3. Move the mouse pointer to the name of the structural plane you want to view.
4. Press the left mouse key.
   
   The selected structural plane will be displayed in the CASM modeling window.

- CASM randomly labels floor, roof, and wall planes. You may want to relabel the planes with descriptive names. Use the Structural Plane Information command on the View pull-down menu to change the name of the current structural plane.

### Command Icons:

The following command icons are located at the right end of the Bottom Tool Palette: Snap to Units, Snap to Grid, Snap to Reference, Define Units, and Tape Measure. Only one snap mode can be selected at a time. The selected snap mode will be highlighted in a lighter gray. To deselect the snap mode, select the highlighted snap mode. Selecting the Define Units command icon will open a dialog window. Selecting the Tape Measure command icon will permit you to select vertices to measure.
VIEWPOINT TOOLS

You may use the Viewpoint Tools located in the Side Tool Palette to change the display of the structural model. You may change the viewing angle, the viewing height, and viewing distance of the model. The Viewpoint Tools are always displayed on the screen.

The Viewpoint Tools selections are:

To rotate the 3-D model on the modeling screen:

1. Move the mouse pointer to the black arrow that points to the circle.
2. Press the left mouse key and hold it down.
3. While holding down the left mouse key, move the mouse to drag the arrow around the circle.
   When the arrow is moved, the 3-D model will rotate on the modeling screen.
4. Release the mouse key when the desired model orientation is established.
   You may also locate the mouse pointer to a new location on the circle and press the left mouse key. The black arrow will move to the new location, and the model will rotate to the new orientation. You may also type in the desired angle in the edit box inside the circle.

To change your 3-D viewing center (initial location is designated by a plus symbol at the center of the ground plane):

1. Move the mouse pointer to the Pan icon.
2. Press the left mouse key.
3. Move the mouse in the direction which your desire to move the viewing center:
   Right/Left = E-W
   Toward/Away = N-S
   Hold down right key & Toward/Away = Vertical
   When the mouse is moved, the viewing center mark on the screen will move.
   Double click the right mouse key to cancel adjusting the viewing center.
4. Press the left mouse key when the desired viewing center location is established.
To pan the 2-D display (change the display vertically or horizontally on the screen):
1. Move the mouse pointer to the Pan icon.
2. Press the left mouse key.
3. Move the mouse in the direction which you desire to Pan the display (right, left, away-up, toward-down).
   When the mouse is moved, the display will pan on the modeling screen.
   >> Double click the right mouse key to cancel panning the display.
4. Press the left mouse key when the desired view is established.

To change your viewing height:
1. Move the mouse pointer to an arrow button above or below the current height value.
2. Press and release the left mouse key to increment the viewer height up or down.
   -OR-
   a. Press and hold the mouse key.
   b. Move the mouse pointer in the direction the height arrow is pointing in order to make large height changes. You may also reverse the direction of the mouse to reverse the height change.

   The 3-D model on the modeling screen will be oriented to reflect the change in viewer height.
   >> You are allowed to select a negative height value (less than zero). This will allow you to look at any structure that is below the ground plane grid.
3. Release the mouse key when the desired viewer height is established.
   >> You may also enter the Height in the edit box.

To change your viewing distance:
1. Move the mouse pointer to an arrow button to the right or left of the current distance value.
2. Press and release the left mouse key to increment the viewer distance farther or closer to the model.
   -OR-
   a. Press and hold the mouse key.
   b. Move the mouse pointer in the direction the distance arrow is pointing in order to make large distance changes. You may also reverse the direction of the mouse to reverse the viewing distance change.

   The 3-D model on the modeling screen will be oriented to reflect the change in viewer distance.
3. Release the mouse key when the desired viewer distance is established.
You may also enter the Distance in the edit box.

When viewing a 2D view, the Distance tool zooms the window out and in.

To zoom the 2-D display:
The Zoom Window command permits you to zoom into a portion of a 2D display.

1. Move the mouse pointer to the Zoom Window icon.
2. Press the left mouse key.
   The Zoom Window icon is highlighted and the mouse pointer changes to a plus (+) symbol.
3. Move the mouse pointer to one corner of the desired zoom window.
4. Press the left mouse key.
5. Move the mouse pointer to the opposite corner of the desired zoom window.
   When the mouse is moved, the zoom window is dragged to the opposite corner.
6. Double click the right mouse key to cancel zooming the display.
7. Press the left mouse key when the desired view is established.
   The selected area will be displayed on the screen.

To return to previous 2-D display:
The View Previous command permits you to go back to the previous 2D view. This command can be used after the Zoom Window, Pan, or Distance Zoom commands.

1. Move the mouse pointer to the View Previous icon.
2. Press the left mouse key.
   The previous view will be displayed. If there are no previous views, the View Previous icon will be gray and there will be no response when selected.
CONTROL MENU

The Control Menu is common to all program applications windows and some dialog windows. It contains commands for manipulating the program application windows. The Control menu is a pull-down menu. It is accessed via the Control Menu Box in the upper left corner of the current Window. Several of the commands have alternate activation methods for the keyboard or mouse. The Control Menu command list and operation sequence are defined below.

To select a command from the CONTROL Menu with the mouse:

1. Move the mouse pointer to the small box in the upper left corner of the CASM Application Window.
2. Press the left mouse key.
3. Move the mouse pointer down the command list to the selection you want.
4. Press the left mouse key to carry out the command.

The CONTROL Pull-down menu has been designed for the keyboard or the mouse. For the mouse there are several additional alternate methods which are faster than using the CONTROL pull-down menu.

Command - Alternate Mouse Action

<table>
<thead>
<tr>
<th>Command</th>
<th>Mouse Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Place the mouse pointer on the Title Bar and double click the left mouse key. Or place the mouse pointer on the double arrows and press the left mouse key. Restore from an Icon - Place the mouse pointer on the Icon at the bottom of the screen and double click the left mouse key.</td>
</tr>
<tr>
<td>Move</td>
<td>Place the mouse pointer on the Title Bar, press the left mouse key and hold it down to move the window.</td>
</tr>
<tr>
<td>Size</td>
<td>Place the mouse pointer on the Window Border. The mouse pointer changes to a double arrow. Press the left mouse key, and hold it down to move the window border.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Place the mouse pointer on the single down arrow at the top right corner of the window and press the left mouse key.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Place the mouse pointer on the single up arrow at the top right corner of the window and press the left mouse key. Or place the mouse pointer on the title bar and double click the left mouse key.</td>
</tr>
<tr>
<td>Close</td>
<td>Place the mouse pointer on the Control menu box and double click the left mouse key.</td>
</tr>
</tbody>
</table>

To select a command from the CONTROL Menu with the keyboard:

- [Alt] + [F4] will close the CASM Application window without displaying the Control menu. [Ctrl] + [Esc] will display the Task List window without displaying the Control menu.

   The CONTROL Menu will appear.
2. Type the underlined letter of the command to carry out the command.
CONTROL MENU

-OR-

Use the up or down direction keys on the keyboard to move the selection bar up or down to the desired selection and press the [Enter] key. The right or left direction keys on the keyboard will allow you to select other pull-down menus on the menu bar.

To select the CONTROL Menu when the CASM Application is an Icon in the Icon area:
1. Move the mouse pointer to the CASM Icon in the Icon Area.
2. Press the left mouse key.
   The CONTROL Menu will appear.
3. Place the mouse pointer on the desired command.
4. Press the left mouse key to carry out the command.

The CONTROL Menu commands are listed on the following pages:

RESTORE

The Restore command is active after you have maximized the current program window (expanded the current program window to fill the screen) or minimized the current program window (changed the window to an icon). It permits you to return the program window display to a shared (overlay) display with other program windows. If you have a mouse you can also Restore the program window by using the double arrow box on the top right corner of the screen or double click the mouse pointer on the Title Bar.

The Restore command is only active when the program window has been maximized or minimized. If the Restore command is not active, the print will appear to be light gray, not black.

Select the RESTORE command with the mouse.
1. Move the mouse pointer to the double arrow box at the top right corner of the screen. (If the double arrow box is not displayed, the restore command is not active.)
2. Press the left mouse key.
   The program window display will return to a shared (overlay) display with other program windows.

Select the RESTORE command with the keyboard.
1. Press the [Alt] + [Spacebar] to display the Control Pull-Down Menu.
2. Press the [R] key (or [ENTER] key if the Restore Command is highlighted) to carry out the command.
   The program window display will return to a shared (overlay) display with other program windows.
To select the RESTORE command from the CONTROL Menu of the CASM icon with the mouse:
1. Move the mouse pointer to the CASM icon in the Icon Area.
2. Double click the left mouse key.
   The CASM icon automatically changes into a CASM Program Window on the screen. You may also access the RESTORE command from the menu by either placing the mouse pointer on the CASM icon and pressing the left mouse key once to display the Control menu or press the [Al] + [Tab] keys until the CASM icon is highlighted, then release the keys. The icon automatically changes into a CASM program window on the screen.

The MOVE command lets you move a program window, toolbox window, or dialog window to another position on the screen. If you have a mouse you can also move the window by using the Title Bar.

Select the MOVE command with the mouse:
1. Move the mouse pointer to the Title Bar in the application or dialog window.
2. Press the left mouse key and hold it down.
   The active program window border is highlighted.
3. Drag the mouse pointer (and window border) to another location on the screen where you want to locate the program window.
4. Release the left mouse key to change the current window location to the new location.
   The program window will move to the new location on the screen.

Select the MOVE command with the keyboard:
1. Press the [Alt] + [Spacebar] keys to display the Control Menu.
2. Press the [M] key to activate the Move command.
   The mouse pointer changes to a four-headed arrow, and the active program window border is highlighted.
3. Use the cursor direction keys on the keyboard to move the outline of the window to the desired new location.
4. Press the [Enter] key to move the program window to the new location on the screen.
   The program window will move to the new location on the screen.
The **Size** command lets you change the size of a program window when the window is sharing the screen with several program windows. If you have a mouse, you can change the size of a window by moving the mouse pointer to one of the four borders or corners of the program window.

**To select the SIZE command with the mouse:**

1. Move the mouse pointer to any of the borders or corners of the current Program Window. The mouse pointer changes to a double-ended arrow.
2. Press the left mouse key and hold it down.
   A highlighted boundary line is created which is attached to the mouse pointer.
3. Drag the boundary line until the desired Window size is achieved.
4. Release the left mouse key to change the current Window size to the new size indicated by the dashed boundary line.

**Select the SIZE command with the keyboard:**

1. Press the [Alt] + [Spacebar] to display the Control Menu.
2. Press the [S] key to carry out the Size command.
   The mouse pointer changes to a double-ended arrow.
3. Use the cursor direction keys to move the mouse pointer to the side or corner that you want to move.
   When the pointer moves to the border of the window, a highlighted boundary line is created and attaches to the pointer.
4. Move the boundary line with the cursor direction keys until the desired Window size is achieved.
5. Press the [Enter] key to change the current Window size to the new size indicated by the dashed boundary line.

The **Minimize** command shrinks the selected program window into an Icon and places the Icon in the Icon area. If you have a mouse you can change the program window to an Icon by using the down arrow on the top right corner of the screen.

**Select the MINIMIZE command with the mouse:**

1. Move the mouse pointer to the down arrow on the top right corner of the program window.
2. Press the left mouse key.
   The CASM Program Window automatically changes into a CASM Icon (small house) located in the Icon Area.
Select the MINIMIZE command with the keyboard:
1. Press the [Alt] + [Spacebar] to display the Control Menu.
2. Press the [N] key to carry out the Minimize command.

The CASM Program Window automatically changes into a CASM Icon (small house) located in the Icon Area.

Select the MAXIMIZE command with the keyboard:
1. Press the [Alt] + [Spacebar] to display the Control Menu.
2. Press the [X] key to carry out the Maximize command.

The program window automatically expands to fill the entire screen. All other Application Windows and the Icon area are hidden.

Select the MAXIMIZE command with the mouse:
1. Move the mouse pointer to the up arrow on the top right corner of the program window.
2. Press the left mouse key.

The program window automatically expands to fill the entire screen. All other Application Windows and the Icon area are hidden.

To select the MAXIMIZE command from the CASM Icon with the mouse:
1. Move the mouse pointer to the CASM Icon in the Icon Area.
2. Double click the left mouse key.

The CASM Icon automatically changes into a CASM Program Window on the screen.

The Close command closes the CASM program and project file running in the CASM Window and removes the CASM program from memory. To use the CASM program again, you must start it from the Windows Program Manager CASM Application Group window. If you have made changes to the project file and have not saved them, a pop-up dialog window will appear which displays the current directory, the file name, and options to save the file (YES, NO, or CANCEL). If you have a mouse you can Close the program by moving the mouse pointer to the Control Menu box and double clicking the left mouse key.
Select the CLOSE command with the mouse:

1. Move the mouse pointer to the Control Menu box on the top left corner of
the current program window.
2. Double click the left mouse key.
   
   If you have made un-saved changes to the file, a pop-up dialog window
appears to permit you to save changes to the current project file.

Select the CLOSE command with the keyboard:

1. Press the [Alt] + [Spacebar] to display the Control Menu. (You may use
[Alt] + [F4] to activate the Close command without displaying the Control
Menu.)
2. Press the [C] key to carry out the Close command.

A pop-up dialog window appears to permit you to save changes to the current
project file.

To save changes if the file is (untitled):

1. Move the mouse pointer to the YES box with the mouse or the [Tab] key.
2. Press the left mouse key or the [Spacebar].

A pop-up dialog window appears which displays the current directory, a box
for the file name, and options to OK the file save or CANCEL the save
command.

3. Type in an appropriate file name with 8 characters or less. The extension
.BLD will be automatically added. If you use another extension, it will
automatically be changed to .BLD.
You may use the tab key to change selections or use the mouse pointer to change selections. Place the mouse pointer on the underlined down arrow for file type or drives or use the cursor direction down key to display the list of file types or drives.

4. Move the mouse pointer to the OK box with the mouse or the [TAB] key.
5. Press the left mouse key or the [Spacebar].

If you save the project file and a project file of the same name exists, you will be prompted if you want to replace (add changes to) the existing project file.

The project file will be saved, the CASM program will stop, and you will be returned to the Windows Program Manager Application.

To save changes if the file has a name:

A pop-up dialog window appears which displays the current directory, the file name, and options to save the file (YES, NO, or CANCEL).

1. Move the mouse pointer to the appropriate box with the mouse or the [Tab] key.
2. Press the left mouse key or the [Spacebar].

Changes will be added to the current project file if YES is selected. If NO is selected, changes will not be added. The CASM program will stop, and you will be returned to the Windows Program Manager Application.

If CANCEL is selected, you will remain in the CASM program window.

The SWITCH TO command opens the Task List pop-up window. The Task List window displays all of the Application windows which are currently open but in the background while CASM is the active window. You may designate an Application window to be displayed on top of the CASM window, you may rearrange the Application windows on the monitor screen, or you may close an Application to free up more RAM memory.

Select the SWITCH TO command with the mouse:

1. Select the Switch To command from the Control pull-down menu.

You can also activate the Task List dialog window by moving the mouse pointer to the Windows background ('desktop') and double click the left mouse key.
A Task List pop-up window will appear listing the active (open) applications.

2. Move the **mouse pointer** to the desired application.
3. Press the **left mouse key**.
   
The selection is highlighted by a dark bar and reverse text.

   **Double clicking the left mouse key will automatically open (switch to) the selected application window on top of the CASM window.**

4. Move the **mouse pointer** to the desired option box.
5. Press the **left mouse key**.
   
The selected option will be activated.

**Select the SWITCH TO command with the keyboard:**

1. Press the [Ctrl] + [Esc] keys.

   **- OR-**

   Use the [Alt] + [Spacebar] keys to display the Control pull-down menu. Press the [W] key or use the down direction key to select the **SWITCH TO** command and press the [Enter] key.

   A Task List window will appear listing the active applications.

2. Use the **up/down direction keys** to move the highlighted bar.
3. Use the [Tab] key to select the desired option box.
4. Press the [Enter] key.
   
The selected option will be activated.

The **SWITCH TO** options are:

- **Switch To** - Will display the selected application window on top of the CASM window. Useful for selecting the Calculator for checking values. To remove the application window and return to CASM, select the Close or Minimize commands.

- **End Task** - Closes the selected application. Can be used to free up more RAM memory for CASM and Excel to run. It will close CASM or the Windows
Program Manager if you have them selected. A confirmation pop-up window will appear permitting you to save changes or remain in windows.

- **Cascade** - Arranges all open windows, stacked with title bars of applications shown above the active window.
- **Tile** - Arranges all open windows next to each other on the screen with no stacking or overlay.
- **Arrange Icons** - Can be used to relocate icons in the icon area at the bottom of the screen.
- **Cancel** - Closes the Task List pop-up window and returns to the active window.

The **RUN** command opens a Run Application pop-up window with a list of applications (programs) that you can run on top of the CASM window. This command provides a convenient access to applications you may need such as Notepad to review and print output files or Calculator to do some calculations. Close or Minimize the application window in order to return to CASM.

Use the Run command when you first open an application window. Do not use the Run command to access applications that are already open or you will be duplicating the open applications reducing your available RAM (memory). Windows will permit you to run the same program in separate application windows. Continuing to use Run to access applications will open multiple windows with the same program in each until you run out of RAM.

Select the **RUN** command with the mouse:

1. Select the **RUN command** from the Control pull-down menu.

A Run Applications window will appear, listing applications that you can run.
2. Move the mouse pointer to the desired application name or circle next to the name.
3. Press the left mouse key.
   A black dot will appear inside the selected application circle.
4. Move the mouse pointer to the OK box.
5. Press the left mouse key.
   The selected application window will open on top of the CASM window.

Select the RUN command with the keyboard:
1. Use the [Alt] + [Spacebar] keys to display the Control pull-down menu. Press the [U] key or use the down direction key to select the RUN command and press the [Enter] key.
   A Run Application window will appear listing applications that you can run.
2. Use the up/down direction keys to change the selected application.
3. Use the [Tab] key to select the OK box.
4. Press the [Enter] key.
   The selected application window will open on top of the CASM window.

The applications that you may select are:

<table>
<thead>
<tr>
<th>Application</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Panel</td>
<td>To change Windows settings.</td>
</tr>
<tr>
<td>Card File</td>
<td>To review information.</td>
</tr>
<tr>
<td>Calculator</td>
<td>To do calculations.</td>
</tr>
<tr>
<td>File Manager</td>
<td>To copy, delete, or rename files.</td>
</tr>
<tr>
<td>Notepad</td>
<td>To review or modify text output files.</td>
</tr>
<tr>
<td>Write</td>
<td>To format a Notepad output file plus 'pasted' graphics.</td>
</tr>
<tr>
<td>Windows Draw**</td>
<td>To edit and print screen images.</td>
</tr>
<tr>
<td>Excel**</td>
<td>To activate member design spreadsheets.</td>
</tr>
</tbody>
</table>

** Windows Draw (or Designer) and Excel are programs that must be purchased separately from Windows 3.x. Both programs must be installed on your computer in order to use the features described in this guide.

You may return to CASM by Closing or Minimizing the application window which is on top of the CASM program window.

If you minimize an application, you may access it later by using the Switch To command on the Control menu.
FILE MENU

The File Menu is a pull-down menu used to manipulate CASM project data files. Use the File Pull-Down Menu to create a new project file, to open an existing project file, to print project data or project views, to save a project file, and to stop the program operation. The last four files worked on are listed at the end of the File Menu.

The New, Open, and Exit commands remind you to save any changes to the current project model before proceeding.

To select a command from the FILE Menu with the mouse:
1. Move the mouse pointer to the File heading on the pull-down menu bar of the CASM program window.
2. Press the left mouse key.
3. Move the mouse pointer down the command list to the selection you want (you may also activate the command by typing the underlined letter in the desired command).
4. Press the left mouse key to carry out the command.
A dialog window will appear.

To select a command from the FILE Menu with the keyboard:
1. Press the [Alt] key and the [F] key together.
The File Menu will appear.
2. Type the underlined letter of the command to carry out the command.
   OR:
   Use the up or down directions on the keyboard to move the selection bar up or down. Then press the [Enter] key to carry out the command.

To select a File Menu command icon from the Side Tool Palette:
1. Move the mouse pointer to the desired File Menu icon.
2. Press the left mouse key.
The dialog window for the selected File Menu icon will be displayed on the screen.

The File Menu command icons are not displayed on the 640 x 480 monitor display.

The FILE Menu command selections are listed on the following pages:
The **New** command removes the current modeling window and project file, then opens a new modeling window and an 'untitled' project file. When you first enter the CASM program you are automatically in the **New** mode. The default project file name is (untitled). When you select the **New** command after doing work on a project file in the CASM program, a dialog box will remind you to save changes to the current project file before starting a new project file.

Select the **NEW** command from the **FILE** menu.

**If changes have been made to the current project file:**

A dialog box prompts you to save changes to the current project file.

![Save current changes: GUIDEMO.BLD](image)

1. Move the mouse pointer to the YES or NO box with the mouse (or use the [Tab] key on the keyboard).
2. Press the **left mouse key** to indicate your selection (or press the [Spacebar] on the keyboard).
   a. If you select YES to save a named project file, the file will be saved and a new (untitled) file will be started.
   b. If you select YES to save the project file and the file is (untitled), you will be prompted for a project file name.
   c. If you select NO to not save the project file, the current project file will be stopped without adding the changes and a new 'untitled' file will be started.
   d. If you select CANCEL, you will remain in the current project file.

**To save changes if the file is (untitled):**

A pop-up dialog window appears which displays the current directory, a box for the file name, and options to OK the file save or to CANCEL the save command.

1. Type in an appropriate file name with 8 characters or less. The extension .BLD will be automatically added. If you use another extension, it will be changed to .BLD.
2. Move the mouse pointer to the OK box (or use the [TAB] key on the keyboard).
3. Press the **left mouse key** (or press the [Spacebar] on the keyboard).
   The file will be saved and a new (untitled) file will be started.
If you select OK to save the project file and a project file of the same name exists, you will be prompted if you want to replace (add changes to) the existing project file.

If you select YES to replace the existing project file, the existing project file will be replaced by the current active file. If you select NO, you will be prompted for another file name.

The OPEN command opens a project file and modeling window of a previously created project. When you select the Open command after doing work on a project file in the CASM program, a dialog box will remind you to save changes to the current project file before opening another project file.

Select the OPEN command from the FILE menu.

If changes have been made to the current project file:

A dialog box prompts you to save changes to the current project file.

1. Move the mouse pointer to the YES or NO box using the mouse (or the [TAB] key on the keyboard).
2. Press the left mouse key (or press the [Spacebar]) to indicate your selection.
   a. If you select YES to save a named project file, the file will be saved.
   b. If you select YES to save the project file and the file is 'untitled,' you will be prompted for a project file name.
   c. If you select NO to not save the project file, the current project file will be stopped without adding the changes.
   d. If you select CANCEL, you will remain in the current project file.
To save changes if the file is (untitled):

A pop-up dialog window appears which displays the current directory, a box for the file name, and options to OK the file save or CANCEL the save command.

1. Type in an appropriate file name with 8 characters or less. The extension .BLD will be automatically added. Do not use another extension.
2. Move the mouse pointer to the OK box using the mouse (or the [Tab] key on the keyboard).
3. Press the left mouse key (or press the [Spacebar]) to indicate your selection.

The file will be saved.

If you select OK to save the project file and a project file of the same name exists, you will be prompted if you want to replace (add changes to) the existing project file.

If you select YES to replace the existing project file, the existing project file will be replaced by the current active file. If you select NO, you will be prompted for another file name.

A dialog box will appear with a listing of CASM project files (filename.BLD). The dialog box prompts you either to choose a project model from the list box or type the project name of the model you want.
If the .bid project file you need is not listed, then you may change directories or disk drives. Directories are represented by names or dots in brackets (i.e., [...] represents the parent directory; [jobs] indicates a subdirectory under the current directory). Select a new drive by clicking on the down arrow to the right of the Drives box. A list of drives will appear on a pull-down menu. Use the mouse to select the desired drive.

To select a project file, change directories or disk drive:

1. Move the mouse pointer to a listed filename, directory or disk drive.
   
   Use the vertical arrows on the side to scroll the list up or down. You may also use the up or down direction keys to change selections.
   
2. Double click the left mouse key on a project file name in order to automatically open the selected project file.
   
   Selecting a directory and double-clicking the left mouse key will change file display from the current directory to the selected directory.

-OR-

Press the left mouse key to highlight the file selection. Then move the mouse pointer to the OK box and press the left mouse key. You may also use the [Tab] key to select the OK box and press the [Enter] key.

The selected project file will be opened. The model will be displayed on the modeling screen. Criteria and load data will be loaded.

To cancel the OPEN command:

1. Move the mouse pointer to the CANCEL box using the mouse (or the [Tab] key on the keyboard).
   
2. Press the left mouse key (or [Spacebar] on the keyboard) to cancel the command.
   
   The dialog window will disappear.

The Save command saves the current project file on disk storage under the existing project file name. The program is interrupted momentarily during the save. An hourglass symbol will be displayed on the screen while the project file is being saved. If the file is untitled, a dialog window will appear to prompt you for a file name.

Select the SAVE command from the FILE Menu.

If the file is named, the program will pause momentarily and the mouse pointer will change to an hourglass while the changes are added.

The project file stored on the disk drive will be automatically replaced with the changed project file in RAM without confirming that you want to replace it.
To save changes if the file is (untitled):

A Save As pop-up dialog window appears which displays the current directory, a box for the file name, and options to OK the file save or to CANCEL the save command.

1. Type in an appropriate file name with 8 characters or less. The extension .BLD will be automatically added. If you use another extension, it will be changed to .BLD.

2. Move the mouse pointer to the OK box using the mouse (or the [Tab] key on the keyboard.

3. Press the left mouse key once and release (or press the [Spacebar]) to activate the command.

The file will be saved with the designated file name.

If you select OK to save the project file and a project file of the same name exists, a dialog window will appear to verify if you want to replace (add changes to) the existing project file. Select YES to replace the existing file or select NO to not replace it. If you select NO, you will be prompted for another file name.

The Save As command saves the current model in a project file on the disk storage. The file may be saved under the current file name or a new file name may be inserted in place of the existing file name. When the file is saved under a new file name, the original version will remain unchanged. The extension .BLD is automatically added to the project file name.

Select the SAVE AS command from the FILE Menu.

A Save As dialog window appears in order to verify the project file name and directory where the file is to be stored. If the file has a name, the name will be highlighted in the box.
You may select another drive by selecting a new drive from the Drives box and another directory by double-clicking on a directory name, then select OK to save the file.

1. Type in a new file name (8 characters or less). The extension, .BLD will be automatically added to the file name.
2. Move the mouse pointer to the OK box in order to save the file (or press the [Enter] key on the keyboard).
3. Press the left mouse key once and release (or press the [Spacebar]) to activate the command.

If a project file of the same name exists, a dialog window will appear to verify if you want to replace (add changes to) the existing project file. Select YES to replace the existing file or select NO to not replace it. If you select NO, you will be prompted for another file name.

The current file name which is displayed on the screen in the title bar is changed to the new file name.

**PRINT DATA**

The PRINT DATA command prints specified criteria or load data. A dialog window prompts you for the list of data to be printed. Choose options from the selections given. All of the selected items will be combined for the output. You may print to the printer or to a file which you may review and edit before printing. A 'File Name' box is provided so that you may assign a file name to the data file.

If you print to a file, the Windows Notepad program window will automatically open with your designated file if you have the Execute Notepad box checked. You may edit your output file in Notepad by using the mouse pointer to position the cursor to insert text by typing from the keyboard or to delete text by using the backspace key. When you are done editing the file, you may save it, then print it by selecting the Save and Print commands from the Notepad File Pull-down Menu from the Menu Bar. Specific procedures for using Notepad are contained in the Windows Desktop
Applications User Guide. You must close the Notepad window to return to CASM. Use Close on the Notepad Control Menu or Exit on the Notepad File Menu.

If printing from the Notepad program, set the left margin to a maximum of 0.5 inches and right margin to 0.0 using the Page Setup command on the Notepad File Menu. The margins must be set every time Notepad is used.

When CASM output files are too large to load in Notepad, Windows Write may be used instead. Most analysis output files are too large for Notepad.

Select the PRINT DATA command from the FILE Menu.

A dialog window appears with several options. You may print out all of the selected output files which you have generated for your current project.

To select a print option:
1. Move the mouse pointer to the empty box to the left of the desired option.
2. Press the left mouse key once and release to select the desired option. An 'X' will appear in the box.

To deselect an item:
1. Move the mouse pointer to a box with an 'X' in it.
2. Press the left mouse key once.
   The 'X' will disappear.

To print to a file:
1. Move the mouse pointer to the left of the heading 'Print to file.'
2. Press the left mouse key and release.
   An 'X' will appear in the box. Deselect the 'X' in the 'Print to printer' box.

You may use the current file name for output or type in a new file name. Because output files can easily be created by CASM, we recommend you use default names and overwrite existing output files rather than generate new output files each time.

3. Move the mouse pointer to the 'File Name' box.
4. Press the left mouse key and drag the pointer across the current name in the box. Release the key when a dark bar highlights the current file name.

-OR-

Move the mouse pointer to the location in the current name where you want to delete characters with the backspace key and type in new characters. Press the left mouse key and a vertical cursor will appear.

5. Type in the new file name (8 characters or less, does not include the extension). The extension .TXT will automatically be added to the new file name.

To automatically open the Notepad program window with the designated file, move the mouse pointer to the Execute Notepad box and press the left mouse key. An "X" will appear in the box. If you do not want to automatically open Notepad ("X" is in the box), move the mouse pointer to the box and press the left key. The "X" will disappear.

To start printing the data file to a file:
1. Move the mouse pointer to the 'OK' box.
2. Press the left mouse key once to initiate the command to print the data to a file.
   If the Execute Notepad box does not have an "X" in it, then the data will be printed to a file and the Print Data pop-up window will disappear.

The CASM program will check for another file with the same name. If the program finds another file with the same name, a dialog window appears to confirm if you desire to replace (add changes to) the existing file which has the same name.
When the Execute Notepad option is selected, the Windows Notepad program window is automatically opened with your designated file. You may edit the file in Notepad by using the mouse pointer to position the cursor to insert text by typing from the keyboard or to delete text by using the backspace key. When you are done editing the file, you may save it, then print it by selecting the SAVE and PRINT commands from the File Pull-down Menu from the Notepad Menu Bar. Specific procedures for using Notepad are contained in the Microsoft Windows User Guide.

To return to the CASM program:
1. Move the mouse pointer to the Control Box in the top left-hand corner of the Notepad window.
2. Double click the left mouse key.
   -OR-
   a. Press the left mouse key.
   b. Move the mouse pointer down to the Close command in the Control Pull-down Menu.
   c. Press the left mouse key (or type the [C] key) to activate the command.

The Notepad program window will disappear and is replaced by the CASM program window.

To print to a printer:
1. Move the mouse pointer to the box to the left of the heading 'Printer (printer name).'
2. Press the left mouse key and release.
   An 'X' will appear in the box. Deselect the 'X' in the 'Print to file' box.
To start printing the data file to the printer:

1. Move the mouse pointer to the 'OK' box to start the printing.
2. Press the left mouse key once to initiate the command.

The Windows Print Manager program will be executed. You may open the Print Manager program window if you want to verify the active printing device and the port where it is connected. You may also use the Print Manager program window to pause or resume printing or to terminate the print out. To open the Print Manager program window, you must double-click on the Print Manager icon or select Print Manager from the Task List from the Switch To command on the Control Menu.

The Print Screen command saves the view of the model currently on the screen to a graphic file or sends the view directly to a printer. The graphic file may be written in several formats which can be accessed, modified, and printed by AutoCAD, Windows Draw, or Designer. A dialog window prompts you for the desired file format. If the view is copied to a Designer or Windows Draw .PIC file, it can be modified and then transferred to the WINDOWS CLIPBOARD, where it can be added to Windows Write or another Windows program which can paste graphics.

Select the PRINT SCREEN command from the FILE Menu.

A dialog window appears with several options. You may send the screen image directly to the printer or save (print) the screen image to a disk in the Designer (In* a* Vision). .PIC file format or the AutoCAD .DXF file format. A 'File Name' box is provided so that you can assign a file name to the screen view.

![Print Screen dialog window](image)
To print to a printer:
1. Move the mouse pointer to the circle to the left of the heading ‘Printer (printer name).’
2. Press the left mouse key and release.
   An black dot will appear in the box.
3. Enter the desired margin dimensions for the printer.
4. Select the desired orientation as Portrait (vertical) or Landscape (horizontal).

To start printing the screen image to the printer:
1. Move the mouse pointer to the ‘OK’ box to start the printing.
2. Press the left mouse key once to initiate the command.
   The Windows Print Manager program will be executed. You may open the Print Manager program window if you want to verify the active printing device and the port where it is connected. You may also use the Print Manager program window to pause or resume printing or to terminate the print out. To open the Print Manager program window, you must double-click on the Print Manager Icon or select Print Manager from the Task List from the Switch To command on the Control Menu.

To select a print to file option:
1. Move the mouse pointer to the empty circle to the left of the desired file option.

   You may change the Windows Draw or Designer options by using the CASM Settings command. Select the option which is installed on your computer.

2. Press the left mouse key once and release to select the desired option.
   A black dot will appear in the circle. Only one can be selected.

   To automatically open the Windows Draw or Designer program window with the designated file, move the mouse pointer to the Execute Windows Draw or Designer box and press the left mouse key. An “X” will appear in the box. If you do not want to automatically open Windows Draw or Designer (“X” is in the box), move the mouse pointer to the box and press the left key. The “X” will disappear.

3. Select the desired orientation as Portrait (vertical) or Landscape (horizontal).
4. Select the desired sheet size by clicking on the down arrow and selecting the size from the pull-down menu with the mouse.
5. If selecting an AutoCAD .DXF file, select either Screen or Exact coordinates.

   When you select the sheet size, the text is automatically scaled correctly. Use the Screen coordinates option to create a .DXF file of the screen view which you can modify with different fonts and additional notes. The Exact coordinates option produces a
dimensionally correct 2D .DXF file which you can dimension and add additional notes.

When saving the screen image to a file, you may use the default file name for output or type in a new file name.

6. Move the mouse pointer to the 'File:' box.
7. Press the left mouse key and drag the pointer across the current name in the box. Release the key when a dark bar highlights the current file name.

-OR-

Move the mouse pointer to the location in the current name where you want to delete characters with the backspace key and type in new characters. Press the left mouse key and a vertical cursor will appear.

8. Type in the new file name (8 characters or less, does not include the extension). The extension .PIC or .DXF will automatically be added to the new file name.

To start saving the screen display to a file:
1. Move the mouse pointer to the 'OK' box to save the data to a file.
2. Press the left mouse key once to initiate the command.

The current view of the model displayed on the screen will be saved to the designated file. If the Execute Windows Draw or Designer box does not have an "X" in it, then the image will be printed in a file and the Print Screen pop-up window will disappear.

The CASM program will check for another file with the same name. If the program finds another file with the same name, a dialog window appears to confirm if you desire to replace (add changes to) the existing file which has the same name.

The AutoCAD DXF file created by CASM contains a header for layers, linetypes, and text styles. If your default ACAD.DWG file contains layers, linetypes, text styles, or entities, the DXFIN command will skip loading the CASM DXF header because the drawing will not be considered new. If you get an error message saying that a linetype or text style is not defined, do the following steps:

- Load the CASM linetype file, CASM.LIN using the AutoCAD Linetype command or run the script file CASMDXF:SCR.
- Create a text style named MONOTEXT using the monospaced text font file.
- Do the DXFIN command again.

To load the AutoCAD Line type and Script files on your hard disk, use the CASM setup program and select "Extra Files: AutoCAD Files".

When the Execute Windows Draw or Designer option is selected and Windows Draw or Designer has been installed and is on the active DOS path, the
The Windows Draw or Designer program window is automatically opened with your designated file. You may edit the file by using the mouse pointer and the graphics commands in the Draw and Edit pull-down menus. When you are done editing the file, you may save it, then print it by selecting the Save and Print commands from the File Pull-down Menu from the menu bar. Specific procedures for using Windows Draw or Designer are contained in the User Guide.

If you selected Landscape or a sheet size other than 8 1/2 x 11, use the Page command in the Preferences pull-down menu to set the selected orientation and sheet size.

You may combine CASM graphic files in Windows Draw or Designer by using the Designer Import command.

To return to the CASM program:

1. Move the mouse pointer to the Control Box in the top left-hand corner of the Windows Draw or Designer window.
2. Double click the left mouse key.

-OR-

a. Press the left mouse key.

b. Move the mouse pointer down to the Close command in the Control Pull-down Menu.

c. Press the left mouse key (or type the [C] key) to activate the command.

The Windows Draw or Designer program window will disappear and is replaced by the CASM program window.
The Printer Setup command permits you to select a printer for your text and/or graphics output. Use the Setup box to change printer options.

Select the PRINTER SETUP command from the FILE Menu.

An Printer Setup dialog window appears with a list of printer drivers installed in Windows.

```
Printer Setup

Printer:
Epson LQ-2500 on LPT1:
HPGL Plotter on None
IBM Proprinter X24 on LPT1:
Panasonic LX-111/4 on LPT1
PostScript (Micrografx) on None

OK
Cancel
Setup...
```

To select a Printer:

1. Move the mouse pointer to the desired printer on the list.
2. Press the left mouse key once and release to select the desired option.
   - The selected printer appear in reversed text. You may use the Setup box to change printer default settings.
3. Move the mouse pointer to the OK box to save the printer selection.

The Import command will permit you to load an AutoCAD 2-D or 3-D graphic reference file. CASM translates the loaded DXF file into a new reference file with the extension REF. All layer changes and changes in reference locations are saved in the REF file. You may use the reference file to aid in developing the building geometry or structural framing layout based on the architect’s initial concept.

Before creating the AutoCAD DXF file, turn off unnecessary layers that you do not need when creating your CASM model. You also have the option of turning layers on/off in CASM.

Select the IMPORT command from the FILE Menu.

An Import dialog window appears with options to select AutoCAD 2D or 3D DXF files or CASM REF files.

A ‘File Name’ box is provided so that you may designate a file name to import.

To select a file to Import:

1. Move the mouse pointer to the empty circle to the left of the desired option.
2. Press the left mouse key once and release to select the desired option. A 'black dot' will appear in the circle. Only one item can be selected.
   a. If the DXF drawing is a plan, select Plan. If the DXF drawing is an elevation, select Elevation.
   b. If the DXF drawing is a plan, enter the Height above grade.
   c. If the DXF drawing is an elevation, select North, South, East, or West.

3. Move the mouse pointer to the desired file in the list of files below the 'File Name:' box.
4. Press the left mouse key to highlights the selected file name.
   The selected file name will appear in the 'File Name:' box.

To import the reference graphics file to your project file:

1. Move the mouse pointer to the 'Import' box.
2. Press the left mouse key once to initiate the command.

The designated reference graphics file will be drawn in light dashed lines. Use the Reference Menu in the Draw Model Tool Palette to control the reference file graphics. You may layout your model on the reference drawing by using the reference file coordinates.

The Export command will permit you to create an AutoCAD .DXF graphics file that you can load into a CAD program such as AutoCAD and create structural drawings such as framing plans or building sections. The Export command generates a 3-D .DXF file.
**Select the **Export** command from the **FILE Menu.**

A dialog window appears with a block for the Export file name. You may use the default file name for output or type in a new file name.

1. Move the **mouse pointer** to the 'Export Filename:' box.
2. Press the left mouse key and drag the pointer across the current name in the box. Release the key when a dark bar highlights the current file name.

-OR-

Move the mouse pointer to the location in the current name where you want to delete characters with the backspace key and type in new characters. Press the left mouse key and a vertical cursor will appear.

3. Type in the new file name (8 characters or less, does not include the extension). The extension .DXF will automatically be added to the new file name.

4. Select the check box to Export Only Visible Entities or de-select to export all entities.

**To start saving the structural model geometry to a DXF file:**

1. Move the **mouse pointer** to the 'EXPORT' box to save the model geometry to a file.
2. Press the **left mouse key** once to initiate the command.

The geometry of the structural model will be saved to the designated file. Structural framing plans and sections can be generated from the Exported files once they have been loaded into a CAD program.

The AutoCAD DXF file created by CASM contains a header for layers, linetypes, and text styles. If your default ACAD.DWG file contains layers, linetypes, text styles, or entities, the DXFIN command will skip loading the CASM DXF header because the drawing will not be considered new. If you get an error message saying that a linetype or text style is not defined, do the following steps:

- Load the CASM linetype file, CASM.LIN using the AutoCAD Linetype command or run the script file CASMDXFSCR.
- Create a text style named MONOTEXT using the monospaced text font file.
- Do the DXFIN command again.
To load the AutoCAD Line type and Script files on your hard disk, use the CASM setup program and select “Extra Files: AutoCAD Files”.

Once you have loaded the CASM AutoCAD file, you may turn off layers that you do not need, in order to view the structural members. You may use the AutoCAD 3D viewing option for 3D views of the CASM model.

The CASM SETTINGS command permits you to adjust the mouse speed for CASM drag and handle selection operations. You may also select which graphics program to execute when using the CASM Run command or the Print Screen command from the CASM File pull-down menu. You select the graphics program which is installed on the computer. The initial method of inputting coordinates can be selected as the mouse or the keyboard. The CASM graphics font and other various workspace settings can also be configured.

Use the Mouse Settings in the Windows Control Panel to adjust the mouse tracking speed and double click speed.

Select the CASM SETTINGS command from the File menu:

A CASM Settings dialog window appears to permit you to change the mouse speed, the designated graphics program, or the tool palette display.

To change the mouse speed:

1. Move the mouse pointer to the square box on the scroll bar between the Fast and Slow boxes.
2. Press and hold the left mouse key and drag the box toward the fast or slow speed boxes.
3. Release the left mouse key.

You will note the change in mouse speed when dragging an object on the screen.
To change the designated graphics program, Windows Draw or Designer:

1. Move the mouse pointer to the desired option button.
2. Press the left mouse key.

The option button will be highlighted. The selection options are changed on the Run Application dialog window and the Print Screen dialog window.

To change the coordinate input:

1. Move the mouse pointer to the desired option button, Mouse or Keyboard.
2. Press the left mouse key.

If the Keyboard is selected, dialog boxes will appear whenever coordinate input is needed. Otherwise, the mouse will be used to input coordinates with the option of using the F2 or F3 function keys to change to keyboard entry.

To change the graphics font:

You can only change the font for Windows version 3.1.

The type of font used for text on the modeling screen is displayed to the left of the Font box.

1. Select the Font box with the mouse.

A Font dialog window will appear with font, style, and size selections.

2. With the mouse select the desired font, style, and size.

The selected items will be highlighted. A sample will appear at the bottom of the dialog window.

3. Select OK with the mouse to save the font selections.

To change button (icon) settings on the Tool Palettes:

1. Select the Button Scale list arrow with the mouse to display the list of scales.
2. Select the desired scale. 1 is the default scale, 2 is the largest scale.
3. Enter a new value in the Separator Width window to change the number of pixels between button groups. 2 is the default setting.
FILE MENU

To change other workspace settings:
1. Move the mouse pointer to the Background Color list arrow. Select Black or White from the pull-down list to change the background color on the modeling screen.
2. Select the Double Buffer check box with the mouse to prevent the CASM graphics display for flashing when updated. Recommended for fast computers.
3. Select the Swap Data to Disk When an icon check box to transfer data to disk to free more memory. However, the transfer of data to Excel and back to CASM will be slower.

To save CASM Settings selections and display them on screen:
1. Select OK to save the settings or Cancel to exist the CASM Settings dialog window without saving the settings.

The new settings will be activated and/or displayed on the modeling screen.

EXIT

The Exit command will permit you to close the file. A prompt will appear to remind you to SAVE the file if you have made changes to it.

Select the EXIT command from the FILE Menu.

A dialog window appears to confirm if you want to save the changes to the project file. It allows you to save changes to the file if you have forgotten to do so.

If changes have been made to the current project file:
A dialog box prompts you to save changes to the current project file.
1. Move the mouse pointer to the YES or NO box.
2. Press the left mouse key to indicate your selection.
   a. If you select YES to save the project file and the file is named, the hourglass symbol will be displayed while the file is saved to disk.
   b. If you select YES to save the project file and the file is (untitled), you will be prompted for a project file name.
   c. If you select NO to not save changes to the project file, the current project file will be stopped without adding the changes.
   d. If you select CANCEL, you will remain in the current CASM project file.
<table>
<thead>
<tr>
<th>To save changes if the file is (untitled):</th>
</tr>
</thead>
<tbody>
<tr>
<td>A pop-up dialog window appears which displays the current directory, a box for the file name, and options to OK the file save or CANCEL the save command.</td>
</tr>
<tr>
<td>1. Type in an appropriate file name with 8 characters or less. The extension .BLD will be automatically added. If you add another extension it will be changed to .BLD.</td>
</tr>
<tr>
<td>2. Move the mouse pointer to the OK box.</td>
</tr>
<tr>
<td>3. Press the left mouse key once and release.</td>
</tr>
<tr>
<td>The project file will be saved, the CASM program will stop, and you will be returned to the Windows Program Manager Application.</td>
</tr>
<tr>
<td>If you select OK to save the project file and a project file of the same name exists, you will be prompted if you want to replace (add changes to) the existing project file.</td>
</tr>
</tbody>
</table>
VIEW MENU

The View Menu is a pull-down menu used to manipulate the CASM model on the screen. Use the View Pull-Down Menu to display information on the screen, to select different model views, to select structural planes, to store and recall views, and to restore the initial viewpoint.

To select a command from the VIEW Menu with the mouse:
1. Move the mouse pointer to the View heading on the pull-down menu bar of the CASM program window.
2. Press the left mouse key.
3. Move the mouse pointer down the command list to the selection you want (you may also activate the command by typing the underlined letter in the desired command).
4. Press the left mouse key to carry out the command.

A dialog window will appear or the model display will be changed.

To select a command from the VIEW Menu with the keyboard:
1. Press the [Alt] key and the [V] key together.

The View Menu will appear.
2. Type the underlined letter of the command to carry out the command.

-OR-

Use the up or down directions on the keyboard to move the selection bar up or down. Then press the [Enter] key to carry out the command.

To select a View Menu command icon from the Side Tool Palette:
1. Move the mouse pointer to the desired View Menu icon.

If the CASM window has been reduced in size, the icons at the bottom of the Side Tool Palette may not be displayed on the screen.
2. Press the left mouse key.

The dialog window for the selected View Menu icon will be displayed on the screen or the model display will be changed.

The VIEW Menu command selections are listed on the following pages:
A dialog window is displayed which shows information about openings, assigned loads on a selected plane (i.e. wall, roof, floor), and lateral resistance systems. The plane is selected by using the Structural Plane Name drop-down list on the Bottom Tool Palette or by selecting the planar views when in the perspective view of the model. The Structural Plane Name can be changed by modifying the name text. The window remains on the screen and displays information on structural planes as they are selected. Use the Control menu to close the Plane Information window or reselect the Structural Plane Information command.

Select the Structural Plane Information command from the View menu.

A Dialog Window will appear. The Dialog Window displays information about openings, assigned loads for a selected plane, and lateral resistance systems. Select a different structural plane and the opening and load information for the structural plane is displayed.

<table>
<thead>
<tr>
<th>Name: Floor 2</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Openings</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Opening 1</td>
</tr>
<tr>
<td>Opening 2</td>
</tr>
<tr>
<td><strong>Loads</strong></td>
</tr>
<tr>
<td>Name</td>
</tr>
<tr>
<td>Assembly: Movable seats</td>
</tr>
<tr>
<td>Floor Type 1</td>
</tr>
<tr>
<td>Wall Type 1</td>
</tr>
<tr>
<td><strong>Lateral Resistance</strong></td>
</tr>
<tr>
<td>EW-1</td>
</tr>
<tr>
<td>EW-2</td>
</tr>
<tr>
<td>NS-1</td>
</tr>
<tr>
<td>NS-2</td>
</tr>
</tbody>
</table>

- To change the Structural Plane Name, use the keyboard to change the Name text.
- To change opening information, double click the left mouse key on the opening name to be changed. An input dialog window will appear.
- To change load information, double click the left mouse key on the load name to be changed. The Loads dialog window will appear. Snow, wind, minimum roof live load, and seismic loads cannot be changed.
- Lateral resistance information cannot be changed.

To close the dialog window:
1. Move the mouse pointer to the Control pull-down menu box.
2. Double click the left mouse key to close the dialog window or select Close from the Control pull-down menu to remove the dialog window from the screen. (Or reselect the Structural Plane Information command on the View menu.)

**SHOW LOADS**

A window is displayed which permits you to selectively display loads on the model. Only the loads shown in bold print are available. Move the mouse pointer to the check box (or load name) and press the left mouse key to select the load you wish to display. After you select OK the load will be displayed on the model.

**Klow is displayed which permits you to selectively display loads on the model.**

**Only one load type can be displayed at a time.**

Select the Show Loads command from the View menu.

The Show Loads Dialog Window will appear.

To display loads:
1. Move the mouse pointer to the selection box next to the desired load.
2. Press the left mouse key.

A dot will appear in the circle when the load is selected for display. Only one option will remain selected.

After selecting the desired load for display:
3. Move the mouse pointer to the OK confirmation box. (You may select the cancel box if you decide not to make any changes.)
4. Press the left mouse key.

The selected loads will be displayed on the structural model.

To not display any loads:
1. Move the mouse pointer to the Show None button.
2. Press the left mouse key.
A window is displayed which permits you to selectively display structural elements on the model. Only the items shown in bold print are available. Move the mouse pointer to the check box (or item name) and press the left mouse key to select the item you wish to display. After you select OK, the selection will be displayed on the model.

Select the Show Structure command from the View menu.

The Show Structure Dialog Window will appear.

To display structure:
1. Move the mouse pointer to the selection box next to the desired structural element.
2. Press the left mouse key.
   
   An 'X' will appear in the box when the structural element is selected for display. To deselect a structural element, move the mouse pointer to a box with an 'X' in it; press the left mouse key, and the X will disappear. The structural element has been deselected.

After selecting all desired structural elements for display:
3. Move the mouse pointer to the OK confirmation box. (You may select the cancel box if you decide not to make any changes.)
4. Press the left mouse key.

The selected structural elements will be displayed on the structural model in all views.
When viewing your model in 3D, the only structure that will be visible is the last viewed structural plane. To view structural elements on all levels, you need to select the "All Planes" option.

The vertical lateral resistance shear wall flanges will only be displayed on rigid diaphragm horizontal planes.

**MODEL VIEWS**

**PERSPECTIVE (3D)**

A three-dimensional view of the model in three-point perspective is displayed in the modeling window. The viewing angle, distance, height, and viewing center may be varied as desired with the Viewpoint Tools.

*Select Perspective (3D) command from the View menu or Side Tool Palette.*

The model will be displayed in 3-D. Either Wire frame, Transparent, or Solid display options may be selected.

**PLAN**

A plan view of the model is displayed on the screen. The Viewpoint Direction tool can be used to reorient the plan north, south, east, or west. The Distance tool, Zoom Window tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

*Select Plan command from the View menu or Side Tool Palette.*

A plan view of the model will be displayed in 2-D.

**ELEVATION**

An orthogonal view of an elevation is displayed. The Viewpoint Direction tool can be used to select north, south, east, or west elevations. The Distance tool, Zoom Window tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

*Select Elevation command from the View menu or Side Tool Palette.*

An elevation of the model will be displayed in 2-D.

**SECTION**

An orthogonal view of a model section is displayed. The Distance tool, Zoom Window tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

*When you do Snow or Wind load generation, the display is automatically switched to the Section display.*
Select Section command from the View menu.

A plan view of the model is displayed at the top of the viewing window with a section cut line extending through it. A small section of the model is displayed below the plan view.

- Moving the mouse toward/away will move the section cut line through the model.
- Press the left mouse key to change the section view.
- **Double click the right** mouse key to select the desired section of the model to display on the screen.

**HORIZONTAL STRUCTURAL PLANE**

A plan view of a horizontal structural plane from the model is displayed on the screen. The Distance tool, Zoom Windows tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

**INCLINED STRUCTURAL PLANE**

A plan view of an inclined structural plane from the model is displayed on the screen. The Distance tool, Zoom Windows tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

You must be in the Perspective (3D) display in order to select an Inclined Structural Plane display. You can select an Inclined Structural Plane when in other views by use of the Structural Plane Name drop-down list.

Select Inclined Structural Plane command from the View menu.

All incline levels of the model are highlighted and marked by a yellow square for selection.

- Click the left mouse key once after the cursor has been located on the yellow square.

A plan view of the selected level is displayed on the screen. The structural plane name is displayed in the Structural Plane Name pull down list.
A plan view of the selected inclined structural plane is displayed on the screen. The structural plane name is displayed in the Structural Plane Name pull down list.

A vertical structural plane from the model is displayed on the screen. The Pan tool, Zoom Windows tool, and View Previous tool on the Side Tool Palette will permit you to zoom in and out. The Pan tool will permit you to pan the display on the screen.

You must be in the Perspective (3D) display in order to select a Vertical Structural Plane display. You can select a Vertical Structural Plane when in other views by use of the Structural Plane Name command.

Select Vertical Structural Plane command from the View menu.

All Vertical planes (interior and exterior) of the model are highlighted and marked by a yellow square for selection.
- Click the left mouse key once after the cursor has been located on the yellow square.

An elevation of the selected vertical structural plane is displayed on the screen. The structural plane name is displayed in the Structural Plane Name pull down list.

The Pan command permits you to change the 3D viewing center and position the 2D display on the screen.

Select Pan command from the View menu or Side Tool Palette.

- Move the mouse in the direction which you desire to Pan the 2D display (right, left, away-up, toward-down) or the 3D display (right - E, left - W, away - N, toward - S, hold right mouse key down for vertical movement).

When the mouse is moved, the 2D display will pan on the modeling screen or the viewing center will change on the 3D display.

Double click the right mouse key to cancel panning the display.
- Press the left mouse key to save the location.

The Zoom Window command permits you to zoom into a portion of a 2D display.

You must be in a 2D view to use the Zoom Window command.

Select Zoom Window command from the View menu or Side Tool Palette.

The Zoom Window icon is highlighted and the mouse pointer changes to a plus (+) symbol.
Move the mouse pointer to one corner of the desired zoom window.

Press the left mouse key.

Move the mouse pointer to the opposite corner of the desired zoom window.

When the mouse is moved, the zoom window is dragged to the opposite corner.

Double click the right mouse key to cancel zooming the display.

Press the left mouse key when the desired view is established.

The selected area will be displayed on the screen.

The View Previous command permits you to go back to the previous 2D view. This command can be used after the Zoom Window, Pan, or Distance Zoom commands.

You must be in a 2D view to use the View Previous command.

Select View Previous command from the View menu or from the Side Tool Palette.

The previous view will be displayed. If there are no previous views, the View Previous icon will be gray and there will be no response when selected.

The Wire frame display is the default 3-D display. All of the edges of each shape are defined by lines. No hidden line removal is available in the Wireframe display.

Select Wire frame command from the View menu or Side Tool Palette.

If a solid model is displayed, the model will change to a 3D Wire Frame model.

The Transparent display is a shaded 3-D display. You may use the Transparent command to make the building model partially transparent (solid) in order to view other objects or items inside or on the other side of the model.

Select Transparent command from the View menu or the Side Tool Palette.

If a solid or wire frame model is displayed, the model will change to a Transparent 3D model.

The view remains shaded until the view is redrawn by changing orientation, height, or distance.

The Solid display is a shaded 3-D display. All of the visible planes of the model are colored. The model is highlighted by two light sources to enhance the perspective.
Select Solid command from the View menu or the Side Tool Palette.

If a wireframe model is displayed, the model will change to a Solid 3D model.

The view remains shaded until the view is redrawn by changing orientation, height, or distance.

A shape that blocks the view of an important feature or degrades the overall view of the model may be selected and turned off (hidden from view).

You must be in the Perspective (3D) display in order to select the Hide Shapes display.

Select Hide Shapes command from the View menu or Side Tool Palette.

All visible planes on shapes are highlighted and marked by a yellow square for selection.

- Click the left mouse key once after the cursor has been located on the yellow square.
  
  The selected shape will disappear. You will remain in the Hide Shapes mode.

- Double click the right mouse key to get out of the Hide Shapes command.

All of the selected shapes will remain hidden until you use the Show Shapes command.

All shapes that were hidden are turned on when you select Show Shapes from the View menu.

Select Show Shapes command from the View menu or Side Tool Palette.

All hidden shapes will be turned on.

Returns display of the model to Distance and Height to view the entire ground plane if in Perspective (3D) or fill the screen if in a 2-D view.

Select Full Screen command from the View menu or Side Tool Palette.

If the Perspective (3D) view is displayed, the model will be returned to a Distance and Height to view the entire ground plane. If a 2D plane is selected, the display will be redrawn to fill the screen.

Permits the storage of four selected views of the model for recall and evaluation.

Select Store View command from the View menu or Side Tool Palette.

A Store View dialog window appears with four view storage selections.


- Move the mouse pointer to the number where you want to store the view. Press the left mouse key. The selected view is stored for later recall with the Recall View command.

Permits selection of one of four previously stored views.

*Select Recall View command from the View menu or Slide Tool Palette.*

A Recall View dialog window appears with four view storage selections.

- Move the mouse pointer to the number of the view that you want to recall. Press the left mouse key.

The view is displayed on the screen.
The Criteria Menu is used to produce a data file of project-specific data and meteorological data which influence the design live loads on the structural model. Three dialog windows which contain project-related data will appear. Data entered via the Criteria pull-down menu will be added to a project criteria file that may be printed by the Print Data command on the CASM File pull-down menu. The Wind Rosette selection is not active.

Data for specific Cities/Installations may be stored and recalled by using the Windows Cardfile program. Thus several criteria data boxes may be automatically filled in by entering the desired City/Installation.

Data entered via the Criteria pull-down menu are used for the Loads Menu. When applying wind, snow, or seismic loads to the model, the initial values and building code parameters are taken from the Criteria lists.

If you press the [Enter] key when typing data into the data boxes, the Criteria window will disappear. All the data which you have entered will be saved. You will need to re-open the Criteria window if you have not finished entering data.

To select a criteria dialog window from the CRITERIA pull-down Menu with the mouse:
1. Move the mouse pointer to the Criteria heading on the system menu bar of the CASM Application Window.
2. Press the left mouse key.
   The Criteria Pull-Down Menu will appear.
3. Move the mouse pointer down the command list to the selection you want.
4. Press the left mouse key to carry out the command.
   A Criteria dialog window will appear.

To select a command from the CRITERIA Menu with the keyboard:
1. Press the [Alt] key and the [C] key together.
   The Criteria Pull-Down Menu will appear.
2. Type the underlined letter of the command to carry out the command.
-OR-
   Use the up or down directions on the keyboard to move the selection bar up or down. Press the [Enter] key to carry out the command.
   A Basic Design Criteria Dialog window will appear to permit the entry of data or the selection of preset data from a variety of data windows.

To enter or change selections or data in the criteria dialog windows:
1. Move the mouse pointer to the appropriate box.
2. Press the left mouse key once and release.
   For text boxes that contain preset data from a data list, use the drop down list button or the data window button to display the data.
A vertical cursor line will be flashing in the text box. You may type the appropriate data into the box. Use the [Backspace] and/or [Del] keys to edit the input.

You may use the Windows Cardfile to develop a database of code and meteorological data for a variety of City/Installations. The City/Installation will be displayed in a list when you select the City/Installation box on the Project Data Criteria. Choosing the appropriate City/Installation from the list will automatically fill in several boxes on the three Criteria dialog windows. If the desired City/Installation is not on the list, the Criteria Data must be entered item by item. Specific procedures for using Cardfile are contained in the Microsoft Windows User's Guide.

---

**Data blocks on Cardfile cards:**

- Country
- State
- Metric
- County
- Design Load
- Elevation (ft)
- Ave Rain (in) Max Rain (in)
- Ground Snow Load (psf)
- Max Snow Depth (in)
- Basic Wind Speed (mph)
- Max Wind Spd (mph) Wind Dirctn Coastal (Y/N)
- Max Temp (°F) Min Temp (°F)
- Frost Depth (ft) Seismic Zone

*You may create new data cards by:*

1. Select Run from the CASM Control pull-down menu.
The Run Application pop-up window will appear.

2. Move the mouse pointer to the Cardfile name or circle.
3. Press the left mouse key.
   A black dot will appear in the circle.
4. Move the mouse pointer to the OK box and press the left mouse key.
   The Cardfile application window will appear on top of the CASM window.
5. Select Open from the Cardfile File pull-down menu.
   The Open File pop-up window will appear with a listing of Cardfile .CRDF files.
6. Place the mouse pointer on the CITIES.CRF file.
7. Double click the left mouse key.
   The current listing of cities/installations and data will be displayed on notecards.
   You may use the Duplicate Command in the Card pull-down menu to create more cards. Then you can replace the data in the duplicated cards as necessary to create new data cards.
   You may use the mouse pointer to position the cursor on the card and use the keyboard to edit the text. Save the new data by using the Save command from the Cardfile File pull-down menu or by using the Save dialog window when exiting the Cardfile program. To exit the Cardfile application, select Close from the Control pull-down menu.

Add the word "Metric" after the state, if the data is in metric units.

Use the following sequence to input or select data for the Design Criteria lists.

The Project selection displays a project information data form including project size, location, and governing codes. Project information is used to print out headings for printouts, to automatically set regional and site-specific data, and to provide a record of specific project information.

Select the PROJECT command from the CRITERIA Menu.

A Basic Design Criteria: Project Data dialog window appears. Use the following sequence to enter or change Project Data selections, entries, or values.

To enter or change the Project Name:
If the value is already highlighted, type in the appropriate entry. If the value is not highlighted:
1. Move the mouse pointer to the 'Project Name' box.
2. Press and hold the left mouse key and drag the pointer over the current entry. Release the mouse key when the current entry is highlighted.
3. Type in a new project name. Use the backspace key to make corrections.
The project name will be used as a heading for the printed data such as Project Criteria and Loads.

To select the City/Installation from a list of Cities/Installations prepared by the CARDFILE program:

1. Move the mouse pointer to the 'City/Installation' drop-down list button.
2. Press the left mouse key and release.

A list will appear which contains a Cardfile listing of Cities/Installations.

3. Move the mouse pointer to the desired selection.

Use the up or down arrows or the white rectangle on the vertical bar between the arrows to see more selections on the list. Place the mouse pointer on the white rectangle, then press and hold the left mouse key as you move the mouse toward and away from you to view more selections.

4. Press the left mouse key and release.

The selection will appear in the 'City/Installation' box. Also, the following data selections and entries will be automatically inserted in the Criteria windows.
Verify the database entries. Complete the remaining entries in the Criteria Windows.

To enter or change the City/Installation entry if it is NOT listed in the CARDFILE database:

1. Type in the appropriate City/Installation. Use the backspace key or drag the mouse pointer to modify or correct entries.

The procedures listed below apply to the following text boxes:

<table>
<thead>
<tr>
<th>Country</th>
<th>No. of Stories</th>
</tr>
</thead>
<tbody>
<tr>
<td>State</td>
<td>Floor Area</td>
</tr>
<tr>
<td>County</td>
<td>Occupancy</td>
</tr>
<tr>
<td>Elevation</td>
<td>Type Construction</td>
</tr>
</tbody>
</table>

To enter or change entries:

1. Move the mouse pointer to the appropriate data box.
2. Press and hold down the left mouse key and drag the pointer over the current entry. Release the mouse key when the entry is highlighted.
3. Type in the appropriate data. Use the backspace key to modify or correct entries.

The procedures listed below apply to the following text boxes:

- Design Load
- Building Code
- Seismic Code

The Design Load data box permits you to select the design load criteria which controls the design load values and calculations in CASM.

For Design Loads, either the TM 5-809-1 1986 or the new TM 5-809-1 1991 (which is the ASCE 7-88 code) can be selected. The Tri-Services design load name uses the TM 5-809-1 1986 criteria.

The Seismic criteria and calculations are based on the SEAOC seismic code which will be the new TM 5-809-10 code.

To enter or change entries:

1. Move the mouse pointer to the drop down list button.
2. Press the left mouse key and release.
   A list of selections will appear on the screen.
3. Move the mouse pointer to the desired selection.
   Use the up or down arrows or the white rectangle on the vertical bar between the arrows to see more selections on the list.
4. Press the left mouse key and release to select an entry.
   The selection will appear in the appropriate data box.
The procedures listed below apply to the following text boxes:

Lateral Load Resistance: N-S System E-W System
N-S Rw E-W Rw

To enter or change Lateral Load Resistance entries:

1. Move the mouse pointer to the data window button next to the N-S System or the E-W System.
2. Press the left mouse key.
   
   A Lateral Load Resisting System dialog window will appear with a list of structural systems and corresponding Rw values and height limits.

<table>
<thead>
<tr>
<th>Structural System #1</th>
<th>Rw #5</th>
<th>H #2</th>
</tr>
</thead>
<tbody>
<tr>
<td>b. Concrete #3</td>
<td>4</td>
<td>-</td>
</tr>
<tr>
<td>c. Heavy Timber</td>
<td>4</td>
<td>65</td>
</tr>
<tr>
<td>B. Building Frame System</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1. Steel Eccentric Braced Frame (EBF)</td>
<td>10</td>
<td>240</td>
</tr>
<tr>
<td>2. Light Framed Walls With Shear Panels</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a. Plywood Walls for Structures 3-stories or Less</td>
<td>9</td>
<td>65</td>
</tr>
<tr>
<td>b. All Other Light Framed Walls</td>
<td>7</td>
<td>65</td>
</tr>
<tr>
<td>3. Shear Walls</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a. Concrete</td>
<td>8</td>
<td>240</td>
</tr>
<tr>
<td>b. Masonry</td>
<td>8</td>
<td>160</td>
</tr>
<tr>
<td>4. Concentric Braced Frames</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a. Steel</td>
<td>8</td>
<td>160</td>
</tr>
</tbody>
</table>

Notes:

1. Basic Structural Systems are defined in Section 1.0.6.
2. H = Height Limit applicable to Seismic Zones 3 and 4. See Section 1.0.7 for exceptions.

3. Move the mouse pointer to the appropriate project structural system. Use the vertical scroll bar at the right side of the list to view other systems.
4. Press the left mouse key.
   
   The selection is highlighted.
5. Select OK to save the selection or Cancel to exist the dialog window without saving.
   
   The selected system type and Rw value are automatically inserted in the text boxes. Initially the N-S and E-W text boxes will be filled in with the same values. You may select the text box for the system in the other direction and select a different structural system, if necessary.

To verify the entries in the Project Data dialog window and add them to the Project data file:

1. Move the mouse pointer to the 'OK' box at the bottom of the 'Project Data' dialog window.
2. Press the left mouse key once and release.
   
   All entries in the dialog window will be added to the Project File. The Project Data Criteria dialog window will disappear.
The Regional selection displays a regional information data form including meteorological influences on the structural model. Regional information is used for applied loads and design influences on the structural model. Data may be preselected by the Project Information or overwritten by direct input.

Select the Regional command from the Criteria Menu.

A Basic Design Criteria: Regional Data dialog window appears. Use the following sequence to enter or change Regional Data selections, entries, or values.

<table>
<thead>
<tr>
<th>Wind</th>
<th>Rain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Wind Speed: 70.0 mph</td>
<td>Annual Average: 12.0 in</td>
</tr>
<tr>
<td>Coastal:</td>
<td>Max. Storm:</td>
</tr>
<tr>
<td>Max. Wind Speed: 71.0 mph</td>
<td>7.33 in</td>
</tr>
<tr>
<td>Direction: SE</td>
<td>Temperature:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Snow</th>
<th>Seismic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ground Snow Load: 5.0 psf</td>
<td>Zone: 2A Z: 0.150 in</td>
</tr>
<tr>
<td>Max. Depth: 6.8 in</td>
<td>Frost Depth: 0 in</td>
</tr>
<tr>
<td>Snow Density: 14.6pcf</td>
<td>Depth: 0</td>
</tr>
</tbody>
</table>

The procedures listed below apply to the following data boxes:

- Wind: Basic Wind Speed, Max Wind Speed, Direction
- Snow: Ground Snow Load, Maximum Depth, Snow Density
- Rain: Annual Average, Max Storm, Temperature
- Seismic: Zone, Frost Depth

The Basic Wind Speed value and Ground Snow Load values are used for Wind Load and Snow Load calculations.

To change or enter values:
1. Move the mouse pointer to the appropriate text box.
2. Press and hold down the left mouse key and drag the pointer over the current value. Release the mouse key when the value is highlighted.
3. Type the appropriate value in the text box. Use the backspace key to modify or correct entries.
The Snow Density value is automatically calculated based on the Ground Snow Load value.

**To select/deselect the Coastal hurricane coefficient:**
1. Move the mouse pointer to the Coastal data box.
2. Press the left mouse key once and release.

   To select the Coastal condition (within 100 miles of a hurricane coastline), press the mouse key until there is an 'X' in the box.

**To enter or change Seismic Zone Factors:**
1. Move the mouse pointer to the Seismic Zone data window button.
2. Press the left mouse key.

   A Seismic Zone Factor Dialog window will appear.

   ![Seismic Zone Factor Dialog Window]

   3. Move the mouse pointer to the desired zone designation.
4. Press the left mouse key.

   The option button will be highlighted.
5. Select OK to save the selection or Cancel to exit the dialog window without saving.

   The dialog window will disappear and the Zone designation and factor will be displayed in the Seismic group box.

**To verify the entries in the Regional Data dialog window and add them to the Project data file:**
1. Move the mouse pointer to the 'OK' box at the bottom of the 'Regional Data' dialog window.
2. Press the left mouse key once and release.

   All entries in the dialog window will be added to the Project File. The Regional Data Criteria dialog window will disappear.
The site selection displays a site-specific information data form including data which directly affect the meteorological influences on the structural model and data on the soil at the site. Site-specific information is used for equation factors for applied loads and for influence on foundation design.

Select the SITE command from the CRITERIA Menu.

A Basic Design Criteria: Site Specific Data dialog window appears. Use the following sequence to enter or change Site Specific Data selections, entries, or values.

The procedures listed below apply to the following text boxes:

Wind: Importance, Exposure, Seismic: Importance, Soil Factor

Snow: Importance, Exposure, Thermal

All displayed factors are used for Wind, Snow, and Seismic Load calculations.

To change or enter Importance, Exposure, Thermal, or Soil factors:

1. Move the mouse pointer to the appropriate data window button.
2. Press the left mouse key once and release.
   A dialog window will appear with code values and descriptions.
3. Move the mouse pointer to the circle in front of the desired selection.
4. Press the left mouse key once and release.
   A solid dot will appear in the circle to indicate your selection.
I AN

**High Risk**
- Buildings where primary occupancy is for assembly of 300 or more people in one area; i.e., auditoriums, recreational facilities, dining hall, commissaries, etc.
- Buildings having high value equipment.
- Facilities involving missile operations.
- Facilities involving sensitive munitions, fuels, chemical and biological contaminants.

**Essential Facilities**
- Buildings housing critical facilities which are necessary for post-disaster recovery and require continuous operation; i.e., hospitals, power stations, fire stations, communications buildings, and other structures housing mission essential operations.

To use the Guidelines button at the bottom of the Seismic Importance Factor dialog window to display the description of the importance values.

**To transfer the selection to the Site Specific Data dialog window:**
1. Move the mouse pointer to the 'OK' box at the bottom of the window.
2. Press the left mouse key once to transfer the selection.

The selected value will appear in the Site Specific Data dialog window.

**To change or enter the Distance to Oceanline value:**
1. Move the mouse pointer to the 'Distance to Oceanline' box.
2. Press and hold down the left mouse key and drag the pointer over the current value. Release the left mouse key when the current value is highlighted.
3. Type in the appropriate value.
   
   Appropriate values range from 0 to 100 miles from a hurricane coastline.

**To change the 'Roof Slippery' check box:**
1. Move the mouse pointer to the check box.
2. Press the left mouse key once and release.

To select the condition noted, press the mouse key until there is an 'X' in the box. An empty box indicates the condition is not selected (i.e., no 'X' in the Roof Slippery box means the roof is NOT slippery).
To enter soil data:
1. Move the mouse pointer to the 'Soil Name' box.
2. Press and hold down the left mouse key and drag the pointer over the current entry. Release the mouse key when the current entry is highlighted.
3. Type in an appropriate soil information heading.

To enter values for the Soil Bearing Pressure, Equivalent Fluid Pressure, Water Table depth, Slope, Depth to Bottom of Footing, and the three blank data blocks:
1. Move the mouse pointer to the appropriate data box.
2. Press and hold down the left mouse key and drag the pointer over the current value. Release the mouse key when the current value is highlighted.
3. Type in the appropriate values.

Once the Soil Information List is complete, several options are available:

- Soil data is automatically saved for each unique name. Use the drop-down list to view other soil boring locations.

To verify the entries in the Site Specific Data dialog window and add them to the Project data file:
1. Move the mouse pointer to the 'OK' box at the bottom of the 'Site Specific Data' dialog window.
2. Press the left mouse key once and release.

All entries in the dialog window will be added to the Project File. The Site Specific Data Criteria dialog window will disappear.

**Wind Rosette (Not Implemented)**

Aids the user in developing a chart depicting seasonal wind speed and directions. The wind rosette is used to influence building design.
HELP MENU

The Help Menu is used to provide the user with detailed guidance on how to use CASM commands. The Contents command which can be activated by selecting the F1 function key contains an outline of all of the CASM commands. Any command on the outline can be selected for specific information on how to use it. The Modeling hints option describes some hints, options, and ramifications when drawing the buildings geometric model. Text for the command descriptions and modeling hints is taken directly from this guide. The Search for Help On command permits you to quickly locate a command which you maybe having difficulty with. The How to Use Help command contains specific guidelines on how to use the help dialog windows. The About CASM command contains CASM program information such as the version number and date. It also includes a block which shows the amount of free memory available.

To select a command from the HELP pull-down Menu with the mouse:
1. Move the mouse pointer to the Help heading on the system menu bar of the CASM Application Window.
2. Press the left mouse key.
   The Help Pull-Down Menu will appear.
3. Move the mouse pointer down the command list to the selection you want.
4. Press the left mouse key to carry out the command.
   A Help dialog window will appear.

To select a command from the HELP Menu with the keyboard:
1. Press the [Alt] key and the [H] key together.
   The Help Pull-Down Menu will appear.
2. Type the underlined letter of the command to carry out the command.
   -OR-
   Use the up or down directions on the keyboard to move the selection bar up or down. Press the [Enter] key to carry out the command.
   A Help dialog window will appear.

To select topics for review in the Help dialog windows:
1. Move the mouse pointer to the colored text representing the topic which you need help.
   The mouse pointer will change to a small pointing finger.
2. Press the left mouse key once and release.
   Additional Help dialog windows will appear to describe the command or sequence which you selected.

The HELP Menu commands are listed on the following pages:
The Contents command displays a CASM Help Table of Contents. The pull down menu bar contains menus with commands to aid in using the CASM Help. The File pull down menu permits you to select a printer and print a topic. The Edit pull down menu permits you to copy Help text to the clipboard and Annotate the Help text as a reminder to other users. The Annotated text is marked by a green mark to the left of the paragraph which can be selected to display the annotated text. The Bookmark pull down menu permits you to save your location in the CASM listing of commands. Your saved location is added to the Bookmark pull down menu list so that you can go directly to your saved location. The Help pull down menu contains information on how to use Help. The Always on Top selection is a setting which will keep the help dialog windows permanently displayed. The About Help command displays a dialog window showing the Help program version number, software license information, the amount of free memory available, and the percentage of free system resources available. The button bar below the pull down menu bar contains commands for accessing the Help Information.

Select the CONTENTS command from the HELP Menu.

A CASM Help pop-up dialog window appears to which displays the CASM Help Table of Contents and commands for accessing and manipulating the help data.

To select topics from the CASM Help Table of Contents:
1. Move the mouse pointer to the desired topic printed in light green.
   The mouse pointer will change to a pointing finger.
2. Press the left mouse key once and release.
   Sub-topics under the selected topic will appear. Continue selecting topics until the desired topic description appears.
   To aid your use of the Help information several commands are available on the pull down menu bar and the button bar. Briefly the commands are:
   • File - Use to select printers, print help topics, and exit the help program.
• Edit - Copy help text to the Windows Clipboard and Annotate the help text for other users. The annotated text is marked.

• Bookmark - Use to save your location in the CASM Help Table of Contents. The saved location is listed on the pull down menu.

• Help - Information on How to Use Help. An Always on Top selection which keeps the Help dialog window visible when you are using CASM. An About Help window which displays a Help program version number, license information, and numbers indicating the amount of free resources and memory which can be helpful if you are experiencing problems such as slow program response when using CASM. You may need to close some applications to free more memory.

• Contents - Returns you to the main CASM Help Table of Contents.

• Search - Opens the Search dialog window so that you can do a more rapid topic search of the Help information.

• Back - Returns you to the previous dialog window.

• History - Provides you with a history of your topic selections.

• Forward & Back arrows - Permits you to move forward or back topic by topic.

To return to the current program window:
1. Move the mouse pointer to the Control Menu box or the File pull down menu.
2. Press the left mouse key once and release.
3. Select Close from the Control Menu or Exit from the File Menu to exit the CASM Help dialog window.

The HELP window does not have to be closed to continue working in CASM.
HELP MENU

The Search for Help On command permits you to do a rapid topic search of the Help information. You may type in a word or select one from the list then select the Show Topics button bar to display related topics to the selected word. Select the desired topic then use the Go To button bar to display the topic information.

Select the SEARCH FOR HELP ON command from the HELP Menu.

A pop-up Search dialog window appears to which displays the program name, current program version, and free memory available.

To do a topic search:
1. Type a word in the box above the list or select one from the list using the mouse.
2. Select the Show Topics button with the mouse or by typing [S].
   A list of related topics will appear in the bottom box.
3. Select the desired topic with the mouse.
4. Select the Go To button with the mouse.
   The CASM Help dialog window will appear with specific information on the selected topic.

To return to the current program window:
1. Move the mouse pointer to the Close button or the Control Menu box.
2. Press the left mouse key once and release.
   The Close button will automatically close the dialog window. If the Control menu was used, you must select Close.

The HELP window does not have to be closed to continue working in CASM.
How to Use Help

The How to Use Help command displays a How to Use Help dialog window. The pull down menu bar contains menus with commands to aid in accessing the help information. The File pull down menu permits you to select a printer and print a topic. The Edit pull down menu permits you to copy Help text to the clipboard and Annotate the Help text as a reminder to other users. The Annotated text is marked by a green mark to the left of the paragraph which can be selected to display the annotated text. The Bookmark pull down menu permits you to save your location in the Help listing of topics. Your saved location is added to the Bookmark pull down menu list so that you can go directly to your saved location. The Help pull down menu contains information on how to use Help. The Always on Top selection is a setting which will keep the help dialog windows permanently displayed. The About Help command displays a dialog window showing the Help program version number, software license information, the amount of free memory available, and the percentage of free system resources available. The button bar below the pull down menu bar contains commands for accessing the Help information.

Select the HOW TO USE HELP command from the HELP Menu.

A pop-up dialog window appears to which displays the Help Table of Contents and commands for accessing and manipulating the help data.

To select topics from the Help Table of Contents:

1. Move the mouse pointer to the desired topic printed in light green.
   The mouse pointer will change to a pointing finger.

2. Press the left mouse key once and release.
Sub-topics under the selected topic will appear. Continue selecting topics until the desired topic description appears.

To aid your use of the Help Information several commands are available on the pull down menu bar and the button bar. Briefly the commands are:

- **File** - Use to select printers, print help topics, and exit the help program.
- **Edit** - Copy help text to the Windows Clipboard and Annotate the help text for other users. The annotated text is marked.
- **Bookmark** - Use to save your location in the CASM Help Table of Contents. The saved location is listed on the pull down menu.
- **Help** - Information on How to Use Help, An Always on Top selection which keeps the Help dialog window visible when you are using CASM. An About Help window which displays a Help program version number, license information, and numbers indicating the amount of free resources and memory which can be helpful if you are experiencing problems such as slow program response when using CASM. You may need to close some applications to free more memory.
- **Contents** - Returns you to the main CASM Help Table of Contents.
- **Search** - Opens the Search dialog window so that you can do a more rapid topic search of the Help Information.
- **Back** - Returns you to the previous dialog window.
- **History** - Provides you with a history of your topic selections.
- **Glossary** - Provides you with a glossary of Windows terminology. Select any term with the mouse to see a description of the selected word.

**To return to the current program window:**

1. **Move the mouse pointer** to the Control Menu box or the File pull down menu.
2. **Press** the left mouse key once and release.
3. **Select Close** from the Control Menu or *Exit* from the File Menu to exit the CASM Help dialog window.

> The HELP window does not have to be closed to continue working in CASM.

**About CASM**

The About CASM command displays information about the CASM application running in the active window.

Select the ABOUT CASM command from the HELP Menu.

A pop-up dialog window appears to which displays the program name, current program version, and free memory available.

**To return to the current program window:**

1. **Move the mouse pointer** to the 'OK' box in the middle of the pop-up window.
2. **Press the left mouse key once and release.**

   The pop-up dialog window will disappear.

   ![About CASM Window]

   - **Free Memory**
     - Free Memory: 22914K
     - Graphics Memory: 22914K

   - **Library Versions**
     - CASM: 4.25
     - Graphics: 4.24
     - Analysis: 4.23
     - TM 5-809-1 1986: 4.23
     - TM 5-809-1 1992: 4.22
     - TM 5-809-10 1992: 4.23
     - DXF Import: 4.24
     - STAAD Input File: 4.24

   If you have difficulties running the CASM program or the computer response seems slow, check the free memory. If the value is real low, then you may need to close some applications and reduce the Program Manager application to an icon to free more memory.
The Draw Model Tool Palette is used to develop the building structural geometry. The building geometry is created by stacking electronic building blocks on the screen. These blocks can be quickly stretched, squeezed, and arranged in order to create the desired building geometry. The menus or icons on the Draw Model Tool Palette permit you to select the desired building block with the Shapes Menu, edit the blocks by stretching or squeezing with the Edit Menu, control the initial block size and positioning with the Layout Menu, and select an initial reference outline from the Architectural CADD drawing with the Reference Menu.

You will need to be in the Perspective (3-D) option on the Viewpoint Tool Palette in order to use the Shapes and Edit menus in the Draw Model Tool Palette.

There are many ways to construct a correct building model. There is almost no limit to the variety and complexity of models that you can create with CASM. However, the shape, type, and position will influence the automatic generation of loads. Refer to the Modeling section in Chapter 5 of this guide for modeling hints, options, and ramifications.

The Draw Model Tool Palette Window is shown below:

The Draw Model Tool Palette shown above will vary depending on the selected resolution, the CASM window size, or if a larger icon size has been selected. Not all of the Modeling icons will be displayed for the 840 x 480 resolution, for a CASM window that has been reduced in size, or if the icon size has been increased by the Button Scale setting in the CASM Settings dialog window.

To select a command from the Draw Model Menu with the mouse:

If the Draw Model tool palette is not displayed:
1. Move the mouse pointer to the Draw Model icon button.
2. Press the left mouse key:
   - The Draw Model Tool Palette will appear below the pull-down menu bar. Also Draw Model menus will be inserted on the pull-down menu bar.
   - You may select a Draw Model command directly from the tool palette or select the command from the pull-down menus.

If the Draw Model tool palette is displayed:
1. Move the mouse pointer to the desired tool icon.
2. Press the left mouse key.
   - The tool icon will be highlighted and a dialog window may appear.
Using the Draw Model menus if the Draw Model tool palette is displayed:

1. Move the mouse pointer to the desired pull-down menu option on the CASM program window.
2. Press the left mouse key.
   The pull-down menu will appear.
3. Move the mouse pointer to the desired menu option (you may also activate the command by typing the underlined letter in the desired command).
4. Press the left mouse key to activate the command.
   A dialog window will appear. Refer to the Draw Model command sequences listed on the following pages.

To select a command from the Draw Model tool palette with the keyboard:

1. Hold down the [Ctrl] key and press the [D] key.
   The Draw Model Tool Palette will appear.
2. Hold down the [Alt] key and press the underlined key of the desired pull-down menu.
   The pull-down menu will be displayed on the screen.
3. Type the underlined letter of the desired command to activate the command.
   -OR-
   Use the up or down direction arrows on the keyboard to move the selection bar up or down to the desired selection; then press the [Enter] key.

The Draw Model Menu command selections are listed on the following pages.
**SHAPES MENU**

Use the Shape pull down menu commands to select a 3-D shape which is used as a building block for the structural design. The graphic Shape Tool icons on the screen may also be used. Initial size and orientation of the shape (length, width, height, radius, and slope) are determined by the Initial Shape Size command on the Layout menu. Also, the initial size of the shape will conform to the size of the previous shape or designated plane when the Stack On Last Shape or Stack On Plane commands are selected on the Layout menu.

▷ You must be in the Perspective (3D) option in order to stack 3-D shapes.

▷ **NOTE**: Before you begin placing shapes there are several items which you should know that will aid in the proper placement of the shape. These items will also be discussed in the menu command sequences described below.

**Use of mouse and keyboard to place shapes.**

Once the shape appears on the screen and becomes linked to movements of the mouse, movement of the shape on the modeling screen corresponds to the mouse movements listed below:

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.
- Pressing the right mouse key and moving the mouse toward/away from you will move the shape up/down.
- Pressing the left mouse key will accept the shape location. A new shape will appear or handles will appear if you are stacking shapes on planes.
- Double click the right mouse key to exit the add shape mode.

▷ The cursor direction keys can be used in combination with the mouse to make final incremental movements of selected shapes. The up \( \uparrow \) and down \( \downarrow \) cursor keys drag in the north-south direction. The left \( \leftarrow \) and right \( \rightarrow \) cursor keys drag in the east-west direction. Hold down the [Alt] key while pressing the up \( \uparrow \) or down \( \downarrow \) cursor keys to drag vertically. The [Enter] key equals the left mouse key (select). The [Esc] key equals a double click right mouse key (cancel).

▷ You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.
The LAYOUT command selections control the initial placement and size of your selected shape. At any time you may modify the Layout selections to aid your initial selection and placement of the shape.

**LAYOUT Selection - DRAW SHAPE command response**

- Define Ground Plane - Permits you to define the ground plane size and grid spacing for an initial placement reference.
- Define Units - Permits you to select dimension increments for placing the object and select U.S. or metric units.
- Snap to Units - Permits you to activate the unit snap for object placement based on the selected increment.
- Snap to Grid - Permits you to snap to the structural grid.
- Snap to Reference - Permits you to snap to an imported reference drawing or the Tape Measure coordinates.
- Initial Shape Size - Permits you to select the initial shape dimensions and orientation. (You may use the Edit commands to make additional dimension changes if you have already placed the shape on the screen.)
- Stack on Ground - The selected shape is initially displayed on the center of the ground grid.
- Stack on Last Shape - The selected shape automatically appears on top of the previous stackable shape and assumes the same width and length of the previous shape. Shapes like Prisms, Vaults, and Domes are not considered stackable.
- Stack on Plane - Colored dots or "handles" appear on all the "visible" planes of previous shapes. Select a "handle" with the mouse pointer and press the left mouse key to stack the new shape. Only stackable planes will have handles.
- Stack Underground - The selected shape is initially displayed on the center of the ground plane below the ground plane.

There are many ways to construct a correct building model. There is almost no limit to the variety and complexity of models that you can create with CASM. However, the shape, type, and position will influence the automatic generation or loads. Listed below are some modeling hints. Refer to the Modeling section in Chapter 5 of this guide for a more detailed discussion of modeling hints, options, and ramifications.

**CASM Modeling Hints**

- Simplify the geometric model. The fewer shapes used to model the building the better. The fewer the shapes, the faster the snow and wind calculations are performed as well as the overall performance of the program.
- Make sure planes are in contact. Adjoining planes of the shapes need to be in contact, or the gap between the shapes will make the surfaces exterior. Use the STACK options to accurately place adjoining shapes. Do not eye-ball the locations of shapes.
Do not intersect shapes. Intersecting shapes will confuse the snow and wind load generation algorithms. The interior portion of the intersected planes will become exterior surfaces, and loads will be applied twice over the overlapped surfaces.

Use of the plane and column shapes vs. the cube shape. Plane and column shapes are drawn as six-sided cube shapes, but are attributed as planes or columns. For the generation of snow loads, the use of these shapes does not matter since snow is applied to all roof surfaces. But, for the generation of wind loads, they do matter. In the generation of wind main force-resisting loads, the cube shapes are included and the plane and column shapes are excluded. Use a plane shape to model a parapet or overhang. If a cube is used, the computer will think that it is a main force resisting element. Plane shapes are used to model open structures. Only the plane or open barrel vault shapes can be selected on which to apply open wind loads. Column shapes are necessary only to visually show support. You can simplify the model by not drawing columns or by drawing only a few of the columns to show support.

Creating floor planes. When two shapes are placed on top of one another, the adjoining surface becomes a floor plane. Floor planes are necessary to be able to draw structure onto, for the calculation of windward wind load levels and for seismic load levels. This is not making the model more complicated because the extra shapes create floor planes which are necessary for structure, wind, and seismic load generation.

Verifying the model. Make sure the geometric model is complete and accurate before drawing structure and calculating loads. If you change the geometry after calculating wind and snow loads, the loads will have to be regenerated. The structure may not line up correctly, and the structural grid will have to be redefined if the model is changed after drawing structure. To verify the model, use the TAPE MEASURE command or zoom in on the plan, elevation, and 3-D views to check all the above precautions.

The CASM Modeling shapes icons are shown below. The Shape names are also located on the Shapes pull-down menu.

Selecting a shape from the Draw Model tool palette:
1. Move the mouse pointer to the desired shape icon in the Draw Model Tools Palette.
2. Press the left mouse key.

The shape icon will be highlighted (white on black) and the shape will appear on the Modeling Screen. The mouse pointer will change to the selected shape on the modeling screen.

**Selecting a shape from the Shapes pull-down menu:**

1. Move the mouse pointer to the Shapes pull-down menu title. (You may also select [Alt] + [S] from the keyboard to display the Shapes pull-down menu.)

2. Press the left mouse key.

The Shape Menu will be displayed.

3. Move the mouse pointer down the list of shapes to the desired shape.

4. Press the left mouse key. (You may also type the underlined letter of the desired shape from the menu.)

The mouse pointer becomes the selected shape which appears on the Modeling Screen.

A dialog box appears which shows you the shape dimensions. The lower portion of the dialog box indicates the translated dimensions of the shape from its initial position. You may refer to the translated dimensions to aid you in positioning the plane in the STACK ON GROUND and STACK UNDERGROUND options on the Layout Menu.

<table>
<thead>
<tr>
<th>Dimensions</th>
<th>Roof Slopes</th>
</tr>
</thead>
<tbody>
<tr>
<td>N-S: 20.00 ft</td>
<td>North: 0.00 in 12</td>
</tr>
<tr>
<td>E-W: 75.00 ft</td>
<td>South: 0.00 in 12</td>
</tr>
<tr>
<td>Vert.: 18.00 ft</td>
<td>East: 0.00 in 12</td>
</tr>
<tr>
<td>Ridge: 0.00 ft</td>
<td>West: 0.00 in 12</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Translated Distances</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>N-S: 0.00 ft</td>
<td>E-W: 0.00 ft</td>
</tr>
<tr>
<td>Vert.: 0.00 ft</td>
<td></td>
</tr>
</tbody>
</table>

The selected shape will be "stacked" on the modeling screen based on the STACK selection in the Layout Menu.

- If the STACK ON PLANE option has been selected on the Layout Menu, colored dots or "handles" will appear on all the visible planes. Move the mouse pointer to the handle of the desired plane the new shape is to be stacked on (you may need to get out of the Shapes command in order to rotate the model if the handle for the desired plane is not accessible). Press the left mouse key to select the plane and the new shape will appear with the same dimensions as the plane.
- If the shape location default is STACK ON LAST SHAPE the shape will appear on the top of the last stackable shape. Prisms and vaults are not stackable shapes.

- If the shape location default is STACK ON GROUND or STACK UNDERGROUND the shape will appear at the center of the ground plane and may be moved horizontally and/or vertically with the mouse to its final position. For the Stack on Ground or Stack Underground options, you may move the shape with the mouse.

  Moving the mouse right/left corresponds to E-W on the screen.
  Moving the mouse toward/away from you corresponds to N-S on the screen.
  Pressing the right mouse key and moving the mouse toward/away from you will move the shape up/down.

  If you do not like the shape location or size, you may double click the right mouse key to cancel the add shape mode.

  You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

5. Press the left mouse key once to accept the shape location and size.

   The program will remain in the add shape mode and a new shape will appear on the screen or handles will appear on all visible planes if the Stack on Plane option is selected.

6. Double click the right mouse key to exit the add shape mode.

   You may modify the shape dimensions later by using the commands from the Edit Menu.
EDIT MENU

Use the Edit pull down menu commands to change a shape which is used as a building block for the structural design. The graphic Edit Tool icons on the screen may also be used. Except for Undo, all of the Edit Menu commands require that you select an item to edit. After selecting the Edit command, use the mouse pointer to select a shape.

- The Edit Menu commands work only in the Perspective (3D) display of the model.
- You will find the Lock N-S, Lock E-W, and Lock Vertical commands on the Layout Menu useful when you Drag Edge.
- NOTE: Before you begin editing shapes there are several items which you should know that will aid in the proper editing of the shape. These items will also be discussed in the menu command sequences described on the following pages.

Once the shape appears on the screen, movement of shapes on the modeling screen corresponds to the mouse movements listed below:

- Clicking the left mouse key once on a yellow dot "handle" which represents a shape selects the shape and permits you to move or modify the shape.
- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.
- Pressing the right mouse key and moving the mouse toward/away from you will move the shape up/down.
- Pressing the left mouse key will accept the edit changes. Handles will reappear for further editing operations.
- Double click the right mouse key to exit the editing mode.

- The cursor direction keys can be used in combination with the mouse to make final incremental movements of selected shapes. The up [↑] and down [↓] cursor keys drag in the north-south direction. The left [←] and right [→] cursor keys drag in the east-west direction. Hold down the [Alt] key while pressing the up [↑] or down [↓] cursor keys to drag vertically. The [Enter] key equals the left mouse key (select). The [Esc] key equals a double click right mouse key (cancel).

- You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

- You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the selected object to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimen-
sions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

The colored squares or "handles" will be located on "visible" parts or front sides and top of the shapes. There will not be any handles on the "nonvisible" or back side of the shapes. You may need to rotate the model in order to access shapes that you desire to modify. You may also hide shapes with the HIDE SHAPES command on the View menu to reduce the number of displayed shapes and handles. Handles are located as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Handle Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Center of visible planes</td>
</tr>
<tr>
<td>Plane</td>
<td>Center of visible planes</td>
</tr>
<tr>
<td>Edge</td>
<td>Midpoint of edge on visible planes</td>
</tr>
</tbody>
</table>

The Layout command selections control the editing of your selected shape. At any time you may modify the Layout selections to aid you in the initial size, placement, and editing of the selected shape.

**Layout Selection - Influence on Editing sequence**

- **Define Units** - Permits you to select dimension increments for editing the shapes.
- **Snap to Units** - Permits you to activate the unit snap for the selected increment.
- **Snap to Reference** - Permits you to snap to an imported reference drawing or the Tape Measure coordinates.
- **Lock N-S** - Permits you to prevent the editing changes or movement in the N-S direction.
- **Lock E-W** - Permits you to prevent the editing changes or movement in the E-W direction.
- **Lock VERT** - Permits you to prevent the editing changes or movement in the VERTICAL direction.

To select a command from the Edit Menu or Icons:

**For the tool palette:**

1. Move the mouse pointer to the desired edit icon in the Draw Model Tools Palette.
2. Press the left mouse key.

   The edit icon will be highlighted and a dialog window may appear or handles will appear on shapes on the Modeling Screen. The mouse pointer will change on the modeling screen.

**For the Edit pull-down menu:**

1. Move the mouse pointer to the Edit pull-down menu title. (You may also select [Alt] + [E] from the keyboard to display the Edit Pull-Down Menu.)
2. Press the left mouse key.

   The Edit pull-down menu will appear.
3. Move the mouse pointer down the list to the desired edit command. (You may also type the underlined letter of the desired edit command from the menu.)

4. Press the left mouse key.

A dialog window may appear or handles will appear on shapes on the Modeling Screen.

The Edit Menu commands are listed on the following pages:

---

The Undo command cancels the last modeling action or last editing action performed. You may continue to Undo commands until an Undo is not possible. The command to be undone is listed after the word Undo.

**DRAG VERTEX**

A designated prism vertex at the ridge may be moved. All edges connected to the vertex are realigned dynamically to the new vertex location.

- The Vertex movement is limited to the ridge orientation. You can only move the selected prism vertex parallel to the ridge orientation. You cannot move the vertex perpendicular to the ridge orientation or vertically.

- The Drag Vertex command works only in the Perspective (3D) display of the model.

Select the Drag Vertex command from the Edit menu or tool icon:

- The mouse pointer changes to a + . (For the Dual-Monitor System the mouse pointer appears as a + on the Matrox modeling screen.)

1. Place the mouse pointer on the desired vertex to be modified.

- You may exit the editing mode at any time without saving changes by double clicking the right mouse key.

2. Press the left mouse key.

The vertex selected will be highlighted. A Dimension Dialog Window will appear which displays dynamic dimensions, roof slopes, and translated distances. Movement of the vertex will match the mouse movements, and the values in the dialog window will change to aid you in positioning the vertex:

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.
- The vertex will not move vertically when you press the right mouse key and move the mouse.
DRAW MODEL TOOL PALETTE

You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the selected object to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimensions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

3. Press the left mouse key to save the vertex change.
   You will remain in the Drag Vertex edit mode.

4. Double click the right mouse key to exit the Drag Vertex edit mode.

A designated edge of a shape may be selected and moved. All planes and vertices connected to the edge are realigned dynamically to the new edge location.

Use the Lock options in combination with this command to control the movement of the selected edge.

The Drag Edge command works only in the Perspective (2D) display of the model.
Select the Drag Edge command from the Edit menu or tool icon.

All edges on visible planes will be highlighted at their midpoint by a colored square ("handle"). The mouse pointer changes to a +.

1. Place the mouse pointer on the handle of the desired edge to be modified.

   You may exit the editing mode at any time without saving changes by double clicking the right mouse key.

2. Press the left mouse key.

   The edge will be highlighted. A Dimension Dialog Window will appear which displays dynamic dimensions, roof slopes, and translated distances. Movement of the edge will match the mouse movements, and the values in the dialog window will change to aid you in positioning the edge:
   - Moving the mouse right/left corresponds to E-W on the screen.
   - Moving the mouse toward/away from you corresponds to N-S on the screen.
   - Pressing the right mouse key and moving the mouse toward/away from you will move the edge up/down.

   You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

   You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the selected object to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimensions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

3. Press the left mouse key to save the edge change.

   The handles on the edges will reappear. You will remain in the Drag Edge edit mode.

4. Double click the right mouse key to exit the Drag Edge edit mode.

A designated plane of a shape may be selected and moved toward or away from its centroid. All planes, edges, and vertices connected to the plane are realigned dynamically to the new plane location.

The Drag Plane command works only in the Perspective (3D) display of the model.
Selecting Drag Plane for the following items will produce the results indicated:

<table>
<thead>
<tr>
<th>Item</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cubes, Columns and Planes</td>
<td>Move shape plane N-S, E-W, and/or up-down.</td>
</tr>
<tr>
<td>Cylinders, Vaults and Prisms</td>
<td>Move end planes toward or away from centroid.</td>
</tr>
</tbody>
</table>

Select the Drag Plane command from the Edit menu or tool icon.

All "visible" planes will be highlighted at the center of the plane by a colored dot or handle. The mouse pointer changes to a +. Move the mouse pointer to the handle on the desired plane to be modified.

You may exit the editing mode at any time without saving changes by double clicking the right mouse key.

Press the left mouse key.

The plane will be highlighted. A Dimension Dialog Window will appear which displays dynamic dimensions, roof slopes, and translated distances. Movement of the plane will match the mouse movements, and the values in the dialog window will change to aid you in positioning the plane:

- Moving the mouse toward/away from you will drag the plane on the screen.

You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the selected object to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimensions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

Press the left mouse key to save the plane change.
The handles on the planes will reappear. You will remain in the Drag Plane edit mode.

4. Double click the right mouse key to exit the Drag Plane edit mode.

**DELETE SHAPE**

You may designate a shape for deletion. Deleting a shape removes it from the graphic file.

- The Delete Shape command works only in the Perspective (3D) display of the model.
- Select the Delete Shape command from the Edit menu or tool icon.
- All "visible" planes of shapes will be highlighted at their center by a colored dot or handle. The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on a plane of the shape to be deleted.
   - You may exit the editing mode at any time without deleting a shape by double clicking the right mouse key.
2. Press the left mouse key.
   - The designated shape will be deleted. The handles on the shapes will reappear. You will remain in the Delete Shape edit mode.
3. Double click the right mouse key to exit the Delete Shape edit mode.
   - If you accidentally delete the wrong shape, immediately select the Undo command.

**MOVE SHAPE**

You may designate a shape to be moved. A dialog window will appear to dynamically display the distance the designated shape is being moved in the N-S, E-W, and vertical directions.

- Use the Lock options in combination with this command to control the movement of the shape.
- The Move Shape command works only in the Perspective (3D) display of the model.
- Select the Move Shape command from the Edit menu or tool icon.
- All "visible" planes of shapes will be highlighted at the center of the plane by a colored dot or handle. The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on a plane of the shape to be moved.
   - You may exit the editing mode at any time without saving changes by double clicking the right mouse key.
2. Press the left mouse key.
The shape will be highlighted. A Dimension Dialog Window will appear which displays dynamic dimensions, roof slopes, and translated distances. Movement of the shape will match the mouse movements, and the values in the dialog window will change to aid you in positioning the shape:

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.
- Pressing the right mouse key and moving the mouse toward/away from you will move the shape up/down.

You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of shape coordinates. Entries in the Dimensions data boxes control the size of the shape. Entries in the Centroid data boxes control the location of the shape. Entries in the Roof Slope data boxes control the slope of the prism.

You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the selected object to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimensions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

3. Press the left mouse key to save the shape change. The handles on the shapes will reappear. You will remain in the Move Shape edit mode.

4. Double click the right mouse key to exit the Move Shape edit mode.

**Rotate Shape**

You may use the Rotate Shape command to rotate a designated shape about its centroidal axes (north-south, east-west, or vertical) or any designated edge of any shape.

The Rotate Shape command works only in the Perspective (3D) display of the model.

Select the Rotate Shape command from the Edit menu tool icon.

All "visible" planes of shapes will be highlighted at the center of the plane by a colored dot or handle. The mouse pointer changes to a + .

1. Move the mouse pointer to the handle on a plane of the shape to be rotated.

   You may exit the editing mode at any time without saving changes by double clicking the right mouse key.

2. Press the left mouse key.

The shape will be highlighted. Centroidal axes with handles will appear at the centroid of the shape and handles will appear on the midpoints of edges on visible planes.
3. Select the desired axis or edge by moving the mouse pointer to the handles on an edge or at one end of the axis.
4. Press the left mouse key.
A Rotate Dialog Window will appear which displays dynamic rotations and slopes. Movement of the shape will match the mouse movements, and the values in the dialog window will change to aid you in rotating the shape:
- Moving the mouse right/left corresponds to rotation on the screen.
- You can press the [F2] function key to bring up a Rotate Coordinates dialog window for keyboard entry of rotation angle or slope.
5. Press the left mouse key to save the shape rotation change.
The handles on the shapes will reappear. You will remain in the Rotate Shape edit mode.
6. Double click the right mouse key to exit the Rotate Shape edit mode.

You may use the Slice Shape command to slice a shape in order to remove a portion of the shape. New wall, roof, or floor planes will be created at the location where the shape was sliced.
- The Slice Shape command works only in the Perspective (3D) display of the model.
- You may need to use the View Direction Tool to orient the shape and cutting plane so that all handles are visible. You may also use the HIDE SHAPES command to 'hide' shapes you do not need in order to reduce the number of handles displayed on the screen.

Select the Slice Shape command from the Edit menu or tool icon:
All "visible" planes of shapes to be sliced will be highlighted at the center of the plane by a colored dot or handle. The mouse pointer changes to a + .
1. Move the mouse pointer to the handle on a plane of the shape to be sliced.
- You may exit the editing mode at any time without saving changes by double clicking the right mouse key.
2. Press the left mouse key.
The shape to be sliced will be highlighted.
3. Move the mouse pointer to the handle on the plane that is to slice the shape.

4. Press the left mouse key.

   The plane that you selected will be highlighted by a different color and linetype. Then the intersection of the plane and the shape will be highlighted by colored lines. The shape to be sliced will be split into two separate shapes at the intersection. Solid lines will mark the intersection.

   The handles on the shapes will reappear. You will remain in the Slice Shape edit mode.

   You may use the Delete Shape command on the Edit Menu to delete the unwanted shape.

5. Double click the right mouse key to exit the Slice Shape edit mode.

   You may duplicate shapes based on the parameters defined in the Duplicate dialog window. Indicate the number of duplicate shapes in the N-S, E-W, and/or vertical direction and the spacing of the duplicate shapes in the N-S, E-W, and/or vertical directions. Positive number entries correspond to N, E, or up. Negative number entries correspond to S, W, or down.

   The Duplicate Shape command works only in the Perspective (3D) display of the model.

Select the Duplicate Shape command from the Edit menu or tool icon.

A Duplicate Dialog Window will appear. The top three selections in the dialog window permit you to specify the number of duplicate shapes to be generated in the N-S, E-W, or Vertical directions. The bottom three selections permit you to specify the spacing of the duplicate shapes in the N-S, E-W, and Vertical directions.

Spacing is the distance between the shapes and not the space between the centroids of the shapes.

For example, if you would like to create a four-story building with floor levels the same as the ground-floor level (14 feet), you would enter "3" in the Vertical block and verify 0.0 in the Vertical Space block.
1. **Enter the desired number of duplicate shapes and spacing in the desired direction.**

2. **Move the mouse pointer to the OK block at the bottom of the window.**

3. **Press the left mouse key.**
   - All "visible" planes of shapes will be highlighted at the center of the plane by a colored dot or handle. The mouse pointer changes to a + .

4. **Move the mouse pointer to the handle on a plane of the shape to be duplicated.**
   - You may exit the editing mode at any time without saving changes by double clicking the right mouse key.

5. **Press the left mouse key.**
   - The shape will be duplicated. The duplicate shapes will appear on the screen. The handles on the shapes will reappear. You will remain in the Duplicate Shape edit mode with the same duplicate options.

6. **Double click the right mouse key to exit the Duplicate Shape edit mode.**

---

### TAPE MEASURE

The distance between two designated vertices will be measured. You can also select Reference vertices. The measurement is displayed on the Windows screen in a dialog window.

- **When in a 2D structural plane view, structural elements can be selected to be measured.**

**Select the Tape Measure command from the Edit menu or tool icon.**

- The mouse pointer changes to a + .

1. **Move the mouse pointer to the first vertex of the shape, structure, or Reference drawing where the measurement is to begin.**
   - You may exit the Tape Measure editing mode at any time without starting the tape measure by double clicking the right mouse key.

2. **Press the left mouse key.**
   - The vertex will be highlighted by a red dot.

3. **Next move the mouse pointer to the second vertex of the shape, structure, or Reference drawing where the measurement is to end.**

4. **Press the left mouse key.**
   - The vertex will be highlighted by a yellow dot. A dashed line will be drawn joining the two dots. A Tape Measure Dialog Window will appear which displays distance and the slope of the second vertex relative to the first vertex in three dimensions. You have the option to select the desired slope unit of measurement by selecting the Slope box ( _ in 12) or the Angle box (°).
The Tape Measure option and window remain active for the selected vertices until you cancel the dialog window. If you perform an editing command which includes one of the measured vertices, the measure information will reflect the movement of the vertices.

When Tape Measure is used for structure, you must select Cancel to proceed to another command.

You may use the Tape Measure command in combination with the [F3] function key when editing shapes. You must select the Tape Measure option in the Translate Coordinates dialog window.

You may use the Tape Measure command in combination with the Snap to Reference mode. When the Snap to Reference mode is on, an shape editing command will automatically snap the tape measure vertices together.

**When you want to stop tape measure.**

1. **Move the mouse pointer to the Cancel block at the bottom of the window.**
2. **Press the left mouse key.**

The Tape Measure Dialog Window will disappear. You will need to select Tape Measure again in order to find another distance or slope.

In Perspective (3D), you do not need to cancel Tape Measure before selecting the Tape Measure command again.
## LAYOUT MENU

Use the Layout Menu commands to aid in creating a dimensionally correct model.

The Layout Menu commands control the initial placement of the selected modeling shapes, the snap increment, the spacing of the ground plane lines, and the movement of selected objects.

To select a command from the Layout Menu:

### Selecting a command from the tool palette:

1. Move the mouse pointer to the desired layout icon in the Draw Model Tools Palette.
2. Press the left mouse key.

   The selected layout icon will be highlighted and a dialog window may appear. The highlighted icon will be a reminder of the selected Layout option.

### Selecting a command from the Layout pull-down menu:

1. Move the mouse pointer to the Layout Pull-Down Menu title. (You may also select [Alt] + [L] from the keyboard to display the Layout Pull-Down Menu.)
2. Type the underlined letter of the desired layout selection from the menu. (You may also move the mouse pointer down the list to the desired layout selection and press the left mouse key.)

   A dialog window may appear or a checkmark will be placed in front of several menu selections as a reminder for the selected Layout option.

The Layout Menu commands are listed on the following pages:

<table>
<thead>
<tr>
<th>Layout</th>
<th>Draw Model Tool Palette</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define Ground Plane...</td>
<td>Define Units...</td>
</tr>
<tr>
<td>✅ Snap to Units F4</td>
<td>✅ Snap to Structural Grid F5</td>
</tr>
<tr>
<td>✅ Snap to Reference F6</td>
<td></td>
</tr>
<tr>
<td>Initial Shape Size...</td>
<td></td>
</tr>
<tr>
<td>✅ Stack on Ground</td>
<td>✅ Stack on Last Shape</td>
</tr>
<tr>
<td>Stack on Plane</td>
<td>Stack Underground</td>
</tr>
<tr>
<td>Lock N-S F7</td>
<td>Lock E-W F8</td>
</tr>
<tr>
<td>Lock Vertical F9</td>
<td></td>
</tr>
</tbody>
</table>
Initially a light grid system is displayed on the modeling screen. The grid system represents the ground plane. A North arrow is included adjacent to the ground plane as a reference. When the ground plane is displayed on the screen, selecting Show Ground Plane will hide the ground plane. You may want to hide the ground plane in order to observe an underground shape.

Select the Show Ground Plane command from the Layout Menu or tool icon.

The Layout Menu will disappear. The ground plane on the screen will disappear. To display the ground plane select the Show Ground Plane command again. The checkmark indicates that the ground plane is displayed.

Define Ground Plane

Permits the selection of the ground plane grid size and spacing. The initial default size is 100 x 100 feet with a 20-foot grid spacing. You may change the grid spacing and ground plane size by entering new values in the dialog window. The ground plane can also be rotated for the insertion of model shapes at a specified angle to other shapes. The ground plane size, spacing, and angle will aid in the initial layout of your structural model. You will note a change in color on the screen when a shape edge line overlays a grid line.

When creating your model, the N-S and E-W dimensions correspond to the orientation of the ground plane. If the ground plane is rotated, all future shape and editing commands will follow the new ground plane angle.

Select the Define Ground Plane Tool Icon or command from the Layout Menu.

The Define Ground Plane Dialog Window will appear in the Dialog area of the Windows screen. You may change the overall ground plane width, spacing, or angle.

<table>
<thead>
<tr>
<th>Ground Plane</th>
</tr>
</thead>
<tbody>
<tr>
<td>N-S Width:</td>
</tr>
<tr>
<td>N-S Spacing:</td>
</tr>
<tr>
<td>E-W Width:</td>
</tr>
<tr>
<td>E-W Spacing:</td>
</tr>
<tr>
<td>North angle 1:</td>
</tr>
<tr>
<td>North angle 2:</td>
</tr>
</tbody>
</table>

Ground Plane Rotated 45°
To change Widths, Spacing, or Angle value:

1. Move the mouse pointer to the text box to be modified. (You may also use the [Tab] key.)
2. Press the left mouse key.
   A vertical cursor will appear in the selected text box. (You may also press and hold the left mouse key as you drag the cursor over the existing entry to highlight it in reversed text.)
3. Type in the new entry. Use the [Backspace] and [Delete] keys as necessary.

New shapes added to the model are oriented to the ground plane. To enter new shapes at an angle to existing shapes, you must first rotate the ground plane.

To change ground plane angle:

There are two angle selections to help you quickly switch from one ground plane angle to another ground plane angle when inserting shapes for your structural model.

1. Move the mouse pointer to the option button corresponding to the desired angle.
2. Press the left mouse key.
   A black dot will appear in the selected option. Only one selection is permitted.

To change the ground plane on the modeling screen:

1. Move the mouse pointer to the OK action box at the bottom of the window. (You may use the CANCEL option if you decide not to change the ground plane.)
2. Press the left mouse key.
   The ground plane will be modified and redrawn on the screen.

You may need to adjust your viewing height or distance to view the entire ground plane. Use the Full Screen command in the View pull-down menu.

You may select a dimension increment to aid in the placement or editing of shapes, planes, edges, and vertices. When an increment is specified and the Snap to Units option is selected, an exact placement of elements can be achieved. You must use the Snap to Units selection to activate the unit snap increment. The initial default unit increment is 12 inches. The Define Units command also selects the format in which dimensions are displayed. The format can be either U.S. decimal, U.S. feet and inches, or metric.

Select the Define Units Tool Icon or command from the Layout Menu.

The Define Units Dialog Window will appear in the Dialog area of the Windows screen. You may change the snap increments by using the option buttons or by entering data in the "other" text box and checking its option button.
1. Move the mouse pointer to the desired increment option button. (You may also use the [Tab] key.)

2. Press the left mouse key.

A solid dot will appear in the option button. Because only one increment can be selected, a solid dot in one of the other option buttons will disappear.

If you desire to add a unit increment other than the displayed increments:

a. Move the mouse pointer to the "other" text box.

b. Press the left mouse key.

A vertical cursor will appear in the selected text box. (You may also press and hold the left mouse key as you drag the cursor over the existing entry to highlight it in reversed text.)

c. Type in the new entry. Use the [Backspace] and [Delete] keys as necessary.

To set the dimension display format:

1. Move the mouse pointer to the desired option, U.S. Decimal, U.S. Feet-Inches, or metric.

2. Press the left mouse key.

To save the unit increment entry:

1. Move the mouse pointer to the OK action box at the bottom of the window. (You may use the CANCEL option if you decide not to change the unit increment.)

2. Press the left mouse key.

The dialog window will disappear.

SNAP TO UNITS [F4]

Activates or deactivates the unit snap increment set by the Define Units command. When the snap increment is specified and used, an exact placement of elements can be achieved. The Snap to Units default is on as signified by a checkmark in front of the Snap to Units option and a highlighted icon.

You can use the F4 key any time to turn on and off the Snap to Units mode.
Select the Snap To Units Tool Icon or command from the Layout Menu.
The Layout Menu will disappear. You may verify that the Snap to Units option is active by checking the Layout Menu for a checkmark in front of the Snap to Units option or the Tool Icons for a highlighted Snap to Units Icon. To turn off the Snap to Units option, select the Snap to Units command or Tool Icon again. The checkmark will disappear and the Tool Icon will no longer be highlighted.

With Snap to Units off, the snap increment is 1 inch. Larger Snap unit increments will permit easier placement or modification of shapes.

Snap To Grid: [F5]
Activates or deactivates the Snap to Grid mode. When the Snap to Grid mode is used, an exact placement of elements can be achieved. The Snap to Grid is only used for drawing openings and assigning loads. When Snap to Grid is on, coordinates are snapped to the closest structural grid intersection. The Snap to Grid mode is on as signified by a checkmark in front of the Snap to Grid option and a highlighted icon.

You can use the F5 key any time to turn on and off the Snap to Grid mode. Only one Snap To option can be selected.

Select the Snap To Grid Tool Icon or command from the Layout Menu.
The Layout Menu will disappear. You may verify that the Snap to Grid option is active by checking the Layout Menu for a checkmark in front of the Snap to Grid option or the Tool Icons for a highlighted Snap to Grid Icon. To turn off the Snap to Grid option, select the Snap to Grid command or Tool Icon again. The checkmark will disappear and the Tool Icon will no longer be highlighted.

Snap To Reference: [F6]
Activates or deactivates the Snap to Reference mode. When the Snap to Reference mode is used, an exact placement of elements can be achieved. The Snap to Reference mode is on as signified by a checkmark in front of the Snap to Reference option and a highlighted icon.

When in Perspective (3D), the Snap to Reference mode snaps the Tape Measure coordinates together. Use the Tape Measure command before the shape editing command.

When viewing a 2D structural plane, the Snap to Reference mode snaps coordinates to the nearest reference coordinate.

You can use the F6 key any time to turn on and off the Snap to Reference mode. Only one Snap To option can be selected.

Select the Snap To Reference Tool Icon or command from the Layout Menu.
The Layout Menu will disappear. You may verify that the Snap to Reference option is active by checking the Layout Menu for a checkmark in front of the Snap to Reference option or the Tool Icons for a highlighted Snap to Reference icon. To turn off the Snap to Reference option, select the Snap to Reference
command or Tool Icon again. The checkmark will disappear and the Tool Icon will no longer be highlighted.

The initial size of the Shape when it first appears on the screen may be defined. An Initial Shape Size dialog window will guide you in specifying the initial N-S and E-W dimensions, the diameter, the height, the plane and column thickness, orientation (N-S or E-W) of the shape in relation to the ground plane, and if the shape is to maintain its initial size when stacking on another shape.

Select the Initial Shape Size Tool Icon or command from the Layout Menu.

The Initial Shape Size Dialog Window will appear in the Dialog area of the Windows screen. You may specify the initial width, diameter, height, thickness, or orientation of the next shape.

To change an Initial Size Dimension:
1. Move the mouse pointer to the text box to be modified. (You may also use the [Tab] key.)
2. Press the left mouse key.
   A vertical cursor will appear in the selected text box. (You may also press and hold the left mouse key as you drag the cursor over the existing entry to highlight it in reversed text.)
3. Type in the new entry. Use the [Backspace] and [Delete] keys as necessary.

The Plane Thickness entry controls the thickness of both vertical planes and horizontal planes selected from the Shapes menu.

To change Orientation or select Maintain Initial Size:
1. Move the mouse pointer to the option button or check box.
2. Press the left mouse key.
   The Maintain Initial Size check box will be changed by adding or removing an X. The Orientation option button will be changed by inserting a black dot in the selected circle. Only one orientation can be selected.
When the Maintain Initial Size box is checked, the shape will maintain its initial size when stacked on a selected plane or shape. When the Maintain Initial Size box is not checked, the shape N-S and E-W widths will match the dimensions of the selected plane or shape.

Shapes stacked on ground and underground will be sized to the specified initial dimensions. For shapes stacked on last shape or plane the specified initial height dimension will be used for the distance perpendicular to the plane.

To save the Initial Shape Size selections:
1. Move the mouse pointer to the OK action box at the bottom of the window. (You may use the CANCEL option if you decide not to change the initial shape size.)
2. Press the left mouse key.
   The Initial Shape Size dialog window will disappear.

STACKING SHAPE OPTIONS

There are four Shape Stacking Options. These options control the initial location of the selected shape when it is placed on the Modeling Screen. Only one option can be selected. The initial default option is Stack on Ground. When two shapes are placed on top of one another, the adjoining surface becomes the floor plane. Floor planes are necessary for developing the structural framing system. For a multi-level building, you need to stack shapes in order to define the floor planes and roof planes for the development and evaluation of a structural framing system. There are several methods for stacking shapes. You will find that the Stack on Last Shape option is useful for creating a multi-level building model and the Stack on Plane option is useful for adding shapes to the side of your model. The four stacking options are:

STACK ON GROUND

As new shapes appear they will be stacked (located) at the center of the ground plane. The initial size of the shape is based on dimensional data saved with the Initial Shape Size command. The shape may be moved to the desired location with the mouse. This is the initial default option whenever you start the CASM program.

After you select a shape by pressing the left mouse key, the displayed shape disappears. This is because the next shape is placed directly on top of the first shape, hiding the lines. You can make the shapes reappear by moving the mouse or double-clicking the right mouse key.

STACK ON LAST SHAPE

As new shapes appear they will automatically be stacked (located) on the roof plane of the last shape placed, if the last shape is compatible with the selected shape (i.e., a cube will not stack on a prism). The shape will automatically be sized to cover the roof plane of the last shape placed, if the Maintain Initial Size option is off on the initial
Shape Size Dialog window. Remaining dimensions will be sized based on dimensional data saved with the Initial Shape Size command. If the Stack on Last Shape is selected before you begin modeling, the first shape placed will be placed on the ground grid.

**STACK ON PLANE**

After selecting a shape you will be prompted for a plane to stack (locate) the shape on. Each visible stackable plane is highlighted by a yellow dot (handle). Select the desired plane by moving the cursor on the dot and by clicking the left mouse key once. The shape may be stacked on the top, sides, or bottom of another shape. The shape will automatically be sized to cover the designated plane, if the Maintain Initial Shape Size option is off on the Initial Shape Size Dialog window. Remaining dimensions will be sized based on dimensional data saved with the Initial Shape Size command.

**STACK UNDERGROUND**

As new objects appear they will be stacked (located) at the center of the ground plane under the ground floor plane of the model. The initial size of the shape is based on dimensional data saved with the INITIAL SHAPE SIZE command.

Select one of the Stack option Tool icons or menu commands from the Layout Menu.

The Layout Menu will disappear. You may verify that the desired Stack option is active by checking the Layout Menu for a checkmark in front of the desired Stack option or look for a highlighted tool icon. To change the Stack option, select another Stack option. The checkmark will change on the Layout Menu. The highlighted tool icon will change.

**LOCKING OPTIONS**

Moving objects in 3-Dimensions on a 2-Dimensional screen can be difficult. The translated distances on the Dimension Dialog window help, but you will find that the Lock options are more convenient. There are three Locking options. These options prevent the dimensional changes or shape movement in the specified directions. None, one, two, or three locking options can be selected. The three options are:

**LOCK N-S**

Prevents dimensional changes or shape movement in the N-S direction.

**LOCK E-W**

Prevents dimensional changes or shape movement in the E-W direction.

**LOCK VERTICAL**

Prevents dimensional changes or shape movement in the vertical direction.
Select one of the Locking option Tool icons or menu commands from the Layout Menu.

The Layout Menu will disappear. You may verify that the desired Lock option is active by checking the Layout Menu for a checkmark in front of the desired Lock option or look for a highlighted tool icon. To change the Lock option, select the Lock option again. The checkmark will disappear on the Layout Menu. The highlighted tool icon will change to unhighlighted.
REFERENCE MENU

Use the Reference Menu commands to aid in creating a dimensionally correct structural model based on the CADD geometry of the Architectural Model. You can use the Import command in the Files Menu to load the Reference CADD file. Once loaded, you can use the Reference Menu commands to control the reference model.

The reference drawing is not added to the current CASM .BLD file. It is maintained as a separate file on the disk drive.

To select a command from the Reference Menu:
1. Move the mouse pointer to the Reference Pull-Down Menu title. (You may also select [Alt] + [F6] from the keyboard to display the Reference Pull-Down Menu.)

If the Reference icons are displayed on the Draw Model tool palette, you may select the desired Reference command with the mouse.

2. Type the underlined letter of the desired reference selection from the menu. (You may also move the mouse pointer down the list to the desired reference selection and press the left mouse key.)

A dialog window will appear.

The Reference Menu commands are listed below:

A dialog window appears to permit you to select specific drawings and layers of an imported CADD drawing or 3-D Architectural model. Drawings which you select will be displayed on the screen. The Import command on the File pull-down menu loads the reference drawing file and controls the initial orientation of 2-D reference drawing elevations and the elevation of 2-D reference drawing plans.
Select the View Reference command from the Reference Menu.

The View Reference dialog window will appear in the Dialog area of the Windows screen. You may specify the desired reference drawing(s) to be displayed on the modeling screen from the Drawings list. You may turn layers listed in the Layers box for the selected drawing in the box above on or off.

To turn drawings on or off:
1. Move the mouse pointer to the desired drawing name.
2. Press the left mouse key.
   The selected drawing will be highlighted.
3. Select the On or Off button with the mouse (or double-click the mouse on the drawing name).
   The off or on setting of the drawing will be displayed next to the drawing name.
   If the drawing is turned off, it will not be displayed on the modeling screen.

To delete a reference drawing:
1. Select the drawing name to delete with the mouse.
2. Select the Delete button.
   The selected drawing name will be deleted from the list.

To turn layers on or off:
1. Select the drawing name on the list of drawings with the mouse.
   The list of layers will be displayed in the Layers box.
2. Select the layer with the mouse to turn on or off.
3. Select the Thaw button to turn the layer on or the Freeze button to turn the layer off (or double-click the mouse on the layer name).
   The off or on setting of the layer will be displayed next to the layer name.

MOVE REFERENCE

You may move the reference model as necessary in order to compare it with the structural model. The Move Reference command only moves visible reference drawings (drawings that are turned on).

Select the Move Reference command from the Reference Menu.

The Move Reference command will activate all of the visible drawings and link them to movement of the mouse. Movement of the shape on the modeling screen corresponds to the mouse movements listed below:

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.
- Pressing the right mouse key and moving the mouse toward/away from you will move the shape up/down.
- Pressing the left mouse key will accept the shape location. A new shape will appear or handles will appear if you are stacking shapes on planes.
The cursor direction keys can be used in combination with the mouse to make final incremental movements of the reference drawing. The up [↑] and down [↓] cursor keys drag in the north-south direction. The left [←] and right [→] cursor keys drag in the east-west direction. Hold down the [Alt] key while pressing the up [↑] or down [↓] cursor keys to drag vertically. The [Enter] key equals the left mouse key (select). The [Esc] key equals a double click right mouse key (cancel).

You can press the [F2] function key to bring up a Shape Coordinates dialog window for keyboard entry of reference drawing coordinates. Entries in the Centroid data boxes control the location of the reference drawing.

You can press the [F3] function key to bring up a Translate Coordinates dialog window for keyboard entry of new coordinates in order to move the visible reference drawing to the new coordinates. You may make changes based on the Initial Coordinates of the selected objects or based on Tape Measure dimensions. In order to use the Tape Measure dimensions, you must first select the Tape Measure command and designate the two vertices that you want to connect.

1. Press the left mouse key to place the reference drawing.
   The visible reference drawing will be located in a new location.

To center the reference drawing on the ground plane.
1. Select the Move Reference command with the mouse.
2. Press the [F2] function key.
   The Shape Coordinates dialog window will appear.
3. Change the values in the Centroid data boxes to 0.
4. Select OK to save the changes.
   The reference drawing will be centered on the ground plane.

You may rotate the reference model as necessary in order to compare it with the structural model.
DRAW STRUCTURE TOOL PALETTE

You may use the Draw Structure Tool Palette to define and layout a structural system for the model. The Draw Structure Tool Palette consists of a tool palette icon area and pull-down menus which have the same function as the tool icons. The menus and icons on the Draw Structure Tool Palette permit you to define a structural grid system and add openings with the Grid/Opening Menus; modify structural members, structural grids, and openings with the Edit Menu; layout structural members with the Surface/Linear, Column/Wall, and Lateral Menus.

With CASM you can create very elaborate structural systems or a complete system for an entire building. Very large detailed models may slow down the operation of the program. You may find it easier to draw a portion of the building structural system to study typical bay framing and make several separate project file copies of the typical bay framing with different materials and layouts in order to determine a final solution.

You must be viewing a 2D structural plane in order to use the Draw Structure menus. You may use the Structural Plane Name drop down list to select a structural plane to view.

Structural Planes are automatically uniquely named and numbered by CASM. However, the names and numbers are often random and may not be useful. You should use the Structural Plane Information command on the View menu to provide a meaningful name for each structural plane.

Before drawing structural elements you must first define a structural grid.

The Draw Structure Tool Palette Window is shown below:

To select a command from the Draw Structure Menu with the mouse:

If the Draw Structure tool palette is not displayed:
1. Move the mouse pointer to the Draw Structure icon button.
2. Press the left mouse key.
   The Draw Structure Tool Palette will appear below the pull-down menu bar.
   Also Draw Structure menus will be inserted on the pull-down menu bar.

   You may select a Draw Structure command directly from the tool palette or select the command from the pull-down menus.

If the Draw Structure tool palette is displayed:
1. Move the mouse pointer to the desired tool icon.
2. Press the left mouse key.
   The tool icon will be highlighted and a dialog window may appear.
Using the Draw Structure menus if the Draw Structure tool palette is displayed:

1. Move the mouse pointer to the desired pull-down menu option on the CASM program window.
2. Press the left mouse key. The pull-down menu will appear.
3. Move the mouse pointer to the desired menu option. (You may also activate the command by typing the underlined letter in the desired command.)
4. Press the left mouse key to activate the command.

A dialog window may appear. Refer to the Draw Structure command sequences listed on the following pages.

To select a command from the Draw Structure Window with the keyboard:

2. Hold down the [Alt] key and press the underlined key of the desired pull-down menu. The pull-down menu will be displayed on the screen.
3. Type the underlined letter of the desired command to activate the command.

-OR-

Use the up or down arrows on the keyboard to move the selection bar up or down to the desired selection, then press the [Enter] key.

The Draw Structure Menu commands selections are listed on the following pages:
EDIT MENU

The Edit pull-down menu contains commands that enable you to modify an existing structural framing system on a selected structural Plane or take components from other locations and use them in the selected structural Plane. The graphic Edit Tool icons on the Draw Structure Tool Palette may also be used.

You must be viewing a 2D structural plane in order to use the Draw Structure commands.

You may use the View Pan tool to move the displayed plane on the screen and the Distance Tool to zoom in and out. Click on the left arrow to zoom in. Click on the right arrow to zoom out.

To select a command from the Edit Menu:

For the tool palette:
1. Move the mouse pointer to the desired edit icon in the Draw Structure Tool Palette.
2. Press the left mouse key.
   The edit icon will be highlighted and a dialog window may appear, or handles will appear on objects on the Modeling Screen.

For the Edit pull-down menu:
1. Move the mouse pointer to the Edit Pull-Down Menu title. (You may also select [Alt] + [E] from the keyboard to display the Edit Pull-Down Menu.)
2. Press the left mouse key.
   The Edit pull-down menu will appear.
3. Move the mouse pointer down the list to the desired edit command. (You may also type the underlined letter of the desired edit command from the menu.)
4. Press the left mouse key.
   A dialog window may appear or handles will appear on shapes on the Modeling Screen. (For the Dual-Monitor System the mouse pointer will change to the Matrox modeling screen.)

The Edit Menu commands are listed on the following pages:
The Undo command cancels the last structural action or last editing action performed. You may continue to Undo commands until an Undo is not possible. The command to be undone is listed after the word Undo.

The Copy Structure command temporarily saves selected structural elements. The Paste Structure command is used to paste the selected elements into other locations on the structural plane. You may copy structural elements from one plane to another. The copied structural elements are saved until new elements are copied or until you exit the project file.

You must be in a 2D structural plane view in order to use the Copy Structure command.

Select the Copy Structure command from the Edit menu or tool icon.

Handles appear at the midpoint of all structural elements on the displayed structural plane. Groups of structural elements such as narrowly spaced elements will be represented by a single handle at the first member. The mouse pointer changes to a + .

You may exit the Copy Structure editing mode at this time without copying elements by double clicking the right mouse key.

1. Place the mouse pointer on the handles of all structural elements to be copied.
2. Press the left mouse key on each handle.
   The selected structural elements will be highlighted. When you have finished selecting elements to be copied:
3. Double click the right mouse key.
   All of the handles will disappear. The mouse pointer remains a + .
4. Place the mouse pointer on a grid intersection near the selected elements to serve as an insert ion origin.
5. Press the left mouse key.
   The designated grid intersection becomes the origin for the copied structural elements. The Past Structure command is automatically started.
You may exit the Paste Structure editing mode at this time without pasting elements by double clicking the right mouse key.

6. Place the mouse pointer on a grid intersection near the location of the insertion origin where the structural elements are to be pasted.

7. Press the left mouse key.

The copied structural elements will be pasted on the structural plane. You will remain in the Paste Structure mode. When you have finished pasting elements on the structural plane:

8. Double click the right mouse key.

The mouse pointer will return to normal.

The Paste Structure command is used to paste the structural elements copied using the Copy Structure command into other locations on structural planes.

You must be in a 2D structural plane view in order to use the Paste Structure command.

WARNING ! ! ! You must verify that the dimensions are identical when you PASTE structural members into another location. CASM currently does not check for equal dimensions. If you PASTE members that are too long or too short, problems with member loadings will result (i.e. the bay sizes must be the same.

The Copy and Paste commands cannot be used when copying structure onto a plane inclined in a different direction from the plane containing the structure to be duplicated.

Select the Paste Structure command from the Edit menu or tool icon.

The mouse pointer changes to a + .

You may exit the Paste Structure editing mode at this time without pasting elements by double clicking the right mouse key.

1. Place the mouse pointer on a grid intersection near the location of the insertion origin where the structural elements are to be pasted.

2. Press the left mouse key.

The copied structural elements will be pasted on the structural plane. You will remain in the Paste Structure mode. When you have finished pasting elements on the structural plane:

3. Double click the right mouse key.

The mouse pointer will return to normal.

The copied structural elements will be retained until you exit CASM, change project files, or copy new elements. You may continue to use Paste Structure to paste copied elements to other structural planes in your structural model. You cannot paste structural elements from a horizontal plane to an inclined plane.
You may designate structural elements for deletion. Deleting a structural element removes it from the graphic file.

You must be in a 2D structural plane view in order to use the Delete Structure command.

Select the Delete Structure command from the Edit menu or the tool icon.

All structural elements will be highlighted at their midpoint by a colored square ("handle"). Groups of structural elements such as narrowly spaced elements will be represented by a single handle at the first member. The mouse pointer changes to a \(+\).

1. Move the mouse pointer to the handle on a structural element to be deleted.

You may exit the Delete Structure editing mode at any time without deleting an element by double clicking the right mouse key.

2. Press the left mouse key.

The designated structural element will be deleted. The handles on the remaining structural elements will reappear. You will remain in the Delete Structure edit mode.

3. Double click the right mouse key to exit the Delete Structure edit mode.

The mouse pointer will return to normal.

If you accidentally delete the wrong structure, immediately use the Undo Delete Structure command.

The Modify Structure command permits you to modify (change) dimensions, orientation, or numbers of structural elements.

You must be in a 2D structural view in order to use the Modify Structure command.

Select the Modify Structure command from the Edit menu or the tool icon.

All structural elements will be highlighted at their midpoint by a colored square ("handle"). Groups of structural elements such as narrowly spaced elements will be represented by a single handle at the first member. The mouse pointer changes to a \(+\).

1. Move the mouse pointer to the handle on a structural element to be modified.

You may exit the Modify Structure editing mode at any time without modifying an element by double clicking the right mouse key.

2. Press the left mouse key.
The designated structural element will be highlighted. The handles on the remaining structural elements will reappear. A dialog window will appear permitting you to change orientation or dimensions. Use the Recalc button to view the change. See the list below.

**Structural attributes that can be modified:**

<table>
<thead>
<tr>
<th>Column:</th>
<th>Wall:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orientation</td>
<td>Beginning &amp; Ending Height</td>
</tr>
<tr>
<td>Height</td>
<td>Thickness</td>
</tr>
<tr>
<td>Narrowly &amp; Widely Spaced:</td>
<td>Truss:</td>
</tr>
<tr>
<td>Orientation</td>
<td>Number</td>
</tr>
<tr>
<td>Number</td>
<td>Spacing</td>
</tr>
<tr>
<td>Spacing</td>
<td>Offsets</td>
</tr>
<tr>
<td>Offsets</td>
<td>Orientation if not gable</td>
</tr>
<tr>
<td>Surface:</td>
<td></td>
</tr>
<tr>
<td>Orientation</td>
<td></td>
</tr>
</tbody>
</table>

3. Select SAVE with the mouse to save changes.

Selecting Cancel will permit you to exit without saving changes.

---

**DELETE GRID LINE**

The Delete Grid Line command permits you to Delete a main structural grid line or a structural sub grid line on the selected structural Plane. Deleting a grid line removes it from the graphic file.

- You must be in a 2D structural plane view in order to use the Delete Grid Line command.

- The main grid line will be deleted on all structural planes. The sub grid line will be deleted only on the structural plane which you have selected.

Select the Delete Grid Line command from the Edit menu or the tool icon.

Grid lines inside the model border are marked near the end of the grid line by a colored square ("handle"). The mouse pointer changes to a +.

You may exit the Delete Grid Line editing mode at any time without deleting a grid line by double clicking the right mouse key.
1. Move the mouse pointer to the handle on a grid line to be deleted.
2. Press the left mouse key.
   The designated grid line will be deleted. The grid line dimensions will be
   automatically revised. The handles on the grid lines will reappear. You will
   remain in the Delete Grid Line edit mode.
3. Double click the right mouse key to exit the Delete Grid Line edit mode.
   If you accidentally delete the wrong grid line, immediately use the
   Undo Delete Grid Line command.

The Move Grid Line command permits you move main grid lines or sub grid lines on
the selected structural plane.
   A main grid line will be shifted on all structural planes. A sub grid line
   will be shifted only on the structural plane which you have selected.
   You must be in a 2D structural plane view in order to use the Move Grid
   Line command.
   The Unit Snap Increment will control the movement of the grid line.
   You may need to adjust the unit snap increment with the Define Units
   command in order to get the desired grid dimension.

Select the Move Grid Line command from the Edit menu or the tool icon.
   All grid lines are marked near the end of the grid line by a colored square
   ("handle"). The mouse pointer changes to a +
1. Move the mouse pointer to the handle on a grid line to be moved.
2. Press the left mouse key.
   The grid line will be highlighted. You may continue to select other grid lines to
   be moved.
   After marking all the grid lines to be moved--
3. Double click the right mouse key.
   The grid lines will change to their normal color. As you move the mouse the
   selected grid lines will move. Grid line dimensions will be dynamically updated
   as you move the grid lines.
   Moving the mouse toward/away from you moves the selected grid lines.
   You may exit the Move Grid Line editing mode at this time without
   saving changes by double clicking the right mouse key and the
   selected grid lines will return to their original locations.
   The [F2] function key will activate the keyboard input mode for Grid
   Coordinate input for only one grid line at a time. A Grid Coordinates
   dialog window will appear for keyboard input. Select OK to save the change.
4. Press the left mouse key to save the grid line change. The selected grid lines will be redrawn in their new locations.

**DELETE OPENING**

The Delete Opening command permits you to Delete an opening on the selected structural plane.

- You must be in a 2D structural plane view in order to use the Delete Opening command.
- If the opening is continuous, you will be prompted by a dialog window if you want the openings deleted at all levels. Select either YES or NO.

Select the Delete Opening command from the Edit menu or the tool icon.

All openings are marked at their center at the intersection of the opening symbol by a colored square ("handle"). The mouse pointer changes to a +.

- You may exit the Delete Opening editing mode at this time without deleting openings by double clicking the right mouse key.

1. Move the mouse pointer to the handle on an opening to be deleted.
2. Press the left mouse key.

The designated opening will be deleted. The sub grid line dimensions will be automatically revised. The handles on the remaining openings will reappear. You will remain in the Delete Opening edit mode.

- If the opening is continuous on all floors, a dialog window will appear to confirm if you want to delete the opening on all floors.

3. Double click the right mouse key to exit the Delete Opening edit mode.

- If you accidentally delete the wrong opening, immediately use the Undo Delete Opening command.

**MODIFY OPENING**

The Modify Opening command permits you to Modify an opening on the selected structural plane.

- You must be in a 2D structural plane view in order to use the Modify Opening command.
- If the opening is continuous, you will be prompted by a dialog window if you want the openings modified at all levels. Select either YES or NO.

- The snap mode and unit increment will control the movement of the opening boundaries. You may need to adjust the unit snap increment with the Define Units command or turn the snap mode off in order to get the desired dimensions.
Select the Modify Opening command from the Edit menu or the tool icon.

All openings are marked at their corners and center at the intersection of the opening symbol by a colored square ("handle"). The mouse pointer changes to a +.

To move the opening:

1. Move the mouse pointer to the center handle on an opening to be moved.
2. Press the left mouse key.

The designated opening will be highlighted and a Tributary Area dialog window will appear. The grid line dimensions will be automatically revised in the Tributary Area dialog window as you move the opening.

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.

The [F2] function key will activate the keyboard Input mode for Area Coordinate input. Enter the Base Point coordinates for the opening and either Point 2 coordinates or Length values in the data boxes. Select OK to save the changes.

You may exit the Modify Opening editing mode at this time without saving changes by double clicking the right mouse key and the selected opening will return to its original location.

3. Press the left mouse key to save the change.

The sub grid lines for the opening will be automatically updated and redrawn.
To change the size of the opening:

1. Move the mouse pointer to the corner handle on an opening to be re-dimensioned.
2. Press the left mouse key.

The designated opening will be highlighted and a Tributary Area dialog window will appear. The opening dimensions will be automatically revised in the Tributary Area dialog window as you drag the opening corner.

- Moving the mouse right/left corresponds to E-W on the screen.
- Moving the mouse toward/away from you corresponds to N-S on the screen.

You may exit the Modify Opening editing mode at this time without saving changes by double clicking the right mouse key and the selected opening will return to its original size.

3. Press the left mouse key to save the change.

If the opening is continuous on all floors, a dialog window will appear to confirm if you want to modify the opening on all floors.

COPY LATERAL VERTICAL ELEMENTS (INACTIVE)

Will permit you to copy defined lateral vertical resistance elements to other locations.

DELETE LATERAL VERTICAL LOCATION

You may designate vertical resistance systems for deletion. Deleting a vertical resistance system removes it from the graphic file.

You must be in a Horizontal or Inclined Structural Plane view in order to use the Delete Lateral Vertical Location command.

Select the Delete Lateral Vertical Location command from the Lateral menu or the tool icon.

All displayed lateral resistance systems will be highlighted at their midpoint by a colored square ("har +le"). The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on a vertical resistance system to be deleted.

You may exit the Delete Lateral Vertical Location mode at any time without deleting a vertical resistance system by double clicking the right mouse key.

2. Press the left mouse key.

The designated vertical resistance system will be deleted. The mouse pointer will return to normal.
You may designate horizontal diaphragm areas for deletion. Deleting a horizontal diaphragm area removes it from the graphic file.

You must be in a Horizontal or Inclined Structural Plane view in order to use the Delete Horizontal Diaphragm command.

Select the Delete Horizontal Diaphragm command from the Lateral menu or the tool icon.

All displayed horizontal diaphragm areas will be highlighted at their midpoint by a colored square ("handle"). The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on a horizontal diaphragm area to be deleted.

2. Press the left mouse key.

The designated horizontal diaphragm area will be deleted. The handles on the remaining areas will reappear. You will remain in the Delete Horizontal Diaphragm area mode.

3. Double click the right mouse key to exit the Delete Horizontal Diaphragm mode.

The mouse pointer will return to normal.

The distance between two designated structural vertices will be measured. The measurement is displayed on the Windows screen in a Structure Measure dialog window.

When in a 2D structural plane view, structural elements can be selected to be measured.

Select the Tape Measure command from the Edit menu or tool icon.

The mouse pointer changes to a +.

1. Move the mouse pointer to the first structural element where the measurement is to begin.

2. Press the left mouse key.

The vertex of the selected structural member will be highlighted by a green dot.

3. Next move the mouse pointer to the second vertex on the structural member where the measurement is to end.
4. Press the left mouse key.

The vertex will be highlighted by a green dot. A dashed line will be drawn joining the two dots. A Structure Measure dialog Window will appear which displays the distance of the second vertex relative to the first vertex in three dimensions.

```
> Structure Measure
| Horizontal:  00" ft |
| Vertical:    140" ft |
| True Length: 140" ft |
```

You must select Cancel to cancel the Tape Measure command and proceed to another command.

When you want to stop tape measure:
1. Move the mouse pointer to the Cancel block at the bottom of the window.
2. Press the left mouse key.

The Structure Measure Dialog Window will disappear. You will need to select Tape Measure again in order to find another distance.
GRID/OPENING MENU

The Grid/Opening pull-down menu contains commands that enable you to develop a structural grid for a structural framing system on a selected structural plane or add openings to the structural plane. The Grid system will define locations for structural elements which you will add later. The opening may be continuous (extend through several stories) or unique for the selected structural plane. The graphic Grid/Opening Tool Icons on the Draw Structure tool palette may also be used.

You must be in a 2D structural plane view in order to use the Grid/Opening menu.

You may use the View Pan Tool to move the displayed plane on the screen and the Distance Tool to Zoom in and out. Click on the left arrow to zoom in. Click on the right arrow to zoom out.

To select a command from the Grid/Opening Menu or Icons:

For the tool palette:
1. Move the mouse pointer to the desired Grid/Opening icon in the Draw Structure Tools Palette.
2. Press the left mouse key.
   The selected Grid/Opening icon will be highlighted and a dialog window may appear, or handles will appear on shapes on the Modeling Screen.

For the Grid/Opening pull-down menu:
1. Move the mouse pointer to the Grid/Opening Pull-Down Menu title. (You may also select [Alt] + [G] from the keyboard to display the Grid/Opening Pull-Down Menu.)
2. Press the left mouse key.
   The Grid/Opening pull-down menu will appear.
3. Move the mouse pointer down the list to the desired command. (You may also type the underlined letter of the desired Grid/Opening command from the menu.)
4. Press the left mouse key.
   A dialog window may appear or handles will appear on shapes on the Modeling Screen.

The Grid/Opening Menu commands are listed on the following pages.
The Define Grid command permits you to define the main structural Grid system for the entire model or for a specified section of the model. The Grid will be spaced based on model dimensions and specified spacing. After activating the command, a dialog box will appear which will permit you to specify spacing and offsets. You may also add new grids, delete grids, define limits, and modify the bubble locations, spacings, and labels by selecting the Options box. The program will lay out the Grid system based on the dimensions of the model and the parameters which you have set.

In order to draw structural elements it is necessary to define a structural grid.

The Defined Grid is aligned with the ground plane. In order to create a rotated Grid system, the Ground Plane must be rotated first by the Define Ground Plane command in the Draw Model Layout menu. Then the rotated structural grid can be defined.

If you add more shapes after you define the structural grid, a dialog window will remind you to redefine the grid.

You may Define Grid in the Perspective 3D display or one of the structural plane displays. You will find it easier to use one of the structural plane displays to define the grids.

Select the Define Grid Tool Icon or command from the Grid/Opening Menu.

The Define Grid Dialog Window will appear in the Dialog area of the Windows screen. You may change the structural grid spacing and offsets. Select the Options selection box to add new grids, delete grids, define limits, and change bubble locations, grid areas, and labels.
To define the grid spacings and offsets for the entire building footprint:

1. Move the mouse pointer to the text box to be modified. (You may also use the [Tab] key.)
2. Press the left mouse key.
   A vertical cursor will appear in the selected text box. (You may also press and hold the left mouse key as you double click on the existing entry to highlight it in reversed text.)
3. Type in the new entry. Use the [Backspace] and [Delete] keys as necessary.
4. You may select the OK box to save the grid settings and display the grid on the model. Use the Cancel option if you decide not to define the structural grid.

If you do not select the Options, the defined grid will cover the entire building footprint area with bubbles on the left and top of the plane. You may use the Options selections to modify the placement or display of the grid or add new grids.

To define the grid spacings and offsets for one of several shapes making up the building footprint:

If you cannot define separate grids on the same shape in plan. The Define Grid command looks for four corners within the defined area to layout the grid.

1. Select the Define Grid Options button with the mouse pointer.
2. Press the left mouse key.
   The Options area of the Define Grid dialog window will be displayed.
3. Select Define Limits with the mouse pointer.
4. Press the left mouse key.
   The mouse pointer will turn into a plus symbol.
5. Select one corner of the grid area with the mouse pointer.
6. Press the left mouse key.
7. Move the mouse pointer to the opposite diagonal corner.
The rectangle defining the area will be dragged by the mouse pointer.

8. **Press** the left mouse key.
   
   The Define Grid dialog window will reappear.

9. **Verify** the desired grid spacings, offsets, numbers, letters, and bubble locations.

10. **Select OK** to save the grid area and settings.

   The grid will be drawn within the modeling coordinates found in the designated area. Select Cancel to not save the grid area and settings.

**To modify grids or layout additional grids**

The Options selection permits you to vary the location of the bubbles and beginning numbers or letters. In addition, the Options selection permits you to define separate grids for adjoining shapes in plan.

**If you have already defined a grid and re-enter the Define Grid command the previously defined grid will be highlighted by a colored border.**

**To modify the current structural grid:**

1. **Select** the Define Grid command.

   The current structural grid will be highlighted by a colored border and the Define Grid dialog window will appear.

   **If the structural grid to be modified is not highlighted, use the Select Grid button in the Define Grid Option dialog window to select the desired grid.**

2. **Enter new grid spacings or offsets** for the current grid. To change bubble locations and/or beginning number and letter, select the Options button and make the changes.

3. **Select OK** to save the changes.

   The grid will be redrawn with the new settings. Select Cancel to not save the changes.

**To redefine limits for a current structural grid:**

1. **Select** the Define Grid command from the Grid/Opening menu.

   The Define Grid dialog window will be displayed. The current grid border will be highlighted.

2. **Move the mouse pointer to the Options selection box.**

3. **Press** the left mouse key.

4. **Move the mouse pointer to the Define Limits box.**

5. **Press** the left mouse key.

   The Define Grid window will disappear and the mouse pointer will change to a graphic cursor.

6. **Position** the mouse pointer to a corner of the desired grid area.
7. Press the left mouse key.
8. Move the mouse pointer to the opposite corner of the desired grid area. (The boundary outline of the grid area will follow the mouse movement.)
9. Press the left mouse key.
   The Define Grid dialog window will reappear to permit you to make dimension changes and assign the grid.
10. Select OK to save the redefined grid.

To layout new grid spacings and offsets on the plan of an adjoining shape:

If the shape is at an angle to the adjoining shape, you will need to rotate the ground plane before you define the new grid.

1. Select the Define Grid command from the Grid/Opening menu.
2. Move the mouse pointer to the Options selection box.
3. Press the left mouse key.
4. Move the mouse pointer to the Add New Grid box.
5. Press the left mouse key.
   The Define Grid window will disappear and the mouse pointer will change to a graphic cursor.
6. Position the mouse pointer to a corner of the new grid area.
7. Press the left mouse key.
8. Move the mouse pointer to the opposite corner of the new grid area.
9. Press the left mouse key.
   The Define Grid dialog window will reappear to permit you to make dimension changes and assign the grid.
10. Select OK to save the new grid.

To delete a structural grid:

1. Select the Define Grid command from the Grid/Opening menu.
   The border of the current grid will be highlighted.
2. Move the mouse pointer to the Options selection box.
3. Press the left mouse key.
   If the structural grid to be deleted is not highlighted, use the Select Grid button in the Define Grid Option dialog window to select the desired grid.
4. Move the mouse pointer to the Delete Grid box.
5. Press the left mouse key.
   The last defined grid (current grid) will disappear.
The Add Main Grid Line command will add a Main Grid line between two existing Main Grid lines.

- The new Main Grid line is added to all levels.
- You must be in a 2D structural plane view in order to use the Add Main Grid command.
- The unit snap will control the placement of the new grid line. You may need to adjust the unit snap by the Define Units command in order to get the desired dimension.

Select Add Main Grid Line command from the Grid/Opening menu or the tool icon.

Colored squares (handles) will appear on the building perimeter midway between the existing Main Grid lines near the grid line bubbles. The mouse pointer changes to a +.

1. Move the mouse pointer to a handle between the existing grid lines.
2. Press the left mouse key.

The new main grid line will appear midway between the existing grid lines at the handle location. The grid line dimensions will be automatically revised.

3. Moving the mouse toward/away from you will move the grid line.

- Double clicking the right mouse key will set the new grid line midway between the existing grid lines.
- The [F2] function key will activate the keyboard input mode for Grid Coordinate input for the new grid line. A Grid Coordinates dialog window will appear for keyboard input. Select OK to save the change.

4. Press the left mouse key to save the new Main Grid at the selected location.

The Add Sub Grid Line command will add a Sub Grid line between two existing main Grid lines.

- The new Sub Grid line is only added to the selected structural plane.
- You must be in a 2D structural plane view in order to use the Add Sub Grid command.
- The unit snap will control the placement of the new grid line. You may need to adjust the unit snap by the Define Units command in order to get the desired dimension.
Select Add Sub Grid Line command from the Grid/Opening menu or the tool icon.

Colored squares (handles) will appear on the building perimeter midway between the existing Main Grid lines near the grid line bubbles. The mouse pointer changes to a +

1. Move the mouse pointer to a handle between the existing grid lines.
2. Press the left mouse key.

The new sub grid line will appear midway between the existing grid lines at the handle location. The grid line dimensions will be automatically revised.

3. Moving the mouse toward/away from you will move the new grid line.
   - Double clicking the right mouse key will set the sub grid line midway between the existing grid lines.
   - The [F2] function key will activate the keyboard input mode for Grid Coordinate input for the new grid line. A Grid Coordinates dialog window will appear for keyboard input. Select OK to save the change.

4. Press the left mouse key to save the new Sub Grid at the selected location.

**ADD OPENING**

The Add Opening command will add an Opening on the selected structural plane.

- You must be in a 2D structural plane view in order to use the Add Opening command.

- You may add an opening at the selected structural plane or you may designate the opening as continuous for all structural floor planes, but not a roof or wall plane.

Use a snap mode to accurately place the opening. Use the Define Units command to set the snap increment.
Select the Add Opening command from the Grid/Opening menu or the tool icon.

A Tributary Area dialog window will appear with opening dimensions and mouse pointer location values from the lower left corner of the floor plan.

1. Locate the mouse pointer at the desired location of one corner of the opening.
2. Press the left mouse key.
3. Moving the mouse will drag the opposite corner of the opening.

Opening dimension changes will appear in the Tributary Area dialog window as you drag the mouse.

The [F2] function key will activate the keyboard Input mode for Area Coordinate Input. Enter the Base Point coordinates for the opening and either Point 2 coordinates or Length values in the data boxes. Select OK to save the changes.

You may exit the Add Opening mode at any time without adding an opening by double clicking the right mouse key.

4. Press the left mouse key again to save the opening dimensions.

Another dialog window will appear with a data box for an opening name and an option box to make the opening continuous through all levels of the structure. You may move the mouse pointer to the Continuous check box and press the left mouse key to make the opening continuous on all floors. The opening will not be continuous at the roof.

5. Move the mouse pointer to the OK action box.
6. Press the left mouse key.

The opening location will be saved and the Tributary Area dialog window will disappear. Sub grid lines and dimensions will be drawn at the opening location.
**SURFACE/LINEAR MENU**

The Surface/Linear pull-down menu contains commands that enable you to lay out a structural framing system on your structural grid on a selected structural plane. When you select the Perspective (3D) view, you will see the structural plane in 3D. It is possible to view the entire structure in 3D by use of the All Planes option on the Show Structure command from the View menu.

- You must be in a 2D structural plane view in order to use the Surface/Linear menu.
- You must define a structural grid before laying out a structural framing system.
- You may use the View Pan Tool to move the displayed plane on the screen and the Distance Tool to Zoom in and out. Click on the left arrow to zoom in. Click on the right arrow to zoom out.

To select a command from the Surface/Linear Menu or Icons:

**For the tool palette:**

1. **Move the mouse pointer** to the desired Surface/Linear icon in the Draw Structure Tools Palette.
2. **Press the left mouse key.**
   - The selected Surface/Linear icon will be highlighted and handles will appear on grid segments on the Modeling Screen.

**For the Surface/Linear pull-down menu:**

1. **Move the mouse pointer** to the Surface/Linear pull-down menu title. (You may also select [Alt] + [S] from the keyboard to display the Surface/Linear Pull-Down Menu.)
2. **Press the left mouse key.**
   - The Surface/Linear pull-down menu will appear.
3. **Move the mouse pointer** down the list to the desired Surface/Linear command. (You may also type the underlined letter of the desired Surface/Linear command from the menu.)
4. **Press the left mouse key.**
   - A dialog window will appear and handles will appear on grid segments on the Modeling Screen.

*The Surface/Linear Menu commands are listed on the following pages.*
### SURFACE

Surface is the heading for the two surface commands One-Way and Two-Way. Both commands will define a surface or deck which you can apply loads to and analyze in order to determine an appropriate material and thickness.

The two surface commands are listed below:

**ONE-WAY**

**D**efines a One-Way structural framing system by drawing a One-Way symbol on the framing plan. You may change the orientation by selecting N-S or E-W orientation. The Surface Element dialog window displays the maximum span.

- One-Way Surface elements distribute loads to their supporting linear elements as uniform loads.

**TWO-WAY**

**D**efines a Two-Way structural framing system by drawing a Two-Way symbol on the framing plan. The Surface Element dialog window displays the span.

The command sequence for adding Surface elements to the structural plane are listed below:

- You must be in a 2D structural plane view in order to add a One-Way or Two-Way surface.
- In order to provide an accurate span value in the Surface Element dialog window, you must define linear elements first.
- You must define the surface element over the same area as the linear elements. For example if you define linear elements for one bay, then you must define the surface element for the same bay.
- Use the Draw Surface option when drawing linear elements to easily add the surface element on the linear elements.

Select One-Way or Two-Way Tool icon or command from the Surface/Linear menu.

After the menu command is activated, all the Grid line segments between grid intersections are marked by a colored square (handle) at their midpoint.

- To define a structural framing area you need to select Grid line segments in a **clockwise** orientation until you have defined the complete area where you desire to lay out the structural system. You do not need to select all the grid segments which represent the four sides of an area. For a simple bay defined by four Grid line segments, you need only to select Grid line segments on opposite sides of the area to define the area. If you select an incorrect handle, double click the right mouse key and select Cancel on the dialog box.

1. Position the mouse pointer on the handle of a grid line which borders the desired structural framing area.
2. **Press** the left mouse key to designate the boundaries or location(s).

   The selected GRID line segment will be highlighted. Continue to select grid segments until you have defined a rectangular area.

   You may exit defining a structural framing area at any time by double clicking the right mouse key.

3. **Double click** the right mouse key after you have defined the entire area for laying out the surface elements.

   The One-Way or Two-Way system symbol is drawn on the selected bay. The arrows indicate the orientation of the span. A Surface Elements dialog window will appear to provide you with options to change the span orientation. The area and maximum span is indicated in the text box.

   ![Surface Element Dialog](image)

   **To change the surface orientation:**
   1. Move the mouse pointer to the desired option button.
   2. **Press** the left mouse key.

   The selected option button will be highlighted. Only one orientation can be selected.

   **To SAVE the surface orientation:**
   1. Move the mouse pointer to the SAVE confirmation box.
   2. **Press** the left mouse key.

   The dialog window will disappear. The surface element will be saved to the data file and remain on the screen. You may select CANCEL if you do not want to save the surface element layout.

   After defining the linear elements and surface elements for one bay, you may use the Copy and Paste commands to repeat the structural bay throughout the structure, including other levels.

**LINEAR**

Linear is the heading for several linear commands. These commands will define linear structural elements which you can apply loads to and analyze in order to determine an appropriate material and size.

The Linear commands are listed below. The sequence for adding Narrowly Spaced and Widely Spaced members is similar.
**NARROWLY SPACED**

Draws and defines a Narrowly Spaced structural framing system by drawing Narrowly Spaced elements in areas which you designate. Narrowly Spaced elements are those that are spaced less than or equal to 4 feet apart and produce distributed reactions on other elements. The Linear Elements dialog window displays the span. You may vary the orientation, spacing, and review the changes before selecting the desired layout.

- If you change the number of elements, spacing, or offsets, you must use the Recalc action box to re-draw the linear elements.
- Narrowly spaced elements spaced greater than 4 feet produce concentrated reactions on other elements.
- You do not need to define a surface element in order to distribute loads to the narrowly spaced elements. However, you will need to include the surface element if you intend to design the surface element based on the assigned loads.

**WIDELY SPACED**

Draws and defines a Widely Spaced structural framing system by drawing Widely Spaced elements within the designated area on the framing plan. Widely Spaced elements are those that are spaced greater than 4 feet apart and produce concentrated reactions on other elements. The members are initially spaced evenly in the designated area. You may vary the orientation, span, spacing, and review the changes before selecting the desired layout. You may also select a single grid line for a single beam using the Widely Spaced command.

- If you change the number of elements, spacing, or offsets, you must use the Recalc action box to re-draw the linear elements.
- You need to define a surface element in order to distribute loads to the widely spaced elements, unless there are narrowly spaced elements framing into it.
- If using the Widely Spaced command to lay out members along a grid line, you must define each element between columns separately. If you define the Widely Spaced element on the grid line over the full width of the building, the program treats the element as one long beam and ignores the column supports at the grid intersections.

The command sequence for adding Linear elements to the structural plane are listed below:

- You must be in a 2D structural plane view in order to add a Narrowly Spaced or Widely Spaced element.
- In order to apply area loads to widely spaced elements, you must define surface elements on the widely spaced elements.
Select the Narrowly Spaced or Widely Spaced Tool icon or command from the Surface/Linear menu.

After the menu command is activated, all the Grid line segments between grid intersections are marked by a colored square (handle) at their midpoint.

To define a structural framing area you need to select Grid line segments in a clockwise orientation until you have defined the complete area where you desire to lay out the structural system. You do not need to select all the grid segments which represent the four sides of an area. For a simple bay defined by four Grid line segments, you need only to select Grid line segments on opposite sides of the area to define the area. For a single beam on the grid line, just select that grid line. If you select an incorrect handle, double click the right mouse key and select Cancel on the dialog box.

1. Position the mouse pointer on the handle of a grid line which borders the desired structural framing area.
2. Press the left mouse key to designate the boundaries or location.
   - If you are defining widely spaced members located on the grid line, designate the widely spaced member from support to support. Do not indicate the entire beam line as the widely spaced element. CASM will ignore intermediate supports and treat the designated beam line as one long beam between exterior walls of the building.

The selected GRID line segment will be highlighted. Continue to select grid segments until you have defined a rectangular area. Selecting a single grid segment will permit you to define a single beam.

You may exit the defining a structural framing area at any time by double clicking the right mouse key.

3. Double click the right mouse key after you have defined the entire area or location for laying out the framing members.
The linear elements are drawn in the selected area defined by the highlighted grid lines. A Linear Elements dialog window appears to provide you with options to change number of members, spacing, or orientation. (Not all options are available for the different commands.) N-S and E-W spans are listed for reference. The spans are calculated from the selected area.

**To make changes to the dialog window:**

1. Move the mouse pointer to the desired check and/or text box to make changes.

   - Linear elements can be placed by fixing the spacing or fixing the number of elements. Use the Recalc button to view the different selections. All text boxes are updated based on the selected option, Number of Elements or Spacing.

2. Press the left mouse key to position the cursor.

3. Enter the value change.

   - If a value in a text box is changed, the appropriate check box must be selected in order for the change to appear on the structural plane.
   - If neither Offset is fixed, the elements are centered in the selected area.
   - Select the check box next to the Draw Surface option to draw a surface element perpendicular to the linear elements.

**To view the change on the screen:**

1. Move the mouse pointer to the Recalc action box.

2. Press the left mouse key.

   The structural elements will be rearranged to match the data in the Linear Element dialog window.

**To accept the framing layout:**

1. Move the mouse pointer to the SAVE action box.

2. Press the left mouse key.

   The dialog window will disappear. The members will be saved to the data file and remain on the screen. You may select CANCEL if you do not want to save the framing layout.

   - After defining the linear elements and surface elements for one bay, you may use the Copy and Paste commands to repeat the structural bay throughout the structure, including other levels.

**BEAMS: ALL GRID LINES**

Automatically draws and defines beams on all main grid lines. After you select the Beams All Grid Lines command from the menu, beams are automatically defined, saved, and drawn on all grid lines. Once drawn you can use the Delete Structure command to eliminate beams that you do not need.
You must be in a 2D structural plane view in order to add beams to all grid lines.

Select Beams All Grid Lines Tool icon or command from the Surface/Linear menu.

After the menu command is activated, beams will automatically be drawn on all the main grid line segments between main grid intersections.

Trusses and defines Trusses in the area or location which you designate. The initial method of defining trusses is the same as the method for defining narrowly spaced or widely spaced members. After defining an area, the Linear Element dialog window appears to aid you in defining the truss spacing, offsets, and orientation. After you select Save, a Truss Custom dialog window appears.

You must be in a 2D structural plane view in order to add a Truss Custom element.

You need to define surface or linear elements which the truss supports in order to distribute loads to the truss elements.

If you are laying out trusses along a grid line, you must define each truss between columns separately. If you define the truss on the grid line over the full width of the building, the program treats the truss as one long span and ignores the column supports at the grid intersections.

Select the Truss - Custom Tool icon or command from the Surface/Linear menu.

After the menu command is activated, all the Grid line segments between grid intersections are marked by a colored square (handle) at their midpoint.

To define a structural framing area you need to select Grid line segments in a clockwise orientation until you have defined the complete area where you desire to lay out the structural system. You do not need to select all the grid segments which represent the four sides of an area. For a simple bay defined by four Grid line segments, you need only to select Grid line segments on opposite sides of the area to define the area. For a single truss on the grid line, just select that grid line. If you select an incorrect handle, double click the right mouse key and select Cancel on the dialog box.

1. Position the mouse pointer on the handle of a grid line which borders the desired structural framing area.
2. Press the left mouse key to designate the boundaries or location.

The selected GRID line segment will be highlighted. Continue to select grid segments until you have defined a rectangular area. Selecting a single grid segment will permit you to define a single truss.

You may exit defining a structural framing area at any time double by clicking the right mouse key.
3. **Double click the right mouse key** after you have defined the entire area or location for laying out the truss members.

The truss elements are drawn in the selected area defined by the highlighted grid lines. A Linear Elements dialog window appears to provide you with options to change number of members, spacing, or orientation. (Not all options are available for the different commands.)  N-S and E-W spans are listed for reference. The spans are calculated from the selected area.

![Linear Elements dialog window](image)

To make changes to the dialog window:

1. **Move the mouse pointer** to the desired check and/or text box to make changes.

   Truss elements can be placed by fixing the spacing or fixing the number of elements. Use the Recalc button to view the different selections. All text boxes are updated based on the selected option, Number of Elements or Spacing.

2. **Press the left mouse key** to position the cursor.

3. **Enter the value change**.

   If a value in a text box is changed, the appropriate check box must be selected in order for the change to appear on the structural plane.

   If neither Offset is fixed, the elements are centered in the selected area.

   Select the check box next to the Draw Surface option to draw a surface element perpendicular to the truss elements.

To view the change on the screen:

1. **Move the mouse pointer** to the Recalc action box.

2. **Press the left mouse key**.
The structural elements will be rearranged to match the data in the Linear Element dialog window.

To accept the framing layout:
1. Move the mouse pointer to the SAVE action box.
2. Press the left mouse key.
   The dialog window will disappear. You may select CANCEL if you do not want to save the framing layout.

A Truss Custom dialog window will appear. The options on the Truss Custom dialog window include:

- Include opposite side of roof - When you have selected an inclined plane on a prism to define the trusses, you can define the trusses on the adjoining inclined plane by selecting the Include Opposite Side check box. The defined trusses will be gable trusses.
- Depth at support - Assigns a truss depth at the truss support for graphic display and design of the truss. For flat trusses you must assign a depth in order for the truss to be displayed on the structural model. Lines representing a basic truss form are drawn on the model. The truss form is displayed in Perspective 3-D and elevations.

   The depth at support is used for the truss analysis. You have an option to change the depth before doing the truss analysis.

- Scissors height - Assigns the height from the base of the prism to base of the scissors truss at the ridge for graphic display and design of the truss. The truss form is displayed in Perspective 3-D and elevations.

   The scissors height is used for the truss analysis. You have an option to change the scissors height before doing the truss analysis.

To include other side of gable roof:
1. Move the mouse pointer to the check box to make change.
2. Press the left mouse key to select the opposite side of roof.
   An 'X' will appear in the box to indicate the other side of the roof is included in the truss design.

   If Include Opposite Side of Roof is unchecked (off), then only half of a gable roof truss would be drawn.

   Structure needs to be drawn on or connecting to trusses so that loads are transferred to the truss correctly, uniform or concentrated. Trusses drawn with less than 4 feet spacing do not assume a uniform load like narrowly spaced linear elements do.

To make value changes to the dialog window:
1. Move the mouse pointer to the desired text box to make changes.
2. Press the left mouse key to position the cursor.
3. Enter the value change.
To accept the truss layout changes:

1. Move the mouse pointer to the OK confirmation box.
2. Press the left mouse key.

The dialog window will disappear. The members will be saved to the data file and remain on the screen. You may select CANCEL if you do not want to save the framing layout.

Note the trusses drawn in the Perspective (3D) display. The webbing shown is the CASM generic webbing. The actual webbing desired is defined during the truss analysis procedure.

After defining the truss elements for one bay, you may use the Copy and Paste commands to repeat the structural bay throughout the structure, including other levels. The copy and paste structure commands cannot be used when desiring to copy structure onto a plane inclined in a different direction from the plane containing the structure to be duplicated.

**Non-Horizontal Arch (Not Implemented)**

Draws and defines Non-Horizontal Arches in the area or location which you designate.

**Grids, Two-Way (Not Implemented)**

Draws and defines a Two-Way Grid system in the area or location which you designate.
COLUMN/WALL

The Column/Wall pull-down menu contains commands that enable you to develop a column and/or bearing wall system for a selected structural plane. When you select the Perspective (3D) view, you will see the structural plane in 3D. It is possible to view the entire structure in 3D by use of the All Planes option on the Show Structure command from the View menu.

- You must define a structural grid before laying out columns and walls.
- You must be in a horizontal or inclined structural plane view in order to use the Column/Wall menu.
- You may use the View Pan Tool to move the displayed plane on the screen and the Distance Tool to Zoom in and out. Click on the left arrow to zoom in. Click on the right arrow to zoom out.

To select a command from the Column/Wall Menu or Icons:

For the tool icons:
1. Move the mouse pointer to the desired Column/Wall icon in the Draw Structure Tools Palette.
2. Press the left mouse key.
   - The selected Column/Wall icon will be highlighted and a dialog window will appear.

For the Column/Wall pull-down menu:
1. Move the mouse pointer to the Column/Wall Pull-Down Menu title. (You may also select [Alt] + [C] from the keyboard to display the Column/Wall Pull-Down Menu.)
2. Press the left mouse key.
3. Move the mouse pointer down the list to the desired Column/Wall command. (You may also type the underlined letter of the desired Column/Wall command from the menu.)
4. Press the left mouse key.
   - A dialog window will appear.

The Column/Wall Menu commands are listed on the following pages.
COLUMN

Column is the heading for three column commands. The commands will define column locations which you can apply loads to and analyze in order to determine an appropriate material and size.

ALL GRID INTERSECTIONS

Activating the All Grid Intersection command will draw columns at all Main Grid intersections on the structural plane which you have selected. A dialog box will permit you to change orientations and add columns on all floors.

You must be in a Horizontal or Inclined Structural Plane view in order to use the All Grid Intersections command.

You may add columns at the selected floor/roof plane or you may designate the columns as continuous for all structural floor planes.

Select All Grid Intersections command from the Column/Wall menu or the tool icon. Columns will be drawn at all Main Grid intersections. A Column Element dialog window will appear with column orientation information and an option box for all floors.

If the Footing option on the Column/Wall menu has been checked, the columns will be automatically drawn with footings at the lowest level.

You can graphically show piers below the ground floor slab if you indicate a height greater than 0.0 for columns inserted under the ground floor slab.

To change column orientation:
1. Move the mouse pointer to the orientation option button.
2. Press the left mouse key.
   The columns are all reoriented.
To change column height:

The column height displayed is automatically set to the level below the displayed level. You may need to change the column height if the column is two stories tall in an open space below or the column is on a pier below the ground floor slab. The displayed height of the column is from the displayed structural plane to the base of the column. If the column height is not correct then the column load rundown and define lateral location will not work.

1. Move the mouse pointer to the Height text box.
2. Press the left mouse key.
3. Change the height value, if desired.

The Distance from grid option is not active when the Columns All Grid Intersections is selected.

To draw columns automatically on all floors:

1. Move the mouse pointer to the All Floors check box.
2. Press the left mouse key.

An 'X' will be drawn in the box. To deselect the All Floors option, select the check box again.

To save your selections:

1. Move the mouse pointer to the SAVE confirmation box.
2. Press the left mouse key.

The column layout will be saved. Selecting CANCEL will remove the column from the grid intersections without saving.

Activating the One Grid Intersection command will draw columns at the designated Main or Sub Grid intersections on the structural plane which you have selected. A dialog box will permit you to change orientations and add the columns on all floors.

You must be in a Horizontal or Inclined Structural Plane view in order to use the One Grid Intersection command.

You may add columns at the selected floor/roof plane or you may designate the columns as continuous for all structural floor planes.

Select the One Grid Intersection command from the Column/Beam menu or the tool icon.

The mouse pointer changes to a + .

1. Move the mouse pointer to a grid intersection where you intend to place a column.
2. Press the left mouse key.
A column symbol will appear at the intersection. Continue to place columns at designated grid intersections. When finished:

3. **Double click the right mouse key** to exit the add column mode.

A Column Element dialog window will appear with column orientation information and an option box for all floors.

olumes will be drawn with footings at the lowest level.

You can graphically show piers below the ground floor slab if you indicate a height greater than 0.0 for columns inserted under the ground floor slab.

**To change column orientation:**

1. **Move the mouse pointer** to the orientation option button.
2. **Press** the left mouse key.

The columns are all reoriented.

**To change column height:**

The column height displayed is automatically set to the level below the displayed level. You may need to change the column height if the column is two stories tall in an open space below or the column is on a pier below the ground floor slab. The displayed height of the column is from the displayed structural plane to the base of the column. The displayed height is not correct then the column load rundown and define lateral location will not work.

1. **Move the mouse pointer** to the Height text box.
2. **Press** the left mouse key.
3. **Change the height value**, if desired.

**To change the reference grid location:**

The N-S and E-W values provide N-S and E-W distance from a reference grid intersection. You may change the reference grid intersection if you desire.

1. **Move the mouse pointer** to the Distance from grid text box.
2. **Press** the left mouse key.
3. **Change the reference grid**, the format must be "letter, number".
4. **Select Recalc** to display the revised distances.

**To draw columns automatically on all floors:**

1. **Move the mouse pointer** to the All Floors check box.
2. **Press** the left mouse key.

An 'X' will be drawn in the box. To deselect the All Floors option, select the check box again.

**To save your selections:**

1. **Move the mouse pointer** to the SAVE confirmation box.
2. **Press** the left mouse key.
The column layout will be saved. Selecting CANCEL will remove the column from the grid intersections without saving.

**WALL**

Wall is the heading for three wall commands. The commands will define wall locations which you can apply loads to and analyze in order to determine an appropriate material and size. If wall dead loads have been defined, you may assign wall dead loads as you designate the wall locations. Openings in walls being used as shear walls are discussed under DEFINE ELEMENTS of the LATERAL pull-down menu.

**2 GRID POINTS**

Permits you to draw and define a bearing/shear Wall between two Grid intersections.

> You must be in a Horizontal or inclined Structural Plane view in order to use the 2 Grid Points command.

> You may add a wall at the selected floor/roof plane or designate the wall as continuous for all floor planes.

> You may assign a wall dead load at the same location as the wall being drawn. You must first define the wall dead load in Loads and Design before drawing the walls.

Select the 2 Grid Points command from the Column/Wall menu or the tool icon.

The mouse pointer changes to a +

1. Move the mouse pointer to a grid intersection where you intend to start the wall.
2. Press the left mouse key.
3. Move the mouse pointer to the second grid intersection where you intend to end the wall.
4. Press the left mouse key.

A wall will be drawn joining the two intersections. A Wall Element dialog window will appear with data boxes to designate wall heights and wall thickness. The wall orientation and length are for reference only and cannot be changed.

> If the Footing option on the Column/Wall menu has been checked and the first floor has been selected, the walls will be drawn with footings at the ground floor or lowest basement level.

> You can graphically show foundation walls below the ground floor slab if you indicate a height greater than 0.0 for walls inserted under the ground floor slab.
To change wall height:

The wall height displayed is automatically set to the level below the displayed level. You may need to change the wall height if the wall is two stories tall in an open space below or the wall is on a foundation wall below the ground floor slab. The displayed height of the wall is from the displayed structural plane to the base of the wall. If the wall height is not correct then the wall load rundown and define lateral location will not work.

1. Move the mouse pointer to the Start Height or End Height text box.
2. Press the left mouse key.
3. Change the height value, if desired.

To change wall thickness:

1. Move the mouse pointer to the Thickness data box, if you want to change the wall thickness.
2. Press the left mouse key to move the cursor to the data box.
3. Enter the new value.
4. To view the change in wall thickness on the screen, select the Recalc action box and press the left mouse key.

The wall will be redrawn with the new thickness.

To draw walls automatically on all floors:

1. Move the mouse pointer to the All Floors check box.
2. Press the left mouse key.

An 'X' will be drawn in the box. To deselect the All Floors option, select the check box again.

To assign wall dead load:

You must first save the wall dead load on the Loads menu from the Loads and Design tool palette before drawing the walls.

1. Move the mouse pointer to the Assign Dead Load check box.
2. Press the left mouse key.
An 'X' will be drawn in the box.

3. Move the mouse pointer to the down arrow on the load list box.

4. Press the left mouse key.
   A list of wall types will be displayed. Use the side scroll arrows to view the list of wall types.

5. Place the mouse pointer on the desired wall type. Press the left mouse key.
   The selected wall type will be displayed in the text box above.

   The wall type and load value will not be displayed on the current level. It will be displayed on the level below the current level.

To save your selections:
1. Move the mouse pointer to the SAVE confirmation box.
2. Press the left mouse key.
   The wall layout will be saved. Selecting CANCEL will remove the wall without saving.

Permits you to draw and define a Pilaster on a Wall.

Enables or disables the placement of a footing at the base of columns and walls. When the footing option is selected, footings are automatically added to the base of all walls and columns drawn after the selection of the Footing option.

   You must select Footing before drawing walls and columns. If you select Footing after drawing walls and columns, they will not be added.

Select the Footing command from the Column/Wall menu or the tool icon.

The Column/Wall menu will disappear. A check mark will be placed in front of the Footing option on the menu. The Footing tool icon will be highlighted. When columns and walls are drawn with the Footing option selected, footings will be automatically drawn at the lowest level of the walls or columns.
# LATERAL MENU

The Lateral pull-down menu contains commands that enable you to develop a lateral load resisting system for a selected structural plane.

- You must be in a Horizontal or Inclined Structural Plane view in order to use the Lateral menu.
- You may use the View Pan Tool to move the displayed plane on the screen and the Distance Tool to Zoom In and out. Click on the left arrow to zoom in. Click on the right arrow to zoom out.
- It is necessary to define a structural grid and define all connecting structural elements (beams, columns, and structural walls) on all floors before defining the lateral load resistance system.

To select a command from the Lateral Menu or Icons:

**For the tool palette:**
1. Move the mouse pointer to the desired Lateral icon in the Draw Structure Tools Palette.
2. Press the left mouse key.
   - The selected Lateral icon will be highlighted and a dialog window will appear.

**For the Lateral pull-down menu:**
1. Move the mouse pointer to the Lateral pull-down menu title. (You may also select [Alt] + [L] from the keyboard to display the Lateral pull-down menu.)
2. Press the left mouse key.
3. Move the mouse pointer down the list to the desired Lateral command. (You may also type the underlined letter of the desired Lateral command from the menu.)
4. Press the left mouse key.
   - A dialog window will appear.

*The Lateral Menu commands are listed on the following pages.*
**VERTICAL**

Vertical is the heading for two Vertical Lateral Resistance elements commands. The commands will define lateral resistance locations and types which you can apply vertical and lateral loads to and analyze in order to determine an appropriate material and sizes.

**DEFINE LOCATION**

Activating the Define Location command will permit you to define lateral load resisting systems on selected grid lines on the structural plane which you have selected.

1. **You must be in a Horizontal or Inclined Structural Plane view in order to use the Define Location command.**
2. **All connecting beams, columns, and structural walls on all floors must be defined before defining the lateral load restraining system location.**

Select the Define Location command from the Lateral menu or the tool icon.

Handles will appear on all beams and structural walls at their midpoint.

1. **Move the mouse pointer to the handle on the beam or structural wall where you intend to define the lateral load resistance system.**
2. **Press the left mouse key.**

Cross-hatching is drawn on the selected structural member and on adjoining structural members on the same grid line to represent the lateral load resisting system. The lateral system is labeled at its midpoint.

When you are defining E-W lateral systems, only E-W lateral systems will be displayed on the screen. When you are defining N-S lateral systems only N-S lateral systems will be displayed on the screen. To see both N-S and E-W lateral systems at the same time you will need to select the N-S Lateral Resistance and E-W Lateral Resistance selection boxes on the Show Structure dialog window which is on the Viewpoint Options menu.
Analysis of lateral resistance locations which are a combination of both shear walls and frames cannot be analyzed by CASM. CASM can create an input file for STAAD-III to do the analysis.

When defining a location which has both shearwall and beam elements, a dialog box will ask if you want to join both types of elements.

**DEFINE ELEMENTS**

Use the Define Elements command to select a location to define a lateral load resisting system. A Lateral Resistance dialog window will appear with system icons and a pull-down menu permitting you to define your overall system on a 2-D view of the selected location. The elements that you can assign to your system include:

- X-Brace
- Knee Brace
- K-Brace
- Frame All Connections
- Spread K
- Frame One Connection
- Single Diagonal
- Continuous Beam or Column
- Offset Diagonal
- Shear Wall Openings
- Shear Wall Separation Joints

You must be in a Horizontal or Inclined Structural Plane view in order to use the Define Elements command.

You must first Define Locations before you can Define Elements.

Select the Define Elements command from the Lateral menu or the tool icon.

Handles will appear on all displayed Lateral Resistance systems. The mouse pointer changes to a + .

1. Move the mouse pointer to a handle on a Lateral Resistance system.
2. Press the left mouse key.

A 2-D view of the lateral resistance location is displayed and a Lateral Resistance dialog window will appear with icons to add the various elements.
3. **Move the mouse pointer** to the element icon which you intend to add.

   You can also select the commands from the pull-down menus.

4. **Press the left mouse key.**

   Handles will appear in all the structural bays where you can add the element or on structural members that you will be connecting the elements to. The following sequences define the method of adding the elements.

**FRAME MENU**

**To add bracing (X, K, Spread K, Knee, Diagonal, Offset Diagonal):**

Handles are drawn in all the structural bays where you can add the element.

1. **Select the bay handle** where you intend to add the element.
2. **Press the left mouse key** to add the element to the bay.

   The selected element will be drawn in the selected bay. The Offset distance controls the element spacing from the columns for the knee braces, offset diagonal, and spread K elements. The Mirror check box controls the orientation of the diagonals, and K-braces. With the Mirror box not checked the elements will be drawn as shown.

   All members will initially be shown as pin ended (moment= 0) and supports initially shown as hinges. The member connection restraints can be modified as desired from the Lateral Resistance icons. The supports can be changed during the Lateral Resistance Design option on the Design menu on the Loads and Design tool palette.

3. **Double click the right mouse key** to exit the add mode.

**To add One Framed Connection:**

Handles will be drawn on beams.

1. **Move the mouse pointer** to the handle on the beam where you intend to add the element.
2. **Press the left mouse key.**

   Handles will be drawn on the columns.

3. **Move the mouse pointer** to the handle of the connecting column.
4. **Press the left mouse key** to add the element to the connection.

   The selected framed connection element will be drawn connecting the beam and column. You may continue to select other members to add framed connections.

5. **Double click the right mouse key** to exit the add mode.

**To add All Framed Connection:**

Framed connection elements are automatically drawn between all beams and columns.

**To make a beam or column continuous:**

Handles will be drawn on beams and columns.
REFERENCE

1. Move the mouse pointer to the handle on the first half of the beam or column.
2. Press the left mouse key.
3. Move the mouse pointer to the handle of the second half of the beam or column.
4. Press the left mouse key to make the member continuous at the connection. You may continue to select other members to make continuous.
5. Double click the right mouse key to exit the add mode.

SHEAR WALL MENU

To add a Shear Wall Opening:
1. Move the mouse pointer to one corner of the shear wall opening.
   Use the [F2] key to activate the keyboard input mode for the Area Coordinates input of the opening. Enter the Base Point coordinates, then enter the opposite corner or Point 2 coordinates or enter the length dimensions of the opening. Select OK to save the opening data and display the opening.
2. Press the left mouse key.
   A Tributary Area dialog window will appear and the mouse pointer will change to an opening.
3. Move the mouse pointer to the opposite corner of the opening.
4. Press the left mouse key to save the opening size and location.
   The opening will be drawn in the shear wall. You may continue to draw more openings in the shear wall.
5. Double click the right mouse key to exit the add mode.

To add a Shear Wall Separation Joint at One Level:
1. Move the mouse pointer to the horizontal location in the level of the separation joint.
2. Press the left mouse key.
   The separation joint will be drawn in the selected level.
3. Double click the right mouse key to exit the add mode.

To add a Shear Wall Continuous Separation Joint:
1. Move the mouse pointer to the horizontal location at any level of the separation joint.
2. Press the left mouse key.
   The separation joint will be drawn continuous through all levels.
3. Double click the right mouse key to exit the add mode.
EDIT MENU

To Undo a command:
1. Move the mouse pointer to the Undo icon.
2. Press the left mouse key to cancel the last action. You may continue to Undo commands until an Undo is not possible.

To delete lateral resistance elements:
1. Move the mouse pointer to the Delete icon.
2. Press the left mouse key.
   Handles will appear on the lateral resistance elements. The mouse pointer will change to a +.
3. Move the mouse pointer to a handle on an element to be deleted.
4. Press the left mouse key.
   The lateral resistance element will be deleted. You will remain in the delete mode until you double-click the right mouse key.
5. Double click the right mouse key to exit the Delete mode.

To exit the Define Elements mode:
1. Move the mouse pointer to the OK action box.
2. Press the left mouse key.

HORIZONTAL

Horizontal is the heading for five Horizontal Lateral Resistance elements commands. The commands will define horizontal resistance locations and types which you can apply vertical and lateral loads to and analyze in order to determine an appropriate material and sizes.

ENTIRE PLANE

Flexible Diaphragm

Rigid Diaphragm

Permits you to define an ENTIRE floor or roof system as a flexible or rigid diaphragm. Controls the distribution of lateral loads to the lateral resistance system. For flexible diaphragms lateral loads are transferred to the lateral resistance locations by tributary area or continuous beam model. For rigid diaphragms, lateral loads are transferred to the lateral resistance locations by relative stiffness. When you define a floor or roof as rigid or flexible, the label Rigid Diaphragm or Flexible Diaphragm is printed in the lower left corner of the modeling screen.
Select the Rigid Diaphragm or Flexible Diaphragm command from the Lateral menu or the tool icon.

Selecting the Flexible Diaphragm or Rigid Diaphragm options from the Lateral menu will define levels as flexible or rigid. The label Flexible Diaphragm or Rigid Diaphragm will be printed in the lower right corner of the modeling screen when you are in a structural plane display. The selection will be marked on the menu and the icon will be highlighted.

To make all the floors rigid and the roof flexible, first designate the floors as rigid, then select the roof plane. It will be initially labeled as Rigid. Select Flexible Diaphragm from the Lateral menu and the roof will be redesignated as Flexible.

### DEFINE AREA

**FLEXIBLE DIAPHRAGM**

**RIGID DIAPHRAGM**

Permits you to define a PORTION of a floor or roof system as a flexible and a portion as a rigid diaphragm. Controls the distribution of lateral loads to the lateral resistance system. For flexible diaphragms, lateral loads are transferred to the lateral resistance locations by tributary area or continuous beam model. For rigid diaphragms, lateral loads are transferred to the lateral resistance locations by relative stiffness. When you define a floor or roof as both flexible and rigid, the label Flexible and Rigid Diaphragm is printed in the lower left corner of the modeling screen.

All lateral locations must be defined before using these commands.
Select the Rigid Diaphragm or Flexible Diaphragm command from the Lateral menu or the tool icon.

1. Pick the first corner with the mouse.
2. Pick the second corner with the mouse.

Corners must fall at end points or intersections of lateral resistance systems.

The designated diaphragm area is hatched and labeled. Select the next diaphragm area.

**SELECTED Diaphragm**

Prints a list of surface (deck) material systems and indicates whether the system can be considered as rigid or flexible.

Select the Diaphragm Guidelines command from the Lateral menu.

A Flexible or Rigid Diaphragm guidelines dialog window will appear with a list of deck (plate) materials and indications of whether the material can be considered as flexible or rigid. Select OK to close the window.

```
<table>
<thead>
<tr>
<th>Plate Type</th>
<th>Rigid</th>
<th>Flexible</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cast in Place Concrete</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Gypsum Concrete</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Pre-cast Concrete Planks</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Steel Decks without Conc.</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Steel Decks with Conc.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wood Decks</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
```

Select OK to close the window.
LOADS AND DESIGN TOOL PALETTE

The Loads and Design Tool Palette is used to define the loads acting on the structural model and make preliminary structural system selections based on the loading conditions on the preliminary structural frame developed in Draw Structure. The Edit pull-down menu permits you to delete or modify assigned loads. It also permits you to copy or modify the member design (designation). The Loads pull-down menu will permit you to generate loads and apply them to the structural model. The Mat pull-down menu permits you to select a material such as steel or concrete for your preliminary design. The material selection will determine the list of displayed systems in the Surface/Linear and Column/Wall pull-down menus. The Design pull-down menu permits you to do a preliminary analysis and design of designated structural elements and Quantity Take-off of all structural members. You may use a spreadsheet in order to select a preliminary element size. The Loads and Design Tool Palette is shown below:

To select a command from the Loads and Design Window with the mouse:

If the Loads and Design tool palette is not displayed:
1. Move the mouse pointer to the Loads and Design icon at the top of the side tool bar.
2. Press the left mouse key.
   The Loads and Design Tool Palette will appear.

If the Loads and Design tool palette is displayed:
1. Move the mouse pointer to the desired tool icon in the Loads and Design Tool Palette.
2. Press the left mouse key.
   The tool icon will be highlighted and a dialog window will appear.

Using the Loads and Design menus if the Loads and Design tool palette is displayed:
1. Move the mouse pointer to the desired pull-down menu option.
2. Press the left mouse key.
   The selected pull-down menu will appear.
3. Move the mouse pointer to the desired menu option (you may also activate the command by typing the underlined letter in the desired command).
4. Press the left mouse key to activate the command.
   A dialog window will appear. Refer to the Loads and Design command sequences listed on the following pages.
To select a command from the Loads and Design Window with the keyboard:

1. Hold down the [Ctrl] key and press the [L]-key.
   
   The Loads and Design Tool Palette will appear.

2. Hold down the [ALT] key and press the underlined key of the desired pull-down menu.
   
   The pull-down menu will be displayed on the screen.

3. Type the underlined letter of the desired command to activate the command.
   
   -OR-
   
   Use the up or down arrows on the keyboard to move the selection bar up or down to the desired selection, then press the [ENTER] key.

The Loads and Design Tool Palette pull-down menus are listed on the following pages:
EDIT MENU

The Edit pull-down menu commands permit you to delete or edit assigned loads on the selected plane. You may also modify or copy member design information.

- You must be in a 2D structural plane view in order to perform an Edit menu command.
- You may use the View Pan Tool to move the displayed plane on the screen and the Distance Tool to Zoom in and out. Click on the left distance arrow to zoom in. Click on the right distance arrow to zoom out.

The Edit Menu command selections are listed on the following pages:

UNDO

The Undo command cancels the last loads and design action or last editing action performed. You may continue to Undo commands until an Undo is not possible. The command to be undone is listed after the word Undo.

DELETE LOAD

You may use the Delete Load command to delete a load assignment from the structural model. Only loads which have been assigned can be deleted. Use the Show Loads command in the View pull-down menu to display the loads you wish to delete.

Select the Delete Load command from the Edit menu:

- All displayed loads will be highlighted at the center of the area load or point load by a colored handle. The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on the desired load to be deleted.
   - You may exit the Delete Load mode at any time by double clicking the right mouse key.
2. Press the left mouse key.
   - The designated load will disappear. The handles on the remaining loads will reappear. You will remain in the Delete Loads mode.
3. Double click the right mouse key to exit the Delete Load mode.
   - If you accidentally delete the wrong load, immediately use the Undo Delete Load command.
You may use the Modify Load command to modify the load area or location assignment on the structural model. Only loads which have been assigned can be modified. Use the Show Loads command in the View pull-down menu to display the loads you wish to delete.

Select the Modify Load command from the Edit menu:

All displayed loads will be highlighted at the center of the area load, linear load, or point load by a colored square (handle). Handles are also located at the corners of area loads and end points of linear loads. The mouse pointer changes to a +.

1. Move the mouse pointer to the handle on the desired load to be modified.
   - Use the handles at the center of the loads to move the loads. The Tributary Area window will display the location changes.
   - Use the handles at the corners of the loads to change the designated load area. The Tributary Area window will display the dimension changes.

You may exit the Modify Load mode at any time without saving changes by double clicking the right mouse key.

2. Press the left mouse key.
   The selected load area will be highlighted and a Tributary Area dialog window will appear. Move the mouse to change the selected load area or position.

3. Press the left mouse key to save the modification.

You may use the Copy Design command to copy an element design size and properties to other elements. First select the element design properties to copy, then select the new elements to receive the design properties. Double click the right mouse key to exit the command.

Before you can copy member design properties, you must first label members using the Preliminary Analysis and CASM Spreadsheets or with the Modify Design command.

Select the Copy Design command from the Edit menu:

Handles will appear on all members with design labels.
1. Select a member design to copy. Place the mouse pointer on the handle and press the left mouse key.

Handles on all other similar members will appear (i.e. if selected member is a widely spaced element, handles will appear on all other widely spaced elements).

2. Select the handle of the member to copy the design to by placing the mouse pointer on the handle and pressing the left mouse key.

The selected member will be labeled with the copied design label.

3. Double click the right mouse key to exit the Copy Design command.

You may use the Modify Design command to add, modify, or delete the member design size and properties. Select the member, then enter the size and properties in the dialog box. Select the Delete button to remove the design size and properties.

Select the Modify Design command from the Edit menu:

Handles will appear on all structural members, labeled and unlabeled.

1. Select a member design to modify by placing the mouse pointer on the handle and pressing the left mouse key.

You may also select a member without a design label in order to assign a design label and member properties.

A Design dialog window will appear with text boxes containing design information for the member selected.

2. Move the mouse pointer to a text box and press the left mouse key.

3. Type in the desired change/entry.

4. Select OK when you have made all desired changes.
When modifying the design of a truss, a 2D view of the truss is displayed allowing you to select which member of the truss to modify.

Other options include:

- Description Data Window button - For steel members you can select the member description and properties from the pop-up AISC database list.
- Delete - Removes the Design label from the selected member.

When Deleting a design of a member in a series, a dialog box asks whether or not to Delete all of the designs in the series.

Cancel - Exits the Modify Design command without making changes.
LOADS AND DESIGN TOOL PALETTE

LOADS MENU

The Loads pull-down menu commands permit you to develop a list of building materials and their corresponding dead load (DL) values for floor, wall, ceiling, and roof assemblies. You may develop a list of concentrated (Point) loads and moments. You may develop a list of occupancy live loads (LL) which apply to your project. All of the loads may be selectively applied to surfaces on the model in order to simulate anticipated loading conditions.

In addition, this version of the CASM program will automatically calculate wind, snow, seismic, and minimum roof live loads based on the structural model geometry.

You must be in a Horizontal or Inclined Structural Plane view in order to assign area loads or point loads.

The Loads Menu command selections are listed on the following pages:

LOAD COMBINATIONS

Before structural members can be analyzed, you need to define load combinations and load factors. The Load Combinations menu selection displays a dialog window where you can define load factors and load combinations.

A Load Combination must be selected before a member can be analyzed or seismic loads calculated.

Select the Load Combinations Icon or command from the Loads Menu.

A Load Combination Dialog Window will appear.

To add load combinations to the Name block:

1. Move the mouse pointer to a load factor text box.
2. Press the left mouse key (you may also hold the left mouse key and drag the cursor over the current factor value to highlight it).
A vertical cursor will appear. Use the keyboard keys to type in a new factor value.

After you have entered all the factors for the desired load combination:

3. Move the mouse pointer to the ADD action block.
4. Press the left mouse key.

The load combination with factors will be added to the list in the Load Combination Name block.

If you need a reference for the code-specified combinations:

1. Move the mouse pointer to the Guidelines action block.
2. Press the left mouse key.


3. Select OK to close the windows.

To select a Load Combination:

1. Move the mouse pointer to a Load Combination in the Name box.
2. Press the left mouse key.

The selected Load Combination will be highlighted and will be used in the analysis.

To select Pattern Occupancy Live Load option:

1. Move the mouse pointer to the Pattern Occupancy Live Load check box.
2. Press the left mouse key.

An 'X' will appear in the box.

Patterned Live Load is used for continuous member analysis. Live loads are automatically varied in the analysis to produce maximum moments and shears in the continuous beam or girder.
After you have entered all the desired Load Combinations and/or selected the desired Load Combination for analysis:

1. Move the mouse pointer to the OK action block.
2. Press the left mouse key.

The dialog window will disappear.

### AREA AND LINEAR DEAD LOADS

All of the Area and Linear Dead Load command sequences are similar. The pop-up dialog window that appears when an area dead load is selected contains a space for the load type name, a list of materials with corresponding weights (PSF), a summary of all the weights, Assign All Floors check box, and confirmation boxes. The four area dead load commands and their Tool Palette symbols are listed below:

#### FLOOR (DL)

Permits you to define a floor system of floor materials and their corresponding weights. Floor materials and weights may be selected from a floor material listing or may be entered from the keyboard. Several systems may be defined for the project. Permits you to selectively assign the floor system to a designated floor area or all floor levels.

#### WALL (DL)

Permits you to define a wall system of wall materials and their corresponding weights. Wall materials and weights may be selected from a wall material listing or may be entered from the keyboard. Several systems may be defined for the project. Permits you to selectively assign the wall system as a line load on the designated plane for the selected floor or all floors. The default units (PSF) value is automatically converted to PLF for floor loadings.

After you have defined your project wall systems, you may assign the wall load when drawing walls in Draw Structure.

#### CEILING (DL)

Permits you to define a ceiling system of ceiling materials and their corresponding weights. Ceiling materials and weights may be selected from a ceiling material listing or may be entered from the keyboard. Several systems may be defined for the project. Permits you to selectively assign the ceiling system to a designated floor/ceiling area or all floor/ceiling areas.

#### ROOF (DL)

Permits you to define a roof system of roof materials and their corresponding weights. Roof materials and weights may be selected from a roof material listing or may be entered from the keyboard. Several systems may be defined for the project. Permits you to selectively assign the roof system to a designated roof area.
Select the Floor, Wall, Ceiling, or Roof command from the Loads menu or Tool Palette.

A loads dialog window appears.

![Loads Dialog Window]

To enter a name for a system type and corresponding loads:

1. Move the mouse pointer to the 'Name' box at the top of the dialog window.
   When the dialog box first appears, the cursor is automatically placed at the 'Name' box. A new name may be added by typing the new name from the keyboard.

2. Press the left mouse key and drag the pointer over the characters to be changed or move the pointer to the desired correction location and press the left mouse key to position the cursor.

3. Type in the appropriate characters to modify the system type name.

Several system types for each roof, wall, ceiling, and floor may be assigned for the project. Use the drop down list button to edit previously defined systems.

To select the material and weight from a list of materials and corresponding weights (PSF):

1. Move the mouse pointer to the appropriate data window button.

2. Press the left mouse key once and release.
   A dialog window will appear which contains a list of materials and their corresponding weights.

3. Move the mouse pointer to the desired selection.
   Use the up or down arrows or the white rectangle on the vertical bar between the arrows to see more selections on the list.

4. Press the left mouse key twice in quick succession (double-click).
   OR
a. Press the left mouse key once to select an item.
   The item will be highlighted by a dark bar.

b. Move the mouse pointer to the 'OK' box at the bottom of the pop-up dialog window in order to transfer the selection to the construction type dead load (DL) list.

c. Press the left mouse key once and release.
   The material will appear in the material type column and the weight will appear in the PSF column. The weight will be added to the weights in the 'Total' box.

To modify a material type:
1. Move the mouse pointer to the material type that is to be changed.
2. Press the left mouse key and hold down while dragging the pointer over the weight that is to be changed.
3. Type in the desired entry.

To change a weight:
1. Move the mouse pointer to the weight that is to be changed.
2. Press the left mouse key and hold down while dragging the pointer over the weight that is to be changed.
3. Type in the new weight.
   The 'Total' will be updated as you type in the new weight.

To assign Floor (DL), Ceiling (DL), or Wall (DL) to all floors:
1. Move the mouse pointer to the Assign All Floors check box.
2. Press the left mouse key.
   An 'X' will appear in the box to apply the load to all floors when assigned to the displayed floor.
Load types are automatically saved for each unique name.

Several options are available once you have completed the list.

ASSIGN
Permits you to ASSIGN the current construction type and total load to the designated plane displayed on the screen.

In order to assign a load you must have a horizontal or inclined structural plane displayed.

Use the Define Units command in the Draw Model Layout pull-down menu to adjust the snap increment or use the Snap to Grid or Snap to Reference mode.

1. Move the mouse pointer to the ASSIGN action block.
2. Press the left mouse key.

After selecting ASSIGN the graphic cursor will appear on the modeling screen. You designate the area where the load is to be applied. A Tributary Area Dialog Window is displayed to aid you in locating the area load.

<table>
<thead>
<tr>
<th>Tributary Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dist. from lower-left corner:</td>
</tr>
<tr>
<td>Horizontal: 20 ft</td>
</tr>
<tr>
<td>Vertical: 40 ft</td>
</tr>
<tr>
<td>Horizontal Length: 20 ft</td>
</tr>
<tr>
<td>Vertical Length: 20 ft</td>
</tr>
<tr>
<td>Tributary Area: 400 sq ft</td>
</tr>
</tbody>
</table>

To assign Area Loads:

1. Move the graphic cursor to the first corner of the area load.

   Refer to the values in the dialog window to aid in the placement of the area load.

   You can press the [F2] function key to activate the keyboard entry mode. An Area Coordinates dialog window will appear. Enter the Base Point coordinates and the Point 2 coordinates or Length dimensions of the load area. Select OK to save and display the entry.

2. Press the left mouse key.

   At any time you may double click the right mouse key to exit the Area Load Assign sequence.

3. Move the graphic cursor to the diagonally opposite corner of the area load.

4. Press the left mouse key.

   The assigned load area will be shaded and the load values will be printed on the screen. The Area Load Dialog window will reappear.
If the Assign All Floor check box is selected, the load will be assigned to all floors. It will not be assigned to the roof plane (highest plane of the model).

To assign Wall Loads:

You may also assign wall loads as you draw walls by selecting the Assign Wall Load option when drawing walls in Draw Structure.

1. Move the graphic cursor to the one end of the wall load.
   Refer to the values in the dialog window to aid in the placement of the wall load.
2. Press the left mouse key.
   At any time you may double click the right mouse key to exit the Wall Load Assign sequence.
3. Move the graphic cursor to the other end of the wall load.
4. Press the left mouse key.
   A Wall Height dialog window will appear to confirm the wall height for load calculations.

<table>
<thead>
<tr>
<th>Wall Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting wall height:</td>
</tr>
<tr>
<td>Ending wall height:</td>
</tr>
</tbody>
</table>

5. Verify the wall height and select OK.
   The assigned wall load will be drawn and the wall load type will be printed on the screen. The wall load will be applied as a PLF load. The Wall Load Dialog window will reappear.

   If the Assign All Floor check box is selected, the wall load will be assigned to all floors. It will not be assigned to the roof plane (highest plane of the model).

STOP
Moving the mouse pointer to the STOP box and pressing the left key returns you to the main CASM screen.

CANCEL
Cancels any changes to the current load system.

POINT LOADS AND MOMENTS

All of the point loads and moment loads command sequences are similar. The dialog window that appears when a point load or moment is selected contains spaces for the load type and weight and action boxes. The point load and moment load commands and their Tool Palette symbols are:
Permits you to define a concentrated load type and corresponding weight. Concentrated load types and weights are entered from the keyboard. Several concentrated loads may be defined for the project. Permits you to selectively assign the concentrated load to a designated floor or roof area. Default units - Pounds.

**POINT (DL)**

Same as POINT (DL) except concentrated load types and weights may be selected from a listing of building code required point loads.

**MOMENT (DL)**

Permits you to define a moment type and corresponding magnitude. Moment types and values may be entered from the keyboard. Several moments may be defined for the project. Permits you to selectively assign the moment to a designated structural member. Default units - Ft-lbs. The Assign option is not implemented at this time.

**MOMENT (LL)**

Same as MOMENT (DL)

Select the Point (DL), Point (LL), Moment (DL), or Moment (LL) from the LOADS pull-down menu or Tool Palette.

A Point or Moment Load dialog window will appear.

<table>
<thead>
<tr>
<th>Point Load (LL)</th>
<th>Project List</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elev. Mach. Rm. Grate (4sf)</td>
<td>300</td>
</tr>
<tr>
<td>Finish Lt. Ft. Plate (1sf)</td>
<td>200</td>
</tr>
<tr>
<td>Garages: Cars (20sf)</td>
<td>2000</td>
</tr>
<tr>
<td>Garages: Trucks, Buses (20sf)</td>
<td>16000</td>
</tr>
<tr>
<td>Office Fr. (2.5sf)</td>
<td>2000</td>
</tr>
<tr>
<td>Roof Truss Panel Pt.</td>
<td>2000</td>
</tr>
<tr>
<td>Accessible Ceilings</td>
<td>200</td>
</tr>
<tr>
<td>Skylight Ribs</td>
<td>200</td>
</tr>
<tr>
<td>Scuttles</td>
<td>200</td>
</tr>
<tr>
<td>Stair Treads</td>
<td>300</td>
</tr>
<tr>
<td>Roof Secondary Member (4sf)</td>
<td>250</td>
</tr>
<tr>
<td>Total</td>
<td>0.0</td>
</tr>
</tbody>
</table>

[Add] [Stop] [OK] [Cancel]
**LOADS AND DESIGN TOOL PALETTE**

**To add loads to the Project List:**
1. Move the mouse pointer to the 'ADD' box in the LOADS dialog window.
2. Press the left mouse key once and release.
   An input load dialog window will appear.

**For Point (LL):**

**To select a point load from the list of code minimums:**
1. Move the mouse pointer to the desired point load.
2. Press the left mouse key twice in quick succession (double-click).
   
**OR**

   a. Press the left mouse key once and release.
   
   The selection is highlighted by a color bar.

   **To transfer the load to the Project List:**
   b. Move the mouse pointer to the 'OK' box at the bottom of the menu.
   c. Press the left mouse key once and release.
   
   The load list disappears and the selected load is added to the project list.

**For Point (DL), Moment (DL), or Moment (LL):**

**To enter a load to the Project List:**
1. Move the mouse pointer to the 'ADD' box.
   
   **NOTE:** You may press the space bar if the cursor is under the ADD box in the dialog window to eliminate the need to use the mouse.

2. Press the left mouse key once and release.
   An input dialog window will appear.
3. Type in the desired load name.
4. Move to the Pounds (P-lbs) box with the mouse pointer or by pressing the tab key on the keyboard.
5. Type in the load value.
6. Press [ENTER] on the keyboard or move the mouse pointer to the 'OK' box at the bottom of the menu and press the left mouse key once and release.
   
   The dialog window disappears and the selected load is added to the project list.

**For Point (DL), Point (LL), Moment (DL), and Moment (LL):**

**To modify a material type or weight:**
1. Move the mouse pointer to a load type on the 'Project List.'
2. Double click the left mouse key.
   
   A dialog window will appear with the load type and its value. The name is highlighted by a dark bar.
3. Type in the new name or move the mouse pointer to the value box; press and hold the left mouse key while dragging the pointer over the old load value. Type in the new value.

4. Press the [ENTER] key or move the mouse pointer to the 'OK' box and press the left mouse key to verify the modification.

The modified item will appear on the Project List.

Changing the value of an assigned point load will automatically change the assigned value.

Once the Project List is complete, several options are available.

**ADD**
Permits you to ADD a new load to the Project List. Moving the mouse pointer to the ADD box and pressing the left mouse key will display the Load Input dialog window.

**ASSIGN**
Permits you to ASSIGN the load to a surface on the model.

In order to assign a load you must have a horizontal or inclined structural plane displayed.

1. Move the mouse pointer to the desired load name on the project list of point loads.
2. Press the left mouse key to highlight the selection.
3. Move the mouse pointer to the ASSIGN block.
4. Press the left mouse key.

The graphic cursor will appear on the modeling screen. The Tributary Load Dialog Window will appear to aid you in locating the Point Load.

<table>
<thead>
<tr>
<th>Tributary Area</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Dist. from lower-left corner:</strong></td>
</tr>
<tr>
<td>Horizontal: 24'0&quot; ft</td>
</tr>
<tr>
<td>Vertical: 36'0&quot; ft</td>
</tr>
<tr>
<td>Horizontal Length: 0'0&quot; ft</td>
</tr>
<tr>
<td>Vertical Length: 0'0&quot; ft</td>
</tr>
<tr>
<td>Tributary Area: 0.00 sqft</td>
</tr>
</tbody>
</table>

5. Move the graphic cursor to locate the designated point load.

Double click the right mouse key at any time to exit the ASSIGN option without assigning a load.

6. Press the left mouse key.

The designated point load will be marked and the load type will be printed on the screen. The Point Load list will reappear to assign another load.
STOP
Moving the mouse pointer to the STOP box and pressing the left mouse key returns you to the main CASM screen.

The dialog window that appears when the OCCUPANCY Load is selected contains a space for the occupancy load type name, weight, Live Load Reduction guidelines, and action boxes.

The OCCUPANCY (LL) command permits you to select occupancy loads from an occupancy load listing or enter an occupancy load from the keyboard. Several occupancy loads may be specified for the project. Permits you to selectively assign the occupancy load to a designated floor area or all floor planes. Default units - PSF.

You must be in a Horizontal or Inclined Structural Plane view in order to assign occupancy loads.

Select the OCCUPANCY command from the Loads menu or Tool Palette.

An Occupancy loads dialog window appears.

<table>
<thead>
<tr>
<th>Office: Files &amp; Storage</th>
<th>60</th>
</tr>
</thead>
</table>

To select the project occupancy types, code load values, and live load reduction factors from a list of occupancy types:

1. Move the mouse pointer to the ADD box in the OCCUPANCY (LL) dialog window.
2. Press the left mouse key once and release.
   A dialog window will appear which contains a list of occupancy types and their corresponding load values.
3. Move the mouse pointer to the desired selection.
Click on the up or down arrows or drag the white rectangle on the vertical bar between the arrows to see more selections on the list.

4. Double click the left mouse key.

OR

a. Press the left mouse key once to select an item.

The item will be highlighted by a dark bar.

b. Move the mouse pointer to the 'OK' box at the bottom of the dialog window in order to transfer the selection to the Occupancy (LL) Project List.

c. Press the left mouse key once and release.

Some occupancy types and their corresponding loads may also have additional notes. For these occupancy loads, a special pop-up dialog window will appear with additional information.

The occupancy type and load value will appear on the project list.

To modify an occupancy type or load value:

1. Move the mouse pointer to the Occupancy type on the 'Project' list.

2. Double click the left mouse key.

A dialog window will appear with the load type, value, and note (if applicable). The name is highlighted by a dark bar.

3. Type in the new name or move the mouse pointer to the value box; press and hold the left mouse key while dragging the pointer over the old load value. Type in the new value.

4. Press the [ENTER] key or move the mouse pointer to the 'OK' box and press the left mouse key to verify the modification.

The modified item will appear on the Project List.

Changing the value of an assigned Occupancy live load on the list will automatically change the assigned value.

5. If Live Load Reductions are to be used, move the mouse pointer to the Live Load Reduction box and press the left mouse key to place an X in the box.

Live load reductions will automatically be applied during the analysis, if the required criteria for live load reductions is met.

Once the Occupancy Load List is complete:

1. Move the mouse pointer to the appropriate action box at the bottom of the dialog window.

2. Press the left mouse key once to activate the command.
The Action Box options are:

**LLR GUIDELINES**
Pop-up windows provide building code criteria for determining if live load reductions apply. Select the OK box to remove the window from the screen.

**ADD**
Permits you to ADD a new occupancy type and load to the Project List. Moving the mouse pointer to the 'ADD' box and pressing the left mouse key will display the list of Occupancy types dialog window. Use procedures listed above to select an occupancy load from the list.

**ASSIGN**
Permits you to ASSIGN the occupancy load value to a surface on the model.
1. Move the mouse pointer to the desired load name on the project list.
2. Press the left mouse key to highlight the selection.
3. Select Assign All Floors if the occupancy load is to be assigned to all the floor planes.
4. Move the mouse pointer to the ASSIGN block.
5. Press the left mouse key.

The graphic cursor will appear on the modeling screen. The Tributary Load Dialog Window will appear to aid you in locating the Occupancy Load.

<table>
<thead>
<tr>
<th>Tributary Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dist. from lower-left corner:</td>
</tr>
<tr>
<td>Horizontal: 20'0&quot; ft</td>
</tr>
<tr>
<td>Vertical: 40'0&quot; ft</td>
</tr>
<tr>
<td>Horizontal Length: 20'0&quot; ft</td>
</tr>
<tr>
<td>Vertical Length: 20'0&quot; ft</td>
</tr>
<tr>
<td>Tributary Area: 400.00 sqft</td>
</tr>
</tbody>
</table>

6. Move the graphic cursor to the first corner of the area load.
Refer to the values in the dialog window to aid in the placement of the area load.

You can press the [F2] function key to activate the keyboard entry mode. An Area Coordinates dialog window will appear. Enter the Base Point coordinates and the Point 2 coordinates or Length dimensions of the load area. Select OK to save and display the entry.

At any time you may double click the right mouse key to exit the Area Load Assign sequence.

7. Press the left mouse key.
8. Move the graphic cursor to the diagonally opposite corner of the area load.
9. Press the left mouse key.
The assigned load area will be shaded and the load values will be printed on the screen. The Area Load Dialog window will reappear.

**STOP**

Moving the mouse pointer to the STOP box and pressing the left mouse key returns you to the main CASM screen.

The CASM program will calculate the minimum live load for roof structural members based on the roof slope and the defined tributary area of the load supported by the member. The calculations and value is automatically printed to an output file. Minimum Roof Live Loads can be generated using either TM 5-809-1 1986 or the new TM 5-809-1 1992 which is the ASCE 7-88.

Minimum roof live loads are automatically calculated during an analysis if the load combination includes minimum roof live loads.

Select the MIN ROOF (LL) from the LOADS menu or Tool Palette.

In order to calculate the Minimum Roof Live Load you must have a horizontal or inclined structural plane view. A preliminary structural framing layout helps to define the tributary area.

The Minimum Roof (LL) dialog window appears.

For inclined roofs, when only one side is selected and you are checking members with spans that include the adjacent inclined plane, select the Add Opposite Side of Roof check box to include the correct tributary area for the Minimum Roof load calculation.

To change the output file name:

1. Move the mouse pointer to the Output File name box.
2. Press and hold the left mouse key while dragging the pointer over the current file name. Release the key when the name is highlighted.
3. Type in a new file name. Use the backspace key to make corrections.

You may use the current file name for output or type in a new file name. Roofout.txt is the default output file. When entering a new output file name, the file name must be eight characters or less. The extension .TXT is automatically added to the new file name.
The CASM program will check for another file with the same name. If the program finds another file with the same name, a dialog window appears to confirm if you desire to replace the existing file which has the same name.

**When the Minimum Roof (LL) file name has been verified:**

1. Move the mouse pointer to the 'OK' box.
2. Press the left mouse key once and release.

   The file name dialog window will disappear and a Tributary Area Dialog Window will appear. The mouse pointer will change to a graphic cursor.
3. Move the graphic cursor to the first corner of the tributary area for the structural member that you want to check.

   Refer to the values in the dialog window to aid in the placement of the area load.
4. Press the left mouse key.

   At any time you may double click the right mouse key to exit the Minimum Roof Live Load calculation sequence.

5. Move the graphic cursor to the diagonally opposite corner of the tributary area.
6. Press the left mouse key.

   Minimum Roof Live Load values will be calculated based on the defined tributary area and slope. The output data will automatically be placed in the designated output file.

   The Minimum Roof Live Load area will be shaded and the load values will be printed on the screen. The Minimum Roof Live Load File Name window will reappear.

**When you have finished calculating Minimum Roof Live Loads:**

7. Select CANCEL with the mouse pointer and press the left mouse key to terminate the Minimum Roof Live Load Command.

You can access the Minimum Roof Live Load file with the Windows NOTEPAD program. To access NOTEPAD you can use the Print Data command on the CASM File pull-down menu.

**To access NotePad:**

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.

   The File pull-down menu will be displayed.
3. Place the mouse pointer on the Print Data command.
4. Press the left mouse key.

   The Print Data dialog window will be displayed.
5. Place the mouse pointer on the check box next to Min Roof Load.
6. Press the left mouse key.
The check box will be checked. Deselect all other selections.

7. Select the Execute Notepad check box.
8. Select OK with the mouse pointer and press the left mouse key.

The Notepad program will be loaded into memory on top of the CASM window with the selected file.

You may review the output data and exit NOTEPAD using the CLOSE command on the CONTROL pull-down menu box or Exit from the NOTEPAD File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the NOTEPAD program.

- If you make editing changes or entries to the output file while in NOTEPAD, you must use the Save or Save As commands in the NOTEPAD File pull-down menu to save them in the output file.

- When you exit the NOTEPAD program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file.

- You may also print a copy of the output file in CASM by selecting the Print Data command from the File pull-down menu, selecting the Min Roof LL option, and selecting the Print to Printer option.

The dialog window that appears when the SNOW LOAD is selected contains input boxes for snow load building code values such as ground snow load, importance factor, exposure, and roof types. If the CRITERIA snow values have been entered prior to selecting SNOW LOAD, the SNOW LOAD dialog window will initially contain the CRITERIA snow values. The values may be verified or modified as desired. Once all the snow data has been entered and confirmed, the program will calculate the roof snow load, including unbalanced, sliding, and drifted snow loads for the model and provide you with a formatted list of calculations and values in an output file (snowout.txt is the default file). The Snow Loads can be generated using either TM 5-809-1 1986 or the new TM 5-809-1 1992 which is the ASCE 7-88.

After the snow loads for the model have been calculated, the modeling screen changes to a SECTION display. You need to position the horizontal line on the building plan at the top of the screen in order to select the section you desire. You may review alternate sections and snow loads by pressing the left mouse key. Double click the right mouse key to select the desired section. When the section is displayed, the snow load values for balanced, unbalanced, drifting, and sliding snow are displayed on the screen.

Select the SNOW command from the LOADS pull-down menu or Tool Palette.

The SNOW LOAD dialog window will appear. The ground snow value will be highlighted. Verify the displayed values and selections which were entered in the CRITERIA dialog window or input the values directly to the boxes provided.
Use the following sequence to change or enter a SNOW LOAD value or selection.

To enter a new ground snow value:

If the value is already highlighted, type in the appropriate entry. If the value is not highlighted:

1. Move the mouse pointer to the appropriate input box.
2. Press and hold the left mouse key while dragging the pointer over the Ground Snow Value. Release the key and type in a new value. Use the backspace key to make corrections.

To enter a new Importance, Exposure factor, or Thermal Factor:

1. Move the mouse pointer to the appropriate data window button.
2. Press the left mouse key once and release.

A dialog window will appear with code values and descriptions.

To transfer the selection to the SNOWLOAD dialog window:

1. Move the mouse pointer to the "OK" box at the bottom of the window.
2. Press the left mouse key once to transfer the selection.
The selected value will appear in the SNOW LOAD dialog window.

To change the 'Roof Slippery' check box:
1. Move the mouse pointer to the appropriate input box.
2. Press the left mouse key once and release.

To select the condition noted, press the mouse key until there is an 'X' in the box. An empty box indicates the condition is not selected (i.e., no 'X' in the Roof Slippery box means the roof is NOT slippery).

To calculate snow loads for a portion of the model:
1. Move the mouse pointer to the appropriate input box.
2. Press the left mouse key once and release.
3. Select the opposite corner.

The selected area is highlighted and the Snow Load dialog window reappears to verify snow load data. Select OK to calculate the snow load for the selected area.

To calculate the snow load and print the load values to an output file:

You may use the current file name for output or enter a new file name. Since the output file is generated quickly, you may want to use the file default name to minimize the number of files stored on your computer.

1. Move the mouse pointer to the data box for the output file.
2. Press and hold down the left mouse key and drag the pointer over the current name. Release the mouse key when the name is highlighted.
3. Type in a file name for the output values.

The file name must be eight characters or less. The extension .TXT is automatically added to the file name.

When all snow load data have been entered and verified:
1. Move the mouse pointer to the 'OK' box.
2. Press the left mouse key once and release.

The CASM program will check for another file with the same name. If the program finds another file with the same name, a dialog window appears to confirm if you desire to replace the existing file which has the same name.

Snow load values will be calculated based on the selections and data displayed in the Snow Load dialog boxes. The output data will automatically be placed in the designated output file.

After the snow loads for the model have been calculated, the modeling screen changes to a SECTION display. You need to position the horizontal line on the building plan at the top of the screen in order to select the section you desire.
To change the section:

1. Move the mouse toward/away from you.
2. Press the left mouse key to review alternate building sections and snow loads.
3. Double click the right mouse key to select the desired section.

When the section is displayed, the snow load values for balanced, unbalanced, drifting, and sliding snow are displayed on the screen. You may use the Print Screen command on the Files Menu to copy the section and snow loads displayed on the screen to the printer or a file.

You may use the Pan, Zoom Window, and Distance tools from the Side Tool Palette to vary the section location and size on the screen. You may also view the Snow Load in 3-D Perspective. Verify that the Snow Load is turned on in the View menu Show Loads command.

If a N-S section is shown, you may view snow loads in an E-W section by (1) selecting the Perspective (3D) view of the model from the View menu; (2) Rotate the model 90 degrees; then (3) select Section from the View menu.

You can access the Snow Load file with the Windows NOTEPAD program. To access NOTEPAD you need to use the Print Data command on the CASM File pull-down menu.

To access Notepad:

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
   The File pull-down menu will be displayed.
3. Place the mouse pointer on the Print Data command.
4. Press the left mouse key.
The Print Data dialog window will be displayed.

5. Place the mouse pointer on the check box next to Snow Load.

6. Press the left mouse key.

The check box will be checked. Deselect all other selections.

7. Select the Execute Notepad check box.

8. Select OK with the mouse pointer and press the left mouse key.

The Notepad program will be loaded into memory on top of the CASM window.

---

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>Search</th>
<th>Help</th>
</tr>
</thead>
</table>

-------------

Cable/Hip Roof Snow Load Design
-------------

Flat Roof Snow Load (PF)
PF = 0.7*Ce*Ce*Ce*Pg

Snow Exposure Category: C
Ce = 1.0

Heated structure.
Ce = 1.0

Importance Category: I
I = 1.0

Pg = 30.0 psf

PF = 21.00 psf

Roof slope: 9.00 in 12

theta = 34 deg

Since theta > 15 deg, min. snow load does not apply.

---

You may review the output data and exit NOTEPAD using the CLOSE command on the SYSTEM pull-down menu box or Exit from the NOTEPAD File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the NOTEPAD program.

>>> If you make editing changes or entries to the output file while in NOTEPAD, you must use the Save or Save As commands in the NOTEPAD File pull-down menu to save them in the output file.

>>> When you exit the NOTEPAD program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file.
The dialog window that appears when the WIND LOAD is selected contains text boxes for wind load building code values such as basic wind speed, importance factor, exposure, and opening coefficients. Option buttons are provided for main wind force resisting systems, components & cladding, and open roofs. If the CRITERIA wind values have been entered prior to selecting WIND LOAD, the WIND LOAD dialog window will initially contain the CRITERIA wind values. The values may be verified or modified as desired. Once all the wind data have been entered and confirmed, the program will calculate the wind load based on the model geometry and provide you with a formatted list of calculations and values (windout.txt is the default output file). The wind load can be generated using either TM 5-809-1 1986 or the new TM 5-809-1 1992 which is the ASCE 7-88.

After main wind force resistance system loads for the model have been calculated, the modeling screen changes to a SECTION display. You need to position the horizontal line on the building plan at the top of the screen in order to select the section you desire. You may review alternate sections and snow loads by pressing the left mouse key. Double click the right mouse key to select the desired section. When the section is displayed, the wind load values for walls and roof are displayed on the screen.

Select the WIND LOAD from the LOADS pull-down menu or Tool Palette.

The WIND LOAD dialog window will appear. The Basic Wind Speed Value is highlighted. Verify the displayed values and selections if entered in the CRITERIA dialog window or input the values directly to the spaces provided.

Use the following sequence to change or enter a WIND LOAD value or selection.

To enter a new Basic Wind Speed value:
If the value is already highlighted, type in the appropriate entry. If the value is not highlighted:
1. Move the mouse pointer to the appropriate input box.
2. Press and hold the left mouse key and drag the pointer over the current entry. Release the mouse key when the entry is highlighted.
3. Type in a new value. Use the backspace key to make corrections.

To select coastal location and distance to oceanline, if the site is located near an ocean coast:
1. Move the mouse pointer to the coastal check box.
2. Press the left mouse key.
   An "X" will appear in the box and the distance to oceanline value will be changed to zero.
3. Move the mouse pointer to the Distance to Oceanline text box.
4. Press the left mouse key.
   The vertical cursor will appear.
5. Enter the appropriate value.

To enter a new Importance Factor or Exposure Category:
1. Move the mouse pointer to the appropriate text data window button.
2. Press the left mouse key once and release.
   A dialog window will appear with code values and descriptions.

<table>
<thead>
<tr>
<th>Wind Exposure Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>O Exposure A:</td>
<td>Large city centers with at least 50% of the buildings having a height in excess of 70 ft.</td>
</tr>
<tr>
<td>O Exposure B:</td>
<td>Urban and suburban areas, wooded areas or other terrain with numerous closely spaced obstructions having the size of single family dwellings or larger.</td>
</tr>
<tr>
<td>O Exposure C:</td>
<td>Open terrain with scattered obstructions having heights generally less than 30 ft.</td>
</tr>
<tr>
<td>O Exposure D:</td>
<td>Flat, unobstructed coastal areas directly exposed to wind flowing over large bodies of water.</td>
</tr>
</tbody>
</table>

3. Move the mouse pointer to the option button in front of the desired selection.
4. Press the left mouse key once and release.
   A solid dot will appear in the option button to indicate your selection.

To transfer the selection to the WIND LOAD dialog window:
1. Move the mouse pointer to the 'OK' box at the bottom of the window.
2. Press the left mouse key once to transfer the selection.
   The selected value will appear in the WIND LOAD dialog window.
% Opening Coefficients:

The internal pressure coefficients can be selected or computed automatically.

You must draw all the openings in the walls if the coefficient is computed.

1. Move the mouse pointer to the % Opening Coef data window button.
2. Press the left mouse key.

An Internal Pressure Coefficient dialog window will appear with several options for selecting the desired pressure coefficients. If the percentage of openings is known, select one of the default values. If the percentage of openings is not known, then you may have CASM compute the percentage of openings and select the appropriate coefficients.

<table>
<thead>
<tr>
<th>Internal Pressure Coefficient</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="LOAS.png" alt="Image" /></td>
</tr>
</tbody>
</table>

NOTE: If Computing percentage of openings, all exterior wall openings must already be drawn.

To compute qz constant:

1. Select the Compute qz constant option with the mouse.
2. Enter the elevation above sea level in the dialog box.

The qz value will be recalculated based on the elevation shown in the dialog box.

Select type of system:

Select Main Force Resisting, Components & Cladding, or Open Structure.

For Main Force Resisting System: Wind Loads are calculated. Then a building section and Wind Load values are displayed for the main force resisting system based on the shape of the model.

For Irregular building forms, the selection of Assumptions allows you to choose a plan ratio and a height ratio for appropriate consideration of B/L and h/L ratios. An option to use the eave height, rather than the roof mean height, for slopes less than 10 degrees, can also be selected.

For Components & Cladding: To determine wind loads on Components and Cladding, you must first define a structural grid and layout structural mem-
bers in the wall. The Surface/Linear menu in Draw Structure contains surface and linear structural elements which can be placed on horizontal, inclined, and vertical planes.

When doing wind loads for Components and Cladding:

1. You verify the wind load data, select the Components and Cladding option button, then select OK.

   The "a" distance (width of pressure coefficient zone) is calculated from each plane intersection. When finished, the "a" distances are displayed by dashed red lines. Handles will appear on the visible planes.

2. Select the plane which contains the structural member to be checked.

   A 2-D elevation of the plane containing the member and a Tributary Area dialog window will appear.

3. Create the tributary area for the member by selecting opposite corners of the area with the mouse.

   A Wind Components and Cladding dialog window will appear.

4. Enter the component or cladding name and select OK.

   A blue hatched rectangle will denote the tributary area.

5. Double click the right mouse key to end the creation of tributary areas.

   Wind load calculations will be performed for the component. A 3-D view of the wind load on the component will appear when calculations are complete and an output file containing the calculations is created.

To view the code prescribed zonal areas for Components and Cladding:

1. Select Perspective (3D) from the View menu.
2. Select Show Loads from the View menu.
3. Turn on the Zone Areas by selecting the check box.
4. Select OK.

   Zone areas with their circled number will be displayed on the 3D model. The members shown on the model and used in the output correspond to the specific zones established in TM 5-809-1.

For Open Roof: To determine wind loads on an Open Roof structure, you must first define the geometry of the open roof.

   You must be in a Perspective (3D) view when doing wind load on an open roof.
You must use the horizontal plane shape when creating the open roof. Columns or supports are not required for the wind loading.

If you are doing a monoslope open roof or an open gable roof, you must create vertical edges on the upper edge or CASM will apply loads to the sloped edge of the plane. You may use the cube shape, drag the edge of the horizontal plane and slice the horizontal plane with the cube plane to get a vertical edge.

1. Verify the wind load data, select the Open Roof option button, then select OK.
   CASM will search for open roof planes. Handles will appear on the visible open roof planes found.
2. Select the plane to receive wind loads with the mouse.
   Wind calculations are performed. A 3D depiction of the wind load will appear on the model when calculations are completed.

For Open Arched Roofs, analysis will been performed for 90 and 60-degree wind angles. Use Show Loads from the View menu to display each load case.

To calculate the wind load and print the load values to an output file:
1. You may use the current file name for output or enter a new file name. To change the name:
   a. Move the mouse pointer to the data box for the output file.
   b. Press and hold down the left mouse key and drag the pointer over the current name. Release the mouse key when the name is highlighted.
   c. Type in a new file name for output values.
   The file name must be eight characters or less. The extension .TXT will be added to the new file name.

When all wind load data have been entered and verified:
1. Move the mouse pointer to the 'OK' box.
2. Press the left mouse key once and release.

The CASM program will check for another file with the same name. If the program finds another file with the same name, a dialog window appears to confirm if you desire to replace (add changes to) the existing file which has the same name.

Wind load values will be calculated based on the selections and data displayed in the dialog boxes. The output data will automatically be placed in the designated output file.

After the main wind force resisting loads for the model have been calculated, the modeling screen changes to a SECTION display. You need to position the horizontal line on the building plan at the top of the screen in order to select the section you desire.
Pressures are shown in a cyan (light blue) color and suction are shown in a magenta color.

The wind direction is always shown left to right in the section view.

To change the section:
1. Move the mouse toward/away from you.
2. Press the left mouse key to review alternate building sections and wind loads.
3. Double click the right mouse key to select the desired section.

When the section is displayed, the wind load values are displayed on the screen. You may use the Print Screen command on the File Menu to copy the section and wind loads displayed on the screen to the printer or a file.

You may use the Pan, Zoom Window, and Distance tools from the Side Tool Palette to vary the section location and size on the screen. You may also view the Wind Load in 3-D Perspective. Verify that the Wind Load is turned on in the View menu Show Loads command.

To change the wind direction:
1. Select the Perspective 3-D display option from the View menu.
2. Rotate the model 90° using the view direction tool on the Side Tool Palette.
3. Select the Section display option from the Viewpoint Options menu.
4. Select the desired section by double clicking the right mouse key.

The wind direction will be 90° to the previous selected section.

To display wind loads with consideration of internal pressures:
1. Select Show Loads from the View menu.
2. Select either GCpi Negative or GCpi Positive.
3. Select OK.

The selected wind loads will be displayed.

To review B & L assumptions used in wind calculations:
1. Select Perspective (3D) from the View menu.
2. Select B & L Assumptions from the Show Loads dialog window from the View menu.

3. Select OK.

Red B & L rectangles for wind in all four directions will appear. The wind direction is shown by a triangle pointing in the direction of the wind. The numbered labels on the rectangles coincide with the numbered titles on the output calculations. To show all four rectangles, you may need to zoom out.

You can access the Wind Load output file with the Windows NOTEPAD program. To access NOTEPAD you will need to use the Print Data command on the File pull-down menu.

You may combine all wind output files into one file and open Notepad by using the Print Data command from the File pull-down menu.

To access Notepad:
1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
   The File pull-down menu will be displayed.
3. Place the mouse pointer on the Print Data command.
4. Press the left mouse key.
   The Print Data dialog window will be displayed.
5. Place the mouse pointer on the check box next to Wind Load.
6. Press the left mouse key.
   The check box will be checked. Deselect all other selections.
7. Select the Execute Notepad check box.
8. Select OK with the mouse pointer and press the left mouse key.
   The Notepad program will be loaded into memory on top of the CASM window.

You may review the output data and exit NOTEPAD using the CLOSE command on the Control pull-down menu box or Exit from the NOTEPAD File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the NOTEPAD program.
Levels on the windward side are designated by numbers starting with 1 at elevation \( z = 0.0 \) feet. Levels 2+ represent floor, eave, or ridge heights. Levels 1-2, 2-3, etc. represent mid-height levels or mean roof elevation for sloped roofs.

If you make editing changes or entries to the output file while in NOTEPAD, you must use the Save or Save As commands in the NOTEPAD File pull-down menu to save them in the output file.

When you exit the NOTEPAD program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file.

The dialog window that appears when the Seismic Load is selected contains input boxes for lateral load resistance types, seismic zone, importance factor, and soil factor. Pop-up dialog windows provide a description of the options and permit you to choose the most appropriate option for the model. If the Criteria seismic values have been entered prior to selecting Seismic Load, the Seismic Load dialog window will initially contain the Criteria seismic values. The values may be verified or modified as desired. Once all the Seismic data has been entered and confirmed, the program will calculate the seismic lateral forces based on the equivalent static force method using the model geometry and applied dead loads. The equivalent static force method used is presented in the TM 5-809-10 Technical Manual Seismic Design for Buildings, 1992. This methodology is an extraction from the Structural Engineer's Association of California (SEAOC), Recommended Lateral Force Requirements and Commentary, 1990 edition. Symbols, seismic vocabulary, and equations used by CASM are taken from these documents. You should be familiar with these documents prior to using CASM to generate seismic lateral forces.

The equivalent static force procedure applies if approximate plan and elevation symmetry exists, not only of the building itself, but also, its lateral resistance elements, arrangements of openings, and distribution of mass. Specific SEAOC limitations on height, building period, soil profile, and plan and vertical irregularities may require a dynamic analysis procedure which is beyond the current capabilities of CASM. The engineer should carefully assess all of these issues prior to using CASM.

Prior to calculating seismic lateral forces you must complete the following steps.

- Draw the complete building model.
- Draw the complete building structural system including lateral resistance systems in the N/S and E/W directions.
- Assign loads including all dead loads, snow loads when the ground snow load exceeds 30 psf, and occupancy load for a storage building or warehouse.
- Select the correct load combination to include appropriate consideration of the loads listed in the statement above.

The output data is automatically printed to an output file. You may view the file with Notepad or print the file with the Print Data command from the File pull-down menu.
Select the SEISMIC LOAD from the LOADS pull-down menu or Tool Palette.

Before calculating seismic lateral forces, you must assign dead loads to all levels of your model. If you do not include beam, girder, and column loads as an estimated area load, then you will need to include structural framing of main beam and girder lines and columns.

Live loads for storage and warehouse occupancies must be added if 25% of the floor live load is to be used in the seismic load calculation.

Snow loads need to be included if the design snow load if the design load exceeds 30 PSF. Select the code specified Load Combination before selecting the Seismic Load command.

It is necessary to draw the structural walls to be considered as shear walls for lateral resistance under Draw Structure. This should not be confused with planes drawn under Draw Model as walls. Openings in these shear walls may be included at the engineer's discretion.

The structural model must include all the lateral resistance elements in the N-S and E-W directions.

When a rigid diaphragm is selected, lateral loads will be distributed to the vertical resisting planes according to the vertical resisting element stiffness. When a flexible diaphragm is selected, lateral loads will be distributed to the vertical resisting planes according to tributary width or based on a continuous beam model at the user's choice.

The Seismic Load dialog window will appear. The N-S Rw text box is highlighted. Verify the displayed values if entered in the Criteria dialog window or input the values directly to the spaces provided.

Use the following sequence to change or enter text values in the Seismic Load text boxes:

To enter a lateral load resistance system and zone, importance, and soil factors:
1. Move the mouse pointer to the desired text data window button.
2. Press the left mouse key.
### Structural System 81

**A. Bearing Wall System**

<table>
<thead>
<tr>
<th>Row</th>
<th>H</th>
<th>H 82</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Light Framed Walls With Shear Panes</td>
<td>8</td>
<td>65</td>
</tr>
<tr>
<td>a. Plywood Walls for Structures 3 stories or Less</td>
<td>6</td>
<td>65</td>
</tr>
<tr>
<td>b. All Other Light Framed Walls</td>
<td>6</td>
<td>65</td>
</tr>
<tr>
<td>2. Shear Walls</td>
<td>6</td>
<td>160</td>
</tr>
<tr>
<td>a. Concrete</td>
<td>6</td>
<td>160</td>
</tr>
<tr>
<td>b. Masonry</td>
<td>6</td>
<td>160</td>
</tr>
<tr>
<td>3. Light Steel Framed Bearing Walls With Tension-Only Bracing</td>
<td>4</td>
<td>65</td>
</tr>
<tr>
<td>4. Braced Frames Where Bracing Carries Gravity Loads</td>
<td>4</td>
<td>65</td>
</tr>
<tr>
<td>a. Steel</td>
<td>4</td>
<td>65</td>
</tr>
<tr>
<td>b. Concrete #3</td>
<td>4</td>
<td>65</td>
</tr>
<tr>
<td>c. Heavy Timber</td>
<td>4</td>
<td>65</td>
</tr>
</tbody>
</table>

**Notes:**

- **B1** Basic Structural Systems are defined in Section 1.0.6.
- **B2** H = Height Limit applicable to Seismic Zones 3 and 4. See Section 1.0.7 for exceptions.
- **B3** Prohibited in Seismic Zones 3 and 4.

#### Zone Factor

<table>
<thead>
<tr>
<th>Zone</th>
<th>1</th>
<th>2A</th>
<th>2B</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
</table>

The zone shall be determined from the seismic zone map in Figure 3-1.

#### Seismic Importance Factor

- I. Essential Facilities
- II. Hazardous Facilities
- III. Special Occupancy Structure
- IV. Standard Occupancy Structure

#### Site Condition

- S1: A soil profile with either:
  - (a) A rock like material characterized by a shear wave velocity greater than 2,500 feet per second or by other suitable means of classification, or
  - (b) stiff or dense soil condition where the soil depth is less than 200 feet.

- S2: A soil profile with dense or stiff soil conditions, where the soil depth exceeds 200 feet.

- S3: A soil profile 70 feet or more in depth and containing more than 20 feet of soft to medium stiff clay but not more than 40 feet of soft clay.

- S4: A soil profile, characterized by a shear wave velocity less than 500 feet per second, containing more than 40 feet of soft clay.

**Note:** The site factor shall be established from properly substantiated geotechnical data. In locations where the soil properties are not known in sufficient detail to determine the soil profile type, soil profile S3 shall be used. Soil profile S4 need not be assumed unless the Building Official determines that soil profile S4 may be present at the site, or in the event that soil profile S4 is established by geotechnical data.
An option list of values with descriptive information will appear. To view the descriptive information for the Seismic Importance Factor, you need to select an option, then select the Guidelines button. Specific guidelines for the selected importance factor will be displayed.

To select an item from the dialog window:
1. Place the mouse pointer on the desired item or on the adjacent option button.
2. Press the left mouse key.
3. Select OK to transfer the selection to the Seismic Loads dialog window.

To view the base shear spectrum and the design base shear coefficient spectrum based on your selected values:
1. Select the Spectral Plots option.

A Spectral Plots dialog window will appear. You may view alternative spectral plots based on selected Ct, ZC, and hn values.

- Select ZC from the drop down list button to view the Base Shear Spectrum.
- Select ZC/Rw-EW from the drop down list button to view the Design Base Shear Coefficient Spectrum.

If the Rw is different in both the N-S and E-W directions, separate ZC/Rw directions will appear in the drop down list button. Select the direction under consideration to view the correct plot.

- You may select Ct to have the building period (T) calculated by equation or input the known building period (T).

Both spectrums can be printed using the Print Screen command.

2. Select OK to return to the Seismic Load dialog window.

To confirm the values and calculate the seismic load:
1. Verify the output file name.
2. Move the mouse pointer to the OK button.
3. Press the left mouse key.

The Seismic Load dialog window will disappear and a series of dialog windows will appear. If an output file with the same name exists, you will be prompted to replace it.

Reminder to confirm that all loads have been applied and the correct load combination selected for the seismic load calculation. Select YES to continue or NO to exit without calculating seismic lateral forces.

![Seismic Load dialog window]

Have ALL the loads been applied to the structure? Is D + E the correct load combination? The diaphragm types at any level are mixed.

Yes  No

Plan Structural Irregularities. Lists plan irregularity types and definition. Select OK to continue or Cancel to exit the seismic load calculation.

<table>
<thead>
<tr>
<th>Irregularity Type and Definition</th>
<th>Reference Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>A. Torsional Irregularity, to be considered when diaphragms are not flexible</td>
<td>1.E.5d, 1.H.1c, 1.H.2[4]</td>
</tr>
<tr>
<td>E. Nonparallel Systems</td>
<td>1.H.1c</td>
</tr>
</tbody>
</table>

Vertical Structural Irregularities. Lists vertical irregularity types and definition. Select OK to continue or Cancel to exit the seismic load calculation.

If your model exhibits any of the Vertical or Horizontal Irregularities, then you should discontinue the CASM seismic evaluation of your model. A dynamic analysis will be required which is beyond the current capabilities of CASM.
**A. Stiffness Irregularity - Soft Story**
A soft story is one in which the lateral stiffness is less than 70 percent of that in the story above or less than 40 percent of the combined stiffness of the three stories above.

**B. Weight (mass) Irregularity**
Mass irregularity shall be considered to exist where the effective mass of any story is more than 150 percent of the effective mass of an adjacent story. A roof which is lighter than the floor below need not be considered a mass irregularity.

**C. Vertical Geometric Irregularity**
Vertical geometric irregularity shall be considered to exist where the horizontal dimension of the lateral force resisting system in any story is more than 130 percent of that in an adjacent story. One-story penthouses need not be considered.

**D. In-Plane Discontinuity in Vertical Lateral Force Resisting Element**
An in-plane offset of the lateral load resisting elements greater than the length of those elements.

**E. Discontinuity in Capacity - Weak Story**
A weak story is one in which the story strength is less than 80 percent of that in the story above. The story strength is the total strength of all seismic resisting elements sharing the story shear for the direction under consideration.

---

**Ct factor** Options for Ct factors are listed. Select the appropriate Ct factor for your building type. You may select a Ct value to have the period calculated or enter a known period (T) to override calculation by the code equation. Select OK to continue or Cancel to exit the seismic load calculation.

- **Ct = 0.035** for steel moment resisting frames
- **Ct = 0.030** for reinforced concrete moment resisting frames and eccentric braced steel frames
- **Ct = 0.020** for all other structures

Alternatively, the value of Ct for structures with concrete or masonry shear walls may be taken as 0.1/seg(Ad).

Period T Based On Ct^2/hu^3/4: 0.189 sec hu 200 ft

User Selected Period T: 0.000 sec

---

The self weight of beams and columns can be included in the building dead weight by either of the following methods: (1) smeared into the area loads, or (2) entered separately in the seismic self weight dialog windows.

**Beam Self Weight.** Permits you to enter an estimated self weight value for all main beams and girders along grid lines in your model. It does not include widely spaced beams (i.e. third point beams). Enter an approximate PLF value. Select OK to continue or Cancel to exit.
You must have drawn main beams and girders on all levels in order for the value to be applied.

Column Self Weight. Permits you to enter an estimated self weight value for all columns in your model. Enter an approximate PLF value. Select OK to continue or Cancel to exit.

You must have drawn columns on all levels in order for the value to be applied.

The beam and column self weights are automatically multiplied by the lengths.

Center of Mass. Calculates the center of mass of your model based on the dead loads. Permits you to select an output file name for the output text. Select OK to continue or Cancel to exit.

The center of mass and seismic lateral forces are calculated and the calculations are saved in output files.

You can access the Seismic Load output file with the Windows NOTEPAD program. To access NOTEPAD you will need to use the Print Data command on the CASM File pull-down menu.

You may combine all seismic output files into one file and open Notepad by using the Print Data command from the File pull-down menu.

To access Notepad:

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
   The File pull-down menu will be displayed.
3. Place the mouse pointer on the Print Data command.
4. Press the left mouse key.
   The Print Data dialog window will be displayed.
5. Place the mouse pointer on the check box next to Seismic Loads.
6. Press the left mouse key.
   The check box will be checked. Deselect all other selections.
7. Select the Execute Notepad check box.
8. Select OK with the mouse pointer and press the left mouse key.
   The Notepad program will be loaded into memory on top of the CASM window.
9. Select the Open command from the File pull-down menu.

You may review the output data and exit NOTEPAD using the CLOSE command on the Control pull-down menu box or Exit from the NOTEPAD File pull-down menu. Because the output file was automatically saved on disk, there is no need to save it when you exit the NOTEPAD program.

If you make editing changes or entries to the output file while in NOTEPAD, you must use the Save or Save As commands in the NOTEPAD File pull-down menu to save them in the output file.

When you exit the NOTEPAD program, a dialog window will appear to remind you to save your work if you have made any changes or entries to the output file.
MAT' L MENU

The Material Menu permits you to define the structural material for your proposed framing system from four different materials. Only one material can be selected. The selection of CASM Excel spreadsheets will be based on the material and element selected. The menu selections for the Surface/Linear and Column/Wall menus are based on the Material selected. The four material selections are:

- It is necessary to select the material before any other element parameter since the element type and menus are material dependent.

Selects concrete as the structural material for the members that are to be analyzed and sized.

Selects masonry as the structural material for the wall or column that is to be analyzed. Preliminary sizing is not implemented.

Selects steel as the structural material for the members that are to be analyzed and sized.

Selects wood as the structural material for the members that are to be analyzed. Preliminary sizing is not implemented.

Select one of the Mat'l option Tool Icons or menu commands from the Mat'l Menu:

The Mat'l Menu will disappear. You may verify that the desired Mat'l option is active by checking the Mat'l Menu for a check mark in front of the desired Mat'l option or look for a highlighted tool icon. To change the Mat'l option, select another Mat'l option. The check mark will change on the Mat'l Menu. The highlighted tool icon will change.
## SURFACE/LINEAR MENU

The Surface/Linear Menu permits you to select a structural member from your proposed framing system. Pop-up dialog windows are displayed with structural design data based on the material and structural element selected. The Material selection determines what structural members are available based on the type of system you have defined in Draw Structure.

<table>
<thead>
<tr>
<th>SURFACE 1-WAY</th>
<th>GRIDS 2-WAY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form Deck</td>
<td>Rolled Sections</td>
</tr>
<tr>
<td>Roof Deck</td>
<td>Trussed</td>
</tr>
<tr>
<td>Floor Deck</td>
<td>Space</td>
</tr>
<tr>
<td>NARROWLY SPACED</td>
<td>Truss - Custom</td>
</tr>
<tr>
<td>Open-Web Joists - K</td>
<td>Arch/Vault</td>
</tr>
<tr>
<td>Open-Web Joists - LH</td>
<td>Folded Plate</td>
</tr>
<tr>
<td>Open-Web Joists - DLH</td>
<td>Dome</td>
</tr>
<tr>
<td>Light Gauge 'C' Channels</td>
<td></td>
</tr>
</tbody>
</table>

### Structure Members

<table>
<thead>
<tr>
<th>WIDELY SPACED</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Rolled Sections</td>
<td>Truss Girders - SJ</td>
</tr>
<tr>
<td>Composite Beam/Slab</td>
<td>Truss Girders - SJI</td>
</tr>
<tr>
<td>Plate Girders</td>
<td>'C' Channels</td>
</tr>
</tbody>
</table>

You must be in a 2D structural plane view in order to select structural members.

**Select a structural member from the menu:**

All of the corresponding structural elements on the structural plane which were drawn and defined by Draw Structure commands are marked by a colored square (handle) at their midpoint (i.e. if Widely Spaced Rolled Sections is selected, all Widely Spaced members will be marked.

1. Select a marked element with the graphic cursor by placing the cursor on the handle.
2. Press the left mouse key.

The selected element will be highlighted by a yellow dashed line. Two dialog windows will appear. The dialog windows for Linear Elements (Narrowly spaced, Widely spaced, and Truss - Custom) are shown below.

The Linear Elements dialog window, lists dimensional information such as span, orientation, and spacing. The other dialog window lists the member type plus design data, based on the selected material, such as l/d ratios, approximate depth of member based on the span, span ranges, and typical depth ranges to aid you in selecting the appropriate member type. The Guidelines selection permits you to view/include specific design guidelines when using the member.
The dialog windows for Surface Elements (Surface 1-Way and Surface 2-Way) are shown below.

The Surface Elements dialog window, lists dimensional information such as span, orientation, and area. The other dialog window lists the member type plus design data, based on the selected material, such as L/d ratios, approximate depth of member based on the span, span ranges, and typical depth ranges to aid you in selecting the appropriate member type. The Guidelines selection permits you to view/include specific design guidelines when using the member.

You can add other guidelines information for an element type by editing the GUIDES.CRD file with the Cardfile program.
Three options are available at this point.

- You may select CANCEL to end consideration of the selected element type.
- You may select a different element type from the same type of system selections.
- You may select a different element using the Select Other Location option. (Not implemented)
- You may continue to the Preliminary analysis. Do not select Cancel if you intend to do a preliminary analysis.

If you decide to do a preliminary analysis of the member at this time:

**Before doing a preliminary analysis, you must verify/select the desired Load Combination from the Loads pull down menu. If no Load Combination has been selected, you will be reminded by a dialog window.**

1. **Select PRELIMINARY from the Design menu.**

A series of dialog windows prompting for additional information will appear. Then the member loads will be displayed for review and an analysis of the member will be performed to determine the shear, moment, deflection, and a preliminary member size for some structural members. The sequence is described in the Preliminary command.
COLUMN/WALL MENU

The Column/Wall Menu permits you to select a structural member from your proposed framing system. The Material selection determines what structural members are available based on the type of system you have defined in Draw Structure.

You must be in a 2D structural plane view in order to select a column or wall.

Select a structural member from the menu:

All of the corresponding structural elements on the structural plane which were drawn and defined by Draw Structure commands are marked by a colored square (handle) at their midpoint (i.e. if a Column Rolled Section element is selected, all column elements are marked).

1. Select a marked element with the graphic cursor by placing the cursor on the handle.
2. Press the left mouse key.

The selected element will be highlighted in yellow. Two dialog windows will appear. One window lists dimensional information such as span, orientation, and spacing. The other dialog window will list design information useful to the user.

You can add other guidelines information for an element type by editing the GUIDES.CRD file with the Cardfile program.

The dialog windows for columns are shown below.

The dialog windows for walls are shown below.
Three options are available at this point.

- You may select CANCEL to end consideration of the selected element type.
- You may select a different element type from the same type of system selections.
- You may select a different element using the Select Other Location option. (Not implemented)
- You may continue to the Preliminary analysis. Do not select Cancel if you intend to do a preliminary analysis.

If you decide to do a preliminary analysis of the member at this time:

1. Select PRELIMINARY from the Design menu.

   A series of dialog windows prompting for additional information will appear. Then the member loads will be displayed for review and an analysis of the member will be performed. Maximum axial loads due to gravity loads will be calculated and displayed. The sequence is described in the Preliminary command.
**DESIGN MENU**

The Design Menu permits you to do a PRELIMINARY analysis of a selected member in order to select a preliminary size for cost estimates and further analysis and evaluation. You can use the compare Min Roof LL and Snow load command to see which roof live load controls. You may use the Compare Wind and Seismic commands to see which load combination for lateral resistance controls. You may use the LATERAL RESISTANCE command to do an analysis of a lateral resistance system. If the members in the selected lateral resistance system have not been previously sized by using the Preliminary analysis command, all E-values and t-values for members in the lateral resistance system will be initially set at 1.0 which will result in errors in the analysis. After you have designated element sizes and properties to all the members in the model, you may do a QUANTITY TAKE-OFF which will list all members and quantities which can be used for cost estimates.

> Before using the Preliminary Design option, you must have assigned loads and assigned a Load Combination from the Loads Menu, laid out a structural framing system in Draw Structure, and selected a member from the Surface/Linear or Column/Wall menus.

> Before using the Lateral Resistance Design option, you must have assigned loads and assigned a Load Combination from the Loads Menu, laid out a structural framing system in Draw Structure for all levels, and assigned a Lateral Resistance system and defined the diaphragm as flexible or rigid. After selecting the Lateral Resistance command from the Design menu, you need to select a Lateral Resistance system.

> Before using the Quantity Take-off Design option, you must have done a preliminary analysis of members in order to select preliminary sizes. You may use the Copy and Modify Design commands in the Loads and Design Edit menu to label other members.

Currently, the Preliminary design is implemented for widely spaced members, narrowly spaced members, trusses, one-way surface, walls, and columns. The program displays the loading on the member for review. If you elect to continue, the shear, moment, deflection, and reactions on the linear or surface member is calculated and displayed on the screen. Axial loads for trusses, walls and columns are calculated and displayed on the screen. A preliminary size for the selected member can be determined from Excel spreadsheets.

Before doing the Preliminary Analysis, the following steps must be completed:

- Create a building model.
- Define a structural grid.
- Lay out a structural framing plan. You do not need to include surface or linear elements if you are doing column or wall load run-downs. Floor/roof loading on columns and walls can be determined by tributary area.
- Assign Loads (for all levels if you are doing a wall or column run-down).
- Select a Load Combination.
- Select a Structural Member using the Surface/Linear or Column/Wall menus.

**SURFACE ELEMENTS**

**The sequence for the Preliminary analysis of a Surface element is:**

1. Select Preliminary Analysis Icon or Preliminary from the Design menu.

   An Analysis dialog window appears.

   ![Analysis Window]

2. Select Analysis options.
   a. Select units (feet or inches, pounds or kips).
   b. Select the desired Load Combination for analysis.
   c. Select the Apply Live Load Reduction option, if applicable.
   d. Select the Pattern Occupancy Live Load option, if applicable.
   e. Select the Use Actual Properties option, if applicable. This selection permits you to use the design properties (E & I) of the selected member for analysis. If not used, an E and I value of 1.0 will be used for analysis.
   f. The DL= Deck + Self Weight selection is for composite construction. The Guidelines option provides you with additional information for when to use the DL= Deck + Self Weight option.
   g. Select OK to continue the analysis.

   Selection of CANCEL in any of the Preliminary Analysis dialog windows will stop the analysis process.

3. A Decking Analysis dialog window will appear. On the framing layout, the deck spans will be numbered across the bay and one edge of the bay parallel to the deck spans will be highlighted.

   a. Select appropriate options in the Decking Analysis dialog window. The dialog window permits you to designate a one foot strip of the surface element with the greatest loading by use of the Distance From Edge and Starting Span Number options.
b. Select the number of spans to be analyzed by selecting the desired option with the mouse pointer and pressing the left mouse key.

The option button will be highlighted.

c. You can select the Distance From Edge text box and enter the desired distance from highlighted edge on the screen. The default value is always located at midspan of the bay.

d. You can select the Starting Span Number of the member of spans to be analyzed. The default value is always the first deck span at one side of the bay.

e. You can select Include Superimposed Dead Load for composite decks. The Guidelines option provides information on whether to include superimposed dead load.

f. Select OK to continue the analysis.

4. If Use Actual Properties has been checked on the Analysis dialog window, a Properties dialog window will appear.

   a. Select the Add Self Weight check box if you want the self weight of the member added to the existing structure dead weight.

   b. Select the Modify button to insert or change the properties of the member.

   c. Select YES if all the properties are correct and to continue.

5. If Live Load Reductions has been checked on the Occupancy Load dialog window, the Live Load Reduction dialog window will appear.

   a. For the use of live load reductions in the analysis, provide information for the following prompts:
(1) Indicate if member is part of a roof.
(2) Indicate if member supports more than one floor.
(3) Indicate if occupancy is public assembly or is a garage.

b. Verify the file name for live load reduction calculations.

6. If Wind Load is included in the Load Combination, a Wind Load options dialog window will appear.

a. Select the wind direction that will likely create the greatest loading by selecting the appropriate option button.
b. When a wind load refers to a pressure and a suction value appearing on the same surface, it is necessary to select either Pressure or Min. Suction or Max Suction for analysis.
c. Wind load for Main Wind Force resisting elements, Components and Cladding, or Open Roof may be selected. If Wind Load for Components and Cladding is selected, you will need to select from the list of Components and Cladding loads in the list box.
d. Select Guidelines for additional information on using the Wind Load Options dialog window.
e. Select OK to save selections and continue the analysis.

7. If the Minimum Roof Live Load is included in the Load Combination, a Minimum Roof LL dialog window will appear.

a. Enter an output filename for the Min Roof LL calculation.
b. Select OK to continue the analysis.

8. An Analysis dialog window will appear with a text box for the analysis output name. The loads and connectivity of the deck will be displayed on the screen. Connectivity is automatically set so the first support is a hinge and all remaining supports are rollers.

```
<table>
<thead>
<tr>
<th>15.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
```

```
Analysis File Name: [Enter filename]

Are the loads and connectivity correct?

Generate Input File
Type: [Enter type]
File Name: [Enter filename]
```

a. Verify the analysis output file name. If you do not need the text output, you can delete the default name to speed up the analysis.
b. View and verify the loads and connectivity displayed on the screen.
c. If you want to generate an analysis input file, select the type of input file and enter the filename.
d. Select YES to continue the analysis.

9. When the analysis is complete, the shear and moment diagrams and relative deflection diagram with load and reactions displayed for the selected load combination will be displayed. A dialog window appears to permit you to change the displayed diagrams for different loads.

- If Use Actual Properties was not selected, the analysis is based on default values of $E = 1.0$ and $I = 1.0$. The displayed deflection is relative. Approximate deflection values are obtained in the spreadsheets after the $E$ and $I$ values are set.

- It is possible to obtain a hardcopy of the diagrams by selecting Print Screen from the File pull-down menu.
a. To select different loads for display, place the mouse pointer on the desired loading and press the left mouse key. The load name will be highlighted and the display will change to the diagrams for the selected load.

The deflection scale can only be adjusted in truss and lateral diagrams.

b. Select OK to continue the analysis.

10. An Excel Data dialog window will appear with an option to Execute Excel or send output data to a file. Refer to the end of this section for use of the Excel spreadsheets and the sizing of members.

**LINEAR ELEMENTS**

The sequence for the Preliminary analysis of a Linear element is:

1. Select Preliminary Analysis Icon or Preliminary from the Design menu.
   An Analysis dialog window appears.

2. Select Analysis options.
   a. Select units (feet or inches, pounds or kips).
b. Select the desired Load Combination for analysis.

c. Select the Apply Live Load Reduction option, if applicable.

d. Select the Pattern Occupancy Live Load option, if applicable.

e. Select the Use Actual Properties option, if applicable. This selection permits you to use the design properties (E & l) of the selected member for analysis. If not used, an E and l value of 1.0 will be used for analysis.

f. The DL = Deck + Self Weight selection is for composite construction. The Guidelines option provides you with additional information for when to use the DL = Deck + Self Weight option.

g. Select the Reanalyze All Adjoining Members option if you changed any part of the model since your last analysis.

h. Select OK to continue the analysis.

Selection of CANCEL in any of the Preliminary Analysis dialog windows will stop the analysis process.

3. A connectivity dialog window will appear. The left and right ends of the selected element will be highlighted on the plane.
a. Select the appropriate connectivity options for each end of member by clicking on the circles on both sides of the connectivity symbol.

Continuous spanning elements require the setting of adjacent spans to the left or right of the single span selected for analysis. Additional connectivity dialog windows will appear to select the adjacent span support conditions when you click on OK until the supports for all spans have been defined. Each additional support will be highlighted by a yellow dot on the screen for your reference.

The number of adjacent spans to either side cannot be set unless a continuous support has been selected at that end.

b. If you select the framed connectivity option for one or both ends, a Column Connectivity dialog window will appear and a yellow dot will highlight the support location. The end of the columns above and below the beam can be selected as pinned or fixed. The column heights need to be verified/set above and below the selected beam. The column heights are automatically defaulted to the floor to floor height.

c. An internal pin option is available for continuous span conditions and for single span support condition with sufficient redundancy. An Internal Pin dialog window will appear to set the location of each internal pin. Enter either distance from right or left, the opposite distance is automatically calculated.

d. Select OK to continue the analysis. If continuous span connectivity has been selected with adjacent spans, additional connectivity dialog window will appear to set all support conditions.

4. If Use Actual Properties has been checked on the Analysis dialog window, a Properties dialog window will appear.
a. Select the Add Self Weight check box if you want the self weight of the member added to the existing structure dead weight.

b. Select the Modify button to insert or change the properties of the member.

c. Select YES if all the properties are correct and to continue.

5. If Live Load Reductions has been checked on the Occupancy Load dialog window, the Live Load Reduction dialog window will appear.

   a. For the use of five load reductions in the analysis, provide information for the following prompts:

      (1) Indicate if member is part of a roof.
      (2) Indicate if member supports more than one floor.
      (3) Indicate if occupancy is public assembly or is a garage.

b. Verify the file name for live load reduction calculations.

   The live load reduction calculation output file can be viewed and printed with the use of the Print Data command on the File pull-down menu.

c. Select OK to continue the analysis.
6. If Wind Load is included in the Load Combination, a Wind Load options dialog window will appear.
   a. Select the wind direction that will likely create the greatest loading by selecting the appropriate option button.
   b. When a wind load refers to a pressure and a suction value appearing on the same surface, it is necessary to select either Pressure or Min. Suction or Max. Suction for analysis.
   c. Wind load for Main Wind Force Resisting elements, Components and Cladding, or Open Roof may be selected. If Wind Load for Components and Cladding is selected, you will need to select from the list of Components and Cladding loads in the list box.
   d. Select Guidelines for additional information on using the Wind Load Options dialog window.
   e. Select OK to save selections and continue the analysis.

7. If the Minimum Roof Live Load is included in the Load Combination, a Minimum Roof LL dialog window will appear.

   ![Minimum Roof LL dialog window]

   a. Enter an output filename for the Min Roof LL calculation.
   b. Select OK to continue the analysis.

8. If the Pattern Occupancy Live Load option on the Load Combinations dialog window is selected, an Analysis dialog window will appear to permit the user to select patterned live loads for analysis of continuous members such as concrete beams.

   ![Pattern Occupancy Live Load]

   a. Select YES to have CASM display pattern live loads and use them for the analysis on continuous members. The patterns include alternate spans for maximum positive moments, adjacent spans for maximum negative moment, and all spans.

9. The tributary area for load calculations on the selected element will briefly appear on the floor plane. The loads and connectivity diagrams for the selected element will be displayed on the screen. If Use Actual Properties was not selected, a Self Weight dialog window will also appear. The dialog window has a text box for the estimated self weight of the member and check boxes to update Area Structure Loads and Adding Self Weight. The options for including the element self weight include the following.
a. Self weight options for steel members.

1. Use the smeared element self weight in the dead load. This is an appropriate choice for joists, not for beams or girders. The psf self weight will already be shown on the dead load diagram. Leave the estimated self weight value in the dialog window as 0.0 psf.

2. Insert a new estimated self weight in the dead load. This is an appropriate choice for joists and beams, not the appropriate choice for girders. Use the Guidelines option to determine an estimated weight. Click on CLOSE to exit the Guidelines dialog window. Enter the estimated weight value in the text box. Click on Update Area Structure Loads to replace the structure self weight in the Floor Dead Load with the new estimated value. The type name for the structure dead load will be changed to "Est. Member Weight" and the psf value will be converted to a psf value.
(3) Add the estimated self weight to the smeared structural dead load. This is the appropriate choice for beams and girders, but not for joints. Use the Guidelines option to determine an estimated weight. Click on CLOSE to exit the Guidelines dialog window. Enter the estimated weight value in the text box. Click on the Add Self Weight check box.

b. Self weight options for concrete members.
(1) The options for concrete members is the same as the steel members.
(2) When the Guidelines dialog window is selected, a Concrete Beam Estimated Self Weight dialog window will appear.

(3) Select the appropriate concrete weight, NLWT or LTWT.
(4) Select the appropriate span type by clicking on the option button. The ACI minimum L/h ratios to avoid deflection calculations are used to determine a preliminary size.
(5) Enter the slab thickness.
(6) The b and h-t values may also be updated if desired.
(7) The calculated pf value is displayed in the text box. Clicking on OK will automatically transfer the value to the Estimated Self Weight text box.

c. Select OK on the Self Weight dialog window to continue the analysis.

10. An Analysis dialog window will appear with a text box for the analysis output name. The loads and connectivity of the linear element will be displayed on the screen.
a. Verify the analysis output file name. If you do not need the text output, you can delete the default name to speed up the analysis.

b. View and verify the loads and connectivity displayed on the screen.

c. If you want to generate an analysis input file, select the type of input file and enter the filename.

d. Select YES to continue the analysis.

11. When the analysis is complete, the shear and moment diagrams and relative deflection diagram with load and reactions displayed for the selected load combination will be displayed. A dialog window appears to permit you to change the displayed diagrams for different loads.

If Use Actual Properties was not selected, the analysis is based on default values of $E = 1.0$ and $I = 1.0$. The deflections are relative. Approximate deflection values are obtained in the spreadsheets after the $E$ and $I$ values are set.

It is possible to obtain a hardcopy of the diagrams by selecting Print Screen from the File pull-down menu.

a. To select different loads for display, place the mouse pointer on the desired loading and press the left mouse key.

The load name will be highlighted and the display will change to the diagrams for the selected load.

The deflection scale can only be changed in truss and lateral diagrams.

b. Select OK to continue the analysis.

12. An Excel Data dialog window will appear with an option to Execute Excel or send output data to a file. Refer to the end of this section for use of the Excel spreadsheets and the sizing of members.
TRUSS ELEMENTS

The sequence for the Preliminary analysis of a Truss-Custom element is:

1. Select Preliminary Analysis Icon or Preliminary from the Design menu.
   An Analysis dialog window appears.

2. Select Analysis options.
   a. Select units (feet or inches, pounds or kips).
   b. Select the desired Load Combination for analysis.
   c. Select the Apply Live Load Reduction option, if applicable.
   d. Select the Pattern Occupancy Live Load option, if applicable.
   e. Select the Use Actual Properties option, if applicable. This selection permits you to use the design properties (E & I) of the selected member for analysis. If not used, an E and I value of 1.0 will be used for analysis.
   f. The DL = Deck + Self Weight selection is for composite construction. The Guidelines option provides you with additional information for when to use the DL = Deck + Self Weight option.
   g. Select the Re-Analyze All Adjoining Members option if you changed any part of the model since your last analysis.
   h. Select OK to continue the analysis.

>>> Selection of CANCEL in any of the Preliminary Analysis dialog windows will stop the analysis process.
3. A connectivity dialog window will appear. The left and right ends of the selected element will be highlighted on the floor plane.

![Connectivity Dialog Window]

- **Left**
  - ✅
  - ✖️
- **Right**
  - ✅
  - ✖️

- **Adjacent Spans**
  - ✖️

**Internal Pin**

**OK**

**Cancel**

- a. Select the appropriate connectivity options for each end of member by clicking on the circles on both sides of the connectivity symbol.

Continuous spanning elements require the setting of adjacent spans to the left or right of the single span selected for analysis. Additional connectivity dialog windows will appear to select the adjacent span support conditions when you click on OK until the supports for all spans have been defined. Each additional support will be highlighted by a yellow dot on the screen for your reference.

- The number of adjacent spans to either side cannot be set unless a continuous support has been selected at that end.

- b. Select OK to continue the analysis. If continuous span connectivity has been selected with adjacent spans, additional connectivity dialog window will appear to set all support conditions.

4. A 2D elevation of the truss and a Truss - Custom dialog box will appear. You can select several truss configurations by use of the Truss - Custom options.

![2D Elevation of Truss]

<table>
<thead>
<tr>
<th>How</th>
<th>Top chord panels:</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>War</td>
<td>Right top chord panels:</td>
<td>2</td>
</tr>
<tr>
<td>Fink</td>
<td>Depth at support:</td>
<td>2.5 ft</td>
</tr>
<tr>
<td>Vierendeel</td>
<td>Scissors height:</td>
<td>0.00 ft</td>
</tr>
<tr>
<td>X-Brace</td>
<td>Verticals</td>
<td>Start at bottom</td>
</tr>
<tr>
<td>E-Brace</td>
<td>Left support at top</td>
<td>Right support at top</td>
</tr>
<tr>
<td>Recall</td>
<td>Delete</td>
<td>Save</td>
</tr>
</tbody>
</table>

- a. To select truss configurations such as Howe, Fink, or Pratt, move the mouse pointer to the name, press the left mouse key to highlight the desired configuration. The 2D elevation view will be redrawn with the selected configuration.
b. Use the Top Chord Panels text box to change the number of panels in the truss. The Right Top Chord Panels is only enabled for an unsymmetrical gable truss. Then select RECALC to redraw the truss with the revised number of panels.

c. The Depth of Support text box controls the depth of the truss at its support. Use RECALC to redraw the truss with the new support depth.

d. Use the Scissors Height text box to change the truss to a scissors truss. Use RECALC to redraw the truss with the new scissors height.

e. Add vertical web members to the Warren truss configuration with the Verticals check box. Use RECALC to redraw the truss with the vertical members.

f. Use the Start at Bottom to change direction of the diagonal members. Use RECALC to redraw the truss with the change in diagonal direction.

g. When the Depth at Support is greater than 0, use the Left Support At Top and/or Right Support At Top to change the location of the support from the bottom chord to the top chord. Select RECALC to redraw the truss with the support at the new location.

h. Use the DELETE option to delete web members. Select RECALC to draw the truss with all the web members.

i. Use the NEXT option to switch spans of a continuous truss.

j. Select OK to save the truss configuration and continue the analysis.

5. Use Actual Properties has been checked on the Analysis dialog window, a Properties dialog window will appear.

   ![Properties Dialog Window]

   a. Select the Add Self Weight check box if you want the self weight of the member added to the existing structure dead weight.

   b. Select the Modify button to insert or change the properties of the member.

   c. Select YES if all the properties are correct and to continue.

6. If Live Load Reductions has been checked on the Occupancy Load dialog window, the Live Load Reduction dialog window will appear.

   ![Live Load Reduction Dialog Window]

   a. For the use of live load reductions in the analysis provide information for the following prompts:
(1) Indicate if member is part of a roof.
(2) Indicate if member supports more than one floor.
(3) Indicate if occupancy is public assembly or is a garage.

b. Verify the file name for live load reduction calculations.

The live load reduction calculation output file can be viewed and printed with the use of the Print Data command on the File pull-down menu.

c. Select OK to continue the analysis.

7. If Wind Load is included in the Load Combination, a Wind Load options dialog window will appear.

a. Select the wind direction that will likely create the greatest loading by selecting the appropriate option button.

b. When a wind load refers to a pressure and a suction value appearing on the same surface, it is necessary to select either Pressure or Min. Suction or Max. Suction for analysis.

c. Wind load for Main Wind Force Resisting elements, Components and Cladding, or Open Roof may be selected. If Wind Load for Components and Cladding is selected, you will need to select from the list of Components and Cladding loads in the list box.

d. Select Guidelines for additional information on using the Wind Load Options dialog window.

e. Select OK to save selections and continue the analysis.

8. If the Minimum Roof Live Load is included in the Load Combination, a Minimum Roof LL dialog window will appear.
a. Enter an output filename for the Min Roof LL calculation.
b. Select OK to continue the analysis.

9. The tributary area for load calculations on the selected element will briefly appear on the screen. The loads and connectivity diagrams for the selected element will be displayed on the screen. If Use Actual Properties was not selected, a Self Weight dialog window will also appear. The dialog window has a text box for the estimated self weight of the member and check boxes to update Area Structure Loads and Adding Self Weight. If Use Actual Properties was selected, the self weight (plf) is computed by the total weight of the member divided by the span.

1.00 Dead (plf)

1.00 Superimposed Dead (plf)

1.00 Snow (plf)

Area Structure Loads and Adding Self Weight

Estimated self weight: [ ] plf
Update area structure loads
Add self weight
Guidelines OK Cancel

a. Select OK to continue the analysis.

10. An Analysis dialog window will appear with a text box for the analysis output name. The loads and connectivity of the linear element will be displayed on the screen.

Analysis File Name: [ ]

Are the loads and connectivity correct?
Generate Input File
Type: Name: File Name: STAAD

a. Verify the analysis output file name. If you do not need the text output, you can delete the default name to speed up the analysis.
b. View and verify the loads and connectivity displayed on the screen.
c. If you want to generate an analysis input file, select the type of input file and the filename.

d. Select YES to continue the analysis.

11. When the analysis is complete, a series of truss 2D elevations are displayed showing truss axial loads, deflection diagram with load and reactions, node and element numbers, and element lengths are displayed for the selected load combination. A dialog window appears to permit you to change the displayed diagrams for different loads.
Color is used to indicate the relative magnitude of axial forces in the following progression: red (max); yellow; cyan; blue (min).

If Use Actual Properties was not selected, the analysis is based on default values of E = 1.0 and I = 1.0. The deflection diagram is relative.

It is possible to obtain a hardcopy of the diagrams by selecting Print Screen from the File pull-down menu.

a. To select different loads for display, place the mouse pointer on the desired loading and press the left mouse key. The load name will be highlighted and the display will change to the diagrams for the selected load.

b. To change the deflection scale change the values in the X: and Y: text boxes.

c. Select OK to continue the analysis.

An Excel Data dialog window will appear with an option to Execute Excel or send output data to a file. Refer to the end of this section for the use of Excel Spreadsheets and sizing of members.

The sequence for the Preliminary analysis of a Column element is:

1. Select Preliminary Analysis Icon or Preliminary from the Design menu.

An Analysis dialog window appears.
2. Select Analysis options.
   a. Select units (feet or inches, pounds or kips).
   b. Select the desired Load Combination for analysis.
   c. Select the Apply Live Load Reduction option, if applicable.
   d. Select the Pattern Occupancy Live Load option, if applicable.
   e. Select the Use Actual Properties option, if applicable. This selection
      permits you to use the design properties (E & I) of the selected member
      for analysis. If not used, an E and I value of 1.0 will be used for analysis.
   f. The DL= Deck + Self Weight selection is for composite construction.
      The Guidelines option provides you with additional information for when
      to use the DL= Deck + Self Weight option.
   g. Select OK to continue the analysis.

3. If Live Load Reductions has been checked on the Occupancy Load dialog
   window, the Live Load Reduction dialog window will appear.

   ![Live Load Reduction Dialog]

   a. For the use of live load reductions in the analysis provide information for
      the following prompts:
      (1) Indicate if member is part of a roof.
      (2) Indicate if member supports more than one floor.
      (3) Indicate if occupancy is public assembly or is a garage.
   b. Verify the file name for live load reduction calculations.

4. If the Minimum Roof Load is Included in the Load Combination, a Mini-
   mum Roof LL dialog window will appear.

   ![Minimum Roof LL Dialog]

   a. Enter an output filename for the Min Roof LL calculation.
   b. Select OK to continue the analysis.
5. A Column Analysis dialog window will appear permitting you to select the method for calculating the loads on the column.

![Dialog Window]

- Select either Tributary Area or Structural Framing

   a. Enter the column self weight in the estimated self weight text box. There are no Guidelines for information on column self weight.
   b. Select OK to continue the analysis.

6. The tributary area for load calculations on the selected element will briefly appear on the plane. The load run down diagram for the selected element will be displayed on the screen. A Self Weight dialog window will also appear. The dialog window has a text box for the estimated self weight of the member.

![Dialog Window]

- Select OK to continue the analysis.

7. The CASM program will sum loads at each level based on tributary areas and provide a graphic display of all of the loads on the column.

<table>
<thead>
<tr>
<th>Tributary Area*</th>
<th>Self Weight</th>
<th>DL</th>
<th>LL</th>
<th>TL</th>
<th>Sum DL</th>
<th>Sum LL</th>
<th>Sum TL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roof: 5</td>
<td>462.3</td>
<td>11.0</td>
<td>0.0</td>
<td>11.0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.6</td>
<td></td>
<td></td>
<td>11.6</td>
<td>0.0</td>
<td>11.6</td>
</tr>
<tr>
<td>Floor: 2</td>
<td>462.3</td>
<td>24.7</td>
<td>37.0</td>
<td>81.7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.6</td>
<td></td>
<td></td>
<td>38.9</td>
<td>37.0</td>
<td>73.9</td>
</tr>
<tr>
<td>Floor: 2</td>
<td>462.2</td>
<td>24.7</td>
<td>37.0</td>
<td>81.7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>0.6</td>
<td></td>
<td></td>
<td>62.2</td>
<td>74.0</td>
<td>136.1</td>
</tr>
</tbody>
</table>

Note: Tributary area includes 15% increase to account for concrete continuity at first interior column.
Column B-2 Load Run Down (k)

4 - 211
8. An Excel Data dialog window will appear with an option to Execute Excel or send output data to a file. Refer to the end of this section for use of the Excel spreadsheets and the sizing of members.

![Excel Data dialog window](image)

WALL ELEMENTS

**The sequence for the Preliminary analysis of a Wall element is:**

1. Select Preliminary Analysis Icon or Preliminary from the Design menu.

   An Analysis dialog window appears.

   ![Analysis dialog window](image)

   a. Select the desired Load Combination for analysis.
   
   b. Select the Apply Live Load Reduction option, if applicable.
   
   c. Select the Pattern Occupancy Live Load option, if applicable.
   
   d. Select the Use Actual Properties option, if applicable. This selection permits you to use the design properties (E & l) of the selected member for analysis. If not used, an E and I value of 1.0 will be used for analysis.
   
   e. The DL - Deck + Self Weight selection is for composite construction. The Guidelines option provides you with additional information for when to use the DL - Deck + Self Weight option.
   
   f. Select OK to continue the analysis.

   Selection of CANCEL in any of the Preliminary Analysis dialog windows will stop the analysis process.

2. Select Analysis options.

3. A Wall Assumptions dialog window will appear.
a. You may distribute concentrated loads into the wall based on the 30° method or the 45° method. Select the desired method by placing the mouse pointer on the selection and press the left mouse key. The selection will appear in the text box to the right.

b. Indicate the estimated concentrated load bearing width by verifying/changing the value in the text box.

c. If the columns supported by the wall are concrete, you may check the Increase Tributary Area check box.

d. Select OK to continue the wall load run down.

4. If Live Load Reductions has been checked on the Occupancy Load dialog window, the Live Load Reduction dialog window will appear.

a. For the use of live load reductions in the analysis provide information for the following prompts:

1. Indicate if member is part of a roof.
2. Indicate if member supports more than one floor.
3. Indicate if occupancy is public assembly or is a garage.

b. Verify the file name for live load reduction calculations.

The live load reduction calculation output file can be viewed and printed with the use of the Print Data command on the File pull-down menu.

c. Select OK to continue the analysis.

5. If the Minimum Roof Live Load is included in the Load Combination, a Minimum Roof LL dialog window will appear.
a. Enter an output filename for the Min Roof LL calculation.
b. Select OK to continue the analysis.

6. A Column Analysis dialog window will appear permitting you to select the method for calculating the loads on the wall.

![Column Analysis Dialog Window]

a. Select either Tributary Area or Structural Framing

If Structural Framing is selected, all adjoining structural elements must be drawn on ALL levels.
b. Select OK to continue the analysis.

7. The tributary area for load calculations on the selected element will briefly appear on the plane. The load run down diagram for the selected element will be displayed on the screen. A Self Weight dialog window will also appear. The dialog window has a text box for the estimated self weight of the columns which the wall supports. The wall dead load must be assigned before you begin the Preliminary Analysis.

![Load Run Down Diagram]

a. Enter the column self weight supported by the wall in the estimated self weight text box.
b. Select OK to continue the analysis.
8. The CASM program will sum loads at each level based on tributary areas and provide a graphic display of the loading on the wall. A dialog window appears to permit you to change the display for different loads.

   It is possible to obtain a hardcopy of the diagrams by selecting Print Screen from the File pull-down menu.
   
a. To select different loads for display, place the mouse pointer on the desired loading and press the left mouse key.

   The load name will be highlighted and the display will change to the diagrams for the selected load.

   b. Select OK to continue the analysis.

9. An Excel Data dialog window will appear with an option to Execute Excel or send output data to a file. There is no Excel spreadsheet for wall member design.
**PRELIMINARY MEMBER SIZING**

To determine preliminary size of members:

1. Select whether to execute Excel or send data to a file.

- [ ] Execute Excel
- [ ] Send data to file

File name: DATA.TXT

- OK
- Cancel

a. Check the appropriate option.
b. Enter a file name if you are sending data to a file.

The SENDXL.EXE file is a stand-alone program to send the data file to Excel at another time. Use this program to send the data if you cannot run CASM and Excel at the same time because of insufficient memory.

Excel is executed if selected. Shear, moment, and deflection data are passed to the CASM Excel spreadsheets in order to determine a preliminary size for:

- Steel Bar Joists
- Steel Beams
- Steel Composite Beams
- Steel Roof Deck
- Steel Form Deck
- Light gauge Steel Joists
- Steel Columns
- Steel Truss Members
- Precast Cored Planks
- Concrete Slabs
- Concrete Beams
- Concrete Pan Joists
- Concrete Columns

Two worksheets for each element are provided in Excel. The Preliminary Selection worksheet uses data from CASM to make a member selection. The Scratch Pad worksheet initially takes data from the Preliminary Selection spreadsheet; however, you may vary spans, spacings, and loads in order to determine a more optimum framing scheme. The Scratch Pad worksheet provides you with preliminary member sizes for each change you make. You may only make changes to values displayed in blue on the screen by the use of pull-down menus on the menu bar. The values in black are calculated values and are protected. Pull-down menus on the spreadsheets allow you to change entries, view special member information, and print spreadsheets. Once you have indicated a preliminary member size on the Preliminary Selection worksheet, you may transfer the data to CASM for a quantity take-off.

To use the Excel member design spreadsheets:

- Microsoft Excel must be on the active path or the path for the Excel program must be designated in the WIN.INI file in order for the spreadsheets to execute from CASM and the Windows Program Manager icons.
After you select the **Execute Excel** option, the Excel spreadsheet program will be opened and the Preliminary Selection spreadsheet for the selected structural member will be displayed.

---

**CASM Load & Analysis Data:**

- **Method:** Analysis
- **Member ID:** J1
- **Connectivity:** Hinge (Left)
- **Beam Span:** 20 ft
- **Trib Width:** 20 ft
- **Depth Limit:** 36.0 in. max
- **Fy:** 36.0 ksi
- **Fb = 66% Fy:** 24.0 ksi
- **Fv:** 14.4 ksi
- **E:** 29,000 ksi

**Load Combination:** D + L

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Left</th>
<th>Mid</th>
<th>Right</th>
<th>Left(k)</th>
<th>Right(k)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roller (Right)</td>
<td>Dead</td>
<td>33.8</td>
<td>6.8</td>
<td>6.8</td>
<td></td>
</tr>
<tr>
<td>Roller (Right)</td>
<td>Dead</td>
<td>33.8</td>
<td>6.8</td>
<td>6.8</td>
<td></td>
</tr>
<tr>
<td>Sup Dead</td>
<td>20.0</td>
<td>4.0</td>
<td>4.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Live</td>
<td>100.0</td>
<td>20.0</td>
<td>20.0</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lmin Roof</td>
<td>Snow</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wind</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Summary</td>
<td>153.8</td>
<td>30.8</td>
<td>30.8</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**CASM Beam Selection Table:**

<table>
<thead>
<tr>
<th>Beam</th>
<th>Depth (in)</th>
<th>Width (in)</th>
<th>lx</th>
<th>Sx</th>
<th>Live Ld Defl (in)</th>
<th>Total Ld Defl (in)</th>
<th>Shear (kips)</th>
<th>Bending (kips)</th>
<th>Beam (lb)</th>
</tr>
</thead>
<tbody>
<tr>
<td>W 14 x 53</td>
<td>13.9</td>
<td>8.06</td>
<td>541</td>
<td>78</td>
<td>-0.38</td>
<td>-0.57</td>
<td>6.0</td>
<td>237</td>
<td>1,060</td>
</tr>
<tr>
<td>W 12 x 58</td>
<td>12.2</td>
<td>10.01</td>
<td>475</td>
<td>78</td>
<td>-0.44</td>
<td>-0.65</td>
<td>7.0</td>
<td>237</td>
<td>1,160</td>
</tr>
<tr>
<td>W 18 x 46</td>
<td>18.1</td>
<td>6.06</td>
<td>712</td>
<td>79</td>
<td>-0.29</td>
<td>-0.44</td>
<td>4.7</td>
<td>23.4</td>
<td>920</td>
</tr>
<tr>
<td>W 16 x 50</td>
<td>18.3</td>
<td>7.07</td>
<td>659</td>
<td>81</td>
<td>-0.31</td>
<td>-0.47</td>
<td>5.0</td>
<td>22.8</td>
<td>1,000</td>
</tr>
<tr>
<td>W 21 x 44</td>
<td>20.7</td>
<td>6.50</td>
<td>843</td>
<td>83</td>
<td>-0.25</td>
<td>-0.37</td>
<td>4.3</td>
<td>22.6</td>
<td>880</td>
</tr>
</tbody>
</table>

**CASM Steel Beam Selection:**

- Live / Total
  - W 18 x 46 | Span= 20.0 ft | lx= 78.9 | Sx= 712.0 | Defl (in)= -0.29 | -0.44

If you experience problems running Excel while CASM is still running or there is not enough RAM memory to run Excel then you can send the spreadsheet data to a file. You may activate the data using the SendXL program once you exit CASM.

To modify data on the spreadsheet:

Individual spreadsheet cells are protected to prevent inadvertent entries that will wipe out essential equations. Entries that are not protected are displayed in blue bold print and are underlined. You may change data in these cells by:

1. **Move the mouse pointer** to the Member pull-down menu selection (or press [ALT] + [M]).
2. **Press the left mouse key.**

The Member pull-down menu will be displayed.
Member menus vary depending on the type of member being sized. The following commands are selections from the Steel Beam Preliminary Selection spreadsheet:

- **Select Member** - Permits you to designate a beam size from the list of beams and send the beam size to CASM where it is displayed on the framing plan.
- **Steel Strength** - Permits you to designate the steel strength to be used in sizing the member.
- **Depth Limit** - Permits you to designate a depth limit for the sizing of the steel beam.
- **Deflections** - Permits you to designate a deflection limit for the sizing of the steel beam.
- **Calculate Now (Ctrl+C)** - Permits you to re-calculate the spreadsheet if you input numbers in the unprotected cells without using the Member pull-down menu.

3. Move the mouse pointer to the desired menu selection.
4. Press the left mouse key.

The menu selection will display a data window where you can change data on the spreadsheet.

5. Move the mouse pointer to the OK box.
6. Press the left mouse key.

The new data is inserted in the cell and the spreadsheet is automatically re-calculated to indicate optional member sizes.

**To view member guidelines:**

1. Move the mouse pointer to the Guidelines pull-down menu.
2. Press the left mouse key.

The Guidelines pull-down menu will appear.

3. Move the mouse pointer to the Cardfile selection.
4. Press the left mouse key.

The Cardfile application program will be opened on top of the spreadsheet with the card for the selected member displayed. Use the mouse pointer to select other guideline cards. Use the Close command in the Cardfile Control pull-down menu to exit the Cardfile Application program.
To use the Scratchpad spreadsheet to vary member parameters in order to determine an optimum member size:

1. Move the mouse pointer to the Scratchpad pull-down menu.
2. Press the left mouse key.

The Scratchpad pull-down menu will appear.

The Scratchpad spreadsheet permits you to vary spans and loadings in order to explore some alternative framing layouts. The Vibration selection permits you to do a vibration analysis of the selected steel beam.

3. Move the mouse pointer to the selection for the current structural member being sized.
4. Press the left mouse key.

The Scratch Pad spreadsheet for the current structural member will be displayed. You may vary the member span, spacing, loads, deflection criteria, and properties in order to determine the optimum parameters. The initial scratchpad load values selected are Equivalent Uniform load values calculated from the Preliminary Selection spreadsheet.
### Load & Analysis Data:

**Method:** Analysis

**Member ID:** J1

**Connectivity:** Hinge (Left) Roller (Right)

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Area Load Factors</th>
<th>Load Combination D * L</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dead</td>
<td>33.8</td>
<td>1.00</td>
</tr>
<tr>
<td>Sup Dead</td>
<td>20.0</td>
<td>1.00</td>
</tr>
<tr>
<td>Live</td>
<td>100.0</td>
<td>1.00</td>
</tr>
<tr>
<td>Lmin Roof</td>
<td>1.00</td>
<td></td>
</tr>
<tr>
<td>Snow</td>
<td>1.00</td>
<td></td>
</tr>
<tr>
<td>Wind</td>
<td>1.00</td>
<td></td>
</tr>
</tbody>
</table>

**Summary:**

- **M+(max):** 153.8 kip-ft
- **M-(max):** 30.8 kip-ft
- **R(max):** 30.8 kips

### Beam Selection Table:

<table>
<thead>
<tr>
<th>Beam Size</th>
<th>Depth (in)</th>
<th>Width (bf)</th>
<th>Ix (in^4)</th>
<th>Sx (in^3)</th>
<th>Live Ld Defl(in)</th>
<th>Total Ld Defl(in)</th>
<th>Shear (kips)</th>
<th>Bending (kips)</th>
<th>Beam Wt(lbs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>W 14 x 53</td>
<td>13.9</td>
<td>8.06</td>
<td>541</td>
<td>78</td>
<td>0.46</td>
<td>0.70</td>
<td>6.0</td>
<td>23.7</td>
<td>1.060</td>
</tr>
<tr>
<td>W 12 x 58</td>
<td>12.2</td>
<td>10.01</td>
<td>475</td>
<td>78</td>
<td>0.52</td>
<td>0.80</td>
<td>7.0</td>
<td>23.7</td>
<td>1.160</td>
</tr>
<tr>
<td>W 18 x 46</td>
<td>18.1</td>
<td>6.06</td>
<td>712</td>
<td>79</td>
<td>0.35</td>
<td>0.54</td>
<td>4.7</td>
<td>23.4</td>
<td>0.920</td>
</tr>
<tr>
<td>W 16 x 50</td>
<td>16.3</td>
<td>7.07</td>
<td>659</td>
<td>81</td>
<td>0.38</td>
<td>0.58</td>
<td>5.0</td>
<td>22.8</td>
<td>1.000</td>
</tr>
<tr>
<td>W 21 x 44</td>
<td>20.7</td>
<td>6.50</td>
<td>843</td>
<td>82</td>
<td>0.29</td>
<td>0.45</td>
<td>4.3</td>
<td>22.6</td>
<td>0.880</td>
</tr>
</tbody>
</table>

**CASM Steel Beam Selection:**

- **Live/Total:** W 10 x 46
  - **Span:** 20.0 ft
  - **Ix:** 712.0
  - **Sx:** 78.6
  - **Defl(in):** 0.35
  - **Wt(lbs):** 0.54

---

**To print spreadsheets:**

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.

The File pull-down menu will appear.

3. Move the mouse pointer to the Print Spreadsheet selection.
4. Press the left mouse key.
The Print pop-up window will appear. If you want to view the spreadsheet before you print it, select the Preview box. A screen displaying the spreadsheet as it would appear on the printout will appear. If it looks good you may select the Print option to send the file to the printer. If the displayed spreadsheet does not look good then you may select the Cancel option to cancel the print command and return to the spreadsheet.

You may use the following File menu selections to make changes to the appearance of the spreadsheet before printing it.

Page Setup - Allows you to change margins.

Select Font - Allows you to change font style and font size. You must select the cell with the font that you intend to change before selecting the command.

Printer Setup - Allows you to change printers.

To return to CASM:

1. Move the mouse pointer to the File pull-down menu.
2. Press the left mouse key.
   The File pull-down menu will appear.
3. Move the mouse pointer to the Return to CASM selection.
   The Return to Preliminary option on the File menu permits you to return to the Preliminary Selection spreadsheet from the Scratchpad spreadsheet. The Project Data option permits you to add Project Information if you are accessing the Scratchpads from the CASM icons.
4. Press the left mouse key.
   The Excel program and the spreadsheet will be closed. You will need to open CASM program window by double clicking the CASM Icon.

To access the Excel Scratch Pad spreadsheets from the CASM Icons:

1. Move the mouse pointer to the desired structural member icon.
2. Double-click the left mouse key.
   The Scratch Pad spreadsheet for the selected structural member will be displayed. You may vary the member span, spacing, loads, deflection criteria, and properties in order to determine the optimum parameters and member selection.

Select "Return to Icons" from the File pull-down menu to return to the icon display.
Using the SendXL program if you cannot access Excel from CASM:

1. Use the "Send data to file" option in the CASM Excel Data window after analyzing a member in CASM.
2. Exit CASM.
3. Start the SendXL program by double-clicking on the SendXL icon in the CASM application window.

4. Move the mouse pointer to the desired file name.
5. Double-click the left mouse key. (You may also press the left mouse key to highlight the file name, then move the mouse pointer to the Send box and press the left mouse key.)

The Excel Preliminary spreadsheet will open with the data created by CASM. You may make changes, designate a selection, and print the spreadsheet by use of the pull-down menu. If the selected file name does not contain CASM Excel data, you will receive a message to reselect another file name.
The Design Lateral Resistance option permits you to do an analysis of the Lateral Resistance system. If you elect to continue, the axial forces in the lateral resistance elements due to applied loads will be displayed on the screen.

Before doing the Lateral Resistance Design option the following steps must be completed:

- Create a building model.
- Define a structural grid.
- Lay out a structural framing plan for all levels.
- Assign Loads for all levels. Do Wind and/or Seismic Loads.
- Select a Load Combination including Wind or Seismic load.
- Define E-W and N-S Vertical Lateral Resistance systems.
- Define Horizontal Lateral Resistance diaphragm systems.

The sequence for Lateral Resistance analysis is:

1. Select the Lateral Resistance option from the Design pull-down menu.
   Visible Lateral Resistance systems on the displayed structural plane will be marked with handles. You may need to use the Show Structure command to display E-W and/or N-S systems.
2. Select a Lateral Resistance system.
   a. Move the mouse pointer to the handle of the lateral resistance system to be analyzed and press the left mouse key. An elevation of the lateral resistance system will be displayed in the modeling window.
3. An Analysis dialog window appears.
   a. Select Analysis options.
b. Move the mouse pointer to the option button next to the desired selection.

c. Press the left mouse key.
The button will be highlighted.

d. The Use Actual Properties selections permits you to use the design properties (E & I) of the elements in the selected lateral resistance system. If you do not use the Actual Properties selection, the E and I values are defaulted to 1.0 which may result in some error in the frame analysis.

Before using the Use Actual Properties selection, you must assign element sizes using the spreadsheets and the Copy Design and Modify Design commands in the Load and Design Edit pull-down menu.

If you have a mixture of shear walls and frames and a rigid diaphragm, you must select the Use Actual Properties option.

e. The DLD- Deck + Self Weight selection is for composite construction. The Guidelines option provides you with additional information for when to use the DLD- Deck + Self Weight option.

f. Select the Reanalyze All Adjoining Members option if you changed any part of the model since your last analysis.

g. Select OK to continue the analysis.

Selection of CANCEL in any of the Lateral Resistance dialog windows will stop the analysis process.

4. A connectivity dialog window will also appear to permit you to define the connectivity at the base of the frame. A yellow handle will appear at each base as a reference.

a. Select a base connectivity for each of the indicated members and select OK.
5. After the base connectivity has been defined, a Lateral Resistance dialog window will appear with icons to change/add the various elements.

   ![Lateral Resistance Dialog](image)

   a. Review the bracing options, make changes if desired.
   b. Move the mouse pointer to the element icon which you intend to add.
   c. Press the left mouse key.

   Handles will appear in all the structural bays where you can add the element or on structural members that you will be connecting the elements to.

   d. Click on OK when done.

6. If Use Actual Properties option has been checked on the Analysis dialog window, a Properties dialog window will appear.

   ![Properties Dialog](image)

   a. Select the Add Self Weight check box if you want the self weight of the member added to the existing structure dead weight.
   b. Select the Modify button to insert or change the properties of the member.
   c. Select YES if all the properties are correct and to continue.

7. A Wind Load Options dialog window will appear.

   ![Wind Load Options Dialog](image)
a. Select the wind direction that will likely create the greatest loading by selecting the appropriate option button.

b. When a wind load refers to a pressure and a suction value appearing on the same surface, it is necessary to select either Pressure or Min. Suction or Max. Suction for analysis.

c. Select wind load for Main Wind Force Resisting elements.

d. Select Guidelines for additional information on using the Wind Load options dialog window.

e. Select OK to save selections and continue the analysis.

8. If Flexible Horizontal Diaphragms have been selected for floors and roof planes, a Flexible Diaphragm dialog window will appear.

   ![Flexible Diaphragm Dialog Window]

   a. Select Simple Beam Model to distribute lateral loads according to tributary width.

   b. Select Continuous Beam Model to distribute lateral loads based on continuous beam analysis.

   c. Select OK to continue.

9. If Rigid Horizontal Diaphragms have been selected for floor and roof planes, a Rigid Horizontal Diaphragm Calculation dialog window will appear. Calculations are printed to an output file.

   ![Rigid Horizontal Diaphragm Calculation Dialog Window]

   a. The percentage of lateral load distributed by stiffness at each level is given. Distribution is based on the stiffness of the lateral resistance element.

   A one thousand kip force is used to compare shear wall stiffnesses. A one kip force is used to compare rigid frame stiffnesses. A one kip force is used to compare trussed bracing stiffnesses.
b. If you select the Enter Deflections at Each Level option, CASM will not compute the deflections. Instead, a dialog window will appear for you to manually enter the deflections at each level for each lateral resistance location. This option permits you to use another analysis package to compute the deflections.

c. For shear walls, you may designate walls perpendicular to the lateral resistance system as flanges monolithic with the shear wall by selecting the Consider Perpendicular Wall Elements check box.

Only 6 times the wall thickness will be used for the attached perpendicular length in the calculations.

If openings have been inserted in shear walls, stiffness calculations will include a percentage increase in moment of inertia to account for perpendicular walls as flanges according to Method C described in TM-5-909-10.

d. For shear walls, you may also select the Use Method C for Stiffness Calculations option.

e. Select OK to continue the analysis.

The tributary areas displayed when the loads are being calculated are for the gravity loads.

10. A Loading diagram for the lateral resistance system will be displayed. A Self Weight dialog window will appear with options to check the different loads. Click on OK when you have finished reviewing the loads.

a. Enter self weights of members in the Beam Self Weight dialog window and the Column Self Weight dialog window, as desired.
The column self weight is treated as a concentrated load at the mid-height of each column.

11. For seismic lateral forces, a Seismic Lateral Resistance Locations dialog window will appear to permit you to verify the output file name. The shear and overturning moments distributed to each resisting element at each level are calculated.

12. An Analysis dialog window with a default Analysis file name will appear for braced and unbraced frames. CASM cannot analyze a shear wall. It will create an analysis input file for STAAD-III.

a. Verify the analysis output file name. If you do not need the text output, you can delete the default name to speed up the analysis.

b. View and verify the loads and connectivity displayed on the screen.

c. If you want to generate an analysis input file, select the type of input file and enter the filename.

d. Click on YES to begin the analysis.

13. Review the axial, shear, moment, deflection, loads and reactions diagrams. You may select different viewing options by selecting the diagram listed on the View Axial, Shear, Moment, & Deflections dialog window.

>> Large lateral load structural models require a significant amount of memory to perform the analysis, so an out of memory error could occur.
Each member is divided into four segments for the purpose of plotting shear, moment, and deflection diagrams.

- Modify the X and Y Deflection Scale as desired.
- Select OK to continue.

Selecting Print Screen from the CASM File pull-down menu will provide you with a hardcopy of the member loading and the shear, moment, and deflection diagrams.
Currently there is no lateral resistance member design at this time.

The Lateral Resistance Input File command permits you to generate analysis input files for stiffness calculations.

Before using the Lateral Resistance Input File command, the following steps must be completed:

- Create a building model.
- Define a structural grid.
- Layout a structural framing plan for all levels.
- Define N-S or E-W vertical lateral resistance systems.

The sequence for the Lateral Resistance Input File command:

After selecting the command a handle will appear on all vertical lateral resistance systems.

1. Select a lateral resistance system.
   a. Move the mouse pointer to the handle of the lateral resistance system to be analyzed and press the left mouse key. An elevation of the selected lateral resistance system will appear in the modeling window.

2. An Analysis dialog window will appear.
a. Select Analysis units.
b. Select Use Actual Properties, if desired, and insert actual properties of members.
c. Select OK to continue.

3. A connectivity dialog window will also appear to permit you to define the connectivity at the base of the frame. A yellow handle will appear at each base as a reference.

4. After the base connectivity has been defined, a Lateral Resistance dialog window will appear with icons to change/add the various elements.

5. Use Actual Properties option has been checked on the Analysis dialog window, a Properties dialog window will appear.
a. Select the Add Self Weight check box if you want the self weight of the member added to the existing structure dead weight.

b. Select the Modify button to insert or change the properties of the member.

c. Select YES if all the properties are correct and to continue.

6. An Analysis dialog window will appear. It will create an analysis input file for STAAD-III.

```
Analysis File Name: 
Are the loads and connectivity correct?
Generate Input File:
Type: STAAD-III File Name: STAAD

Yes    No
```

a. View and verify the loads and connectivity displayed on the screen.

b. Select the type of input file and enter the filename.

c. Click on YES to generate the input file.

The Compare Min Roof LL & Snow Load command permits you to display the minimum roof live load and snow loads for the selected member to see which controls.

Before doing the Compare Min Roof LL & Snow Load command the following steps must be completed:

- Create a building model.
- Define a structural grid.
- Layout a structural roof framing plan.
- Calculate the snow load.
- Select a structural member using the Surface/Linear or Column/Wall menus.

The sequence for the Compare Min Roof LL & Snow Load command:

1. After selecting the command an Analysis dialog window will appear.

```
Analysis:
Units:
  ○ Inches ○ Pounds
  ○ Foot ○ Kips
Load Combination:
  [ ]
[ ] Apply Live Load Reduction
[ ] Pattern Occupancy Live Load
[ ] Use Actual Properties
[ ] DL = Deck + Self Weight
[ ] SDL = All Other DL
[ ] Re-Analyze All Adjoining Members
Guidelines  OK  Cancel
```
a. Select Analysis units.
   b. Select OK to continue.

2. A connectivity dialog window will appear. The left and right ends of the selected element will be highlighted on the plane.

   ![Connectivity Diagram]

   a. Select the appropriate connectivity options for each end of the member by clicking on the circles on both sides of the connectivity symbol.
   b. Select OK to continue the analysis.

3. The Minimum Roof LL dialog window will appear.

   ![Minimum Roof LL Dialog]

   a. Use the default filename or enter an output filename, if desired, for the Min Roof LL calculations. The analysis will proceed faster if the filename is deleted.
   b. Select OK to continue the analysis.

A load diagram of the selected member will appear showing both the minimum roof live load and snow load. A View Moments dialog window will appear to permit you to display the moments based on the loading of the selected member.
4. Select YES to display the moment diagrams or select NO to exit the command.

The Compare Wind & Seismic command permits you to display an elevation view of the entire building with the wind and seismic loads at each level and the total base shear.

Before doing the Compare Wind & Seismic command the following steps must be completed:

- Create a building model.
- Assign Loads for all levels.
- Do Wind loads.
- Do Seismic Loads.

N-S Building Levels

E-W Building Levels

The sequence for Compare Wind & Seismic:

1. Select the N-S Building Levels or E-W Building Levels option from the Design pull-down menu.

An elevation view of the entire building with the wind and seismic loads at each level and the total base shear is displayed.
2. Select OK to exit.

**Resistance Location (Not Implemented)**

Displays Wind and Seismic loads at each Lateral Resistance location.

The Quantity Take-Off command automatically accumulates structural member quantities for preliminary cost estimating. Information stored from the geometric model and from the selection and design of structural elements using the CASM spreadsheets is used for automatic generation of material quantities. When spreadsheets do not exist to design a particular type of element, you can manually enter the necessary information by using the Modify Design command on the Loads and Design Edit pull-down menu.

Three levels of quantity take-offs may be considered useful by the engineer during the preliminary comparison of structural systems: (1) one typical interior bay; (2) one typical level; or (3) the entire building. The choice is limited to the number of different elements the user cares to design, as well as time and storage considerations.

You must assign element sizes by use of the spreadsheets from the Preliminary Design menu and the Copy Design and Modify Design commands from the Loads and Design Edit pull-down menu before generating a quantity take-off list of structural elements.

Select the Quantity Take-Off command from the Design menu or the tool icon. The Quantity Take-Off dialog menu will appear. The CASM default calculates the total square footage for all levels based on the size of the model created. In order
to override this default, you need to enter the dimensions of a single bay when a single bay quantity take-off is desired.

To select the Override calculated square footage of total floor and roof planes:
1. Move the mouse pointer to the Override check box.

2. Press the left mouse key.
   An 'X' will appear in the check box.

3. Move the mouse pointer to the Single Bay Dimension text boxes.
4. Press the left mouse key. Double click the left mouse key if you want to highlight and change the entire value.
5. Enter the desired single bay dimensions.

To select the Current Structural Plane for quantity take-off:
1. Move the mouse pointer to the Current Structural Plane check box.
2. Press the left mouse key.
   An 'X' will appear in the check box.

To perform the quantity take-off:

If no check boxes are selected, the quantity take-off will be performed for the entire model.

1. Verify the desired output file name.
2. Move the mouse pointer to the OK confirmation box.
3. Press the left mouse key.

The Notepad program will automatically be executed with the quantity take-off file. Review the quantity take-off file. You may print the file using the Notepad Print command on the Notepad File pull-down menu (use Page Setup to set the left margin at 0.5" and the right margin at 0" before printing) or the CASM Print Data command on the CASM File pull-down menu. Exit Notepad by using the Exit command on the Notepad File pull-down menu or the Close command on the Notepad Control pull-down menu.

Structural elements drawn, but not designed appear on the output file without descriptions or weights.
This chapter describes some hints, options, and ramifications when drawing the building's geometric model. There are usually many ways to construct a correct building model. The use of commands such as STACK, SLICE SHAPE, and TAPE MEASURE allows you to accurately draw the shapes. The shape, type, and position will influence the generation of loads.

The fewer shapes used to model the building the better. The fewer the shapes, the faster the snow and wind calculations are performed as well as the overall performance of the program.

Note: For single-monitor users, a simplified model will increase the redraw speed of the screen.

For buildings with repetitive wings, only one wing needs to be drawn. The extra wings will not influence snow or wind load generation, and for preliminary design, the structure can be assumed the same.

Extra wings are not necessary

Simplified model

Insignificant portions of the building should not be modeled. If the portions do not significantly influence snow and wind load generation, they do not need to be drawn. Some examples of insignificant portions are chimneys, dormers, and small projections.

Adjoining planes of the shapes need to be in contact, or the gap between the shapes will make the surfaces exterior. Use the STACK options to accurately place adjoining shapes. Do not eye-ball the locations of shapes.

Intersecting shapes will confuse the snow and wind load generation algorithms. The interior portion of the intersected planes will become exterior surfaces, and
loads will be applied twice over the overlapped surfaces. When modeling parapet walls, make sure the corners do not intersect.

To correctly model the above building, follow one of these two procedures:

1. Use the SLICE SHAPE command to create the three cubes.
   a. Draw the two CUBES as incorrectly intersecting.
   b. SLICE one of the cubes with an intersecting plane.
   c. SLICE the sliced cube with the other intersecting plane.
   d. DELETE the cube that is inside the full cube.

- OR -

2. Use the STACK ON PLANE and DRAG PLANE commands.
   a. Draw one CUBE.
   b. Turn on STACK ON PLANE.
   c. Stack a CUBE on the wall of the first cube.
   d. Drag the planes to the correct proportions.
   e. Stack another CUBE on the other wall of the first cube.
   f. Drag the planes to the correct proportions.

Plane and column shapes are drawn as six-sided cube shapes, but are attributed as planes or columns. The proportions of the plane and column shapes can be edited just like the cube shape using the DRAG PLANE command. For the generation of snow loads, the use of these shapes does not matter since snow is applied to all roof surfaces. But, for the generation of wind loads, they do matter.

In the generation of wind main force-resisting loads, the cube shapes are included and the plane and column shapes are excluded. The plane and column shapes do not influence the B and L dimensions calculated. Use a plane shape
to model a parapet or overhang. If a cube is used, the computer will think that it is a main force resisting element.

Plane shapes are used to model open structures. Only the plane or open barrel vault shapes can be selected on which to apply open wind loads.

Column shapes are necessary only to visually show support. You can simplify the model by not drawing columns or by drawing only a few of the columns to show support.

The more the edges of the shapes line up, the faster the generation of snow and wind loads. This becomes a factor mainly when modeling parapet walls so as not to intersect.

Incorrect  Not recommended  Correct

To correctly model the parapets shown above, use one of the two procedures.

1. Drag the planes on the ends of the parapets.
   a. Set the SNAP INCREMENT to the width of the parapets.
   b. Drag the end planes of the parapets making sure to drag both ends of the same plane.

- OR -

2. Use the SLICE SHAPE command.
   a. SLICE the ends of the planes with the inner side of the parapet wall making sure to slice the same plane at both ends.
   b. DELETE the unwanted parts of the parapets.

When two shapes are placed on top of one another, the adjoining surface becomes a floor plane. Floor planes are necessary to be able to draw structure onto, for the calculation of windward wind load levels and for seismic load levels. This is not making the model more complicated because the extra shapes create floor planes which are necessary for structure and wind and seismic load generation.
Here are two ways to model floors of equal height:

1. Use STACK ON LAST SHAPE to draw the cubes.
   a. Set the INITIAL SHAPE SIZE to the proper width, length, and height of the building.
   b. Turn on STACK ON LAST SHAPE.
   c. Insert the correct number CUBES to represent the floors.

   Note: If there are no shapes to stack on, the shape will be stacked on to the ground plane.

   - OR -

2. Use the DUPLICATE SHAPE command.
   a. Insert a CUBE to the correct proportions.
   b. DUPLICATE the cube vertically to create the additional floors.

There are two ways to model a two-story space. One is to draw the two-story space as one shape. The second is to draw two shapes stacked on top of each other and then draw an opening on all or part of the adjoining floor plane.

Since the height of a structural column is calculated to the next lower floor plane, the column heights will be calculated correctly by the first method. If the second method is used, the column height will have to be manually adjusted when drawing the column. Currently, when finding the height of the column, the open areas are not checked.

Here is a method to model the open two-story gable roof space.

   a. Draw the open gable roof space as a PRISM stacked on a CUBE.
   b. Drag the top plane of the cube above the ridge of the prism.
   c. SLICE the cube with both top planes of the prism.
   d. DELETE the unwanted parts of the cube and the prism.
Use the structural grid to create structural bays, not duplicated cube shapes. This will simplify the model with no unnecessary shapes. The use of the structural grid will make it easier to adjust the bay size.

When modeling overhangs, use a plane shape, not the cube shape. This will not make the overhangs a main wind force-resisting element and will exclude their proportions in the B and L dimension calculations. For a wind component in the overhang, the wind components and cladding generation will add the additional uplift load from the bottom of the overhang to the component.

When drawing the overhang, make sure the top plane is exactly the same slope as the rest of the roof. Otherwise, the overhang will not be included with the plane of the roof. Using the SLICE SHAPE command will ensure that the top plane of the overhang is the same as the roof.

Here are two ways to model the above overhang.

1. Use the SLICE SHAPE command.
   a. Draw the main portion as a CUBE and a PRISM.
b. Set the INITIAL SHAPE SIZE Height to the width of the overhang and the Wall Thickness to the overall thickness of the overhang.

c. Turn on STACK ON PLANE.

d. Insert a VERTICAL PLANE on upper edge of the wall of the cube.

Note: A vertical plane is draw perpendicular to the stacked surface.

Note: If the plane remains vertical when stacked, switch the orientation to the other direction.

e. SLICE the plane shape with the roof surface.

f. DELETE the unwanted part of the plane shape.

- OR -

2. Use the DRAG EDGE command. For this method to work, the edge of plane shape has to be able to be dragged in 1-inch increments to achieve the correct slope.

a. Follow steps a through d as in method 1.

b. Turn off SNAP TO UNITS so the edge is dragged in 1-inch increments.

c. Use TAPE MEASURE on the top plane of the overhang to measure the slope.

d. LOCK the N-S and E-W directions so the edge is only dragged vertically.

e. Drag the edge vertically to the same slope as the roof.

f. UNLOCK the N-S and E-W directions.

g. Turn on SNAP TO UNITS.

When drawing, the N-S and E-W dimensions correspond to the directions of ground plane. If the ground plane is rotated, all future draw commands will follow the new angle. There are two angles for the ground plane to allow for easy switching between angles. The commands which follow the angle of the ground plane are: all draw shape commands, define grid, draw openings, and draw structure, and assign loads.
Follow these steps for one way to draw a 45-degree angle dogleg:

a. Draw one CUBE the width of the leg and the length of the leg to the inner intersection point. Place the intersection point of the cube at the center of the ground plane.

**Hint:** Translate the cube half the width and length to place the corner at the center of the ground plane.

b. Use DEFINE GROUND PLANE to change the angle of the ground plane to 45 degrees.

c. Use a similar process to draw the other leg.

d. Drag one of the cube's end plates to overlap the other cube completely.

e. SLICE the dragged plane cube with the exterior wall plane and the interior wall plane of the other cube.

f. DELETE the unwanted parts of the cube.

g. To draw the structural grid, use the DEFINE GRID OPTIONS to select the area where to grid will follow the ground plane, the bubble location, and the beginning letter and number. Rotate the ground plane before defining the other half of the structural grid.
MODELING

Sometimes it is difficult to select the proper handle to perform an operation because the shape's handles overlap or are too close together. Using the HIDE SHAPE command to temporarily not display a shape can help select the proper handle because the handles of hidden shapes are not drawn. Hidden objects are still used in snow and wind calculations.

Another reason to use the HIDE SHAPE command is to view only the structure since the structure on the planes of a hidden shape is still drawn. To not display structure, turn off Structure in the SHOW STRUCTURE dialog window.

Use the SHOW SHAPE command to redisplay all the hidden shapes.

Make sure the geometric model is complete and accurate before drawing structure and calculating loads. If you change the geometry after calculating wind and snow loads, the loads will have to be regenerated. The structure may
not line up correctly, and the structural grid will have to be redefined if the model is changed after drawing structure.

To verify the model, use the TAPE MEASURE command or zoom in on the plan, elevation, and 3-D views to check all the above precautions.

Only plane shapes can be used to model open roof structures for wind load calculations. In order to eliminate undesired wind load values and prevent potential analysis problems, you need to make the top edge of inclined planes vertical to the ground plane. If the top edge is not vertical to the ground plane, CASM tries to apply a wind load to the edge.

Here are two ways to model the top edge correctly:

1. Use the SLICE SHAPE command.
   a. Draw a HORIZONTAL PLANE.
   b. ROTATE the plane to the correct slope.
   c. Enclose the plane with a CUBE
   d. Use DRAG EDGE to drag the edge of the plane beyond the face of the cube
   e. Use the SLICE SHAPE command to slice the edge of the plane with the face of the cube
   f. DELETE the cube and the sliced plane.

2. Use the DRAG EDGE command.
   a. Draw a HORIZONTAL PLANE.
   b. LOCK the N-S and E-W directions.
   c. Use TAPE MEASURE to measure the slope of the top plane.
   d. Use DRAG EDGE to locate the top edge of the plane.
   e. Use DRAG EDGE to locate the bottom edge of the plane.
   f. UNLOCK the N-S and E-W directions.
   g. Cancel TAPE MEASURE.
See also the Tutorial Guide examples for Wind Loads on Unenclosed Buildings.
DRAW STRUCTURE

This chapter describes some hints, options and ramifications when drawing the building's structure.

- Structure on structural planes
  Structure can only be drawn on structural planes. Structural planes can be horizontal (roofs and floors), inclined (roofs) and vertical (walls). To view a structural plane, use the Horizontal Structural Plane, Inclined Structural Plane, or Vertical Structural Plane commands in the View menu or use the Structural Plane Name Drop-Down List box. The structural plane view commands can only be used while viewing the 3D model whereas the Structural Plane Name Drop-Down List can be used any time.

- Naming structural planes
  The names of structural planes are initially numbered sequentially as the model is drawn. To make the structural plane name more meaningful, change the name of the plane using the Structural Plane Information command in the View menu.

- Structural roof plane
  CASM defines a roof plane as one which has no objects stacked on it. If the plane has an object stacked on top of it, it is labeled as a floor plane. Planes which are partial roof and partial floor are considered as floor planes.

- Distribution of loads.
  The selection to draw linear elements with the Narrowly Spaced or Widely Spaced command effects the distribution of loads to the supporting elements and the selection of the element type. CASM defines narrowly spaced elements as those which are spaced less than or equal to 4 feet apart and produce uniformly distributed reactions on supporting elements. Narrowly spaced elements spaced greater than 4 feet apart produce concentrated reactions on supporting elements. Widely spaced elements are spaced greater than 4 feet apart and produce concentrated reactions on supporting elements. Widely spaced elements spaced less than 4 feet apart still produce concentrated reactions.

- Surface elements on linear elements.
  Narrowly spaced elements are assumed to have a surface above them to distribute the loads uniformly to them. A surface element does not need to be drawn above a narrowly spaced element. Widely spaced elements need adjoining elements to be drawn so loads can be distributed correctly to them. Third point beams need a surface element drawn above them. If no elements
are drawn to distribute loads to a widely spaced element, CASM assumes the beam is next to an opening.

- **Analyzing linear elements**
  When analyzing linear elements, the structure types listed in the Surface/Linear menu are different for narrowly spaced and widely spaced elements. For example, steel narrowly spaced elements can be open web joists and widely spaced elements can be rolled sections. Narrowly spaced elements cannot be rolled sections and widely spaced elements cannot be open web joists.

- **Truss element load distribution**
  Linear truss elements distribute loads to supporting elements exactly like narrowly spaced elements. Truss elements spaced less than or equal to 4 feet produce uniformly distributed reactions and trusses spaced greater than 4 feet produce concentrated reactions. Loads are distributed to a truss element exactly like a widely spaced element. All adjoining elements must be drawn to distributed the loads to the truss.

- **Defining areas for drawing linear and surface elements**
  When defining the area to draw surface and linear elements, select the handles in a clockwise order. Handles represent the midpoint of a line which contains two points on one edge of the perimeter. The perimeter is made up of these points. To easily and accurately draw the surface element on a linear element, use the option to draw the surface element when drawing the linear element.

- **Linear elements on a grid line**
  To draw a single beam or truss along a grid line, select the handles along the grid line then double click the right mouse key to cancel defining the location. An area does not need to be defined when drawing widely spaced and truss elements. Narrowly spaced elements cannot be drawn along a single grid line.

- **Supports for linear elements**
  It is not necessary to draw the columns and walls which support the linear elements. Supports are assumed at the end points. Continuous beams must be drawn in segments so the support locations can be positioned. If you do not draw the beam in segments, CASM will interpret the beam as spanning the entire length.

- **Dimensions must be identical**
  When copying structure the source and destination bay sizes must be exactly the same dimensions. If the bay sizes are off by just 1/32 of an inch, the loads will not be distributed to the supporting members.
• Copying structure to other planes

It is possible to copy structure from one horizontal plane to another horizontal plane. It is not possible to copy structure from an inclined plane to another inclined plane or a horizontal plane. It is also not possible to copy structure from a vertical plane to another vertical plane.

• Structural walls are not the same as vertical plane shapes

Structural walls should not be confused with vertical plane shapes. Structural walls are drawn from the Draw Structure Tool Palette and represent vertical and lateral load carrying elements. Vertical plane shapes are drawn from the Draw Model Tool Palette and represent the building elements, usually parapet walls.

• Assigning wall weight

When drawing structural walls, it is easiest and most accurate to assign the wall weight at the same time. Define the wall weight using the Wall (DL) command before drawing the structural wall. Then, turn on Assign Wall Dead Load and select the wall weight type from the list when drawing the structural wall.

• Structural walls and wall dead loads

Structural walls support the structural plane they are drawn on and wall dead loads are applied on top of the structural plane they are assigned on.

• Deletion of structural walls

Deleting or modifying a structural wall does not automatically delete or modify the assigned wall dead load.
**Irregularly Spaced Grids**

To define an irregularly space grid more easily, set the grid spacing to 9999 feet (or any number greater than the overall dimensions of your building) in each direction. Then, place each grid line separately with the Add Main Grid Line command.

**Main vs. Sub Grid Lines**

Main grid lines are used for the entire building. Sub grid lines are used only on the selected structural plane. The sub grid line A.5 on the second floor plane does not appear on the third floor plane.

**Surface Element Defined Area**

The area defined when drawing surface elements can not be larger than the linear element's defined area below them. When drawing a linear element, use the option to draw the surface element at the same time to eliminate this warning.
This chapter describes some hints, options and ramifications when assigning and computing loads.

Assigning loads to structural planes
Loads can only be assigned while viewing a 2D horizontal or vertical structural plane. Use the Horizontal Structural Plane or the Inclined Structural Plane commands or the Structural Plane Name Drop-Down List to select a structural plane.

Roof Loads vs. Floor Loads
Floor loads and roof loads can be assigned on either a roof plane or a floor plane. The only difference between floor and roof loads are the material types.

Calculation of minimum roof live loads
The Min. Roof LL command does not need to be used to compute minimum roof live loads. If minimum roof live loads are in your load combination, the minimum roof live loads are automatically calculated during the analysis. Minimum roof live loads are also automatically calculated when using the Compare Min. Roof LL & Snow Loads command. The Min. Roof LL command is used to calculate the minimum roof live load without going through the analysis of a member.
ANALYSIS AND DESIGN

This chapter describes some hints, options and ramifications when performing analysis and design.

- **Self weight options**
  
  When not using actual properties, there are three self weight options contained in the Self Weight dialog box.

  1. **Use the smeared element self weight called “Structure” in the assigned dead load.**
     
     This is an appropriate choice for joists but not for beams and girders. If the pf self weight is already shown in the dead load diagram, leave the estimated self weight as 0.0. For example, when designing an open-web steel joist and you estimated the joist weight in the assigned floor dead load structure type, you would use the smeared structural self weight displayed in the dead load diagram and not enter a new estimated self weight.

  2. **Insert a new estimated pf self weight.**
     
     This is an appropriate choice for joists and third point beams but not for girders. Turn off Add Self Weight so the dead load pf is replaced with the new value. Turn on Update Area Structure Loads if you want the new pf self weight smeared into the area structure dead loads. The “Structure” type would be renamed “Est. Member Weight” and the pf value converted to a psf value. Since the area structure loads will be updated, when creating the area dead loads, the “Structure” type can be set to 0.0. For example, when designing a third point rolled section beam, you would use guidelines to estimate the self weight and then smear that weight into the assigned floor dead load.

  3. **Add the estimated pf self weight to the smeared structural dead load.**
     
     This is an appropriate choice for girders but not for joists or third point beams. Turn on Add Self Weight and turn off Update Area Structure Loads. For example, when designing a rolled section girder, the dead load diagram shows the weight of the structure framing into the girder so you would add the girder self weight to the displayed dead load and not update the smeared weight of the assigned floor dead load which contains the weight of the members framing into the girder.
• Including member self weight during analysis
  Turn on Use Actual Properties to include the member’s self weight in the calculation of the reactions of adjoining members. During analysis, the structural weight of the member design properties is used instead of the smeared structure weight and an estimated self weight. A warning dialog box is displayed and the member is highlighted if no self weight was used when calculating the dead load reactions of an adjoining member.

• Analysis of frames
  Turn on Use Actual Properties when analyzing a frame to more accurately calculate the distribution of lateral loads from a rigid diaphragm and the axial, shear and moment forces. Actual properties must be used if using a rigid diaphragm and a mixture of shear walls and frames for the vertical lateral load resistance.

• Assigning design properties
  When using actual properties, all members being analyzed as well as all adjoining members must have design properties assigned. Design each member or use the Modify Design and Copy Design commands to assign the design properties.

Re-Analyzing Adjoining Members

• Reactions of designed members are automatically stored
  Reactions from adjoining members are automatically calculated and stored by CASM when a member is designed. Simple span connectivity and the smeared structure weight is used for the self weight. A warning dialog box is displayed and the member is highlighted if no self weight was used when calculating the dead load reactions. Use the option to Re-analyze All Adjoining Members if any part of the model was changed since your last analysis. For example, all adjoining members would need to be re-analyzed if an area dead load was changed since the stored reactions are for the old weight.

• Self weight accuracy
  A more accurate adjoining member self weight can be used by turning on Use Actual Properties.

Default Values

• Default values
  Analysis without using actual properties is based on default values of E and I equal to 1.0. Real deflection values are obtained in the spreadsheets after E & I are set.
• Surface Element Self Weight

The surface element self weight used for analysis is the Floor (DL) or Roof (DL) 'Deck' type. The 'Structure' type is not used. During the surface analysis process, there is no Self Weight dialog box as in the linear analysis process. When Using Actual Properties, the surface properties design weight will be used instead of the 'Deck' type. For example, when analyzing a 6" precast cored plank for a floor, the self weight of 49 psf is entered into the Floor (DL) 'Deck' type and assigned over the surface element before doing the preliminary analysis.

• Tributary Area vs. Structural Framing

When calculating a column or wall load run down, you have a choice of calculating the loads based on the tributary area or based on the structural framing. When using the tributary area method, the tributary area is found by locating the next column or wall along the grid lines in all four directions. The structural dead weight is calculated using the smeared structure weights. When using the structural framing method, all adjoining structural members on all levels must be drawn to calculate the reactions at each level. Turn on the Use Actual Properties option to include the assigned self weight for each member. Otherwise, the smeared structure weight is used for the self weight of each member.
SPREADSHEETS

The CASM program uses member design spreadsheets developed using the Microsoft Excel program to select a preliminary structural member size based on analysis data from CASM. The spreadsheets quickly provide you with several member size options to choose from based on analysis data and designated design parameters such as material strength and deflection limits. Once you have selected a preliminary member size, you may transfer the member size to CASM for a quantity take-off or re-analysis using actual member properties. There are two member design spreadsheets. The Preliminary Selection spreadsheet can only be accessed from CASM. In addition, a Scratchpad spreadsheet has been developed which will aid you in selecting a structural member size based on the inputted member span, spacing, deflection criteria, loads, and member properties without using the CASM analysis. The Scratchpad uses only basic analysis routines for uniform loading to arrive at an initial member size which must be verified through CASM or another analysis program. The Scratchpad spreadsheets can be accessed from the Preliminary Selection spreadsheet or by icons in the CASM application group window.

SPREADSHEET FORMAT

The format for all of the member design spreadsheets is similar in order to aid you in quickly identifying the displayed information.

- The parts of the member design spreadsheet include the pull-down menu, the project data section, the loads and analysis data section, the selection table, the final member selection, and structural notes.

  Pull-down menus are available to change member properties, display a list of user generated member guidelines, designate a final member size, and print the spreadsheet.

  The project data section contains the CASM project data information, the current date, plus a space to record the initials of the engineer working on the project.

  The load and analysis area contains the load and analysis data passed to the spreadsheet by the CASM program. On the Preliminary Selection spreadsheet most of this data cannot be changed because it is based on CASM analysis data. Only the depth limit, material strength, and deflection limits can be changed. On the Scratchpad all of the data in this section can be changed in order to explore other framing configurations and loadings which can be used in CASM when laying out a structural framing system.

  The selection table section includes a list of adequate structural members sizes which meet the criteria listed in the load and analysis data section. Included with the member sizes is the member design properties based on the CASM analysis data which permits you to make a selection from the list of members.

  The final member selection and design properties based on the CASM analysis data is displayed at the bottom of the spreadsheet.
### Preliminary Selection Spreadsheet

Below the final member selection are displayed notes which include the reference for the design methods used and limitations in design using the spreadsheet.

- Text which is highlighted in blue, bold print on the member design spreadsheets are values that can be modified by use of the pull-down menu commands. The cells which contain the values that can be modified are unprotected so that you could input the values directly by selecting the cell. However, the spreadsheet is not set up for automatic re-calculation. If you input values directly in the cell without using the pull-down menu commands, then you must recalculate the spreadsheet by selecting the [F9] function key, the [Ctrl] + [C] keys, or by selecting the Calculate Now command on the Member pull-down menu.

---

**CASIM Load & Analysis Data:**

<table>
<thead>
<tr>
<th>Method: Analysis</th>
<th>Load Combination: D + S</th>
<th>Factored Moment (ft-lb)</th>
<th>Factored Reaction (lb)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Member ID:</td>
<td></td>
<td>Left</td>
<td>Mid</td>
</tr>
<tr>
<td>Connection:</td>
<td>Hinge (Left)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Roller (Right)</td>
<td>Dead</td>
<td></td>
</tr>
<tr>
<td>Span:</td>
<td>12.2 ft</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spacing:</td>
<td>60.0 in</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Depth Limits:</td>
<td>38.8 in max</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fg:</td>
<td>50.0 ksi</td>
<td>Snow</td>
<td></td>
</tr>
<tr>
<td>Fl:</td>
<td>30.0 ksi</td>
<td></td>
<td></td>
</tr>
<tr>
<td>E * 29,000 ksi</td>
<td>Summary</td>
<td>5,010</td>
<td></td>
</tr>
</tbody>
</table>

**CASIM Joist Selection Table:**

<table>
<thead>
<tr>
<th>Joist Size</th>
<th>Spacing (in)</th>
<th>Total Ld (lb)</th>
<th>Live Ld (lb)</th>
<th>Min Aims (kip)</th>
<th>Max Aims (kip)</th>
<th>Total Fmr (in)</th>
<th>Total Ld (lb)</th>
<th>Ponding Ld (lb)</th>
<th>Joist Weight (psf)</th>
</tr>
</thead>
<tbody>
<tr>
<td>10K1</td>
<td>60.0</td>
<td>593</td>
<td>429</td>
<td>9,959</td>
<td>3,273</td>
<td>0.18</td>
<td>0.12</td>
<td>128</td>
<td>5.0</td>
</tr>
<tr>
<td>12K1</td>
<td>60.0</td>
<td>550</td>
<td>543</td>
<td>10,182</td>
<td>3,347</td>
<td>0.13</td>
<td>0.08</td>
<td>127</td>
<td>5.0</td>
</tr>
<tr>
<td>8K1</td>
<td>60.0</td>
<td>423</td>
<td>277</td>
<td>8,009</td>
<td>2,632</td>
<td>0.30</td>
<td>0.20</td>
<td>130</td>
<td>5.1</td>
</tr>
<tr>
<td>12K3</td>
<td>60.0</td>
<td>550</td>
<td>543</td>
<td>10,182</td>
<td>3,347</td>
<td>0.10</td>
<td>0.07</td>
<td>127</td>
<td>5.7</td>
</tr>
</tbody>
</table>

**CASIM Bar Joist Selection:**

<table>
<thead>
<tr>
<th>Joist Size</th>
<th>12K1</th>
<th>Span: 12.2 ft</th>
<th>Spacing: 60 in</th>
<th>TL defl: 0.20 in</th>
<th>LL defl: 0.13 in</th>
<th>Weight: 0.03</th>
<th>Min Ax: 10,182</th>
<th>Max Ax: 3,347</th>
<th>Total Ld: 550 lb</th>
<th>Live Ld: 543 lb</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ponding Check:</td>
<td>&gt;&gt;&gt;</td>
<td>&gt;&gt;&gt;</td>
<td>&gt;&gt;&gt;</td>
<td>&gt;&gt;&gt;</td>
<td>&gt;&gt;&gt;</td>
<td>783</td>
<td>Pond Ld: 127 lb</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**NOTES:**

2. Approximate moment of inertia of the joist in inches^4 is:
   \[ I = 26.767 \text{ (kVLL)} [L (\text{in})]^2 \text{ (in}^4 \text{)} \], where VLL = Live Load value in table.
   \[ I = L \cdot \text{Span} \cdot 0.33 \text{ in} \cdot \text{ft} ^2 \]
3. Ponding check based on SJL Technical Digest. Refer to AISC Commentary section K2.
Depending on the type of member being designed, there are four to six spreadsheets for each member. There are two visible design spreadsheets, the Preliminary Selection spreadsheet and the Scratchpad spreadsheet which contain the calculations for the design of the members. The Excel program uses separate spreadsheets for macros. Two spreadsheets are used for macro commands to control the design spreadsheets and the pull-down menus. In addition, steel members require a spreadsheet listing all members and their design properties. Bar joists and steel beams require an additional spreadsheet for vibration analysis. The only visible spreadsheets will be the design or vibration spreadsheets all of the rest are either hidden or behind the displayed spreadsheet.
PULL DOWN MENUS

The recommended method for using the spreadsheets is to use the pull-down menus to access commands and dialog boxes for inputting data. All of the spreadsheets have similar menus and commands. The Preliminary Selection spreadsheet has an added menu labeled Scratchpad which permits you to select the Scratchpad spreadsheet. Listed below are the pull-down menus and their selections.

The File Menu is a pull down menu used to print the spreadsheet, change the page format, select a printer, add project data, exit Excel or return to the previous spreadsheet. The File pull-down menu varies slightly on the different spreadsheets. All of the File pull-down menus are shown below.

- **Return to CASM** (Preliminary Selection spreadsheet only)
  - Automatically closes all of the spreadsheets and exits the Excel program.

- **Return to Icons** (Scratchpad spreadsheet only when accessed by an icon)
  - Automatically closes all of the spreadsheets and exits the Excel program.

The spreadsheets have been developed using Excel 3.0. If you are using Excel 4.0, you will be prompted to save the spreadsheet in Excel 4.0 format. You should select YES to save the spreadsheet in the Excel format.

Return to Preliminary (Scratchpad spreadsheet only when accessed from the Preliminary Selection spreadsheet)
Automatically closes the Scratchpad spreadsheet and opens the Preliminary Selection spreadsheet.

- **Activate EXCEL Menu**
  
  Displays the Excel menu bar. The design spreadsheet menu bar will disappear.

  The use of the Activate EXCEL Menu command is **not** recommended unless you are familiar with using Excel. It can be used if you experience some problems using the design spreadsheet menus or want to modify your spreadsheets.

  If you use the Activate EXCEL Menu and want to return to the design pull-down menus, use the [Ctrl] + M key to activate the Preliminary Selection pull-down menu, use the [Ctrl] + S key to activate the Scratchpad pull-down menu.

- **Page Setup**

  Displays the Page Setup dialog window where you can change margins, paper size, add headers or footers, and printing options.

- **Print Spreadsheet**

  Displays the Print dialog window. Automatically selects the preview option so that you can check the spreadsheet before it is printed. Prints only the design portion of the spreadsheet.

- **Printer Setup**

  Permits you to select a printer for the output. This command allows you to switch to a different printer to print the design spreadsheets.

- **Select Font**

  Permits you to change the font, font style, font size, and color for the font in the selected cells.

- **Project Data**

  Displays a dialog window which will permit you to edit or add project data in the space provided on the spreadsheet. Initially the CASM project data is passed to the Preliminary Selection spreadsheet.

---

**The Member Menu** is a pull down menu used to select a final member size, change member properties, and select the Calculate Now command to recalculate formulas on the spreadsheet. The Member pull-down menu varies slightly on the different spreadsheets for different members and materials. The Member pull down menu for the Preliminary Selection spreadsheet has less commands than the Scratchpad spreadsheet. Two of the Member pull-down menus for steel bar joist design are shown on the following page.
Select Member

Permits you to select a final member from the list of members. The selected member and its properties will be displayed at the bottom of the spreadsheet. On the Preliminary Selection spreadsheet there is a Send Member Size to CASM check box. If the box is checked, the member size and properties are sent to your project CASM file where the member size will be displayed for the designated member on the Structural Plane.

Depth Limit

Permits you to limit the depth of the structural member that you are designing. If the depth limit is too shallow, no structural members may be found. The depth may need to be increased.

Deflection Limit

Permits you to change the live load and total load deflection limits for the member design.

Strength

Permits you to modify the design strength of the member.

Span/Spacing (Scratchpad spreadsheet only)

Permits you to modify the member span and spacing.

Loading/Factors (Scratchpad spreadsheet only)

Permits you to modify the loading on the member and include load factors.
- Vibration Check

The Vibration Check command is only provided for the Steel Bar Joist and Steel Beam members. Selecting the Vibration Check command will display the Vibration Check spreadsheet.

![Vibration Check Spreadsheet](image)

**Estimated Damping Ratio Percentage**

<table>
<thead>
<tr>
<th>Item</th>
<th>Est Ratio %</th>
<th>Range</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bare Floor</td>
<td>3.9</td>
<td>1.0 - 3.0</td>
<td>Lower limit for thin slab of LTWT concrete</td>
</tr>
<tr>
<td>Ceiling</td>
<td>Dv = 1.9</td>
<td>1.0 - 3.0</td>
<td>Upper limit for thick slab of LTWT concrete</td>
</tr>
<tr>
<td>Dustwork &amp; Mech</td>
<td>Dv = 0.9</td>
<td>1.0 - 10.0</td>
<td>Depends on amount and attachment</td>
</tr>
<tr>
<td>Partitions</td>
<td>Dv = 0.9</td>
<td>1.0 - 10.0</td>
<td>Lower limit for hung ceiling</td>
</tr>
</tbody>
</table>

**Velocity Method - Steel**

![Velocity Method Diagram](image)
• Ponding

The Ponding command is available only for steel bar joist members. Selecting the command permits you to define ponding parameters.

- Ponding - Joist supported by beam
  - Beam Select:
    - W 14 x 36
    - W 12 x 170
    - W 14 x 22
    - W 14 x 34
  - Beam Span: 30 ft
  - Acting Live Load Percent: 40%

- Ponding - Joist supported on wall
  - Estimated water height above support: 2 in
  - Estimated adverse manufacturing tolerance: 0.25 in
  - Acting live load percentage at time of ponding: 40%

- Calculate Now

Selecting this command will re-calculate the spreadsheet values. It can be used if you enter data directly in the unprotected cells without using the menus.

Each of the pull-down menu command selections will automatically recalculate the spreadsheet. However, if you input values directly into unprotected cells, you will need to use the Calculate Now command, the [F9] function key, or the [Ctrl] + [C] keys to recalculate the spreadsheet.

The Scratchpad Menu is a pull-down menu used to select the Scratchpad spreadsheet for the member you are checking on the Preliminary Selection spreadsheet. Generally there is only one selection unless you are using the Column design spreadsheets where the command selection for Footing design has been added.

The Guideline Menu is a pull-down menu used to select a database of structural information. There is one command, Cardfile which activates the Windows Cardfile program which contains the database of structural information. The displayed card should match the material and member type that you are designing. You may edit and modified the data as desired to include specific reminders and cautions for your own use.

CAUTION: Whenever you load newer versions of CASM, you will need to ensure that you do not save over your modified card file.
CASM OUTPUT

CASM provides the user with several options for producing hardcopy text and graphics. The user can elect to send text output files and screen images directly to the printer or edit and enhance the output using the Windows Notepad program for text output, the Micrograﬁx Windows Draw or Micrograﬁx Designer programs for graphics output, or the Windows Write program for very large text files or combined text and graphic ﬁles. This chapter brieﬂy describes the use of these output programs to edit and enhance CASM output and the Windows printer selection and management programs to control the output directly from CASM. If you are interested in more detailed information on these programs, you are encouraged to review the Windows User Guide and/or the Micrograﬁx User Guides.

PRINTING OUTPUT DIRECTLY FROM CASM

The CASM Print Data command for text and Print Screen command for screen displays on the File pull-down menu, permits the user to send output directly to the printer. All of the output provides documentation for the selection of a building structural system. The use of Print Data and Print Screen is covered in the Overview and Reference chapters of the User Guide. Briefly the sequence for sending data to the printer from CASM is listed below.

Select Print Data or Print Screen from the File pull-down menu.

A dialog window will appear. If you select Print Data, the dialog window contains a list of text ﬁles which you must select for printing. Only those ﬁles that you have created for the current project will be printed, even though there are default ﬁle names in all of the text boxes.

1. Select the Printer or Print to Printer options.
2. Deselect the Print to File options.
3. Select OK to begin printing.

The ﬁle is transferred to the Windows Print Manager program. The Print Manager then works in the background, sending the ﬁle to the printer while you continue working. As you send more ﬁles to the printer, the Print Manager creates a list of ﬁles waiting to be printed. You can check on the status of a ﬁle on the list at any time and change its status up until the time that it starts printing. You can also stop a ﬁle that is printing.

USE OF THE PRINT MANAGER

The Print Manager is a program that temporarily stores output ﬁles and sends them to the printer while you do other work on the computer. The Print Manager is activated automatically whenever you print a text or graphics ﬁle. The switch that controls it is located on the Printers dialog window which is accessed from the Windows Control Panel on the Main group window. If the Print Manager is de-
selected, only one file can be sent to the printer at a time and the computer will be
unusable until the printer has finished.

You can access the Print Manager directly from the Print Manager icon which
appears in the lower left corner when you are printing files or from the Main group
window if you want to change printer priorities. The printer priorities are accessed
from the Print Manager Options pull-down menu and are listed below.

- Low Priority - To decrease printing speed and run applications faster.
- Medium Priority - Standard setting. To print and run applications equally.
- High Priority - To increase printing speed and slow down applications.

To change printing priority:
1. Select the Options pull-down menu.
2. Move the mouse pointer to the desired priority.
3. Press the left mouse key. A check will be placed in front of the selected pri-

To delete a file from the list:
1. Move the mouse pointer to the name of the file to delete.
2. Press the left mouse key to highlight the file name.
3. Place the mouse pointer on the Delete box.
4. Press the left mouse key to delete the file name from the list to be printed.

To pause the printer:
1. Move the mouse pointer to the Pause button.
2. Press the left mouse key.
PRINTING OUTPUT DIRECTLY FROM CASM

CASM uses the printers which are accessed by Windows. If you have several printers installed and want to change printers when using CASM, you can use the Printer Setup command on the CASM File pull-down menu. The Printer Setup dialog window displays a list of available printers and the printer port.

To select a printer:
1. Move the mouse pointer to the name of the desired printer.
2. Press the left mouse key.

The selected printer name will be highlighted.

The Setup option permits you to select the paper orientation, paper size, graphics resolution, and other special features of your printer. The Graphics Resolution setting will control how fast the graphics will be printed. A medium resolution should be adequate for all of the graphics that you print from CASM.

3. Select OK to save settings.
PRINTING OUTPUT FROM OTHER PROGRAMS

The use of the Windows Notepad program for editing and printing CASM text output files is reviewed in the Overview and Reference chapters in the discussion of output files. You can access Notepad from CASM by two methods. You can access Notepad at any time by selecting the Run command from the Control pull-down menu. Select Notepad from the list of programs on the Run Application list and select OK. A Notepad window will be opened over the CASM window. You may access files by using the Open command on the Notepad File pull-down menu. You may also access Notepad from CASM by using the Print Data command on the CASM File pull-down menu.

To activate Notepad from the File pull-down menu,
1. Select Print Data.
2. Select the desired output files.
3. Select the Print to File option.
4. Verify/change the desired output file name.
5. Select the Execute Notepad option.
6. When you select OK, a Notepad window will be opened over the CASM window with the text file displayed.

The Windows Notepad program is only an ASCII text editor. Your options for formatting the text is very limited. You can only change the text, margins, header, and footer. You can select printers. Notepad has a file size limitation of approximately 50,000 characters. If the CASM text file is too large, such as the analysis output files, you will receive a warning that Notepad cannot handle the file. You can load the file into the Windows Write program or any word processor that will read ASCII text files.
The Windows Write program is a word processor. With Windows Write you can change fonts, justification, appearance, and size. You can also add graphics from CASM. You can access Write at any time by selecting the Run command from the Control pull-down menu. Select Write from the list of programs on the Run Application list and select OK. A Write window will be opened over the CASM window.

To access CASM text files:

1. Select the Write File pull-down menu.
2. Select the Open command.
3. Change the directory and file designator by typing the path to the CASM text files in the Open File Name block (ie. C:\CASM\*.txt).
4. Press the [Enter] key.
   The default directory will be changed to the CASM directory and all the CASM .txt files will be displayed.
5. Double-click the mouse pointer on the desired file to load it into Write.

A Write dialog window will appear, prompting you to Convert the selected text file. If you intend to use the word processing options on the text and add graphics, then you must select the Convert option. If you want the text to remain in ASCII format, then you must select the No Conversion option.

- Use the Page Layout command from the Select Document pull-down menu to change margins.

- Use the Character pull-down menu to change fonts. First, the text to change must be selected with the mouse. Since CASM output is formatted for monospaced fonts, select the Courier, Roman, or Terminal font.
To insert graphics in Windows Write

1. First select the graphics in the graphics program (Windows Draw or Designer).
2. Select the Copy command from the Edit pull-down menu when in the graphics program. This places the selected graphics on the Windows Clipboard.
3. Exit or Minimize the graphics program.
4. Activate the Windows Write program with the text where you intend to place the graphics.
5. Move the cursor to the desired location for the graphics.
6. Select Paste from the Write Edit pull-down menu.

The graphics will be drawn at the selected location. After selecting the graphics, you may use the Move Picture or Size Picture commands from the Edit pull-down menu to change the graphics.

You can print the file by using the Print command on the File pull-down menu.

When you save the file, you will need to use the standard.WRI format, if you added graphics to the file or changed the fonts and format.

The use of the Windows Draw and Designer programs is similar. The discussion below for the Windows Draw program is similar for Designer.

The use of the Windows Draw program for editing and printing CASM graphic output files is reviewed in the Overview and Reference chapters in the discussion of output files. You can access Windows Draw from CASM by two methods. You can access Windows Draw at any time by selecting the Run command from the Control pull-down menu. Select Windows Draw from the list of programs on the Run Application list and select OK. A Windows Draw window will be opened over the CASM window. You may access files by using the Open command on the Windows Draw File pull-down menu. You may also access Windows Draw from CASM by using the Print Screen command on the CASM File pull-down menu.
To activate Windows Draw from the File pull-down menu:

1. Select Print Screen.
2. Select the Windows Draw File option.
3. Verify/change the desired output file name.
4. Select the Execute Windows Draw option.

When you select OK, a Windows Draw window will be opened over the CASM window with the screen graphics file displayed. You may use the Edit commands to modify the graphics.

Use the Print command on the File pull-down menu to print the graphics.

To combine CASM screen graphics in Windows Draw or Designer:

1. Create the screen graphic files by saving them with separate file names. Do not select the Execute Windows Draw option until you do the last graphic screen file.
2. After the Windows Draw window has opened on the screen with the graphics, move the graphics so that other graphics can be placed on the screen.
3. Use the Import command on the File pull-down menu to access the CASM graphics files.
4. Select the .PIC Micrograph Pictures option.
5. Change the path, if necessary to the CASM directory (i.e. enter c:\casm\*.pic in the Open File Name box, then press [Enter]).
6. Select Autopaste ON.
7. Double-click on the desired file name.

The graphics will automatically be "pasted" on the screen.

8. Place the mouse pointer on the graphics, then press and hold the left mouse key to drag it to the desired location.
9. Release the left mouse key.
10. Repeat steps 3 to 9 for additional graphics.
The use of the AutoCAD program for editing and printing CASM graphic output .DXF files is noted briefly in the Reference chapter in the discussion of the Print Screen and Export commands. You cannot access AutoCAD from CASM. Depending on your computer type and capabilities, you may be able to create an AutoCAD application window. You can create CASM .DXF files from the CASM Print Screen command and the Export command on the File pull-down menu. The CASM Print Screen command produces a 2D image in .DXF format either the screen or exact coordinates. The CASM Export command produces a three-dimensionally accurate .DXF drawing. You can use the exported .DXF drawing in AutoCAD to create dimensionally correct drawings.

The AutoCAD DXF file created by CASM contains a header for layers, linetypes, and text styles. If your default ACAD.Dwg file contains layers, linetypes, text styles, or entities, the DXFIN command will skip loading the CASM DXF header because the drawing will not be considered new. If you get an error message saying that a linetype or text style is not defined, do the following steps:

1. Load the CASM linetype file, using the AutoCAD Linetype command.
2. Create a text style named MONOTEXT using the monospaced text font file.
3. Do the DXFIN command again.

Sample script files can be used to perform the above steps and zoom to the correct view. The script files assume you are creating a new drawing with the same name as the .DXF file and are executing the script file from the DOS prompt.

To use the script files:

```
ACAD casmdxf casmscr
```

where: casmdxf is the name of the .DXF file
casmscr is the name of the correct script file
based on the graphics resolution.

Do not include the file extensions .DXF and .SCR.
ADDITIONAL CASM PROGRAMS

The following programs are stand alone applications provided with the CASM program. They can be accessed from the CASM group window by double clicking on the icon. Three of the programs, BMWT, FRAME, and LOADS, are used in CASM. BMWT is used when estimating member weights for analysis. LOADS is used to generate loads based on model geometry. FRAME is the program used for the Preliminary Analysis.

BMWT

The BMWT.EXE (Beam Weight) program is a stand alone Windows program to help estimate a member's selfweight. Given the member's span and total load, an estimated member weight in pounds per linear foot is displayed in a table. This is the program which is executed when the Guidelines button is pressed on the Self Weight dialog window during preliminary analysis.

<table>
<thead>
<tr>
<th>Span</th>
<th>PLF</th>
<th>Mid-Range Wt.</th>
</tr>
</thead>
<tbody>
<tr>
<td>16'</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>28'</td>
<td>6</td>
<td></td>
</tr>
<tr>
<td>28'</td>
<td>7</td>
<td></td>
</tr>
<tr>
<td>32'</td>
<td>8</td>
<td></td>
</tr>
<tr>
<td>36'</td>
<td>9</td>
<td></td>
</tr>
<tr>
<td>48'</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>48'</td>
<td>13</td>
<td></td>
</tr>
<tr>
<td>48'</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>52'</td>
<td>15</td>
<td></td>
</tr>
</tbody>
</table>

Running the BMWT program by selecting the icon:
1. Place the mouse pointer on the BMWT icon.
2. Double-click the left mouse key.
   The Beam Weight dialog window will appear. To check beam weights for a given span:
3. Place the mouse pointer on the Span text box.
4. Enter the desired span value.
5. The SPAN can be changed to any length or 'ALL' to display all the spans listed for the current member type.
6. Select the NEXT button to view the next member type or the PREVIOUS button to view the previous member type.
7. Select the CLOSE button to exit from the program.
The information displayed is stored in the text file BMWT.DAT. The text file format is as follows:

- # MATERIAL: member type as listed in STRUCT.DAT headings for the span table
- ----- dashed line
- spans listed as x' or x1-x2' in ascending order
- ----- dashed line
- optional notes

The member type can be listed more than once in the file. A span can be listed more than once in the same table. See the BMWT.DAT file which is included in your CASM directory for examples.

**FRAME**

FRAME.EXE is a Windows version of the X0020 2D Frame Analysis program. The program uses the same ANALYSIS.DLL library as CASM. The input format is the same as the U.S. Army Corps of Engineers X0020 program. See the X0020 program documentation for the format.

In the INPUT group box, enter the input file name and select the units the input file is in. In the OUTPUT group box, enter an output file name and select the units of the output file. The input and output units do not have to be the same. Select the EXECUTE button to perform the analysis. When the analysis is completed, Notepad is automatically executed with the output file loaded. Select the CLOSE button to exit from the Frame program.

**LOADS**

LOADS.EXE is a stand alone program to calculate snow loads, wind loads, minimum roof live loads and seismic loads. This program is non-graphical so all the dimensions, heights, slopes, and weights are entered numerically and there is
no graphical output. The program uses the same 5809186.DLL, 5809191.DLL and 58091081.DLL libraries as CASM. The program has similar features as those found in CASM Version 0.10, the first non-graphical release of CASM.

Listed and displayed below are the LOADS menus and dialog windows. Refer to the Loads and Design section in the Reference chapter of the User Guide for additional information on creating the design loads in the LOADS program.

File Menu

Exit
Exit the Loads program.

About Loads
Displays the About dialog box showing the version of the program and the libraries.

Project

Displays the Project dialog window used to enter the project name, city/installation, state, design load, and seismic code which is used as a header for the LOADS output files. Units can be selected.

Loads Menu

Min Roof (LL) Displays the Minimum Roof Live Load dialog window used to calculate minimum roof live load based on the tributary area and roof slope entered. After selecting OK, the minimum roof live load is
calculated and the output is displayed in Notepad. Select CANCEL to not calculate the minimum roof live load.

**Snow**

Displays the Snow Load criteria dialog window. Enter the correct criteria then select OK for the Snow Load Dimensions dialog window to appear. After entering the correct dimensions, select OK to calculate the snow loads. The output is then displayed in Notepad.

<table>
<thead>
<tr>
<th>Snow Loads</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Ground Snow:</td>
<td>30</td>
<td>psf</td>
</tr>
<tr>
<td>Importance Factor:</td>
<td>1.0</td>
<td></td>
</tr>
<tr>
<td>Exposure:</td>
<td>C</td>
<td>1.0</td>
</tr>
<tr>
<td>Roof Slippery:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Thermal Factor:</td>
<td>1.0</td>
<td></td>
</tr>
<tr>
<td>Output File:</td>
<td>SNOWOUT.TXT</td>
<td></td>
</tr>
</tbody>
</table>

**Snow Load Dimensions**

<table>
<thead>
<tr>
<th>Flat/Lean-to Roof</th>
<th></th>
<th>Drift Load</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Roof Slope:</td>
<td>0.00</td>
<td>in 12</td>
<td>Projection Height:</td>
</tr>
<tr>
<td>Gable/Hip Roof</td>
<td></td>
<td></td>
<td>Projection Length:</td>
</tr>
<tr>
<td>Roof Slope A:</td>
<td>8.00</td>
<td>in 12</td>
<td>Upper Roof Length:</td>
</tr>
<tr>
<td>Roof Slope B:</td>
<td>8.00</td>
<td>in 12</td>
<td>Separation Distance:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Arched Roof</th>
<th></th>
<th>Drift Load and Sliding Snow</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Crown Height:</td>
<td>0.0</td>
<td>ft</td>
<td>File of roof producing sliding snow:</td>
</tr>
<tr>
<td>Width:</td>
<td>0.0</td>
<td>ft</td>
<td></td>
</tr>
<tr>
<td>Height of eave above grade or lower roof:</td>
<td>0.0</td>
<td>ft</td>
<td></td>
</tr>
</tbody>
</table>

**Wind**

Displays the Wind Load criteria dialog window. Enter the correct criteria then select OK for the Wind Load Dimensions dialog window to appear. There are different dimension dialog windows for Main Wind Force Resisting System, Components and Cladding, and Open Roof Wind Loads. For the Wind Load Dimension dialog window, enter the number of Levels above grade to display text boxes for each of the building levels. After entering the correct dimensions, select OK to calculate the wind loads. The output is then automatically displayed in Notepad.
Seismic

Displays the Seismic Load criteria dialog window. Enter the correct criteria then select OK for the Seismic Load Dimensions dialog window to appear. Enter the number of Levels above grade to display text boxes for each of the levels. After entering the correct dimensions and loads, select OK to calculate the seismic loads. The output is then automatically displayed in Notepad.
ICONS

ICONS.EXE is a Windows program which contains the spreadsheet icons used for the CASM Program Manager Group Window. When executed, all the icons are displayed in a dialog window. Select OK to exit the program.

XGLUT

XGLUT.EXE is a Windows program which displays the color palette the CASM display library XG1281.DLL uses. The program also lists the displayable resolution of CASM graphics and the amount of memory needed for the z-buffer which is used by the Solid and Transparent commands.

Select CLOSE from the Control menu to exit the program.
TROUBLE SHOOTING

PRECAUTIONS

This is version 5.0 of the CASM program. Following this release, there will be subsequent periods of enhancements to the program. As such, the program and Windows 3.x still has a few bugs. Most of the bugs are related to the amount of available RAM (memory) on your system. Since we cannot predict when and if things will go wrong, we will try to give you some good advice.

DO make sure you have enough RAM memory in your computer. This program is being developed with a 486 computer with 8 MB of RAM and a VGA graphics card. 1 MB of RAM should be enough for small structural models if you use the Matrox graphics card. If you use the single screen configuration, 3 MB should be the minimum configuration for most projects. Windows alone takes up 320KB of RAM.

DO NOT run Windows with memory resident programs. This may cause memory conflicts. Check your manuals first to see if your memory resident programs will work with Windows.

DO use the SendXL program to send data to the Excel spreadsheets if you experience problems sending data directly from CASM to Excel.

DO NOT try to run too many programs under Windows. Again, due to memory limitations you may need as much memory as you can get.

DO make sure that if you have an expanded memory card and the Matrox graphics card, that the memory address locations 0C6000 to 0C63FF are available for Matrox use. These address locations are in the 384Kb memory segment from 640Kb to 1.0Mb. If the expanded memory software tries to access the same memory segment, the computer will lock up.

DO make sure that if you have the Matrox graphics card, you verify all switch settings before installing the card. Make sure that you are grounded before touching the card. If you have any problems with the graphics card, contact the Matrox Technical Support personnel for assistance. Use the telephone number listed in the Technical Guide.

DO make sure all your cables are properly connected to and from the computer.

DO make sure all equipment is switched on and in operable condition.

DO SAVE YOUR WORK OFTEN. We cannot stress this enough.
ERROR MESSAGES AND CORRECTIVE ACTIONS

In the event that you do receive an error message when using CASM the following error messages, corrective actions, and descriptions should be helpful.

### Windows Fatal Errors

**Error Message:**

"Unrecoverable Application Error"

**Corrective Action:**

After a Windows Fatal Error, exit Windows and re-boot the machine.

**Problem:** A program wrote to a memory space it did not have access to.

**Solution:** Try the procedure again. If the error happens again, document the complete procedure and contact us if CASM was running when the error occurred.

**See Also:** Windows Resource Kit, Troubleshooting

### CASM Fatal Errors: Program Terminates

**Error Messages:**

"Could not load STRUCT.DAT."

"LOADS.DAT data file not found."

"OCCUPAN.DAT data file not found."

"CITIES.CRD data file not found."

"Could not load DEFAULT.BLD."

**Corrective Action:**

After a CASM Fatal Error, exit Windows before executing CASM again.

**Problem:** The file does not exist or is bad.

**Solution:** Make sure the file is located in the CASM directory. Reinstall CASM using the CASM Setup program.

**Error Message:**

"Out of global memory!"

**Corrective Action:**

After a CASM Fatal Error, exit Windows before executing CASM again.
Problem: There was not enough memory for allocation.
Solution: Purchase more extended memory.
Run Windows in Enhanced mode.
Work with only a portion of a complete model.

Error Messages:

"Handle NULL! "
"Bad memory lock! "
"Invalid handle when unlocking! 

Corrective Action:
After a CASM Fatal Error, exit Windows before executing CASM again.

Problem: Windows could not lock or unlock a memory block.
Solution: Try the procedure again. If the error happens again, document the complete procedure and contact us.

Error Message:

"CASM.TMP "

Corrective Action:
After a CASM Fatal Error, exit Windows before executing CASM again.

Problem: Could not create or open the CASM temporary file CASM.TMP.
Solution: Free more hard disk space on the drive where CASM resides.
Do not erase this file if CASM is running.

Error Message:

"File read error: Could not find new handle XXX. "
"File read error: Could not convert old handle to index. "

Corrective Action:
After a CASM Fatal Error, exit Windows before executing CASM again.

Problem: Error loading a building file.
Solution: Try loading the file again. If the error happens again, send a copy of the bad file to us.
Regenerate the model from scratch.
WHAT TO DO IF SOMETHING IS WRONG

If you get an error:

1. If it is an error message, write down the complete message.

2. First check the error messages listed above and in Appendix B of the "Microsoft Windows Operating Environment" manual. Follow any instructions there if the error is listed.

3. If the error message is not listed or it is some other problem, write down a complete description of the events that led to the error. Also, try to recreate the event and be as specific as possible in your description; also, save the data file on a floppy, if possible. This will help us when we try to locate the problem. Send all information to:

   Commander and Director
   US Army Engineer Waterways Experiment Station
   ATTN: CEWES-IM-DS
   3909 Halls Ferry Road
   Vicksburg, MS  39180-6199
   Phone (601) 634-2300

We will make every effort to correct the problem in the next release.
Appendix A: TRADEMARKS

Microsoft, MS-DOS, Windows, and Excel are registered trademarks of Microsoft Corporation.

IBM is a registered trademark of IBM Corporation.

Hercules is a trademark of Hercules Corporation.

AutoCAD is a registered trademark of AutoDesk, Inc.

Windows Draw and Designer are registered trademarks of Micrografx, Inc.
# Appendix B:
## CASM FILE CONTENTS

The files listed below are included on the CASM release disks. All files are compressed on the installation diskettes. The CASM Setup program must be used to install all the files on your computer.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>README.TXT</td>
<td>Information for loading and running CASM. Contains new features and information not in the Reference Guide.</td>
</tr>
<tr>
<td>SETUP.EXE</td>
<td>Windows program to load all the necessary CASM files on your hard disk.</td>
</tr>
<tr>
<td>CITIES.CRD</td>
<td>CARDFILE list of cities/installations and criteria data.</td>
</tr>
<tr>
<td>LOADS.DAT</td>
<td>NOTEPA D list of dead load and live load values.</td>
</tr>
<tr>
<td>LOADSM.DAT</td>
<td>NOTEPA D list of metric dead load and live load values.</td>
</tr>
<tr>
<td>OCCUPAN.DAT</td>
<td>NOTEPA D list of occupancy live loads.</td>
</tr>
<tr>
<td>OCCUPANM.DAT</td>
<td>NOTEPA D list of metric occupancy live loads.</td>
</tr>
<tr>
<td>STRUCT.DAT</td>
<td>NOTEPA D file of the structural element database with span ranges and L/d ratios.</td>
</tr>
<tr>
<td>STRUCTM.DAT</td>
<td>NOTEPA D file of the structural element metric database with span ranges and L/d ratios.</td>
</tr>
<tr>
<td>GUIDES.CRD</td>
<td>CARDFILE list of general structural guidelines.</td>
</tr>
<tr>
<td>BMW.T.DAT</td>
<td>NOTEPA D list of structural estimated self weights for BMWTEXE.</td>
</tr>
<tr>
<td>BMWTM.DAT</td>
<td>NOTEPA D list of structural estimated metric self weights for BMWTEXE.</td>
</tr>
<tr>
<td>RW.DAT</td>
<td>List of seismic Lateral Resistance System Rw factors.</td>
</tr>
<tr>
<td>DEFAULT.BLD</td>
<td>CASM default building project file.</td>
</tr>
<tr>
<td>ANALYSIS.DLL</td>
<td>Structural analysis program library.</td>
</tr>
<tr>
<td>CASMLIB.DLL</td>
<td>Library used by all the CASM programs.</td>
</tr>
<tr>
<td>TM5809186.DLL</td>
<td>TM 5-809-1 1986 design load program library.</td>
</tr>
<tr>
<td>TM5809191.DLL</td>
<td>TM 5-809-1 1992 design load program library.</td>
</tr>
<tr>
<td>TM58091091.DLL</td>
<td>TM 5-809-10 1992 seismic load program library.</td>
</tr>
<tr>
<td>BMWTEXE</td>
<td>Stand-alone Windows estimated self weight program.</td>
</tr>
<tr>
<td>CASM.EXE</td>
<td>The CASM program.</td>
</tr>
<tr>
<td>XG1281.DLL</td>
<td>Graphics library for the dual-monitor Matrox SM-1024 and SM-1281 graphics card.</td>
</tr>
<tr>
<td>XG1281.DLL</td>
<td>Graphics library for the single-monitor Windows version.</td>
</tr>
<tr>
<td>XG1281.DLL</td>
<td>Graphics library for the dual-monitor Matrox SM-640 graphics card.</td>
</tr>
</tbody>
</table>
### Appendix B

<table>
<thead>
<tr>
<th>File Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.SCR</td>
<td>AutoCAD script files to DXFIN the CASM DXF print screens and CASM exports. For example, 'ACAD CASM CASM1024' will run AutoCAD and DXFIN the CASM DXF print screen image, then zoom to the proper view.</td>
</tr>
<tr>
<td>CASM.LIN</td>
<td>Contains linetypes the CASM.DXF Print Screens and Export commands use.</td>
</tr>
<tr>
<td>CASM.HLP</td>
<td>CASM on line Help file.</td>
</tr>
<tr>
<td>DXF.DLL</td>
<td>AutoCAD DXF import library.</td>
</tr>
<tr>
<td>STAAD.DLL</td>
<td>STAAD III analysis input file library.</td>
</tr>
<tr>
<td>CASMMENU.DAT</td>
<td>CASM menu data file.</td>
</tr>
<tr>
<td>SENDXL.EXE</td>
<td>Windows program to send the CASM analysis data file to Excel. Run this program if you are unable to execute CASM and Excel at the same time. Do not execute while CASM is running.</td>
</tr>
<tr>
<td>XGDOWNL.BAT</td>
<td>Sample Matrox LIB shell download batch program.</td>
</tr>
<tr>
<td>EMMTEST.EXE</td>
<td>DOS program to test for expanded memory. Checks the page frame location for a conflict with the Matrox board. If conflicts exist, refer to the expanded memory installation guide and the CASM installation chapter.</td>
</tr>
<tr>
<td>FRAME.EXE</td>
<td>Stand-alone Windows frame analysis program which uses the ANALYSIS.DLL library. The program uses the same input format as the program Analysis of Two-Dimensional Frame Structures (X0020).</td>
</tr>
<tr>
<td>LOADS.EXE</td>
<td>Stand-alone Windows program to calculate snow, wind, minimum roof live load, and seismic loads. The program has no graphical input or output.</td>
</tr>
<tr>
<td>ICONS.EXE</td>
<td>Windows program which contains the Program Manager; group icons for the scratchpad spreadsheets.</td>
</tr>
<tr>
<td>XGLUT.EXE</td>
<td>Windows program to display the color look-up table for the graphics library.</td>
</tr>
<tr>
<td>CASM.BMP</td>
<td>CASM bitmap for the Windows desk top.</td>
</tr>
<tr>
<td>USACEWES.BMP</td>
<td>Corps of Engineers bitmap for the Windows desktop.</td>
</tr>
<tr>
<td>*.BLD</td>
<td>Tutorial examples.</td>
</tr>
<tr>
<td><em>.XL</em></td>
<td>Excel spreadsheets and macros.</td>
</tr>
</tbody>
</table>
Appendix C: MATROX INSTALLATION

These instructions are the necessary steps to install your Matrox SM-1024 or SM-1281 graphics card. They do not include all installation options. Please refer to the Matrox Installation and Technical Manual, the README files on the diskettes or the Matrox technical phone support if a problem arises.

1. Inspect the equipment.
   a. Visually check for no damage.
   b. The SM-Series-1 board set including the SM-1281 or SM-1024 board, the PG-Series-1 board, and the GSP board should be attached.
   c. Two plastic card guides should be included.
   d. A mounting bracket should be on one end of the SM-Series-1 board set.

2. Check the dip switches.
   a. The switches should be set as follows for a dual-monitor system:

<table>
<thead>
<tr>
<th>Switch</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>Off</td>
</tr>
<tr>
<td>A2</td>
<td>Off</td>
</tr>
<tr>
<td>A3</td>
<td>Off</td>
</tr>
<tr>
<td>A4</td>
<td>Off</td>
</tr>
<tr>
<td>A5</td>
<td>Off</td>
</tr>
<tr>
<td>A6</td>
<td>On</td>
</tr>
<tr>
<td>B1</td>
<td>On</td>
</tr>
<tr>
<td>B2</td>
<td>Off</td>
</tr>
<tr>
<td>B3</td>
<td>Off</td>
</tr>
<tr>
<td>B4</td>
<td>Off</td>
</tr>
<tr>
<td>B5</td>
<td>On</td>
</tr>
<tr>
<td>B6</td>
<td>Off</td>
</tr>
</tbody>
</table>

   These are not the standard switch settings; therefore, the board set will have to be taken apart to change.

   b. Change the dip switches. A qualified person should take the board set apart in a static-free environment.

      (1) Remove the four screws.
      (2) Carefully pry the boards apart with a pair of long-nose pliers. Do not use a screwdriver.
      (3) Change the dip switches.
      (4) Realign the pins and carefully push the board back together.
      (5) Replace the four screws.
3. Install the SM-Series-I board set. A qualified person should install the board set in a static-free environment.
   a. Turn the computer off.
   b. Remove the cover.
   c. Remove the blank panel covers on two empty adjoining slots.
   d. Install the card edge guides if they are missing.
   e. Press the SM-Series-I board set into the slots.
      (1) Gently slide through the two mounting fixtures and card edge guides.
      (2) Carefully slide the PC edge connectors into the motherboard.
      (3) Firmly press the board set all the way in.
   f. Attach the board to the mounting fixture with a screw.
   g. Connect the high-resolution monitor cable to the female connector. Do not connect anything to the male connector.
   h. Replace the cover and screws.

4. Run the diagnostic test.
   For the SM-1024: DIAG1024 [path\filename.val]
   For the SM-1281: DIAG1281 [path\filename.val]
   Replace [path\filename.val] with the appropriate customization file for the monitor attached to the Matrox board.

<table>
<thead>
<tr>
<th>Customization File</th>
<th>Resolution</th>
<th>XTAL(MHz)</th>
<th>Monitor(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>lgpl1.val</td>
<td>1024x768</td>
<td>64</td>
<td>Nec Multisync XL</td>
</tr>
<tr>
<td>lgpl1w.val</td>
<td>1024x768</td>
<td>64</td>
<td>Special configuration</td>
</tr>
<tr>
<td>lgp22.val</td>
<td>1280x960</td>
<td>104/8</td>
<td>Olivetti monitor</td>
</tr>
<tr>
<td>lgp23.val</td>
<td>1280x960</td>
<td>104/4</td>
<td>Olivetti monitor</td>
</tr>
<tr>
<td>lh434.val</td>
<td>1280x1024</td>
<td>110</td>
<td>Hitachi 4115,4119,4619,4625</td>
</tr>
<tr>
<td>lgp34.val</td>
<td>1280x1024</td>
<td>110</td>
<td>Mitsubishi 9918,6600,6605</td>
</tr>
</tbody>
</table>

   For example, to test a SM-1024 attached to a Nec Multisync XL, do the following:
   A:
   DIAG1024 VAL\LGP11.VAL
   Everything should be OK.

5. Install the Matrox software. Do the following steps:
   C:
   MKDIR \XG1281
   CD \XG1281
   XCOPY A:*.* C:/s/v

6. Configure the LIB shell. This needs to be done only once.
   CD \XG1281\UTIL
CUSTOM \XG1281\BIM\SMLS.OUT \XG1281\BIM\VAL\LGP11.VAL

This is to configure an SM-1024 attached to a Nec Multisync Monitor. If you have a different configuration, substitute the LGP11.VAL file with the appropriate file name from the above table.

7. Modify the AUTOEXEC.BAT file. This will set the path and download the Matrox LIB shell every time you turn the computer on. The LIB shell MUST be downloaded before executing CASM. Use a text editor to modify.
   a. Add the \XG1281\UTIL directory to the PATH.

   PATH= C:\WIN;C:\CASM;C:\XG1281\UTIL;

   b. Add the Matrox LIB shell download commands:

   SMDO\N\XG1281\BIM\SCALER.LOD \XG1281\BIM\FEEDER.LOD
   PGDOW\N\XG1281\BIM\SMLS.OUT
   LSFLUSH

   Refer to the sample Matrox LIB shell download batch program XGDOWNLBAT contained in \PROGRAMS on the CASM disk 1 as an example.

   c. Run the AUTOEXEC.BAT to update the changes.

8. Try running the Matrox demo.

   For the SM-1281: SMDEMO
   For the SM-1024: SMDemo06

   There is no demo specifically for the SM-1024; therefore, use the SM-641 demo. If the demo runs, the Matrox board is installed properly.
Appendix D: SAMPLE OUTPUT

The following pages contain sample graphics and text from the CASM program. All samples have been taken from the CASM Tutorial. Refer to the Tutorial for guidance on the detailed methods of creating this output.
Design Criteria Output Example

Basic Design Criteria

Project Data

- **Project name**: Auditorium
- **City/Installation**: Ft. Huachucal
- **Country**: USA
- **State**: AZ
- **County**: Cochise
- **Design Load**: TM 5-809-1 1986
- **Building Code**: UBC
- **Seismic Code**: TM 5-809-10 1991
- **Elevation above sea level**: 2584 ft.
- **No. of Stories**: 2
- **Floor Area**: 60000 sqft.
- **Occupancy**: A2.1
- **Type of Construction**: II-FR

Seismic Lateral Load Resistance

- **N-S System**: B4a
- **N-S Rw**: 8
- **E-W System**: B4a
- **E-W Rw**: 8

Regional Data

Wind

- **Basic Wind Speed**: 70.0 mph
- **Coastal**: No
- **Maximum Wind Speed**: 71.0 mph
- **Wind Direction**: SE

Snow

- **Ground Snow Load**: 5.0 psf
- **Maximum Snow Depth**: 6.8 in.
- **Snow Density**: 10.0 pcf

Rain

- **Average Annual Rainfall**: 12.0 in.
- **Maximum Rainfall**: 7.9 in.

Temperature

- **Maximum Temperature**: 98.3 F
- **Minimum Temperature**: 38.2 F

Seismic Zone: 2A

Site Specific Data

Wind

- **Exposure**: C
- **Importance**: II
- **Importance**: 1.07

Snow

- **Exposure**: C
- **Importance**: II
- **Importance**: 1.10
- **Roof Smooth**: No
- **Thermal Factor**: 1.0

Seismic

- **Importance**: IV
- **Soil Factor**: S3
- **Soil Name**: Boring #1
- **Allowable Bearing Pressure**: 3500.0 psf
- **Equivalent Fluid Pressure**: 30.0 pcf
- **Water Table**: 6.0 ft.
- **Slope**: 0.5
- **Depth to Bottom of Footing**: 2.0 ft.
- **Gravels with fines**: D-2
Notes
Importance Factor for Snow and Wind:
II High Risk
- Buildings where primary occupancy is for assembly of 300 or more people in one area; i.e., auditoriums, recreational facilities, dining hall, commissaries, etc.
- Buildings having high value equipment.
- Facilities involving missile operations.
- Facilities involving sensitive munitions, fuels, chemical and biological contaminants.

Wind Exposure Category:
Exposure C:
Open terrain with scattered obstructions having heights generally less than 30 ft.

Snow Exposure Category:
Exposure C:
Snow removal by wind cannot be relied on to reduce roof loads because of terrain, higher structures, or several trees nearby.

Snow Thermal Factor:
Heated structure.
* These conditions should be representative of those that are likely to exist during the life of the structure.

Seismic Lateral Load Resistance System:
B. Building Frame System
  4. Concentric Braced Frames
    a. Steel
       Height limit #2: 160
       #1 Basic Structural Systems are defined in Section 1.D.6.
       #2 H = Height Limit applicable to Seismic Zones 3 and 4. See Section 1.D.7 for exceptions.
       #5 See Section 1.E.3 for combination of Structural System.

Importance Factor for Seismic:
I. Essential Facilities
  Hospitals and other medical facilities having surgery and emergency treatment areas.
  Fire and police stations.
  Tanks or other structures containing, housing or supporting water or other fire-suppression materials or equipment required for the protection of essential or hazardous facilities, or special occupancy structures.
  Emergency vehicle shelters and garages.
  Structures and equipment in emergency preparedness centers.
  Stand-by power generating equipment for essential facilities.
  Structures and equipment in communication centers and other facilities required for emergency response.

II. Hazardous Facilities
  Structures housing, supporting or containing sufficient quantities of toxic or explosive substances to be dangerous to the safety of the general public if released.

III. Special Occupancy Structure
  Covered structures whose primary occupancy is public assembly - capacity more than 300 persons.
  Buildings for schools (through secondary) or day-care centers - capacity more than 250 students.
  Buildings for colleges or adult education schools - capacity more than 500 students.
  Medical facilities with 50 or more resident incapacitated patients, but not included above.
  Jails and detention facilities.
  All structures with occupancy more than 5000 persons.
  Structures and equipment in power generating stations and other public utility facilities not included above, and required for...
IV. Standard Occupancy Structure

All Structures having occupancies or functions not listed above.

Seismic Soil Factor:

S3: A soil profile 70 feet or more in depth and containing more than 20 feet of soft to medium stiff clay but not more than 40 feet of soft clay.

The site factor shall be established from properly substantiated geotechnical data. In locations where the soil properties are not known in sufficient detail to determine the soil profile type, soil profile S3 shall be used. Soil profile S4 need not be assumed unless the Building Official determines that soil profile S4 may be present at the site, or in the event that soil profile S4 is established by geotechnical data.

Snow Load Output Examples

Snow Unbalanced (psf) 13.2 29.4 44.1 58.9 73.5 88.2 102.6
Snow Balanced (psf) 26.8 86.8 526.5 26 526.5 86.8 526.5 26.5
Snow Drift (psf) 77.8 0.0
Snow Sliding (psf) 19.8 0.0
Snow Combined (psf) 120.0 286.5
**Snow Load Output Examples**

Project: Warehouse  
Location: Anchorage  
Design Load: TM 5-809-1 1986  
Time: Thu Sep 12, 1991 1:17 PM

*************** Multiple Folded Plate Roof Snow Load Design ***************

Flat Roof Snow Load (Pf)

\[ Pf = 0.6 \cdot Ce \cdot Ct \cdot I \cdot Pg \]

- Snow Exposure Category: B
- Unheated Structure
- Importance Category: I
- \( I = 1.0 \)
- \( Pg = 45.0 \text{ psf} \)
- \( Pf = 29.16 \text{ psf} \)
- Roof Slope: 4.00 in 12

\( \theta = 18 \text{ deg} \)

Since \( \theta > 15 \text{ deg} \), min. snow load does not apply.
Since \( \theta > 1/2 \text{ in/ft} \), rain-on-snow surcharge does not apply.

\[ Pf = 29.16 \text{ psf} \]

Sloped Roof Snow Load (Ps)

\[ Ps = Cs \cdot Pf \]

- Roof Slippery: No
- \( Cs = 1.00 \)
- \( Ps = 29.16 \text{ psf} \)

Note: See Gable output for first windward and last leeward slope.

Unbalanced Snow Load (Punbal)

**Ridge**

\[ Punbal = 0.5 \cdot Pf \]

\( Punbal = 14.58 \text{ psf} \)

**Valley**

\[ Punbal = 3 \cdot Pf / Ce \]

\( Punbal = 97.20 \text{ psf} \)

Height of unbalanced load = 4.86 ft <= height of ridge = 5.00 ft

*************** Gable/Hip Roof Snow Load Design ***************

Flat Roof Snow Load (Pf)

\[ Pf = 0.6 \cdot Ce \cdot Ct \cdot I \cdot Pg \]

- Snow Exposure Category: B
- Unheated Structure
- Importance Category: I
- \( I = 1.0 \)
- \( Pg = 45.0 \text{ psf} \)
- \( Pf = 29.16 \text{ psf} \)
Roof Slope: 4.00 in 12
Theta = 18 deg
Since theta > 15 deg, min. snow load does not apply.
Since theta > 1/2 in/ft, rain-on-snow surcharge does not apply.

\[ P_f = 29.16 \text{ psf} \]

Sloped Roof Snow Load (Ps)
\[ Ps = C_s P_f \]
Roof Slippery: No
\[ C_s = 1.00 \]

\[ Ps = 29.16 \text{ psf} \]

Unbalanced Snow Load (Punbal)
Since 15 deg < theta < 70 deg, unbalanced condition applies.
\[ Punbal = 1.5 \times Ps / C_s \]

\[ Punbal = 48.60 \text{ psf} \]

Wind Load Main Force Resisting System Output Examples
Wind Load: GCpi=0 (psf)

---

Velocity Importance Exposure Width Length Roof Type

<table>
<thead>
<tr>
<th>(mph)</th>
<th>Factor</th>
<th>Exposure</th>
<th>Perpend.</th>
<th>Parallel to Wind</th>
<th>to Wind</th>
</tr>
</thead>
<tbody>
<tr>
<td>70.0</td>
<td>1.00</td>
<td>C</td>
<td>20.0</td>
<td>75.0</td>
<td></td>
</tr>
</tbody>
</table>

Distance to ocean line >= 100 mi.  h/d = 1.05 <= 5

---

Main Framing Pressures

---

**Parallel to Ridge or Length**

<table>
<thead>
<tr>
<th>Location</th>
<th>s or h</th>
<th>Gh</th>
<th>Kz</th>
<th>z /</th>
<th>Cp</th>
<th>External Pressure P (psf)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windward Wall</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>GCpi=0 -0.25 0.75</td>
</tr>
<tr>
<td>level 3</td>
<td>24.0</td>
<td>1.29</td>
<td>0.92</td>
<td>11.5</td>
<td>0.80</td>
<td>11.9</td>
</tr>
<tr>
<td>level 2 - 3</td>
<td>21.0</td>
<td>1.29</td>
<td>0.88</td>
<td>11.0</td>
<td>0.80</td>
<td>11.4</td>
</tr>
<tr>
<td>level 1 - 2</td>
<td>9.0</td>
<td>1.29</td>
<td>0.80</td>
<td>10.0</td>
<td>0.80</td>
<td>10.3</td>
</tr>
<tr>
<td>level 1</td>
<td>0.0</td>
<td>1.29</td>
<td>0.80</td>
<td>10.0</td>
<td>0.80</td>
<td>10.3</td>
</tr>
</tbody>
</table>

Leeward Wall | 21.0 | 1.29 | 0.88 | 11.0 | -0.21 | -3.0 | -0.2 | -11.2 |

Side Wall | 21.0 | 1.29 | 0.88 | 11.0 | -0.70 | -9.9 | -7.2 | -18.2 |

Roof | 21.0 | 1.29 | 0.88 | 11.0 | -0.70 | -9.9 | -7.2 | -18.2 |

Internal | 21.0 | 0.88 | 11.0 | 0.0 | -2.0 | 8.3 |
Appendix D  Wind Load Main Force Resisting System Output Examples

*********************** Wind Load - 2 ***********************

<table>
<thead>
<tr>
<th>Velocity Importance Factor</th>
<th>Exposure Width</th>
<th>Length</th>
<th>Roof Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>(mph)</td>
<td>(ft)</td>
<td>(ft)</td>
<td></td>
</tr>
<tr>
<td>70.0</td>
<td>1.00</td>
<td>C</td>
<td></td>
</tr>
</tbody>
</table>

**Main Framing Pressures ****************************

**Perpendicular to Ridge or Length**

<table>
<thead>
<tr>
<th>Location</th>
<th>z or h (ft)</th>
<th>Gh (psf)</th>
<th>Ks (psf)</th>
<th>qz (psf)</th>
<th>Cp (psf)</th>
<th>External Pressure P (psf)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windward Wall</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>level 2</td>
<td>18.0</td>
<td>1.29</td>
<td>0.84</td>
<td>10.5</td>
<td>0.80</td>
<td>10.8</td>
</tr>
<tr>
<td>level 1 - 2</td>
<td>9.0</td>
<td>1.29</td>
<td>0.80</td>
<td>10.0</td>
<td>0.80</td>
<td>10.3</td>
</tr>
<tr>
<td>level 1</td>
<td>0.0</td>
<td>1.29</td>
<td>0.80</td>
<td>10.0</td>
<td>0.80</td>
<td>10.3</td>
</tr>
<tr>
<td>Leeward Wall</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Side Wall</td>
<td>21.0</td>
<td>1.29</td>
<td>0.88</td>
<td>11.0</td>
<td>-0.50</td>
<td>-7.1</td>
</tr>
<tr>
<td>Windward Roof</td>
<td>21.0</td>
<td>1.29</td>
<td>0.88</td>
<td>11.0</td>
<td>-0.29</td>
<td>-0.29</td>
</tr>
<tr>
<td>Leeward Roof</td>
<td>21.0</td>
<td>1.29</td>
<td>0.88</td>
<td>11.0</td>
<td>-0.29</td>
<td>-4.1</td>
</tr>
<tr>
<td>Roof Parallel</td>
<td>21.0</td>
<td>1.29</td>
<td>0.88</td>
<td>11.0</td>
<td>-0.70</td>
<td>-9.9</td>
</tr>
<tr>
<td>Internal</td>
<td>21.0</td>
<td>0.88</td>
<td>11.0</td>
<td>0.0</td>
<td>-2.8</td>
<td>-2.8</td>
</tr>
</tbody>
</table>

Notes for main framing:
Positive pressures act toward surfaces.
Pressure or suction = P = q*Gh*Cp and/or P = qh*Gh*Cp-qh*(GCpi)
Wind Load Components and Cladding Output Example

---

### Wind Load Components and Cladding Output Example

---

**Project**: Industrial Building  
**Location**: Huntsville  
**Design Load**: TM 5-809-1 1986  
**Time**: Thu Sep 12, 1991 4:26 PM

---

#### Wind Load Components and Cladding Output Example

---

**Velocity Importance Exposure Width Length Room Type**  
**(mph)** | **Factor** | **Exposure** | **Width Perpend.** | **Length Parallel to Wind** | **(ft)** | **(ft)**
---|---|---|---|---|---|---
70.0 | 1.00 | C | 75.0 | 20.0

**Distance to ocean line**: $>$= 100 mi.  
**h/d**: $1.05 <= 5

**Height** | **Kh** | **qh** | **GCPi**  
---|---|---|---
21.0 | 0.88 | 11.0 | -0.25 0.75

**Height**: $<= 60$ ft

---

#### Component/Cladding Pressures (psf)

---

<table>
<thead>
<tr>
<th>Tributary</th>
<th>Windward</th>
<th>Leeward</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zone 4 middles</td>
<td>GCP P</td>
<td>GCP P</td>
</tr>
<tr>
<td>Zone 5 corners</td>
<td>GCP P</td>
<td>GCP P</td>
</tr>
<tr>
<td>Zone 4 middles</td>
<td>GCP P</td>
<td>GCP P</td>
</tr>
<tr>
<td>Zone 5 corners</td>
<td>GCP P</td>
<td>GCP P</td>
</tr>
</tbody>
</table>

**Internal**:  
-2.8  
-2.8  
8.3  
8.3

**Door**:  
100.0  
1.16  
15.5  
1.16  
15.5  
-1.26  
-22.1  
-1.47  
-24.4

**a = 3.0 ft**

**Notes for components and cladding:**  
- $P = qh(GCPi)$  
- **Internal pressures have been included in above values.**  
- *for roof overhangs: algebraically add this pressure to the above values.**  
- $P = qh(GCPi) = 0.8qh$
Wind Load Open Enclosure Output Example

Wind Load: Open Roof (psf)

---

Project: Carport
Location: Chanute AFB - Rantoul
Design Load: TM 5-809-1 1986
Time: Fri Sep 13, 1991 9:46 AM

*************** Wind Load ***************

<table>
<thead>
<tr>
<th>Velocity</th>
<th>Importance</th>
<th>Exposure</th>
<th>Width</th>
<th>Length</th>
<th>Roof Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>(mph)</td>
<td>Factor</td>
<td></td>
<td>(ft)</td>
<td>(ft)</td>
<td></td>
</tr>
<tr>
<td>70.0</td>
<td>1.00</td>
<td>C</td>
<td>68.0</td>
<td>10.0</td>
<td>Gable</td>
</tr>
</tbody>
</table>

Distance to ocean line > 100 mi.

**Open Roof Pressures (psf)**

\[ z = h = 9.25 \text{ ft} \]
\[ Gh = 1.32 \]
\[ Kz = 0.80 \]
\[ qz = 0.00256*Ks*(I*V)*(I*V) = 10.00 \text{ psf} \]
\[ Af = \frac{1}{\cos(\theta)}*B = 700.8 \text{ sqft} \]
\[ \theta = 14.0 \text{ deg} < 30 \text{ deg} \]
\[ Cf = 0.6 \]
\[ F = qz*Gh*Af \]

\[ | \text{Windward } F = 5.55 \text{ k} | \]
\[ | \text{Leeward } F = -5.55 \text{ k} | \]
Minimum Roof Live Load Output Example

Project: Industrial Building
Location: Vicksburg

Minimum Roof Live Loads (psf)

\[ X = 0.5^*L = 5.00 \text{ ft} \]
\[ w = F/Af \]

\[ +----------------------------------
| Windward \( w \) = 7.92 \text{ psf} |
+----------------------------------
| Leeward \( w \) = -7.92 \text{ psf} |
+----------------------------------

Notes for open roof pressures:
Positive pressures act toward surfaces.

Example Windward:

\[ X = 0.5^*L = 5.00 \text{ ft} \]
\[ w = F/Af \]

\[ +----------------------------------
| Windward \( w \) = 7.92 \text{ psf} |
+----------------------------------
| Leeward \( w \) = -7.92 \text{ psf} |
+----------------------------------

Design Load: TM 5-809-1 1986

*********************** Minimum Roof Live Load (Lr) ***********************

Tributary area (\( At \)) : 1200 \text{ sf}
Roof slope (F) : 3.00 in 12

\[ Lr = 20*R1*R2 >= 12 \]
\[ At >= 600 \quad R1 = 0.60 \]
\[ F <= 4 \quad R2 = 1.00 \]
\[ Lr = 12.00 \text{ psf} \]

minimum Lr = 12 psf

\[ +----------------------------------
| Lr = 12.00 \text{ psf} |
+----------------------------------

Check minimum roof live load, Lr, against minimum snow design loads.

Additionally, for the design of secondary members such as roof decking and rafters, a concentrated live load with 250 lbs uniformly distributed over an area of 2 feet square (4 sqft) will be included. The concentrated load will be located so as to produce the maximum stress in the member.
Structural Analysis And Design Output Examples

1.00 Dead (plf)

1.00 Superimposed Dead (plf)

1.00 Live (plf)

Shear (lb)

Moment (lb-ft)

Deflection

Total Combined Load

Shear (lb)

Moment (lb-ft)

Deflection
Steel Beam Selection

STEEL BEAM PRELIMINARY SELECTION

Project: Corps Office Building
Location: Viborg

Date: Oct 01, 1991

ENGR:

CASM Load & Analysis Data:

Method: Analysis

Load Combination: D + L

Member ID:

Connectivity: Hinges (Left)

Load Type | Left | Mid | Right
--- | --- | --- | ---
Roller (Right) | 10.2 | 1.7 | 1.7
Beam Span | 24.0 ft | Sup Dead | 79.5 | 13.3 | 13.3
Trib Width | 24.0 ft | Live | 121.0 | 20.2 | 20.2
Depth Limit | 21.5 in. max | Lmin Roof |  |  |  
Fy | 36.0 ksi | Snow |  |  |  
Fx = 86.0°F | 24.0 ksi | Wind |  |  |  
Fx | 14.4 ksi | Summary | 210.6 | 35.1 | 35.1

E = 29,000 ksi

Live Ld Defl: L/360 = 0.80 in
Total Defl: L/240 = 1.20 in

Max: M = 210.6 k-ft | R = 35.1 kips

CASM Beam Selection Table:

<table>
<thead>
<tr>
<th>Beam</th>
<th>Depth (in)</th>
<th>Width (in)</th>
<th>bx (in^3)</th>
<th>Sx (in^3)</th>
<th>Live Ld Defl (in)</th>
<th>Total Ld Defl (in)</th>
<th>Shear (k-lbs)</th>
<th>Bending (k-ft)</th>
<th>Weight (lbs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>W 12 x 79</td>
<td>12.4</td>
<td>12.06</td>
<td>692</td>
<td>107</td>
<td>-0.85</td>
<td>-1.14</td>
<td>6.0</td>
<td>23.5</td>
<td>1,050</td>
</tr>
<tr>
<td>W 18 x 60</td>
<td>18.2</td>
<td>7.56</td>
<td>986</td>
<td>108</td>
<td>-0.44</td>
<td>-0.77</td>
<td>4.6</td>
<td>22.4</td>
<td>1,440</td>
</tr>
<tr>
<td>W 21 x 67</td>
<td>21.1</td>
<td>6.56</td>
<td>1,170</td>
<td>111</td>
<td>-0.37</td>
<td>-0.64</td>
<td>4.1</td>
<td>22.8</td>
<td>1,060</td>
</tr>
<tr>
<td>W 14 x 74</td>
<td>14.2</td>
<td>10.07</td>
<td>796</td>
<td>112</td>
<td>-0.54</td>
<td>-0.96</td>
<td>5.5</td>
<td>22.6</td>
<td>1,776</td>
</tr>
<tr>
<td>W 16 x 67</td>
<td>16.3</td>
<td>10.24</td>
<td>954</td>
<td>117</td>
<td>-0.45</td>
<td>-0.79</td>
<td>5.4</td>
<td>21.8</td>
<td>1,600</td>
</tr>
</tbody>
</table>

CASM Steel Beam Selection:

W 21 x 67 | Span= 24.0 ft | bx = 1,170 | Sx = 111 | Defl (in): -0.37 | -0.64 |

N= 4.1 | L= 3.8 | Beam Width (mils) = 0.86

Notes:

Appendix D

Structural Analysis And Design Output Examples

1.00 Dead (plf)

1.00 Superimposed Dead (plf)

1.00 Snow (plf)

D - 14
Structural Analysis And Design Output Examples

Appendix D

Snow Load — Loads & Reactions (lb)

<table>
<thead>
<tr>
<th>Story</th>
<th>Roof</th>
<th>1st Floor</th>
<th>2nd Floor</th>
<th>3rd Floor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Self Weight</td>
<td>1.0</td>
<td>1.0</td>
<td>1.0</td>
<td>1.0</td>
</tr>
<tr>
<td></td>
<td>40.0</td>
<td>30.0</td>
<td>20.0</td>
<td>10.0</td>
</tr>
<tr>
<td></td>
<td>1.1</td>
<td>1.1</td>
<td>1.1</td>
<td>1.1</td>
</tr>
</tbody>
</table>

Total Combined Load — Sum (kif)
Lateral Resistance Element Output Example

---

100 Wind (klf)
Lateral Resistance Element Output Example

Total Combined Load — Axial (k)

Total Combined Load — Shear (k)

Total Combined Load — Moment (kft)
Appendix D  Lateral Resistance Element Output Example

Total Combined Load -- Deflection

Total Combined Load -- Loads & Reactions (k)

1.00 Wind (klf) -- WS-2 -- 42% 42%

D - 18
**Lateral Resistance Element Output Example**

**Project:** Lateral Example 4  
**Location:** Amoco Plant  
**Time:** Wed Sep 25, 1991 2:00 PM

************** Rigid Horizontal Diaphragm Calculations ***************

---

### NS-1

**Level Height:** 12.0 ft

<table>
<thead>
<tr>
<th>Name</th>
<th>t</th>
<th>l</th>
<th>Area (ft²)</th>
<th>Arm (ft)</th>
<th>NS Moment (ft·lb)</th>
<th>EW Moment (ft·lb)</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS-1</td>
<td>1.00</td>
<td>40.00</td>
<td>40.0</td>
<td>20.00</td>
<td>800</td>
<td>0.00</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td></td>
<td>40.0</td>
<td>800</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

Centroid = \( \frac{\text{sum(MomentArea)}}{\text{sum(Area)}} \)

NS Centroid = 20.00 ft  
EW Centroid = 0.00 ft

**Area:** 40.00 sqft

<table>
<thead>
<tr>
<th>Name</th>
<th>b</th>
<th>h</th>
<th>12 (ft)</th>
<th>Area (ft²)</th>
<th>d</th>
<th>Ad² (ft²)</th>
<th>I+Ad² (ft⁴)</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS-1</td>
<td>1.00</td>
<td>40.00</td>
<td>5333</td>
<td>40.0</td>
<td>0.00</td>
<td>0</td>
<td>5333</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>5333</td>
</tr>
</tbody>
</table>

Deflection = 0.084 in  
**Height:** 12.0 ft

Total Deflection: 0.084 in

---

### NS-2

**Level Height:** 24.0 ft

Same As Previous Level

**NS Centroid:** 20.00 ft  
**EW Centroid:** 0.00 ft

**Area:** 40.00 sqft  
**Moment of Inertia:** 5333 ft^4

Deflection = 0.084 in  
**Height:** 12.0 ft

Total Deflection: 0.168 in

---

### NS-3

**Level Height:** 12.0 ft

Same As NS-1

**NS Centroid:** 20.00 ft  
**EW Centroid:** 0.00 ft

**Area:** 20.00 sqft

<table>
<thead>
<tr>
<th>Name</th>
<th>t</th>
<th>l</th>
<th>Area (ft²)</th>
<th>Arm (ft)</th>
<th>NS Moment (ft·lb)</th>
<th>EW Moment (ft·lb)</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS-3</td>
<td>1.00</td>
<td>20.00</td>
<td>20.0</td>
<td>10.00</td>
<td>200</td>
<td>0.00</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td></td>
<td>20.0</td>
<td>200</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>

---
Appendix D

Lateral Resistance Element Output Example

Centroid = \( \frac{\text{sum(Moment Area)}}{\text{sum(Area)}} \)

<table>
<thead>
<tr>
<th>Name</th>
<th>b (ft)</th>
<th>h (ft)</th>
<th>Area (ft^2)</th>
<th>d (ft^2)</th>
<th>Ad (ft^4)</th>
<th>I+Ad (ft^4)</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS-3</td>
<td>1.00</td>
<td>20.00</td>
<td>667</td>
<td>20.0</td>
<td>0.30</td>
<td>667</td>
</tr>
</tbody>
</table>

Moment of Inertia: \( bh^3/6 \)

**Deflection**: 0.222 in  **Height**: 12.0 ft  **Total Deflection**: 0.222 in

**Level Height**: 24.0 ft

Same As Previous Level

**Deflection**: 0.222 in  **Height**: 12.0 ft  **Total Deflection**: 0.444 in

Center of Rigidity

<table>
<thead>
<tr>
<th>Name</th>
<th>h (ft)</th>
<th>I (ft^4)</th>
<th>Av Deflection Rigidity</th>
<th>R/sum(R)</th>
<th>x (ft)</th>
<th>R*x (ft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>MS-1</td>
<td>24.0</td>
<td>5333</td>
<td>40</td>
<td>0.168</td>
<td>5.952</td>
<td>42.05%</td>
</tr>
<tr>
<td>NS-2</td>
<td>24.0</td>
<td>5333</td>
<td>40</td>
<td>0.168</td>
<td>5.952</td>
<td>42.05%</td>
</tr>
<tr>
<td>NS-3</td>
<td>24.0</td>
<td>667</td>
<td>20</td>
<td>0.444</td>
<td>2.252</td>
<td>15.91%</td>
</tr>
</tbody>
</table>

**Centroid from lower left** = \( \frac{\text{sum(R*x)}}{\text{sum(R)}} \) : 29.55 ft

**Maximum dimension** : 80.00 ft

Eccentricity (e) = centroid-(max dimension)/2 : 10.45 ft

Eccentricity (e) used for torsional analysis : 10.45 ft

Eccentricity (e) considered only for seismic analysis.

<table>
<thead>
<tr>
<th>Name</th>
<th>h (ft)</th>
<th>I (ft^4)</th>
<th>Av Deflection Rigidity</th>
<th>R/sum(R)</th>
<th>x (ft)</th>
<th>R*x (ft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS-1</td>
<td>24.0</td>
<td>5333</td>
<td>40</td>
<td>0.168</td>
<td>5.952</td>
<td>42.05%</td>
</tr>
<tr>
<td>NS-2</td>
<td>24.0</td>
<td>5333</td>
<td>40</td>
<td>0.168</td>
<td>5.952</td>
<td>42.05%</td>
</tr>
<tr>
<td>NS-3</td>
<td>24.0</td>
<td>667</td>
<td>20</td>
<td>0.444</td>
<td>2.252</td>
<td>15.91%</td>
</tr>
</tbody>
</table>

**Centroid from lower left** = \( \frac{\text{sum(R*x)}}{\text{sum(R)}} \) : 29.55 ft

**Maximum dimension** : 80.00 ft

Eccentricity (e) = centroid-(max dimension)/2 : 10.45 ft

Eccentricity (e) used for torsional analysis : 10.45 ft

Eccentricity (e) considered only for seismic analysis.
Seismic Output Example

Assumptions used:

\[ E_m = 144,000 \text{ ksf} \]
\[ E_v = 0.4 \times E_m = 57,600 \text{ ksf} \]

All wall thicknesses are equal.

Deflections calculated by applying a 1,000 kip load.

Interstory shear wall deflection is calculated based on cantilever action. Deflection at a level is obtained by summing each story's cantilever deflection from grade.

\[ \text{Deflection} = \frac{P(h^3)}{3 \times E_m I} + \frac{(1.2 \times P \times h)}{(A \times E_v)} \]

\( h \) = floor to floor height

<table>
<thead>
<tr>
<th>Name</th>
<th>( h )</th>
<th>Rigidity</th>
<th>( dx )</th>
<th>( R \times dx )</th>
<th>( R \times dx^2 )</th>
<th>( R \times dx^3 )</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS-1</td>
<td>12.0</td>
<td>11.905</td>
<td>29.5</td>
<td>351.732</td>
<td>10392.070</td>
<td>0.01519</td>
</tr>
<tr>
<td>NS-2</td>
<td>12.0</td>
<td>11.905</td>
<td>10.5</td>
<td>124.459</td>
<td>1301.161</td>
<td>0.00537</td>
</tr>
<tr>
<td>NS-3</td>
<td>12.0</td>
<td>4.505</td>
<td>50.5</td>
<td>227.273</td>
<td>11466.942</td>
<td>0.00981</td>
</tr>
</tbody>
</table>

Sum 23160.173

<table>
<thead>
<tr>
<th>Name</th>
<th>( h )</th>
<th>Rigidity</th>
<th>( dx )</th>
<th>( R \times dx )</th>
<th>( R \times dx^2 )</th>
<th>( R \times dx^3 )</th>
</tr>
</thead>
<tbody>
<tr>
<td>NS-1</td>
<td>24.0</td>
<td>5.952</td>
<td>29.5</td>
<td>175.866</td>
<td>5196.035</td>
<td>0.01519</td>
</tr>
<tr>
<td>NS-2</td>
<td>24.0</td>
<td>5.952</td>
<td>10.5</td>
<td>62.229</td>
<td>650.580</td>
<td>0.00537</td>
</tr>
<tr>
<td>NS-3</td>
<td>24.0</td>
<td>2.252</td>
<td>50.5</td>
<td>113.636</td>
<td>5733.471</td>
<td>0.00981</td>
</tr>
</tbody>
</table>

Sum 11580.087

Shear distribution:
\[ F_v = \frac{V \times R}{\text{sum}(R)} \]

Torsional moment:
\[ M_t = V \times e \]

Torsional component:
\[ F_t = \frac{M_t \times R \times dx}{\text{sum}(R \times dx^2)} \]

Total shear to element:
\[ F_{total} = F_v + F_t \]

Seismic Output Example

<table>
<thead>
<tr>
<th>1</th>
<th>20.0</th>
<th>2</th>
<th>20.0</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.75</td>
<td>8.75 k</td>
<td>0.00 k</td>
<td>0.00 k</td>
<td>12.0</td>
</tr>
<tr>
<td></td>
<td>8.75 k</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5.86</td>
<td>14.59 k</td>
<td>222.50 k</td>
<td>0.97 k</td>
<td>15.55 k</td>
</tr>
<tr>
<td></td>
<td>14.59 k</td>
<td>222.50 k</td>
<td>0.97 k</td>
<td></td>
</tr>
<tr>
<td></td>
<td>15.55 k</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1.00 Seismic (klf) -- NS-2 -- F. 41%
Project: Seismic Example 1
Location: Savannah
Seismic Code: TM 5-809-10 1991
Time: Wed Oct 09, 1991 4:02 PM

*************** Seismic Lateral Resistance Locations **************

<table>
<thead>
<tr>
<th>Level</th>
<th>Floor (ft)</th>
<th>F (k)</th>
<th>V (k)</th>
<th>OTM (k)</th>
<th>sum(OTM) (kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>24.0</td>
<td>14.0</td>
<td>14.0</td>
<td>168</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>12.0</td>
<td>14.4</td>
<td>28.4</td>
<td>341</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>0.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Sum</td>
<td>28.4</td>
<td></td>
<td></td>
<td>509</td>
<td></td>
</tr>
</tbody>
</table>

Project: Seismic Example 1
Location: Savannah

*************** Center Of Mass ***************

------------
Roof -- 24.00 ft
### Seismic Output Example

#### Appendix D

<table>
<thead>
<tr>
<th>Name</th>
<th>Weight (k)</th>
<th>NS (ft)</th>
<th>NS*Weight (kft)</th>
<th>EW (ft)</th>
<th>EW*Weight (kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall Type 1</td>
<td>18.7</td>
<td>20.0</td>
<td>374.4</td>
<td>0.0</td>
<td>0.0</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>9.4</td>
<td>40.0</td>
<td>374.4</td>
<td>10.0</td>
<td>93.6</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>18.7</td>
<td>20.0</td>
<td>374.4</td>
<td>40.0</td>
<td>748.8</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>9.4</td>
<td>10.0</td>
<td>93.6</td>
<td>80.0</td>
<td>748.8</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>4.7</td>
<td>0.0</td>
<td>0.0</td>
<td>75.0</td>
<td>351.0</td>
</tr>
<tr>
<td>Roof Type 1</td>
<td>67.2</td>
<td>20.0</td>
<td>1344.0</td>
<td>40.0</td>
<td>2688.0</td>
</tr>
<tr>
<td>Beam Self Weight</td>
<td>6.2</td>
<td>20.0</td>
<td>124.0</td>
<td>40.0</td>
<td>248.0</td>
</tr>
<tr>
<td>Column Self Weight</td>
<td>0.9</td>
<td>20.0</td>
<td>17.3</td>
<td>40.0</td>
<td>34.6</td>
</tr>
</tbody>
</table>

Sum: 135.1 2702.1 4912.8

N-S Center Of Mass: 20.00 ft
E-W Center Of Mass: 36.36 ft

---

### Second Floor -- 12.00 ft

<table>
<thead>
<tr>
<th>Name</th>
<th>Weight (k)</th>
<th>NS (ft)</th>
<th>NS*Weight (kft)</th>
<th>EW (ft)</th>
<th>EW*Weight (kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall Type 1</td>
<td>37.4</td>
<td>20.0</td>
<td>748.8</td>
<td>0.0</td>
<td>0.0</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>18.7</td>
<td>40.0</td>
<td>748.8</td>
<td>10.0</td>
<td>187.2</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>37.4</td>
<td>20.0</td>
<td>748.8</td>
<td>40.0</td>
<td>1497.6</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>18.7</td>
<td>10.0</td>
<td>187.2</td>
<td>80.0</td>
<td>1497.6</td>
</tr>
<tr>
<td>Wall Type 1</td>
<td>9.4</td>
<td>0.0</td>
<td>0.0</td>
<td>75.0</td>
<td>702.0</td>
</tr>
<tr>
<td>Floor Type 1</td>
<td>148.2</td>
<td>20.0</td>
<td>2963.2</td>
<td>40.0</td>
<td>5926.4</td>
</tr>
<tr>
<td>Beam Self Weight</td>
<td>6.2</td>
<td>20.0</td>
<td>124.0</td>
<td>40.0</td>
<td>248.0</td>
</tr>
<tr>
<td>Column Self Weight</td>
<td>1.7</td>
<td>20.0</td>
<td>34.6</td>
<td>40.0</td>
<td>69.1</td>
</tr>
</tbody>
</table>

Sum: 277.8 5555.4 10127.9

N-S Center Of Mass: 20.00 ft
E-W Center Of Mass: 36.46 ft

---

Project: Seismic Example 1
Location: Savannah
Seismic Code: TM 5-809-10 1991
Time: Wed Oct 09, 1991 4:02 PM

*************** Seismic Lateral Resistance Locations ***************

<table>
<thead>
<tr>
<th>Level</th>
<th>h (ft)</th>
<th>Floor h (ft)</th>
<th>F (k)</th>
<th>Φ (k)</th>
<th>OTM (kft)</th>
<th>sum(OTM) (kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>24.0</td>
<td>12.0</td>
<td>14.0</td>
<td>14.0</td>
<td>168</td>
<td>168</td>
</tr>
<tr>
<td>2</td>
<td>12.0</td>
<td>14.4</td>
<td>28.4</td>
<td>341</td>
<td>509</td>
<td>509</td>
</tr>
</tbody>
</table>

Sum: 28.4 509

NS-2 -- F, 41%

---

D - 23
### Quantity Take-Off Output Example:

<table>
<thead>
<tr>
<th>Level</th>
<th>Floor to Sum</th>
<th>F(ft)</th>
<th>V(k)</th>
<th>OTM(kft)</th>
<th>Sum OTM(kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>24.0</td>
<td>12.0</td>
<td>14.0</td>
<td>14.0</td>
<td>341</td>
</tr>
<tr>
<td>2</td>
<td>12.0</td>
<td>12.0</td>
<td>14.4</td>
<td>20.4</td>
<td>341</td>
</tr>
<tr>
<td>1</td>
<td>0.0</td>
<td>12.0</td>
<td>28.4</td>
<td>28.4</td>
<td>509</td>
</tr>
</tbody>
</table>

**Sum**: 28.4 509

---

### Quantity Take-Off Output Example:

<table>
<thead>
<tr>
<th>Level</th>
<th>Floor to Sum</th>
<th>F(ft)</th>
<th>V(k)</th>
<th>OTM(kft)</th>
<th>Sum OTM(kft)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>24.0</td>
<td>12.0</td>
<td>14.0</td>
<td>14.0</td>
<td>341</td>
</tr>
<tr>
<td>2</td>
<td>12.0</td>
<td>12.0</td>
<td>14.4</td>
<td>20.4</td>
<td>341</td>
</tr>
<tr>
<td>1</td>
<td>0.0</td>
<td>12.0</td>
<td>28.4</td>
<td>28.4</td>
<td>509</td>
</tr>
</tbody>
</table>

**Sum**: 28.4 509

---

### Quantity Take-Off Output Example:

- **Project**: Bank - Scheme C
- **Location**: Champaign
- **Time**: Mon Sep 30, 1991 12:56 PM

---

**Roof - 2**

- **Plan Area**: 24.0 ft x 24.0 ft: 576.0 sqft
### Floor - 1

Plan Area: 24.0 ft x 24.0 ft; 576.0 sqft

**STEEL: Widely Spaced Elements**

<table>
<thead>
<tr>
<th>Description</th>
<th>Weight/ Element</th>
<th>Total Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Length (ft)</td>
<td>Weight (plf)</td>
</tr>
<tr>
<td>W 16 x 40 (58)</td>
<td>24.0 40.0</td>
<td>960.0</td>
</tr>
<tr>
<td>W 12 x 19 (20)</td>
<td>24.0 19.0</td>
<td>456.0</td>
</tr>
</tbody>
</table>

**Sum**

Total Weight: 1.2 tons

Weight Per Square Foot: 4.0 psf

Number of Shear Studs: 116

**STEEL: Surface Elements**

<table>
<thead>
<tr>
<th>Description</th>
<th>Total Depth (in)</th>
<th>Area (sqft)</th>
<th>Weight (pcf)</th>
<th>Weight (psf)</th>
<th>Conc Total Weight (lbs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2&quot; - 20 ga + 2-1/2&quot; Conc.</td>
<td>4.5 576</td>
<td>2.0 145.0</td>
<td>40.0</td>
<td>0.0</td>
<td>1152 23040</td>
</tr>
</tbody>
</table>

**Sum**

Concrete Cubic Yards: 5.9

Total Weight: 0.6 tons
ABOUT CASM 4-63
Actual Properties 8-2
Add Main Grid 4-114
Add Opening 4-115
Add Sub Grid 4-114
Advanced User 1-4
Analysis
  Column Elements 4-209
  Lateral Resistance 4-223
  Linear Elements 4-195
  Load Run Down Hints 8-3
  Re-analyzing Adjoining Members 8-2
  Surface Elements 4-191
  Truss Elements 4-203
  Wall Elements 4-212
Application programs 3-46 - 3-50
Arch 4-126
Area and Linear dead loads 4-151
AUTOCAD.DXF 4-28, 4-32, 10-8

Beam Weight Program 3-49, 11-1
Beams All Grid Lines 4-122
Beginning User 1-4

CASM 0-x1, 3-5
  File Contents B-1
  Program Precautions 12-1
  Program Window 3-5 - 3-7
  Running the program 3-8 - 3-11
CASM OUTPUT 10-1 - 10-8
CASM SETTINGS 4-33
CEILING (DL) 4-151
Click 1-6
  Double 1-6
CLOSE 4-10
COL/WALL 4-134
COL/WALL MENU 4-188
Column
  One Grid Intersection 4-129
  Column
    All Grid Intersections 4-128
  Column Element Analysis 4-209
  Column/Wall Menu 4-127, 4-188
  Compare Min Roof LL & Snow Load 4-232
  Compare Wind & Seismic 4-234
  Concrete 4-184
  CONTROL MENU 4-6 - 4-15
  Conventions 1-5 - 1-8
  Coordinate input 3-20
  Copy Design 4-146
  Copy Lateral Vertical Elements 4-106
  Copy Structure 4-99
    Hints 6-2
  Creating Floor Planes 4-69, 5-3
  CRITERIA MENU 4-47 - 4-57

D
Define Grid 4-110
Define Ground Plane 4-85
Define Units 4-86
Delete Grid Line 4-102
Delete Horizontal Diaphragm 4-107
Delete Lateral Vertical Location 4-106
Delete Load 4-145
Delete Opening 4-104
Delete Shape 4-78
Delete Structure 4-101
Design
  Lateral Resistance 4-223
    Preliminary 4-190
    Quantity Take-off 4-235
DESIGN MENU 4-190
Designer Program 10-6
Dialog Windows 3-12 - 3-16
Diaphragm Guidelines 4-141
Direction keys 1-5
Drag 1-6
Drag Edge 4-75
Drag Plane 4-76, 5-2
Drag Vertex 4-74
DRAW MODEL 4-65 - 4-133
Draw Program 10-6
DRAW STRUCTURE 4-96 - 4-133
Draw Structure Tool Palette 4-85
DRAW STRUCTURE WINDOW 4-95
Duplicate Shape 4-81
INDEX

E
E and I Values 8-2
Earth Loads 4-183
EDIT MENU
LOADS 4-145
MODEL 4-72
Structure 4-98
Elevation 4-41
Error Messages 12-2 - 12-3
CASM Fatal Errors 12-2
Corrective Action 12-4
Windows Fatal Errors 12-2
Error signal 12-4
Excel
Member Sizing 4-216
Ponding 9-8
Pull down Menus 9-4 - 9-8
Scratchpad 4-219
Sizing members 3-39 - 3-42
Spreadsheet Format 9-1 - 9-3
Vibration Check 9-7
EXIT 4-35
EXPORT 4-31

F
FILE MENU 4-16 - 4-36
Flexible Diaphragm 4-139
FLOOR (DL) 4-151
Footing 4-133
Frame Program 3-49, 11-2
FULL SCREEN 4-45

G
Getting Started 3-1 - 3-4
Grid Lines
Hints 8-4
GRID/OPENING 4-109
Grid/Opening Menu 4-109
Grid Two-Way 4-126
Ground Plane
Rotated 5-7

H
HELP CONTENTS 4-59
HELP MENU 4-58 - 4-64
Hide Object 5-8
Hide Shape 4-45
Horizontal Lateral Resistance
Define Area 4-140
Entire Plane 4-139
Flexible Diaphragm 4-139
Rigid Diaphragm 4-139
Horizontal Structural Plane 4-42
HOW TO USE HELP 4-62
Icons Program 11-7
IMPORT 4-30
Inclined Structural Plane 4-42
Initial Shape Size 4-89
Installation 2-5 - 2-8
Keyboard Input 3-25
Lateral - Horizontal
Flexible Diaphragm 4-139
Lateral - Horizontal Diaphragm
Copy Elements 4-141
Diaphragm Guidelines 4-140
Rigid Diaphragm 4-139
Lateral - Vertical
Define Elements 4-136
Define Location 4-135
Lateral Load Resistance 4-52
Lateral Menu 4-134
Lateral Resistance
Analysis 4-223
Input File 4-230
LAYOUT MENU 4-84
Learning Windows 3-48
Linear Element Analysis 4-195
Linear Elements 4-119
Hints 6-1
Load Combinations 4-149
LOADS AND DESIGN 4-143 - 4-185
Column Elements 4-209
Hints 7-1
Linear Elements 4-195
Surface Elements 4-191
Truss Elements 4-203
Wall Elements 4-212
LOADS MENU 4-149
Loads Program 3-49, 11-2 - 11-6
<table>
<thead>
<tr>
<th>INDEX</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>M</strong></td>
</tr>
<tr>
<td>Masonry 4-184</td>
</tr>
<tr>
<td>MAT'L MENU 4-184</td>
</tr>
<tr>
<td>MAXIMIZE 4-10</td>
</tr>
<tr>
<td>Member Self Weights 6-1</td>
</tr>
<tr>
<td>Member Sizing 4-216</td>
</tr>
<tr>
<td>Menus 3-12 - 3-16</td>
</tr>
<tr>
<td>MIN ROOF (LL) 4-162</td>
</tr>
<tr>
<td>MINIMIZE 4-9</td>
</tr>
<tr>
<td>Model Views 4-41</td>
</tr>
<tr>
<td>MODELING 5-1 - 5-10</td>
</tr>
<tr>
<td>Floor Plans 5-3</td>
</tr>
<tr>
<td>Ground Plane Angle 5-6</td>
</tr>
<tr>
<td>Open Roofs 5-9</td>
</tr>
<tr>
<td>Overhangs 5-5</td>
</tr>
<tr>
<td>Simplify 5-1</td>
</tr>
<tr>
<td>Structural Bays 5-5</td>
</tr>
<tr>
<td>Two-story spaces 5-4</td>
</tr>
<tr>
<td>Modeling Hints 4-68</td>
</tr>
<tr>
<td>Modify Design 4-147</td>
</tr>
<tr>
<td>Modify Loads 4-146</td>
</tr>
<tr>
<td>Modify Opening 4-104</td>
</tr>
<tr>
<td>Modify Structure 4-101</td>
</tr>
<tr>
<td>MOMENT (DL) 4-156</td>
</tr>
<tr>
<td>MOMENT (LL) 4-156</td>
</tr>
<tr>
<td>Mouse</td>
</tr>
<tr>
<td>Double-click 3-22</td>
</tr>
<tr>
<td>Speed 3-22</td>
</tr>
<tr>
<td>Mouse, Use of</td>
</tr>
<tr>
<td>Input 3-21</td>
</tr>
<tr>
<td>MOVE 4-8</td>
</tr>
<tr>
<td>Move Grid Line 4-103</td>
</tr>
<tr>
<td>Move Reference 4-94</td>
</tr>
<tr>
<td>Move Shape 4-78</td>
</tr>
<tr>
<td><strong>N</strong></td>
</tr>
<tr>
<td>Narrowly-Spaced 4-120</td>
</tr>
<tr>
<td>NEW 4-17</td>
</tr>
<tr>
<td>Notepad Program 10-4</td>
</tr>
<tr>
<td><strong>O</strong></td>
</tr>
<tr>
<td>OCCUPANCY (LL) 4-159</td>
</tr>
<tr>
<td>OPEN 4-18</td>
</tr>
</tbody>
</table>

| **P** |
| Pan 4-43 |
| Parapet 4-69, 5-3 |
| Paste Structure 4-100 |
| Perspective (3D) 4-41 |
| Pileaeter 4-133 |
| Plan 4-41 |
| Point 1-6 |
| POINT (DL) 4-156 |
| POINT (LL) 4-156 |
| Point loads and moments 4-155 |
| Pop-up dialog windows 3-14 |
| Preliminary Design 4-190 |
| Preliminary Member Size 4-216 |
| Print |
| Printing CASM Output 10-1 - 10-3 |
| Printing output from other programs 10-3 |
| PRINT DATA 4-22 |
| Print Manager 10-1 |
| PRINT SCREEN 4-26 |
| Printer |
| Changing Printers 10-3 |
| Setup 10-3 |
| Printer Set Up 4-30 |
| Productivity Pack 3-48 |
| Program Requirements 2-1 - 2-4 |
| PROJECT 4-49 |
| Pull-down menu bar 3-12 |
| **Q** |
| Quantity Take-off |
| Design 4-235 |
| **R** |
| RECALL VIEW 4-46 |
| Reference |
| Menu 4-93 |
| Move 4-94 |
| Rotate 4-95 |
| View 4-93 |
| REFERENCE MENU 4-93 |
| REGIONAL 4-53 |
| RESTORE 4-7 |
| Rigid Diaphragm 4-139 - 4-140 |
| ROOF (DL) 4-151 |
| Rotate Reference 4-95 |
| Rotate Shape 4-79 |
| Rotated Ground Plane 5-7 |
INDEX

RUN 4-14
Running the Program 3-8 - 3-11

S
SAVE 4-20
SAVE AS 4-21
Saving work
output files 3-30 - 3-35
project files 3-29
SEARCH FOR HELP ON 4-61
Section 4-41
Seismic
Lateral Load Resistance 4-52
Zone Factor 4-54
SEISMIC LOADS 4-176
Selecting Coordinate Input Mode 3-20
SendXL 3-40, 4-217, 4-222
SETTINOS 4-33
Setup 2-5, 2-7
SHAPES MENU 4-87
Show Ground Plane 4-85
Show Loads 4-39
Show Object 5-8
Show Shapes 4-45
Show Structure 4-40
SITE 4-55
SIZE 4-9
Slice 5-2
Slice Shape 4-60
SNAP TO GRID 4-88
SNAP TO REFERENCE 4-88
Snap to Units 4-87
SNOW LOADS 4-164
Solid 4-44
Spreadsheet
File Menu 9-4
Format 9-1 - 9-3
Guidelines Menu 9-8
Member Menu 9-5
Ponding 9-8
Pull-down menu 9-4 - 9-8
Scratchpad Menu 9-6
Vibration Check 9-7
Stack on Ground 4-90
Stack on Last Shape 4-90
Stack on Plane 4-91, 5-2
Stack Underground 4-91
Starting CASM
DOS Method 3-3
Windows Method 3-1
Steel 4-184
Stopping CASM 3-43 - 3-45
STORE VIEW 4-45
Structural Plane
Hints 6-1
Horizontal 4-42
Inclined 4-42
Vertical 4-43
Structural Plane Information 4-38
Structural Walls
Hints 6-3
Surf/Line MENU 4-185
Surface Element Analysis 4-191
Surface Elements
Analysis Hints 6-3
Hints 6-4
Surface One-Way 4-118
Surface Two-Way 4-118
Surface/Linear Menu 4-117, 4-185
SWITCH TO 4-12
T
Tape Measure 4-82, 4-107
Temperature Loads 4-183
Tool Palette
Bottom 4-2
Tool Palette Windows 3-13
Transparent 4-44
Trouble Shooting 3-48
Truss Custom 4-123
Truss Element Analysis 4-203
U
UNDO 4-74, 4-99, 4-145
V
Vertical Structural Plane 4-43
VIEW
RECALL 4-46
STORE 4-45
View Menu 3-19, 4-37
View Previous 4-44
View Reference 4-93
Viewpoint Tools 3-17, 4-3 - 4-5
INDEX

W
WALL (DL) 4-151
Wall 2-Grid Points 4-131
Wall Element Analysis 4-212
Widely Spaced 4-120
WIND LOADS 4-169
Windows
   Productivity Pack 3-48
Wireframe 4-44
Wood 4-184
Working Smarter 3-48
Write Program 10-5

Z
Zoom 4-5
ZOOM WINDOW 4-43
The Computer-Aided Structural Modeling (CASM) computer program is designed to aid the structural engineer in the preliminary design and evaluation of structural building systems by the use of three-dimensional (3-D) interactive graphics. CASM allows the structural engineer to quickly evaluate various framing alternatives in order to make more informed decisions in the initial structural evaluation process. The program was developed by the Information Technology Laboratory in conjunction with the Computer Aided Structural Engineering (CASE) Project, Building Systems Task Group.

This release of the CASM is designed to aid the user with design criteria, building loads, and structural framing and design. The various parts of the program are summarized below:

a. Basic design criteria. The user can enter information directly or retrieve information from a user-definable database. The design criteria include information about the project, regional design information, and site-specific design information.

b. Building geometry. The user can assemble the building shape using 3-D primitives (cubes, prisms, spheres, cylinders, etc.) in an easy manner using pull-down menus, icons, and a mouse.

c. Dead and live loads. The user can select and construct dead and live loads from several user-definable menus of building materials and load conditions. These loads can then be applied to any desired area of the building volume.
13. (Concluded).

d. Snow and wind loads. These loads are automatically calculated in 3-D using information from the basic design criteria database. Wind loads are also calculated for components and cladding and open roof structures. These loads are calculated in accordance with TM 5-809-1.

e. Seismic loads. These loads are calculated based on the equivalent static force method presented in TM 5-809-10.

f. Structural layout. The engineer can easily and rapidly experiment with various framing schemes inside the defined building volume. Beams, girders, joists, girts, columns, walls, and custom trusses are some of the structural elements that can be modeled.

g. Member analysis and preliminary sizing. The user can apply loads to the building geometry from a list of user-defined load cases. The shear, moment, and deflection of selected members may be calculated for various loading conditions (including pattern loads) and connectivity (including continuous beams). The design of a member is performed using a spreadsheet.

Data from the various investigated framing schemes can be edited and printed by CASM and used as justification in a design document.
<table>
<thead>
<tr>
<th>Title</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instruction Report K-80-3 A Three-Dimensional Finite Element Data Edit Program</td>
<td>Mar 1980</td>
</tr>
<tr>
<td>Report 3: General Analysis Module (CGAM)</td>
<td>Jun 1982</td>
</tr>
<tr>
<td>Instruction Report</td>
<td>Title</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------</td>
</tr>
<tr>
<td>K-83-5</td>
<td>User’s Guide: Computer Program to Calculate Shear, Moment, and Thrust (CSMT) from Stress Results of a Two-Dimensional Finite Element Analysis</td>
</tr>
<tr>
<td>K-83-1</td>
<td>Basic Pile Group Behavior</td>
</tr>
<tr>
<td>K-83-4</td>
<td>Case Study of Six Major General-Purpose Finite Element Programs</td>
</tr>
<tr>
<td>K-84-8</td>
<td>Seepage Analysis of Confined Flow Problems by the Method of Fragments (CFRAG)</td>
</tr>
<tr>
<td>K-84-3</td>
<td>Computer-Aided Drafting and Design for Corps Structural Engineers</td>
</tr>
<tr>
<td>ATC-86-5</td>
<td>Decision Logic Table Formulation of ACI 318-77, Building Code Requirements for Reinforced Concrete for Automated Constraint Processing, Volumes I and II</td>
</tr>
<tr>
<td>ITL-87-2</td>
<td>A Case Committee Study of Finite Element Analysis of Concrete Flat Slabs</td>
</tr>
<tr>
<td>ITL-87-1</td>
<td>User’s Guide: Computer Program for Two-Dimensional Analysis of U-Frame Structures (CUFRAM)</td>
</tr>
<tr>
<td>ITL-87-2</td>
<td>User’s Guide: For Concrete Strength Investigation and Design (CASTR) in Accordance with ACI 318-83</td>
</tr>
<tr>
<td>ITL-87-6</td>
<td>Finite-Element Method Package for Solving Steady-State Seepage Problems</td>
</tr>
<tr>
<td>Title</td>
<td>Date</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Instruction Report ITL-87-4 User’s Guide: 2-D Frame Analysis Link Program (LINK2D)</td>
<td>Jun 1987</td>
</tr>
<tr>
<td>Technical Report ITL-87-4 Finite Element Studies of a Horizontally Framed Miter Gate</td>
<td>Aug 1987</td>
</tr>
<tr>
<td>Report 1: Initial and Refined Finite Element Models (Phases A, B, and C), Volumes I and II</td>
<td></td>
</tr>
<tr>
<td>Report 2: Simplified Frame Model (Phase D)</td>
<td></td>
</tr>
<tr>
<td>Report 3: Alternate Configuration Miter Gate Finite Element Studies—Open Section</td>
<td></td>
</tr>
<tr>
<td>Report 4: Alternate Configuration Miter Gate Finite Element Studies—Closed Sections</td>
<td></td>
</tr>
<tr>
<td>Report 5: Alternate Configuration Miter Gate Finite Element Studies—Additional Closed Sections</td>
<td></td>
</tr>
<tr>
<td>Report 6: Elastic Buckling of Girders in Horizontally Framed Miter Gates</td>
<td></td>
</tr>
<tr>
<td>Report 7: Application and Summary</td>
<td></td>
</tr>
<tr>
<td>Instruction Report ITL-87-5 Sliding Stability of Concrete Structures (CSLIDE)</td>
<td>Oct 1987</td>
</tr>
<tr>
<td>Instruction Report ITL-87-6 Criteria Specifications for and Validation of a Computer Program for the Design or Investigation of Horizontally Framed Miter Gates (CMITER)</td>
<td>Dec 1987</td>
</tr>
<tr>
<td>Title</td>
<td>Date</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>Volume A: Program Criteria and Documentation</td>
<td></td>
</tr>
<tr>
<td>Volume B: User's Guide for Basins</td>
<td></td>
</tr>
<tr>
<td>Volume C: User's Guide for Channels</td>
<td></td>
</tr>
<tr>
<td>Instruction Report ITL-92-3 Concept Design Example, Computer Aided Structural Modeling (CASM)</td>
<td></td>
</tr>
<tr>
<td>Report 1: Scheme A</td>
<td>Jun 1992</td>
</tr>
<tr>
<td>Report 2: Scheme B</td>
<td>Jun 1992</td>
</tr>
<tr>
<td>Report 3: Scheme C</td>
<td>Jun 1992</td>
</tr>
</tbody>
</table>

(Continued)
<table>
<thead>
<tr>
<th>Title</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optimization of Steel Pile Foundations Using Optimality Criteria</td>
<td>Jun 1992</td>
</tr>
<tr>
<td>Refined Stress Analysis of Melvin Price Locks and Dam</td>
<td>Sep 1992</td>
</tr>
<tr>
<td>Knowledge-Based Expert System for Selection and Design of Retaining Structures</td>
<td>Sep 1992</td>
</tr>
<tr>
<td>Evaluation of Thermal and Incremental Construction Effects for Monoliths AL-3 and AL-5 of the Melvin Price Locks and Dam</td>
<td>Sep 1992</td>
</tr>
<tr>
<td>The Seismic Design of Waterfront Retaining Structures</td>
<td>Nov 1992</td>
</tr>
<tr>
<td>Report 2: Field Test and Analysis Correlation at John Hollis Bankhead Lock and Dam</td>
<td>Dec 1993</td>
</tr>
<tr>
<td>Report 3: Field Test and Analysis Correlation of a Vertically Framed Miter Gate at Emsworth Lock and Dam</td>
<td>Dec 1993</td>
</tr>
<tr>
<td>Theoretical Manual for Analysis of Arch Dams</td>
<td>Jul 1993</td>
</tr>
<tr>
<td>Steel Structures for Civil Works, General Considerations for Design and Rehabilitation</td>
<td>Aug 1993</td>
</tr>
<tr>
<td>Soil-Structure Interaction Study of Red River Lock and Dam No. 1 Subjected to Sediment Loading</td>
<td>Sep 1993</td>
</tr>
<tr>
<td>Load and Resistance Factor Design for Steel Miter Gates</td>
<td>Oct 1993</td>
</tr>
<tr>
<td>Tutorial Guide: Computer-Aided Structural Modeling (CASM); Version 5.00</td>
<td>Apr 1994</td>
</tr>
<tr>
<td>User's Guide: Computer-Aided Structural Modeling (CASM); Version 5.00</td>
<td>Apr 1994</td>
</tr>
</tbody>
</table>

Destroy this report when no longer needed. Do not return it to the originator.