A USER'S GUIDE FOR THE SOFTWARE TECHNOLOGY ECONOMIC IMPACT MODEL

Barry W. Boehm
Thomas P. Frazier
Bruce N. Angier
Elizabeth K. Bailey
Philip M. Lurie
Kathryn L. Wilson

October 1991

Prepared for
Defense Advanced Research Projects Agency

INSTITUTE FOR DEFENSE ANALYSES
1801 N. Beauregard Street, Alexandria, Virginia 22311-1772
**DEFINITIONS**

IDA publishes the following documents to report the results of its work.

**Reports**

Reports are the most authoritative and most carefully considered products IDA publishes. They normally embody results of major projects which (a) have a direct bearing on decisions affecting major programs, (b) address issues of significant concern to the Executive Branch, the Congress and/or the public, or (c) address issues that have significant economic implications. IDA Reports are reviewed by outside panels of experts to ensure their high quality and relevance to the problems studied, and they are released by the President of IDA.

**Group Reports**

Group Reports record the findings and results of IDA established working groups and panels composed of senior individuals addressing major issues which otherwise would be the subject of an IDA Report. IDA Group Reports are reviewed by the senior individuals responsible for the project and others as selected by IDA to ensure their high quality and relevance to the problems studied, and are released by the President of IDA.

**Papers**

Papers, also authoritative and carefully considered products of IDA, address studies that are narrower in scope than those covered in Reports. IDA Papers are reviewed to ensure that they meet the high standards expected of refereed papers in professional journals or formal Agency reports.

**Documents**

IDA Documents are used for the convenience of the sponsors or the analysts (a) to record substantive work done in quick reaction studies, (b) to record the proceedings of conferences and meetings, (c) to make available preliminary and tentative results of analyses, (d) to record data developed in the course of an investigation, or (e) to forward information that is essentially unanalyzed and unevaluated. The review of IDA Documents is suited to their content and intended use.

The work reported in this document was conducted under contract MDA 903 89 C 0003 for the Department of Defense. The publication of this IDA document does not indicate endorsement by the Department of Defense, nor should the contents be construed as reflecting the official position of that Agency.

Approved for public release; distribution unlimited.
A User's Guide for the Software Technology Economic Impact Model

Barry W. Boehm, Thomas P. Frazier, Bruce N. Angier, Elizabeth K. Bailey, and Kathryn L. Wilson

Institute for Defense Analyses
1801 N. Beauregard Street
Alexandria, VA 22311-1772

DARPA
3701 North Fairfax Drive
Arlington, VA 22204-1714

Approved for public release; distribution unlimited.

The Software Technology Economic Impact Model was developed by IDA for use in analyzing the effect that improvements in software technology have on the total DoD development and maintenance costs of weapon systems. The model displays the costs savings that result from three major sources: work avoidance, working smarter, and working faster. This user's manual gives instructions for installing and starting the model on an IBM or IBM-compatible PC or an Apple Macintosh computer. It also describes how to modify the baseline parameters of the model and how to estimate both development and maintenance cost savings using the model. Illustrations included show examples of the screens the user will see when maneuvering through the model.
A USER'S GUIDE FOR THE SOFTWARE TECHNOLOGY ECONOMIC IMPACT MODEL

Barry W. Boehm
Thomas P. Frazier
Bruce N. Angier
Elizabeth K. Bailey
Philip M. Lurie
Kathryn L. Wilson

October 1991

INSTITUTE FOR DEFENSE ANALYSES

Contract MDA 903 89 C 0003
Task A-144
PREFACE

This document was prepared by the Institute for Defense Analyses (IDA) for the Defense Advanced Research Projects Agency (DARPA), under contract MDA 903 89 C 0003, Task Order T-A-144, issued 16 June 1990, and amendment. The objective of the task was to develop practical ways to model and measure increases in productivity, reductions in total lifecycle costs, and effects on quality of the Department of Defense (DoD) Software Technology Plan (SWTP). The model presented here was used to calculate the cost and savings of various software technologies outlined in the SWTP and forms the basis of Chapter 10, "Return-on-Investment," of the SWTP.

This work was reviewed within IDA by Michael C. Frieders and Stanley A. Horowitz. Barry Boehm, the lead author of this document, is the Director of the Information Systems Technology Office at DARPA.
## CONTENTS

Preface ........................................................................................................... iii  

I. Introduction ............................................................................................ 1  
   A. Model Structure and Parameters .................................................. 2  
   B. Calculating Development Savings ............................................... 3  
   C. Calculating Maintenance Savings ............................................... 4  
   D. Calculating Return on Investment (ROI) and Net Present Value (NPV) ............................................................... 5  

II. Getting Started ...................................................................................... 7  
   A. Installing the Model ........................................................................ 7  
   B. Model Overview ........................................................................... 7  
   C. Starting the Model ........................................................................ 8  

III. View ....................................................................................................... 11  

IV. Modifying the Baseline Parameters .................................................... 15  
   A. Total DoD Costs ............................................................................ 15  
   B. Development/Maintenance Split .................................................. 16  
   C. Growth Rates ............................................................................... 16  
   D. Investment .................................................................................... 17  
   E. Inflation Indices ............................................................................ 18  

V. Modifying the Development and Maintenance Parameters ............ 19  

VI. File Management ................................................................................... 23  
   A. File ............................................................................................... 23  
   B. Edit ............................................................................................... 24  
   C. Print ............................................................................................... 24  
   D. Help ............................................................................................... 25  

Bibliography ................................................................................................. 27  

Abbreviations ............................................................................................ Abb-1
FIGURES

1. Model Overview .................................................................................... 8
2. Title Screen .......................................................................................... 9
3. Opening a File ..................................................................................... 9
4. Totals by Lifecycle Screen .................................................................... 10
5. View Pull-Down Menu ......................................................................... 11
6. Totals by Lifecycle Chart ...................................................................... 12
7. Totals by Source Chart ......................................................................... 12
8. Development Chart ............................................................................... 13
9. Maintenance Chart ............................................................................... 13
10. Full Financial Summary ........................................................................ 14
11. Total DoD Cost Dialog Box .................................................................. 15
12. Development/Maintenance Value Entry Screen ................................... 16
13. Growth Rates Dialog Box ...................................................................... 17
14. Inflation Indices Screen ........................................................................ 18
15. Development Pull-Down Menu .............................................................. 19
16. Fraction of Time and Fraction of Savings for Development/End Product Avoidance (Reuse) .......................................................... 20
17. Edit Pull-Down Menu .......................................................................... 21
18. Saving a File ......................................................................................... 24
19. Print Pull-Down Menu .......................................................................... 25
20. Example of a Help Screen ..................................................................... 25
# TABLES

1. Baseline Parameters and Default Values ........................................... 2  
2. Savings Sources ..................................................................................... 3  
3. Software Technology Plan Parameters and Default Values .............. 5
I. INTRODUCTION

The Institute for Defense Analyses (IDA) developed a model to support analyses of the impact of improvements in software technology on total Department of Defense (DoD) software development and maintenance costs. The model, called the Software Technology Economic Impact Model, displays the cost savings resulting from three major sources. The sources are "work avoidance" through software reuse improvements, "working smarter" through process improvements, and "working faster" through improvements in the tool environment. These cost savings are calculated for both development and maintenance from the years 1992 through 2008.

This software technology analysis has been automated by IDA through the use of Microsoft Excel programming. The resulting model provides a set of pull-down menus that allow a user to rapidly change a number of assumptions underlying the analysis and obtain graphical output of the resulting savings. A primary motive for automating this model is to encourage exploration of alternative scenarios, providing the user better understanding of the potential cost savings from various software technology initiatives.

The remainder of this section provides a description of the general logic of the analysis. Included are a basic description of the model's structure, a list of the

1 The model was originally developed to analyze options for and to assess the impact of the Defense Advanced Research Projects Agency (DARPA) program for Software Technology for Adaptable, Reliable Systems (STARS), which is focused on the areas of software reuse, process, and environments. The model has subsequently been found to be equally useful in assessing more general software technology impacts, and is currently being used to support the development of the DoD Software Technology Plan (SWTP).

"The purpose of the DoD Software Technology Plan is to define and justify a program of coordinated DoD software science and technology activities and investments. The objectives of the SWTP are, by the year 2000, to: reduce software costs by a factor of 2, reduce software problem rates by a factor of 10, and significantly expand DoD capabilities via software." (Director of Defense Research and Engineering, "Proposed DoD Software Technology Plan," Draft, July 1991, p. 1-1.)

2 Microsoft Excel is a registered trademark of the Microsoft Corporation.
required input parameters, and a brief description of the way the model calculates potential savings. The rest of the manual provides step-by-step instructions in both written and pictorial form on how the model is used.

A. MODEL STRUCTURE AND PARAMETERS

The model structure allows comparison of a "baseline" scenario to a scenario that adjusts this baseline by estimates of the effects of the SWTP. The baseline includes estimates of DoD software expenditure in 1992, the distribution of this expenditure between development and maintenance, and expenditure growth rates over time. The effect of the SWTP is to adjust the original baseline by annual estimates of the cost saving effects of work avoidance, working smarter, and working faster.

The model displays the scenarios in total, by source of saving, and by stage in the software lifecycle. The model allows the user to enter estimates of the investment required to produce the cost savings, and displays the net present value of the savings and the return on investment (ROI).

The model provides a file with default values for both the baseline and SWTP scenarios. All default parameter estimates in the baseline are generated from single values. The SWTP estimates are entered year by year from 1992 to 2008. All baseline parameters and default values are shown in Table 1. The bibliography section documents the sources of the default parameter estimates.

<table>
<thead>
<tr>
<th>Table 1. Baseline Parameters and Default Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameter Category</td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>Baseline</td>
</tr>
<tr>
<td>Total DoD 1992 software spending</td>
</tr>
<tr>
<td>Development/maintenance split</td>
</tr>
<tr>
<td>Growth rates</td>
</tr>
<tr>
<td>Demand growth</td>
</tr>
<tr>
<td>Productivity growth</td>
</tr>
<tr>
<td>Inflation rate</td>
</tr>
</tbody>
</table>

The model identifies three sources of cost savings due to software technology improvements. Table 2 shows the notation used to identify these savings sources.
Throughout this document, the formal name and characteristics are used interchangeably. For example, EPCA and Reuse are both used to mean savings from the reuse of code.

<table>
<thead>
<tr>
<th>Source</th>
<th>Formal Name</th>
<th>Characteristic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work avoidance</td>
<td>End Product Cost Avoidance (EPCA)</td>
<td>Reuse</td>
</tr>
<tr>
<td>Working faster</td>
<td>Process Cost Reduction (PCR)</td>
<td>Tools and Software Engineering Environments (SEEs)</td>
</tr>
</tbody>
</table>

EPCA occurs by reusing software through code libraries, commercial off-the-shelf (COTS) software, generics, and any other product-related improvements. PCA corresponds to savings due to process-related improvements such as those captured by the Software Engineering Institute (SEI) process maturity assessment. PCR results from improvements in Software Engineering Environments (SEEs), frameworks, and better, more interoperable tools that partially automate software development and maintenance.

The model is divided into a development and a maintenance portion. The actual cost savings due to each of the three sources is determined by the assumed fraction of savings and by the fraction of time these savings are realized. The components of savings are described in more detail in Section V.

B. CALCULATING DEVELOPMENT SAVINGS

The model estimates the savings resulting from software technology improvements for the years 1992 to 2008. For each saving source and year, the user may enter a fraction of savings (FS) from use of technologies as well as a fraction of time (FT) for the fraction of projects on which any given technology is used. The proportion of cost avoidance per source in a given year is the product of FS and FT. That product subtracted from 1 is the residual cost fraction (RCF), which is the fraction of costs left after the technology improvements have been applied. The RCF multiplied by the annual baseline cost gives the annual cost under a software technology improvement program.

The following example shows the calculation of development savings.
Given that:

EPCA FS = 20%
EPCA FT = 10%

Baseline development = $5 billion for one year,
then:

RCF = 1 - (0.20 x 0.10) = 0.98
Baseline development = $5 billion x 0.98 = $4.9 billion with EPCA
improvements or $0.10 billion savings.

If the FT and FS for PCA and PCR are the same as for EPCA, the savings would increase:

Baseline development = $4.9 billion x 0.98 = $4.8 billion with PCA
improvements
Baseline development = $4.8 billion x 0.98 = $4.7 billion with PCR
improvements.

Use of all three improvements, EPCA, PCA, and PCR, would result in $0.3 ($5.0-
$4.7) billion in savings, compared to the unimproved baseline.

An improved baseline case has been defined where the FS and FT for each of the three sources of development savings change over time. The model developed by IDA allows you to change any of these values and observe the effect on savings. The SWTP parameters and default values for the FTs and FSs are shown in Table 3.

C. CALCULATING MAINTENANCE SAVINGS

The model also estimates the savings for maintenance resulting from software technology improvements for the years 1992 to 2008. For each year, fraction of savings and fraction of time are calculated for each of the three sources. Each source is made up of the following savings areas:

- EPCA: (1) use of COTS and (2) megaprogramming technology (Ada generics, domain-specific software architecture, module composition technology, application generators).
- PCA: (1) improved maintenance process and (2) improved understandability of software.
- PCR: (1) increased use of tools and environments and (2) better structured, easy-to-modify software.
The improved maintenance cost is calculated in the same way as the development cost. These values can also be changed within the model.

D. Calculating Return on Investment (ROI) and Net Present Value (NPV)

To achieve the software development and maintenance cost savings discussed above, a substantial investment by the DoD would be required. To assess the potential worth of such investments, two financial measures of merit are computed. One measure is the ROI. The other measure is NPV. Both measures are calculated from constant dollars and account for time value of money by "discounting" the benefits (in this case the DoD cost savings) and the costs (i.e., the DoD investment).³

³ Constant dollars are used so that, after adjusting for inflation, a dollar in the future has the same purchasing power as a dollar in the present. Discounted dollars are used so that, after discounting, a future dollar has the same value to us now as does a dollar in the present.
The formula used in the NPV computation can be shown as:

\[
NPV = \sum_{t=0}^{m} \frac{S_t - C_t}{(1 + d)^t}
\]

where

- \(S_t\) = the cost savings for year \(t\),
- \(C_t\) = the dollar value of the investment in year \(t\),
- \(d\) = the discount rate,
- \(m\) = the number of years over which the calculations are made.

For example, \(m = 16\) and \(t = 0\) corresponds to the year 1992.

To be consistent with Office of Management and Budget (OMB) guidelines, we assume the discount rate to be 10 percent. The resulting NPV figure is the present value (or worth today) of the stream of savings derived from the stream of investments made over the period of the analysis.

The ROI computation is closely related to the NPV figure. The ROI measure is the ratio of the discounted savings to the discounted costs. Algebraically this can be shown as:

\[
ROI = \frac{\sum_{t=0}^{m} \frac{S_t}{(1 + d)^t}}{\sum_{t=0}^{m} \frac{C_t}{(1 + d)^t}}
\]

where the variables are defined as for NPV.

The ROI figure used in this analysis is interpreted as the return for a dollar of investment when adjusted for price level changes and the time value of money. For example, if the ROI is computed to be 6, then for every constant, time-discounted dollar invested by the government, 6 constant, time-discounted dollars in savings will be returned.
II. GETTING STARTED

The model runs on the IBM PC\textsuperscript{4} and compatibles and on the Apple Macintosh.\textsuperscript{5} Either system must have a copy of Microsoft Excel, Version 3.0. It is assumed that the user is familiar with pull-down menus, dialog boxes, and the use of a mouse.

A. INSTALLING THE MODEL

To install the Software Technology Economic Impact Model, copy all files from the disk into a single directory or folder, preferably on the drive that contains Excel. To access the model, open Excel, pull down the File menu and select the Open option. Select the directory where the model is located, and double-click on SOFTTECH.XLM.

B. MODEL OVERVIEW

The model has two main sections. The first concerns the analysis of the effects of various technology changes on existing DoD software spending parameters. Using options from the Baseline, Development, and Maintenance pull-down menus, the user examines and changes the parameters that describe costs and possible cost avoidance over the software lifecycle. The Edit pull-down menu is used to help with data entry.

The second section of the model involves file and display management. The pull-down menus View and Print implement displays and the results of data changes. File management functions are performed under the File menu. The purpose of the Help menu is to provide on-line help for all the other parts of the model. A schematic of the model's menu bar and pull-down menus is shown in Figure 1.

\begin{footnotesize}
\begin{enumerate}
\item IBM PC is a registered trademark of the IBM Corporation.
\item Apple Macintosh is a registered trademark of the Apple Corporation.
\end{enumerate}
\end{footnotesize}
After opening the Software Technology Economic Impact Model, the title screen (Figure 2) appears. When you first open the model, the only active items on the menu bar are File and Help. The Help menu is always available to the user as an on-line reference for model operation. The commands available under the File menu are Open Case and Exit. If you select File/Exit, you will exit the model and return to the operating system. If you select File/Open Case, the dialog box in Figure 3 appears. The dialog box allows you to choose the default file (DEFAULT.STR) or any other file previously saved. On the PC, only files with the extension .STR will appear in the dialog box. On the Macintosh, choose only files with an .STR extension. Double click on the chosen file to open it.

Once you have opened a file, a chart showing totals by lifecycle appears (Figure 4). The top two lines of the graph show the total DoD software expenditures without and with the software technology initiative. The remaining lines represent maintenance costs and development costs. The table below the
chart shows the savings (difference between costs without and with the software technology improvements) at two-year intervals. From this point, you may access different views of the data and change the default values, as explained in the following sections.

Figure 2. Title Screen

Figure 3: Opening a File
Figure 4. Totals by Lifecycle Stage
III. VIEW

The View pull-down menu provides access to graphical and numerical views of the data as well as the choice of current or constant 1992 dollars (Figure 5).

Figure 5. View Pull-Down Menu

Graphical views include two total cost charts, a development chart, and a maintenance chart. The Totals by Lifecycle chart is broken out by development and maintenance (Figure 6). The Totals by Source chart, as well as the Development and Maintenance charts, is broken out by Reuse, Process, and SEE (Figures 7, 8, and 9). A summary of cost savings is presented below each chart.

In addition to the graphs, two numerical views of the data are available. One is Full Spreadsheet, which provides a view of the actual spreadsheet that generates the spending and savings estimates. You may move around through the entire spreadsheet underlying the model. This spreadsheet may be viewed but not changed directly. The other numerical view is the Full Financial Summary (Figure 10). This view shows the NPV of all the savings, and the ROI. The computation of these two measures is detailed in Section I of this guide.
Figure 6. Totals by Lifecycle Chart

Figure 7. Totals by Source Chart
Figure 8. Development Chart

Figure 9. Maintenance Chart
Figure 10. Full Financial Summary

The financial summary displays the investment costs entered in the Software Technology Plan budget line and the cost savings generated by the model. At this time, investment costs are designated at $1 million as a placeholder. See Section IV.D. for an explanation.) For this reason, the NPV and ROI are also placeholders. The net present value measure combines the costs and cost savings of the SWTP and brings the resulting "net" to a 1992 "present value" by use of a 10% discount rate. The present value approach allows comparisons of different streams of costs and cost savings flowing from alternative SWTP policies. How to change the amount of investment is discussed in Section IV. This financial summary display can also be used as a summary indicator of the overall effects of large numbers of changes to Reuse, Process, and SEE's.
IV. MODIFYING THE BASELINE PARAMETERS

Baseline parameters relate to basic assumptions about DoD spending, including the total software costs, the proportion of dollars split between development and maintenance, the rate of cost growth, the amount of investment in new technologies, and the expected rate of inflation. All of these parameters may be modified by using the options under the Baseline menu, as explained in the following subsections.

A. TOTAL DOD COSTS

After you select Baseline/Total DoD Cost, the dialog box shown in Figure 11 appears. You may change the total DoD cost from the baseline default value of $24 billion (1992 constant dollars). This start value is automatically modified over time through the Baseline/Growth Rates option. The graph and the savings values are recomputed to reflect the new total.

![Figure 11. Total DoD Cost Dialog Box](image)
B. DEVELOPMENT/MAINTENANCE SPLIT

You may also change the proportion of total DoD spending that is spent on development versus maintenance. The default values are 30% for development and 70% for maintenance (Figure 12). To change this proportion, select Development/Maintenance from the Baseline menu and type in the maintenance percentage (without the % sign). The development percentage will be automatically computed.

![Figure 12. Development/Maintenance Value Entry Screen](image)

When you choose the Development/Maintenance option, only the File, Edit, and Help menus remain active on the menu bar. File/Edit allows you to leave the model at any time. The Edit menu has three options when Development/Maintenance has been chosen: Close Window, Calculate Now, and Align. Close Window calculates any changes and closes the open window, in this case, the Development/Maintenance window. Calculate Now shows the correct development percentage without closing the window. Align brings you back to the "home" position, should you get lost in the spreadsheet.

C. GROWTH RATES

The model allows changes to the growth rate for total DoD costs by choosing the Baseline/Growth Rates option (Figure 13).
The net growth rate is determined by the difference between the yearly percentage increase in demand and the yearly percentage increase in productivity that are assumed will occur independently of the DoD Software Technology Plan. The growth rate equals the percentage increase in productivity less the percentage increase in demand. For the baseline case, demand is assumed to increase at a rate of 9% while the annual productivity increase without the SWTP is assumed to be 4%. This results in a net growth in costs of 5%. To move between the two growth rates in the dialog box, press the Tab key or use the mouse to point and click on the value you want to change.

Unlike the usual compounded growth, the net growth is calculated from the original total DoD cost. That is, with a net growth of 5% per year and 1992 total cost of $24 billion, total spending in constant dollars for 1993, 1994, and 1995 is $25.2 billion, $26.4 billion, and $27.6 billion, respectively. With compounding, these spending amounts would be $25.2 billion, $26.5 billion, and $27.8 billion, respectively.

D. INVESTMENT

Achieving cost savings requires investment in new software technologies. Choose the Baseline/Investment option to view or change the investment defaults. The DoD Software Technology Plan details several investment scenarios that the DoD might pursue. Until the plan is officially released, however, the investment
levels must remain confidential. As a place holder, the investment default values are set at $1 million per year.

E. INFLATION INDICES

The model allows changes in the inflation indices used to "deflate" future values of savings and investment. Choose the Baseline/Inflation Indices option to change and view the indices (Figure 14). The default inflation indices assume 5% inflation per year.

Figure 14. Inflation Indices Screen
V. MODIFYING THE DEVELOPMENT AND MAINTENANCE PARAMETERS

Both the Development and Maintenance menus have three options that represent the three parameters that may be changed: End Product Cost Avoidance (Reuse), Process Cost Avoidance (Process), and Process Cost Reduction (SEEs). Figure 15 shows the Development menu as an example.

![Figure 15. Development Pull-Down Menu]

Each of the parameters for Development and Maintenance is changed in the same way. We use the Development/End Product Cost Avoidance (Reuse) option as an example (Figure 16) here. You may change any of the values listed under the "Fraction of Savings" or "Fraction of Time" columns. Select a cell, type a new value, and press either the Return or the Enter key. As stated in Section IV, the overall proportion of savings is the product of the fraction of time and the fraction of savings. For published sources of these and alternative time and savings estimates, see the bibliography at the back of this guide.
When you choose an option under Development or Maintenance, only the File, Edit, and Help menus remain active on the menu bar. File/Edit allows you to leave the model at any time. The Edit menu offers four choices: Close Window, Calculate Now, Align, and Cancel (Figure 17). Close Window calculates any changes and close the open window. Calculate Now calculates the effects of the changes, which will show up in the background graph without closing the window. Align brings you back to the "home" position, should you get "lost" in the spreadsheet. Cancel erases any entries you have made and replaces them with the values present when the window was first opened.

The remaining options under the Development and Maintenance menus are analogous to the Development/End Product Cost Avoidance (Reuse) example used here, and changes can be made in the same way.
Figure 17. Edit Pull-Down Menu
VI. FILE MANAGEMENT

This section explains the menus and options used to save and close files, exit the model, print results, and access help.

A. FILE

The File menu allows the user to open, save, and close files as well as exit the model.

1. Open Case

Open Case allows you to retrieve a case that was previously saved, or the original case with the default values, DEFAULT.STR. All cases will have the extension .STR. On the PC, only files with the .STR extension will appear. Macintosh users should be careful to open only those files with an .STR extension.

2. Close Case

This option allows you to close the current case, but remain in the model. It gives you the option of saving the case, if any changes have been made. Once the case is closed, you may open another case.

3. Save Case

When you are finished entering savings estimates, you may save your results by selecting Save Case. You will be asked to supply a name for the case you are saving. The file name is limited to eight characters for the IBM PC and compatibles, as shown in Figure 18. Do not put the extension .STR on the file name; it is automatically attached. Do not save the file as DEFAULT or the original default values will be overwritten. If DEFAULT.STR is accidentally overwritten, copy DEFAULT.BAK to DEFAULT.STR. DEFAULT.BAK can be found in your model directory or folder, or on the original diskette.
4. **Exit**

When you are ready to leave the program, select the Exit option from the File menu. The Exit option returns you to the operating system or desktop. If changes were made during your use of the model, you will be asked if you want to save the current case.

**B. EDIT**

The Edit menu assists you in maneuvering around the spreadsheet and through the model and in calculating changes to the default values (see Figure 17 in the previous section).

When a window has been opened to change values, the other Edit options become available: Calculate Now, Close Window, and Cancel. Close Window calculates any changes and closes the open window. Calculate Now calculates the effects of the changes, which shows up in the background graph, without closing the window. Align brings you back to the "home" position, should you get "lost" in the spreadsheet. Cancel erases any entries you have made and replaces them with the values present when the window was first opened.

**C. PRINT**

The Print menu options are shown in Figure 19. If you choose All, each chart is printed along with its savings table. Also included are options for printing
individual charts and certain combinations of charts. For example, the Development Windows and Maintenance Windows options each print all three savings sources. The model also has a Printer Setup option available to PC users. It accesses the Windows Printer Setup facility.

Figure 19. Print Pull-Down Menu

D. HELP

On-line help is available for each item on the menu bar. An example of the use of the Help menu option File is shown in Figure 20.

Figure 20. Example of a Help Screen
This bibliography lists the sources for the input parameters used in the model. The sources are organized according to the pull-down menu in which they appear in the model. Annotations are supplied where needed.

GENERAL ISSUES


BASELINE

Total DoD Cost


 Estimates MCCR (mission critical computer resources) software in the year 1992 at $25 billion.


The 1980 and 1985 reports by the Electronic Industries Association (EIA) have estimates for hardware and software for both Information Technology (management information system-like) and MCCR or embedded systems. EIA's 1990 report is strictly for Information Technology. We extracted a software-only estimate from these sources. The 1992 current dollar estimate for Information Technology alone is $9.1 billion (from EIA's 1990 report), and the MCCR alone is $29 billion (from EIA's 1985 report).

Development/Maintenance


Growth Rates


Investment

Until the SWTP is officially released, the investment levels must remain confidential. As a placeholder, the investment default values are set at $1 million per year.
Inflation Indices

We assumed inflation of 5%.

DEVELOPMENT

End Product Cost Avoidance (Reuse)

Fraction of Savings (FS)

Seidowitz, E., and M. Stark, "Ada in the SEL: Experience with Operational Ada Projects," *Proceedings of the Second NASA Ada Users' Symposium*, SEL-89-008, NASA/SEL, Goddard Space Flight Center, November, 1989. Siedowitz and Stark show that two recent NASA/SEL projects have 76% and 90% code savings through reuse. Accompanying data suggest 30-40% savings from code reuse, with as much as 60-70% savings for code, design, and requirements reuse. The latter example might be representative of the reuse savings available in a domain-specific software architecture.

Fraction of Time (FT)


Process Cost Avoidance (Process)

Fraction of Savings (FS)


Fraction of Time (FT)


Process Cost Reduction (SEEs)


Another report ("Case Studies of Projects Using the Rational Software/Hardware Products," mimeograph, 1990) suggests that 50% cost savings is possible. Actual values for both FT and FS are based on Boehm (1991).
MAINTENANCE

ABBREVIATIONS
<table>
<thead>
<tr>
<th>Abbreviation</th>
<th>Full Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>COTS</td>
<td>commercial off-the-shelf</td>
</tr>
<tr>
<td>DARPA</td>
<td>Defense Advanced Research Projects Agency</td>
</tr>
<tr>
<td>DoD</td>
<td>Department of Defense</td>
</tr>
<tr>
<td>EPCA</td>
<td>End Product Cost Avoidance</td>
</tr>
<tr>
<td>FS</td>
<td>fraction of savings</td>
</tr>
<tr>
<td>FT</td>
<td>fraction of time</td>
</tr>
<tr>
<td>IDA</td>
<td>Institute for Defense Analyses</td>
</tr>
<tr>
<td>MCCCR</td>
<td>mission critical computer resources</td>
</tr>
<tr>
<td>NPV</td>
<td>net present value</td>
</tr>
<tr>
<td>OMB</td>
<td>Office of Management and Budget</td>
</tr>
<tr>
<td>PCA</td>
<td>Process Cost Avoidance</td>
</tr>
<tr>
<td>PCR</td>
<td>Process Cost Reduction</td>
</tr>
<tr>
<td>RCF</td>
<td>residual cost fraction</td>
</tr>
<tr>
<td>ROI</td>
<td>return on investment</td>
</tr>
<tr>
<td>SEE</td>
<td>Software Engineering Environment</td>
</tr>
<tr>
<td>SEI</td>
<td>Software Engineering Institute</td>
</tr>
<tr>
<td>STARS</td>
<td>Software Technology for Adaptable, Reliable Systems</td>
</tr>
<tr>
<td>SWTP</td>
<td>Software Technology Plan</td>
</tr>
</tbody>
</table>